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Welcome 1o KnockOut 2

The KnockOut 2 plug-in is a powerful masking tool that lets you

isolate and separate a detailed foreground object from an image,
while preserving edge detail such as hair, transparencies, blurred
edges, and shadows. You can use KnockOut 2 in conjunction with

Adobe® Photoshop®, or Corel PHOTO-PAINT® 10 and above,
Corel® Painter™ 6, or Painter 7™.

In this section, you'll learn about
* what’s new in KnockOut 2

* Corel Corporation

What’s Nnew iN KnockOut 2

KnockOut 2 has new features and enhancements that will
facilitate your masking tasks:

plug-in — KnockOut 2 is not a stand-alone application, but a
plug-in that you can use with one or more bitmap-editing
applications. This improves the workflow and saves time.

CMYK support — KnockOut 2 supports CMYK images.

Touchup tools — The Touchup tools let you fine-tune the
knocked-out image you create. You can restore foreground
colors that were removed after processing, and you can erase
leftover background colors.

multiple undo — You can easily correct mistakes by undoing
single or multiple actions. You can set the number of undo
levels.

property bar — The newly added property bar displays
selection tools associated with the selection tool that’s active
in the toolbox, bringing forward some of the hidden features
in Corel® KnockOut 1.5.
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¢ revert file — This feature lets you revert to an image’s earlier
or original state if you are not satisfied with the outcome.

About Corel CorporaTion

Founded in 1985, Corel Corporation (www.corel.com) is a leading
technology company specializing in content creation tools,
business process management and XML-enabled enterprise
solutions. The company’s goal is to give consumers and
enterprise customers the ability to create, exchange and instantly
interact with visual content that is always relevant, accurate and
available. With its headquarters in Ottawa, Canada, Corel’s
common stock trades on the Nasdaq Stock Market under the
symbol CORL and on the Toronto Stock Exchange under the
symbol COR.
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Corel CustOMER SuppoORT SERVICES

Corel® Customer Support Services can provide you with prompt
and accurate information about product features, specifications,

.. o . . Web service
pricing, availability, services, and technical support.

Description

Online Support Services Corel® Knowledge Base

For information about online support services, visit
www.corel.com. Please note, some of the services at this address

Lets you read, print, and
download documents that
contain answers to many
technical questions

are available in English only. N (P >
ewsgroups (Peer-to-Peer

forums)

Let you exchange information,
tips, and techniques with other
users of Corel products

Downloads

Allows you to download product
patches, updates, and trial
versions
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Telephone SupporT Services

For detailed information about the levels of telephone support
provided for Corel products, visit www.corel.com.

“%  Live telephone support is available for all Corel
products from Warranty Support (30 days) to
fee-based Priority and Premium Services. OEM,
“white box,” jewel case (CD only), trial, and Academic
versions of Corel products are eligible for fee-based
support only.

North America

For pricing, purchasing, or general inquiries about Corel
products, you can call Customer Support Services toll-free at
1-800-772-6735.

To speak directly to a technician, you can call 1-613-274-0500.
The hours of operation are 8:30 a.m. to 7:30 p.m., Monday to
Friday, eastern standard time (EST).

Outside NorTh America

For pricing, purchasing, or general inquiries about Corel
products, you can call Customer Support Services toll-free at
1-800-267-35127. However, if the country you are calling from is
listed below, call the corresponding number.

Please note that these numbers may change as we adapt our
services to fit user needs. Please check the international support
numbers page at www.corel.com for the most up to date contact
details.

Contact Customer Service for pricing, purchasing, general
inquiries, or replacement CDs. Contact Technical Support

Services should you require technical assistance operating your

Corel software.

Country Customer service Technical support
Argentina 0800 777 3203 57 1523 1240
Australia 1 800 658 850 (02) 8844 4101
Austria 0192 89600 0192 89600
Belgium (Dutch) 0240 06733 0240 06733
Belgium (French) 0240 06777 0240 06777

Brazil

Chile

China
Columbia
Czech Republic
Denmark
Finland

France

Germany

0800 14 1212

54 0800 777 3203

10 800 610 2323

01 800 091 9370

0224 239645

352 58008

922 906040

0170 706090

06922 2220288

55115696 5797

57 1523 1240

10 800 610 2673

57 1523 1240

0224 239645

352 58008

922 906040

0170 706090

06922 2220288
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Country Customer service Technical support Country Customer service Technical support
Hong Kong 800 964 514 800 964 515 South Korea 822 3444 5166 82 23444 5166
Hungary 204 117089 204 117089 Spain 0914 141500 0914 141500
Indonesia 180361539 1803 61544 Sweden 0856 610555 0856 610555
Ireland 0124 77724 0124 77724 Switzerland 0158 03280 0158 03280
(German)
Israel 44 1628 581601 44 1628 581601
Switzerland (French) 0158 03300 0158 03300
Italy 0236 003600 0236 003600
Taiwan 00801 61 1411 00801 61 1412
Japan 81 3554 53274 81353193013
UK 0870 774 0202 0870 774 0202
Luxembourg 441628 581603 441628 581603
Malaysia 1 800 807 895 1 800 807 899 Mail and Fax Support Services
Mexico 01 800 1234-854 57 1523 1240 You can send inquiries to Corel Support Services representatives

Netherlands
New Zealand
Norway
Poland
Portugal
Singapore

South Africa

0207 132700

0508 267 351

229 71908

071 3477279

44 1628 581601

800 6161853

0860 223388

0207 132700

0800 908 592

229 71908

0713477279

441628 581601

800 6161854

0860 223388

by mail or fax.

Corel Support Services

1600 Carling Avenue

Ottawa, Ontario
K1Z 8R7

Canada

Fax: 1-613-761-9176

Corel Customer SuppoRT SeRrvices






GeTTing STARTEd

This section provides you with information about how KnockOut
works. It also familiarizes you with the KnockOut workspace.

In this section, you'll learn about
* how KnockOut works

* the KnockOut workspace

¢ installing KnockOut

® learning to use KnockOut

¢ changing memory settings

* loading and saving images

® using the toolbox

® viewing images

* undoing and redoing actions
® returning to the host application

Commonly used tools in KnockOut have shortcuts. For a list of
shortcuts you can use, see “Keyboard shortcuts” on page 39.

How KnockOut works

A mask is applied to an image during image-editing to define
protected areas and editable areas. A conventional mask can be
used to separate foreground from background by defining an
edge between the two. When you define an edge, however, it’s
difficult to capture fine detail, such as hair. KnockOut solves this
problem by letting you define three areas — a foreground area, a
background area, and a transition area. When you process an
image, KnockOut determines what material in the transition area
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belongs to the foreground and what material belongs to the
background.

The following steps provide a general overview of a process for

creating a knocked-out image and combining it with other

images in a bitmap-editing application.

1 Bring the image into KnockOut — Bring a single-layer bitmap
image from Adobe Photoshop, Corel PHOTO-PAINT, Corel
Painter 6, or Painter 7.

2 Define the foreground and background — Define the
foreground to be preserved and the background to be
removed.

3 Process the image — Knock out the foreground from the
background.

4 Evaluate the processing results — Switch between views of
the original image, knocked-out image, and alpha channel to
evaluate the results of processing.

5 Refine the transition area — If the processing results are not
satisfactory, refine the transition area. You can keep
processing and refining until you achieve the results you
want.

6 Return the image to the host application — Bring the image
back into Adobe Photoshop, Corel PHOTO-PAINT, Corel
Painter 6, or Painter 7.

7 Use the knocked-out image in a bitmap-editing application
— Combine the knocked-out image with other images in
Adobe Photoshop, Corel PHOTO-PAINT, Corel Painter 6, or
Painter 7.

Open a bitmap image (1). Define the foreground and background (2).
Process the image and evaluate the results by viewing the original,
the knocked-out image, and the alpha channel (3).

The KnockOut workspace

KnockOut provides the following screen elements to give you
quick access to tools, commands, and information about the
active image. You can customize your workspace by hiding or
displaying these elements.

* property bar — displays the selection tools associated with
the active tool in the toolbox

* toolbox — contains tools that let you define, fine-tune, and
view selections

KnockOut 2 User Guide



Process palette — lets you choose the transition complexity To display or hide a palerte
setting and process the image

Click Windows (Mac OS[) or Window (WindowsU), and click

Selection palette — lets you hide or display selection lines the command that corresponds to the palette you want to

and single-pixel selections

display or hide.
* Info palette — displays information about the active image - . .
. .. ’ Press Tab to hide or display all palettes.
such as its RGB or CMYK values, as well as the position of the Q\‘ play at b
pointer
£ ' KnockOut 2 File Edit View Selection Windows Help Wed 3:38 PM
I [#] | Dot mese | (A GugE OBjer )
toolbox - ; property bar
006 35036dfly.tif RGB @ 100%
i
28 2 e 7 Selection palette
T P
o » é |
Underlay X l;‘
- ' =

Process palette T =

Info palette
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Installing KnockOur

You can install KnockOut on as many host applications as you
have installed on your computer. For example, if you have both
Adobe Photoshop and Corel PHOTO-PAINT installed on your
system, you can install KnockOut 2 for use with both
applications.

Before you install KnockOut 2, ensure that you close all
applications and that your computer meets the system
requirements.

To install KnockOut on The Mac OS

1 Insert the KnockOut 2 CD into the CD drive.
2 Double-click the KnockOut 2 Installer.

3 Follow the instructions in the Installer.

To install KnockOut on Windows
1 Insert the KnockOut 2 CD into the CD drive.

If the Setup wizard does not start automatically, click Start on
the Windows taskbar, and click Run. Type D:\KnockOut.exe,
where D is the letter that corresponds to the CD drive.

2 Follow the instructions in the Setup wizard.

X

S

You can install KnockOut 2 on more than one host
application by re-running the setup. Re-running the
setup will install one new file in the host application’s
plug-in folder.

To uninstall KnockOut on The Mac OS
1 Locate the KnockOut 2 folder on your hard drive.
2 Drag the KnockOut 2 folder to the Trash.

To uninsTall KnockOut on Windows

1 Click Start on the Windows taskbar, and click Programs »
KnockOut 2 » KnockOut 2 uninstall.

2 Follow the instructions in the Uninstall wizard.

@ If you have KnockOut installed on more than one host
application, the Uninstall wizard will uninstall
KnockOut from all host applications.

Learning To use KnockOurt
The following resources will help you to learn and use KnockOut:

* Tutorials — provide step-by-step lessons for learning
KnockOut. They are accessed from the Help menu and open
in your Web browser.

® Help — provides information about KnockOut and
procedures for completing tasks. You can find topics in Help
by browsing the contents, or clicking keywords in the index.

* KnockOut 2 User Guide — is a paper version of the Help. It
explains the features of KnockOut and provides procedures
for most of the tasks you will perform.

* ToolTips — display the name of a tool when you place the
pointer on that tool.

The KnockOut 2 User Guide and Help are written for both the
Mac OS and Windows platforms. By convention, Mac OS

10
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commands precede Windows commands in the text. For
simplicity, the term “folder” refers to directories as well as
folders. The KnockOut interface for Mac OS and Windows
platforms is identical unless otherwise specified.

To seT up your windows before using A TuTorial in
Windows

1 Close all applications except KnockOut.
2 Click Help » Tutorials.

3 Right-click the Windows taskbar, and click Tile windows
vertically.

4 Adjust the size of the Web browser window and the
KnockOut application window.

To access Help

® Click Help » Help topics.

ChaNngiNng MEMORY SETTINGS

Because KnockOut works with multichannel images, you must
make sure that your computer has enough memory to handle the
images. It’s recommended that you set the maximum virtual
memory of your computer to eight times the size of the image. If
you have a Mac OS, you will also need to increase the amount of
memory allocated to KnockOut. The suggested memory
requirements are set at 32 MB, but the preferred size will need to
be increased if you are working with larger images. For
information about how to increase the virtual memory and the
memory allocated to an application, see the Mac OS or Windows
documentation.

To make additional memory available for processing, you can set
preferences in KnockOut. A certain amount of memory is
allocated to store the previously processed image and the alpha
channel where the shadow selections are stored.

To set preferences
1 Click Edit » Preferences.

2 Enable the check box that corresponds to the preferences you
want to set.

“%  Preferences are applied only when the image is
closed and reopened.

@: If you don’t need to capture shadows, you can disable
&\ the Shadow memory buffer check box.

If you don’t need to view the results of previous
processing, you can disable the Previous process
viewing check box.

Loading ANd saving imMAGES

KnockOut lets you load files from Adobe Photoshop, Corel
PHOTO-PAINT 10 and later, Corel Painter 6, and Painter 7. You can
also load a saved project. The filename extension for a saved file
is .cko.

To minimize memory requirements and speed up screen refresh
and processing times, it's recommended that you crop the image
before you load it into KnockOut.

KnockOut works with single-layer 24-bit RGB images and CMYK
images.
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You can save an image as a KnockOut project as you work on it.
The project is saved with the selection lines that you've defined,
so that you can return to a project later.

To load The current Adobe Photoshop image in
KnockOur

® In Adobe Photoshop, click Filter » KnockOut » Load working
layer.

w KnockOut supports 24-bit RGB and CMYK color
spaces.

You can only load a valid unlocked layer. To load the
background layer, you must duplicate it first or
convert it into a layer.

- .
@\‘ You can also open a previously saved KnockOut
S\ project by clicking Load saved project.

To load the current Corel PHOTO-PAINT, Corel
PainTerR 6, orR PainTer 7 image in KnockOur

* In Corel PHOTO-PAINT 10 or later, Corel Painter 6, or Painter
7, click Effects » KnockOut » Load working layer.

%’”}A KnockOut supports 24-bit RGB and CMYK color
spaces.

You can only load the background after creating a
new object from it.

@: You can also open a previously saved KnockOut
§ N project by clicking Load saved project.

To save A KnockOur projecr

® C(lick File » Save project.

To save A project with A New Name or locaTtion
1 Click File P Save project as.

2 Choose the folder where you want to save the file.

3 Type a filename.

Using The toolbox

The following table describes all the tools in the KnockOut
toolbox. For more information about how these tools work
together, see “Creating knocked-out images” on page 17.

Tool Description
@ The Inside object tool lets you
draw an inside object selection

line to define the foreground.
You can also use it to add or
delete single or multiple pixels in
an inside object selection.

‘.&) The Outside object tool lets you

draw an outside object selection
line to define the background.
You can also use it to add or
delete single or multiple pixels in
an outside object selection.

12
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Tool Description Tool Description
@ The Inside shadow tool lets you ‘E‘TD The Hand tool lets you drag
draw an inside shadow selection areas of an image into view when

line. You can also use it to add or
delete single or multiple pixels in
an inside shadow selection.

The Outside shadow tool lets
you draw an outside shadow
selection line. You can also use it
to add or delete single or
multiple pixels in an outside
shadow selection.

The Inside syringe tool lets you
inject foreground color into
areas in the transition area that
have become too transparent
after processing.

The Edge feather tool lets you
remove jagged edges from the
processed foreground.

The Touchup brush tool lets you
recover colors removed during
processing.

The Touchup eraser tool lets you
remove colors after image
processing.

the image is larger than the
image window.

@ The Zoom tool lets you zoom in
on or zoom out of an image.

Viewing images

You can change your view of an image by zooming in to get a
closer look at a particular area or zooming out to view a larger
area of the whole image. KnockOut lets you zoom in and out
using both the menu and the property bar. You can also zoom in
from a specific area of an image.

You can pan to view areas of an image that fall outside the image
window.

To zoom iN or out FrRom The cenTer of AN iMAGE using
The menu

® Click Windows (Mac OS) or Window (Windows), and click one
of the following:
® Zoom in — lets you increase the zoom level

® Zoom out — lets you decrease the zoom level

You can also

Fit an image to the window Click Fit window.

GerTing sTarTed
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You can also

View an image at its actual print Click Zoom 100%.

size

To zoom iN or out FrRom The cenTer of AN iMAGE using
The property bar

1 Click the Zoom @ tool in the toolbox.
2 On the property bar, click one of the following:
e Zoomin | tool

e Zoom out =, tool

You can also

Click the Fit to screen button on
the property bar.

Fit an image to the window
View an image at its actual print Click the Actual size button on
size the property bar.

Choose a zoom level from the list
box on the property bar.

Set a predefined zoom level

< You can also zoom in to a specific area of an image by
SN\ dragging over an area of the image.

To view image Areas That Fall outside The image
window

1 Click the Hand tool.

2 Drag the image until the area you want to see is visible in the
image window.

Undoing ANd rRedoing AcTiONS

KnockOut lets you reverse an action you perform and redo the
last reversed action. You can set the number of actions that you
can undo.

You can revert to a previously saved image. You can also revert to
the original image if you have not yet saved the image you are
working on.

To undo and redo acTions

To Do the following

To zoom in 10 A specific Area of an image
1 Click the Zoom @ tool in the toolbox.
2 Click the area of the image.

If you want to zoom out from a specific area of an image,
Option-click (Mac OS) or right-click (Windows) an area with
the Zoom tool.

Reverse an action Click Edit » Undo.

Redo the last reversed action Click Edit » Redo.

To set The undo levels for aAcTions
1 Click Edit » Preferences.
2 Type avalue in the Undo levels box.

14
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w You can specify up to 99 undo levels.

To reverT 10 The previously saved image

® (lick File P Revert.

If you have not saved the image you are working on,
the original image from the host application is
recalled.

7

You cannot undo a reverted image.

ReTurnNing 10 The host applicaTion

Once you have brought an image into KnockOut, you can return
to the host application at any time. You can exit KnockOut and

apply the changes to the image in the host application. Then, you

can create a mask that contains the knocked-out image and its
shadow.

You can also exit KnockOut without applying the changes made
to an image.

To exit KNockOut and apply changes
® C(lick File » Apply.

To create A mask For The knocked-out image in
Adobe Photoshop

1 With the knocked-out layer selected, click Select » Load
selection.

2 Click OK in the Load selection dialog box.
Click Select »  Save selection.
4 Type a name in the Name box.

To create A mask for The knocked-out image in Corel
PHOTO-PAINT

* With the knocked-out object selected, click Object » Clip

mask » Create » From object transparency.

To exit KNnockOut without applying changes
1 Click File P Quit.
2 Click Don’t apply.

< InMacOSX, you can exit KnockOut without applying
S changes by clicking KnockOut 2 » Quit KnockOut 2.

GerTing sTarTed
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Creating knocked-out imAGes

You can knock out an image and add it to a background image in
a bitmap-editing application.

In this section, you'll learn about

* defining the foreground and background

® viewing selections

® editing inside and outside selections

® cutting out areas of the foreground

* processing images and evaluating the results
* refining images after processing

* saving knocked-out images as masks

Commonly used tools in KnockOut have shortcuts. For a list of
shortcuts you can use, see “Keyboard shortcuts” on page 39.

Defining The foreground and background

In KnockOut, you define inside and outside selections to isolate
the foreground from the background. The inside selection line
defines the foreground and is drawn through only the foreground
colors. The outside selection line defines the background and is
drawn through only the background colors. The area between
the inside and outside selection lines, which contains both
foreground and background information, is the transition area.

In an image where the transition area is composed of few colors,
the selection lines can be loosely drawn. If the transition area is
composed of many colors, the selection lines should be drawn as
close together as possible to create a narrow transition area.

If you want the inside or outside selections to be the same
shape, you can generate the inside or outside selection line
automatically. You can also create straight selection lines.

Creating knocked-out images

17



The inside object selection line is drawn in the foreground object (1).
The outside object selection line is drawn around the outside of the
foreground object (2). The area between the inside and outside
selection lines, which contains both foreground and background
information, is the transition area (3).

To define The foreground
1 Click the Inside object |# tool.

2 Draw a line inside the foreground object that traces its shape,
without passing through any background colors.

To define The background
1 Click the Outside object @ tool.

2 Draw a line around the foreground object, without passing
through any foreground colors.

To generaTe A selection Line automaTically
1 Click a selection tool.
2 Click Selection, and click one of the following:

* Auto inside object — lets you generate an inside selection
line automatically

* Auto outside object — lets you generate an outside
selection line automatically

w At least one of the selection lines must be defined
before you can use the Auto Inside/Outside function.
If you have defined both selections, the line that is
not active is regenerated.

@\: You can also generate a selection line automatically
&\ by clicking the Auto inside object or Auto outside
object button on the property bar.

To create A sTraighT selection line

1 Click a selection tool.

2 Enable the Polygonal mode check box on the property bar.
3 Click points in the image to create a selection line.

18
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o . 3 Draw the selection line.
%}« When you are in polygonal mode, you can create )
freehand selection lines by pressing Option (Mac OS) 4 Press L again to turn off the Loupe zoom.

or Alt (Windows) and drawing a selection line.
%”;A The Loupe zoom feature only works at 100% zoom.

Viewing selections

If you make many selections, the lines sometimes become
cluttered and difficult to define. You can hide or display selection
lines to help you precisely define and edit a selection.

Magnifying a selection as you define it lets you make more
precise selection lines.

To hide or display a selection

® C(lick View, and click the command that corresponds to the ;
selection line that you want to hide or display. The Loupe zoom feature magnifies selections as you define them.

You can also

Hide or display a selection line Enable or disable the check box . L. . .
next to the selection tool on the Editing inside ANd ouTside selections

Selection palette. - . .
P After you define the inside and outside selections, you can add or

Hide or display all selection lines  Click the Open eye | #| or subtract specific areas from them. You can also expand or
contract entire selection areas.

Closed eye = button on the

Selection palette. . .. . .
P To edit an inside object selecrion

1 Click the Inside object @ tool.
2 On the property bar, click one of the following buttons:

* Inside object addition @ — lets you add to an inside
object selection

To magNify A selection as you define it
1 Click a selection tool.
2 PressL.

The Loupe zoom magnifies the area that you are currently
defining.

Creating knocked-out images 19



* Inside object subtraction 'E — lets you subtract from
an inside object selection

3 Draw around the area you want to edit.

%”}A Once the button is clicked, you remain in addition or
subtraction mode until you click another button.

< You can also enable the Inside object addition button
&\ by pressing Shift. When you enable the Inside object
addition button using the shortcut key, addition
mode quits once you complete the selection.

You can also enable the Inside object subtraction
button by pressing Option (Mac OS) or Alt
(Windows). When you enable the Inside object
subtraction button using the shortcut keys,
subtraction mode quits once you complete the
selection.

The butterfly’s wings are added to the inside selection.

To edit an outside object selection
1 Click the Outside object 'E tool.
2 On the property bar, click one of the following buttons:

® Outside object addition 'E — lets you add to an
outside object selection

® Qutside object subtraction 'E‘ — lets you subtract from
an outside object selection

3 Draw around the area you want to edit.

%"’}A Once the button is clicked, you remain in addition or
subtraction mode until you click another button.

@: You can also enable the Outside object addition

&\ button by pressing Shift. When you enable the
Outside object addition button using the shortcut
key, addition mode quits once you complete the
selection.

You can also enable the Outside object subtraction
button by pressing Option (Mac OS) or Alt
(Windows). When you enable the Outside object
subtraction button using the shortcut keys,
subtraction mode quits once you complete the
selection.

20
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The dragonfly’s wings are subtracted from the outside selection.

To expand a selection
1 Click a selection tool.
2 Click Selection » Expand.

@\: You can also expand a selection by clicking the
S\ Expand == button on the property bar.

To conTRACT A selecTion
1 Click a selection tool.
2 Click Selection » Contract.

@: You can also contract a selection by clicking the
ES =
Contract |— button on the property bar.

CutTing out AReas of The foreground

After you define the inside and outside selections, you can define
areas in the foreground that you want to cut out and remove
with the background; for example, areas in the foreground where
the background shows through. If you want to remove all the
colors from the area you want to cut out, ensure that you select a
sample of all the colors present in the cutout. When you process
the image, anything in the cutout that is the same color value as
the single-pixel selections is removed with the background.

The following image contains areas in the foreground where the
background shows through. With the inside and outside object
selections already defined, several pixels in the cutout are
selected so that pixels of the same color value are removed with
the background when the image is processed.

Areas in the foreground that you want to cut out and remove with
the background are subtracted from the inside selection, and then
single-pixel selections are designated as background colors (1). All
pixels of the same color value are removed by reprocessing (2).

Creating knocked-out images
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To cut out aAreas of the foreground processing an image with different transition complexity settings

1 Click the Inside object E tool. and switching between views.
2 Click the Inside object subtraction E button on the property  After processing your image, you can evaluate the knocked-out
bar. image by displaying it against different background colors or a
3 Draw around the area you want to cut out. background image and switching between views of the original,
. . . = the current knocked-out image, the last knocked-out image, and
4 Click the Outside OIECt [ tool. the alpha channel. You can then make refinements and reprocess
5 Click the Tweezers |#* button on the property bar. the image until you are satisfied with the results.
6 Click the pixels within the cutout area that represent the .
colors you want to remove with the background. To process AN imAGE
1 Move the Transition complexity slider to one of the following
%’”}A If you try to make single-pixel selections in an area levels:
other than the cutout area, the pointer changes to * 1 — for less detailed images with few colors in the
indicate that you can’t make a selection within that foreground or background
area.
e 2 — for images with multiple colors in the foreground and
few colors in the background
@\: You can also e1?able th'e Inside object subtrac.tion e 3 — for images with few colors in the foreground and
s”\v mode by pressing Option (Mac OS) or Alt (Windows). multiple colors in the background
You can also enable the Tweezers tool by pressing * 4 — for images with multiple colors in both the
Command (Mac OS) or Ctrl (Windows). foreground and the background

2 Click Edit » Process.
Processing images aANd evaluating The
rResults \: You can also process an image by clicking the Process
\

o . ) & ¢> | button on the Process palette.
After you define the inside and outside selections, you can

process an image to produce a knocked-out foreground with the
original background removed and the mask stored in an alpha
channel. Before you process the image, you can choose the
transition complexity, which specifies the number of colors that
enter the transition area. It might be necessary to experiment by
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iMAGE

Images suitable for the different transition 'compléxities. Clockwise
from top left: level 1, level 2, level 3, and level 4.

To change Tthe background color behind A processed
iMAGE

Displaying a processed image against a background
color is for preview purposes only. It has no effect on
a processed image that is brought back to the host
application.

To display a background image behind A processed

1 Click the Image button in the toolbox.
2 Choose the folder where the file is stored.
3 Double-click the filename.

Displaying a processed image against a background
image from disk is for preview purposes only. It has
no effect on a processed image that is brought back
to the host application.

You can display the processed image against the
background image you’ll be using in the host
application.

To switch berween views of AN image

* Open the Underlay color picker in the toolbox, and click a

color. ® (lick View, and enable one of the following menu items:

If you want to choose a custom color, click Custom (Mac OS) * Original — displays the original image

or Other (Windows). ® Current knocked out — displays the current knocked-out
image

* Last knocked out — displays the last knocked-out image

* Alpha — displays the alpha channel

Creating knocked-out images
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After the image is processed, you can switch between views of the
original image, the knocked-out image, and the alpha channel.

To switch berween views of The current and
previously processed image
® Press one of the following:
* Command + 2 (Mac OS) or Ctrl + 2 (Windows) — lets
you view the current processed image
* Command + 3 (Mac OS) or Ctrl + 3 (Windows) — lets
you view the previous processed image

* Command + 4 (Mac OS) or Ctrl + 4 (Windows) — lets
you toggle between the alpha channel view of the current
and previous processing results

If you want to return to the original image, press Command
+ 1 (Mac OS) or Ctrl + 1 (Windows).

%”}A You must have processed the image more than once
to use this feature.

Refining imAges AFTER PROCESSING

After you process images, you can recover foreground colors you
removed during processing. You can also remove background
colors that remain after processing.

When you process an image you may remove colors that you want to
keep. You can recover these colors with the Touchup brush.

To recover colors rRemoved durinGg pROCESSING
1 Click the Touchup brush ? tool in the toolbox.
2 Drag over image areas where you want to recover colors.

When the Touchup brush tool is enabled, split screen
mode is also enabled and the original image as well
as the knocked-out image display side by side.
Changes made to the image in the Edit window will
display immediately in the Original window.

7

Any edits made with the Touchup brush tool are lost
when you reprocess an image.
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After processing, you may have unwanted colors. You can remove
these colors with the Touchup eraser.

To remove colors AfTerR iMAGE pROCESSiING
1 Click the Touchup eraser |§‘ tool in the toolbox.
2 Drag over colors you want to remove.

When the Touchup eraser tool is enabled, split
screen mode is also enabled and the original image as
well as the knocked-out image display side by side.
Changes made to the image in the Edit window will
display immediately in the Original window.

7

Any edits made with the Touchup eraser tool are lost
when you reprocess an image.

Saving knocked-out images as masks

You can save knocked-out images as masks for later use. You can
import a saved mask in Adobe Photoshop or Corel PHOTO-PAINT
and add it to any background image you want. For information

about using saved masks of knocked-out images, see “Working

with knocked-out images” on page 37.

To save A knocked-image as A mask

1 Click File » Save image mask.

2 Choose the folder where you want to save the file.
3 Type a filename.

%‘”’}A This procedure saves a mask of the knocked-out
image without its shadow.

Creating knocked-out images
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RefiniNG TRANSITION AREAS

This section explains how to refine the transition area to
preserve foreground detail.

In this section, you will learn about

* restoring foreground detail in the transition area

* removing background color from the transition area
* working with images of transparent objects

¢ feathering the transition area

Commonly used tools in the KnockOut application have
shortcuts. For a list of shortcuts you can use, see “Keyboard
shortcuts” on page 39.

RestorinGg foreground detail in The
TRANSITION AREA

In some images, areas in the transition area can become too
transparent after processing if the inside object selection line
does not flow through a specific foreground color that appears in
the transition area. For example, strands of hair in the transition
area can appear transparent or even disappear after processing,
since the colors in the strands are not defined as part of the
foreground. You can restore transparent areas in the transition
area by withdrawing a similar color from the foreground and
injecting it into the transparent strands. You may have to make
several injection points or sample different foreground colors.
You can also delete selected groups of injection points. After you
reprocess the image, the strands of hair will become visible in
the transition area.

Refining TRANSITION AREAS
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You can also designate single pixels in the transition area as To resTore foreGround dertail in The TRANSITION AREA
foreground detail. This procedure is useful if you have colors in 1 Click the Inside syringe tool.

the transition area that are not in the foreground area but you
would like to keep visible in the knocked-out image.

2 Click the Extract button on the property bar.
3 Click a color in the foreground.

The color must be opaque and approximately the color you
want to appear in the transition area.

Click the Inside syringe tool on the property bar.

5 Click several points where you want to inject color in the
transition area.

The color over which the Inside syringe tool is
positioned displays in the circle below the tool. The
color that is sampled displays in the color swatch on
the property bar.

&

Single-pixel selections are easiest to make at a zoom
level of 100% or greater.

@: You can also enable the Extract tool by pressing
&\ Command (Mac 0S) or Ctrl (Windows).

To restore foreground detail that is lost after processing (1), withdraw .
a similar color from the foreground (main) and inject it into the You can use the Loupe zoom feature to rr?agnlfy. the
transparent area. The hair detail is restored by reprocessing (2). area where you want to make your selection points.

You can access the Loupe zoom by pressing L.

To delete A selected group of injecTion poinTs

1 Click the Inside syringe subtraction button on the property
bar.

2 Drag around the injection points you want to remove.
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\: You can also delete a selected group of injection
S points by holding down Option (Mac OS) or Alt
(Windows), and dragging around the injection points
you want to remove.

To designaTe single pixels in The TRANsiTION AREA AS
foreground deTail

1 Click the Inside object E tool.

2 Click the Pushpin E button on the property bar.

3 Click the pixels within the transition area you want to
designate as foreground detail.

By making single-pixel selections in the transition
area, you define as foreground detail all pixels of the
same or similar color value.

&

Single-pixel selections are easiest to make at a zoom
level of 100% or greater.

@\: You can also enable the Pushpin tool by pressing
S Command (Mac OS) or Ctrl (Windows).

Removing background From The TRANSITION
AREA

You can designate single pixels in the transition area as
background detail. This procedure is useful if you have colors in
the transition area that are not in the background area but you
would like to delete from the knocked-out image.

To designate single pixels in The TrRaNsiTIiON AREA AS
background derail

1 Click the Outside object E tool.

2 Click the Tweezers ? button on the property bar.

3 Click the pixels within the transition area you want to
designate as background detail.

By making single-pixel selections in the transition
area, you define as background detail all pixels of the
same or similar color value.

&

Single-pixel selections are easiest to make at a zoom
level of 100% or greater.

@s You can also enable the Tweezers tool by pressing
SN\ Command (Mac OS) or Ctrl (Windows).

Working with images of TRANSpARENT
objects

You can knock out objects that are primarily made up of
transparent material, while retaining any foreground detail. In
such cases, because the area in which you would draw the inside
selection line is often too small, you can make single opaque
pixel selections to either define or add to an inside object
selection. After you process the image, the areas defined by the
single-pixel selections are preserved with the foreground.

For example, in the water droplets shown here, most of the
foreground image is transparent. To knock out the foreground,
you would first define the outside selection around the water
droplets, and then define the inside object selection by selecting

Refining TRANSITION AREAS
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opaque single pixels in the foreground. When you process the
image, the area of the image that is the same color as your
single-pixel selections is retained as foreground.

With objects that are mamly transparent, define the outside object
selection, and then define the inside object selection by making
single—pixel selections in the opaque material in the foreground. The
foreground detail is retained after processing.

In the case of the dragonfly shown here, you define the outside
selection around the dragonfly, and then define the inside
selection within the body of the dragonfly. The dragonfly’s wings
appear in the transition area. To retain the fine detail in the
wings, you can make several single-pixel selections on the wings
to add to the inside selection.

Making opaque single-pixel selections in the dragonfly’s wings ensures
that the detail in the wings is retained with the foreground during
processing.

To preserve derail in A foreground object Thar is
mAinNly TRANSPARENT

1 Click the Inside object tool.
2 Click the Pushpin button on the property bar.

3 Click the pixels in the foreground that you want to add to the
selection.

“%x  Single-pixel selections are easiest to make at a zoom

level of 100% or greater.

@w You can also enable the Pushpin tool by pressing
Command (Mac OS) or Ctrl (Windows).
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Feathering The TRANSITION AREA

The edges of a knocked-out image can appear jagged if the
colors in the foreground and background are similar — for
example, a polar bear against a backdrop of snow. You can
feather any edges that appear jagged, and then reprocess the
image to produce a softer, more natural-looking transition edge.

After processing an image in which background and foreground
colors are similar, the edges of the foreground can appear jagged (1).
Feathering the edges and reprocessing results in a softer, more
natural-looking transition edge (2).

To fFeather The TRANSITION AREA

1 Click the Edge feather tool.
2 Drag around the edge you want to feather.
3 Click Edit » Process.

-
23

You can also add to or subtract from the area you
want to feather by clicking the Feather addition
or Feather subtraction buttons on the property
bar, and drawing around the area you want to edit.
Once a button is clicked, you remain in addition or
subtraction mode until you click another button.

Refining TRANSITION AREAS
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CapTuring shadows

KnockOut lets you capture the shadows of foreground objects
and return the shadows to the host application in a separate
alpha channel.

In this section, you'll learn about
* defining shadow selections

* editing shadow selections

¢ saving knocked-out shadows as masks

Commonly used tools in KnockOut have shortcuts. For a list of

shortcuts you can use, see “Keyboard shortcuts” on page 39.

Defining shadow selecTions

KnockOut lets you capture the shadows of foreground objects by

defining inside and outside shadow selections. The inside

shadow selection line defines the shadow and is drawn through
the inside of the shadow. The outside shadow selection line
defines the background and is drawn around the shadow.
Wherever the shadow touches the foreground object, both inside
and outside shadow selection lines are drawn through it, as if the
shadow were an object independent of the foreground.

Capruring shadows
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Editing shadow selections

After you define the inside and outside shadow selections, you
can add or subtract specific areas from these selections. You can
also expand or contract entire selection areas.

To edit AN inside shadow selecTion
1 Click Inside shadow tool.

2 On the property bar, click one of the following buttons:

* Inside shadow addition — lets you add to an inside
shadow selection

* Inside shadow subtraction — lets you subtract from
an inside shadow selection

3 Draw around the area you want to edit.

EQ}A Once the button is clicked, you remain in addition or
subtraction mode until you click another button.

To capture shadows in an image, draw the inside and outside shadow
selections through the foreground object, as if the shadow were an
object independent of the foreground.

@ 2 You can also enable the Inside shadow addition
&\ button by pressing Shift. When you enable the Inside
To define an inside shadow selection shadow addition button using the shortcut key,

1 Click the Inside shadow E tool. addition mode quits once you complete the

2 Draw a line inside the shadow that traces its shape, without selection.

passing through any background colors. You can also enable the Inside shadow subtraction
button by pressing Option (Mac OS) or Alt

To define an outside shadow selection (Windows). When you enable the Inside shadow

1 Click the Outside shadow |@ tool. subtraction button using the shortcut keys,
2 Draw a line around the shadow, without passing through it. subtraction mode quits once you complete the
selection.
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To edit an outside shadow selecrtion
1 Click the Outside shadow E tool.
2 On the property bar, click one of the following buttons:
® OQutside shadow addition — lets you add to an
outside shadow selection
® OQutside shadow subtraction — lets you subtract
from an outside shadow selection

3 Draw around the area you want to edit.

X”’? Once the button is clicked, you remain in addition or
subtraction mode until you click another button.

@: You can also enable the Outside shadow addition

&\ button by pressing Shift. When you enable the
Outside shadow addition button using the shortcut
key, addition mode quits once you complete the
selection.

You can also enable the Outside shadow subtraction
button by pressing Option (Mac OS) or Alt
(Windows). When you enable the Outside shadow
subtraction button using the shortcut keys,
subtraction mode quits once you complete the
selection.

To expand A shadow selecrion
1 Click a shadow selection tool.
2 Click Selection » Expand.

@: You can also expand a shadow selection by clicking
SV the Expand = button on the property bar.

To contrAcT A shadow selecTion
1 Click a shadow selection tool.
2 Click Selection » Contract.

@‘ You can also contract a shadow selection by clicking
the Contract |—| button on the property bar.

Saving knocked-out shadows as masks

Once you have processed an image with shadow selections, you
can save the knocked-out shadow as a mask. This feature is
useful if you want to adjust the transparency of a knocked-out
shadow when adding it to a background image in the host
application.

For information about processing images, see “Processing images
and evaluating the results” on page 22.

To save A knocked-out shadow as a mask

1 Click File » Save shadow mask.

2 Choose the folder where you want to save the file.
3 Type a filename.

%”}A You can only save a knocked-out shadow as a mask
after you have processed the image.

Capruring shadows
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WORkiNE?\;/TTl-I knocked-out imAGeEs

L4

You can add knocked-out images or their saved masks to To add A knocked-out image 1o A background image
background images in bitmap-editing applications. in Adobe Photoshop

In this section, you'll learn about 1 In KnockOut, click File b Apply.

. . . . .. 2 In Adobe Photoshop, open a background image.
* working with knocked-out images in bitmap-editing

applications 3 Click the knocked-out image, and click Select » Load

selection.
* working with saved masks of knocked-out images 4 Click Edit » Copy.

. . . . 5 Click the background image, and click Edit » Paste.
Working with knocked-out images in
bitmap-editing applicaTions

When you are satisfied with a knocked-out image, you can add it

to a background image in Adobe Photoshop or Corel
PHOTO-PAINT 10 and above.
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To add a knocked-out image 10 A background image
in Corel PHOTO-PAINT

1 In KnockOut, click File » Apply.

2 In Corel PHOTO-PAINT, open a background image.
3 Click the knocked-out image, and click Edit » Copy.
4

Click the background image, and click Edit » Paste » As new
object.

Working with saved masks of knocked-out
iMAGES

You can use saved masks of a knocked-out image and its shadow

to create a composite image. For information about saving
knocked-out images as masks, see “Saving knocked-out images

as masks” on page 25; for information about saving knocked-out
shadows as masks, see “Saving knocked-out shadows as masks”

on page 35.

To use a saved mask in Adobe Phortoshop
1 Open the background image you want.

Open the saved mask.

Click the background image.

B W N

On the Channels palette, click the Create new channel
button.

Click the mask file.

Click Select » Load selection, and click OK.
Click Edit » Copy.

Click the background image.

Click Edit » Paste.

© 0o N O U

To use A saved mask in Corel PHOTO-PAINT

1
2

Open the background image you want.

Do one of the following:

®* On Mac OS, click Windows » Palettes » Channels.
* In Windows, click Window » Dockers » Channels.

Click the arrow in the top-right corner of the Channels palette
(Mac OS) or Channels Docker window (Windows), and click
Open.

Open the saved mask.
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RefERENCE SECTION

Keyboard shortcurs

Keyboard shortcuts can save you time. Many of the menu
commands and toolbox items in KnockOut have shortcuts you
can use to help you work more efficiently.

Menu commands shortcut keys

File menu command

Shortcut

Apply

Option + Command + A (Mac
0S) or Ctrl + Shift + A
(Windows)

Edit menu command

Shortcut

File menu command Shortcut

Quit Command + Q (Mac OS) or Ctrl
+ Q (Windows)

Save Project Command + S (Mac OS) or Ctrl
+ S (Windows)

Save Project As Shift + Command + S (Mac 0S)

or Ctrl +Shift + S (Windows)

Undo Command + Z (Mac OS) or Ctrl
+ Z (Windows)
Redo Command + Y (Mac OS) or

Ctrl+ Y (Windows)

Reference section
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Edit menu command

Shortcut

View menu command

Shortcut

Process

Preferences

Command + P (Mac OS) or Ctrl
+ P (Windows)

Command + ; (Mac OS) or Ctrl
+ ; (Windows)

View menu command

Shortcut

Original

Current knocked out

Last knocked out

Alpha

Hide/Show All

Hide/Show Inside Object

Hide/Show Outside Object

Command + 1 (Mac OS) or Ctrl
+ 1 (Windows)

Command + 2 (Mac 0OS) or Ctrl
+ 2 (Windows)

Command + 3 (Mac OS) or Ctrl
+ 3 (Windows)

Command + 4 (Mac OS) or Ctrl
+ 4 (Windows)

Command + H (Mac OS) or Ctrl
+ H (Windows)

Option + Command + 1 (Mac
0S) or Ctrl + Shift + 1
(Windows)

Option + Command + 2 (Mac
0S) or Ctrl + Shift + 2
(Windows)

Hide/Show Inside Shadow

Hide/Show Outside Shadow

Hide/Show Inside Syringe

Hide/Show Edge Feather

Option + Command + 3 (Mac
0S) or Ctrl + Shift + 3
(Windows)

Option + Command + 4 (Mac
0S) or Ctrl + Shift + 4
(Windows)

Option + Command + 5 (Mac
0S) or Ctrl + Shift + 5
(Windows)

Option + Command + 6 (Mac
0S) or Ctrl + Shift + 6
(Windows)

Selection menu command

Shortcut

Deselect

Select All

Expand

Contract

Command + D (Mac OS) or Ctrl
+ D (Windows)

Command + A (Mac OS) or Ctrl
+ A (Windows)

Command + | (Mac OS) or Alt +
] (Windows)

Command + [ (Mac OS) or Alt +
[ (Windows)
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Windows menu command

Shortcut

Edge feather F

Zoom in

Zoom out

Fit Window

Zoom 100%

Command + + (Mac OS) or Ctrl
+ + (Windows)

Command + - (Mac OS) or Ctrl
+ - (Windows)

Command + 0 (Mac OS) or Ctrl
+ 0 (Windows)

Option + Command + 0 (Mac
0S) or Ctrl + Alt + 0 (Windows)

Shortcut keys for Tools and palertes

Touchup tools Shortcut
Touchup brush B
Touchup eraser E
Zoom tools Shortcut
Hand H
Zoom Z
Loupe zoom L (toggle)

Selection tools Shortcut
Inside object |
Outside object (o}

Inside shadow Y
Outside shadow U

Other tools Shortcut
Inside syringe S
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