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Getting Started

 

When you work with Metro to compose a piece of music, you are creating a 
Metro document file.  This can include a song with up to 32 Sections, each 
of which can contain up to 99 tracks of MIDI or audio data; each MIDI track 
can contain 64 SubSections (placing a Section within another Section 
creates a “SubSection”) and Instrument definitions for 254 Instruments.  
Metro can simultaneously play up to 64 tracks of stereo audio files (audio 
performance is dependent on CPU speed and Hard Disk throughput).  All of 
these elements of a Metro document file, and others, including references to 
audio files, are loaded or saved under a single file name, usually the title of 
the song.  

All processing of audio files in Metro is constructive and disk-based.  In 
other words, Metro never alters or overwrites an original audio file, instead it 
creates a new file which is substituted for the original file.

 

Quick Setup

 

This is a quick tutorial to get you set up and recording right away. To set up 
METRO, we recommend that you first install OMS, the program that links 
MIDI programs with MIDI hardware. Install OMS from the METRO CD and 
follow the OMS directions to create a Studio Setup Document. However, you 
can run METRO without OMS. See “MIDI Setup Without OMS” on page 4.

Once you have a Studio Setup Document,

 

 create a new METRO 
projec

 

t, called a METRO document:

1. Select Save from the File menu.

2. Type a name for your Metro document, then click OK to save it to a 
drive or diskette.

 

Tip

 

: You may want to create a folder named  “Metro documents” within the 
Metro application folder. 

 

Now create some instruments:
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1. From the Special menu, choose Modify Instruments and Busses.

The Modify Instruments and Aux Busses dialog box appears.

2. Click the Create Current OMS Instruments button.

METRO duplicates the instruments that are in your Studio Setup 
Document. 

 

Select your recording criteria:

 

1. Choose Record Criteria from the Setup menu.

The Record Criteria dialog box appears. 

2. Check the data types you want to record.

 

Note

 

: Check the Audio checkbox if you want to record audio into Metro  
(only supported on machines with built-in 16 bit audio).

3. Click OK.

 

Set record and play preferences:

 

1. Choose Record/Play from the Setup menu. 

The Record and Play Setup dialog box appears.

2. Select how you want Metro to begin playing and recording:

• No Countoff 

• Countoff 

• Wait for first note before recording 

3. Under Record Mode, choose Replace or Overdub.

4. Click OK.

5. In the Switches menu, make sure Partial Track Recording is checked if 
you plan to do any punch recording.

 

Set up the metronome:

 

1. Open the Transport window (Command-B).

          Metronome Door
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2. Find the metronome icon in the lower right corner and click the little 
door  on its lower right corner.

The Metronome dialog box appears.

3. From the Port popup menu, choose an instrument for your metronome 
sound.

4. Select a Channel and Pitch.

5. Click OK.

The metronome icon must be highlighted for the metronome to sound.

 

Now pick a MIDI instrument and track to record on:

 

1. Open the Tracks window (Command-K).

2. In the “R” column on the far left, click a track to record enable it.

3. In the Name column, option-click the name field, type a track name, and 
press Enter.

4. Click in the Bars column, type the number of bars you want the track to 
last and press Enter.

5. Choose an Instrument from the Instruments column popup menu (for 
right now, don’t select an instrument that says “Port” in front of it).

6. Click the Pgm column, enter a program number, and press Enter.

 

Record the track you record enabled:

 

1. Press Option-R to start recording.

2. Play your controller.

3. Press the Spacebar to stop recording.

 

Play back your track:

 

1. Press the Spacebar to start or stop playback.

2. Press Return to return the counter to the beginning.

Record Zoom Menu
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Save your recording:

 

Choose Save from the File menu.

 

Save your record and play preferences:

 

• From the File menu, choose Preferences > General and click the Save 
button.

To set up audio recording, see “Setting Up Audio Instruments” on page 7 of 
Chapter 3.

The next section covers more MIDI setup topics.

 

Detailed Setup

 

This section explains setup in more detail than the Quick Setup tutorial. It 
steps you through setting up your recording environment, covering the 
following topics:

• Opening Metro 

• MIDI Setup Without OMS 

• OMS MIDI Setup 

• Setting Up MIDI Timecode 

• Selecting Record Criteria 

• Setting Record and Play Preferences 

 

Opening Metro

 

To open Metro:

1. Double-click the Metro application icon located in the Cakewalk folder 
on your hard drive. If you are running Metro for the first time, you must 
have the product CD in your CD-ROM drive.

2. Click OK. 

Once Metro is open, the next step is to indicate your MIDI setup and 
recording preferences. We recommend that you install OMS before setting 
up MIDI.

 

MIDI Setup Without OMS

 

Metro is an Open Music System (OMS) compatible application. You can run 
Metro with or without OMS, however OMS offers many advantages, 
especially when working with multiport interfaces like Studio 5 or MIDI Time 
Piece II. You can download OMS at no chrarge from www.Opcode.com.
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MIDI setup without OMS: 

1. Choose MIDI Setup from the Setup menu. 

The MIDI Setup dialog box appears.

2. Check the Port(s) that represents the Macintosh port(s) you hooked 
your MIDI interface to.

If you have a single-port MIDI interface, you’ll need to check either the 
Modem or Printer port depending on the Macintosh port to which you 
connected your interface.  If you have a dual-port interface check both 
the Modem and Printer ports.  

3. Below each Port you checked:

• Click the Speed pop-up if you want to alter the speed (1 MHz is 
typical); hold down the mouse and choose from the pop-up menu.

• Check MIDI Time Piece (below the Port check box) only if you have 
and are using a MOTU MIDI Time Piece on that port.

• Click the Record button under the desired port in the MIDI Setup 
dialog box.

• Click the Receive Sync button if you

  

re syncing Metro to external 
timing sources.

• Click the Send Sync button if you

  

re syncing other MIDI devices to 
MIDI Clocks generated by Metro.

4. Select a timing resolution in Clocks per quarter note (pulses per quarter 
note) by choosing a setting from the pop-up menu. 

5. Click OK.

 

OMS MIDI Setup

 

Metro’s MIDI Setup dialog box appears differently when OMS is installed.  If 
you are not running OMS, you may wish to skip this section of the 
Reference.

When OMS is installed, Metro can derive its MIDI Setup and Instrument 
configuration directly from the Current OMS Studio Setup document.  This 
feature can save a considerable amount of time as far as MIDI device setup 
and initial configuration are concerned—especially when running multiple 
OMS-savvy applications. 

When using a multiport MIDI interface, such as the Studio 5 or MIDI Time 
Piece, OMS allows you to custom-name each of the devices/ports within the 
Studio Setup Document.  Custom OMS device names allow Metro to refer to 
ports by names rather than numbers. 
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When you choose MIDI Setup from the Setup menu, the MIDI setup dialog 
box appears, offering the following options:

Record FromæYou can select up to 8 different MIDI controllers across 
multiple ports when using OMS in tandem with Metro.  Click and hold the 
mouse on the Record From pop-up menu and designate which MIDI 
devices/ports you wish to record from.  Devices with a checkmark before 
their name are selected to record from.  

Receive Sync FromæClick and hold the mouse on the Receive Sync From 
pop-up menu to select the device/port from which Metro will receive timing 
data.  The Receive Sync From setting is only relevant when you are in 
external sync mode.  The Receive Sync From pop-up menu only displays 
devices designated to send MIDI Time Code or MIDI Beat Clock within the 
Current OMS Studio Setup document.  Metro can only receive sync from 
one device/port at a time.

Send Sync ToæClick and hold the mouse on the Send Sync To pop-up 
menu to select devices/ports to which you want to send MIDI Clock.  
Devices with a checkmark before their name are selected to receive MIDI 
Clock from Metro.  Send Sync To will function whether Metro is using its 
internal clock or is synced to external timecode/MIDI clock.  The Send Sync 
To pop-up menu only displays devices designated to receive MIDI Time 
Code or MIDI Beat Clock within the Current OMS Studio Setup document.  
Metro can send sync to multiple devices simultaneously.

Clocks per quarter noteæclick the popup menu to tell Metro how many 
subdivisions you want each beat divided into.

 

Setting Up MIDI Time Code

 

If your MIDI interface can translate SMPTE Time code to MIDI Time Code, 
Metro can respond to SMPTE times. 

1. Choose Time Code from the Setup menu.

The MIDI Time Code Setup dialog box appears.

2. Select  one of the following MIDI Time Code Types (frame rates):

• 24 Frames per Second: Film frame rate standard

• 25 Frames per Second: Black and white European video standard

• 30/29.97 Frames per Second (drop frame): NTSC color standard

• 30/29.97 Frames per Second (non drop): Black and white 
American video standard. 

3. Enter a SMPTE offset time in the SMPTE start time fields, if you like.  

For example, if you want a Section to start 1 hour, 12 minutes, 13 
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seconds, 12 frames, and 3 bits into a film, you would enter a SMPTE 
start time of 01:12:13:12:03.  Each of the 32 Metro Sections can have 
its own independent SMPTE Start Time. You’ll see the current Section’s 
SMPTE start time displayed in the Transport window. There are 80 bits 
per SMPTE frame.

4. Click OK.

 

Selecting Record Criteria

 

You must select the MIDI data types you want to record.  If a data type is not 
checked, it will not be recorded.  Once you select your Record Criteria, be 
sure to save your settings within any of the Preferences dialogs (File menu).

1. Choose Record Criteria from the Setup menu.

The Record Criteria dialog box appears. 

2. Check the data types you want to record. 

3. Click OK.

 

Setting Record and Play Preferences

 

To set Record and Play preferences:

1. Choose Record/Play from the Setup menu. 

The Record and Play Setup dialog box appears.

2. Select how you want Metro to begin playing and recording:

• No Countoff 

• Countoff 

• Wait for first note before recording

3. Choose a Record Loop Setup (you enable looping in the Transport 
window):

• Song Building mode--

 

Song Building mode lets you listen to, and 

reject, passes as you record them, recording onto one or multiple 

tracks depending on whether you’ve chosen Overdub or Replace. 

The number of passes you can record depends on the number of 

MIDI record tracks you specify in the Record/Play dialog box 

(before Loop Recording, you must choose both a Record mode 

and a Loop Recording mode). 

 

• Multiple Take mode--Multiple Take mode lets you listen only to the 
pass you’re currently recording so each "take" is not influenced by 
the last. Multiple take mode records onto one or multiple tracks 
depending on whether you’ve chosen Overdub or Replace in the 
Record Mode section of the dialog box.
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• "N" Tracks maximum--"N" Tracks maximum when loop recording 
tells Metro how many extra tracks to use for loop recording in 
Replace mode. 

4. Choose A Record Mode:

• Choosing Overdub tells Metro to record loop passes onto one track 
only.

• Choosing Replace tells Metro to record loop passes onto separate 
tracks.

• Choosing Input Quantize opens the Input Quantize dialog box, 
where you can choose how you want Metro to quantize notes as 
you record them. See Qauntize under the Options menu for more 
information about quantizing.

5. Click OK.

Now that you have set your Record and Play preferences, put them to use in 
the Chapter 2 tutorial, “Your First Session with Metro.”
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Your First Session with Metro

 

This tutorial guides you through MIDI setup and configuration and 
introduces you to Metro’s compositional environment. For this tutorial you 
need a Macintosh with 16 bit digital audio capabilities, a MIDI input device 
(such as keyboard synthesizer or MIDI controller), a multi-timbral sound 
module supporting the General MIDI standard, a Macintosh-compatible 
MIDI interface, and Opcode’s Open Music System (OMS) installed. Your 
MIDI devices must be properly configured and connected to your MIDI 
interface, and your MIDI interface must be properly connected to your 
Macintosh. 

• Opening Metro and Setting Up MIDI (with OMS) 

• Configuring Your Audio Setup 

• Creating New Instruments 

• Setting Up the Metronome 

• Using MIDI Thru 

• Customizing Metro's  Window Layout 

• Saving Preferences 

• Creating a New Metro File 

• Importing an Audio File 

• Looping a Track 

• Recording Your First MIDI Track. 

• Editing Your First MIDI Track 

• Recording a MIDI Bass line 

• Recording Another Track 

 

Opening Metro and Setting Up MIDI (with OMS)

 

To open Metro and set up MIDI:
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1. Double-click the Metro application icon, which you’ll find in the 
Cakewalk folder on the drive where you installed Metro.

The MIDI Setup dialog box appears when you launch Metro for the first 
time, or if METRO does not detect a record source (when running 
OMS).  

2. Click and drag the Record From pop-up menu to select a MIDI device 
you wish to record from. For the purposes of this tutorial, be sure to 
select your MIDI controller as a record source. A check mark next to a 
device in the  pop-up designates it is selected for recording. 

3. Choose the Record From pop-up again for each additional MIDI device 
you wish to record from.

4. Choose 480 under the Clocks per quarter note pop-up menu. 480 
clocks (sometimes called pulses or ticks) per quarter note is the 
standard timing resolution for most professional MIDI sequencer 
applications. (Metro’s highest timing resolution can be set to 960 clocks 
per quarter note.)

5. Click OK to close the MIDI Setup dialog.

You have configured METRO’s MIDI recording options. Don’t worry about 
the Receive Sync From and Send Sync To options in the MIDI Setup dialog, 
these features are only applicable when working with MIDI Time Code or 
MIDI Clock, which are not relevant for the purposes of this tutorial.

 

Configuring Your Audio Setup

 

Metro supports digital audio on 16 bit Macintosh machines. For the 
purposes of this tutorial, connect your Macintosh audio output to an input of 
your mixing board or some other source set up for monitoring the output 
signal.

1. Choose Digital Audio from the Setup menu.

The Digital Audio Setup dialog box appears.

2. Under For Metro Digital Audio, do one of the following:

 

•

 

Click Direct Support and choose Built-in from the Direcr Support 
popup menu. This configures Metro to use Sound Manager

  

s built-
in audio capabilities. Metro requires Sound Manager 3.2 or higher.

 

•

 

Click Direct Support and choose your external soundcard from the 
popup menu.

 

•

 

Click ASIO and choose your external soundcard from the popup list 
of ASIO devices, if you have downloaded and installed your 
soundcard’s ASIO driver. We recommend ASIO as a first choice.
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3. Set the Sample Rate to 44100 and the Bits to 16 (see your soundcard’s 
documentation for more options for sample rates and bits).

4. Select the Stereo checkbox so that Metro will record stereo interleaved 
AIFF audio files.

5. Click Recording Options to open either your soundcard’s control 
console (if any) or the Sound Manager Parameters dialog box.

6. In the Sound Manager Parameters dialog box, you can set Playthrough, 
set Input Gain, or click the More button to set Sound Input options (the 
Sound Input dialog box looks different for each soundcard you select in 
the Digital Audio Setup dialog box).

7. Click OK enough times to get back to the Digital Audio Setup dialog box 
and make sure For connecting to Deck™ II is unchecked (for now).

8. Click OK to close the Digital Audio Setup dialog box.

You have set Metro to work with either your Mac’s internal soundcard, an 
external soundcard, or an external soundcard with an ASIO driver.

The next step in your first session is Creating New Instruments.

 

Creating New Instruments

 

Now that your Record From devices are configured, the next step is to 
create Metro Instruments. Ideally, there should be a Metro Instrument 
representing every MIDI channel associated with each of your MIDI devices, 
and one Metro Instrument for each Audio Track. For example, a 16 channel 
multi-timbral MIDI device will require 16 Metro Instruments, one for each 
MIDI channel. Metro Instruments also address audio ports.

MIDI note events within a track as well as allow you to name of the channels 
of your MIDI devices.

METRO’S instruments can be automatically derived from your Studio Setup 
Document.

To automatically create new instruments:

1. Choose Modify Instruments and Busses under the Special menu.

The Modify Instruments and Aux Busses dialog box appears.

2. Click the Create Current OMS Instruments button, then click OK.

You have automatically configured  Metro Instruments. Open the 
Instruments window and notice there’s now a fader representing each MIDI 
channel of all of your MIDI devices. Assign Metro Instruments to tracks 
within the Tracks and Graphic Editor windows; use the Instruments window 
to mix volume and pan settings
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Setting Up the Metronome

 

Metro’s Metronome helps you record tempo-oriented MIDI and audio parts. 
You can configure Metronome settings to use built-in sounds or trigger 
external MIDI devices. For the purposes of this tutorial, let’s set up the 
Metronome to trigger an external MIDI sound module.

To set up the metronmome:

1. Open the Transport window (Command-B) and click the Zoom box to 
expand the window to its full size, if necessary.

2. Click the door on the Metronome button to open the Metronome dialog 
box.

3. Select the MIDI device you wish to use for your MIDI Metronome under 
the Port menu. In this case, choose your General MIDI sound module 
as a MIDI Metronome source.

4. Enter Channel 10 in both the fields of the Bar and Beats Channel 
settings. Channel 10 represents the drum track on General MIDI 
modules.

5. Enter your preferred pitch settings in both the fields of the Bar and 
Beats Pitch settings. MIDI notes D#4 and E4 work well as Bar and 
Beats settings, respectively. You can also enter a note value when the 
Bar or Beats field is active by playing it directly from your MIDI 
controller.

6. Click OK to close the dialog box.

You have set up Metro’s Metronome. Use the Metronome as a tempo 
reference when recording new tracks into Metro.

 

Using MIDI Thru

 

Metro’s MIDI Thru controls which module you hear when you play your MIDI 
controller. You can play any of your MIDI sound modules without having to 
reroute cables or switch channels on your MIDI devices. MIDI data is sent 
from your MIDI controller through Metro and rerouted out to any of your MIDI 
devices. When you work with a MIDI controller and one or more sound 
modules, use MIDI Thru to select which sound you’ll hear when you play 
your controller. 

We recommend turning off local control on your MIDI controllerwhen using 
MIDI Thru as the primary means to trigger your sound modules.

Click the Local Cntrl Off button in the Instruments window to disable local 
control. Open the Instruments window by pressing Command-

 

I.

 

 Let’s try an 
example to learn more about the capabilities of MIDI Thru:

1. Open the Transport window (Command-B) and expand it to its full size, 
if necessary. 
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2. Click and drag the MIDI Thru popup and set it to Off. This disables MIDI 
Thru.

3. Open the Instruments window and click the Local Off button located 
above the Master Fader. Now play your MIDI controller. If your 
controller has its own internal sounds, you should NOT hear the 
instrument playing.

4. Within the Transport window, click and drag the MIDI Thru pop-up and 
select your General MIDI sound module. The popup window closes. 

5. Choose channel 10 from the MIDI channel popup directly below the 
MIDI Thru device name you selected.

6. Play your MIDI controller and you should hear the drum sounds 
associated with channel 10 of your General MIDI sound module.

7. Switch the MIDI Thru channel to 2. Now play your MIDI controller and 
you should hear the sound on channel 2 of your General MIDI  device.

When you record new MIDI tracks, use MIDI Thru in Metro to route data 
from your MIDI controller to any channel of any of your MIDI devices. Enable 
Automatic MIDI Thru in the Switches menu to instruct Metro to automatically 
change the MIDI Thru device to match the Instrument channel and port 
setting of the record-enabled track, when you use Metro Instruments. When 
using Ports, you will need to set the MIDI Thru manually.

The next step in your first session is Customizing Metro's  Window Layout.

 

Customizing Metro's  Window Layout

 

Metro’s default window configuration is optimized for a 9” monitor screen. 
(Yes, Metro is the only modern day sequencer that still runs on the original 8 
MHz Mac Plus.)  Take this opportunity to resize Metro’s windows to better 
suit your individual monitor display size.

As the default window Metro configuration demonstrates, it’s good to leave 
the Tracks, Graphic Editor, Transport and Sections windows exposed. 

Let’s try an exercise in window management:

                                          MIDI Thru Menu
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1. Open the Instruments window (Command-

 

I

 

) and the Tracks window 
(Command-B).

2. Drag the Tracks window so that it covers part of the Instruments window 
but does not  cover the faders.

3. Metro allows you to manipulate the faders and buttons in the 
Instruments window without making the window active. 

4. Drag one of the faders up and down without activating the Instruments 
window. Be sure to drag from the thumb of a fader, otherwise you may 
activate the Instruments window.

5. Open the Graphic Editor window (Command-J), and click the Zoom box 
to expand the window to full size.

Window Size ButtonPiano Roll Zoom Buttons
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6. Click the Graphic Editor’s Zoom box again to return the window to its 
original position. This is a handy technique for optimizing screen real 
estate.

Try the same procedure with the Tracks window and other Metro windows. 
Use the Command keys to make the Tracks (Command-K), Sections 
(Command-Y) or Graphic Editor (Command-J) window active. Look in the 
Windows menu for a list of window shortcut keys.

Of course everyone works in a unique way. This particular layout exemplifies 
only one approach designed to get you quickly configured and feeling 
comfortable in a workable environment. Feel free to explore your own 
configurations to better suit your specific needs.

The next step in your first session is Saving Preferences.

 

Saving Preferences

 

With everything now in place and properly configured, let’s Save 
Preferences so that your custom environment awaits you each time Metro is 
launched. Let’s also set one more preference in the process.

To save preferences (and set selection color):

1. Choose Preferences from the File menu.

The Preferences dialog box appears.

2. Click the General tab.

While the General Preferences dialog box is open, let’s also configure 
how Metro displays selected notes. By default, Metro displays notes by 
color according to MIDI channel, 16 channels display as 16 colors. 
When working with OMS and Metro Instruments, channel data 
associated with individual MIDI events becomes irrelevant (since all 
channel data on a track is reassigned on the fly by Metro Instruments). 
Let’s make better use of color by configuring Metro to display selected 
note data by color.

3. In the Note Colors field click the Use Color for Selection Info button. 
This instructs Metro to use a color to denote selected note and drum 
events, the default selection color is red.

4. Click the Save button to save all of your configuration settings and exit 
the dialog box.

Remember that saving Preferences stores the parameters of Metro’s current 
state as the default configuration. Metro Instruments, window positions, 
Metronome settings and other relevant setup information are saved as part 
of the Metro Preferences file.



 

2-8

 

Creating a New Metro File

 

Metro always creates a new and empty session when launching the 
application. Metro loads the empty session into RAM and saves it to disk as 
a Metro file, after you select Save from the File menu.

To create a METRO file:

1. Select Save from the File menu.

2. Type a name for your Metro file, then click OK to save it to a drive or 
diskette. 

 

Importing an Audio File

 

Metro offers a variety of methods of MIDI and digital audio recording, 
including linear, partial track, punch-in and step-entry modes. Metro’s 
arrangement features facilitate linear or nonlinear section-based 
arrangements. This section of the tutorial focuses on recording and editing a 
linear multitrack arrangement.

Let’s start out by constructing some tracks around an existing drum loop 
sample that was saved in AIFF format.

To import an audio file:

1. Choose Import Audio File from under the File menu. 

2. Locate the folder called Drum Sounds folder and open the file named 
Drum Loop 120.AIFF. 

3. Click the Convert button to import the file into the active Section.

The next step in your first session is Looping a Track.

 

Looping a Track

 

To loop a track:

1. Within the Tracks window, click the Loop icon next to the track named 
“Drum Loop 120”. 
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2. Set the track length (in the Bars column) for “Drum Loop 120” to 2 bars.

Looping a track causes it to repeat over and over from the beginning to end. 
Loop length is determined by the number in the Bars column (next to the 
Loop column).

 

Recording Your First MIDI Track.

 

From within the Tracks window, double-click the track named “Drum Loop 
120” to display it within the Graphic Editor window. Notice the audio file 
display within the Graphic Editor.

Now let’s record a MIDI track to add a 16th note high-hat figure over the top 
of the drum loop sample. The file Drum Loop 120 plays back at 120 beats 
per minute, which is Metro’s default BPM configuration. Remember, MIDI 
channel 10 is designated as the drum channel for all General MIDI sound 
modules. 

Before we record, let’s configure Metro’s count off time:

1. Choose Record/Play from the Setup menu.

The Record and Play dialog box appears. Use it to configure Metro for 
record and play operations such as count off, record mode and input 
quantize.

2. Enter 1 in the Count off “N” bars before recording field. This sets Metro 
to play a 1 bar count off before recording.

3. Click OK to exit the Record and Play dialog box.

4. Open the Transport window (Command-B) and expand it to its full size, 
if necessary.

5. Choose CountOff from the popup menu in the far right portion of the 
Transport window.

            Loop Icon       
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This instructs Metro to play a count-off before recording. Count-off time is 1 
bar, the number you specified in the Record/Play dialog.

Now let’s record our first MIDI track:

1. Within the Tracks window, click on the “R” column to record-enable track 
3.

2. In the track 3 Instruments column, click the popup menu and choose 
Channel 10 of your General MIDI device. 

3. Click the Record button in the Transport window to begin recording. 
Remember, there will be a one measure count-off.

4. After the 1 bar coun- off, play a high-hat figure to complement the drum 
loop. MIDI notes F#1, G#1 and A#1 are assigned to high hat sounds on 
the drum channel of General MIDI sound modules.

5. Click the Stop button in the Transport or press the spacebar after you’ve 
played in at least 2 bars of a high-hat figure. 

6. To name your newly recorded track, Option-click on the name of track 3 
and type in the name “high-hat 16ths”, press Return to enter the name.

 

Editing Your First MIDI Track

 

Next we will edit and loop the high-hat track. Remember, the sample Drum 
Loop 120 is a 2 bar loop. 

Let’s modify the high-hat track so that it plays as a 1 bar loop:

1. Double-click the name of track 3, “high-hat 16ths,” to view it within the 
Graphic Editor window.

2. Choose Select All from the Edit menu to select all of the data within 
track 3.

3. Press the Shift key and click Bar 1 in the time line of track 3 within the 
Graphic Editor. This deselects Bar 1 from the active selection.

CountOff Popup Menu
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4. Choose the Delete from the Edit menu, or press the Delete key, to 
delete the active selection. This shortens the high-hat track to a length 
of 1 bar.

5. Click the Loop field in the track’s titlebar to activate track looping. The 
track length should already be set to 1 bar.

Track 3 is now set to a 1 bar loop. Looping is an effective compositional tool, 
which, among other things, allows you to set up unique cross rhythms and 
motifs that cycle in and out over time.

Now let’s Quantize your high-hat part so that it plays in perfect sync with the 
120 BPM drum loop sample:

1. Within the Tracks window, double-click the track “high-hat 16ths” to view 
it in the Graphic Editor.

2. Choose Quantize from the Options menu.

The Quantize dialog box appears.

3. Enter 120 in the Quantize to field. 120 clocks represents a 16th note 
value when Metro is set to 480 clocks per quarter note. 

Quantization shifts individual MIDI notes and events within the selection 
to the nearest beat boundary that you specify, 16th notes in this case.

4. Click OK to close the Quantize dialog box and process the selected 
MIDI data. 

Click  the Play button in the Transport or press the spacebar to audition the 
quantized high hat part in tandem with the drum loop. Notice how the 
Quantize operation added machine-like precision to the feel of your high hat 
part. Quantization has mathematically perfected the rhythm of your high hat 
part. This is an example of quantization in its most raw and basic sense. 

Time Line
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Metro features other variants of the Quantize operation, such as Swing Feel, 
Strength and Groove Quantize.

 

Recording a MIDI Bass line

 

OK, as the next step, let’s add a 4 bar MIDI bass line over top of the drum 
loop and high hat tracks:

1. Within the Transport window, click and drag the MIDI Thru Channel 
popup to set it to channel 1.

2. Click the Play button in the Transport window or press the spacebar to 
start playback. As the sequence plays, select a bass sound on your 
General MIDI sound module and work out a 4 bar bass line to go along 
with the drums. 

3. Click the Stop button in the Transport or press the spacebar once you’re 
figured out your part.

4. From within the Tracks window, click the R column to record enable 
track 4 for recording. 

5. Click and drag the Instrument popup on track 4 to assign it to Channel 1 
of your General MIDI sound module.

6. Click the Record button in the Transport or press Option-R to begin 
recording your MIDI bass line to track 4. (Remember, the count off is set 
to 1 bar.)

7. Click the Stop button in the Transport or press the spacebar after you’ve 
played in at least 4 bars worth of material. 

8. Within the Tracks window, click the Loop button to loop the bass track 
and specify 4 bars for the track duration.

9. Choose Save from the File menu. This saves the contents of the active 
session to the current Metro file.

 

Recording Another Track

 

Now lets add an 8 bar melodic or chordal figure on top of the existing drum 
and bass tracks:

1. Within the Transport window, click and drag the MIDI Thru Channel 
popup to set it to channel 2.

2. Click the Play button in the Transport window or press the spacebar to 
start playback. As the sequence plays, select a melodic lead or chordal 
sound on your General MIDI sound module and work out an 8 bar 
passage to go along with the drums and bass. 

3. Click the Stop button in the Transport or press the spacebar once 
you’ve figured out your part.
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4. From within the Tracks window, click the R column to record enable 
track 5 for recording. 

5. Click and drag the Instrument popup on track 5 to assign it to Channel 2 
of your General MIDI sound module. Remember, each new sound must 
be assigned  to an unused MIDI channel.

6. Click the Record button in the Transport or press Option-R to begin 
recording your MIDI melodic or chordal line to track 5 (remember, the 
count off is set to 1 bar)

7. Click the Stop button in the Transport or press the spacebar after you’ve 
played in at least 8 bars worth of material. 

8. Within the Tracks window, click the Loop button to loop track 5 and 
specify 8 bars for the track’s duration.

9. Choose Save from the File menu. This saves the contents of the active 
session to the current Metro file.

Congratulations!  You’ve just completed your first piece done with Metro. 
Continue on with the next tutorial, “Getting Deeper”, to further explore 
Metro’s compositional tools.D
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 Getting Deeper

 

This tutorial builds upon your work in the tutorial “Your First Session with 
METRO”. In this tutorial we’ll cover the following topics:

• Customizing Program Names 

• Drum Machine-style Recording 

• Creating a Section 

• Drum Grid Recording 

• Drum Grid Editing 

• Adding Tracks within the Graphic Editor Window 

• Plugging In and Testing a Microphone 

• Setting Up Audio Instruments 

• Latency and the Sound Manager 

• Changing Audio Volume 

• Adding Effects in Real-time 

• Adding Offline Effects 

• Arranging with Subsections 
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Customizing Program Names

 

METRO allows you to create custom Program Names to track program 
change messages sent to your MIDI devices. It’s helpful to work in a MIDI 
environment where names are substituted for numbers; METRO can even 
alphabetize Program Names when displayed in a pop-up menu. 

General MIDI devices incorporate a universal patch naming scheme. 

Let’s configure METRO to display the General MIDI patch names contained 
within your GM-compatible sound module:

1. Choose Program Names from the Setup menu.

The Program Names dialog box appears.

2. From the Channels for port menu, choose the name of your General 
MIDI-compatible device. 

3. Click the Open button and locate the METRO Instruments File named 
“General MIDI Patches”, which is found in the Program Names folder 
within the folder containing the METRO application. The “General MIDI 
Patches” file contains the names of all programs within a General MIDI 
compatible sound module.

4. Click the All button in order to assign all 16 MIDI channels of the 
designated port to the General MIDI Patches Program Names file. 
Select the port that’s connected to your GM-compatible sound module.

5. Click OK to close the Program Names dialog box.

METRO is now configured to display the Program Names of your General 
MIDI-compatible instrument. METRO substitutes Program Names, instead 
of numbers within its Program Name fields.

Choose General Preferences from the File menu and select Save in order to 
save Program Names within your custom METRO environment.
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Drum Machine Style Recording

 

Drum Grid editing coupled with drum machine-style recording comprise an 
excellent tool set for recording and editing rhythmic loops in METRO. Real-
time MIDI editing keeps the creative juices flowing, allowing you to edit 
without having to stop the recording process.

The Record and Play Setup dialog box configures METRO for a variety of 
record loop modes including Song Building mode, which is a great way to 
emulate drum machine-style recording.

Loop Recording does not support the recording of Audio Tracks.

In the previous tutorial you used this same dialog box for setting up a count-
off time. Now let’s configure METRO’s record mode:

1. Choose Record/Play from the Setup menu.

The Record and Play Setup dialog box appears.

2. Click the Song building mode button to select your record mode setup.

3. Enter 1 in the field for “N” Tracks maximum when loop recording. This 
sets METRO to record each of its loop passes onto a single track.

4. Click the Overdub button to select your Record mode setup. Selecting 
Overdub as the record mode instructs METRO to layer each record 
pass on top of one another.

5. Click OK to enter your new settings and close the dialog box.

6. Open the Transport window (Command-B) and expand its window to full 
size, if necessary.

7. Click to select the Rec checkbox within the Looping display. This 
enables record looping.

You’ve now configured loop recording in Song Building Mode, which 
overdubs successive record passes onto a single track. This is exactly the 
formula needed to emulate drum machine-style recording. 

 

Creating a Section

 

Let’s continue with the METRO file that we created in “Your First Session 
with METRO.” First, let’s create a new Section to work with. Remember, 
each METRO Section is a chunk of musical time containing up to 99 tracks. 
Sections are independent of each other, but they can be linked together and 
superimposed, which we’ll explore later in this tutorial in Arranging with 
Subsections.

To create a Section:

1. Choose Sections from the Windows menu, or press Command-Y.

The Sections window appears, displaying the name of your METRO 
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document at the top of the window and your Sections in the numbered 
list.

2. Click Section 2, which is currently labeled “Empty”. This instructs 
METRO to make Section 2 the active Section for recording and play-
back; this also changes the Section name to “untitled”.

3. Double-click the name of Section 2 in order to name it. Type in the 
name “Vamp” in the name field and press the Return key.

Now that you’ve created a new Section to record in, let’s move to the next 
step in this tutorial, Drum Grid Recording.

 

Drum Grid Recording

 

Drum Grid recording within the Graphic Editor window is much like having 
multiple tracks displayed within a single track. However, these tracks are 
optimized for the display of drum data. Within the Drum Grid display, Drum 
Names represent individual drum sounds; you can Mute and Solo Drum 
Names just like you can Mute and Solo individual tracks within a Section. 
Click a Drum Name to select its contents across a track. A Drum Grid is to a 
track what a track is to a Section.

Now let’s record and loop a drum track:

1. Within the Tracks window, click and drag the Instrument pop-up on track 
1 and assign it to channel 10 of your General MIDI compatible sound 
module. Channel 10 denotes the drum channel on GM-compatible 
sound modules.

2. Double-click the empty name field of track 1 to open it within the 
Graphic Editor window.

3. Within the Graphic Editor, choose Drums from the data-type display 
popup in the track’s titlebar, or press the d key. This changes the track 
display from Notes to Drums.

4. Option-click the Track name in the track titlebar of the Graphic Editor 
window in order to name it. Type the name “MIDI Drums” and press the 
Return key.

5. Choose Set Selection from the Edit menu.

6. In the Set Selection dialog box, enter a Start time of 1 Bar, 1 Beat and 0 
Clocks, and an End Time of 3 Bars, 1 Beat and 0 Clocks, then click OK. 

This sets a 2 bar selection across measures 1 and 2. 

7. Press Option-R to begin recording.

The Record Loop dialog box appears.

8. After a 4 beat count-off, METRO begins to loop record for a length of 2 
bars. Play drum patterns and begin to build a rhythmic loop. You may 
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wish to begin with a kick drum pattern, then add snare, high-hat and 
then further embellishments.

9. Click the Pause Recording button in the Record Loop dialog box in 
order to experiment with parts over the existing loop without recording 
them to a track. Press the Record button in the dialog box in order to 
drop back into recording.

10. Notice how the Drum Names stack up across the Drum Grid display 
after each record loop pass. You can even edit the drum sounds without 
having to stop recording.

11. Press the spacebar once you’re happy with the content of your loop. 

12. In track 2’s titlebar of the Graphic Editor window, just to the right of the S 
button, click to select the Loop icon, and type 2 bars as the track length 
in the field just to the right of the Loop icon.

You have loop-recorded a short drum track and set it to loop on play-back. 

 

Drum Grid Editing

 

The Drum Grid displays note events as Drum Strikes corresponding to 
Drum Names (or MIDI note numbers) displayed across their own row. Drum 
Strikes denote ranges of note velocity, the larger the Strike, the louder it will 
sound. Try these convenient editing operations:

• Click a Drum Name to select it across the entire duration of the Drum 
Grid. All Drum Strikes associated with the Drum Name become 
selected. Clicking a Drum Name also plays the corresponding drum 
sound out the current Instrument’s port.

• Shift-click to select multiple noncontiguous Drum Names. 

• Click to the left of a Drum Name to Mute and Solo individual drum 
sounds within the Drum Grid. Click the Drum Set name to unmute and 
unsolo all Drum Names.

• Click the M button within the Drum Grid

  

s titlebar to Mute the entire 
track. Track Mute and Solo affect the entire contents of the Drum Grid 
display.

• Drag a Drum Name up or down to reposition it within the Drum Grid 
display.

For more information, please refer to Working with Drumsets.

 

Adding Tracks within the Graphic Editor Window

 

Let’s record a MIDI bass part to go along with the drum track. We’ll stay 
within the Graphic Editor window to perform the bulk of the new track 
operations. 
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First, let’s add a track within the Graphic Editor window:

1. Choose Graphic Editor from the Windows menu, or press Command-J.

2. Click the Add Track icon (the “+” symbol in the upper left corner of the 
Graphic Editor window) to add a new track into the Graphic Editor 
display. This displays track 2 (in Notes display mode) below track 1’s 
Drum Grid display.

3. Disable record loop mode and reconfigure METRO’s Record/Play 
dialog to tun off Overdub mode:

a) Choose Record/Play from the Setup menu.

b) Click the Replace button to change your Record mode setup back to 
METRO’s default setting. Overdub mode was only required for the loop-
based recording from the previous example.

c) Open the Transport window (Command-B) and deselect the Rec 
checkbox in the Looping section. This disables record looping.

4. 4In the Graphic Editor window, click the R button in track 2’s titlebar to 
enable the track for MIDI recording.

5. In the middle of track 2’s titlebar, click and drag the Instrument popup to 
select channel 2 of your General MIDI sound module. Be sure the 
Automatic MIDI Thru is enabled under the Switches menu.

6. Click the Program popup in the upper right part of the Graphic Editor 
window to select a bass program for channel 2 of your General MIDI 
sound module. Remember, you can select programs by name.

7. Press Option-R to begin recording.

8. Play a 4 bar bass line after the 4 beat count-off. 

9. 9Press the spacebar once you’ve finished recording. 

Add Track Icon
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10. In the titlebar of track 2, just to the right of the S button, click to select 
the Loop icon, and type in 4 bars as the track length in the field just to 
the right of the Loop icon.

Now you have a drum and bass vamp that you can use in your final 
arrangement. Choose Save from the File menu to save the new tracks in the 
current session.

Notice that the Graphic Editor window displays your bass line underneath 
the Drum Grid (you may need to use the vertical scroll bars to locate the 
bass notes). The Graphic Editor window allows up to 16 tracks from the 
current Section to be viewed simultaneously.

 

Plugging In and Testing a Microphone

 

Let’s flesh out our song by recording some audio into it. For this exercise, 
the audio can be of anything you like; you could record snapping your 
fingers, counting along into a microphone, playing some notes on a guitar or 
bass, or even trying out your singing voice. All you need is some kind of 
audio signal to be plugged into your Mac’s audio input (usually marked with 
a microphone symbol) or your dedicated sound card. Let’s start out by 
plugging a microphone into your Mac sound card. If you have a sound card 
from a separate company, follow the directions that came with that sound 
card.

To plug in and test a microphone:

1. Locate the microphone input on the back of your computer. It has a 
microphone icon above it or next to it.

2. Look at the connection jack on the end of your microphone:

 

•

 

If it came with your computer, it should have a one-eighth inch jack 
that will plug right into the microphone input. 

 

•

 

If you have a larger, one-quarter inch jack or guitar cord, plug the 
one-quarter inch microphone jack or guitar cord into a one-eighth 
inch adapter.

3. Plug in the microphone, if you haven’t done so.

4. From the Apple menu, choose Simple Sound > File > New.

The Simple Sound recording dialog box appears.

5. Click the Record button and speak into the microphone or play your 
guitar.

6. Click Stop and click Play.

You should hear your recording coming from the Mac’s speakers (make sure 
they are on and turned up). 
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If you don’t hear anything, check your connections and repeat steps 4-6. You 
may need to adjust Volumes, Sound Out, or Sound In in the Control Panels. 
Open the Sound window by choosing Apple menu > Control Panels > Sound 
(not Monitors and Sound). Also, make sure no Mute buttons are checked in 
the Sound window.

Setting Up Audio Instruments
Let’s set up an instrument to record on the Audio Port:

1. In the Special menu, choose the Modify Instruments and Busses 
command. 

The Modify Instruments and Aux Busses dialog box appears.

2. Click Add, and check the checkbox below it. 

 

3. We want to add one instrument, so type a one in the field to the right of 
the checkbox. 

4. In the Port popup menu (to the right of the words “Instrument on”), 
choose Audio. 

5. In the Named field, name it “recording test” or something similar. Leave 
the Channel selection at the default, 1, and click OK to add the 
Instrument. 

6. Notice that in the Instruments popup in the Tracks window, there is now 
an instrument called recording test-1. Choose this instrument now for a 
track to get ready to record.

7. Make sure that the track you selected is record-enabled (with a dot in 
the “R” column). 
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Your First Audio Recording
Before we start recording, we should make sure that there is a good audio 
signal coming in. You might find it helpful to expand the Levels section of the 
Tracks window to get a more precise level reading.

To do this, move the mouse pointer over the vertical bar that marks the right 
side of the Levels column until it turns into left and right arrows indicating 
that the divider can be moved. Click and drag it to the right to expand the 
meters as much as you like.

To check METRO’S audio recording level:

• Plug in your microphone or other device. You should see the meters 
responding to your input. If you can see the input, but cannot hear 
anything, perform the following three steps to check your audio 
configuration:

a) From the Setup menu choose Digital Audio.

The Digital Audio Setup dialog box appears.

b) Click Recording Options. 

The sound manager Parameters dialog box appears. 

c) Click Play Through. If your signal distorts, you can adjust the gain of 
the incoming signal here as well. See Digital Audio Setup for more 
about the audio setup dialog. For our purposes here, we can move 
forward by clicking OK in both dialog boxes. 

Now let’s make a recording:

1. Make sure that the track you selected is record-enabled (with a dot in 
the “R” column). 

2. Press Option-R and record some audio. 

3. Press the spacebar to stop recording.

4. Press the spacebar again to play your recording.

Notice in the Tracks window that METRO builds an Audio Display for the 
recorded audio information. Remember that you can always Undo the 
recording if you make a mistake (Command-Z). METRO rebuilds the audio 
display for you periodically while you work with audio to reflect your edits, 
tempo changes and new audio recordings. 

If you use Apple’s built-in sound card, you may notice a slight time gap 
before your audio starts playing. If so, see the topic Latency and the Sound 
Manager. If not, go on to Changing Audio Volume.
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Latency and the Sound Manager
When using the Mac’s built-in audio to record (via the system software’s 
Sound Manager), you may periodically find that your audio is slightly offset 
from where you thought you began recording. This is called latency. It is a 
limitation of the Sound Manager, and every application that uses the Mac’s 
built-in audio hardware to record and play audio at the same time will display 
this problem. (Dedicated audio cards you add to your Mac, like the 
AudioMedia III, Sonorus STUDI/O,. and the Korg 1212I/O, don’t display this 
problem.)

If you notice some offset audio, you’ll need to make subtle adjustments to 
the start times of new audio tracks. These minor adjustments are easily 
done with the Delete Time (Shift-Command-D) and Insert Time (shift-
Command-I) selections in the Edit menu.

Here’s some more detail about what to do if you notice any timing problems 
with your new audio track and the previous tracks: 

1. In the Tracks window, double-click the name of your audio track.

The Graphic Editor window appears, displaying your new audio track.

2. Use the scroll bar at the bottom of the window to scroll to a region of 
blank space that comes before the audio waveform. 

3. Use the Select tool (the pointer) in the Graphic Editor to click and drag a 
small amount of blank space.

4. From the Edit menu, choose Delete Time or Insert Time to reconcile the 
start times. Experiment until the timing sounds acceptable.

There will be many occasions like the one above when it will be helpful to 
Zoom all the way in to the Sample level on a waveform in the Graphic Editor 
in order to make precise edits. Let’s do it now to get a feel for it:

1. Select a small section of your recorded audio with the Select tool.

2. Click the Magnifying Glass Icon with the plus sign or press Command- 
= to Zoom in on the waveform. You will notice the wave getting more 
and more detailed as you do. 

3. To Zoom back out again, click the Magnifying Glass with the minus sign 
or press Command- - to Zoom back out to your desired level.

If you select data in a MIDI track instead of an audio track, METRO will 
always let you zoom in and out, but won’t burrow all the way down to the 
audio sample level; this actually saves some time, since METRO doesn’t 
have to calculate the wave’s image each time you zoom in to look at MIDI.
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Changing Audio Volume
Volume levels for audio tracks in METRO can be changed several ways. You 
can change the volume in real time (maintaining the original audio data) 
using the faders in the Instruments window. To make a permanent change to 
the audio data (known as an offline edit), you can use commands in the Edit 
menu’s Audio submenu: Scale Amplitude, Fade, Normalize, and Group 
Normalize. 

For this tutorial, we’ll investigate only one of the methods, the Normalize 
command. This command allows you to maximize the volume in any 
recorded audio, helpful before you begin mixing a song. It does this by 
searching through the current audio selection to detect the highest 
amplitude peak, then scaling the rest of the audio up to match. You can 
control whether METRO scales it all the way up to its maximum amount with 
the Normalize dialog box and the Change audio to “N”% of maximum field.

The Change audio to “N”% of maximum field accepts values between 1 and 
500, a 100% amplitude setting scales the detected amplitude peak to 0 dB 
(to the maximum volume before distortion, or “clipping,” occurs). The overall 
affect of applying the Normalize command increases perceived loudness 
across an audio selection.

To normalize your audio, use these steps:

1. Select a small portion of audio.

2. Choose Audio and Normalize from the Edit menu and see what it does 
for your waveform and the playback volume!

Adding Effects in Real-time
And now for the real fun stuff: effects! METRO supports Cakewalk Audio 
Effects, VST, and Adobe Premiere Plug-ins. Let’s add some from METRO’s 
included Cakewalk Audio Effects suite onto one of our audio tracks. First, 
make sure that an entire audio track is selected by activating it in the 
Graphic Editor or clicking on its track number in the Tracks window. Once the 
track has been selected, choose Windows and Plug-ins (or type command-
9) and Windows and Effects (or type command-0). Feel free to move these 
windows around to suite your screen layout.

To add an effect to your track in real-time: 

1. Double click one of the plug-ins. For this experiment, double-click the 
Cakewalk Stereo Delay Plug-in. Its parameters will appear in the Effects 
window. 

2. Play your track (or you might just want to Cue a section of your track) 
and adjust the Wet/Dry mix and the other parameters to get a delay 
sound you like. 
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3. Try adding another effect and playing around with it, too. Notice that the 
Bypass button lets you quickly turn the effect off to compare what it is 
doing to the original sound.

4. When you find an effects setting you like, open the popup window in the 
top right of the Effect and choose Save Preset As to create your own 
preset. 

Adding Offline Effects
Being able to apply Effects offline is a useful tool, especially if you want to 
save processor power during playback. To demonstrate how this works, let’s 
apply the Preset you just created to an audio track:

1. Select the track (or the region of a track) to which you would like to add 
the effect and choose Audio from the Edit menu. 

2. Click the Delay Plug-in from the list. When the Plug-in’s window 
appears, you will notice that it looks a little different from the way it looks 
when used in real time. 

3. Choose your preset from the Presets popup window. You can click OK 
to go ahead and apply it or click Preview to test it out first.

There are a number of edits you can apply to your audio tracks other than 
adding Effects: you can change pan and volume as you would on a mixer 
(and automate those changes in real time) from the Instruments window, 
and you will find other editing options in the Edit Menu under Audio. Try 
selecting a section of your audio track and reversing it. Try a fade out or fade 
in. 

Arranging with Subsections
Let’s create several variations of the music you’ve recorded in this tutorial. 
Thus far, you’ve recorded material into two separate Sections: a Theme and 
a Vamp. Now you’ll create several quick variations of the main Theme. Each 
variation will require a dedicated Section.

To copy and paste a Section:

1. Within the Sections window (Command-Y), click the name of Section 1 
to select it.

2. Choose Copy from the Edit menu, or press Command-C to copy 
Section 1 to the Clipboard.

3. Click the name of Section 3 select it for editing.

4. Select Paste from the Edit menu, or press Command-V to paste the 
contents of the Clipboard into Section 3.

5. Section 3 now contains the same data as Section 1. Let’s create a quick 
variation of Section 1 by muting several tracks within the copied version:
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6. Within the Tracks window, click the Mute button next to the melodic or 
chordal track you recorded. This creates a version of the Theme that 
plays only the drums, percussion and bass.

7. Double-click the name of Section 3 and type in the name “Theme - 
sparse”, then press the Return key to enter the name.

8. Now let’s create a sparse variation of the main Theme, this time only 
with drums and percussion:

9. Click the name of Section 4 to select it for editing.

10. Select Paste from the Edit menu, or press Command-V to paste the 
contents of the Clipboard into Section 4.

11. Double-click the name of Section 4 and type the name “Theme - drums 
only”, then press the Return key to enter the name.

12. Within the Tracks window, click the Solo button next to the Tracks titled 
“Drum Loop 120” and “16th high hats”. This creates a version of the 
Theme that plays only the soloed tracks.

You’ve now created three variations of the main Theme. These, together 
with the end Vamp, will be enough to put together your first METRO 
arrangement. We’ll create final arrangement using METRO’s powerful 
SubSection techniques. METRO allows you to make arrangements of 
different SubSections by dragging them to playback within a track.   

Let’s try working with SubSections within the following example:

1. Within the Sections window, double-click the name of Section 5. Type 
the name “Arrangement”, then and press the Return key. This names 
Section 5 and selects it as the active Section.

2. Carefully drag the Selector Triangle next to the name of Section 4 into 
the track displayed within the Graphic Editor window. This drags the 
Section into a track. Drop the Section as close as you can to Bar 1. The 
Section will auto-quantize to the nearest Bar boundary.

Notice how the 4 bar Section is drawn within the Notes display of the 
Graphic Editor window.

3. Within the Graphic Editor, click three times on the right Magnifying Tool 
to zoom out several levels. This Zooms Out and allows you to see more 
time across the current track.

4. Within the Sections window, carefully drag Selector Triangle next to the 
name of Section 3 into Bar 5 within the Graphic Editor window.

5. Within the Sections window, carefully drag the Selector Triangle next to 
the name of Section 1 into Bar 9 of the track displayed within the 
Graphic Editor window.
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6. Within the Graphic Editor, click the area representing Section 1 to open 
the SubSection Event Edit dialog box. Enter a duration of 8 Bars and 
click OK.

The duration of the main Theme has been extended to 8 bars so that it 
repeats twice. Now let’s add the Vamp as the last part to play after the 
main Theme.

7. Within the Section window, carefully drag the Selector Triangle next to 
the name of Section 2 into Bar 17 of the Graphic Editor window.

Press the spacebar to listen to your final arrangement. Notice how the audio 
file (Drum Loop 120) plays throughout most of the piece even though its 
original length is only 2 bars. METRO’s SubSection techniques allow for 
flexible manipulation of Sections to create complex arrangements. You can 
even play multiple SubSections simultaneously, which accommodates yet 
another style of composition and arrangement.

Save your file and continue on experimenting with METRO. You may want to 
explore the next tutorial on MIDI recording. 
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 MIDI Recording Tutorial

In this tutorial, you’ll be playing back from the same MIDI device that you’re 
recording from, so you’ll be using Ports on all tracks. Ports allow a track to 
play the device and the device channels originally recorded on that track. At 
start-up, METRO initially assigns Ports to all tracks in the Tracks window. 
Ports also allow each track to record up to 16 independent channels and 
playback separate events on separate channels

There are two types of Instruments you may work with: Ports and METRO 
Instruments. When OMS is installed, METRO can also automatically extract 
METRO Instruments from your Current OMS Studio Setup document. 

This tutorial covers the following topics:

• Setting a Port to the Record Track 

• Enabling the Metronome Click 

• Setting the Record Mode: Replace or Overdub 

• Beginning Recording 

• Naming Your Track 

• Viewing Note Data 

• Playing Back the Track 

• Playing From a Selection or Bar Number 

• Adjusting Note Velocity 

• Saving Your Recording as a METRO File 

• Enlarging the Transport Window 

• Playing and Setting Cues 

• Looping Playback of Your Track 

• Adjusting Current Playback Tempo 

• Auditioning Programs 
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• Looping Playback of an Area Within Your Track 

• Looping Cues 

• Recording Another Track 

• Displaying Multiple Tracks in the Graphic Editor Window 

• Selecting Tracks in the Graphic Editor Window 

• Naming the Current Section 

• On-The-Fly Recording 

Setting a Port to the Record Track
Let’s start our tutorial by creating a new METRO file:

• From the File menu, choose New.

A new METRO document appears.

METRO automatically record-enables Track 1 in a new document.

Now let’s set a port to the record track:

1. Make sure the Instrument on the record-enabled track is a Port and that 
port is set up as the Record From device in the Setup menu’s MIDI 
Setup dialog box.

2. If the Instrument is not set to “Port,” click in the Instruments column, 
hold down the mouse to display a popup menu, and choose a Port on 
the appropriate device. If the Port is not set to the correct device, select 
Edit Port from the popup menu.

The Edit Track Output Port dialog box appears. 

3. Choose the correct device from the dialog box and click OK. For the 
purposes of this tutorial, do not select an audio device.

4. Adjust your MIDI device to send whatever Program Change (sound) 
that you want to record (be sure that Program Changes are enabled in 
the Record Criteria dialog under the Setup menu).

Enabling the Metronome Click
If you’d like to hear a Metronome click as you record:

• Click the Metronome icon in the lower right corner of the enlarged 
Transport window. 

 The Metronome icon becomes highlighted to indicate it is enabled. 

If you want to adjust the Metronome beat:

• Click the door in the Tempo icon to open the Tempo dialog box, then 
adjust the tempo to suit your needs.
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Now let’s move on to Setting the Record Mode: Replace or Overdub.

Setting the Record Mode: Replace or Overdub
To indicate Replace or Overdub Record modes for all types of recording 
operations:

1. Select the Record/Play under the Setup menu.

The Record and Play setup dialog box appears.

2. In the Record Mode field, choose Replace or Overdub and click OK.

Replace replaces previously recorded data on a track with newly recorded 
data; Overdub records on top of existing data, merging old and new data on 
the same track. In the future, you may want to experiment recording in 
Overdub mode (which is good for drum machine-style recording).

You can also specify Replace or Overdub Record modes by clicking the 
door on the Punch setting icon within the Transport window. 

Now let’s move to the next step in our tutorial, Beginning Recording.

Beginning Recording
To begin recording:

1. Click the Record button in the Transport window, or press Option-R.

If you followed the previous steps in the tutorial, Your First Session with 
METRO, you set a Countoff of 1 bar (Record/Play under the Setup 
menu). You’ll see the Counter move forward through 1 bar, which gives 
you time to ready yourself to record. 

2. Play your controller keyboard or MIDI device.

3. Stop recording by clicking the Stop button in the Transport or pressing 
the Spacebar. 

METRO records what you just played. The Tracks window Overview 
changes to show that your new track contains data. Proceed on to Naming 
Your Track.

Tempo Icon Door Metronome Icon Door



4-4

Naming Your Track
You’ll notice the Tracks window displays the number of bars you recorded 
and the new track is now called “Untitled”. You can now name that track 
whatever you like.

To name your track:

1. Option-click the “Untitled” Track Name and type a name for the track.

2. Press Return.

Now let’s take a look at the data we recorded by Viewing Note Data.

Viewing Note Data
Open the Graphic Editor window by double-clicking the new track name you 
just entered. Notice the Graphic Editor window for Track 1 now displays the 
note data you recorded. Notice some of the other attributes of the Graphic 
editor window:

• MIDI Notes are displayed graphically as black bars (or in color 
according to Channel or Selection, if you have a color monitor), and 
their duration is shown by the length of the bar. 

• When the Graphic Editor window is in Notes display, the Audible 
Keyboard to the left of the piano roll lets you quickly see the note’s 
pitch. When you click a key on the Audible Keyboard, METRO plays that 
note on the track’s currently assigned Instrument.

• If you position the cursor over the Audible Keyboard or over a particular 
note, you’ll see that, in the upper left of the window, the Current Cursor 
Position display shows the selected note’s pitch as well as the Bar/Beat/
Clock location of the cursor. 

Now let’s try Playing Back the Track.

Playing Back the Track
To play back the track:

Data in Tracks Window Overview
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1. In the Transport window, click the Return button, or press the Return 
key, to move the Counter back to Bar 1

2. Click the Play button, or press the Spacebar to initiate playback. 

3. If you want to stop playback before the end of the track, either click 
Stop, or press the Spacebar. 

You won’t always want to play the track from the beginning, so let’s try 
Playing From a Selection or Bar Number.

Playing From a Selection or Bar Number
You can begin playback at any particular section of your file by either 
selecting an insertion point in the Graphic Editor window, or by changing the 
Bar number field of the Counter in the Transport window.

To play back from a selection or bar number:

Do one of the following:

• Click the Arrow Tool in the Graphic Editor window then click in the 
Graphic Editor s piano roll (when in Notes display) at the point where 
you want playback to begin. This creates an insertion point.

• Click the Bar field in the Transport window and change it to the location 
where you want playback to begin. 

Click Play or press the Spacebar to continue playback from the selected 
location. 

Adjusting Note Velocity
Within the Graphic Editor’s Notes display (piano roll), you can view graphic 
representations of individual note velocities by checking Velocity Stems in 
the Switches menu.

MIDI notes within the Notes display show a “velocity stem” rising from them; 
the length of the “stem” rising from each note indicates the velocity level of 
that note. 



4-6

To edit velocity using velocity stems:

1. Click the Velocity Tool icon in the top portion of the Graphic Editor 
window (it’s just to the right of the Forceps Tool icon).

The cursor becomes a tweezers. 

2. Click and drag Note Velocity Stems up or down to raise or lower 
individual note velocity. You can also scale the velocities across a 
selected range of notes—using the Velocity Tool on a single note will in 
turn scale the velocities of all other notes within the selection.

To turn off Velocity Stems in the Graphic Editor window, select Velocity 
Stems in the Switches menu so that the checkmark is removed.

You can also use the Average Velocity display of the Graphic Editor window 
to view the velocity of notes in a track. Click and hold the mouse on the 
track’s Data Type pop-up menu and select Average Velocity, or press the V 
key within the Graphic Editor, and the current track will switch to show note 
velocities. The track view displays on an x/y graph for the average velocity of 
each note in the selected track. If there is only one note at a given time, the 
“y” direction represents the exact velocity. In this display, you can “draw in” 
velocity curves, crescendos, decrescendos, and so on with relative ease 
(you can even do this in real time during playback for instant feedback). 
When in the Graphic Editor’s Average Velocity display, use the Curve Tools 
to the left of the Magnifying Tools to create ultra-smooth velocity transitions. 

Saving Your Recording as a METRO File
Before continuing, save your recording as a METRO document file. Later in 
this tutorial, you’ll record more tracks to form a Section, and then record 
more Sections to save within your METRO document file. It’s always a good 

Velocity Tool
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idea to save your work as often as possible; unforeseen problems can cause 
file loss or damage. It is a good idea to save your work to floppy disks at 
least once a day so that you have a backup of your work.

To save your recording as a METRO file:

1. Choose Save or Save As from the Edit menu.

2. Type a name for your METRO file, then click OK to save it to a drive or 
diskette.

METRO saves your file under the name you designate. 

Enlarging the Transport Window
If you haven’t done so yet, enlarge the Transport window so you can gain 
access to more features:

1. Click the Zoom box in the upper right of the Transport window.

The Transport window enlarges so you can see more of its features.

Let’s explore another playback option by Playing Cues.

Playing and Setting Cues
The “current cue” is a specific range of music that plays when you click the 
Cue button in the Transport window or press the C key. You determine the 
current cue by your most recent action—whatever range of music you most 
recently played or selected becomes the current cue. Selecting or playing a 
new range erases the old cue and creates a new, current cue. You can save 
a cue into four different locations, which you set up and are not dependent 
on the most recent action. These cues remain as you set them unless you 
overwrite them by setting a new cue. You can set 4 different cues.

To select and play the current cue:

1. Click the Arrow Tool icon in the Graphic Editor window to turn the cursor 
into the Arrow Selection Tool.

2. Drag in the Graphic Editor window’s Notes display (or within other Data 
Type display modes) across the desired range.

3. Play the cue by clicking the Cue button in the Transport window or by 
pressing the C key.

If you play back or select a different range, that range becomes the current 
cue.

To set a cue:

1. Select a region by dragging across a range in the Graphic Editor 
window’s Notes display (or within other Data Type display modes of the 
Graphic Editor).
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2. Click the Set button in the Transport window.

3. Click one of the four numbered Cue buttons. 

METRO saves the current cue in the location (1 through 4) that you choose.   

To playback stored cues:

• Click the numbered button (under the Set button in the Transport 
window) associated with the desired range, then click the Cue button. 

 

The next step in our tutorial is Looping Playback of Your Track.

Looping Playback of Your Track
Looping playback means that METRO automatically rewinds and plays the 
entire MIDI track you just recorded. Playback continues infinitely, as long as 
the longest track (the one with the highest bar count) is looped.

To loop playback:

1. Click the Loop column in the Tracks window on the track you recorded.

Notice a Loop icon appears to indicate track looping is enabled. 

You can disable track looping at any time by clicking the Loop icon again to 
remove it.   

Now let’s try Looping Playback of an Area Within Your Track.

Looping Playback of an Area Within Your Track
In addition to looping an entire MIDI track, you can specify a range 
anywhere within a MIDI track to loop play as many times as you want, or to 
virtually play forever (or at least for many hours).

METRO’s loop playback feature is a powerful compositional tool that allows 
you to build increasingly complex patterns without actually increasing the 
amount of data contained in a track. 

You can specify the range you want to loop by graphically selecting it within 
any of the Graphic Editor window’s display types (Notes, Drums, Controllers, 

Cue Button                    Set Cues Button     Numbered Cue Buttons
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After Touch, etc.), or by typing the beginning and ending locations directly 
into the Looping dialog box (Special menu). If you select the range 
graphically, METRO automatically enters the beginning and ending 
locations into the Looping Options dialog box.

To loop playback of an area within your track:

1. Click the Arrow Tool in the Graphic Editor window.

2. Drag across the desired range to select it, then release the mouse.

3. Choose Looping from the Special menu.

The Looping Options dialog box appears. Notice that the beginning and 
ending locations of your selection are entered in the From and To fields 
in the Looping Options dialog box. 

4. If you want the range to loop a specific number of times, click the Loop 
“N” Times button and enter the desired value.

5. If you want the range to loop virtually infinitely, click the For Many Hours 
button.

6. Click OK.

Notice that Loop icons now appear within the Graphic Editor window at the 
specified begin and end locations. In the Graphic Editor window you’ll see a 
number next to the Loop End icon, which is the number of times you 
specified the range to loop. Once playback of the loop begins, you’ll see a 
number next to the Loop Begin icon that designates the cycle number of the 
loop currently playing. 

If you play looped and unlooped tracks at the same time, when the looped 
track finishes the looped section, it skips over enough of the following 
measures to catch up to the unlooped track.

In the Tracks window you’ll see one of two Loop icons in the Loop column, 
indicating the track is loop enabled. A Loop icon with a single arrow 
designates that the entire track is looped (from beginning to end); a Loop 
icon with two arrows designates that a range within that track is looped.

Loop ranges within tracks do not support Audio Tracks.

Looping Cues
Looping Cues is an extremely powerful way to edit data on-the-fly. You play 
the current Cue by simply clicking the Cue button in the Transport or 
pressing the C key.

Perhaps the quickest way to loop cues for editing purposes is to:

1. Select a range in your track that you’re not satisfied with, causing that 
range to become the Current Cue. 
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2. Enable Cue looping by checking the Cue Loop checkbox in the 
Transport (under the Loop Record checkbox).

3. Press the C key or click the Cue button in the Transport to start 
playback of the looped Cue.

4. Listen to the Cue loop play and edit the MIDI data to your satisfaction. 

For example, click directly on individual notes or Drum Strikes within the 
Graphic Editor’s Notes (piano roll) or Drums display and drag them to the 
left or right to alter the start time; drag them upward to alter the pitch, or 
Shift-click them and drag them to the right to alter duration. Option-click and 
then drag a note or Drum Strike, or a entire range of data, to create a copy, 
or Command-click on events to select them noncontiguously.

Auditioning Programs
You can experiment with different programs and sounds using the Program 
setting in the Instruments window. Using the Program setting is a temporary 
way to audition various programs on your MIDI devices—keep in mind that 
the Program setting is for playback purposes only. In order for a track to 
always play the same program or sound, a Program Change event must be 
contained in the track. In this section you’ll simply audition Program 
Changes (not encode them into tracks). 

To audition programs:

1. Press the Return key to move the Counter back to Bar 1, then press the 
Spacebar to play your file.

2. Open the instruments window (Command-I) and click the Program field 
(Pgm) of an Instrument Panel within the Instruments window.

The Program setting will be a popup menu if you have a Program Name 
List assigned to the track’s corresponding port and channel (see 
Program Names).

3. Increase or decrease the Pgm# value to change programs (click on the 
program number and drag the mouse up or down, or type in a new 
program number to change its value).

4. Release the mouse to listen to each program that you want to audition. 

If you own either MOTU’s Unisyn™ version1.0 or Opcode’s Galaxy™, 
METRO can automatically display programs by name rather than by number 
To enable this feature, choose either Subscribe to Galaxy™ or Subscribe to 
Unisyn™ under the Program Names dialog in the Setup menu. Metro also 
supports Cakewalk instrument files for program names.

After you try different programs, try different tempos by Adjusting Current 
Playback Tempo. 
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Adjusting Current Playback Tempo
You can try playing your Section at different tempos by temporarily adjusting 
the tempo during playback using METRO’s Tempo setting. METRO sets the 
initial tempo of each Section to 120 BPM. The Tempo display is in the lower 
left corner of the Transport window.

To adjust tempo during playback, do one of the following:

1. In the Transport window (Command-B), click the Tempo setting’s left or 
right arrows to decrease or increase the tempo by 1/10th of a beat per 
minute, or hold the mouse button down for larger changes.

2. Also in the Transport window, drag the slider below the Tempo setting 
either left or right. 

In addition to adjusting the current playback tempo, you can set a Section to 
always play a particular tempo by placing a Tempo event in the Section. 
METRO automatically places a Tempo event at a default tempo of 120 at the 
beginning of each new Section. This tempo is displayed in the Transport in 
the Tempo setting (Tempo = 120). 

To change initial default tempo of the current Section and any new Sections 
you create:

1. Click the door on the Tempo setting to open the Tempo dialog box. 

2. Within the Tempo dialog box, enter a new initial tempo display and click 
OK. 

The default initial tempo setting affects the current Section and any new 
Sections you subsequently create. You can easily view all Tempo, Time 
Signature, and Key Signature events within a Section in the Section Event 
Editor window (Windows menu).

Recording Another Track
Let’s record another MIDI track to accompany the first track you recorded:

1. Click the Record “R” column of the track you want to record, placing a 
selector dot in that column.

2. Option-click the track Name field and type a name. When finished 
typing, press Return in order to exit from Track Name mode.

3. Click Record (Transport window), or press Option-R, and play your MIDI 
device.

The previously recorded track plays back as you record; if you’d rather 
mute the track and only listen to the one you’re recording, click the “M” 
(Mute) column next to the previously recorded track’s name, placing a 
selector dot there. To unmute a track, click the dot again to remove it.

4. Click Stop or press Spacebar when you’re finished recording.
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5. Repeat steps 1-4 to record more tracks. You can record up to 99 tracks 
per Section.

Displaying Multiple Tracks in the Graphic Editor 
Window
To display a track in the Graphic Editor window, do one of the following:

• In the Tracks window, click a track’s Number, Name, or Bar field.

Whatever track is selected in the Graphic Editor window changes to 
display the track you clicked. 

• Within the Graphic Editor window, click the track name in the titlebar of 
any displayed track and select new or existing tracks to display from the 
popup menu.

A track’s titlebar also displays other relevant controls and menus for that 
track, including Record, Mute, Solo, and Loop buttons, and the Track Name, 
Data Type and Instrument popup menus. New tracks will default to the name 
“Untitled”. Name tracks by Option-clicking on the Track Name popup menu 
(within the track’s titlebar), or by Option-clicking the corresponding track’s 
Name field in the Tracks window.

The Graphic Editor window can simultaneously display up to 16 tracks in a 
variety of graphical displays (Notes, Drums, Controllers, After Touch, Pitch 
Bend, etc.). 

To add tracks to the Graphic Editor window:

• Click the Add Tracks icon (the “+” symbol to the left of the Timeline) in 
the Graphic Editor window. 

Once you add a new track, you can change it to view data in any variety 

Graphic Editor Track Titlebar                   Data Type Display Menu
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of graphical displays by clicking the data display popup in the titlebar.

To close a track in the Graphic Editor window:

• Click the close box at the left end of the track’s titlebar.

To resize a track’s display in the Graphic Editor window:

• Click and drag the track’s Resize icon. It appears in the titlebar between 
the Close box and the Track Name popup menu when multiple tracks 
are displayed. 

Now that you can display multiple tracks in the Graphic Editor window. Let’s 
try Selecting Tracks in the Graphic Editor Window.

Selecting Tracks in the Graphic Editor Window
To select a track in the Graphic Editor window, click anywhere in its display.

To select multiple tracks in the Graphic Editor window, click anywhere within 
the display area and drag up or down to select multiple tracks. 

Naming the Current Section
To name the current Section:

1. Choose Sections from the Windows menu.

The Sections window appears. The name of your METRO document 
appears in the window’s titlebar. The name of the current Section is 
highlighted.

2. Double-click the name “Untitled,” which is highlighted.

3. Type a Section name in the name field that appears, and press Return.

You’ll see the Section name displayed in the Sections window and in the title 
bar of that Section’s Track window. You can edit the Section name in the 
same way you entered it. To make a Section the current Section, click its 
name in the Section window.

Before the last step of this tutorial, save all the recent changes you made by 
pressing Command-S.

Now let’s finish this tutorial by trying some On-The-Fly Recording.

On-The-Fly Recording
On-the-fly recording is useful if you are recording someone else and only 
want to record a small portion of their performance.

To record on-the-fly:

1. In the Transport window, click the Record button while Play is already 
engaged (pressing Option-R does not work for on-the-fly recording).
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METRO immediately switches to record mode and begins recording 
from that point in the track and onwards. 

2. Click Stop or press the Spacebar to stop recording.


