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Using Help

 

About online Help

 

Adobe Systems, Inc. provides complete documentation in the Adobe PDF Help system. 
The Help system includes information on all the tools, commands, and features for both 
Windows and Mac OS. The PDF format is designed for easy navigation online, and support 
for third-party screen readers compatible with Windows. The Help can also be printed as a 
desktop reference.

 

Navigating in Help

 

The Help will open in an Acrobat window with the bookmark pane open. If the bookmark 
pane is not open choose Window > Bookmarks. You can also navigate using the 
navigation bar, the index, or search the document.

At the top and bottom of each page is a navigation bar. Click Using Help to return to this 
introduction. Clicking Contents, or Index will take you to that section.

The Next Page  and the Previous Page  arrows let you move through the pages 
sequentially. Click Back to return to the last page you viewed. You can also use the 
navigation arrows in the Acrobat toolbar. 

 

Using bookmarks, the table of contents, the index, and Find

 

The contents of Help are shown as bookmarks in the bookmark pane. To view subtopics, 
click the plus sign next to a bookmark. Each bookmark is a hyperlink to the associated 
section of the Help document. 

To go to the information, click its bookmark. As the information is displayed in the 
document pane, its bookmark is highlighted.

You can turn highlighting on or off by selecting the Highlight Current Bookmark option 
from the bookmark pane menu.

 

To find a topic using the table of contents:

1

 

Click Contents in the navigation bar at the top or bottom of any page.

 

2

 

Click a topic on the Contents page to move to the first page of that topic.

 

3

 

In the bookmark pane, expand the topic to see its subtopics.

 

To find a topic using the index:

1

 

Click Index in the navigation bar at the top or bottom of any page.

 

2

 

Click the appropriate letter at the top of the page.

You can also expand the Index bookmark, and click the letter in the bookmark pane.

 

3

 

Locate your entry, and click the page number link to view the information.

 

4

 

To view multiple entries, click Back to return to the same place in the index.
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To find a topic using the Find command:

1

 

Choose Edit > Find.

 

2

 

Enter a word or a phrase in the text box, and click OK.

Acrobat will search the document, starting from the current page, and display the first 
occurrence of the word or phrase you are searching for. 

 

3

 

To find the next occurrence, choose Edit > Find Again.

 

Printing the Help file

 

Although the Help has been optimized for on-screen viewing, you can print pages you 
select, or the entire file.

To print, choose Print from the File menu, or click the printer icon in the Acrobat toolbar.
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Looking at the Work Area

 

Using the tools

 

Some tools in the toolbox are for selecting, editing, and creating page elements. Other 
tools are for choosing type, shapes, lines, and gradients. You can change the overall layout 
of the toolbox to fit your preferred window and palette layout. By default, the toolbox 
appears as two vertical columns of tools. You can also set it up as a single vertical column 
or as one horizontal row. However, you can’t rearrange the positions of individual tools in 
the toolbox.

Select a tool from the default toolbox by clicking it. The toolbox also contains several 
hidden tools related to the visible tools. Hidden tools are indicated by arrows to the right 
of the tool icons. Select a hidden tool by clicking the current tool in the toolbox and then 
selecting the tool that you want.

To find complete procedures for using any tool, see the index.

 

To move the toolbox:

 

Drag the toolbox by the title bar.

 

To display the toolbox:

 

Choose Window > Tools.

 

To select a tool:

 

Click its icon in the toolbox.

 

To display and select hidden tools:

1

 

Position the pointer over a tool in the toolbox that has hidden tools underneath it and 
hold down the mouse button. (Tools that have hidden tools are identified by a triangle in 
the lower right corner.)

 

2

 

When the hidden tools appear, select a tool. 

 

Hidden tools panel

 

All tool shortcuts are listed on the Adobe InDesign Quick Reference Card and tool tips.
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To change the toolbox layout:

1

 

Choose Edit > Preferences > General (Windows or Mac OS 9) or InDesign > Preferences 
> General (Mac OS 10.1).

 

2

 

In the Tools Palette menu in the General Options section, do any of the following, and 
then click OK:

 

•

 

To display the toolbox as one narrow vertical column, choose Single Column.

 

•

 

To display the toolbox as two columns with a large fill box and a stroke box, choose 
Double Column (default).

 

•

 

To display the toolbox as one narrow horizontal row, choose Single Row.

You can quickly cycle through toolbox display options by double-clicking the title bar 
(Windows) or clicking the zoom box (Mac OS) in the upper right corner of the toolbox.

 

Using palettes

 

Most Adobe products include a number of palettes to help you monitor and modify your 
work. By default, these palettes appear stacked together in several groups. You can display 
and hide these palettes as you work.

When combined in one group, the InDesign Transform, Character, and Paragraph palettes 
work dynamically with one another. For example, when the type tool  is selected and an 
insertion point is active, the Character or Paragraph palette is active (depending on which 
one was last used); when any other tool is selected, the Transform palette is active.

 

To show one palette:

 

Choose the palette name in the Window menu. For example, choose Window > Stroke to 
display the Stroke palette. (A check mark indicates that the palette is active.)

 

Note:

 

 If the palette is already open, choosing its name in the menu brings the palette to 
the front of its group. 

 

To hide one palette or a palette group:

 

Do one of the following:

 

•

 

Click the close button in the upper right (Windows) or upper left (Mac OS) corner 
of the palette.

 

•

 

Choose the palette name in the Window menu.

 

To show or hide all palettes:

 

Make sure that you have no text-insertion point (that is, no flashing vertical line) in text or 
in a palette text box, and press Tab. 

 

To show or hide all palettes except the toolbox: 

 

Make sure that you have no text-insertion point in a text frame or palette text field, and 
press Shift+Tab.

 

I

 

f you have more than one monitor connected to your system and your operating 
system supports a multiple-monitor desktop, you can drag palettes to any monitor.
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Changing the palette display

 

You can rearrange your palettes to customize your work area by using the following 
techniques:

 

•

 

To bring a palette to the front of its group, click the palette’s tab, choose the palette 
name in the Window menu, or press the palette’s keyboard shortcut.

 

•

 

To move an entire palette group, drag its title bar.

 

•

 

To rearrange or separate palettes in a group, drag a palette’s tab. Dragging a palette out 
of an existing group creates a new palette.

 

Click palette tab and drag palette to new location (top); palettes are then separated (bottom)

 

•

 

To move a palette to another group, drag the palette’s tab to that group.

 

•

 

To display a palette menu, position the pointer on the triangle in the upper right corner 
of the palette and hold down the mouse button.

 

Note:

 

 Not all palettes have a palette menu.

 

Palette menu

 

•

 

To change the size of a palette, drag any of its corners (Windows) or the lower right 
corner (Mac OS).

 

Note:

 

 Resizing one palette does not resize all palettes in that group. Also, not all palettes 
can be resized.

 

•

 

(Windows only) To collapse a group to the palette titles only, click the Minimize/
Maximize box. Click the box again to restore the palette display. 

 

•

 

(Mac OS only) To collapse the palette to the title bar only, click the zoom box in the 
upper right corner of the palette.
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•

 

To alternate between an abbreviated (limited options visible) and normal version of 
a palette, choose Show/Hide Options in the palette menu (this is not available for all 
palettes).

To cycle quickly through collapsed, abbreviated, and normal views, double-click the 
palette tab. In Windows, you can also double-click the title bar to cycle through just 

the collapsed and normal views.

 

•

 

With palettes that expand and collapse, click the arrows  to the left of the palette 
name to cycle through expanded, normal, and collapsed views.

 

Docking palettes

 

Dock palettes by connecting the lower edge of one palette to the top edge of another, 
so that both palettes move together and are shown and hidden together. When you dock 
palettes, both palettes remain fully visible. In contrast, when you group palettes, only the 
frontmost palette is visible.

You can dock one palette to another single palette or to a group of palettes. However, you 
can’t dock a group of palettes unless you dock each of them individually, because docking 
involves dragging an individual palette’s tab and not the title bar.

 

To dock palettes:

 

Drag a palette’s tab to the lower edge of another palette. When the lower edge of the 
other palette is highlighted, release the mouse button.

 

To move a set of docked palettes:

 

Drag its title bar.

 

Compacting list palettes

 

You can save space by compacting rows in palettes that display lists, such as the Layers 
and Swatches palettes.

 

To compact a list palette:

 

Choose Small Palette Rows in the palette menu.

 

Calculating values in palettes and dialog boxes

 

You can perform simple math in any numerical text box. For example, if you want to move 
a selected object 3 units to the right using the current measurement units, you don’t 
have to work out the new horizontal position—simply type 

 

+3

 

 after the current value in 
the Transform palette.

 

To enter values by calculating:

1

 

In a text box that accepts numerical values, do one of the following:

 

•

 

To replace the entire current value with a mathematical expression, select the entire 
current value.

 

•

 

To use the current value as part of a mathematical expression, click before or after the 
current value.

 

2

 

Type a simple mathematical expression. You can use 

 

+

 

 (plus), 

 

-

 

 (minus), 

 

*

 

 (multipli-
cation), 

 

/

 

 (division), or % (percent) signs among the values you type.
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3

 

To make the calculation, use the mouse or keyboard to change 

 

focus

 

 to another option 
or press Shift+Enter (Windows) or Shift+Return (Mac OS) to keep the focus in the current 
option. (Focus refers to the part of the application, such as a palette option or selected 
object, that is affected when you type on the keyboard. For example, a blinking text cursor 
in a text frame indicates that focus is on the text frame. Any text you type affects that 
text frame).

 

Note:

 

 If an error occurs, make sure that the expression is mathematically valid and that 
only one operation is entered at a time. Use only the mathematical symbols noted in 
step 2.

 

About measurement units and increments in palettes and dialog 
boxes

 

Palettes and dialog boxes use the measurement units and increments defined in the Edit > 
Preferences > Units & Increments (Windows and Mac OS 9) or InDesign > Preferences > 
Units & Increments (Mac OS 10.1) dialog box. However, you can specify values using any of 
the supported measurement units at any time by temporarily overriding the current 
preference settings. For more information, see “Setting up measurement units and rulers” 
on page 34.

 

Tips for working with palettes 

 

Knowing a few techniques for changing and applying settings can help you work faster. By 
using special keystrokes, you can activate a palette, specify the option that has focus, and 
change that option’s value. 

 

To activate one palette using the keyboard:

 

Press the keyboard shortcut. See the 

 

Adobe InDesign Quick Reference Card

 

 or the shortcut 
editor for a listing of all palette shortcuts.

 

To specify focus after changing a palette setting:

1

 

Change a setting in a palette by typing a value. Simply choosing a setting from a palette 
menu does not specify focus.

 

2

 

Do one of the following:

 

•

 

Use the mouse to move the focus to another option or object.

 

•

 

Press Tab or Shift+Tab to apply the new value and move the focus to the next or 
previous option. If a palette option is not in focus (selected), pressing Tab hides all open 
palettes instead of moving the focus to the next option.

 

•

 

Press Shift+Enter (Windows) or Shift+Return (Mac OS) to apply the new value and keep 
the focus on the palette option.

 

•

 

Press Enter (Windows) or Return (Mac OS) to apply the new value and shift focus to your 
page layout.

 

•

 

Press Esc to shift focus back to your page layout.

 

To change numeric values in palettes:

 

Do any of the following:

 

•

 

Choose a value in the pop-up menu (if one is present).
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•

 

Click an insertion point in the value and press the Up or Down Arrow key to increase 
or decrease the value. Press Shift as you use the Up or Down Arrow key to change the 
value in greater increments. The degree to which Shift incrementally increases a value 
depends on the individual option.

 

•

 

Select an existing value by clicking the icon or label next to it or by double-clicking the 
value itself. Then type another value. 

 

Note:

 

 When you make changes using the arrow buttons, arrow keys, or pop-up menus, 
InDesign applies the change immediately.

 

To select an item in a palette list:

 

Choose from the following options:

 

•

 

Click an item to select it.

 

•

 

Shift-click to select a range of items.

 

•

 

Ctrl-click (Windows) or Command-click (Mac OS) to select a nonconsecutive range 
of items.

 

•

 

Press Ctrl+Alt (Windows) or Command+Option (Mac OS) as you click in the palette. When 
a dark outline appears around the list to indicate that the list has focus, type the first few 
characters of the name of the listed item.

 

Customizing keyboard shortcuts

 

InDesign provides a vast array of shortcuts to help you quickly maneuver through and 
alter a document without using the mouse. You can use the default InDesign shortcut set 
or the QuarkXPress

 

®

 

 4.0 shortcut set, or create your own shortcut set. The 

 

Adobe InDesign 
Quick Reference Card

 

 lists the most commonly used default shortcuts, and tool tips provide 
an instantaneous reference for shortcuts. You can share shortcut sets with others using 
InDesign on the same platform.

InDesign also provides a shortcut editor in which you can view and generate a list of all 
shortcuts, and edit or create your own shortcuts. This editor includes all the commands 
that accept shortcuts but are undefined in the Default shortcut set. Using this editor, you 
can create shortcuts that suit your own workflow. For example, you can create a shortcut 
that activates a specific font, font style, or font size.

 

To change the active shortcut set:

1

 

Choose Edit > Keyboard Shortcuts.

 

2

 

Select a shortcut set in the Set menu. For example, select Shortcuts for QuarkXPress 4.0.

 

3

 

Click OK.

 

To view shortcuts:

1

 

Choose Edit > Keyboard Shortcuts.

 

2

 

For Set, select a shortcut set.

 

3

 

For Product Area, select the area containing the commands you want to view.

 

4

 

From Commands, select a command. The shortcut is displayed in the Current Shortcut 
section.
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To generate a list of shortcuts:

1

 

Choose Edit > Keyboard Shortcuts.

 

2

 

For Set, select a shortcut set.

 

3

 

Click Show Set. A text file containing all current and undefined shortcuts for that set 
will open.

 

To create a new shortcut set:

1

 

Choose Edit > Keyboard Shortcuts.

 

2

 

Click New Set.

 

3

 

Type a name for the new set and select a shortcut set in the Based On menu. Then 
click OK.

 

To create or redefine a shortcut:

1

 

Choose Edit > Keyboard Shortcuts.

 

2

 

For Set, select a shortcut set or click New Set to create a new shortcut set.

 

Note:

 

 You cannot edit the Default or QuarkXPress shortcut sets. However, you can create 
a new set based on one of these sets, and then edit the new set.

 

3

 

For Product Area, select the area containing the command you want to define or 
redefine.

 

4

 

In the Commands list, select the command that you want to define or redefine.

 

5

 

In the New Shortcut box, press the keys for your new keyboard shortcut. If the key 
sequence is currently being used for another command, InDesign displays that command 
under Current Shortcuts. You can choose to change the original shortcut also, or try 
another shortcut.

 

Note:

 

 Do not assign single-key shortcuts to menu commands because they interfere 
with the typing of text. If an insertion point is active when you type a single-key shortcut, 
InDesign inserts the character in the text instead of carrying out the command.

 

6

 

In the Context list, select the context in which you want the keyboard shortcut to 
function. The context ensures that the shortcut performs the way you intended. For 
example, you can assign Ctrl+G to group two cells together (Table context) and Ctrl+G 
to insert special characters (Text context).

 

7

 

Do one of the following:

 

•

 

Click Assign to create a new shortcut where none currently exists.

 

•

 

Click Assign to add another shortcut to a command other than a menu command. If you 
like, you can remove the previous shortcut after assigning the new one.

 

8 Click OK to close the dialog box, or click Save to keep the dialog box open while you 
enter more shortcuts.

Using context menus
Unlike the menus that appear at the top of your screen, context-sensitive menus display 
commands related to the active tool or selection. You can use context menus as a quick 
way to choose commonly used commands.
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To display context menus:

1 Position the pointer over the document or an object in the document.

2 Click the right mouse button (Windows) or press the Control key as you hold down the 
mouse button (Mac OS).

Opening and closing documents
In general, you open and close document and template files the same way you do in other 
programs. When you open an InDesign template, it opens as a new, untitled document 
by default. In Windows, document files use the extension .indd, template files use the 
extension .indt, library files use the extension .indl, and book files use the extension .indb. 
For more information on creating books, see “Using object libraries” on page 246 and 
“Creating a book file” on page 167.

You can also use the File > Open command to open files from Adobe PageMaker® 6.5 
and later and QuarkXPress 3.3 or later; see “Opening PageMaker and QuarkXPress files in 
InDesign” on page 12. In addition, other software vendors may make plug-in software that 
lets you open other file formats. 

To open one or more InDesign documents:

1 Choose File > Open and select one or more documents.

2 Do one of the following and click Open:

• Select Normal (Windows) or Open Normal (Mac OS) to open the original document or 
a copy of a template.

• Select Original (Windows) or Open Original (Mac OS) to open an original document or 
template.

• Select Copy (Windows) or Open Copy (Mac OS) to open a copy of a document or 
template.

3 If an alert message appears telling you that the publication contains missing or 
modified links, do one of the following:

• Click Fix Links to let InDesign locate the missing files or give you an opportunity to 
locate them.

• Click OK to defer fixing the links until later. You can then fix the links yourself at any time 
using the Links palette.

Note: For more information about working with linked files, see “Managing links and 
embedded graphics” on page 235.

4 If an alert message appears telling you that the publication contains missing fonts, do 
one of the following:

• Click OK. InDesign will automatically format the text with a substitute.

• Click Find Font to search for and list fonts used throughout your document.

For more information on finding missing fonts, see “Finding and changing fonts” on 
page 94.
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Choosing User Dictionary or Document when opening a 
document
When opening a document, you may see an alert message asking if you want to use the 
exception word list in the user dictionary or the one in the document. If you know which 
exception word list you use, click its button. If you’re not sure, click either button, choose 
Edit > Dictionary to inspect the word lists, and then, if necessary, choose Edit > Prefer-
ences > Dictionary (Windows or Mac OS 9) or InDesign > Preferences > Dictionary 
(Mac OS 10.1) to reset the word list used for composition. For more information about 
choosing from among multiple exception word lists, see “Working with hyphenation and 
spelling dictionaries” on page 96.

Creating and opening document templates
Templates are useful starting points for standard documents, because you can preset 
them with layout, graphics, and text. For example, if you prepare a monthly magazine, 
you can create a template that contains the layout of a typical issue, including ruler 
guides, grids, master pages, placeholder frames, layers, and any standard graphics or text. 
That way you can simply open the template each month and import new content.

You create a template the same way you create a regular document; the only difference 
occurs when you save the document. When you are preparing a template for others to 
use, it’s a good idea to add a layer containing instructions about the template; simply hide 
or delete the layer before printing the document. (See “Creating layers and specifying 
layer options” on page 68.)

To save a document as a template:

1 Choose File > Save As, and specify a location and filename.

2 Do one of the following, and click Save:

• (Windows) Choose InDesign 2.0 Template in the Save as Type menu.

• (Mac OS) Choose Stationery Option in the Format menu. Click Stationery, and click OK.

To start a new document from a template:

1 Choose File > Open.

2 Locate and select a template.

3 Select Normal (Windows) or Open Normal (Mac OS), and then click Open.

4 Save the new document with its own name.

To edit an existing template:

1 Choose File > Open.

2 Locate and select a template.

3 Select Original (Windows) or Open Original (Mac OS), and then click Open.

Opening PageMaker and QuarkXPress files in InDesign
InDesign can convert document and template files from Adobe PageMaker 6.5 or later 
and QuarkXPress 3.3 or later. Both types of files open in InDesign as untitled document 
files. See “Creating and opening document templates” on page 12. 

When you open a PageMaker or QuarkXPress file, InDesign converts the original file infor-
mation to native InDesign information. For example:
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• Text is converted to InDesign text frames.

• Styles are converted to existing InDesign styles.

• Text and graphics links are preserved and appear in the Links palette. Embedded 
graphics—those added to the original document using the Paste command—are not 
converted. For more information on embedded graphics, see “Managing links and 
embedded graphics” on page 235.

Note: InDesign does not support OLE or Quark XTensions®. Consequently, when you open 
files that contain OLE or Quark XTensions graphics, those graphics will not appear in 
the InDesign document. If your QuarkXPress document does not convert, check the 
original and remove any objects that were created by an XTension; then save, and try 
to convert again.

• Color profiles for PageMaker files are converted directly. Because QuarkXPress uses 
different color profiles, they are ignored in InDesign.

• Colors are converted exactly to InDesign colors, except in the following situations: 
PageMaker HLS colors are converted to RGB colors, and colors from the color library 
are converted based on their CMYK values; QuarkXPress 3.3 HSB colors are converted 
to RGB, and colors from the color library are converted based on their CMYK values; 
QuarkXPress 4.1 HSB and LAB colors are converted to RGB, and colors from the color 
library are converted based on their RGB values; QuarkXPress 4.1 colors from the color 
library are converted based on their CMYK values.

• All master pages and layers are converted to InDesign masters and layers. For infor-
mation on converting Adobe PageMaker layers, see the technical support documents 
on the Adobe Web site.

• All master-page objects, as well as QuarkXPress guides, are placed on the corre-
sponding InDesign master pages.

• PageMaker document guides are placed on the Default layer in InDesign.

• Grouped objects remain grouped except where nonprinting items are included in 
a group.

• All strokes and lines are converted to the line styles they most closely resemble.

For information about other conversion issues, check the support documents on the 
Adobe Web site.

To open a PageMaker or QuarkXPress document or template:

1 Make sure that the original application file is closed.

To ensure that all links are maintained, copy all linked files to the same PageMaker or 
QuarkXPress document folder.

2 In InDesign, choose File > Open.

3 In Windows, choose PageMaker 6.5-7.0, or QuarkXPress 3.3-4.1 or later in the Files of 
Type menu.

4 Select a file and click Open.

Note: If InDesign cannot convert a file or a specific part of a file, it displays a warning 
describing the reasons it cannot convert it and the results of the conversion. 
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5 If a warning dialog box appears, do one of the following:

• Click Save to save a copy of the warnings as a text file, and then open the file in 
InDesign.

• Click Close to close the dialog box and open the file in InDesign.

To save a PageMaker or QuarkXPress template as an InDesign template: 

1 Open the template in InDesign.

2 Choose File > Save As and specify a location and filename. 

3 Do one of the following, and then click Save:

• (Windows) Choose InDesign Template in the Save as Type menu.

• (Mac OS) Choose Stationery Option in the Format menu. Click Stationery, and click OK.

About converting InDesign 1.0 and 1.5 documents 
Use the File > Open command to convert InDesign 1.0 and 1.5 documents. Keep the 
following in mind:

• For best results, save the InDesign 2.0 document under a new name.

• If you used third-party plug-ins to create an InDesign 1.0 or 1.5 document, check with 
the manufacturer to make sure that they are installed correctly for and compatible with 
InDesign 2.0 before you convert the document. (See “Using plug-in modules” on 
page 28.

• InDesign 1.0 and 1.5 can’t open InDesign 2.0 documents.

• InDesign 2.0 can’t save documents in InDesign 1.0 or 1.5 format.

• When you convert a document, you may see an alert message asking if you want to use 
the exception word list in the user dictionary or the one in the document. For infor-
mation about this alert message, see “Choosing User Dictionary or Document when 
opening a document” on page 12.

• Libraries created in InDesign 1.0 or 1.5 must be converted, using the Asset Library 
Converter, prior to opening in InDesign 2.0. (See “Converting InDesign 1.0 and 1.5 
library files” on page 249.)

Changing the view
Adobe Photoshop, Illustrator, PageMaker, and InDesign include a number of common 
tools, settings, and commands—including the hand tool, the zoom tool, the Zoom In and 
Zoom Out commands, and the Navigator palette—to let you view different parts of a 
spread at various magnifications.

Magnifying and reducing the view
The zoom tool and Zoom In and Zoom Out commands magnify or reduce the display of 
any area in your document window. The lower left corner of the document window 
displays the zoom percentage at all times.
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To zoom in:

Do one of the following:

• Select the zoom tool  and click the area you want to magnify. Each click magnifies the 
view to the next preset percentage, centering the display around the point you click. At 
maximum magnification, the center of the zoom tool appears blank.

• Activate the window you want to view and choose View > Zoom In to magnify to the 
next preset percentage.

• Type or choose a magnification level in the Zoom text box at the lower left corner of the 
document window.

To zoom out:

Do one of the following:

• Select the zoom tool . Hold down Alt (Windows) or Option (Mac OS) to activate the 
Zoom Out tool, and click the area you want to reduce. Each click reduces the view to 
the previous preset percentage.

• Activate the window you want to view, and choose View > Zoom Out to reduce the 
view to the previous preset percentage.

• Type or choose a reduction level in the Zoom text box at the lower left corner of the 
document window.

To magnify by dragging:

1 Select the zoom tool.

2 Drag to create a dotted rectangle, called a marquee, around the area you want to 
magnify.

To activate the Zoom In tool while using another tool, press Ctrl+spacebar (Windows) 
or Command+Ctrl+spacebar (Mac OS). To activate the Zoom Out tool while using 

another tool, press Ctrl+Alt+spacebar (Windows) or Command+ Option+Ctrl+spacebar 
(Mac OS).

To display the document at 100%:

Do one of the following:

• Double-click the zoom tool.

• Choose View > Actual Size.

• Type or choose a magnification level of 100 in the Zoom text box at the lower left 
corner of the document window.

To fit the page, spread, or pasteboard within the active window:

Do one of the following:

• Choose View > Fit Page in Window.

• Choose View > Fit Spread in Window.

• Choose View > Entire Pasteboard.

To switch between your last two zoom levels:

Press Ctrl+Alt+2 (Windows) or Command+ Option+2 (Mac OS).
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For a complete list of keyboard shortcuts for changing the active view, see the Adobe 
InDesign Quick Reference Card.

Using the Navigator palette
The Navigator palette contains a thumbnail of the selected spread, so that you can quickly 
change the view of a document.

A. Thumbnail B. View box C. Zoom text box  
D. Zoom out button E. Zoom slider F. Zoom in button

To display the Navigator palette:

Choose Window > Navigator.

To alternate between viewing one or all open spreads:

Choose View Active Spread/All Spreads in the Navigator palette menu.

If you decide to view all spreads, viewing may be easier if you resize the Navigator 
palette to make it tall and narrow.

To magnify or reduce the view using the Navigator palette:

Do one of the following:

• Click the zoom in  or zoom out  button at the bottom of the Navigator palette.

• Drag the zoom slider at the bottom of the palette.

• In the Zoom text box, type the magnification or reduction percentage and press Enter 
(Windows) or Return (Mac OS).

To change the color of the Navigator palette view box:

1 Choose Palette Options in the Navigator palette menu.

2 Choose a color:

• To use a preset color, select one from the pop-up menu.

• To specify a different color, double-click the color box, and specify a color in the system 
color picker.

Scrolling the view
You can easily adjust the degree to which pages or objects are centered in the document 
window. These techniques are also useful for navigating between pages.

B

C

A

D E F
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To scroll the view:

Do one of the following:

• Select the hand tool  from the toolbox, and then click and drag in the document 
window.

• To use the hand tool temporarily, select any tool except the type tool, and press the 
spacebar as you drag in the document window. If the type tool is selected and the 
insertion point (blinking text cursor) is active, hold down Alt (Windows) or Option 
(Mac OS) as you drag.

• Select any tool, press Ctrl+spacebar (Windows) or Command+Ctrl+spacebar (Mac OS), 
and then release the Ctrl or Command key while still pressing the spacebar.

• In the Navigator palette, click the thumbnail or drag the view box that represents the 
visible area of the current spread.

• Click the horizontal or vertical scroll bars or drag the scroll box.

• Press Page Up or Page Down.

Turning pages
InDesign makes it easy to jump from page to page in a document. For example, just as 
most Web browsers provide Back and Forward buttons to navigate through pages you’ve 
visited, InDesign keeps track of the order in which you’ve viewed pages in a document. 
You can use the Go Back and Go Forward commands in the Layout menu to move through 
pages according to the order in which you viewed them during the current session.

Note: If the page you want to go to is the one you are currently viewing, or if it is not 
available, that specific page in the Layout menu command is dimmed.

To go to the next page:

Do one of the following:

• Click the next-page button  at the lower right of a document window.

• Choose Layout > Next Page.

To go to the previous page:

Do one of the following:

• Click the previous-page button  at the lower left of a document window.

• Choose Layout > Previous Page.

To go to the first page:

Do one of the following:

• Click the first-page button  at the lower left of a document window.

• Choose Layout > First Page.

To go to the last page:

Do one of the following:

• Click the last-page button  at the lower right of a document window.

• Choose Layout > Last Page.
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To go to the most recently visited page:

Choose Layout > Go Back.

To go to the next page:

Choose Layout > Go Forward. 

Note: These commands become unavailable when you reach the end of the sequence of 
pages you’ve viewed during a session.

To go to a specific page:

Do one of the following:

• Click the downward-facing arrow at the right of the page box, and then choose a page.

Choose a page from the page box to go to a specific page

• Click in the page box at the lower left of the document window. Type the page number 
or the master page name, and press Enter (Windows) or Return (Mac OS).

• If necessary, choose Window > Pages to see the Pages palette. Double-click a page icon 
to center that page in the document window, or double-click the page numbers to 
center a spread in the window. 

Double-click a page icon to center the page in the document window (left); double-click the page 
numbers to center the spread in the document window (right)

To go to a master page:

Do one of the following:

• Click in the page box at the lower left of the document window. Type the first few 
letters of the master page name, and press Enter (Windows) or Return (Mac OS).

• In the Pages palette, double-click a master page icon or double-click the page numbers 
below the icons.

For more information about master pages, see “Using masters” on page 57.

1

A A A
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Using additional windows
You can open additional windows for the same document or for other InDesign 
documents. With additional windows, you can do the following:

• Compare different spreads simultaneously, especially spreads that are not adjacent.

• Display different magnifications of the same page, so that you can work closely on 
details while watching how the changes affect the overall layout.

• Display a master page in one window, and pages based on it in other windows, to see 
how editing the master page affects various parts of your document.

When you reopen the document, only the last used window appears. 

To create a new window for the same document:

Choose Window > New Window.

To arrange windows automatically:

Do one of the following:

• Choose Window > Cascade to arrange all windows into a stack, with each window offset 
slightly.

• Choose Window > Tile to display all windows equally without overlapping.

To activate a window:

Do one of the following:

• Click the window title bar.

• Choose the name of the view in the Window menu. Multiple windows for a document 
are numbered in the order they were created.

To close all windows for the active document:

Press Shift+Ctrl+W (Windows) or Shift+Command+W (Mac OS).

To close all windows for all open documents:

Press Shift+Ctrl+Alt+W (Windows) or Shift+Command+Option+W (Mac OS).

Setting anti-aliasing
Anti-aliasing smooths the jagged edges of type and bitmap images by softening the color 
transition between edge pixels and background pixels. Since only the edge pixels change, 
no detail is lost.

To smooth edges around text and images:

1 Choose Edit > Preferences > Display Performance (Windows and Mac OS 9), or InDesign 
> Preferences > Display Performance (Mac OS 10.1).

2 Select Enable Anti-Aliasing, and then click OK.

Greeking type
When display capabilities are not sufficient to show text at a small size, InDesign greeks—
displays as a dimmed bar—type below a specified type size. Any type at or below the 
specified type size is replaced on-screen with non-letterforms that act as placeholders in 
the artwork.
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To set the greek type limit:

1 Choose Edit > Preferences > Display Performance (Windows and Mac OS 9), or InDesign 
> Preferences > Display Performance (Mac OS 10.1).

2 For Greek Type Below, type a value, and then click OK.

Selecting objects
An object is any printable element on a document window or on the pasteboard, such as a 
path or an imported graphic. A frame or path is an object you draw that you can use as a 
line, a filled graphic, or a container for text or graphics; see “Laying out pages with frames” 
on page 63. Before you can modify an object, you must select it using a selection tool. 
Although text characters are also objects you can select individually, you use the text tool 
for them, not the tools described in this topic.

Two tools are available for selecting objects: the selection tool and the direct-selection 
tool. Switching between the two tools changes the appearance of the selection. By 
paying attention to the handles or points that appear on a path, you can instantly tell if 
a path is properly selected for the task you want to perform:

• Use the selection tool  for general layout tasks, such as positioning and sizing objects. 
When you select an object using this tool, the object displays a bounding box rectangle 
with eight handles. (See “Using the selection bounding box” on page 22.)

Unselected path (left) and path selected using the selection tool (right)

• Use the direct-selection tool  for tasks involving drawing and editing paths, frames, 
or frame contents, or moving anchor points on a path. When you select an object using 
this tool, it displays special handles called anchor points that make up the path. Anchor 
points are explained in “Parts of a path” on page 193.

Note: An imported graphic is always contained within a frame. It’s possible to select the graphic 
and its frame, the graphic only, or its frame only. To see how InDesign indicates what’s selected, 
see “Modifying objects using graphics frames” on page 256.

Path (left) and imported graphic (right) selected using the direct-selection tool

• With rectangular objects, it can be difficult to tell the difference between the object and 
its bounding box. A rectangular path always displays four small anchor points (which 
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can be hollow or solid and is displayed in the opposite color of its layer color; for 
example, if the layer color is blue, the path color is orange), while a bounding box 
always displays eight large hollow anchor points (displayed in its layer color).

Rectangular path selected with selection tool (left) and direct-selection tool (right)

• If the frame contains graphics or text, you can use the direct-selection tool or text tool 
to select the contents. The direct-selection tool automatically changes to the hand 
tool  when placed over the contents of the frame.

• Special techniques are available for selecting ruler guides, objects inside frames or 
groups, master objects on document pages, inline objects (that flow with text), and 
objects behind or in front of other overlapping objects in a stack. For more information, 
see the index.

To temporarily activate the last-used selection tool when using any other tool, hold 
down Ctrl (Windows) or Command (Mac OS).

Using the selection tool
The selection tool  is useful for general layout-oriented selection tasks such as moving or 
resizing objects. For more information, see “Arranging and Combining Objects” on 
page 256.

To select an object:

Using the selection tool, do one of the following:

• Click the object. If the object is an unfilled path, click its edge.

• Drag a dotted selection rectangle or marquee around part or all of the object.

You can also use the selection tools to select ruler guides. (See “Working with ruler 
guides” on page 41.)

To select or deselect multiple objects:

Do one of the following:

• Using the selection tool, drag a marquee over the objects you want to select. This is 
useful when you want to select all the objects in a rectangular area.

• Using the selection tool, select an object and then press Shift as you click additional 
objects. This is useful when the objects you want to select are not adjacent. Clicking 
selected objects deselects them.



Using Help | Contents | Index Back 22  

Adobe InDesign Help Looking at the Work Area 

Using Help | Contents | Index Back 22  

• With an object selected, press Shift as you use the selection tool to drag a marquee over 
other objects you want to select. Dragging over selected objects deselects them.

If you want to select specific objects nested inside groups or frames, use these same 
techniques, but with the direct-selection tool  instead.

Using the selection bounding box
For any selected object, you can activate its bounding box, a rectangle that represents the 
object’s horizontal and vertical dimensions. The bounding box makes it possible to quickly 
move, duplicate, and scale the object without having to use any other tool. For paths, the 
bounding box makes it easy to work with an entire object without accidentally altering 
the anchor points that determine its shape. When you select one or more objects with the 
selection tool, you see a bounding box that indicates the size of each object. If you don’t 
see a bounding box when an object is selected, you may have selected the object using 
the direct-selection tool.

Note: For more precise moving and scaling, and for other modifications such as rotation, 
use the transformation tools and the Transform palette. (See “Using the Transform palette” 
on page 271.)

To activate an object’s bounding box:

With an object selected, click the selection tool .

To deactivate an object’s bounding box:

With an object selected, click the direct-selection tool . The object remains selected.

You can use the selection tool keyboard shortcuts to activate or deactivate a 
bounding box quickly. Press the V key to activate the bounding box, or press A to 

deactivate. These shortcuts work only when a graphics object is selected.

Selecting all objects
You can use the Select All command to select all objects on a spread and its pasteboard. 
The current tool affects how objects are selected by the Select All command:

• If the selection tool  is active, paths and frames are selected with their bounding boxes 
active.

• If the direct-selection tool  is active, paths and frames are selected with their anchor 
points active.

• If any other tool is active, the last-used selection tool determines whether objects are 
selected with bounding boxes or anchor points active.

• If you used the type tool  to click an insertion point in a text frame (indicated by a 
flashing vertical line), choosing Edit > Select All selects all text in that text frame as well 
as all text in any text frames threaded to it, but selects no other objects.

The Select All command won’t select the following:

• Objects positioned on locked or hidden layers.

• Objects on spreads and pasteboards other than the target spread, except when you’ve 
selected threaded text using the type tool.

• Objects nested inside groups or frames. Only the parent object will be selected.

• Guides.
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To select all objects on a spread and its pasteboard:

With the selection tool or direct-selection tool active, choose Edit > Select All.

To deselect everything on a spread and its pasteboard:

Do one of the following:

• Choose Edit > Deselect All.

• With the selection tool or direct-selection tool, click at least 3 pixels away from 
any object.

Saving a document
Saving a document saves the current layout, references to source files, which page is 
currently displayed, and the zoom level. Protect your work by saving often. You can save 
a file as any of the following:

• A regular document.

• A copy of the document, which creates a duplicate of the document under a different 
name, leaving the original document active.

• A template, which normally opens as an untitled document. A template can contain 
settings, text, and graphics that you preset as a starting point for other documents. (See 
“Creating and opening document templates” on page 12.)

The Save, Save As, and Save a Copy commands store documents in the InDesign file 
format only. For information about storing documents in other file formats, see “Exporting 
text” on page 112.

To save a document:

Do any of the following:

• To save a document under a new name, choose File > Save As, specify a location and 
filename, and click Save. The newly named file becomes the active document.

Note: Using the Save As command may reduce the file size.

• To save an existing document under the same name, choose File > Save.

• To save all open documents to their existing locations and filenames, press 
Control+Alt+Shift+S (Windows) or Command+Option+Shift+S (Mac OS).

• To save a copy of a document under a new name, choose File > Save a Copy, specify a 
location and filename, and click Save. The saved copy does not become the active 
document.

 If you’re saving a document in order to bring it to a prepress service provider for final 
output, InDesign can automatically collect all necessary files, such as linked graphics 

and fonts, in one folder. (See “Packaging files for handoff” on page 408.)
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Recovering a document after a failure
InDesign guards your data against unexpected power or system failures using an 
automatic recovery feature. Automatically recovered data exists in a temporary file that is 
separate from the original document file on disk. Under normal circumstances you don’t 
need to think about automatically recovered data, because any document updates stored 
in the automatic recovery file are automatically added to the original document file 
when you choose the Save or Save As command or exit InDesign normally. Automatically 
recovered data is important only if you were not able to save successfully before an 
unexpected power or system failure. 

Nevertheless, you should save your files often and create backup files in case of 
unexpected power or system failures.

To recover automatically recovered data:

1 Restart your computer.

2 Start InDesign.

If automatically recovered data exists, InDesign automatically displays the recovered 
document. The word [Recovered] appears after the filename in the title bar of the 
document window to indicate that the document contains unsaved changes that were 
automatically recovered.

Note: If InDesign fails after attempting to open a document using automatically 
recovered changes, the automatically recovered data may be corrupted. 

3 Do one of the following:

• To save the recovered data, choose File > Save As, specify a location and a new filename, 
and click Save. The Save As command keeps the recovered version that includes the 
automatically recovered data; the word [Recovered] will disappear from the title bar. 

• To discard automatically recovered changes and use the most recent version of the 
document that was explicitly saved to disk before the unexpected power or system 
failure occurred, close the file without saving and open the file on disk, or choose 
File > Revert.

To change the location of recovered documents:

1 Choose Edit > Preferences > General (Windows or Mac OS 9) or InDesign > 
Preferences > General (Mac OS 10.1).

2 Under Temporary Folder, click Choose.

3 Specify the new location for the recovered document, click OK, and then click OK again.

Undoing mistakes
If you change your mind or make a mistake, you can cancel a lengthy operation before it 
completes, undo recent changes, or revert to a previously saved version. You can undo or 
redo up to several hundred of the most recent actions; however, the exact number may be 
limited by the amount of RAM available and the kinds of actions you have performed. The 
series of actions is discarded when you choose the Save As command, close a document, 
or when you exit the program.
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To correct mistakes:

Do one of the following:

• To undo the most recent change, choose Edit > Undo action. (You cannot undo certain 
actions, such as scrolling.)

• To redo an action you just undid, choose Edit > Redo action.

• To undo all changes made since the last time you saved the project, choose File > 
Revert.

• To stop a change that InDesign isn’t finished processing (for example, if you see a 
progress bar), press the Esc (Windows) or Command (Mac OS) key.

• To close a dialog box without applying changes, click Cancel.

Working with preferences and defaults
Numerous program preferences and default settings are stored in the Adobe InDesign 
preferences files, called InDesign Defaults and InDesign SavedData. Both of these defaults 
files are saved each time you exit InDesign. These preferences and default settings are 
stored in the Adobe InDesign 2.0 folder:

• In Windows, these files are located in Windows\Local Settings\Application 
Data\Adobe\InDesign\Version 2.0 (Windows 98) or WINNT\Profiles\[user name]\Local 
Settings\Application Data\Adobe\InDesign\Version 2.0.

• In Mac OS 9, the files are located in the System Folder\Preferences\Adobe 
InDesign\Version 2.0.

• In Mac OS 10.1, the files are located in Users\[user name]\Library\Preferences\Adobe 
InDesign\Version 2.0.

Changing preference settings specifies how InDesign documents and objects behave 
initially. Default settings are used for every new document or object you create. For 
example, you can specify the default font and other type specifications for all new 
documents or text frames.

Note: Installing plug-in software not included with InDesign may alter the default settings 
for palettes and other features. (See “Using plug-in modules” on page 28.)

Setting preferences
Preferences include settings such as palette positions, measurement options, and display 
options for graphics and typography.

To open the Preferences dialog box:

Choose the desired preference dialog box from the Edit > Preferences > submenu 
(Windows or Mac OS 9), or InDesign > Preferences > submenu (Mac OS 10.1).

For information on a specific preferences option, see the index.

To set general preferences:

1 Choose Edit > Preferences > General (Windows or Mac OS 9), or InDesign > Preferences 
> General (Mac OS 10.1).

2 In the Page Numbering section, choose a page numbering method in the View menu.
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3 In the General Options section, choose a display option in the Tool Tips menu. This 
changes the amount of time that Tool Tips are displayed.

4 In the General Options section, choose the layout option in the Tools Palette menu. 
This changes the layout appearance of the Tools Palette to single or double column, or 
single row.

5 In the Printing Options section, select or deselect Overprint Black. Selecting this option 
overprints all Black strokes, fills, and type characters of any size.

6 In the Temporary Folder section, specify a location where you want recovered 
documents stored.

7 In the Clipboard section, select or deselect Prefer PDF When Pasting. Selecting this 
option imports Adobe Illustrator files as PDF, which preserves the appearance of trans-
parency objects, blends, and patterns.

8 In the Clipboard section, select or deselect Copy PDF to Clipboard. Selecting this option 
creates a temporary PDF file using PDF style settings.

9 Click OK.

Setting defaults
If you change settings when no documents are open, your changes set the defaults for 
new documents. If a document is open when you change settings, the changes affect only 
that document.

Similarly, if you change settings when no objects are selected, your changes set the 
defaults for new objects.

To specify default settings for new documents:

1 Close all InDesign documents.

2 Change any menu items or palette or dialog box settings. 

If you use the same page size and language for most of your documents, you can 
change these defaults with no document open. For example, to change the default 

page size, close all documents, choose File > Document Setup, and select a desired page 
size. To set a default dictionary, close all documents, choose Edit > Preferences > 
Dictionary (Windows and Mac OS 9), or InDesign > Preferences > Dictionary (Mac OS 10.1), 
and select an option in the Language menu.

To specify default settings for new objects in a particular document:

1 With an InDesign document open, choose Edit > Deselect All.

2 Change any menu items, or palette or dialog box settings. 

To restore all preferences and default settings for Windows:

1 Choose Start > Search > For Files or Folders.

2 Select Tools > Folder Options.

3 Select the View tab in the Folder Options dialog box.

4 Select Show hidden files and folders in the Advanced Settings list, and click OK.

5 Locate the InDesign Version 2.0 folder.
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6 Select the InDesign Defaults file, and rename or delete it. Repeat this step for the 
InDesign Saved Data file.

To restore all preferences and default settings for Mac OS 9 and 10.1:

1 Locate the InDesign Version 2.0 folder. (See “Working with preferences and defaults” on 
page 25.)

2 Select the InDesign Defaults file, and rename or delete it. Repeat for the InDesign 
SavedData file.

Important: If you are using a multiple-user system, be sure you know where your prefer-
ences folder is located so that you do not delete another user’s file.

Note: A new InDesign Defaults file and InDesign SavedData file will be created the next 
time you start InDesign.

To reset all warning dialog boxes:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or InDesign > Prefer-
ences > General (Mac OS 10.1).

2 Click Reset All Warning Dialogs, and then click OK.

About InDesign styles
InDesign includes a number of ways in which you can store settings for later reuse, 
including the following:

• Creating paragraph and character styles. (See “Using styles” on page 146.)

• Creating PDF styles. (See “Using Adobe PDF export styles” on page 364.)

• Creating Printer styles. All the attributes in the Print dialog box are included in the style. 
(See “Using styles for printing” on page 388.)

• Creating Trapping styles. (See “Using the Trap Styles palette” on page 327.)

• Creating Flattener styles. (See “Controlling flattener settings and results using styles” on 
page 294.)

• Creating table of contents styles. (See “Saving table of contents styles” on page 179.)

In general, change the feature settings in the dialog box, and then save the settings. Styles 
are stored in the document in which they are created. However, when saving changes 
made to PDF, Printer, Trapping, and Flattener styles, the style changes become new default 
settings and are applied to future documents. Use the styles from another document by 
importing, or loading, the styles from that document. 

You can also share resources by using the Books feature. For more information, see 
“Synchronizing documents in a book file” on page 169.
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Using plug-in modules
The InDesign plug-in modules are software programs developed by Adobe Systems, and 
by other software developers working in conjunction with Adobe, to add features to 
Adobe software. A number of importing, exporting, automation, and special-effects plug-
ins come with your program and are automatically installed in the Plug-Ins folder. In fact, 
most of the features you see in InDesign are provided by plug-ins. Because many features 
are stored as individual plug-ins, you can easily upgrade or remove specific parts of the 
program just by replacing or removing plug-ins.

Once installed, plug-in modules appear as options on InDesign menus, in dialog boxes, or 
in palettes. 

You can use any commercial plug-in designed for use with InDesign. Adobe Technical 
Support can help you isolate problems related to plug-ins. However, if it has been deter-
mined that the problem is directly related to a plug-in created by another company, you 
will need to contact that company for further support. 

To install a plug-in:

1 If an installer is provided, use it to install the plug-in module. Otherwise, drag a copy of 
the module into the Plug-Ins folder inside the Adobe InDesign 2.0 folder.

2 Follow any installation instructions that come with the plug-in.

Configuring plug-ins
Use the Configure Plug-ins dialog box to inspect and customize the set of installed plug-
ins. For example, you can get detailed information about installed plug-ins, create custom 
plug-in sets for different tasks or workgroups, and isolate plug-ins when troubleshooting 
problems.

In the Configure Plug-ins dialog box, icons identify different kinds of plug-ins:

• Enabled plug-ins  were loaded when you started the current InDesign session, and 
will stay loaded until you exit InDesign.

• Adobe  plug-ins are provided by Adobe.

• Required  plug-ins must be present for InDesign to start.

Note: You can’t edit, rename, or delete the All Plug-ins, Adobe Plug-ins, or Required Plug-
ins sets. To change any of those sets, duplicate it, and then edit the duplicate.

To configure plug-ins:

1 Choose Help > Configure Plug-ins (Windows), choose Configure Plug-ins in the Apple 
menu (Mac OS), or choose InDesign > Configure Plug-ins (Mac OS 10.1).

2 Do any of the following, and then click OK:

• To change the active set of plug-ins, choose one in the Set menu.

• To disable or enable a plug-in, make sure that a custom set is active, and then click to 
hide or show the check mark at the far left of the plug-in listing.

Note: When you enable or disable plug-ins or choose a different plug-in set, the change 
doesn’t take effect until you exit and restart InDesign.
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• To change the plug-ins list display, select or deselect any option in the Display section. 
Changing options in this section affects the list display only, not the actual status of 
plug-ins.

• To create a new plug-in set from a duplicate of the active set, click Duplicate, name the 
set, and then click OK. The set you create becomes the active set.

• To rename the active set of plug-ins, click Rename, name the set, and then click OK.

• To permanently remove the active set, click Delete, and then click OK when an alert 
message appears.

• To import a file of plug-in sets, click Import, locate and select the file containing the sets 
you want to import, and then click OK. If the file you import contains a set that has the 
same name as an existing set, the imported set will be renamed as a copy. The first set 
in the file you import becomes the active set.

Note: (Windows only) When importing plug-in sets, if you select Plug-in Manager Import 
Files Family in the Files of Type menu in the Open a File dialog box, plug-in set files will 
appear only if the files are named with a filename extension .pset.

• To export all custom plug-in sets to one file, click Export, go to the folder in which you 
want to store the file, select Export All Sets, and then click Save. In Windows, plug-in 
sets are exported with the filename extension .pset.

• To see detailed information about a plug-in, select the plug-in and click Show Info. 
In addition to viewing such information as a plug-in’s version, you can find out if it 
depends on other plug-ins. When you’re finished, click OK to close the Plug-in Infor-
mation dialog box.

You can also view plug-in details by double-clicking a plug-in in the list.
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Setting Up Pages

Setting up basic layout options
Page design begins with the basics: starting a new document and setting up margins and 
columns.

Starting a new document
The New Document dialog box combines the Document Setup and Margins and Columns 
dialog boxes, so that you can set up the page size, margins, and page columns all in one 
place. Although you can change these settings at any time, you will minimize rework by 
determining your final page settings before you add objects to pages.

For information about starting a document based on a template, see “Creating and 
opening document templates” on page 12. For information on creating books, see 
“Creating a book file” on page 167.

To set default layout settings for all new documents, choose File > Document Setup or 
Layout > Margins and Columns, and set options when no documents are open.

To start a new document:

1 Choose File > New > Document.

2 In the Page Size section of the New Document dialog box, specify the following 
options:

Number of Pages Type a value for the total number of pages for this document.

Facing Pages Select this option to make left and right pages face each other in a double-
page spread. Deselect this option to let each page stand alone, such as when you plan to 
print on both sides of a sheet of paper. You can also create spreads with more than two 
pages; see “Creating multiple-page spreads” on page 47.

Note: Selecting Facing Pages affects only margins and on-screen spread display. To print 
the entire spread on one side of a sheet, use the Reader’s Spread option; see “Specifying 
which pages to print” on page 390.

Master Text Frame Select this option to create a text frame the size of the area within 
the margin guides, matching the column settings you specified. The master text frame is 
added to the A-Master. (See “About text frames on master pages” on page 82.)

Note: The Master Text Frame option is available only when you’ve chosen File > New > 
Document.

Page Size Choose a page size from the menu, or type values for Width and Height. Page 
size represents the final size you want after bleeds or other marks outside the page are 
trimmed.
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Orientation Click the portrait  (tall) or landscape  (wide) icons. These icons interact 
dynamically with the dimensions you enter in Page Size. When Height is the larger value, 
the portrait icon is selected. When Width is the larger value, the landscape icon is selected. 
Clicking the deselected icon switches the Height and Width values.

3 In the Margins and Columns section of the New Document dialog box, specify options 
and click OK. The options are the same as those in the Layout > Margins and Columns 
dialog box; see “Changing margin and column settings” on page 32.

Looking at the document window
In a document window, structural areas of a page are marked by the following default 
colors:

• Black lines describe the size of each page in a spread. A thin drop shadow helps distin-
guish a spread from its pasteboard. You can’t change the color of these lines.

• Magenta lines are margin guides.

• Violet lines are column guides.

• Lines of other colors are ruler guides which, when present, appear in the layer color 
when selected; see “Choosing a layer color” on page 71.

Column guides appear in front of margin guides. When a column guide is exactly in front 
of a margin guide, it hides the margin guide.

A. Spread B. Page size C. Margin guides D. Column guides

To customize the colors of column and margin guides:

1 Choose Edit > Preferences > Guides (Windows and Mac OS 9), or InDesign Preferences 
> Guides (Mac OS 10.1).

2 Under Margins or Columns, choose a preset color in the Color menu; you can also 
choose Other, or double-click the color box to specify the color in the system color picker.

3 Click OK to close the Preferences dialog box.

You can change the on-screen color of your paper by double-clicking the Paper color 
in the Swatches palette (choose Window > Swatches). The Paper color appears on-

screen only, and does not affect output; it is intended only to simulate designing for 
nonwhite paper.

Changing document settings
Changing options in the Document Setup dialog box affects every page in the document.

A

D

B

C
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If you change page size or orientation after objects have been added to pages, you can 
use the Layout Adjustment feature to minimize the amount of time needed for arranging 
existing objects.

To change document settings:

Choose File > Document Setup, specify the document options, and then click OK. The 
options are the same as those in the New Document dialog box; see “Starting a new 
document” on page 30.

Changing margin and column settings
Changing options in the Margins and Columns dialog box changes only the pages or 
masters selected in the Pages palette. By default, a page has one column defined by two 
column guides, one at the left and one at the right margin. Changing the number of 
columns replaces all existing columns with a new set of equally spaced columns. If you 
want to make unequal columns, drag a column guide; see “Creating unequal column 
widths” on page 32.

You can set up columns within individual text frames by selecting them and using the 
Columns options in the Text Frame Options dialog box. Text frame columns exist only 
within individual text frames, not on the page itself. (See “Setting text frame properties” 
on page 83.)

To change margin and column settings:

1 Do one of the following:

• To change margin and column settings for one spread or page, go to the spread you 
want to change, or select one spread or page in the Pages palette.

• To change margin and column settings for multiple pages, select those pages in the 
Pages palette, or select a master that controls the pages you want to change.

2 Choose Layout > Margins and Columns, specify the following options, and then click 
OK.

Margins Type values to specify the distance between margin guides and each edge of 
the page. If Facing Pages is selected in the New Document or Document Setup dialog box, 
the Left and Right margin option names change to Inside and Outside so that you can 
specify additional inside-margin space to accommodate binding.

Columns For Number, type the number of columns to be created within the margin 
guides. For Gutter, type a value for the width of the space between columns.

Note: The Margins and Columns dialog box doesn’t alter columns inside text frames, 
although text frame columns may be resized if the frame is resized by the Layout 
Adjustment feature.To change columns inside frames, see “Setting text frame properties” 
on page 83.

Creating unequal column widths
When you have more than one column on a page, the column guides in the middle 
appear in pairs. When you drag one column guide, the pair moves. The space between 
the column guides is the gutter value you specified; the pair moves together to maintain 
that value.
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To create columns of unequal widths:

1 Go to the master or spread you want to change.

2 Using the selection tool , drag a column guide. You can’t drag it past an adjacent 
column guide or beyond the edge of the page.

Dragging a column guide to create unequal column widths

To create columns with unequal gutters, create evenly spaced ruler guides and then 
drag individual guides to the desired location. (See “Creating ruler guides” on 

page 39.)

Using rulers, grids, and guides
In addition to the margin and column guides that define each page, you can build a 
framework of grids and guides that help you position and align objects precisely. Grids and 
guides can be visible or hidden on screen and in print. For information on printing guides 
and grids, see “Printing grids, guides, and other nonprinting objects” on page 390.

One set of rulers and grids exists per page, but a guide can exist across all pages of a 
spread or within a single page only. Rulers are dimmed on all spreads except the target 
spread, to identify the target spread when several spreads are visible in the document 
window.

To show or hide rulers:

Choose View > Show Rulers or Hide Rulers.

About measurement units and rulers
You can work with several standard measurement units. Changing the measurement units 
doesn’t move guides, grids, and objects, so when ruler tick marks change, they might not 
line up with objects aligned to the old tick marks.

A. Labeled tick marks B. Major tick marks C. Minor tick marks

A

B

C
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You can set up different measurement systems for horizontal and vertical rulers; for 
example, many newspapers measure horizontal layouts in picas and vertical text stories in 
inches. The system you select for the horizontal ruler governs tabs, margins, indents, and 
other measurements. Each spread has its own vertical ruler; however, all vertical rulers use 
the same settings you specify in the Units & Increments preferences dialog box. 

The default units of measure for the rulers are picas (a pica equals 12 points). However, you 
can change custom ruler units, and control where the major tick marks appear on a ruler. 
For example, if you change the custom ruler units for the vertical ruler to 12 points, a major 
ruler increment appears every 12 points (if such display is possible in the current magnifi-
cation). The tick mark labels include your customized major tick marks, so when the ruler 
reads 3 in the same example, it marks the third instance of the 12-point increment, or 
36 points.

Vertical ruler using inches (left), and custom 12-point increments (right)

Setting custom ruler increments in the vertical ruler is useful for lining up a ruler’s 
major tick marks with a baseline grid. (See “Creating grids” on page 37.)

Setting up measurement units and rulers
You can set custom measurement units for the 
on-screen rulers and for use in palettes and dialog boxes; you can also change these 
settings at any time and temporarily override the current measurement units as you enter 
a value.

To specify the measurement units:

1 Choose Edit > Preferences > Units & Increments (Windows and Mac OS 9), or InDesign > 
Preferences > Units & Increments (Mac OS 10.1).

2 For Horizontal and Vertical, choose the measurement system you want to use for 
horizontal and vertical dimensions in rulers, dialog boxes, and palettes; or choose Custom, 
and type the number of points at which you want the ruler to display major tick marks. 
Click OK.

You can also change ruler units by right-clicking (Windows) or Control-clicking 
(Mac OS) a ruler, and choosing the units from the context menu.
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To temporarily override the measurement units:

Highlight the existing value in a palette or dialog box, and type the new value using the 
notation in the following table:

Note: Like other graphic-arts software from Adobe and other companies, InDesign uses 
PostScript points, which don’t correspond exactly to traditional printer points. There are 
72.27 traditional printer points in an inch, as opposed to 72 PostScript points.

You can quickly cycle through units of measurement by pressing Ctrl+Shift+Alt+U 
(Windows) or Cmd+Shift+Opt+U (Mac OS).

Changing the zero point
The zero point is the position at which the zeros on the horizontal and vertical rulers 
intersect. By default, the zero point is at the top left corner of the first page of each spread. 
This means that the default position of the zero point is always the same relative to a 
spread, but may seem to vary relative to the pasteboard.

The X and Y position coordinates in the Transform palette are displayed relative to the zero 
point. You can move the zero point to measure distances, to create a new reference point 
for measurement, or to tile oversized pages. By default, each spread has one zero point at 
the upper left corner of the first page, but you can also locate it at the binding spine, or 
specify that each page in a spread has its own zero point.

To specify: Type these 
letters after 
the value:

Example 
(original)

Example 
(InDesign 
notation)

Inches i, in, inch, or " 5 1/4 inches 5.25i

Millimeters mm 48 millime-
ters

48mm

Picas p 3 picas 3p

Points p (before value) 
pt (after value)

6 points p6, 6pt

Picas and 
points

p (after value) 3 picas, 
6 points

3p6

Ciceros c 5 ciceros 5c



Using Help | Contents | Index Back 36  

Adobe InDesign Help Setting Up Pages 

Using Help | Contents | Index Back 36  

To move the zero point:

Drag from the intersection of the horizontal and vertical rulers to the position on the 
layout where you want to set the zero point.

Establishing zero point

When you move the zero point, it moves to the same relative location in all spreads. 
For example, if you move the zero point to the top left corner of the second page of a 
page spread, it will appear in that position on the second page of all other spreads in 
the document.

To reset the zero point:

Double-click the intersection of the horizontal and vertical rulers .

To lock or unlock the zero point:

Right-click (Windows) or Control-click (Mac OS) the zero point of the rulers, and choose 
Lock Zero Point or Unlock Zero Point in the context menu.

To set the scope of the horizontal ruler origin:

1 Choose Edit > Preferences > Units & Increments (Windows and Mac OS 9), or InDesign > 
Preferences > Units & Increments (Mac OS 10.1).

2 In the Ruler Units section, choose one of the following in the Origin menu:

• Spread, to set the ruler origin at the top left corner of each spread.

• Page, to set the ruler origin at the top left corner of each page in each spread.

• Spine, to set the ruler origin at the binding spine of each spread.

Note: If you set the ruler origin at each spread’s binding spine, the origin becomes locked 
at the spine. You won’t be able to reposition the ruler origin by dragging it from the inter-
section of the rulers unless you choose another origin option.

You can also change horizontal ruler origin settings using the context menu that 
appears when you right-click (Windows) or Control-click (Mac OS) the horizontal ruler.
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Creating grids
Two kinds of nonprinting grids are available: a baseline grid for aligning columns of text, 
and a document grid for aligning objects. On the screen, a baseline grid resembles ruled 
notebook paper, and a document grid resembles graph paper. You can customize both 
kinds of grids.

Baseline grid (left) and document grid (right)

When a grid is visible, you can observe the following characteristics:

• The baseline grid covers entire spreads, but the document grid covers the entire 
pasteboard.

• Grids appear on every spread and cannot be assigned to any master.

• The document grid can appear in front of or behind all guides, layers, and objects, but 
cannot be assigned to any layer.

To set up a baseline grid:

1 Choose Edit > Preferences > Grids (Windows and Mac OS 9), or InDesign > Preferences 
> Grids (Mac OS 10.1).

2 Specify a baseline grid color by choosing a preset color in the Color menu. You can also 
choose Other in the Color menu, or double-click the color box to specify a custom color in 
the system color picker.

3 For Start, type a value to offset the grid from the top of the page, usually to account for 
the top margin. If you have trouble aligning the vertical ruler to this grid, try starting with a 
value of zero.

4 For Increment Every, type a value for the spacing between grid lines. In most cases, type 
a value that equals your body text leading, so that lines of text align perfectly to this grid.

A. Baseline grid start B. Increment between grid lines

A B
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5 For View Threshold, type a value to specify the magnification below which the grid 
does not appear, and click OK. Increase the view threshold to prevent crowded grid lines 
at lower magnifications.

To set up a document grid:

1 Choose Edit > Preferences > Grids (Windows and Mac OS 9), or InDesign > Preferences 
> Grids (Mac OS 10.1).

2 Specify a document grid color by choosing a preset color in the Color menu. You can 
also choose Other in the Color menu, or double-click the color box to specify a custom 
color in the system color picker.

3 To set horizontal grid spacing, specify a value for Gridline Every in the Horizontal 
section of the Document Grid section, and then specify a value for Subdivisions between 
each grid line.

Baseline grid at magnification below view threshold (left) and above view threshold (right)

4 To set vertical grid spacing, specify a value for Gridline Every in the Vertical section 
of the Document Grid section, and then specify a value for Subdivisions between each 
grid line.

5 Do one of the following, and click OK:

• To put the document and baseline grids behind all other objects, make sure that Grids 
in Back is selected.

• To put the document and baseline grids in front of all other objects, deselect Grids in 
Back.

You can also choose Guides in Back in the context menu that appears when you select 
a guide, and then right-click (Windows) or Control-click (Mac OS) an empty area of the 

document window in order that objects will appear in front of the guides.

To show or hide the grids:

To show or hide the baseline grid, choose View > Show/Hide Baseline Grid. To show or 
hide the document grid, choose View > Show/Hide Document Grid.
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Creating ruler guides
Ruler guides are different from grids in that they can be positioned freely on a page or on 
a pasteboard. You can create two kinds of ruler guides: page guides, which appear only on 
the page on which you create them, or spread guides, which span all pages and the paste-
board of a multiple-page spread. You can drag any ruler guide to the pasteboard. A ruler 
guide is displayed or hidden with the layer on which it was created. (See “Working with 
layers” on page 67.)

New ruler guides always appear on the target spread. For example, if several spreads are 
visible in the document window and you drag a new guide into the window, the new 
guide becomes visible only on the target spread. (See “Targeting and selecting spreads or 
pages” on page 46.)

A. Spread guide B. Page guide

To create guides:

1 Make sure that the correct spread is targeted; if necessary, click the spread in the 
document window to target it.

2 If the document contains multiple layers, click a layer name in the Layers palette to 
target the layer.

3 Do one of the following:

• To create a page guide, position the pointer inside a horizontal or vertical ruler and then 
drag to the desired location on the target spread. If you drop the guide onto the paste-
board, it spans the pasteboard and spread; it will act as a page guide if you later drag it 
onto a page.

• To create a spread guide, drag from the horizontal or vertical ruler, keeping the 
pointer in the pasteboard but positioning the guide at the desired location on the 
target spread.

Horizontal spread guide

A B
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• To create a spread guide when the pasteboard is not visible (for example, when 
you’ve zoomed in), press Ctrl (Windows) or Command (Mac OS) as you drag from the 
horizontal or vertical ruler to the target spread.

• To create a spread guide without dragging, double-click a specific position on the 
horizontal or vertical ruler. If you want to snap the guide to the nearest tick mark, hold 
down the Shift key when you double-click the ruler.

• To create vertical and horizontal guides simultaneously, press Ctrl (Windows) or 
Command (Mac OS) as you drag from the target spread’s ruler intersection to the 
desired location.

A vertical and horizontal guide created concurrently

To create a set of evenly spaced page guides:

1 If the document contains multiple layers, click a layer name in the Layers palette to 
target the layer.

2 Choose Layout > Create Guides.

3 For Number, type a value to specify the number of rows or columns you want to create.

4 For Gutter, type a value to specify the spacing between rows or columns. Start with a 
low value, such as 1 pica; large gutters leave little space for columns.

Note: Columns created with the Create Guides command are not the same as those 
created with the Layout > Margins and Columns command. For example, columns created 
using Create Guides cannot control text flow when a text file is placed. Use the Margins 
and Columns command to create major column divisions appropriate for autoflow text, 
and use the Create Guides command to create column grids and other layout aids.

5 For Fit Guides To, click Margins to create the guides within the page margins, or click 
Page to create the guides within the page edges.

Ruler guides evenly spaced within page margins (left) and page edges (right)

6 To delete any existing guides, select Remove Existing Ruler Guides on Page.
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7 If you like, select Preview to see the effect of your settings on the page, and then 
click OK.

Note: The Create Guides command can create page guides only; it cannot create spread 
guides.

Working with ruler guides
You can change the attributes of individual ruler guides, and move, cut, copy, paste, or 
delete multiple ruler guides simultaneously. Cut or copied ruler guides can be pasted to 
other pages 
or documents, but not to other programs. To change attributes of specific guides, you 
must select the guides you want to change. When no guides are selected, the Ruler Guides 
command sets the defaults for new guides only.

To show or hide all margin, column, and ruler guides:

Choose View > Show/Hide Guides.

To lock or unlock all ruler guides:

Choose View > Lock Guides to select or deselect the menu command.

To show, hide, lock, or unlock ruler guides on one layer only:

1 In the Layers palette, double-click the layer name.

2 In the Layer Options dialog box, select or deselect Show Guides or Lock Guides, and 
then click OK.

To select a ruler guide:

Using the selection tool  or the direct-selection tool , click the guide to highlight it in 
its layer color. No additional handles or anchor points appear on selected ruler guides, the 
way they do on other selected objects.

If you can’t select a ruler guide and the View > Lock Guides command is already 
deselected, the guide might be on that page’s master, or on a layer where guides 

are locked.

To select multiple ruler guides:

Using the selection or direct-selection tool, hold down Shift as you click guides. You can 
also drag over multiple guides, as long as the selection marquee doesn’t touch or enclose 
any other object.

To select all ruler guides on the target spread:

Press Ctrl+Alt+G (Windows) or Command+Option+G (Mac OS).

To move ruler guides:

Using the selection or direct-selection tool, do one of the following:

• Drag a ruler guide.

• Select multiple ruler guides, and then drag them.

• Move selected guides just as you would any other selected object, including nudging 
with the arrow keys and using the Transform palette. (See “Moving objects” on 
page 275.)
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• To make a guide snap to a ruler tick mark, press Shift as you drag it. Or select the guide, 
press and hold down the Shift key, and then click the mouse button.

• To move a spread guide, drag the part of the guide that’s on the pasteboard, or press 
Ctrl as you drag the guide from within the page.

To move guides to another page or document:

1 Select one or more guides.

2 Choose Edit > Copy or Edit > Cut, go to another page, and then choose Edit > Paste. If 
you’re pasting onto a page of the same size and orientation as the guides’ original page, 
the guides appear in the same position.

Note: The Paste Remembers Layers option affects the layer on which pasted guides 
appear. (See “Copying and pasting objects on layers” on page 70.)

To delete ruler guides:

Select one or more ruler guides, and press Delete.

To delete all ruler guides on a spread:

Press Ctrl+Alt+G (Windows) or Command+Option+G (Mac OS) to select all ruler guides on 
the target spread, and then press Delete.

To customize ruler guide color and visibility:

1 Do one of the following:

• To change options for one or more existing ruler guides, select those ruler guides.

• To set default options for new ruler guides, deselect all guides by clicking in an empty 
area.

2 Choose Layout > Ruler Guides.

3 For View Threshold, specify the magnification below which ruler guides do not appear. 
This prevents ruler guides from appearing too close together at lower magnifications.

4 For Color, choose a preset color. You can also choose Other or double-click the color box 
to specify a custom color in the system color picker. Then click OK.

You can set the current magnification as the view threshold for new ruler guides 
by pressing Alt (Windows) or Option (Mac OS) as you drag the ruler guides 

you’ve selected.

Changing ruler guide stacking order
By default, ruler guides appear in front of all other guides and objects. However, some 
ruler guides may block your view of such objects as lines with narrow stroke widths.
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You can change the Guides in Back preference to display ruler guides in front of or behind 
all other objects. However, regardless of the Guides in Back setting, objects and ruler 
guides are always in front of margin and column guides. Also, although putting guides 
on different layers organizes them structurally, it does not affect their visual stacking 
order—the Guides in Back preference stacks all ruler guides as a single set in relation to 
all page objects.

A. Ruler guides B. Page objects C. Margin and column guides D. Page

To display ruler guides behind objects:

Choose Edit > Preferences > Guides (Windows and Mac OS 9), or InDesign > Preferences > 
Guides (Mac OS 10.1), make sure that Guides in Back is selected, and click OK.

Guides in front (left), and guides in back (right)

Snapping objects to guides and grids
To precisely align objects to guides, use the Snap to Guides and Snap to Document Grid 
commands. Object edges will snap to (pulled toward) the nearest grid intersection or 
guide when you draw, move, or resize the objects.

The exact range within which an object snaps to guides is called the snap-to zone, which 
you can adjust. When you select both the Snap to Guides and the Snap to Document Grid 
commands, the grid takes precedence.

Keep the following guidelines in mind as you align objects to guides and grids:

• Guides must be visible for objects to snap to them. However, objects can snap to the 
document and baseline grids whether the grids are visible or not.

• Objects on one layer snap to ruler guides visible on any other layer. If you don’t want 
objects to snap to guides on a certain layer, hide that layer’s guides.

• For the baselines of text to snap to the baseline grid, press the Align to Baseline Grid 
button  for individual paragraphs or paragraph styles. (See “Aligning paragraphs to a 
baseline grid” on page 127.)

A

B

C

D
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To enable or disable snapping to the document grid or guides:

Choose View > Snap to Document Grid or View > Snap to Guides, and make sure that the 
command is selected (enabled) or deselected (disabled).

Note: The Snap to Guides command controls both snapping to guides and snapping to 
the baseline grid.

To specify the snap-to zone:

Choose Edit > Preferences > Guides (Windows and Mac OS 9), or InDesign > Preferences > 
Guides (Mac OS 10.1), type a value for Snap to Zone, and click OK. The Snap to Zone value 
is always in pixels.

To snap an object to a guide:

Drag an object toward a guide until one or more of the object’s edges is within the guide’s 
snap-to zone.

Previewing a document
Use Preview Mode to quickly hide such nonprinting elements as rulers, grids, and 
frame edges.

You can turn off individual nonprinting elements by choosing the appropriate command 
in the View menu, such as View > Hide Guides.

To turn on Preview mode:

Click the Preview mode icon  at the bottom of the toolbox.

To return to Normal View mode:

Click the Normal View mode icon  at the bottom of the toolbox.

Working with pages and spreads
When you select the Facing Pages option in the File > Document Setup dialog box, 
document pages are arranged in spreads. A spread is a set of pages viewed together, such 
as the two pages visible whenever you open a book or magazine. Every InDesign spread 
includes its own pasteboard, which is an area outside a page where you can store objects 
that aren’t yet positioned on a page. Each spread’s pasteboard provides space to accom-
modate objects that bleed, or extend past the edge of a page.
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Using the Pages palette
The Pages palette provides information about and control over pages, spreads (sets of 
pages seen together), and masters (pages or spreads that automatically format other 
pages or spreads).

A. Page icons in lower half of Pages palette B. Pages displaying prefix of applied master  
C. Highlighted page, indicating that it is selected D. Highlighted numbers, indicating target spread

To show the Pages palette:

Choose Window > Pages.

To change the page and spread display:

1 Choose Palette Options in the Pages palette menu.

2 To set the size for page icons, choose an option in the Icon Size menu in the Pages 
section.

3 To display page icons in one vertical column, make sure that Show Vertically is 
selected in the Pages section. To display page icons as a series of horizontal rows, deselect 
Show Vertically.

4 To set the size for master icons, choose an option in the Icon Size menu in the 
Masters section.

5 To display master icons in one vertical column, make sure that Show Vertically is 
selected in the Masters section. To display master icons as a series of horizontal rows, 
deselect Show Vertically.

6 In the Palette Layout section, do one of the following:

• Select Pages on Top to display the page icon section above the master icon section.

• Select Masters on Top to display the master icon section above the page icon section.

7 To control how Pages palette sections grow when you resize the palette, choose one of 
the following in the Resize menu in the Palette section, and then click OK:

• To resize both the Pages and Masters sections of the palette, choose Proportional.

• To maintain the size of the Pages section and let the Masters section grow, choose 
Pages Fixed.

• To maintain the size of the Masters section and let the Pages section grow, choose 
Masters Fixed.
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Targeting and selecting spreads or pages 
You can target or select spreads, depending on the task at hand:

• Target the spread on which the next new object should appear. This is helpful when, for 
example, several spreads are visible in the document window and you want to paste an 
object on a specific spread. Only one spread can be the target at any given time. By 
default, the target spread occupies the center of the document window. It is indicated 
by the highlighted page numbers (not highlighted page icons) in the Pages palette and 
by a vertical ruler that is not dimmed.

• Select a page or spread when your next action will affect a page or spread rather than 
objects, as when you’re setting margin and column options for a specific page only. 
When all pages of a spread are highlighted in the Pages palette, that spread is selected. 
You can select multiple spreads in a document. A selected spread is indicated by the 
highlighted page icons (not highlighted page numbers) in the Pages palette.

To target a spread:

Do one of the following:

• In the document window, modify any object on a spread or its pasteboard.

• In the document window, click a spread or its pasteboard.

• In the Pages palette, double-click the page numbers under a spread. If the spread is not 
completely visible, this also moves the entire spread into view in the document 
window.

To select a page:

In the Pages palette, click a page to select it. Don’t double-click unless you want also to 
target it and move it into view.

To select a spread:

Do one of the following:

• In the Pages palette, click the page numbers under the spread you want to select.

• In the Pages palette, press Shift as you click the first and last page icons in a spread.

One page selected (left) and entire spread selected (right)

• In the document window, click a spread or its pasteboard, or select any object on 
a spread.

Note: Some spread options, such as those in the Pages palette menu, are available only 
when an entire spread is selected.
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Creating multiple-page spreads
If you want the reader to see more than two pages at a time, you can create gatefold or 
accordion foldouts by creating a multiple-page spread and adding pages to it. A multiple-
page spread is like an island in your document; the original pages in a spread are 
unaffected when you add pages before or after the spread, on either side of the binding 
spine. The binding spine indicates how pages will be bound or folded in the final piece. 
The Adobe InDesign Quick Reference Card included is an example of a document in which 
a reader sees three pages at the same time; you can arrange pages this way by creating 
two spreads and adding one page to each.

You can clear a multiple-page spread, which redistributes a spread’s pages to match the 
Facing Pages setting in the File > Document Setup dialog box. You can identify a multiple-
page spread in the Pages palette by the brackets around its page numbers.

A. One-page spread B. Four-page spread, identified by brackets around page numbers 
C. Entire two-page spread selected

In Western languages, an odd-numbered page is always a right (recto) page and an even-
numbered page is a left (verso) page. As a result, the odd-numbered first page of a 
document (or of a section, depending on the page numbering) appears alone by default. 
Such pages are not considered parts of spreads because they are merely following page-
numbering conventions.

To create a multiple-page spread:

1 Select a spread in the Pages palette, and then choose Keep Spread Together in the 
Pages palette menu.

2 Add pages to the spread. (See “Adding, arranging, and duplicating pages and spreads” 
on page 47.)

To clear a multiple-page spread:

Select the spread, choose Keep Spread Together in the Pages palette menu, and deselect 
the option.

Adding, arranging, and duplicating pages and spreads
You can use the Pages palette to freely arrange, duplicate, and recombine pages and 
spreads. Keep the following guidelines in mind when adding or removing pages:

A
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• When you add, arrange, duplicate, or delete pages, the threads between text blocks on 
those pages are preserved.

• When you add, arrange, duplicate, or delete pages, InDesign redistributes pages 
according to how the Allow Pages to Shuffle command is set. (See “Controlling spread 
pagination” on page 50.)

• When your document has facing pages and you add or remove an odd number of 
pages anywhere other than at the end of the document, the verso (even-numbered) 
pages that follow the deletion become recto (odd-numbered) pages, and vice versa. 
Because this switches those pages’ inside and outside edges, you may need to 
reposition objects that originally spanned multiple pages or extended onto the 
pasteboard.

Objects that span multiple pages stay with the page on which they cover the most area

To add a page after the active page or spread:

Click the New Page button  in the Pages palette. The new page uses the same master as 
the existing active page.

Using the File > Document Setup dialog box to increase the number of pages you can 
add pages after the last page or spread.

To add pages and specify options for the new pages:

1 Choose Insert Pages in the Pages palette menu.

2 Type the number of pages you want to add.

3 For Insert, choose where the pages will be added, or type the page number in the box 
to the right of the menu.

4 For Master, choose a master to apply.

To add existing pages to existing spreads:

1 If you want to add an existing page to a spread, target the spread and choose Keep 
Spread Together in the Pages palette menu.

1
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2 In the Pages palette, drag a page icon to the spread icons; a black vertical bar will 
appear. Drag until the bar touches a page or appears between pages. To drag an entire 
spread, drag its page numbers.

Adding a page to a spread

Note: You can include up to ten pages in a spread. When you have reached the limit, the 
black vertical bar will not appear.

To arrange pages:

In the Pages palette, drag a page icon to a new position within the document. As you drag, 
the vertical bar indicates where the page will appear when you drop it. If the black 
rectangle or bar touches a spread, the page you’re dragging will extend that spread; 
otherwise, document pages will be redistributed to match the Facing Pages setting in the 
File > Document Setup dialog box.

Moving a page’s position

To duplicate a page or spread:

In the Pages palette, do one of the following:

• Drag the page range numbers under a spread to the New Page button . The new 
spread appears at the end of the document.

• Select a page or spread, and then choose Duplicate Page or Duplicate Spread in the 
Pages palette menu. The new page or spread appears at the end of the document.

• Press Alt (Windows) or Option (Mac OS) as you drag the page icon or page range 
numbers under a spread to a new location.

Note: Duplicating a page or spread also duplicates all objects on the page or spread. Text 
threads from the duplicated spread to other spreads are broken, but all text threads within 
the duplicated spread remain intact—as do all text threads on the original spread.

To remove a page from a spread while keeping it in the document:

1 If you want to remove a page from a spread, target the spread and choose Keep Spread 
Together in the Pages palette menu.
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2 In the Pages palette, drag a page out of the spread until the vertical bar is not touching 
any other pages.

Note: If you remove an odd number of pages in a spread, later pages will change sides 
and objects may be repositioned relative to the new margins. When text flows onto the 
pasteboard or onto pages where you don’t want it, you must reposition it manually on 
each page.

To delete a page or spread from the document:

Do one of the following:

• In the Pages palette, drag one or more page icons or page-range numbers to the 
Trash icon .

• Select one or more page icons in the Pages palette, and click the Trash icon.

• Select one or more page icons in the Pages palette, and then choose Delete Page(s) 
or Delete Spread(s) in the Pages palette menu.

Controlling spread pagination
You can easily create spreads of more than two pages. However, most documents use 
two-page spreads exclusively. You can prevent unexpected pagination by making sure 
that your document contains only two-page spreads. The Allow Pages to Shuffle 
command specifies how pages and spreads are redistributed when you add, remove, 
or arrange pages.

To specify how the document’s pages are distributed when you add, remove, or 
arrange pages:

In the Pages palette, do one of the following:

• To preserve all two-page spreads and prevent the creation of spreads with more than 
two pages, make sure that Allow Pages to Shuffle is selected in the Pages palette menu. 
This is the default setting.

• To allow the creation of spreads of more than two pages and to preserve those spreads 
when you add, remove, or arrange preceding pages, deselect Allow Pages to Shuffle on 
the Pages palette menu. InDesign will preserve spreads of more than two pages while 
letting two-page spreads repaginate normally.
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Numbering pages
You can add a page-number marker to your pages to specify where a page number sits on 
a page and how it will look. Because a page-number marker updates automatically, the 
page number it displays is always correct even as you add, remove, or rearrange pages in 
the document.

Page number on master A (left), and page 5 based on same master (right)

A single InDesign document can contain up to 9999 pages, but page numbers can be 
as large as 99,999 (for example, you can correctly number a 100-page document that 
starts on page 9949). By default, the first page is a recto (right) page numbered 1. Odd-
numbered pages always appear on the right; if you use the Section Options command 
to change the first page number to an even number, the first page becomes a verso 
(left) page.

To add an automatically updated page number:

1 Do one of the following to specify where the page-number marker appears:

• If you want a page number to appear on all pages based on a master, double-click the 
master in the Pages palette.

• If you want the page number to appear on a specific page only, double-click a page in 
the top half of the Pages palette.

2 On the master or page, position the type tool  where you want a page number to be 
added, then drag to create a new text frame large enough to hold the longest instance of 
the page number and any text you want to appear next to the page number, such as the 
section marker or document name.

3 With a blinking insertion point positioned in the new text frame, do any of 
the following:

• Type any text that you want to accompany the page number, such as the document 
name.

• Use the Insert Section Name command to add custom section marker text, as explained 
in “Defining section numbering” on page 52.
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4 Choose Type > Insert Special Character > Auto Page Number. If the automatic page 
number is on a master page, it displays the master page prefix. On a document page, the 
automatic page number displays the page number. On a pasteboard, it displays PB.

The Auto Page Number command is also available in a context menu under the Insert 
Special Character command. To see the context menu, position the text insertion 

point in the page number text frame, and right-click (Windows) or Control+click (Mac OS).

Insert Section Marker (left), and Insert Page Number Marker (right)

Changing Numbering and Section Options
You can divide content into sections that are numbered differently. For example, the first 
ten pages of a book (the front matter) might use Roman numerals, and the rest of the 
book might use Arabic numerals, starting at the eleventh page, which is numbered page 1 
in this example. To provide for multiple kinds of page numbering, you can set up named 
sections within individual documents, or within several documents in a book.

By default, page numbers in a book are numbered consecutively. Using Numbering & 
Section Options, you can restart numbering at a specified page, change the numbering 
style, and add prefixes and section marker text to the numbers.

Defining section numbering
Create all of the pages necessary for your document (or all of the documents necessary for 
your book), and then use the Pages palette to define ranges of pages as sections. 



Using Help | Contents | Index Back 53  

Adobe InDesign Help Setting Up Pages 

Using Help | Contents | Index Back 53  

You can define a section marker to label section pages automatically. Any prefix you add 
appears as part of the automatic page number, table of contents entry, cross-reference, 
index entry, or any other automatic number. For example, if you specify A– for Section 
Prefix on page 16 of a document, the generated number in the table of contents or index 
would appear as A–16. Text you type for a section marker appears when you choose the 
Insert Section Name command.

A. Section indicator icon indicates start of section  
B. Page number is changed for new section C. Status bar 
displays document length

To define section numbering:

1 In the Pages palette, select the first page in the section you want to define.

2 Do one of the following:

• Choose Layout > Numbering & Section Options.

• Choose Numbering & Section Options in the Pages palette.

3 If you’re changing the numbering options for any page other than the first page of the 
document, make sure that Start Section is selected. This option marks the selected page as 
the beginning of a new section. 

4 As necessary, specify the following options, and then click OK:

• Select Automatic Page Numbering if you want the page numbers of this section to 
follow the numbering of the previous section. When you select this option, this 
section’s page numbers update automatically when you add pages before the first 
page of this section.

• Select Start Page Numbering At to make sure that the first page of this section is a 
specific number, regardless of where it is in the document, and type the number; or 
type 1 to restart the numbering. The remaining pages in the section will be numbered 
accordingly. If you chose a non-Arabic page-numbering style for the Style option (such 
as Roman numerals), you still must type an Arabic numeral in this box.

• Select Section Prefix, and type a label for this section. This label appears in the page 
box at the lower left corner of the document window, and it appears as part of such 
automatic page numbers as table of contents and index entries. Include spaces or 
punctuation as necessary so that the automatic number will appear as, for example, A–
16 or A 16, not A16. This label must fit in the page box, so it is limited to five characters. 
It cannot be empty, and it cannot contain blank spaces.
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• Select Style, and choose a page-numbering style from the menu. The style applies to all 
pages in this section only.

Note: Changing the first page of a section from an even number to an odd number (or vice 
versa) switches the inside and outside edges of facing pages in that section, possibly 
affecting object placement. (See “Adding, arranging, and duplicating pages and spreads” 
on page 47.)

• Select Section Marker, and type a label that can be inserted on the page itself.

A. The section marker appears on the page itself  
B. The section prefix appears in the page box in the document window

5 To end the section, repeat the section numbering steps on the first page that follows 
the section.

To add section marker text to a page or master:

1 On a page or master that you’re using in a section, drag the type tool  to create a text 
frame large enough for the section marker text, or click in an existing frame.

2 Right-click (Windows) or Control-click (Mac OS) and choose Insert Special Character > 
Section Name in the context menu.

Creating a section marker

To change settings for an existing section:

In the Pages palette, do one of the following:

• Double-click the section indicator icon  that appears above the page icon in the 
Pages palette.

• Select a page that uses a section marker, and choose Numbering & Section Options 
in the Pages palette menu.

To remove a section:

1 In the Pages palette, select a page with a section indicator icon.

BA
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2 Choose Numbering & Section Options in the Pages palette menu.

3 Deselect the Start Section option, and click OK.

To quickly identify a section in the Pages palette, position the pointer precisely over 
any section indicator icon . A tool tip appears, displaying the starting page number 

or section prefix.

Displaying absolute or section numbering in the Pages palette
The Pages palette can display absolute numbering (labeling all pages with consecutive 
numbers, starting at the first page of the document) or section numbering (labeling pages 
by section, as specified in the Section Options dialog box). Changing the numbering 
display affects how pages are indicated in the InDesign document, as in the Pages palette 
and in the page box at the bottom of a document window. However, it does not change 
the appearance of page numbers on document pages.

To display absolute or section numbering in the Pages palette:

1 Choose Edit > Preferences > General (Windows and Mac OS 9) or InDesign > Prefer-
ences > General (Mac OS 10.1)

2 For Page Numbering, choose a numbering method in the View menu.

Pages palette showing absolute numbering (left) and section numbering (right) 

Adding automatic page numbers for story jumps
You can easily maintain the jump lines of stories that continue to other pages, such as 
a line that says “Continued on page 42.” Use a jump-line page number to automatically 
update the number of the page containing a story’s next or previous threaded text frame 
when you move or reflow the story’s threaded text frames.

Usually the jump-line page number should be in a separate text frame from the story 
it tracks. That way, the jump-line page number remains in position even if the story’s 
text reflows.
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If an unwanted character appears at the beginning of the page number (so that, for 
example, a jump line reads Cont’d on page A16 instead of Cont’d on page 16), you included 
a section prefix in the Numbering & Section Options dialog box. Remove or edit the prefix; 
see “Defining section numbering” on page 52.

Note: If you type an automatic page number special character in the Find/Change dialog 
box, jump-line page numbers can also be found and changed.

Make sure that a jump-line page number’s text frame overlaps the text frame containing the story 
you want it to track

To add an automatic jump-line page number:

1 With the type tool , drag to create a new text frame above or below an existing text 
frame that contains the story you want to track.

2 With the selection tool, position the new text frame so that it overlaps the frame 
containing the story you want to track.

3 With a text insertion point active in the new text frame, type text such as “Continued 
from” or “Continued on”, and then do one of the following:

• To add a “continued from” page number, choose Type > Insert Special Character > 
Previous Page Number. You can also right-click (Windows) or Control-click (Mac OS) the 
text frame, and in the context menu that appears, choose Insert Special Character > 
Previous Page Number.

• To add a “continued to” page number, choose Type > Insert Special Character > Next 
Page Number. You can also right-click (Windows) or Control-click (Mac OS) the text 
frame, and in the context menu that appears, choose Insert Special Character > Next 
Page Number.

Note: If the jump-line page number is the same as the current page number, make sure 
that you overlap the text frames of the jump line and the story, and make sure that the 
story is threaded to a text frame on a different page.

4 (Optional) With the selection tool, hold down Shift as you select the frames containing 
the story and its jump-line page number.

5 (Optional) Choose Object > Group. This keeps the story and its jump line together if you 
move them.

6 If necessary, repeat this procedure to add more jump lines.

To insert the previous page number in a jump line using a keyboard shortcut, press 
Alt+Shift+Ctrl+[ (Windows) or Option+Shift+Command+[ (Mac OS). To insert the next 

page number in a jump line, press Alt+Shift+Ctrl+] (Windows) or 
Option+Shift+Command+] (Mac OS).

he large island of Niphon and wooded 
region, fifty leagues from Yokohama    
.. lies hidden the ancient city of the 
al dead— the necropolis of Japanese

continued on page 42
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Using masters
A master is like a background that you can quickly apply to many pages. A master can be 
one page or a multiple-page spread. Use masters for objects or guides, such as margins, 
columns, page numbers, headers, footers, and repeating logos or artwork that appear 
in the same position on many pages. Using masters can minimize the time you spend 
keeping your design consistent. And if you need to reposition an item, you only have to do 
it once, on the master.

You can quickly compare alternative design ideas by creating a variety of masters and 
applying them in turn to sample pages containing typical content.

Guidelines for working with masters
Keep the following guidelines in mind as you work with masters:

• For best results, apply a master to a spread of the same number of pages. For example, 
design and apply a three-page master to your three-page spreads for a consistent look.

• If you want to create a set of masters that are slight variations on one main design, don’t 
recreate each master completely; instead, create a main master and base design varia-
tions on it. (See “Basing one master on another” on page 62.)

• If you don’t specify options for a new master, it uses a default prefix and name, and is 
not based on any other master.

• Masters cannot contain sections. Set up sections in regular pages.

• If Layout Adjustment is active, applying a different master may alter the positions and 
sizes of objects in your layout. When used properly, Layout Adjustment can automati-
cally adjust objects to fit the new master.

Creating and applying masters
Manage masters by using the master icons in the Masters section (upper half ) of the Pages 
palette (default) or the commands in the Pages palette menu. Every master has a name, 
and assigns a prefix to the labels of the icons of the pages using that master.

A. Master icons in top half of Pages palette B. Master prefix and name  
C. Pages displaying prefix of applied master
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To create a new master spread:

Press Ctrl (Windows) or Command (Mac OS) as you click the New Page button  in the 
Pages palette. A new, blank master spread appears; if Facing Pages is active in File > 
Document Setup, the master will have facing pages.

To create a new master spread from an existing page or spread:

Drag an entire spread from the Pages section of the Pages palette to the Masters section. 
Any objects on the original page or spread become part of the new master. If the original 
page used a master, the new master is based on the original page’s master.

Creating a new master spread based on another page or spread

To create a master and specify options for it:

1 Choose New Master in the palette menu.

2 Specify the following options, and click OK:

• For Prefix, type a prefix that identifies the applied master for each page in the Pages 
palette. You can type as many as four characters.

• For Name, type a name for the master spread.

• For Based on Master, choose an existing master spread on which you’ll base this master 
spread (see “Basing one master on another” on page 62), or choose None.

• For Number of Pages, type a value for the number of pages you want in the master 
spread (as many as ten). 

To edit the options of an existing master:

1 In the Masters section of the Pages palette, click the name below a master spread to 
select the entire master spread.

2 Choose Master Options For [master spread name] in the Pages palette menu.

To apply a master or master spread to a document page or spread:

Do one of the following:

• To apply a master to one page, drag its name from the top half of the Pages palette to 
the page icon in the Pages section of the palette. When a black rectangle surrounds the 
desired page only, release the mouse button.

None
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• To apply a master to a spread, drag its name from the top half of the Pages palette to 
the page numbers of the desired spread in the Pages section of the palette. When a 
black rectangle surrounds all pages in the desired spread, release the mouse button.

Applying a master to a page (left) and applying a master to a spread (right)

To apply a master to multiple pages:

1 (Optional) In the Pages section of the Pages palette, select the pages to which you want 
to apply a new master.

2 Do one of the following:

• If you selected pages, press Alt (Windows) or Option (Mac OS) as you click a master.

• If you didn’t select pages, choose Apply Master to Pages in the Pages palette menu, 
select a master for Apply Master, make sure that the page ranges in the To Pages option 
are the ones you want, and click OK. You can type page numbers using section 
numbering; you can type page ranges with hyphens; and you can separate pages and 
ranges with commas. For example, you can type 5, 7-9, 13-16 as a single entry.

Applying a master to a range of pages

To edit a master:

1 In the Masters section of the Pages palette, double-click the icon for the master 
you want to edit, or select the master page from the text box list at the bottom of the 
document window. The master spread appears in the document window.

2 Make changes to the master. InDesign automatically updates any pages using 
that master.

Use multiple views to see the results of master edits. Choose Window > New Window, 
and then choose Window > Tile. Set one view to a page and the other view to the 

master applied to that page. Then edit the master and watch the page update.

To remove a master from document pages:

Apply the None master from the Masters section of the Pages palette using the same 
procedures you’d use in applying any other master.
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To duplicate a master spread:

In the Masters section of the Pages palette, do one of the following:

• Drag the page name of a master spread to the New Page button  in the Pages palette.

• Select the page name of a master spread, and choose Duplicate Master Spread [spread 
name] in the Pages palette menu.

To copy a master spread to another document:

Drag the master page name from the Masters section of the Pages palette to the window 
of another document.

To delete a master from the document:

1 In the Pages palette, select one or more master page icons. To select all unused master 
pages, choose Select Unused Masters in the Page palette menu.

2 Do one of the following:

• Drag a selected master page or spread icon to the Trash icon .

• Click the Trash icon.

• Choose Delete Master Spread [spread name] in the Pages palette menu.

About overriding and detaching master objects
Sometimes you want a specific page to be only slightly different from a master. In this 
situation you don’t need to re-create the master layout on the page or create a new 
master. You can override (modify) any master object or object attribute; other master 
objects on the document page will continue to update with the master. You can control 
master object updates in the following ways:

Override individual attributes of an object You can selectively override one or more 
attributes of a master object. For example, suppose a document page contains a frame 
from a master, and you override the frame’s size. If you resize the original frame on the 
master, the size of the frame on the document page remains unchanged. However, if you 
change the fill color of the same frame on the master, the fill color changes on the resized 
frame on the document page. In short, overrides occur on an attribute-by-attribute basis.

Detach objects from their master On a document page, you can detach (disassociate) a 
master object from its master. When you do this, none of the object attributes on the 
document page updates when you edit the object on the master.

Remove overrides You can remove overrides from master objects. When you do this, the 
object’s attributes revert to their state on the corresponding master, and will once again 
update when you edit the master. You can remove overrides for selected objects or all 
objects on a spread, but not across an entire document at once. You can’t remove 
overrides from objects detached from the master.

Reapply the master You can reapply a master to a page. All master objects appear with 
the attributes they have on the corresponding master. While removing master overrides 
returns overridden master objects to their original state on the master, reapplying a 
master doesn’t change overridden or detached objects, but will leave them on the page 
while reintroducing their master versions. For this reason, reapplying a master may result 
in two copies of some objects on the page.
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Some sets of attributes are affected together when you override any attribute in the set. 
These include transformation attributes (moving, scaling, rotating, reflecting, shearing), 
and attributes of contents of frames (frame options). For example, if you rotate an 
overridden object, and then skew the original master object’s size, the new size is not 
reflected in the overridden object.

Overriding and detaching master objects
When updating or reapplying a master, be aware that overridden objects will be detached 
when re-applying a master. For example, updates to the original master item will no 
longer be reflected on the layout pages that have had their masters reapplied. Also, 
detached objects won’t be reset to the master, so an original master object will be added 
back to the layout in addition to the detached version of the object.

Note: Reapplying a master is the same as applying a master. (See “Creating and applying 
masters” on page 57.)

To show or hide master items on a spread:

Target a spread, and then choose View > Display Master Items.

To override a master object:

1 When viewing a spread (or master spread), press Ctrl+Shift (Windows) or 
Command+Shift (Mac OS) as you select any object belonging to the master applied to the 
page (or master applied to the master page).

2 Change the object as desired.

To remove master overrides from one or more objects:

1 On a document spread, select objects that were originally master objects. 

2 In the Pages palette, target a spread and choose Remove Selected Local Overrides in 
the Pages palette menu.

To remove all master overrides from a spread:

1 Target the spread (or master spread) from which you want to remove all master 
overrides.

2 Choose Edit > Deselect All to make sure that no objects are selected.

3 In the Pages palette, choose Remove All Local Overrides in the Pages palette menu.

To detach a master object from its master:

1 Override the master item. See previous section.

2 Choose Detach Selection from Master in the Pages palette menu.

To detach all overridden master objects on a spread:

1 Go to the spread that contains the overridden master objects you want to detach from 
their master (don’t go to the master page that contained the original item).

2 Choose Detach All Objects from Master in the Pages palette menu. If the command isn’t 
available, there aren’t any overridden objects on that spread.

Note: The Detach All Objects from Master command detaches all overridden master 
objects on a spread, not all master objects. If you want to detach all master objects on a 
spread, you must manually override each master object first.
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Basing one master on another
You can create a master variation that is based on and updates with another master within 
the same document. For example, if your document has ten chapters that use master 
spreads that vary only slightly, base all of them on a master spread that contains the layout 
and objects common to all ten. This way, a change to the basic design requires editing just 
one master spread—the parent—instead of editing all ten separately. This is a powerful 
way to keep a consistent yet varied design up to date. The master spreads based on the 
parent are called child masters.

Original parent and child masters (left); when the parent master is modified, the child masters are 
automatically updated (right)

You can override parent master objects on a child master to create variations on a 
master, just as you can override master objects on document pages.

To base one master on another:

In the Masters section of the Pages palette, do one of the following:

• Select a master spread, and choose Master Options for [master spread name] in the 
Pages palette menu. For Based on Master, choose a different master, and click OK.

• Drag the master spread you want to use as the base onto a different master icon (to 
apply it to a master page) or onto page numbers under a different master spread (to 
apply it to an entire spread). As you drag over another master, the black rectangle that 
appears indicates whether you are about to apply the master to a master page or to a 
master spread.

B-Master based on A-Master

About masters, stacking order, and layers
When a document has one master layer, objects appear behind other objects on a page. If 
you want a master object to appear in front of document page objects, place it on a higher 
layer on the master. An object on a higher layer of a master page appears at the back of 
that layer on a document page, and in front of all objects on lower layers. Because master 
objects and document page objects alternate in the layer stacking order, merging layers 
will move master objects of an upper layer behind document page objects of a lower layer.

None

10–11 12–13 14–15

None

10–11 12–13 14–15

A-Master B-MasterA-Master

A A

B-Master
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Objects on a single layer have their own stacking order within that layer. (See “Stacking 
objects” on page 268.)

Master objects (top left) appear behind page objects on the same layer (bottom left); moving a master 
object to a higher layer (top right) moves it in front of all objects on lower layers (bottom right)

Laying out pages with frames
After you set up the structure of a layout using such features as masters and guides, build 
a document by adding text and graphics, or placeholders for text and graphics.

About paths and frames
You can draw objects in a document and use them as paths or as frames:

• Paths are vector graphics like those you create in a drawing program such as Adobe 
Illustrator.

• Frames are identical to paths, with only one difference—they can be containers for text 
or other objects. A frame can also exist as a placeholder—a container without contents. 
As containers and placeholders, frames are the basic building blocks for a document’s 
layout.

A. Path B. Frame as graphic container C. Frame with 
placed graphic

You can draw both paths and frames using tools in the toolbox. You can also create frames 
by simply placing (importing) or pasting contents into a path.

Because a frame is just a container version of a path, you can do anything to a frame that 
you can do to a path, such as add a color or a gradient to its fill or stroke, or edit the shape 
of the frame itself with the pen tool. You can even use a frame as a path, or vice versa, at 
any time. This flexibility makes it easy to change your design, and provides a wide range of 
design choices.

8 • FOOTBALL

A • SECTION A • SECTION

CBA
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Frames can contain text or graphics. A text frame determines the area to be occupied by 
text, and how text will flow through the layout. You can recognize text frames by the text 
ports in their respective upper left and lower right corners.

A graphics frame can function as a border and background, and can crop or mask a 
graphic. When acting as an empty placeholder, a graphics frame displays a crossbar.

Text frame (left) and empty graphics frame (right)

If you don’t see the crossbar inside an empty graphics frame, the frame edges display may 
be turned off; see “Showing and hiding frame edges” on page 64.

Showing and hiding frame edges
Unlike with paths, you can see the nonprinting strokes (outlines) of frames by default 
even when the frames aren’t selected. If the document window is getting crowded, use 
the Show/Hide Frame Edges command to simplify the screen display by hiding the frame 
edges. Doing this also hides the crossbar in a graphics placeholder frame. The display 
setting for frame edges doesn’t affect the display of the text ports on text frames.

Note: The frame edge is defined as a frame’s stroke, not the outer edge of the 
stroke’s weight.

To show or hide frame edges and placeholder indicators:

Choose View > Show/Hide Frame Edges.

You can also hide frame edges by clicking Preview Mode  at the bottom of the toolbox. 
(See “Previewing a document” on page 44.)

Using placeholders to design pages
When your final text and graphics are available, you can simply add them to a document; 
InDesign automatically creates frames when you import them (unless you’re importing 
text or graphics directly into existing frames). However, when you don’t have the content 
yet or you want to block out the design before adding text and graphics, you can use 
frames as placeholders. For example, you might use one of these strategies:

• Draw text frames using the type tool, and graphics frames using the drawing tools. 
Thread empty text frames together so that importing final text takes just one step.

• Draw empty shapes using drawing tools. When you’re ready to start defining areas for 
text and graphics, redefine the placeholder frames for either text or graphics.

To redefine the purpose of paths and frames:

Do any of the following:

• To use a path or text frame as a graphics placeholder frame, select a path or an empty 
text frame, and then choose Object > Content > Graphic.
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• To use a path or graphics frame as a text placeholder frame, select a path or an empty 
graphics frame, and then choose Object > Content > Text.

• To use a text or graphics frame as a path only, select an empty frame, and then choose 
Object > Content > Unassigned.

Note: When a frame contains text or graphics, you cannot redefine it using the Object > 
Content menu. However, the frame automatically redefines itself if you select it and 
replace its contents.

Adjusting layout objects automatically
If you use the Document Setup or Margins and Columns commands to make changes to 
an existing layout, such as altering column widths or page orientation, you could spend 
considerable time and effort in rearranging objects to fit the new layout. The Layout 
Adjustment feature can do much of that work automatically. For example, you can quickly 
reformat a wide four-column document designed for an A4-size page to a tall two-column 
format on a U.S. legal-size page. With Layout Adjustment, text and graphics frames are 
moved and resized as necessary based on the new relative positions of column guides, 
page margins, and page edges.

Note: Dragging column guides does not trigger layout adjustment.

About automatic layout adjustment
When you change a layout setting that affects page size, margins, or columns, and the 
Layout Adjustment feature is enabled, that feature uses a set of logical rules to move and 
resize page guides and objects.

Page designed vertically, for print (left); page orientation changed for on-screen viewing, with layout 
automatically refitted by the Layout Adjustment feature (right)

You can modify the rules in the Layout Adjustment dialog box. The Layout Adjustment 
feature attempts to approximate the proportions of the old layout in the new layout by 
doing the following:

• Repositioning margin guides, but maintaining margin widths, if the page size changes 
moving column and ruler guides to maintain proportional distances from page edges, 
margins, or column guides.

• Adding or removing column guides at the right side of the page, if the new layout 
specifies a different number of columns.

• Moving objects already aligned to any margin, column, or ruler guide, or to any two 
guides perpendicular to each other, so that the objects stay with those guides if the 
guides move during layout adjustment.
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• Proportionally resizing objects already aligned to two parallel margin, column, or ruler 
guides or to guides on three sides, so that the objects stay with those guides if the 
guides move during layout adjustment.

• Moving objects to keep them in the same relative position on the page, if the page size 
changes.

The Layout Adjustment feature produces more predictable results when a layout is tightly 
based on a framework of margins, page columns, and ruler guides, and where objects are 
snapped to guides. Results are less predictable when objects don’t adhere to margins, 
columns, and guides, or when extraneous ruler and column guides clutter a page. Layout 
adjustment is not affected by the document grid or the baseline grid.

Note: Layout Adjustment affects columns inside a text frame differently than it does page 
columns. If the frame itself is resized by Layout Adjustment and the Fixed Column Width is 
not selected in the Object > Text Frame Options dialog box, text frame columns are resized 
proportionally. If the Fixed Column Width option is selected, columns are added or 
removed as necessary

Setting options for layout adjustment
Use the Layout Adjustment dialog box to enable or disable layout adjustment and modify 
the rules used to adjust a layout. 

Note: It’s important to remember that changing options in the Layout Adjustment dialog 
box does not immediately change anything—because layout adjustment is triggered only 
by changes to page size, page orientation, margins, or column settings.

When you want to restore a layout to its previous state, you must undo the action that 
triggered the layout adjustment. (See “Undoing mistakes” on page 24.)

To set layout adjustment options:

Choose Layout > Layout Adjustment, specify the following settings, and click OK:

Enable Layout Adjustment Select this option so that layout adjustment will occur 
whenever you change page size, page orientation, margins, or columns.

Snap Zone Type a value to specify how near an object must be to the closest margin 
guide, column guide, or page edge to snap to that element during layout adjustment.

Allow Graphics and Groups to Resize Select this option to let the Layout Adjustment 
feature scale graphics, frames, and groups. When deselected, graphics and groups can be 
moved by Layout Adjustment, but not resized.

Allow Ruler Guides to Move Select this option when you want ruler guides to be reposi-
tioned by the Layout Adjustment feature.

Ignore Ruler Guide Alignments Select this option when ruler guides are not well 
positioned for layout adjustment (see “About automatic layout adjustment” on page 65). 
Objects will still align to column and margin guides, and to page edges.

Ignore Object and Layer Locks Select this option when you want the Layout 
Adjustment feature to reposition objects that are locked individually, or locked as a result 
of being on a locked layer.



Using Help | Contents | Index Back 67  

Adobe InDesign Help Setting Up Pages 

Using Help | Contents | Index Back 67  

Working with layers
Each document includes at least one named layer. By using multiple layers, you can create 
and edit specific areas or kinds of content in your document without affecting other areas 
or kinds of content. For example, if your document prints slowly because it contains many 
large graphics, you can use one layer for just the text in your document; then, when it’s 
time to proofread the text, you can hide all other layers and quickly print the text layer 
only. You can also use layers to display alternate design ideas for the same layout, or 
versions of advertisements for different regions.

For information on converting layers from Adobe PageMaker or QuarkXPress, see the 
related technical support documents on the Adobe Web site.

About the Layers palette
The Layers palette lists layers with the frontmost layer appearing at the top of the palette. 
Use it to create and delete layers, hide and lock them, merge them, and specify options 
that determine how layers are displayed and printed. You can also change the stacking 
order of layers and move objects from one layer to another.

Think of layers as transparent sheets stacked on top of each other. If a layer doesn’t have 
objects on it, you can see through it to any objects on layers behind it.

A document and its layers

Note: Objects on masters appear at the bottom of each layer, so master objects can 
appear in front of document page objects. (See “About masters, stacking order, and layers” 
on page 62.)
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Layers involve all pages of a document, including masters. For example, if you hide Layer 1 
while editing page 1 of your document, the layer is hidden on all pages until you decide to 
show it again.

A. Target layer for next new object B. Show/Hide (currently visible) C. Hidden layer (eye 
icon hidden)  D. Lock/unlock (currently locked) E. Layers selected for next layer command  
F. Layers containing selected objects G. New Layer button H. Trash button

Creating layers and specifying layer options
You can add layers at any time using the New Layer command on the Layers palette menu 
or the New Layer button at the bottom of the Layers palette. The number of layers a 
document can have is limited only by the RAM available to InDesign.

To show the Layers palette:

Choose Window > Layers.

To create a new layer using default settings:

Do one of the following:

• To create a new layer at the top of the Layers palette list, click the New Layer button .

• To create a new layer above the selected layer, hold down Ctrl (Windows) or Command 
(Mac OS) as you click the New Layer button.

To create a new layer and specify options:

1 Choose New Layer in the Layers palette menu.

2 Specify the following options, and then click OK:

Name Type a label for the layer.

Color Choose a layer color. (See “Choosing a layer color” on page 71.)

Show Layer Select this option to make a layer visible and printable. Selecting this option 
is the same as the making the eye icon  visible in the Layers palette.

Show Guides Select this option to make the guides on the layer visible. This does not 
affect guides anywhere else in the document.

Lock Layer Select this option to prevent changes to any objects on the layer. Selecting 
this option is the same as making the crossed-out-pencil icon visible in the Layers palette.

Lock Guides Select this option to prevent changes to all ruler guides on the layer.

B
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To specify options for existing layers:

Do one of the following:

• Double-click a layer in the Layers palette.

• Select one or more layers in the Layers palette, and choose Layer Options for [layer 
name] in the Layers palette menu. 

• Specify options as described in the previous procedure (see “To create a new layer and 
specify options:” on page 68), and click OK.

Adding objects to layers
Any new object is placed on the target layer, the layer currently displaying the pen icon in 
the Layers palette. Targeting a layer also selects it. If multiple layers are selected, targeting 
one of them doesn’t change the selection; but targeting a layer outside the selection 
deselects the other layers.

You can add objects to the target layer by any of the following methods:

• Creating new objects with the text tool or drawing tools.

• Importing, placing, or pasting text or graphics.

• Selecting objects on other layers, and then moving them to the new layer. See 
“Selecting, moving, and copying objects on layers” on page 70.

You cannot draw or place a new object on a hidden or locked layer. When you select a 
drawing tool or the text tool, or place a file when the target layer is hidden or locked, the 
pointer changes to a crossed-out pencil icon  when it is positioned over the document 
window. Either show or unlock the target layer, or target a visible, unlocked layer. If you 
choose Edit > Paste when the target layer is hidden or locked, an alert message gives you 
the choice of showing or unlocking the target layer.

To target a layer for the next new object:

Click a layer in the Layers palette to target it. The pen icon  appears on the layer you 
clicked, and the layer also highlights to indicate that it is targeted.

Changing the target layer for the next new object

Note: When you place or paste text or graphics into an existing frame on a different 
layer, the text or graphics move to the frame’s layer, because they become contained by 
the frame.
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Selecting, moving, and copying objects on layers
By default, you can select any object on any layer. In the Layers palette, dots mark layers 
that contain selected objects. The layer’s selection color helps you identify an object’s 
layer. To prevent selecting objects on a specific layer, lock the layer.

To select all objects on a specific layer:

Hold down Alt (Windows) or Option (Mac OS) as you click a layer in the Layers palette.

To move or copy objects to another layer:

1 Using the selection tool, select one or more objects on a document page or master.

2 In the Layers palette, do one of the following:

• To move selected objects to another layer, drag the colored dot on the right side of the 
layer list to the other layer. To move selected objects to a hidden or locked layer, hold 
down Ctrl (Windows) or Command (Mac OS) as you drag the colored dot.

Moving an object between layers

• To copy selected objects to another layer, hold down Alt (Windows) or Option (Mac OS) 
as you drag the colored dot on the right side of the layer list to the other layer. To copy 
selected objects to a hidden or locked layer, hold down Ctrl+Alt (Windows) or 
Command+Option (Mac OS) as you drag the colored dot.

Copying and pasting objects on layers
The Paste Remembers Layers command affects how objects pasted from other locations 
interact with existing layers:

• If the Paste Remembers Layers command is selected, objects cut or copied from 
different layers retain their layer assignments when pasted to the new page or position. 
If you paste objects to a document that doesn’t have the same layers as the document 
from which they were copied, InDesign adds the objects’ layer names to the Layers 
palette in the second document, and pastes each object on its layer.

• If the Paste Remembers Layers command is unselected, objects cut or copied from 
different layers are pasted together on the target layer.

To enable objects to keep layering information when pasted to a different page or 
position:

Choose Paste Remembers Layers in the Layers palette menu.

To paste objects to a different layer:

1 Make sure that Paste Remembers Layers is unselected in the Layers palette menu.
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2 Select objects and choose Edit > Copy or Edit > Cut.

3 In the Layers palette, click the other layer to target it.

4 Select Edit > Paste.

Duplicating a layer
When you duplicate a layer, you copy its contents and settings. The duplicate layer then 
appears above the original layer in the Layers palette. Any duplicated frames that were 
threaded to other frames on the layer remain threaded. Duplicated frames whose originals 
were threaded to frames on other layers are no longer threaded to those frames.

To duplicate a layer:

In the Layers palette, do one of the following:

• Select the layer name and choose Duplicate [layer name] in the Layers palette menu.

• Drag a layer name and drop it on the New Layer button .

Choosing a layer color
Assigning a color to a layer makes it easier to distinguish the layers of different selected 
objects. For each layer that contains a selected object, the Layers palette displays a dot in 
the layer’s color. On the page, each object displays the color of its layer in its selection 
handles, bounding box, text ports, text wrap boundary (if used), and frame edges 
(including the X displayed by an empty graphics frame).

The layer color does not appear for an unselected frame if its edges are hidden; see 
“Showing and hiding frame edges” on page 64.

To specify a selection color for a layer:

1 In the Layers palette, double-click a layer or select a layer and choose Layer Options for 
[layer name].

2 For Color, choose a preset color. You can also choose Other, or double-click the color 
box to specify a color in the system color picker.

Changing the order of layers
Change the stacking order of layers in your document by rearranging the layers on the 
Layers palette. Rearranging layers changes the order of layers on every page, not just on 
the target spread.
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To change the order of layers:

In the Layers palette, drag a layer up or down in the list. You can also drag multiple 
selected layers.

Reordering layers

Showing and hiding layers
You can hide or display any layer at any time. Hidden layers can’t be edited, and don’t 
appear on screen or in print. Hiding layers can be useful when you want to do any of 
the following:

• Hide parts of a document that are not meant to appear in the final document.

• Hide alternate versions of a document.

• Simplify the display of a document, to make it easier to edit other parts of the 
document.

• Prevent a layer from printing.

• Speed up screen redraw when a layer contains high-resolution graphics.

To hide or show one layer at a time:

In the Layers palette, click the square at the far left of a layer name to hide or show the eye 
icon  for that layer.

To hide all layers except the selected layer:

Choose Hide Others in the Layers palette menu.

To show all layers:

Do one of the following:

• Choose Show All Layers in the Layers palette menu.

• When only one layer is hidden, click its eye icon  to show it.

Locking and unlocking layers
Locking is useful for preventing accidental changes to a layer. A locked layer displays a 
crossed-out-pencil icon in the Layers palette. Objects on locked layers cannot be selected 
or edited directly; however, if objects on locked layers have attributes that can be edited 
indirectly, they will change. For example, if you edit a tint swatch, objects on locked 
layers using that tint swatch will reflect the change. Similarly, putting a series of threaded 
text frames on both locked and unlocked layers will not prevent text on locked layers 
from recomposing.
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To lock or unlock one layer at a time:

In the Layers palette, click a square in the second column from the left to show (lock) or 
hide (unlock) the crossed-out-pencil icon  for a layer.

To lock all layers except the target layer:

Choose Lock Others in the Layers palette menu.

To unlock all layers:

Choose Unlock All Layers in the Layers palette menu.

Deleting layers
Remove layers from your document by using the Delete Layer or Delete Unused Layers 
commands on the Layers palette menu.

Note: Remember that each layer is document-wide—it appears on every page of a 
document. Before deleting a layer, consider hiding all other layers first, and then turn 
to each page of the document to verify that it is safe to delete the remaining objects.

To delete layers:

Do one of the following:

• In the Layers palette, drag a layer to the Trash icon .

• Select one or more layers in the Layers palette and click the Trash button.

• Select one or more layers in the Layers palette and choose Delete Layer [layer name] 
from the Layers palette menu. If you select multiple layers, the command is Delete 
Layers.

To delete all empty layers:

Choose Delete Unused Layers in the Layers palette menu.

Merging layers and flattening a document
You can reduce the number of layers in a document without deleting any objects by 
merging layers. When you merge layers, objects from all selected layers are moved to the 
target layer. Of the layers you merge, only the target layer remains in the document; the 
other selected layers are deleted.

You can also flatten a document by merging all layers.

Note: If you merge layers containing a mix of page objects and master objects, the master 
objects move to the back of the resulting merged layer. (See “About masters, stacking 
order, and layers” on page 62.)

To merge layers or flatten a document:

1 In the Layers palette, select any combination of layers. Be sure to include the layer you 
want to target as the merged layer. If you’re flattening the document, select all layers in 
the palette.

2 Click any selected layer to make it the target layer, indicated by the pen icon .

Note: If you click an unselected layer, you lose the current selection.

Choose Merge Layers in the Layers palette menu.
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About converting layers from PageMaker and QuarkXPress
By default, a new document (or one converted from QuarkXPress) contains just one layer, 
called Layer 1.

InDesign converts Adobe PageMaker 6.5 documents differently to accommodate the 
differences in PageMaker and InDesign layers. In PageMaker 6.5, master page objects on 
layers always appear behind all objects on document pages. In InDesign, however, master 
objects on layers appear at the back of each corresponding layer. (See “Opening 
PageMaker and QuarkXPress files in InDesign” on page 12.)
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Working with Text

About text frames
All text in Adobe InDesign resides inside containers called text frames. Like graphics 
frames, text frames can be moved, resized, and otherwise manipulated. The tool with 
which you select a text frame determines the kind of changes you can make. Use the type 
tool  to enter or edit text in a frame. Use the selection tool  for general layout tasks such 
as positioning and sizing a frame; use the direct-selection tool  to alter a frame’s shape.

Text frames can also be connected to other text frames so that the text in one frame can 
flow into another frame. Frames that are connected in this way are threaded. Text that 
flows through one or more threaded frames is called a story. When you place (import) 
a word-processing file, it comes into your document as a single story, regardless of the 
number of frames it may occupy.

Text frames can have multiple columns. Text frames can also be placed on master pages 
and still receive text on document pages; and they can be based on, yet independent of, 
page columns. In other words, a two-column text frame can sit on a four-column page. 

About threading text frames
The text in a frame can be independent of other frames, or it can flow between connected 
frames. Connected frames can be on the same page or spread, or on another page in the 
document. The process of connecting text among frames is called threading text.

Each text frame contains an in port and an out port, which enable connections to other 
text frames. An empty in port or out port indicates the beginning or end of a story, respec-
tively. An arrow in a port indicates that the frame is linked to another frame. A red plus sign 
(+) in an out port indicates that there is more text in the story to be placed but no more 
text frames in which to place it. This remaining unseen text is called overset text.

A. In port at beginning of story B. Out port indicating thread to next frame C. Text thread  
D. In port indicating thread from previous frame E. Out port indicating overset text

Open the case for the first time and 
take in the sights and smells of your 
hand-made instrument. See the 
way the soft light reflects off the 
handrubbed satin finish. Breath in 
the perfume of the finest exotic 
tone-woods. Then, finally, take it in 
your hands and begin to play. The 
experience will leave you swept 
away, and your life and your music 
will never be the same again. For 
the select few thousand individuals 

ferent from the multitude of other 
fine instruments available now to 
discerning musician and collector. 
To this day, each and every guitar, 
man-dolin, banjo, and the dulcimer 
produced at Anton is afforded the 
exact same care and attention to 
detail as those that he created one-
by-one in the first few years. The 
same attention to detail, the same 
demand for the best of wood and 
hardware available, and of course 
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When you add or remove text in a threaded story, the text flows through existing frames 
until it gets to the end of the story. (See “Adding text to frames” on page 78.) You may need 
to resize the last frame or create a new frame so that all of the text is visible.

Original text in threaded frames (top); after you add text to first frame, 
text reflows to second frame (bottom)

Original text in frames that are not threaded (top); after you add text to first frame, 
text reflows in first frame only (overset); second frame is unaffected (bottom)

Threading text through frames
You can thread text frames whether or not they contain text.

You can add automatic “continued on” or “continued from” jump lines that track 
threaded stories as they jump from frame to frame. (See “Adding automatic page 

numbers for story jumps” on page 55.)

To add a new frame to the thread:

1 Using the selection tool , select a text frame, and then click the in port or out port 
to load a text icon. Clicking the in port lets you add a frame before the selected frame; 
clicking the out port lets you add a frame after the selected frame.

2 Position the loaded text icon  where you want a new text frame to appear, and then 
click or drag to create a new text frame. 

When the loaded text icon is active, you can perform many actions, including turning 
pages, creating new pages, and zooming in and out. If you start to thread two frames 

and change your mind, you can cancel the thread by clicking any tool in the toolbox. No 
text will be lost.

To add an existing frame to the thread:

1 Using the selection tool, select a text frame, and then click the in port or the out port to 
load a text icon.

1.Light
2.Water

3.Topsoil

1.Light (natural
   or electric)

2.Water
3.Topsoil

1.Light 
2.Water

3.Topsoil

3.Topsoil1.Light (natural
   or electric)



Using Help | Contents | Index Back 77  

Adobe InDesign Help Working with Text 

Using Help | Contents | Index Back 77  

2 Position the loaded text icon over the frame you want to connect to. The loaded text 
icon changes to the thread icon.

With a loaded text icon, click a frame to add it to the thread

3 Click inside the second frame to thread it to the first. 

To show text threads:

1 Choose View > Show Text Threads.

2 Using either selection tool, select any frame in the story.

If you want to see threads from different stories at the same time, Shift-click to select a 
frame in each story. To turn off text threads, choose View > Hide Text Threads.

To unthread text frames:

1 Using the selection tool, click an in port or an out port that represents a thread to 
another frame. For example, in a two-framed thread, click either the out port of the first 
frame or the in port of the second frame.

2 Position the loaded text icon over the previous or next frame to display the unthread 
icon.

Removing a frame from a thread

3 Click in the frame. InDesign breaks the connection between the frames.

You can also double-click an in port or out port to break the connection between 
frames. 

To add a frame inside a sequence of threaded frames:

1 Using the selection tool, click the out port at the point in the story where you want to 
add a frame. When you release the mouse button, a loaded text icon appears.

Open the case for the first time and take in the 

sights and smells of your hand-made instrument. 

See the way the light reflects off the handrubbed 

satin finish. Breath in the perfume of the finest 

exotic tone-woods. Then, finally, take it in your 

hands and begin to play. The experience will leave 

you swept away, and your life and your music will 

never be the same again. For the select few thou 
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2 Drag to create a new frame, or select a different text frame. InDesign threads the frame 
into the series of linked frames containing the story.

Adding frame inside a thread (top) and result (bottom)

To disconnect a frame from a thread:

1 Using the selection tool, select one or more frames (Shift-click to select 
multiple objects).

2 Choose Edit > Cut.

The frame disappears, and any text contained in it flows to the next frame in the story. 
When you cut the last frame in a story, the text is stored as overset text in the 
previous frame.

3 If you want to use the disconnected frame elsewhere in your document, go to the page 
where you want the disconnected text to appear and choose Edit > Paste.

The pasted frame or frames include a copy of any text they originally contained, but the 
frames are no longer threaded to the original story. 

Although the frame or frames were removed with a copy of the text, no text is removed 
from the original story. When you cut and paste a series of threaded text frames at once, 
the pasted frames maintain their connection to each other, but lose connection to any 
other frames in the original story.

Adding text to frames
Add text to a document by typing or by pasting or placing text from a word-processing 
application. If your word-processing application supports drag-and-drop, you can also 
drag text into InDesign frames. For large blocks of text, the Place command is an efficient, 
versatile way to add text to your document. InDesign supports a variety of word-
processing, spreadsheet, and text file formats (see “Working with text import filters” on 
page 109). 

You can place or paste text without first creating a text frame; InDesign will create one for 
you automatically.

Typing text
To type text in a document, first create a text frame, or place the insertion point in an 
existing text frame.

1 2

1 32
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To create an empty text frame:

Using the type tool , drag to define the width and height of a new text frame. Hold down 
Shift as you drag to constrain the frame to a square. When you release the mouse button, a 
text insertion point appears in the frame.

Dragging to create new text frame 

Clicking the type tool inside any empty frame or path converts that path or frame to a 
text frame.

To type text into a document:

1 Using the type tool , drag to create a new text frame, or click in an existing text frame. 

2 Begin typing.

If you created a text frame on a master page, hold down Ctrl+Shift (Windows) or 
Command+Shift (Mac OS) as you click in the frame on your document page. You can then 
use the type tool to add text to the selected frame.

Pasting text
You can paste text from an InDesign document or from another application, such as a text 
editor or word-processing application. When you paste text from another application, 
InDesign preserves formatting attributes and adds any styles used to format the text to 
the Paragraph Styles palette. If the pasted text is formatted with fonts not available in 
InDesign, the text is highlighted as a missing font; see “Handling missing fonts” on 
page 125.

When you drag text into InDesign from another application, InDesign attempts to 
preserve as much formatting as possible, and it converts unavailable fonts.

To paste text into a document:

1 Cut or copy text in another application or in an InDesign document.

2 If you like, select text or click in a text frame. Otherwise, the text will be pasted into its 
own new frame.

3 Choose Edit > Paste.

To paste text from another application using the drag-and-drop technique:

1 Select text in an application that lets you drag and drop text.

2 Drag the selection into an InDesign document.

InDesign adds the copied text to a new text frame.

You can also drag a text file or word-processing file into your InDesign document 
directly from Windows Explorer or Mac OS Finder. The text will be added to a 

new frame.

Color is the 

foundation 

of 
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Placing text
When placing text, you can specify whether the text will retain its formatting and use 
typographic quotation marks and apostrophes. You can also specify additional import 
options.

To place a text file:

1 Do one of the following:

• Make sure that no insertion point is present and that no text or frames are selected. 
The placed text will appear in a new frame.

• Using the type tool , select text or click in an existing frame. The placed text will be 
added at the insertion point, or it will replace the selection.

• Using the selection tool  or the direct-selection tool , select an existing frame. The 
placed text will replace the contents of the frame.

If you accidentally replace a text file or graphic using this method, choose Edit > 
Undo Replace.

2 Choose File > Place.

3 Locate and select a text file.

4 To keep existing formatting in the text file, select Retain Format. To strip all formatting 
out of the text file upon importing, deselect this option.

5 To convert straight quotation marks (" ") and apostrophes (') to typographic quotation 
marks (“ ”) and apostrophes (’) in the imported file, select Convert Quotes.

6 If you want the imported text to replace the currently selected text or frame, select 
Replace Selected Item.

7 To display additional options for importing the type of file you’ve selected, select Show 
Import Options or Shift-click Open. For more information on additional import options, 
see “Working with text import filters” on page 109.

8 Click Open. If you selected Show Import Options or held down Shift, InDesign displays a 
dialog box containing import options for the type of file you’re placing. Select any options 
you want, and then click OK.

If you haven’t already designated an existing frame to receive text, the pointer becomes a 
loaded text icon, ready to flow text wherever you click or drag. For information on flowing 
text, see “Flowing text manually or automatically” on page 80.

Flowing text manually or automatically
When your pointer becomes a loaded text icon  after you place text or click an in port 
or out port, you are ready to flow text onto your pages. When you position the loaded text 
icon over a text frame, parentheses enclose the icon .

In addition, the icon can appear in one of three forms, which correspond to the method 
you choose for controlling the flow of text on your pages:

Manual text flow  adds text one frame at a time. It stops flowing text at the bottom 
of a text frame, or at the last of a series of linked frames. You must reload the text icon 
to continue flowing text.
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Semi-autoflow  works like manual text flow, except that the pointer becomes a 
loaded text icon each time the end of a frame is reached, until all text is flowed into 
your document.

Autoflow  adds pages and frames until all text is flowed into your document.

To flow text manually one frame at a time:

1 Use the Place command to select a file, or click the out port  of a selected text frame.

Click the out port of a selected frame

2 Do one of the following:

• Position the loaded text icon anywhere within an existing frame or path, and then click. 
The text flows into the frame and any other frames linked to it. Note that text always 
starts filling the frame at the top of the leftmost column, even when you click in a 
different column.

• Position the loaded text icon in a column to create a text frame the width of that 
column. The top of the frame appears where you click.

• Drag the loaded text icon to create a text frame the width and height of the area 
you define.

3 If there is more text to be placed, click the out port and repeat steps 1 and 2 until all text 
has been placed. (See “Threading text through frames” on page 76.)

Note: When you place text in a frame that is threaded to other frames, text autoflows 
through the threaded frames, regardless of the text flow method you choose.

To flow text semi-automatically:

With a loaded text icon, Alt-click (Windows) or Option-click (Mac OS) a page or frame. The 
text flows one column at a time, as in manual flow, but the loaded text icon automatically 
reloads after each column is placed.

To flow an entire story automatically:

With the loaded text icon displayed, hold down Shift as you do one of the following:

• Click the loaded text icon in a column to create a frame the width of that column. 
InDesign creates new text frames and new document pages until all text is added to 
the document.

• Click inside a text frame that is based on a master text frame. The text autoflows into the 
document page frame and generates new pages as needed, using the master frame’s 
attributes.

To cancel a loaded text icon without placing text:

Select any tool in the toolbox to cancel the loaded text icon. No text will be deleted.

If there are any rules

when choosing colors

for your garden, the
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Inserting placeholder text
While you can lay out and thread text frames before adding text to them, adding place-
holder text can give you a more complete sense of your document’s design. InDesign can 
add placeholder text that you can easily replace with real text later.

If you add placeholder text to a frame that’s threaded to other frames, the placeholder text 
is added at the start of the first text frame (if all frames are empty) or at the end of the 
existing text (if some text is already in the threaded frames).

Note: Placeholder text doesn’t represent any particular language. Before you adjust 
settings that depend on the rules of a specific language, replace the placeholder text with 
the actual text in your document’s final language.

To add placeholder text to a text frame:

1 Do one of the following:

• Using the selection tool, select one or more text frames.

• Using the type tool, click in a text frame.

2 Choose Type > Fill with Placeholder Text.

You can also choose Fill with Placeholder Text in the context menu that appears when 
you right-click (Windows) or Control-click (Mac OS) a selected empty text frame or a 

text frame with an active insertion point.

About text frames on master pages
When you start a new document, you can select the Master Text Frame option so that an 
empty text frame is placed on the document’s default master page. This frame has the 
column and margin attributes specified in the New Document dialog box.

Follow these guidelines for using text frames on master pages:

• Set master text frames when you want each page in your document to contain a page-
sized text frame into which you can flow or type your text. If your document requires 
more variation, such as pages with different numbers of frames or frames of different 
lengths, leave the Master Text Frame option deselected.

• Whether or not you select the Master Text Frame option, you can add text frames to a 
master page to act as placeholders. You can thread these empty placeholder frames 
together to establish a flow.

• Flow text into master text frames using the same procedures you would use with 
frames created on document pages. 

• If you need to type text in a master text frame on a document page, hold down 
Ctrl+Shift (Windows) or Command+Shift (Mac OS) as you click the text frame on the 
document page. Then click in the frame using the type tool and begin typing.

• If you change the page margins, text frames adjust to the new margins only if the 
Enable Layout Adjustment option is selected; see “Adjusting layout objects automati-
cally” on page 65.

• Selecting the Master Text Frame option does not affect whether new pages are added 
when you autoflow text.

• When you place text into a frame on a document page that is based on one of several 
threaded frames on a master page, the text only flows into the frame you click. That’s 
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because clicking the icon in the frame overrides only that frame. However, when you 
hold down Shift as you click in a frame based on a master page so that text is autof-
lowed, InDesign overrides all the threaded text frames, flowing text into each and 
creating new pages as needed.

Setting text frame properties
Use Text Frame Options to change settings such as the number of columns in the frame, 
the vertical alignment of text within the frame, or the inset spacing, which is the distance 
between the text and the frame. 

Before setting inset and creating two columns (left), and after (right)

To change properties for a text frame:

1 Using the selection tool , select a frame, or using the type tool , click inside the text 
frame or select text.

2 Choose Object > Text Frame Options.

3 Select Preview to preview any options before accepting the changes and closing the 
dialog box.

4 In the Columns section, do one or more of the following:

• Set the number of columns.

• Set the column width.

• Select Fixed Column Width to maintain column width when you resize the frame. When 
this option is selected, resizing the frame can change the number of columns, but not 

Open the case for the first time and take in the sights and smells of 
your hand-made instrument. See the way the light reflects off the 
handrubbed satin finish. Breath in the perfume of the finest exotic tone 
woods. Then, finally, take it in your hands and begin to play. The 
experience will leave you swept away, and your life and your music will 
never be the same again.
For the select few thousand people across the continent playing  
Antons it’s no mystery why our guitars look and sound so different from 
the multitude of other instruments available to the discerning musician 
and collector. To this day, each guitar, mandolin, banjo, and dulcimer 
produced at Anton is afforded the same care and attention to detail as 
those he created. Open the case for the first time and take in the sights 
and smells of your hand-made instrument. See the way the light 
reflects off the handrubbed satin finish. Breath in the perfume of the 
finest exotic tone woods. Then, finally, take it in your hands and begin 
to play. The experience will leave you swept away, and your life and 
your music will never be the same again.
For the select few thousand people across the con-tinent playing  
Antons it’s no mystery why our guitars look and sound so different from 
the multitude of other instruments available to the discerning musician 
and collector. To this day, each guitar, mandolin, banjo, and dulcimer 
produced at Anton is afforded the same care and attention to 
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their width. Leave this option deselected if you want column widths to change when 
you resize the text frame.

A. Original text frame B. Text frame resized with Fixed Column Width deselected  
C. Text frame resized with Fixed Column Width selected

• Specify a Gutter value to set the distance between columns.

5 In the Inset Spacing section, type the offset distances you want for Top, Left, Bottom, 
and Right. If the frame you’ve selected has a non-rectangular shape, the Top, Left, Bottom, 
and Right options are dimmed, and an Inset option is available instead.

6 For First Baseline Offset, do one of the following:

• Select Ascent so that the height of the “d” character in the font falls below the top inset 
of the text frame.

• Select Cap Height so that the top of uppercase letters touch the top inset of the text 
frame.

• Select Leading to use the text’s leading value as the distance between the baseline of 
the first line of text and the top inset of the frame. 

• Select x Height so that the height of the “x” character in the font falls below the top 
inset of the frame.

• Select Fixed to specify the distance between the baseline of the first line of text and the 
top inset of the frame.

• Select a minimum value for the baseline offset. For example, if Leading is selected and 
you specify a minimum value of 1p, InDesign uses the leading value only when it’s 
greater than 1 pica.

7 Select Ignore Text Wrap to make the text in the text frame ignore any text wraps.

A

B

C
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Editing text
InDesign includes many word-processing features. As you move the insertion point 
through a story, InDesign scrolls and, when necessary, turns pages to display the current 
insertion-point position. To move through a story more quickly, you can use keyboard 
shortcuts. InDesign’s shortcuts are similar to those found in most popular word 
processors.

Hold down Shift while using the above keyboard shortcuts to select text.

To move the 
insertion point:

Press:

One character right Right arrow

One character left Left arrow

Up one line Up arrow

Down one line Down arrow

Right one word Ctrl+Right arrow (Windows) or 
Command+Right arrow (Mac OS)

Left one word Ctrl+Left arrow (Windows) or 
Command+Left arrow (Mac OS)

Up one paragraph Ctrl+Up arrow (Windows) or 
Command+Up arrow (Mac OS)

Down one 
paragraph

Ctrl+Down arrow (Windows) or 
Command+Down arrow (Mac OS)

End of line End

Start of line Home

End of story Ctrl+End (Windows) or 
Command-End (Mac OS)

Start of story Ctrl+Home (Windows) or 
Command-Home (Mac OS)
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When you use the selection tool or direct-selection tool to select a frame, the following 
shortcuts will help you navigate through threaded frames and change which frame is 
selected.

Selecting text
You can select single characters, single words, or ranges of words. You can also set 
a preference for triple-clicking to select a line instead of a paragraph.

To select text:

Using the type tool , do one of the following:

• Drag over a character, word, or an entire text block to select it.

• Double-click a word to select it.

• Triple-click anywhere in a line to select a line. If the Triple Click to Select a Line prefer-
ences option is deselected, triple-clicking selects the entire paragraph.

You can also press Ctrl+Shift+\ (Windows) or Command+Shift+\ (Mac OS) to select 
a line.

• If the Triple Click to Select a Line option is selected, quadruple-click anywhere in a 
paragraph to select the entire paragraph or quintuple-click to select the entire story.

• Click anywhere in a story, and choose Edit > Select All to select all the text in that story.

To determine whether triple-clicking selects a line or a paragraph:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 Select Triple Click to Select a Line to enable triple-clicking to select a line (this is the 
default). Deselect this option if you want triple-clicking to select a paragraph.

To deselect text:

Do one of the following:

• Using the type tool, click a blank area of your document window or pasteboard.

• Click a selection tool in the toolbox.

• Choose Edit > Deselect All.

To select: Press:

The next frame in 
the thread

Ctrl+Alt+Page Down (Windows) or 
Command+Option+Page Down 
(Mac OS)

The previous frame 
in the thread

Ctrl+Alt+Page Up (Windows) or Com-
mand+Option+Page Up (Mac OS)

The first frame in 
the story

Ctrl+Alt+Shift+Page Up (Windows) or 
Command+Option+Shift+Page Up 
(Mac OS)

The last frame in 
the story

Ctrl+Alt+Shift+Page Down (Windows) 
or Command+Option+Shift+Page 
Down (Mac OS)
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To select text in a frame covered by other overlapping frames:

1 Using the selection tool , hold down Ctrl (Windows) or Command (Mac OS) and click 
to select the text frame.

2 Select the type tool, and then click inside the text frame or select text.

Viewing nonprinting characters
When you’re editing text, it helps to be able to see nonprinting characters such as those 
for spaces, tabs, ends of paragraphs, index markers, and ends of stories. These special 
characters are visible only in a document window; they don’t print or output to formats 
such as PDF and XML.

For more information on working with nonprinting markers for indexes, hyperlink 
anchors, and XML tags, see “Working with markers” on page 190.

Nonprinting characters hidden (top) and visible (bottom)

To view hidden characters:

Choose Type > Show Hidden Characters. A check mark appears next to the menu 
command. To hide visible characters, choose the command again to deselect it.

Hidden characters appear in the same color as the current layer. To change the color of 
hidden characters, change the layer color.

Inserting glyphs
InDesign makes it easy to insert any glyph defined in a font without using additional 
software. A glyph is a specific form of a character. For example, in certain fonts, the capital 
letter A is available in several forms, such as swash and small cap.

Growth in production of custom
hand-made guitars by year:

1996 1997 1998
12 36 89

Growth in production of custom
hand-made guitars by year:

1996 1997 1998
12 36 89#
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OpenType fonts such as Adobe Caslon Pro provide multiple glyphs for many standard 
characters. Use the Glyphs palette when you want to insert these alternate glyphs in 
your document. You can also use the Insert Glyphs palette to view and insert OpenType 
attributes such as ornaments, swashes, fractions, and ligatures. For more information, see 
“About OpenType fonts” on page 115.

A. Show menu B. Font family C. Type style  D. Zoom buttons

To insert a glyph from a specified font:

1 Using the type tool, click to place the insertion point where you want to enter a 
character.

2 Choose Type > Insert Glyphs to display the Glyphs palette.

3 To display a different set of characters in the Glyphs palette, select a different font (such 
as Adobe Caslon Pro) and type style, if available. 

4 In the Show pop-up menu, choose Entire Font. If you selected an OpenType font, you 
can choose from a number of OpenType categories, such as fractions, oldstyle figures, and 
small caps; see “About OpenType fonts” on page 115.

5 Scroll through the display of characters until you see the glyph you want to insert. If you 
selected an OpenType font, you can display a flyout menu of alternate glyphs by clicking 
the triangle in the lower right corner of the glyph box.

Flyout menu containing alternate glyphs

6 Double-click the character you want to insert. The character appears at the text 
insertion point.

To replace a character with an alternate glyph:

1 Choose Type > Insert Glyphs to display the Glyphs palette.

2 For Show, select Alternates for Selection.

3 Using a type tool, select a character in your document. The Glyphs palette displays 
alternate glyphs, if they’re available.

B C D

A
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4 Double-click a glyph in the Glyphs palette to replace the selected character in 
the document.

To highlight alternate glyphs in the text:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 Select Substituted Glyphs, and then click OK. Substituted glyphs in the text are 
highlighted in nonprinting purple.

Inserting common symbols, spaces, and hyphens
You can insert common characters such as em dashes and en dashes, registered 
trademark symbols, and different kinds of quotation marks. You can also insert specific 
types of white space, including em spaces and en spaces.

To insert special characters:

1 Using the type tool, position the insertion point where you want to insert a character.

2 Choose Type > Insert Special Character, and then select a character in the 
context menu.

To insert specific types of white space:

1 Using the type tool, position the insertion point where you want to insert a certain 
amount of white space.

2 Choose Type > Insert White Space, and then select one of the spacing options (such as 
Flush Space) in the context menu.

To specify the kinds of quotation marks to be used:

1 Choose Edit > Preferences > Dictionary (Windows and Mac OS 9), or InDesign > Prefer-
ences > Dictionary (Mac OS 10).

2 Do one of the following:

• For Double Quotes, select a pair of quotation marks, or type the pair of characters you 
want to use, and then click OK.

• For Single Quotes, select a pair of quotation marks, or type the pair of characters you 
want to use, and then click OK.

Note: These quotation mark characters appear only when the Use Typographer’s Quotes 
option is selected in the Text panel of the Preferences dialog box.

Adding column, frame, and page breaks
Control column, frame, and page breaks by inserting special break characters in the text. 
The special characters are visible when you choose Type > Show Hidden Characters. 

Related break options are available in the Keep Options dialog box (see “Controlling 
paragraph breaks” on page 132) and in the New Paragraph Style dialog box. These break 
characters do not work in tables.

The following break options are available:

Column break Flows text to the next column in the current text frame. If the frame has 
only one column, the text goes to the next threaded frame.
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Frame break Flows text to the next threaded text frame, regardless of the current text 
frame’s column setup.

Page break Flows text to the next page with a text frame threaded to the current text 
frame.

Odd page break Flows text to the next odd-numbered page with a text frame 
threaded to the current text frame.

Even page break Flows text to the next even-numbered page with a text frame 
threaded to the current text frame.

Note: If you create a break by changing paragraph settings (as in the Keep Options dialog 
box), the break precedes the paragraph that contains the setting. If you create a break 
using a special character, the break occurs immediately after the special character.

To create a column, frame, or page break:

1 Using the type tool, click to place the insertion point where you want the break to 
occur.

2 Choose Type > Insert Break Character, and then choose a break character from the 
submenu.

You can also create breaks by using the Enter key on the numeric keypad. For a 
column break, press Enter; for a frame break, press Shift+Enter; and for a page break, 

press Ctrl+Enter (Windows) or Command+Enter (Mac OS).

To remove a break character:

1 If necessary, choose Type > Show Hidden Characters.

2 Select and delete the break character.

Editing and updating a linked text file
When you place text, the name of the text file appears in the Links palette, which you 
can use to update and manage the file. When you update a linked text file, any editing or 
formatting changes applied within InDesign are lost. Because of this risk, linked text files 
are not automatically updated when the original file is edited. However, you can easily 
update the linked file using the Links palette. For more information, see “Managing links 
and embedded graphics” on page 235.

To edit a linked text file in its original application:

1 If necessary, choose Window > Links to open the Links palette.

2 In the Links palette, select the text file you want to edit, and then choose Edit Original 
in the Links palette menu.

To update a linked text file:

1 If necessary, choose Window > Links to open the Links palette.

2 In the Links palette, select the text file you want to update. If the original has been 
edited since the file was placed in InDesign, an exclamation mark icon  appears to the 
right of the filename.

3 In the Links palette menu, choose Update Link.
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4 If you have applied any additional formatting to the file in InDesign, an alert message 
notifies you that all new formatting will be lost. Click OK if you want to update the 
file anyway.

To remove the link to a text file:

1 In the Links palette, select the text file.

2 Choose Embed File in the Links palette menu.

Finding and changing text
You can search for and change specific occurrences of characters, words, groups of words, 
or text formatted a certain way. You can also search for other items, including OpenType 
attributes such as fractions and swashes.

Note: If you want to list, find, and replace fonts in your document, you may want to use 
the Find Font command instead of the Find/Change command. (See “Finding and 
changing fonts” on page 94.)

Using Find/Change
You can find and change text across a selection, one or more stories, a document, or 
multiple open documents. 

To find and change text:

1 To narrow your search, do one of the following:

• To search in a story, use the type tool to click in a text frame.

• To search only within a selection, select the text you want to search.

• To search in one or more stories, use the selection tool  to select one or more frames.

2  Choose Edit > Find/Change.

3 For Search, specify the range of your search by selecting Document (searches entire 
document), All Documents (searches all open documents), Story (searches all text in the 
threaded text frames, including overset text), Stories (searches stories in all selected 
frames), To End of Story (searches from the insertion point), or Selection (searches only 
the selected text).

4 For Find What, type or paste the text you want to find. 

5 For Change To, type or paste the new text. 

Note: To search for formatting only, leave the Find What and Change To boxes blank. 
(See “Finding and changing formatted text” on page 93.)
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6 To search for tabs, spaces, and other special characters, or for unspecified or wildcard 
characters, select InDesign’s metacharacters in the pop-up menu to the right of the Find 
What box; see “Typing metacharacters for Find/Change” on page 92.

Searching for tabs, spaces, and other special characters

If you want to search for text that includes metacharacters such as em dashes or bullet 
characters, you may want to select the text first, and then paste it into the Find/

Change dialog box.

7 Select Case Sensitive or Whole Word, as desired:

• Whole Word disregards search characters when they are embedded within a 
larger word. For example, if you are searching for “any” as a whole word, InDesign disre-
gards “many.”

• Case Sensitive searches for only the word or words that exactly match the capitalization 
of the text in the Find What box. For example, a search for “PrePress” will not find 
“Prepress,” “prepress,” or “PREPRESS.”

8 Click Find Next to begin the search.

9 To continue searching, click Find Next, Change, Change All (a message indicates the 
number of changes), or Change/Find.

10 Click Done when changes are complete.

Typing metacharacters for Find/Change
Metacharacters represent a character or symbol in InDesign. Metacharacters begin with 
a caret (^). You can use the following metacharacters in the Find/Change dialog box:

Character: Enter:

Auto Page Numbering ^#

Section Marker ^x

Bullet Character ^8

Caret Character ^^

Copyright Symbol ^2

End of Paragraph ^p

Forced Line Break ^n

* Inline Graphic Marker ^g

Paragraph Symbol ^7
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* Can be entered in the Find What box only.

Finding and changing formatted text
You can use Find/Change to find and change text formatting such as styles, indents and 
spacing, and stroke and fill colors.

To find and change formatted text:

1 As necessary, follow steps 1–7 in “Using Find/Change” on page 91.

2 Click More Options to display Find Format and Change Format options.

3 Click Format in the Find Format Settings section.

Registered Trademark Symbol ^r

Section Symbol ^6

Tab Character ^t

Right Indent Tab ^y

Indent to Here ^i

Em Dash ^_

Em Space ^m

En Dash ^=

En Space ^>

Flush Space ^f

Hair Space ^|

Nonbreaking Space ^s

Thin Space ^<

* White Space (any space or tab) ^w

Discretionary Hyphen ^-

Nonbreaking Hyphen ^~

Double Left Quotation Mark ^{

Double Right Quotation Mark ^}

Single Left Quotation Mark ^[

Single Right Quotation Mark ^]

*Any Character ^?

*Any Digit ^9

*Any Letter ^$

Character: Enter:
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4 On the left side of the Find Format Settings dialog box, select a type of formatting, 
specify the format attributes, and then click OK.

Note: When you have specified formatting for your search criteria, alert icons appear 
above the Find What or Change To boxes. These icons are a reminder that formatting 
attributes have been set and that the find or change operation will be restricted 
accordingly.

5 If you want to apply formatting to the found text, click Format in the Change Format 
Settings section. Then select a type of formatting, specify the format attributes, and 
click OK.

6 Use the find and change buttons to format the text.

To quickly remove all formatting attributes in the Find Format Settings or Change 
Format Settings sections, click the Clear button.

Tips for using the Find/Change command
Use these tips to simplify the process of finding and changing text.

• Use wildcard characters in your search. For example, typing “s^?ng” in the Find What 
box searches for words beginning with an “s” and ending with “ng,” such as “sing,” 
“sang,” “song,” and “sung.”

• If you don’t get the search results you expected, make sure that you clear any 
formatting you may have included in a previous search. Also, if you have pasted text 
into the Find What or Change To boxes, nonprinting characters like tabs or returns are 
included as part of the text that is searched for or replaced.

• InDesign remembers as many as the last 15 entries in the Find What or Change To 
boxes. Click the down arrow next to these boxes to select one of your previous 
searches. However, these saved entries do not include formatting attributes.

• If the Change To box is empty and no formatting has been set, clicking Change or 
Change All will delete the occurrence of the text you found. This is an effective method 
of removing unwanted text.

• If you change your mind about replacing text, choose Edit > Undo Replace Text (or 
Undo Replace All Text).

• To find the next occurrence of a previously searched-for phrase without having to open 
the Find/Change dialog box, choose Edit > Find Next. 

Finding and changing fonts
Use the Find Font command to search for and list the fonts used throughout your 
document. You can then replace any fonts (except those in imported graphics) with any 
other fonts available on your system.

A font name is listed once for its use in the layout and listed each time in imported 
graphics. For example, if you use the same font three times in the layout and three times in 
imported graphics, it will be listed in the Find Font dialog box four times—once for all 
layout instances, and then three more times for each imported graphic.
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The Find Font dialog box displays icons to indicate the kinds of fonts or font conditions, 
such as PostScript fonts , imported images , TrueType fonts , OpenType fonts , 
and missing fonts .

Note: Use the Type > Find Font command to help ensure consistent output by analyzing 
font usage on pages and in imported graphics. To find and change specific text attributes, 
characters, or styles, use the Edit > Find/Change command instead.

To find and replace fonts in your file:

1 Choose Type > Find Font.

2 Select one or more font names in the Fonts in Document list.

3 Do one of the following:

• To find the first occurrence in the layout of the font selected in the list, click Find First. 
The text using that font moves into view. The Find First button is unavailable if the 
selected font is used in an imported graphic or if you selected multiple fonts in the list.

• To select an imported graphic that uses a font marked in the list by an imported image 
icon , click Find Graphic. The graphic also moves into view. The Find Graphic button 
isn’t available if the selected font is used only in the layout or if you selected multiple 
fonts in the Fonts in Document list.

4 To see details about a selected font, click More Info. To hide the details, click Less Info. 
The Info area is blank if you selected multiple fonts in the list.

Note: A font may be listed as Unknown if the file of the selected graphic doesn’t supply 
information about it. Fonts in bitmap graphics (such as TIFF images) won’t appear in the 
list at all because they aren’t true characters.

5 To replace a font, select the new font you want to use from the Replace With list, and do 
one of the following:

• Click Change to change just one occurrence of the selected font. This option is not 
available if multiple fonts are selected.

• Click Change/Find to change the font in that occurrence and then find the next 
instance. This option is not available if multiple fonts are selected.

• Click Change All to change all instances of the font selected in the list. 

When there are no more occurrences of a font in your file, its name is removed from the 
Fonts in Document list.

Note: To change fonts in imported graphics, use the program that originally exported the 
graphic, and then replace the graphic or update the link using the Links palette.

6 If you clicked Change, click Find Next to locate the next instance of the font.

7 Click Done.

You can open the Find Font dialog box while preflighting a document. In the Preflight 
dialog box, switch to the Fonts tab and click Find Font.
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Checking spelling
You can check the spelling in a selected range of text, in all of the text in a story, in all 
stories in a document, or in all stories in all open documents. InDesign highlights 
misspelled or unknown words, words typed twice in a row (such as “the the”), and words 
with possible capitalization errors.

When you check spelling, InDesign uses the dictionary for the languages you assigned to 
the text in your document. (See “Assigning a language” on page 124.)

To check spelling in one or more documents:

1 To narrow your spell-checking, do one of the following:

• Using the type tool, click in a text frame to check a story.

• Select text to check only the selection.

• Using the selection tool , select one or more frames to check one or more stories.

2 Choose Edit > Check Spelling.

3 For Search, specify the range of your spell-checking: Document (checks the entire 
document), All Documents (checks all open documents), Story (checks all threaded text 
frames in story, including overset text), Stories (searches stories in all selected frames), To End 
of Story (checks from the insertion point), or Selection (checks only selected text).

4 Click Start to begin checking the spelling.

5 When InDesign displays unfamiliar or misspelled words or other possible errors, choose 
an option:

• Click Ignore or Ignore All to continue spell-checking without changing a certain word. 
The word will be ignored until you restart InDesign. 

• Select a word from the Suggested Corrections list or type the correct word in the 
Change To box, and then click Change to change only that occurrence of the misspelled 
word. You can also click Change All to change all occurrences of the misspelled word in 
your document.

• Click Add to have InDesign store an acceptable but unrecognized word in the 
dictionary so that subsequent occurrences are not considered misspellings. See 
“Working with hyphenation and spelling dictionaries” on page 96.

Working with hyphenation and spelling dictionaries
By default, hyphenation and spelling rules are based on the dictionary for the language 
specified for the text. When you customize the words in a dictionary, you actually create 
exception lists of added words (words that aren’t already in the dictionary) and removed 
words (existing dictionary words you want InDesign to ignore). 

By default, hyphenation and spelling exceptions are located only in user dictionary files 
stored outside the document on the computer where InDesign is installed (dictionary 
filenames end with the extensions .udc and .not). However, you can also store exception 
lists inside any InDesign document. In addition, you can specify that the text-composition 
engine composes text using the word list stored in the external user dictionary, the word 
list stored in the current document, or both. Specify storage and composition settings in 
the Dictionary panel of the Preferences dialog box.
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Storing hyphenation and spelling exceptions inside a document makes it easier to treat 
text consistently when you move that document to other computers. For this reason, you 
can also control the location of exceptions from the Create Package Folder dialog box (see 
“Packaging files for handoff” on page 408). In contrast, storing an exception list outside 
the document makes it easier to use the same list of exceptions for multiple documents.

Changing hyphenation and spelling dictionary preferences
Use the Dictionary panel of the Preferences dialog box to specify how InDesign handles 
hyphenation and spelling dictionaries. By default, InDesign uses Proximity dictionaries to 
verify spelling and to hyphenate words. If you have installed hyphenation or spelling 
components from a different company, you can select a different vendor for each installed 
language.

To specify hyphenation and spelling preferences:

1 Choose Edit > Preferences > Dictionary (Windows and Mac OS 9), or InDesign > Prefer-
ences > Dictionary (Mac OS 10).

2 For Language, specify the language for which you want to select a different vendor of 
hyphenation or spelling components.

3 If you have installed a hyphenation component from a company other than Adobe, 
select it in the Hyphenation menu. 

4 If you have installed a spelling dictionary component from a company other than 
Adobe, select it in the Spelling menu.

5 In the Compose Using menu in the Hyphenation Exceptions menu, do one of 
the following:

• To compose text using the hyphenation exceptions list stored in the external user 
dictionary, choose User Dictionary.

• To compose text using the hyphenation exceptions list stored inside the document, 
choose Document.

• To compose text using both lists, choose User Dictionary and Document. This is the 
default setting.

6 To add the exceptions list stored in the external user dictionary to the exceptions list 
stored within the document, select Merge User Dictionary into Document. 

Note: You may want to deselect the Merge User Dictionary into Document option if you 
work with many partners or clients; for example, if you’re a service provider, you probably 
don’t want your user dictionary merged with every customer’s file.

7 To recompose all stories when certain settings are changed, select Recompose All 
Stories When Modified. Selecting this option recomposes stories when you change the 
Compose Using settings (see step 5) or when you use the Edit Dictionary command to add 
or remove words. Recompose All Stories When Modified is off by default, because recom-
posing all stories may take some time, depending on the amount of text in the document.

8 Click OK.



Using Help | Contents | Index Back 98  

Adobe InDesign Help Working with Text 

Using Help | Contents | Index Back 98  

Adding or removing words from exception word lists
Both the external dictionary and the word list inside an InDesign document can include 
a list of words you add to or remove from consideration when hyphenating or checking 
spelling. InDesign can maintain a separate set of added and removed words for each 
installed language.

To add words to a hyphenation exceptions list:

1 Do one of the following:

• If, during a spell check, InDesign displays an unfamiliar word in the Check Spelling 
dialog box, click Add to add it to your dictionary, if you like.

• Select a word and choose Edit > Dictionary. InDesign displays that word in the Word 
box; click Add.

• Choose Edit > Dictionary and type the word you want to add; click Add.

2 In the Target menu, choose the dictionary where you want to store the word. The Target 
menu lets you store the changes in the external user dictionary or in any open InDesign 
document; for more information, see “Controlling hyphenation and justification” on 
page 141.

3 In the Dictionary List menu, do one of the following:

• To modify the list of additions to the selected Target word list, choose Added Words.

• To modify the list of words that are ignored by the selected Target word list, choose 
Removed Words.

4 Click Hyphenate to see the word’s default hyphenation. Tildes (~) indicate possible 
hyphenation points.

5 If you don’t like InDesign’s hyphenation points, follow these guidelines to indicate your 
preferred hyphenation of the word:

• Type one tilde to indicate the best possible hyphenation point, or the only acceptable 
hyphenation point, in the word. 

• Type two tildes to indicate your second choice.

• Type three tildes to indicate a poor but acceptable hyphenation point.

• If you want the word never to be hyphenated, type a tilde before its first letter.

If you need to include an actual tilde in a word, type a backslash before the tilde (\~).

6 Click Add, and then click Done. InDesign adds the word to the currently selected 
Dictionary List.

Note: Remember that hyphenation points interact with the hyphenation settings in your 
documents. As a result, the word might not break where you expect it to. Control these 
settings by choosing Hyphenation in the Paragraph palette menu. (See “Adjusting hyphen-
ation” on page 141.)

To remove a word from a hyphenation exceptions list:

1 Do one of the following:

• Select a word and choose Edit > Dictionary. InDesign displays that word in the Word 
box.

• Choose Edit > Dictionary and type the word you want to add.
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2 In the Target menu, choose the dictionary from which you want to remove the word. 
The Target menu lets you choose that of the external user dictionary or that of any open 
InDesign document; for more information, see “Controlling hyphenation and justification” 
on page 141.

3 In the Dictionary List menu, do one of the following:

• To modify the list of added words in the Target word list, choose Added Words.

• To modify the list of ignored words in the Target word list, choose Removed Words.

4 In the word list, select the word and click Remove.

5 Click Done.

Using dictionaries in a workgroup
Make sure that each station in your workgroup has the same customized user dictionary 
installed, so that a document uses the same spelling and hyphenation rules regardless of 
who is working on it.

If you are using the Proximity dictionaries installed by InDesign, you can recognize the 
user dictionary file for each language by its .udc filename extension (such as usa.udc). Use 
your system Find command to locate user dictionary files and copy them from one 
workstation to another.

Make sure that all persons in the InDesign workgroup use the customized user dictionary 
installed on their workstation, not the dictionary inside a document. However, before you 
take a document to a service provider, you may want to merge the user dictionary into the 
document. (See “Changing hyphenation and spelling dictionary preferences” on page 97.)

After you update a workstation’s user dictionary, exit from and restart InDesign, or 
press Ctrl+Alt+/ (Windows) or Command+Option+/ (Mac OS) to recompose all text.

Combining text and graphics
In most cases, graphics and text have distinctly different capabilities and attributes. But 
you can make text wrap around a graphic or another text frame, embed frames inside 
other frames, and combine graphics and text in other ways.
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Creating an inline frame
With the type tool selected, you can paste or import a frame into text. Such a frame, called 
an inline frame, behaves as if it were a single character of text. An inline frame can contain 
text and graphics. You can select an inline frame with the type tool and then change its 
leading, baseline shift, and other attributes.

Inline frame embedded in text (top); when text reflows, the inline frame moves accordingly (bottom)

You can paste a text frame inside another text frame. You can even paste an inline 
frame inside another inline text frame.

To create an inline frame by pasting a frame:

1 Using the selection tool , select the frame you want to use as an inline frame. 

2 Choose Edit > Cut or Edit > Copy.

3 Using the type tool , click in a text frame where you want the inline frame to appear.

4 Choose Edit >Paste.

To create an inline frame by placing:

1 Using the type tool, click in a text frame where you want the inline frame to appear.

2 Choose File > Place.

3 Locate and select the graphics file you want to import, and then click Open. InDesign 
places the graphic as an inline frame at the insertion point.

If autoleading is turned on, you may see increased space above the line an inline 
frame is on. To remove the extra space, either resize the inline object or specify a fixed 

leading value for the surrounding lines. (See “Changing leading” on page 116.)

To adjust the position of an inline frame:

Do one of the following:

• Use the type tool to select the inline frame and then, in the Character palette, specify a 
value for Baseline Shift.

• To move the inline frame parallel to the baseline, place the insertion point before or 
after the inline frame and specify a value for Kerning.

• Use the selection tool  or direct-selection tool  to select the inline frame, and then 
drag the frame perpendicular to the baseline. You cannot drag the frame parallel to the 

�

�

�
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baseline, nor can you drag the bottom of the frame above the baseline or the top of the 
frame below the baseline.

You can resize, rotate, or otherwise transform an inline frame. (See “Arranging and 
Combining Objects” on page 256.)

Wrapping text around objects
You can wrap text around any object, including text frames, imported graphics, and 
objects you draw in InDesign. When you apply a text wrap to an object, InDesign automat-
ically creates a boundary around the object that repels text. If the object is an imported 
graphic, you can specify whether to wrap text around the image’s alpha channel or its 
Photoshop path. For more information on clipping paths, see “Working with clipping 
paths” on page 261. 

Regardless of the type of object or the text wrap method you use, you can always 
manually adjust the resulting text wrap boundary.

To set default text wrap options for all new objects, deselect all objects and then set the 
following options.

To apply a text wrap to an object:

1 If necessary, choose Window > Text Wrap to display the Text Wrap palette.

2 Using the selection tool  or direct-selection tool , select a frame—usually the image 
you want the text to wrap around.

3 In the Text Wrap palette, click the button for the desired wrap shape:

• Wrap Around Bounding Box  creates a rectangular wrap whose width and height are 
determined by the bounding box of the selected object.

• Wrap Around Object Shape , also known as contour wrapping, creates a text wrap 
boundary that is the same shape as the frame you’ve selected (plus or minus any offset 
distances you specify). Continue to the next procedure to specify contour options.

Wrap Around Bounding Box (left) and Wrap Around Object Shape (right)

• Jump Object  keeps text from appearing in any available space to the right or left of 
the frame.

• Jump to Next Column  forces the surrounding paragraph to the top of the next text 
column or text frame.

Open the case for the first time and take 
in the sights and smells of your hand-
made instrument. See the way the light 
reflects off the handrubbed satin finish. 
Breath in the perfume of the finest exotic 
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4 For the wrap offset values, type offset distances. Positive values move the wrap away 
from the edges of the frame; negative values position the wrap boundary inside the edges 
of the frame.

To apply a text wrap to items on a master page, hold down Ctrl+Shift (Windows) or 
Command+Shift (Mac OS) and click the item on the document page. With the image 

selected on the document page, apply text wrap. 

To specify text-wrap contour options for an imported graphic:

1 If necessary, choose Window > Text Wrap to display the Text Wrap palette, and select an 
imported graphic.

2 In the Text Wrap palette, click the Wrap Text Around Object Shape option, and specify 
wrap offset values as necessary.

3 To specify contour options, choose one of the following in the Type menu on the Text 
Wrap palette:

• To wrap text to the rectangle formed by the graphic’s height and width, choose 
Bounding Box.

• To generate the text wrap boundary using InDesign’s automatic edge detection, choose 
Detect Edges.

• To generate the text wrap boundary from an alpha channel saved with the image, 
choose Alpha Channel, and then choose the channel you want to use in the Alpha 
Channel menu on the Text Wrap palette. If the Alpha Channel option isn’t available, 
no alpha channels were saved with the image. InDesign automatically recognizes 
Photoshop’s default transparency (the checkerboard pattern) as an alpha channel; 
otherwise you must use Photoshop to delete the background or create and save one 
or more alpha channels with the image.

• To generate the text wrap boundary from a path saved with the image, choose 
Photoshop Path, and then choose the path you want to use in the Path menu on the 
Text Wrap palette. If the Photoshop Path option isn’t available, no named paths were 
saved with the image.

• To construct the text wrap boundary from the container frame, choose Graphic Frame.

• To use the imported image’s clipping path as the text wrap boundary, select Same as 
Clipping.

4 To let text appear inside “holes” in an imported graphic, such as a photo of a tire, select 
Include Inside Edges on the Text Wrap palette.

Include Inside Edges off (left) and on (right)

How many things can you name that are round?
a circle • an orange • the sun • a baseball • the rim of 
a glass • the end of a pipe • a button • a bubble • dots
marbles • peas • a basketball • the moon • wedding 
rings • o’s • mouth when it goes 
oooh bicycle wheels •
one of Saturn’s rings 
a a ping-pong 

paddle • the 
little black 
dots in the 
middle of 
your eye • 
a tire • the 

very end of a 
garden hose • 

the bottom of a can 
search- lights • spectacles
a camera’s lens • the earth • some 
snowflakes • a bowling ball • cherries • a roll of tape • 
headlights • the equator• a golf ball • cantalope • the 
head of a pin • a period

How many things can you name that are round?
a circle • an orange • the sun • a baseball • the rim of 
a glass • the end of a pipe • a button • a bubble • dots
marbles • peas • a basketball • the moon • wedding 
rings • o’s • mouth when it goes 
oooh bicycle wheels •
one of Saturn’s rings 
a a ping-pong 

paddle • the 
dots in the 
eye • a tire • 
garden 
tom of a 
lights • 

spectacles
a camera’s lens • 
the earth • some 
snow- flakes • a bowling 
ball • cher- ries • a roll of tape • 
headlights • the equator• a golf ball • cantalope • the 
head of a pin • a period

little black 
middle of your 

the very end of a
hose • the bot-

can • search



Using Help | Contents | Index Back 103  

Adobe InDesign Help Working with Text 

Using Help | Contents | Index Back 103  

To create an “inside out” wrap:

1 Using the selection tool or direct-selection tool, select an object, such as a compound 
path, that will allow text to wrap inside it.

2 If necessary, choose Window > Text Wrap to display the Text Wrap palette, and apply a 
text wrap, such as Object Shape, to the object.

3 Select the Invert option. Invert is commonly used with the Object Shape option.

Wrap Around Object Shape (left), and Invert option selected (right)

To change the shape of a text wrap:

1 Using the direct-selection tool, select an object that has a text wrap applied to it. If the 
text wrap boundary is the same shape as the object, the boundary is superimposed on the 
object.

2 Use the pen tool  and direction-selection tool to edit the text wrap boundary.

Editing a text wrap boundary

Justifying text wrapped around an object
To justify text next to wrap objects, select the Justify Text Next To Wrap option in Compo-
sition Preferences. This option applies to the entire document.

To justify text next to wrap objects:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 Select Justify Text Next To Wrap, and then click OK.

Tips for wrapping text
Keep these tips in mind as you work with text wraps:

• If you want to wrap text around the shape of an imported graphic, save the clipping 
path in the application where you created it, if possible. When you place the graphic in 
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InDesign, select the Apply Photoshop Clipping Path option in the Image Import 
Options dialog box. 

• Text frames inside a group ignore any text wrap you’ve applied to the group.

• To prevent the text in a frame from wrapping around text wrap boundaries, use the 
selection tool  to select the text frame and choose Object > Text Frame Options. 
Select Ignore Text Wrap, and then click OK.

• You can move the text wrap boundary anywhere you like on the current page or spread, 
and you can reshape the wrap boundary so that it looks nothing like the frame.

Creating path type
You can format text to flow along the edge of an open or closed path of any shape. Apply 
options and effects to path type: Slide it along the path, flip it over to the other side of the 
path, or use the shape of the path to distort the characters. Path type has an in port and an 
out port just like other text frames, so you can thread text to and from it.

A. Start bracket B. In port C. Center bracket D. End bracket E. Out port indicating threaded text

Keep the following points in mind as you create path type:

• The alignment setting in the Paragraph palette controls the alignment of path type.

• You can include only one line of type on a path, so any type that won’t fit on the path 
will be overset (hidden), unless you’ve threaded it to another path or text frame.

• You can apply character and paragraph options to path type. However, paragraph rules 
and paragraph spacing options have no effect on path type.

• You can’t create path type using compound paths, such as those that result from using 
the Create Outlines command.

To create path type:

1 Select the path-type tool .

2 Position the pointer on the path until a small plus sign appears next to the pointer , 
and then follow these steps:

• To type using default settings, click the path. An insertion point appears at the start of 
the path by default. If the current default paragraph settings specify an indent, or any 
alignment other than left, the insertion point may appear somewhere other than at the 
start of the path.

At the Door of the Palace
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• To confine the text to a specific portion of the path, drag along the path.

Drag along the path to determine the location of text

Note: If neither clicking nor dragging seems to work, make sure that the small plus sign 
appears next to the path-type tool.

3 Type the text you want. If you clicked to place the insertion point on the path, type will 
appear along the entire length of the path. If you dragged, type will appear only along the 
length you dragged.

Note: If the path was originally visible, it remains visible after you add type to it. To hide 
the path, select it with the selection or direct-selection tool, and then apply a fill and stroke 
of None.

To edit path-type characters:

1 Using the path-type tool, do one of the following:

• To add an insertion point, click between any two characters in the path type.

• To select characters, drag through the path type.

2 Edit the text as needed.

To delete type from a path:

1 Using the selection tool  or direct-selection tool , select one or more path-type 
objects.

2 Choose Type > Type on a Path> Delete Type from Path.

If the path text is threaded, type moves to the next threaded text frame or path-type 
object. If the path text isn’t threaded, text is deleted. The path remains, but loses any path-
type attributes—all brackets, in and out ports, and threading properties are removed.

Note: If the path’s fill and stroke is set to None, the path is invisible after you delete the 
type. To make the path visible, press the D key immediately after you choose Type > Type 
on a Path > Delete Type from Path. This applies the default fill and stroke to the selected 
path.

To change the start or end position of path type:

1 Using the selection tool , select the path type.

2 Position the pointer over the path type’s start or end bracket until a small icon appears 
next to the pointer . Do not position it over the bracket’s in port or out port.

At the
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3 Drag the start or end bracket along the path.

Position the pointer on start or end bracket; then drag to reposition boundary of path type

Note: If you apply a paragraph indent value, it’s measured from the start and end 
brackets.

To slide path type along a path:

1 Using the selection tool , select the path type.

2 Position the pointer over the path type’s center bracket until a center bracket icon 
appears next to the pointer .

3 Drag the center bracket along the path.

Note: The text won’t move if both the start and end brackets are at the ends of the path. To 
create some space for dragging text, drag the start or end bracket away from the ends of 
the path.

To control vertical alignment of path type:

1 Using the selection tool or the type tool, select the path type.

2 Choose Type > Type on a Path > Options.

3 Choose one of the following in the Align menu to specify how to align all characters to 
the path, relative to a font’s total height:

• To align by the font’s top edge, choose Ascender.

• To align by the font’s bottom edge, choose Descender.

• To align by the point halfway between the font’s ascender and descender, choose 
Center.

• To align by baselines, choose Baseline. This is the default setting.

Note: Characters without ascenders or descenders (such as a letter e) or baseline (such 
as an apostrophe) are vertically aligned with characters that have ascenders, descenders, 
and baselines. These font dimensions are permanently specified by the font designer.

4 Choose one of the following in the To Path menu to specify where to align the path to 
all characters, relative to the path’s stroke weight when drawn left to right:

• To align the path at the top edge of its stroke, choose Top.

• To align the path at the bottom edge of its stroke, choose Bottom.
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• To align the path to the stroke’s center, choose Center. This is the default setting.

For more control over vertical alignment, use the Baseline Shift option in the 
Character palette. For example, type a negative value in the Baseline Shift text box to 

lower the type. 

To flip path type by dragging:

1 Click the selection tool .

2 Position the pointer over the path type’s center bracket until a center bracket icon 
appears next to the pointer .

3 Drag the center bracket across the path.

Position pointer on center bracket, and then drag across path to flip type

To flip path type using a dialog box:

1 Using the selection tool or the type tool, select the path type.

2 Choose Type > Type on a Path > Options.

3 Select the Flip option, and then click OK.

To apply a path type effect:

1 Using the selection tool or the type tool, select the path type.

2 Choose Type > Type on a Path > Options.

3 Choose one of the following in the Effect menu, and then click OK:
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• To keep the center of each character’s baseline parallel to the path’s tangent, choose 
Rainbow. This is the default setting because it looks natural.

A. Rainbow effect B. Skew effect C. 3D Ribbon effect D. Stair Step effect E. Gravity effect

• To keep characters’ vertical edges perfectly vertical regardless of the path shape, 
while letting characters’ horizontal edges follow the path, choose Skew. The resulting 
horizontal distortion is useful for text that appears to follow waves or go around a 
cylinder, as on a beverage can label.

• To keep characters’ horizontal edges perfectly horizontal regardless of the path 
shape, while keeping each character’s vertical edge perpendicular to the path, choose 
3D Ribbon.

• To keep the left edge of each character’s baseline on the path without rotating any 
characters, choose Stair Step.

• To keep the center of each character’s baseline on the path while keeping each vertical 
edge in line with the path’s center point, choose Gravity. You can control this option’s 
perspective effect by adjusting the arc of the text’s path.

To tighten character spacing around sharp turns and acute angles:

1 Using the selection tool or the type tool, select the path type.

2 Choose Type > Type on a Path > Options.
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3 For Spacing, type a value in points. Higher values remove the extra space from between 
characters positioned on sharp curves or angles.

Path type before (left) and after (right) applying spacing adjustment

Note: The Spacing value compensates for the way characters fan out around a curve or 
sharp angle. It has no effect on characters positioned on straight segments. To change 
spacing of characters anywhere along the path, select them, and then apply kerning 
or tracking.

Working with text import filters
You can import text from other InDesign documents, word-processing and spreadsheet 
applications, text or table editors, or any application that can export text in the text-only, 
RTF, or ASCII format. In Windows, importable file formats are listed in the Format menu in 
the Place dialog box.

To open PageMaker or QuarkXPress documents, see “Opening PageMaker and QuarkX-
Press files in InDesign” on page 12.

About import filters
InDesign imports most character and paragraph formatting attributes from text files but 
ignores most page-layout information, such as margin and column settings (which you 
can set in InDesign).

The import options appear when you select Show Import Options in the Place dialog box. 
If this option is deselected, InDesign uses the import options last used for a similar 
document type. The options you set remain in effect until you change them.

If InDesign cannot find a filter that recognizes a file by either its file type or file extension, 
an alert message tells you that. For best results in Windows, use the standard extension 
(such as .doc, .txt, .rtf, or .xls) for the type of file you’re importing. You may need to open 
the file in its original application and save it in a different format.

If your word-processing application supports character and paragraph styles and if 
InDesign has an import filter for the application, you can import styles when you import 
the text file. InDesign generally imports all formatting information specified in the word-
processing application, except information for word-processing features not available 
in InDesign.

InDesign adds imported styles to its list of styles for the document. If an imported style has 
the same name as an existing InDesign style, InDesign overrides the imported style with 
the existing style.
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Importing text files
When placing a file, you can set import options for recent versions of Microsoft Word. If 
you are placing a file from a different word-processing application or from Word 7.0 or 
earlier, open the file in its original application and save it in a compatible Word format or in 
RTF format, which preserves most formatting.

For information on which features are imported, see the Filters ReadMe file located in the 
InDesign 2.0 folder.

To import a file and set import options:

1 Choose File > Place.

2 Do one of the following:

• Make sure that Show Import Options is selected, and then double-click the file you 
want to import.

• Hold down the Shift key and double-click the text file you want to import.

3 Set options as explained in “Import options for Microsoft Word” on page 110 and 
“Microsoft Excel import options” on page 111. Then click OK.

Note: An alert message notifies you if your document calls for unavailable fonts. You may 
want to add these missing fonts to your system.

Import options for Microsoft Word
InDesign does not support Microsoft Word 7.0 and earlier. To import a file from an earlier 
version of Word, either save the file in RTF format, or open it in a more recent version of 
Word, and then save it in an importable format.

If you select Show Import Options when placing a Microsoft Word file, you can choose 
from these options:

Table of Contents Text Imports the table of contents as part of the text in the story. 
These entries are imported as text only.

Index Text Imports the index as part of the text in the story. These entries are imported as 
text only.

Footnotes/Endnotes Imports footnotes and endnotes as part of the text at the end of 
the story.

User Defined Page Breaks To Determines how page breaks from the Word file are 
formatted in InDesign. You can select Page Breaks, Column Breaks, or No Break.

Text-file import options
If you select Show Import Options when placing a text file, you can choose from 
these options:

Character Set Specifies the computer language character set, such as ANSI or ASCII, that 
was used to create the text file. The default selection is the character set that corresponds 
to the default language of InDesign.

Platform Specifies whether the file was created in Windows (PC) or Mac OS (Macintosh).

Set Dictionary To Specifies the dictionary to be used by the imported text.



Using Help | Contents | Index Back 111  

Adobe InDesign Help Working with Text 

Using Help | Contents | Index Back 111  

Extra Carriage Returns Specifies how InDesign imports extra paragraph returns. Choose 
Remove at End of Every Line or Remove Between Paragraphs. If you select either of these, 
you can select Keep Tables, Lists and Indents As Is to preserve the extra paragraph returns 
associated with tables, lists, and indents.

Extra Spaces Replaces a specified number of spaces with a tab.

Microsoft Excel import options
InDesign does not support versions of Microsoft Excel 7.0 and earlier. To import a file from 
an earlier version of Excel, open the file in a more recent version of Excel, and then save it 
in an importable format.

If you select Show Import Options when placing a Microsoft Excel file, you can choose 
from these options:

View Specifies whether to import any stored custom or personal views, or to ignore the 
views.

Sheet Specifies the worksheet you want to import.

Cell Range Specifies the range of cells, using a colon (:) to designate the range (such as 
A1:G15). If there are named ranges within the worksheet, these names appear in the Cell 
Range menu.

Apply Default Spreadsheet Style Applies Excel’s default style settings for the spread-
sheet to the imported cells. If you select this option, the Cell Alignment and Decimal 
Places options are disabled.

Cell Alignment Specifies the cell alignment for the imported document. 

Decimal Places Specifies the number of decimal places. This option is available only if 
you select Decimal Cell Alignment.

Show Hidden Cells Includes any cells formatted as hidden cells in the Excel spreadsheet.

Tagged-text import options
You can import (or export) a text file capable of taking advantage of InDesign’s formatting 
capabilities by using the tagged text format. Tagged-text files are text files containing 
information describing the formatting you want InDesign to apply. Properly tagged 
text can describe almost anything that can appear in an InDesign story, including all 
paragraph-level attributes, character-level attributes, and special characters.

For information on specifying tags, open the Tagged Text.PDF document, which is located 
in the Tagged Text folder in the Adobe Technical Info folder on the InDesign CD.

The following options are available when you import a tagged-text file and select Show 
Import Options in the Place dialog box.

If Text Style Conflicts Use Specifies which character or paragraph style to apply when 
there is a conflict between the style in the tagged-text file and the style in your InDesign 
document. Select Publication Definition to use the definition that already exists for that 
style in the InDesign document. Select Tagged File Definition to use the style as defined 
in the tagged text. This creates another style name, with “copy” appended to it in the 
Style palette.

Show List of Problem Tags Before Place Displays a list of unrecognized tags. If a list 
appears, you can choose to cancel or continue the import. If you continue, the file may not 
look as expected.
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Exporting text
You can save all or part of an InDesign story in file formats that you can open later in other 
applications. Each story in a document exports to a separate document.

InDesign can export text in several file formats, which are listed in the Export dialog box. 
The formats listed are used by other applications, and they may retain many of the type 
specifications, indents, and tabs set in your document. 

To export a story:

1 Using the type tool , click in the story you want to export.

2 Choose File > Export.

3 Specify a name and location for the exported story, and select a text file format under 
Save as Type.

If you don’t see a listing for your word-processing application, you may need to save the 
document in a format the application can import, such as RTF. If your word-processing 
application doesn’t support any other InDesign export formats, use a text-only format. 
Note, however, that exporting in text-only format removes all character attributes from 
the text.

To retain all formatting, use InDesign’s Tagged Text export filter. Refer to the Tagged 
Text.PDF document on the InDesign CD.

4 Click Save to export the story in the format you’ve selected.
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Setting Type

Formatting characters
The Character palette contains the basic options for formatting individual characters in 
your documents. Values you enter are precise to 0.001 of a point.

A. Font Family B. Type Style C. Font Size D. Kerning  E. Vertical Scale F. Baseline Shift  
G. Palette menu  H. Leading I. Tracking J. Horizontal Scale K. Skew  L. Language

To format characters:

1 Select the type tool .

2 Do one of the following:

• Select a range of text you want to format.

• Click in a frame to format the next text you type.

• To set the formatting for all future text frames that you’ll create in the current 
document, make sure that the insertion point is not active and that nothing is selected.

3 If the Character palette is not already visible, choose Type > Character to display it.

To format all text in the story, use the selection tool to select the text frame, and then 
use the Character palette or Type menu commands to format the text.

4 Specify settings as explained in the following topics.

About fonts
A font is a complete set of characters—letters, numbers, and symbols—that share a 
common weight, width, and style, such as 10-pt Adobe Garamond Bold. 

Typefaces (often called type families or font families) are collections of fonts that share an 
overall appearance, and are designed to be used together, such as Adobe Garamond.

A type style is a variant version of an individual font in a font family. Typically, the Roman or 
Plain (the actual name varies from family to family) member of a font family is the base 
font, which may include type styles such as regular, bold, semibold, italic, and bold italic. 
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Installing fonts
You can make fonts available in InDesign by copying the font files into the Fonts folder 
inside the InDesign 2.0 folder on your hard drive. (In Mac OS, you can even make Windows 
fonts available by copying the font files into the Fonts folder.) Note that fonts in the Fonts 
folder will be available only to InDesign.

If you have Adobe Type Manager (ATM) or another font management application on your 
system, see its documentation for help on installing fonts.

Selecting a font
When you specify a font, you can select the font family and its type style independently. 
When you change from one font family to another, InDesign attempts to match the 
current style with the style available in the new font family. For example, Arial Bold would 
change to Times Bold when you change from Arial to Times. If a corresponding style does 
not exist in the new family, InDesign marks the style as missing. (See “Handling missing 
fonts” on page 125.)

When you apply a bold or italic style to type, InDesign applies the face specified by the 
font. In most cases, the specific version of bold or italic are applied as expected. However, 
some fonts may apply a bold or italic variation that isn’t exactly labeled bold or italic, 
respectively. For example, some font designers specify that when you apply bold to a font, 
the semibold variation is applied. 

To best preserve the font designer’s intentions, InDesign does not “synthesize” many type 
faces, such as shadow or outline, that are not part of the original font. However, for some 
fonts, InDesign provides additional faux styles (faux bold and faux italic) that can make any 
font wider or slanted. These faux styles are available even if true bold and italics are 
available, which means you can make a bold font thicker or an italic font more slanted. 
Note that using these faux styles may subvert a font designer’s intentions.

To select a font family or style:

Do any of the following:

• In the Character palette, select a font in the Font Family menu or a style in the Type Style 
menu. (In Mac OS, you can select type styles in the Font Family submenus.)

• In the Character palette, click in front of the font family name or type style name (or 
double-click its first word) and type in the first few characters of the name you want. As 
you type, InDesign displays font family or type style names that match the characters 
you’ve typed.

• Choose a font in the Type > Font menu. Note that you choose both a font family and a 
type style when you use this menu.

To specify type size:

Do any of the following:

• In the Character palette, choose the desired size in the Size menu .

• Select the existing size and type a new value.

• Choose a size in the Type > Size menu. Choosing Other lets you type a new size in the 
Character palette.

• Right-click (Windows) or Control-click (Mac OS), and then choose a size in the 
Size menu. 
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You can specify any type size from 0.1 to 1296 points (the default is 12 points), in 0.001-
point increments.

About OpenType fonts
OpenType fonts may include a number of features, such as swashes and discretionary 
ligatures, that aren’t available in current PostScript and TrueType fonts. In addition, 
OpenType fonts provide alternate glyphs for many characters, which you can insert using 
the Glyphs palette. For information on inserting alternate glyphs and highlighting substi-
tuted glyph characters, see “Inserting glyphs” on page 87.

Regular (left) and OpenType (right) A. Ordinals  B. Discretionary ligatures C. Swashes

InDesign includes fonts from the following OpenType families: Adobe Garamond Pro, 
Adobe Caslon Pro, and Caflisch Script Pro. These fonts are located in the Adobe 
OpenType Fonts folder in the Goodies folder on the InDesign Application CD. For infor-
mation on installing these fonts, see the OpenType User Guide.PDF file in the OpenType 
User Guides folder.

When you use an OpenType font for your text, you can select the following OpenType 
features. Note that OpenType fonts vary greatly in the number of type styles and kinds of 
features they offer. Square brackets [ ] indicate a feature not supported by the currently 
selected font.

Discretionary Ligatures Font designers may include optional ligatures that should not 
be turned on in all circumstances. Selecting this option allows these additional optional 
ligatures to be used, if they are present. For more information on ligatures, see “Using 
ligatures” on page 124.

Fraction Numbers separated by a slash (such as 1/2) are converted to a fraction (such as 
1/2), when fractions are available.

Ordinal Ordinal numbers such as 1st and 2nd are formatted with superscript letters (1st 
and 2nd), when ordinals are available. Letters such as the superscript a and o in the Spanish 
words segunda (2a) and segundo (2o) are also typeset properly.

Swash When they are available, regular and contextual swashes, which may include 
alternate caps and end-of-word alternatives, are provided.

Titling Alternatives When they are available, characters used for uppercase titles are 
activated. In some fonts, selecting this option for text formatted in both uppercase and 
lowercase letters can yield undesired effects.

Contextual Alternatives When they are available, contextual ligatures and connecting 
alternates are activated. This option is turned on by default.

A
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All Small Caps For fonts that include real small caps, selecting this option turns all 
characters into small caps. For more information, see “Applying all caps or small caps” on 
page 122.

Superscript/Superior & Subscript/Inferior Some OpenType fonts include raised or 
lowered glyphs that are sized correctly relative to the surrounding characters.

Numerator & Denominator Some OpenType fonts include raised or lowered glyphs that 
are sized correctly relative to the surrounding characters.

Tabular Lining Full-height figures all of the same width are provided. This option is 
appropriate in situations where numbers need to line up from one line to the next, as 
in tables.

Proportional Oldstyle Varying-height figures with varying widths are provided. This 
option is recommended for a classic, sophisticated look in text that doesn’t use all caps.

Proportional Lining Full-height figures with varying widths are provided. This option is 
recommended for text that uses all caps.

Tabular Oldstyle Varying-height figures with fixed, equal widths are provided. This 
option is recommended when you want the classic appearance of old-style figures, but 
need them to align in columns, as in an annual report.

Default Figure Style Figure glyphs use the default figure style of the current font.

To select OpenType font attributes:

1 In the Character palette, make sure that an OpenType font is selected.

2 Choose OpenType in the Character palette menu, and then select an OpenType 
attribute, such as Discretionary Ligatures or Fractions. Square brackets [ ] indicate a feature 
not supported by the currently selected font.

Using or modifying multiple master fonts
Multiple master fonts are customizable Type 1 fonts whose typeface characteristics are 
described in terms of variable design axes such as weight, width, style, and optical size. 

Some multiple master fonts include an optical size axis, which lets you use a font specifi-
cally designed for optimal readability at a particular size. Generally, the optical size for a 
smaller font, such as 10 point, is designed with heavier serifs and stems, wider characters, 
less contrast between thick and thin lines, taller x height, and looser spacing between 
letters than the optical size for a larger font, such as 72 point. 

To use a multiple master font’s optical size:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 Select Automatically Use Correct Optical Size, and then click OK.

Changing leading
The vertical space between lines of type is called leading. Leading (rhymes with “sledding”) 
is measured from the baseline of one line of text to the baseline of the line above it. 
Baseline is the invisible line on which most letters—that is, those without descenders—sit.

The default auto-leading option sets the leading at 120% of the type size (for example, 
12-point leading for 10-point type). When auto-leading is in use, InDesign displays the 
leading value in parentheses in the Leading menu of the Character palette.
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By default, leading is a character attribute, which means that you can apply more than one 
leading value within the same paragraph. The largest leading value in a line of type deter-
mines the leading for that line. However, you can select a preferences option so that 
leading applies to the entire paragraph, instead of to text within a paragraph.

To specify leading:

Do any of the following:

• In the Character palette, choose the leading you want in the Leading menu .

• Select the existing leading value and type a new value. You can type leading values 
from 0 to 5000 points in 0.001-point increments.

You can also adjust vertical space by aligning text to the baseline grid. (See “Aligning 
paragraphs to a baseline grid” on page 127.)

To change the default auto-leading percentage:

1 Choose Type > Paragraph to display the Paragraph palette.

2 Choose Justification in the Paragraph palette menu.

3 For Auto Leading, specify a new default percentage. The minimum value is 0%, and the 
maximum value is 500%.

To change the preferences setting so that leading applies to the entire paragraph:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 Select Apply Leading to Entire Paragraph, and then click OK.

Note: When you use a character style to apply leading to text, the leading affects only the 
text to which the style is applied, not the entire paragraph, regardless of whether the 
Apply Leading to Entire Paragraph option is selected.

About kerning and tracking
Kerning is the process of adding or subtracting space between specific pairs of characters. 
Tracking is the process of loosening or tightening a block of text. 

You can automatically kern type using metrics kerning or optical kerning. Metrics kerning 
uses kern pairs, which are included with most fonts. Kern pairs contain information about 
the spacing of specific pairs of letters. Some of these are: LA, P., To, Tr, Ta, Tu, Te, Ty, Wa, WA, 
We, Wo, Ya, and Yo. InDesign uses metrics kerning by default so that specific pairs are 
automatically kerned when you import or type text.
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Some fonts include robust kern-pair specifications. However, when a font includes only 
minimal built-in kerning or none at all, or if you use two different typefaces or sizes in one 
or more words on a line, you may want to use the optical kerning option. Optical kerning 
adjusts the spacing between adjacent characters based on their shapes. 

Before applying the optical kerning option to the “W”  and “a” pair (top), and after (bottom)

You can also use manual kerning, which is ideal for adjusting the space between two 
letters. Tracking and manual kerning are cumulative, so you can first adjust individual pairs 
of letters, and then tighten or loosen a block of text without affecting the relative kerning of 
the letter pairs.

A. Original B. Kerning applied between “W” and “a”  C. Tracking applied

When you click to place the insertion point between two letters, InDesign displays kerning 
values in the Character palette. Metrics and optical kerning values (or defined kern pairs) 
appear in parentheses.

Similarly, if you select a word or a range of text, InDesign displays the tracking values in the 
Character palette.

Adjusting kerning and tracking
You can apply kerning, tracking, or both to selected text. Tracking and kerning are both 
measured in 1/1000 em, a unit of measure that is relative to the current type size. In a 6-
point font, 1 em equals 6 points; in a 10-point font, 1 em equals 10 points. Kerning and 
tracking are strictly proportional to the current type size.
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You can also directly adjust the kerning between words only, by using keyboard shortcuts. 
Word kerning isn’t the same as the Word Spacing option in the Justification dialog box; 
word kerning changes the kerning value only between a specific word’s first character and 
the word space preceding that character. The amount of the word kerning adjustment is 
the same as the Kerning value in the Units & Increments Preferences dialog box. When you 
press the shortcut and hold down the Shift key, the kerning amount is the Kerning prefer-
ences value multiplied by 5.

To use a font’s built-in kerning information for selected text:

In the Character palette, select Metrics in the Kerning  menu. Metrics is the default.

To automatically adjust the spacing between selected characters based on 
their shapes:

In the Character palette, select Optical in the Kerning menu. 

To adjust kerning manually:

1 Using the type tool, click to place an insertion point between two characters.

Note: If a range of text is selected, you can’t manually kern the text (you can choose only 
Metrics, Optical, or 0). Instead, use tracking.

2 Do any of the following:

• In the Character palette, type or select a numeric value in the Kerning menu. 

• Press Alt+Left/Right Arrow (Windows) or Option+Left/Right Arrow (Mac OS) to 
decrease or increase the kerning between two characters. When you kern using these 
shortcuts, the increment used is 1/50 of the em space for the current type size. Holding 
down Ctrl or Command when you use these keystrokes multiplies the kerning 
increment value by 5 with each keystroke.

To change the default kerning increment value:

1 Choose Edit > Preferences > Units & Increments (Windows and Mac OS 9), or InDesign > 
Preferences > Units & Increments (Mac OS 10).

2 Type a new value for the Kerning option and click OK.

To turn off kerning for selected text:

In the Character palette, type 0 or choose 0 in the Kerning menu.

You can also press Alt+Ctrl+Q (Windows) or Opt+Command+Q (Mac OS) to reset kerning 
and tracking. When you do so, kerning is set to Metrics, regardless of which kerning option 
was previously applied.

To adjust kerning between words only:

With the type tool , select a range of text, and do one of the following:

• To add space between selected words, press Alt+Ctrl+\ (Windows) or 
Option+Command+\ (Mac OS).

• To remove space between selected words, press Alt+Ctrl+Backspace (Windows) or 
Option+Command+Delete (Mac OS).

• To multiply the kerning adjustment by 5, hold down Shift as you press the keyboard 
shortcut.
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To adjust tracking:

1 Select a range of characters.

2 In the Character palette, type or select a numeric value for Tracking .

Scaling type
You can specify the proportion between the height and width of the type, relative to the 
original width and height of the characters. Unscaled characters have a value of 100%. 
Some type families include a true expanded font, which is designed with a larger horizontal 
spread than the plain type style. Scaling distorts the type, so it is generally preferable to 
use a font that is designed as condensed or expanded, if one is available.

Horizontally scaled font (left) and true expanded font (right)

When you scale a text frame using the scale tool, the Scale dialog box, or the Transform 
palette, you can determine whether the appearance of text is scaled, or whether text 
attributes are adjusted; see “Scaling type attributes” on page 120. 

To adjust vertical or horizontal scaling of selected text:

In the Character palette, type a numeric value to change the percentage of Vertical 
Scaling  or Horizontal Scaling .

Scaling type attributes
Use the Adjust Text Attributes When Scaling text preferences option to determine whether 
the appearance of text is scaled, or whether text attributes are adjusted when you scale a 
text frame.

For example, suppose you double the scale of a text frame that has 12-point type and a 2-
pica tab setting. If this option is turned on when you scale by 200%, the text will be 
formatted in 24-point type with a 4-pica tab setting; scaling values will return to 100% in 
the Transform palette. If this option is turned off when you double the scale, the effective 
size of text doubles, but text is still formatted in 12-point type and a 2-pica tab setting. For 
the type style, the Character palette displays the font size as 12pt(24).

The Adjust Text Attributes When Scaling option is turned on by default; if you want to use 
the same scaling behavior used in InDesign 1.5 and earlier, deselect this option. If you 
want to scale text attributes rather than scaling the appearance of text, use the Scale Text 
Attributes command.

Note: The Adjust Text Attributes When Scaling option applies only to text frames scaled 
after the option is turned on. This option does not apply to existing text frames that were 
scaled when the option was turned off. Use the Scale Text Attributes command to adjust 
text attributes based on scaling.
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To turn off the Adjust Text Attributes When Scaling preferences option:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 Deselect Adjust Text Attributes When Scaling, and then click OK. 

To scale text attributes:

1 Using the selection tool, select the text frame that has been scaled.

2 Choose Scale Text Attributes in the Transform palette menu. Text attributes are adjusted 
based on the scaling percentage; scaling options in the Transform palette revert to 
100% scale.

Applying baseline shift
Use Baseline Shift to move a selected character up or down relative to the baseline of the 
surrounding text. This option is especially useful when you’re hand-setting fractions or 
adjusting the position of inline graphics.

Baseline shift values applied to a picture font

To apply baseline shift:

In the Character palette, type a numeric value for Baseline Shift . Positive values move 
the character’s baseline above the baseline of the rest of the line; negative values move it 
below the baseline.

To increase or decrease the value, click in the Baseline Shift box, and then press the Up 
or Down Arrow key. Hold down Shift while you press the Up or Down Arrow key to 

change the value in greater increments. 

To change the default increment for baseline shift:

1 Choose Edit > Preferences > Units & Increments (Windows and Mac OS 9), or InDesign > 
Preferences > Units & Increments (Mac OS 10).

2 For Baseline Shift, specify a value and click OK.

Skewing type
You can distort your type by slanting or skewing it to produce a special effect. However, 
note that applying an angle to type does not produce true italic characters.

To skew type:

In the Character palette, type a numeric value for Skewing . Positive values slant type to 
the right; negative values slant type to the left.

- 6  - 4 - 2 0 2 4 6
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Applying all caps or small caps
InDesign can automatically change the case of selected text. When you format text as 
small caps, InDesign automatically uses the small-cap characters designed as part of 
the font, if available. Otherwise, InDesign synthesizes the small caps using scaled-down 
versions of the regular capital letters. The size of small caps is set in the Text Preferences 
dialog box.

Before and after setting BC and AD in small caps to complement old-style numerals 
and surrounding text

If you select All Caps or Small Caps in an OpenType font, InDesign creates more elegant 
type. For example, when All Caps is selected, InDesign shifts certain punctuation marks 
and makes other typographic improvements. In addition, you may want to apply the All 
Small Caps attribute; see “About OpenType fonts” on page 115.

To change the case of selected text:

Choose All Caps or Small Caps in the Character palette menu. If the text was originally 
typed in all caps, selecting Small Caps will not change the text.

Note: Applying Small Caps or All Caps to text does not change the case, only the 
appearance. For example, if you type “spiders” in your document and then apply All Caps, 
using Find/Change (with Case Sensitive selected) to search for “SPIDERS” will not find the 
instance of “spiders” to which All Caps was applied.

To specify the size for synthesized small caps:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 For Small Caps, type a percentage of the original font size for text to be formatted as 
small caps. (The default value is 70%.) Then click OK.

Changing capitalization
The Change Case command lets you change the case setting of selected text. The Change 
Case command is different than All Caps formatting in that it actually changes the under-
lying characters instead of merely changing the format appearance.

If you’re using an OpenType font, you may want to take advantage of All Caps formatting 
to create more elegant type; see “Applying all caps or small caps” on page 122.

To change the capitalization of selected text:

Choose one of the following in the Type > Change Case submenu:

• To change all characters to lowercase, choose Lowercase.
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• To capitalize the first letter of each word, choose Title Case.

• To capitalize the first letter of each sentence, choose Sentence Case.

Note: The Sentence Case command assumes that the period (.), exclamation point (!), and 
question mark (?) characters mark the ends of sentences. Applying Sentence Case may 
cause unexpected case changes when these characters are used in other ways, as in abbre-
viations, filenames, or Internet URLs. In addition, proper names may become lowercase 
when they should be uppercase.

• To change all characters to uppercase, choose Uppercase.

Making characters superscript or subscript
When you choose Superscript or Subscript, InDesign applies a predefined baseline shift 
value and a predefined type size to the selected text. 

The values applied are percentages of the current font size and leading, and are based on 
settings in the Text Preferences dialog box. These values do not appear in the Baseline 
Shift or Size boxes of the Character palette when you select the text.

If you’re using an OpenType font, you may want to take advantage of the OpenType 
Superscript & Subscript and Numerator & Denominator attributes to create more elegant 
type; see “About OpenType fonts” on page 115.

To make selected type superscript or subscript:

Choose Superscript or Subscript in the Character palette menu.

To specify point size and shift increment for subscripts and superscripts:

1 Choose Edit > Preferences > Text (Windows and Mac OS 9), or InDesign > Preferences > 
Text (Mac OS 10).

2 For Size, type a percentage of the font size for superscripted and subscripted text.

3 For Position, type a percentage of the regular leading to specify how much the super-
script and subscript text will move. Then click OK.

Applying underline and strikethrough
The weight of an underline depends on the size of the type; the weight of a strikethrough 
is a half point.

To apply an underline or a strikethrough to selected text:

Choose Underline or Strikethrough in the Character palette menu.
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Using ligatures 
InDesign can automatically insert ligatures, which are typographic replacement 
characters for certain letter pairs, such as “fi” and “fl,” when they are available in a given 
font. The characters that InDesign uses when the Ligature option is selected appear and 
print as ligatures, but are fully editable, and do not cause the spell checker to flag a 
word erroneously.

Individual characters (top) and ligature combinations (bottom)

With OpenType fonts, when you choose Ligatures in the Character palette menu, InDesign 
produces any standard ligature defined in the font, as determined by the font designer. 
However, some fonts include more ornate, optional ligatures, which can be produced 
when you choose the Discretionary Ligatures command; see “About OpenType fonts” on 
page 115.

To apply ligatures to selected letter pairs:

Select Ligatures in the Character palette menu.

Changing the color and gradient of type
You can apply colors and gradients to the stroke and fill of characters, and continue to edit 
the text.

When applying color to the text rather than the container, make sure that you select the 
Formatting Affects Text icon  in the toolbox or in the Swatches palette. (See “Applying 
color” on page 302.)

To create reverse type, you can change the text fill color to white or [Paper] and the 
frame’s fill color to a dark color. You can also create reverse type by using a paragraph 

rule behind text. (See “Adding rules above or below paragraphs” on page 130.)

Assigning a language
InDesign uses Proximity language dictionaries for both spelling and hyphenation. These 
dictionaries let you specify a different language for as little as a single character of text. 
Each dictionary contains hundreds of thousands of words with standard syllable breaks. 
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You can customize language dictionaries to ensure that any unique vocabulary you use is 
recognized and treated correctly. (See “Working with hyphenation and spelling dictio-
naries” on page 96.)

A. “Glockenspiel” in English B. “Glockenspiel” in Traditional German  
C. “Glockenspiel” in Reformed German

To assign a language dictionary to selected text:

In the Character palette, choose the appropriate dictionary in the Language menu.

To choose a new default language:

Do one of the following:

• To change the default dictionary used in InDesign, choose the language with no 
documents open.

• To change the default dictionary for a specific document, choose Edit > Deselect All, 
and then choose the language.

Handling missing fonts
When you open or place documents that include fonts not installed on your system, an 
alert message appears, indicating which fonts are missing. If you select text that uses a 
missing font, the Character palette indicates that this font is missing by displaying 
[Missing] in the font style pop-up menu.

InDesign substitutes missing fonts with available matching fonts. When this happens, you 
can select the text and apply any other available font. Missing fonts for which others have 
been substituted will appear at the top of the Type > Font menu in a section marked 
“Missing Fonts.” By default, text formatted with missing fonts appears in pink highlighting.

To make missing fonts available in InDesign:

Do any of the following:

• Install the missing fonts on your system.

• Place the missing fonts in the Fonts folder, which is located in the InDesign 2.0 folder. 
Fonts in this folder are available only to InDesign.

• Activate the missing fonts using ATM Deluxe or another font management application.

To highlight substituted fonts in your document:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 Select Substituted Fonts, and then click OK.
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If this option is selected, text formatted with missing fonts appears in pink highlighting.

Formatting paragraphs
Use the Paragraph palette for attributes that apply to an entire paragraph.

A. Alignment and justification buttons B. Left Indent  C. First Line Left Indent D. Space Before  
E. Drop Cap Number of Lines F. Palette menu G. Justify All H. Right Indent I. Align to Baseline 
Grid J. Space After K. Drop Cap One or More Characters

To apply any kind of paragraph formatting, you don’t need to select an entire paragraph—
selecting any word or character, or placing the insertion point in a paragraph will do. 

To format paragraphs:

1 Select the type tool .

2 Do one of the following:

• Click in a paragraph to position the insertion point.

• Make a selection within a range of paragraphs.

• To set paragraph formatting for future text frames, make sure that the insertion point is 
not active and that nothing is selected.

Note: When you press Enter or Return in text, you create a new paragraph with the same 
formatting as the previous paragraph. When you create a new text frame and start typing, 
you create a paragraph that uses the document’s default paragraph formatting.

3 Do one of the following:

• If necessary, choose Type > Paragraph to display the Paragraph palette.

• If necessary, choose Type > Tabs to display the Tabs palette.

4 If the options you want in the Paragraph palette do not appear, choose Show Options in 
the Paragraph palette menu.

To format all text in the story, use the selection tool to select the text frame, and then 
use the Paragraph palette to format the text.

5 Specify settings as explained in the following topics.

About text alignment
Text can be aligned with one or both edges (or insets) of a text frame. Text is said to be 
justified when it is aligned with both edges. To align text vertically within a text frame, see 
“Aligning and justifying text vertically” on page 128.
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You can choose to justify all text in a paragraph excluding the last line (Justify Left or 
Justify Right), or you can justify text in a paragraph including the last line (Justify All). 
When you have only a few characters on the last line, you may want to use a special end of 
story character and create a flush space. (See “Using a flush space with justified text” on 
page 145.)

Justify Left (left) and Justify All (right)

When you justify all lines of text and you are using the Adobe Paragraph Composer, 
InDesign shifts text from line to line to ensure that the paragraph has consistent text 
density and is visually appealing; see “About composition methods” on page 140. To fine-
tune spacing after justifying text, see “About spacing in justified text” on page 143. 

To change paragraph alignment:

In the Paragraph palette, click an alignment button.

If you want the left side of a line of text to be left-aligned and the right side to be right-
aligned, position the insertion point where you want to right-align the text, press Tab, 

and then right-align the rest of the line.

Changing space above or below paragraphs
You can control the amount of space between paragraphs. If a paragraph begins at the 
top of a column or frame, InDesign does not insert extra space before the paragraph. In 
such a case, you can increase the leading of the first line of the paragraph or increase the 
top inset of the frame; see “Setting text frame properties” on page 83.

To adjust space above or below a paragraph:

In the Paragraph palette, adjust the appropriate values for Space Before  and Space 
After .

Aligning paragraphs to a baseline grid
The baseline grid represents the leading for body text in a document. You can use 
multiples of this leading value for all elements of the page to ensure that text always lines 
up between columns and from page to page. For example, if the body text in your 
document is 12-point leading, you could make your heading text 18-point leading and 
add 6 points of space before the paragraphs that follow the headings.

Using a baseline grid ensures consistency in the location of text elements on a page. You 
can adjust the leading for the paragraph to ensure that its baselines align to the page’s 
underlying grid. This is useful if you want the baselines of text in multiple columns or 
adjacent text frames to align. You change settings for the baseline grid by using the Grids 
panel of the Preferences dialog box.
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To view the baseline grid:

Choose View > Show Baseline Grid.

To align selected paragraphs to the baseline grid:

In the Paragraph palette, click Align to Baseline Grid .

To ensure that the leading of your text does not change, set the baseline grid leading 
to the same leading value as your text, or to a multiple thereof.

Aligning and justifying text vertically
You can align or distribute lines of text in a frame along its vertical axis to help keep type 
vertically consistent among frames and their columns. You can align text to the top, center, 
or bottom of the frame using each paragraph’s leading and paragraph spacing values. You 
can also justify text vertically, which evenly spaces lines regardless of their leading and 
paragraph spacing values.

Bottom alignment (left) and Justify (right)

Vertical text alignment and justification is calculated from the baseline positions of each 
line of text in the frame. Keep the following in mind as you adjust vertical alignment:

• The top of the frame is defined as the baseline of the first line of top-aligned text. The 
First Baseline Offset option in the Text Frame Options dialog box affects this value; for 
more information about the First Baseline Offset option see “Setting text frame 
properties” on page 83.

• The bottom of the frame is defined as the baseline of the last line of bottom-aligned 
text.

• When the Align to Baseline Grid option is applied to paragraphs with Top, Center, or 
Bottom alignment, all lines will be aligned to the baseline grid. With the Justified 
option, only the first and last lines will be aligned to the baseline grid.

• If you adjust a text frame’s Top or Bottom Inset values in the Text Frame Options dialog 
box, you change the location of the first or last baseline, respectively.

• Vertical justification isn’t applied to text that takes on a non-rectangular shape due to 
influences such as text frame shape, text wrap, or corner effects. In these cases, top 
alignment is applied. When a corner effect is applied, vertical justification is possible if 
you make the text area rectangular by increasing the Inset value in the Text Frame 
Options dialog box, relative to the Size value in the Corner Effects dialog box.
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To align or justify text vertically within a text frame:

1 Do one of the following:

• With the selection tool, select a text frame.

• With the type tool, click in a text frame.

2 Choose Object > Text Frame Options.

3 In the Vertical Justification section of the Text Frame Options dialog box, choose one of 
the following options in the Align menu:

• To vertically align text down from the top of the frame, choose Top. (This is the default 
setting.)

• To center lines of text in the frame, choose Center.

• To vertically align lines of text up from the bottom of the frame, choose Bottom.

• To evenly distribute lines of text vertically between the top and bottom of the frame, 
choose Justify.

4 If you choose Justify and you want to prevent the leading value from becoming dispro-
portionately larger than the paragraph spacing value, specify a Paragraph Spacing Limit 
value. The space between paragraphs is expanded up to the value you specify; if the text 
still doesn’t fill the frame, the space between lines is adjusted until the frame is filled. The 
paragraph spacing limit value is applied in addition to the Space Before or Space After 
values entered on the Paragraph palette. 

Paragraph spacing limit set to zero (left) and 1 pica (right)

5 Click OK.

An easy way to adjust the Paragraph Spacing Limit value is to select Preview, and then 
click the up or down arrow next to the Paragraph Spacing Limit value until paragraph 

spacing appears to be balanced with leading.
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Creating drop caps
You can add drop caps to one or more paragraphs at a time. The drop cap’s baseline sits 
one or more lines below the baseline of the first line of a paragraph.

One-character, three-line drop cap (left), and four-character, two-line drop cap (right)

To format a drop cap:

1 In the Paragraph palette, type a number for Drop Cap Number of Lines  to indicate 
the number of lines you want the drop cap to occupy.

2 For Drop Cap One or More Characters , type the number of enlarged characters 
you want.

3 If you want to resize, skew, or change the typeface of the drop cap letter for added 
effect, select the letter or letters and make the formatting changes. For example, if your 
drop cap letter has a descender, you can use baseline shift to adjust the placement.

If you want more control over the position of your drop cap, you can place it in a 
separate frame, and then apply a text wrap.

To remove a drop cap:

In the Paragraph palette, type 0 for Drop Cap Number of Lines.

Adding rules above or below paragraphs
Rules are paragraph attributes that move and are resized along with the paragraph on the 
page. If you’re using a rule with headings in your document, you may want to make the 
rule part of a paragraph style definition.

Paragraph rules reflow and resize with text frames

To apply a paragraph rule:

1 Choose Paragraph Rules in the Paragraph palette menu.

2 At the top of the Paragraph Rule dialog box, select Rule Above or Rule Below.
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3 Select Rule On.

Note: If you want both a rule above and a rule below, make sure Rule On is selected for 
both Rule Above and Rule Below.

4 Select Preview to see what the rule will look like.

5 For Weight, choose a weight or type a value to determine the thickness of the rule. For 
Rule Above, increasing the weight expands the rule upwards. For Rule Below, increasing 
the weight expands the rule downward.

6 Select Overprint Stroke when you want to make sure that the stroke doesn’t knock out 
underlying inks on a printing press.

7 Do one or both of the following:

• Choose a color. The available colors are those listed in the Swatches palette. Select the 
Text Color option to make the rule the same color as the first character in the paragraph 
for Rule Above and the last character for Rule Below.

• If you like, choose a tint or specify a tint value. The tint is based on the color you 
specified. Note that you can’t create tints of the built-in colors None, Paper, Regis-
tration, or Text Color.

8 Choose the width of the rule. You can choose either Text (from the left edge of text to 
the line end) or Column (from the left edge of the column to the right edge of the 
column). If the left edge of the frame has a column inset, the rule begins at the inset.

9 To determine the vertical position of the rule, type a value for Offset.

The offset for a rule above a paragraph is measured from the baseline of the top line of 
text to the bottom of the rule. The offset for a rule below a paragraph is measured from the 
baseline of the last line of text to the top of the rule. Rules can be positioned accurately to 
within 0.001 point.

A. Rule above paragraph B. Rule below paragraph

10 Set left or right indents for the rule (not for text) by typing values for Left Indent and 
Right Indent.

11 Select Overprint Stroke if the paragraph rule will be printed over another color, and 
you want to avoid errors that can occur with printing misregistration. (See “Manually 
overprinting strokes or fills” on page 419. Then click OK.)

B

A



Using Help | Contents | Index Back 132  

Adobe InDesign Help Setting Type 

Using Help | Contents | Index Back 132  

To remove a paragraph rule:

1 Using the type tool, click in the paragraph containing the paragraph rule.

2 Choose Paragraph Rules in the Paragraph palette menu.

3 Deselect Rule On and click OK.

Controlling paragraph breaks
You can eliminate orphans and widows, words or single lines of text that become 
separated from the other lines in a paragraph. Orphans fall at the bottom of a column or 
page, and widows fall at the top of a column or page.

In addition, you can specify how many lines of the following paragraph remain with the 
current paragraph as it moves between frames—a convenient way to ensure that 
headings don’t become isolated from the body text they introduce. InDesign can 
highlight the paragraphs that sometimes break in violation of your settings.

To control widows and orphans and other breaks:

1 Choose Keep Options in the Paragraph palette menu.

2 Select any of these options and then click OK:

• For Keep With Next _ Lines, specify the number of lines (up to five) of the subsequent 
paragraph that the last line of the current paragraph stays with. This option is especially 
useful for making sure that a heading stays with the next few lines of the paragraph 
that follows it.

• Select the Keep Lines Together option and select All Lines in Paragraph to prevent the 
paragraph from breaking.

• Select the Keep Lines Together option, select At Start/End of Paragraph, and specify the 
number of lines that must appear at the beginning or ending of the paragraph to 
prevent orphans and widows.

• For Start Paragraph, choose In Next Column to force InDesign to push the paragraph to 
the next frame or column in a frame; choose On Next Page to force the paragraph to 
the first frame on the next page.

To highlight paragraphs that violate Keep Options:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 Select Keep Violations and click OK.
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Specifying Optical Margin Alignment
Optical Margin Alignment controls whether punctuation marks (such as periods, commas, 
quotation marks, and dashes) and edges of letters (such as W and A) hang outside the text 
margins, so that the type looks aligned.

Before and after applying Optical Margin Alignment

When a punctuation character is followed by an end quotation mark, both characters 
hang. Optical Margin Alignment applies to all frames in the story.

To select Optical Margin Alignment:

1 Select a text frame, or click anywhere in the story. 

2 Choose Type > Story.

3 Select Optical Margin Alignment.

4 Select a font size to set the appropriate amount of overhang for the size of type in your 
story. For optimal results, use the same size as the text.

Setting indents
Indents move text inward from the right and left edges of the frame. Use first-line indents, 
not spaces or tabs, to indent the first line of a paragraph. A first-line indent is positioned 
relative to the left-margin indent. For example, if a paragraph’s left edge is indented one 
pica, setting the first-line indent to one pica indents the first line of the paragraph two 
picas from the left edge of the frame or inset. 

To set an indent using the Paragraph palette:

Adjust the appropriate indent values in the Paragraph palette. For example, typing 1p in 
the Left Indent box  indents the entire paragraph one pica; typing 1p in the First Line 
Left Indent box  indents only the first line of the paragraph.

To set an indent using the Tabs palette:

1 Choose Type > Tabs to display the Tabs palette.

2 Do one of the following to the indent markers  in the Tabs palette:
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• Drag the top marker to indent the first line of text. Drag the bottom marker to move 
both markers and indent the entire paragraph.

First-line indent (left) and indented paragraph (right)

• Select the top marker and type a value for X to indent the first line of text. Select the 
bottom marker and type a value for X to move both markers and indent the entire 
paragraph.

For more information on using the Tabs palette, see “Working with tabs” on page 135.

To create a hanging indent:

1 Using the type tool, click in the paragraph you want to indent.

2 In the Paragraph palette or the Tabs palette, specify a left indent value.

3 Do one of the following:

• In the Paragraph palette, type a negative value for the first-line left indent .

• In the Tabs palette, drag the top marker to the left, or select the marker and type a 
negative value for X.

In most cases you’ll specify the negative equivalent of the value you entered in step 2; for 
instance, if you specified a left indent of 2 picas, your first-line left indent will typically 
be –2 picas.

To create a hanging indent, indent the paragraph (left), and then add a negative value 
for the first-line left indent

4 Using the type tool, click in front of the first word of the paragraph, and then type the 
text that you want to hang over the indent.

5 Press Tab, and type any additional paragraph text.
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Controlling left indents with a special character
You can use the Indent to Here special character to indent lines in a paragraph indepen-
dently of a paragraph’s left indent value. The Indent to Here special character is different 
from the paragraph’s left indent in the following ways:

• Indent to Here is part of the text flow, as if it were a visible character. If text reflows, the 
indent moves with it.

• Indent to Here affects all lines after the line where you’ve added its special character, so 
you can indent just some of the lines in a paragraph.

• When you choose Type > Show Hidden Characters, the Indent to Here character ( ) 
is visible.

Indented using paragraph’s left indent (left) and indented 
using Indent to Here special character (right)

To mark a location in the text as a left indent:

1 Using the type tool , click the insertion point where you would like to indent.

2 Choose Type > Insert Special Character > Indent to Here.

Note: If you insert more than one Indent to Here special character on a line, InDesign uses 
the one furthest to the right.

Working with tabs
Tabs position text at specific horizontal locations in a frame. The default tab settings 
depend on the unit of measurement selected in the Units & Increments preferences dialog 
box. 

Tabs apply to an entire paragraph. The first tab you set deletes all default tab stops to its 
left. Subsequent tabs delete all default tabs between the tabs you set.

You set tabs using the Tabs palette.

A. Tab alignment buttons B. Tab position C. Tab leader box D. Align On box E. Tab ruler  
F. Snap palette above frame

It was a particularly dark

night and the stars and planets 

were beginning to appear.

Soon a glittering tapestry of

light emerged from the dark- 

ness. “Where did all the stars 

come from?” Saturn always 

wondered. They were truly 

amazing, a wonder to behold.

It was a particularly dark

night and the stars and planets 

were beginning to appear.

Soon a glittering tapestry

of light emerged from the 

darkness. “Where did all 

the stars come from?” 

Saturn always wondered. 

They were truly amazing, 

a wonder to behold.

B C D

FE

A



Using Help | Contents | Index Back 136  

Adobe InDesign Help Setting Type 

Using Help | Contents | Index Back 136  

Setting tabs
You can set left, center, right, and decimal or special-character tabs. When you use the 
special-character tab, you can set a tab to align to any character you choose, such as a 
colon or a dollar sign.

To display the Tabs palette:

1 Using the type tool, click in the text frame.

2 Choose Type > Tabs.

If the top of the frame is visible, the Tabs palette snaps to the current text frame and 
matches its width to the current column. 

To align the Tabs palette ruler with your text:

Scroll through your document to display the top of the text frame, and then click the 
magnet icon  on the Tabs palette. The Tabs palette snaps to the top of the column that 
includes the selection or the insertion point.

To set a tab:

1 Press Tab in the paragraphs where you want to add horizontal space. (You can also add 
tabs after you create your tab settings.)

Press Tab to insert horizontal space

2 To specify which paragraphs will be affected, select a paragraph or a group of 
paragraphs.

3 For the first tab, click a tab-alignment button (left, right, center, or decimal) in the Tabs 
palette to specify how text will align to the tab’s position.

4 Do one of the following:

• Click a location on the tab ruler to position a new tab.

Click to add a tab setting
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• Type a position in the X box and press Enter or Return. If the X value is selected, press 
the up or down arrow key to increase or decrease the tab value by 1 point, respectively.

5 For subsequent tabs with different alignments, repeat steps 3 and 4.

The first tab setting is right-aligned; the second tab setting is left-aligned

Note: You cannot set tabs using increments smaller than one point using the Tab ruler, but 
you can type tabs to within 0.01-point accuracy by entering a value for X.

To repeat a tab:

1 In the Tabs palette, select a tab on the tab ruler.

2 Choose Repeat Tab in the Tabs palette menu.

The Repeat Tab command creates multiple tabs based on the distance between the tab 
and the left indent or the previous tab stop.

Using the Repeat Tab command

To move a tab:

1 In the Tabs palette, select a tab on the tab ruler.

2 Do one of the following:

• Type a new location for X and press Enter or Return.

• Drag the tab to a new location.

To remove a tab:

In the Tabs palette, drag the tab off the tab ruler.

To change a tab from one alignment to another:

1 In the Tabs palette, select a tab on the tab ruler.

2 Click a tab-alignment button.

You can also hold down Alt (Windows) or Option (Mac OS) while clicking the tab stop 
marker to cycle through the four alignment options.
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To specify a decimal or other special-character tab:

1 In the Tabs palette, create or select a decimal tab  on the tab ruler.

2 In the Align On box, type the character to which you want to align. You can type or 
paste any character. Make sure that the paragraphs you’re aligning contain the character 
you specified.

Here, the lines are aligned on the x character

To insert a tab character in a table:

Choose Type > Insert Special Character > Tab.

Adding tab leaders
A tab leader is a repeated pattern of characters, such as a series of dots or dashes, between 
a tab and the following text.

To add a tab leader to a tab:

1 In the Tabs palette, select a tab on the tab ruler.

2 Type a pattern of as many as eight characters in the Leader box, and then press Enter or 
Return. InDesign repeats the characters you entered across the width of the tab.

3 To change the font or other formatting of the tab leader, select the tab character in the 
text frame, and use the Character palette or Type menu to apply formatting.

Setting a right indent tab
In one step, you can add a right-aligned tab at the right indent, making it easier to prepare 
tabular text that spans an entire column. Right indent tabs are slightly different from 
regular tabs. A right indent tab:

• Aligns all subsequent text to the right edge of the text frame. If the same paragraph 
includes any tabs after the right indent tab, those tabs and their text are pushed to the 
next line.

• Is a special character located in the text, not in the Tabs palette. You add a right indent 
tab using a context menu, not the Tabs palette. As a result, a right indent tab can’t be 
part of a paragraph style.

• Is different from the Right Paragraph Indent value in the Paragraph palette. The Right 
Paragraph Indent value keeps the entire right edge of the paragraph away from the 
right edge of the text frame.

• Can’t be used with a tab leader. To create a right-aligned tab with a tab leader, use the 
Tabs palette.
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To set a right indent tab:

1 Using the type tool , click on the line where you want to add the right indent tab.

2 Choose Type > Insert Special Character > Right Indent Tab.

You can also insert a right indent tab by pressing Shift+Tab with the insertion 
point active.

Copying type attributes with the eyedropper tool
You can use the eyedropper tool to copy the character, paragraph, fill, and stroke 
attributes, and then apply those attributes to other type. By default, the eyedropper tool 
copies all attributes of a type selection.

To customize the attributes you want to copy with the eyedropper tool, use the 
Eyedropper Options dialog box. For more information about using the eyedropper tool 
and the Eyedropper Options dialog box, see “Copying attributes between objects” on 
page 319.

To copy type attributes to unselected text:

1 With the eyedropper tool , click the text from which you want to copy attributes. (The 
text can be in another open InDesign document.) The eyedropper tool reverses direction, 
and appears full , to indicate that it’s loaded with the attributes you copied. When you 
position the eyedropper over text, an I-beam appears next to the loaded eyedropper .

2 With the eyedropper tool, select the text you want to change. The selected text takes 
on the attributes loaded in the eyedropper. As long as the eyedropper tool is loaded, you 
can select additional text to apply the loaded formatting.

3 To deselect the eyedropper tool, click another tool.

Type attributes copied to unselected text

Note: If you use the eyedropper tool to copy a paragraph style from text in one document 
to text in another, and the paragraph style has the same name but different sets of 
attributes, any style differences will appear as local overrides to the destination style.

To copy type attributes to text you select:

1 With the type tool  or path type tool , select the text to which you want to copy 
attributes. The text from which you want to copy formatting must be in the same InDesign 
document as the text you want to change.
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2 Using the eyedropper tool , click the text from which you want to copy attributes. The 
eyedropper tool reverses direction and appears full , to indicate that it’s loaded with 
the attributes you copied. The attributes are applied to the text you selected in the 
previous step. 

Type attributes copied to selected text

To pick up new attributes when the eyedropper tool is loaded:

1 Press Alt (Windows) or Option (Mac OS) while the eyedropper tool is loaded. The 
eyedropper tool reverses direction and appears empty , to indicate that it’s ready to pick 
up new attributes.

2 Without releasing the Alt or Option key, click an object containing the attributes you 
want to copy, and then release the Alt or Option key so that you can drop the new 
attributes on another object.

To change the text attributes affected by the eyedropper tool:

1 In the toolbox, double-click the eyedropper tool.

2 Choose Character Settings or Paragraph Settings in the menu at the top of the 
Eyedropper Options dialog box.

3 Select the attributes you want to copy with the eyedropper tool, and then click OK.

To copy or apply paragraph attributes only without having to change settings in the 
Eyedropper Options dialog box, hold down Shift as you click text with the 

eyedropper tool.

Working with composition
The appearance of text on your page depends on a complex interaction of processes 
called composition. Using the word spacing, letterspacing, glyph scaling, and hyphenation 
options you’ve selected, InDesign composes your type in a way that best supports the 
specified parameters.

About composition methods
InDesign offers two composition methods: Adobe Paragraph Composer (the default) and 
Adobe Single-line Composer. Both composition methods evaluate possible breaks, and 
choose those that best support the hyphenation and justification options you’ve specified 
for a given paragraph.
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The Adobe Paragraph Composer Considers a network of breakpoints for an entire 
paragraph, and thus can optimize earlier lines in the paragraph in order to eliminate 
especially unattractive breaks later on. Paragraph composition results in more even 
spacing with fewer hyphens.

The Paragraph Composer approaches composition by identifying possible breakpoints, 
evaluating them, and assigning a weighted penalty to them based on such principles as 
evenness of letter spacing, word spacing, and hyphenation.

You can use the Hyphenation dialog box to determine the relationship between 
better spacing and fewer hyphens; see “Adjusting hyphenation” on page 141.

The Adobe Single-line Composer Offers a traditional approach to composing text one 
line at a time. This option is useful if you want to restrict composition changes from late 
stage edits.

To choose a composition method for a paragraph:

In the Paragraph palette menu, choose Adobe Paragraph Composer (the default) or 
Adobe Single-line Composer.

Note: Additional composition engine plug-ins from other companies may be available, 
along with interfaces that let you customize an engine’s parameters.

To set composition preferences:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 To use on-screen highlighting to identify compositional problems, select Keep Viola-
tions and H&J Violations (hyphenation and justification). (See “Highlighting loose or tight 
lines” on page 145.)

3 To justify text that wraps around an object, select Justify Text Next to an Object. (See 
“Justifying text wrapped around an object” on page 103.)

4 Click OK.

Controlling hyphenation and justification
The settings you choose for hyphenation and justification affect the horizontal spacing of 
lines and the aesthetic appeal of type on your pages. Hyphenation options determine 
whether words can be hyphenated and, if they can, which breaks are allowable.

Justification is controlled by the alignment option you choose, the word spacing and 
letterspacing you specify, and whether or not you have used glyph scaling. The variables 
are where to hyphenate, how much spacing to put between words and letters, and 
whether to allow glyph scaling.

For information on justifying single words in narrow columns of fully justified text, see 
“Setting justification for a single word” on page 145.

Adjusting hyphenation
You can hyphenate words manually or automatically, or you can use a combination of the 
two methods. The safest way to hyphenate manually is to insert a discretionary hyphen, 
which is not visible unless the word needs to be broken at the end of a line.
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Hyphenation is based on word lists that can be stored either in a separate user dictionary 
file on your computer, or in the document itself. To ensure consistent hyphenation, you 
may want to specify which word list to refer to, especially if you will be taking your 
document to a service provider or if you work in a workgroup. For more information, see 
“Working with hyphenation and spelling dictionaries” on page 96.

When you set automatic hyphenation options, you can determine the relationship 
between better spacing and fewer hyphens.

To hyphenate words manually:

1 Using the type tool, click where you want to insert the hyphen.

2 Do one of the following:

• Choose Type > Insert Special Character > Discretionary Hyphen.

• Press Ctrl+Shift+- (Windows) or Command+Shift+- (Mac OS) to insert a discretionary 
hyphen.

Note: Entering a discretionary hyphen in a word does not guarantee that InDesign will 
break the word at that point. Whether or not the word breaks depends on other hyphen-
ation and composition settings. Entering a discretionary hyphen in a word does, however, 
guarantee that InDesign will not break the word at other points.

To turn automatic hyphenation on or off for a paragraph:

In the Paragraph palette, select or deselect the Hyphenate option.

You can also include this option in a paragraph style.

To set automatic hyphenation options for a paragraph:

1 Click in a paragraph or select the range of paragraphs you want to affect.

2 Choose Hyphenation in the Paragraph palette menu.

3 Select the Hyphenate option, if necessary.

4 Make changes to the following settings as needed:

• For Words Longer than _ Letters, specify the minimum number of characters for 
hyphenated words.

• For After First _ Letters and Before Last _ Letters, specify the minimum number of 
characters at the beginning or end of a word that can be broken by a hyphen. For 
example, by specifying 3 for these values, aromatic would be hyphenated as aro- matic 
instead of ar- omatic or aromat- ic.

• For Hyphen Limit, specify the maximum number of hyphens that can appear on consec-
utive lines. Zero means unlimited hyphens.

• For Hyphenation Zone, specify the amount of white space allowed at the end of a line of 
unjustified text before hyphenation begins. This option applies only when you’re using 
the Single-line Composer with nonjustified text.

• To alter the balance between better spacing and fewer hyphens, adjust the slider at the 
bottom of the dialog box. 

5 To prevent capitalized words from being hyphenated, deselect Hyphenate Capitalized 
Words. Then click OK.
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Preventing unwanted word breaks
By using nonbreaking hyphens, you can prevent certain words from breaking at all—for 
example, proper names or words which, when broken, become unattractive fragments. By 
using nonbreaking spaces, you can also keep multiple words from breaking—for example, 
clusters of initials and a last name (P. T. Barnum). If you apply the no-break attribute to text 
longer than a line, InDesign compresses the text so that it fits on one line.

To prevent selected text from breaking:

Choose No Break in the Character palette menu.

Another way to prevent a word from breaking is to place a discretionary hyphen at the 
beginning of the word. Press Ctrl+Shift+- (Windows) or Command+Shift+- (Mac OS) 

to insert a discretionary hyphen.

To create a nonbreaking hyphen:

1 Using the type tool, click where you want to insert the hyphen.

2 Do one of the following:

• Choose Type > Insert Special Character > Nonbreaking Hyphen.

• Press Ctrl+Alt+- (Windows) or Command+Option+- (Mac OS).

To create a nonbreaking space:

1 Using the type tool, click where you want to insert the space.

2 Do one of the following:

• Choose Type > Insert Special Character > Nonbreaking space.

• Press Ctrl+Alt+x (Windows) or Option+spacebar (Mac OS).

About spacing in justified text
Using the options in the Justification dialog box, you can set the degree to which you will 
allow InDesign to deviate from normal word spacing, letter spacing, and glyph scaling.

Minimum, Maximum, and Desired The Minimum and Maximum values apply only 
when you’re setting justified type. For all other paragraph alignments, InDesign uses the 
values you entered for Desired. The more the Minimum and Maximum percentage values 
differ from the Desired percentage, the more latitude you give to InDesign to increase or 
decrease spacing in justifying the line. The composers always try to make the spacing for a 
line as close to the desired settings as possible.

Word spacing Refers to the space between words (called the spaceband) that is created 
by pressing the spacebar.

Letterspacing Refers to the distance between letters and includes kerning or tracking 
values. Each character in a font is surrounded by a specific amount of space (called the side 
bearing), which is built in by the font designer. A character’s width includes not just the 
character itself, but the side bearing, as well.

Glyph scaling Refers to the process of changing the width of characters. A glyph is a 
specific form of a font character.
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If you are using the Adobe Single-line Composer, setting a narrow range in the Minimum 
and Maximum values helps achieve a desired result. However, setting a narrow range may 
not be beneficial with the Adobe Paragraph Composer, because it decreases the 
difference between a reasonable break and a bad break over a range of lines. If you 
change the default values for the Adobe Paragraph Composer, make sure the values you 
use can accommodate a generous range. 

Note: When specifying word spacing, Minimum should be less than or equal to the 
percentage set for Desired, and Maximum should be greater than or equal to the 
percentage set for Desired.

Controlling spacing and glyph scaling
You can precisely control the way in which InDesign spaces letters and words and scales 
characters, which is especially useful in justified text.

To set word spacing or letterspacing:

1 Choose Justification in the Paragraph palette menu.

2 Do either of the following, and then click OK:

• For justified text only, type values for Minimum and Maximum to define a range of 
acceptable spacing. Word spacing values can range from 0% to 1000%. Letter spacing 
can range from 100% to 500%.

• Type a value for Desired to set the spacing for the selected paragraphs.

Note: Entering a Glyph Scaling value other than 100% for Desired for nonjustified text is 
the same as entering a value for Horizontal Scaling.

To set glyph scaling:

1 Choose Justification in the Paragraph palette menu.

2 Type values for Glyph Scaling Minimum, Desired, and Maximum. Then click OK.

Before (top) and after (bottom) glyph scaling in justified text

Glyph scaling can help in achieving even justification; however, values more than 3% 
from the 100% default value may result in distorted letter shapes. Unless you are 

trying to achieve a special effect, it’s best to keep glyph scaling to values most people 
won’t notice, such as 97–100–103.

Traditionally, x-height is the height of 

the lowercase letter x. It is also the 

height of the body of lowercase let-

ters in a font, excluding the ascenders 

and descenders.

Traditionally, x-height is the height of the 
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cluding the ascenders and descenders.
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the



Using Help | Contents | Index Back 145  

Adobe InDesign Help Setting Type 

Using Help | Contents | Index Back 145  

Setting justification for a single word
In narrow columns, a single word will occasionally appear by itself on a line. If the 
paragraph is set to full justification, a single word on a line may appear to be too stretched 
out. Instead of leaving such words fully justified, you can center them or align them to the 
left or right margins.

To set justification for a single word:

1 Choose Justification in the Paragraph palette menu.

2 For Single Word Justification, choose Fully Justify, Left Align, Center Align, or Right 
Align, and then click OK.

Using a flush space with justified text
Using a flush space character adds a variable amount of space to the last line of a fully 
justified paragraph—between the last word and an end-of-story character from a 
decorative font. Used with nonjustified text, the flush space appears as a normal word 
space. In justified text, it expands to absorb all available extra space on the last line. Using 
a flush space can make a dramatic difference in the way the entire paragraph is formatted 
by the Adobe Paragraph Composer.

Before and after adding a flush space character

To insert a flush space:

1 Using the type tool, click directly in front of the end-of-story character.

2 Choose Type > Insert White Space > Flush Space. 

Note: The effect of a flush space is not apparent until you apply the Justify All Lines 
option  to the paragraph.

Highlighting loose or tight lines
Because composing a line of type involves many factors in addition to word spacing and 
letterspacing (hyphenation preferences, for example), InDesign cannot always honor your 
settings for word spacing and letterspacing. However, compositional problems in lines of 
text can be highlighted in yellow; the darkest of three shades indicates the most serious 
problems.

To highlight lines that are too tight or too loose:

1 Choose Edit > Preferences > Composition (Windows and Mac OS 9), or InDesign > 
Preferences > Composition (Mac OS 10).

2 Select H&J Violations and click OK.

Once you understand the dynamics of 

color, shape and texture, you can begin to 

experiment with different designs to find 

what inspires you. Part of a good design 

is scaling your garden to fit your lifestyle. 

We offer up these tips—in simple terms, 

to encourage you to get started.
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Using styles
A character style is a collection of character formatting attributes that can be applied to a 
selected range of text. A paragraph style includes both character and paragraph 
formatting attributes, and can be applied to a selected paragraph or range of paragraphs.

Styles can save time when you apply and revise text formatting, and they give your 
documents a consistent look. When you change the formatting of a style, all text to which 
the style has been applied will be updated with the new format.

Using the Styles palettes
Paragraph styles and character styles are found on separate palettes. However, the 
palettes are nearly identical in appearance. When you select text or click an insertion 
point, the style that has been applied to that text (if any) is highlighted in the Styles 
palette. If you select a range of text covering multiple styles, no style is highlighted in the 
Styles palette.

A. Style name B. Style with additional formatting (overrides) C. Imported style  
D. New Style button  E. Trash button

To display the Paragraph Styles palette:

Choose Type > Paragraph Styles.

To display the Character Styles palette:

Choose Type > Character Styles.

Creating styles
If the styles you want already exist in another InDesign document, you can import those 
styles for use in your current document. You can also import styles from word-processing 
applications; see “Working with text import filters” on page 109.

To define a new style:

1 If you want to base your new style on the formatting of existing text, select the text.

2 Do one of the following:

• Choose New Style in the Character Styles or Paragraph Styles palette menu.

• Click the Create New Style button in the Character Styles or Paragraph Styles palette. 
To keep the appearance and default name of the new style, skip the remaining steps. To 
change the style, double-click the new style name in the palette.

3 For Style Name, type a name for your new style.

A

B

C

D E
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4 For Based On and Next Style (Paragraph Styles palette only), see “Basing styles on other 
styles” on page 149 and “Setting the Next style” on page 148.

5 To add a shortcut keystroke, make sure Num Lock is turned on in Windows. Then hold 
down any combination of Shift and Ctrl (Windows) or Option, Shift, and Command (Mac 
OS), and press a number on the numeric keypad. You cannot use letters or non-keypad 
numbers for defining style shortcuts.

6 On the left side of the dialog box, select the group of attributes you want to modify. 
Specify the desired formatting attributes for your new style.

7 Click OK. The style name appears in the palette. Any changes you made to the 
formatting options are applied to selected text.

Applying styles
Applying a character or paragraph style is similar to applying a character or paragraph 
attribute. If you have selected text, the formatting attributes affect the selection or 
selected paragraph. If you did not, the next character you type appears with the 
formatting attributes.

By default, applying a style won’t remove any existing character and paragraph formatting 
or character styles applied to the text, although you have the option of removing existing 
formatting when you apply a style. A plus sign (+) appears next to the current style in the 
Styles palette if the selected text uses a character or paragraph style and also uses 
additional formatting that isn’t part of the applied style.

Note: After you apply a style to text, applying No Paragraph Style or No Character Style to 
the text removes the style but leaves the formatting intact, unless you do this while 
holding down Alt (Windows) or Option (Mac OS); see “Removing assigned styles from text” 
on page 149.

To apply a character style to selected text:

Do one of the following:

• Click the character style name in the Character Styles palette.

• Make sure Num Lock is on in Windows, and press the keyboard shortcut you assigned 
to the style.

InDesign applies the character style to the selected characters. 

To apply a paragraph style to selected paragraphs:

Do one of the following:

• Click the paragraph style name in the Paragraph Styles palette.

• Make sure Num Lock is on in Windows, and press the keyboard shortcut you assigned 
to the style.

InDesign applies the paragraph style to the selected paragraphs.

To apply a paragraph style and preserve character styles, but remove character 
format overrides:

In the Paragraph Styles palette, hold down Alt (Windows) or Option (Mac OS) as you click 
the name of the style.
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To apply a paragraph style and remove both character styles and character format 
overrides:

In the Paragraph Styles palette, hold down Alt+Shift (Windows) or Option+Shift (Mac OS) 
as you click the name of the style.

Editing styles
You can change the definition of a character or paragraph style at any time. When you 
change the definition of a style, all of the text formatted with that style changes to match 
the new style definition.

To edit a style using the styles palette:

1 Do one of the following:

• Double-click the style name in the Styles palette. Note that this applies the style to any 
selected text or text frame or, if no text or text frame is selected, sets the style as the 
default style for any new text you type. If you don’t want the style to be applied to 
selected text, hold down Shift+Ctrl (Windows) or Shift+Option (Mac OS) when you 
double-click the style name.

• Select the style in the palette, and then choose Style Options in the Styles palette menu.

2 Adjust settings in the Modify Style Options dialog box, and then click OK.

When specifying a Character Color in the Modify Style Options dialog box, you can 
create a new color by double-clicking the fill or stroke box.

To redefine the currently selected style based on selected text:

1 Using the type tool, select the text formatted with the style you want to redefine.

2 Make changes to the paragraph or character attributes.

3 Choose Redefine Style in the Styles palette menu.

To select unused styles:

Choose Select All Unused Styles in the Styles palette menu.

Setting the Next style
You can automatically apply styles as you type text. If, for example, your document’s 
design calls for the style “body text” to follow a heading style named “heading 1,” you can 
set the Next Style option for heading 1 to “body text.” After you’ve typed a paragraph 
styled with “heading 1,” pressing Enter or Return starts a new paragraph styled with the 
style “body text.”

The style you choose in the Next Style menu is only applied when you type text.

Note: If you select No Paragraph Style as the Next Style, the formatting of the style 
remains intact when you press Enter or Return. To remove the style’s formatting, select the 
text, hold down Alt (Windows) or Option (Mac OS), and then click No Paragraph Style.

To set a style that will apply to the next paragraph you type:

1 Double-click a style name in the Paragraph Styles palette.

2 Choose a style in the Next Style menu, and then click OK.
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Basing styles on other styles
Many document designs feature hierarchies of styles sharing certain attributes. The 
headings and subheads, for example, often use the same font. You can easily create links 
between similar styles by creating a “base” or “parent” style. When you change the base 
style, the attributes you change that appear in the related styles will change as well. 
Attributes that are not shared among the styles are left unchanged in the related styles.

To define a new style based on an existing style:

Create a new style as explained in “Creating styles” on page 146. In the New Paragraph 
Style dialog box, select the “parent” style in the Based On menu. The new style becomes 
the “child” style.

Deleting styles
When you import text from other applications or documents, you may have several 
unwanted styles in your styles palettes. You can delete these styles. The appearance of 
paragraphs tagged with the deleted style doesn’t change, but their formatting is no 
longer associated with a style. For information on removing assigned styles from text, 
see “Removing assigned styles from text” on page 149.

To delete a style:

1 Select the style name or names in the Styles palette.

2 Do one of the following:

• Choose Delete Styles in the palette menu.

• Click the Trash button  at the bottom of the palette. 

• Drag the style to the Trash button at the bottom of the palette.

To delete all unused styles:

Choose Select All Unused Styles in the Styles palette menu, and then click the 
Trash button.

Removing assigned styles from text
You can break the link between text and its assigned style. The text’s formatting does not 
change, but any changes you make to the style will not be reflected in the text. You can 
also remove both the style and the formatting from text to which a style has been applied.

To break the link between text and its style:

1 Select the text whose style you want to remove.

2 Do one of the following:

• To remove the style but leave the formatting, click [No Character Style] or [No 
Paragraph Style] in the Styles palette.

• To remove the style and whatever formatting was applied with the style, hold down 
Alt (Windows) or Option (Mac OS), and then click [No Character Style] or [No Paragraph 
Style] in the Styles palette.
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Loading styles from another document
You can load (import) paragraph styles, character styles, or both from another InDesign 1.x 
or 2.0 document into the active document. If you load a style from another document 
that has the same name as an existing style in the current document, the loaded style will 
overwrite the existing style and apply its new attributes to all text in the current document 
that uses the old style.

You can also use the Books feature to share styles; see “Synchronizing documents in a 
book file” on page 169.

To load styles from another InDesign document:

1 In the Styles palette, do one of the following:

• Choose Load Character Styles or Load Paragraph Styles in the Styles palette menu.

• Choose Load All Styles in the Styles palette menu to load both character and paragraph 
styles.

2 Double-click the InDesign document containing the styles you want to import.
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Creating Tables

About tables
A table consists of rows and columns of cells. A cell is like a text frame in which you can add 
text, inline graphics, or other tables. To format the table, you can change row height and 
column width, apply alternating colors to rows or columns, rotate text, and merge and 
split cells.

A. Rotated text in a merged table cell B. Alternate shaded rows

To edit and format tables, use the commands on the Table menu, or choose Window > 
Table to display the Table palette.

Creating a table
When you create a table, the new table fills the width of the container text frame. A table 
is inserted on the same line when the insertion point is at the beginning of the line, or on 
the next line, when the insertion point is in the middle of a line.

The default height of a row is equivalent to the slug of the current text attributes at the 
insertion point. (A slug is the approximate height of the highlighting in selected text.)

Tables flow with surrounding text just as inline graphics do. For example, a table moves 
through threaded frames when the text above it changes in point size, or when text is 
added or deleted. However, a table cannot appear on a text-on-path frame.

To create a table:

1 Using the type tool , draw a new text frame, or place the insertion point in a text 
frame or an existing table.

2 Choose Table > Insert Table.

3 Specify the numbers of rows and columns, and then click OK.

Adding content to a table
You can add text, inline graphics, inline text frames, and other tables to table cells. To add 
text, type, paste, or place it. The height of a table row expands to accommodate additional 
lines of text, unless you set a fixed row height; see “Changing row height” on page 160.
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You can also add graphics to table cells. When you add a graphic that is larger than the 
cell, the cell height expands to accommodate the graphic, but the width of the cell does 
not change—the graphic may extend beyond the right side of the cell. If the row in which 
the graphic is placed is set to a fixed height, a graphic that is taller than the row height 
causes the cell to be overset. For more information on overset text in a table, see “Working 
with overset cells” on page 162.

To add text to a table:

Using the type tool , do any of the following:

• Place the insertion point in a cell, and type text. Press Enter or Return to create a new 
paragraph in the same cell. Press Tab or Shift+Tab to move the insertion point to the 
next or previous cell, respectively.

• Cut or copy text, place the insertion point in the table, and then choose Edit > Paste. 

• Position the insertion point where you want to add text, choose File > Place, and then 
double-click a text file.

To add graphics to a table:

Do any of the following:

• Position the insertion point where you want to add the graphic, choose File > Place, and 
then double-click the graphic’s file name.

To avoid an overset cell, first place the image outside the table, use the selection tool 
to resize and cut the image, and then use the type tool to paste the image into the 

table cell.

• Use the selection tool  to cut or copy a graphic or a frame, use the type tool  to 
position the insertion point in the table, and then choose Edit > Paste. 

Moving around in a table
You can navigate from one cell to the next using the mouse or keyboard. You can also 
specify which rows you want to jump to—a feature that is especially useful in long tables.

If the table is at the top of a text frame and you want text to precede the table, 
place the insertion point at the beginning of the first cell, press the left arrow key, and 

begin typing.

To move to the next or previous cell:

Do any of the following:

• Press Tab to move to the next cell. If you press Tab in the last table cell, a new row is 
created. (For information on inserting tabs, see “Inserting tabs in a table cell” on 
page 161.)

• Press Shift+Tab to move to the previous cell. If you press Shift+Tab in the first table cell, 
the insertion point moves to the last table cell.

• Press the arrow keys to navigate within and between table cells. If you press the right 
arrow key when the insertion point is at the end of the last cell in a row, the insertion 
point moves to the beginning of the first cell in the same row. Similarly, if you press the 
down arrow key when the insertion point is at the end of the last cell in a column, the 
insertion point moves to the beginning of the first cell in the same column.
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To jump to a specific row:

1 Choose Table > Go to Row.

2 Specify the row number you want to jump to, and then click OK.

Creating a table from existing text
Before you convert text to a table, make sure that you set up the text properly. InDesign 
begins new rows at paragraph returns and new columns at tab characters.

To create a table from existing text:

1 To prepare the text for conversion, insert tabs to delineate columns; insert paragraph 
returns to delineate rows.

2 Using the type tool , select the text you want to convert to a table.

3 Choose Table > Convert Text to Table.

Converting tables to text
When you convert a table to text, InDesign removes the table lines and inserts a 
paragraph return at the end of each row and a tab at the end of each column.

To convert a table to text:

1 Using the type tool , place the insertion point inside the table, or select text in the 
table.

2 Choose Table > Convert Table to Text.

Importing tables from other applications
When you use the Place command to import a Microsoft Excel spreadsheet or a Microsoft 
Word document that includes tables, the imported data appears in an InDesign table, 
which you can edit or update using the Links palette. You can also copy and paste data 
from Excel or Word into an InDesign document.

For information on importing from other applications, see “Working with text import 
filters” on page 109.

Embedding a table within a table
You can embed, or nest, a table within another table. If you create a table within a cell, you 
cannot use the mouse to select any part of the table that oversets the cell boundary. 
Instead, expand the row or column; or place the insertion point in the first part of the 
table, and use shortcut keystrokes to move the insertion point and select text.

To embed a table within another table:

1 Do one of the following:

• Select the cells or table you want to embed, and then choose Edit > Cut or Copy. Place 
the insertion point in the cell where you want the table to appear, and then choose Edit 
> Paste.

• Click inside the table, choose Table > Insert Table, specify the number of rows and 
columns, and then click OK.

2 Adjust the cell inset as necessary; see “Changing cell inset spacing” on page 160.
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Editing a table
InDesign offers a wide array of table editing features: add or delete rows and columns, cut 
or copy and paste selected cells, change the column and row height, split or merge cells, 
and much more.

Selecting cells, rows, and columns
When you select part or all of the text in a cell, that selection has the same appearance as 
text selected outside a table. However, if the selection spans more than one cell, the cells 
and their contents are selected.

To select a cell or multiple cells:

Using the type tool , do any of the following:

• Click inside a table, or select text, and then choose Table > Select > Cell.

• Drag across a cell border, being careful not to drag the column or row line so that you 
don’t resize the table.

• With the insertion point at the end of a cell, press Shift+Right Arrow or 
Shift+Down Arrow.

• With the insertion point at the beginning of a cell, press Shift+Left Arrow or 
Shift+Up Arrow.

To select the cell, press Esc. Press Esc again to place the insertion point at the 
beginning of the cell.

To select entire columns or rows:

Using the type tool , do any of the following:

• Click inside a table, or select text, and then choose Table > Select > Column or Row.

• Move the pointer over the top edge of a column or the left edge of a row so that the 
pointer becomes an arrow shape (  or ), and then click to select the entire column 
or row.

Before and after selecting Row

To select the entire table:

Using the type tool , do any of the following:

• Click inside a table, or select text, and then choose Table > Select > Table.
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• Move the pointer over the upper left corner of the table so that the pointer becomes an 
arrow shape , and then click to select the entire table.

Before and after selecting Table

You can also select a table in the same way you select an inline graphic—place the 
insertion point immediately before or after a table, and then hold down Shift while 

pressing the Right Arrow key or Left Arrow key, respectively, to select the table.

Inserting a row or column
Use the Insert command in the Table menu to insert columns and rows. The cells in the 
new row or column have the same formatting as the text in the row or column in which 
the insertion point was placed.

You can also use the Alt (Windows) or Option (Mac OS) key to insert new rows using the 
mouse; see “Inserting rows or columns by dragging” on page 156.

To insert a row:

1 Place the insertion point in a row below or above where you want the new row 
to appear.

2 Choose Table > Insert > Row.

3 Specify the number of rows you want.

4 Specify whether the new row or rows should appear above or below the current row, 
and then click OK.

You can also create a new row by pressing Tab when the insertion point is in the 
last cell.

To insert a column:

1 Place the insertion point in a column next to where you want the new column 
to appear.

2 Choose Table > Insert > Column.

3 Specify the number of columns you want.

4 Specify whether the new column or columns should appear to the left or the right of 
the current column, and then click OK.

To insert rows and columns using the Table Options dialog box:

1 With the insertion point in the table, choose Table > Table Options > Table Setup.

2 Specify a different number of rows and columns, and then click OK.

N
am

e

R
eg

io
n 

an
d 

C
it

y

Address 

Lee

Luebke

Sanchez

Stewart

Rhoades

Eas

Eas

Sou

No

We

N
am

e

R
eg

io
n 

an
d 

C
it

y

Address 

Lee

Sanchez

Rhoades

Eas

Sou

We

Luebke

Stewart

Eas

No



Using Help | Contents | Index Back 156  

Adobe InDesign Help Creating Tables 

Using Help | Contents | Index Back 156  

New rows are added to the bottom of the table; new columns are added to the right side 
of the table.

You can also change the number of rows and columns using the Table palette. 
To display the Table palette, choose Window > Table.

Inserting rows or columns by dragging
By holding down Alt (Windows) or Option (Mac OS) as you drag a row or column border, 
you can add rows or columns. 

When adding columns, if you drag more than 1 1/2 times the width of the column being 
dragged, new columns are added that have the same width as the original column. If you 
drag to insert only one column, that column can have a narrower or wider width than 
the column from where you dragged. The same behavior is true of rows, unless the Row 
Height for the row being dragged is set to At Least. In this case, if you drag to create 
only one row, InDesign will “grow” the new row, if necessary, so that it’s tall enough to 
contain text.

Note that dragging to insert rows or columns doesn’t work at the top or left edges of 
a table.

To insert a row or column by dragging:

Position the type tool  over the border of a column or row so that a double-arrow icon 
(  or ) appears; hold down the mouse button, and then hold down Alt (Windows) or 
Option (Mac OS) while dragging down to create a new row, or to the right to create a new 
column.

Note: If you press Alt or Option before holding down the mouse button, the hand tool 
appears—so make sure you begin dragging before you press Alt or Option.

Deleting a row, column, or table
You can delete the structure of cells, rows, and columns, you can delete the entire table, 
and you can clear the contents of selected cells.

To delete rows and columns using the Table Options dialog box:

1 Choose Table > Table Options > Table Setup.

2 Specify a different number of rows and columns, and then click OK.

Rows are deleted from the bottom of the table; columns are deleted from the right side 
of the table.

To delete a row, column, or table:

1 Place the insertion point inside the table, or select text in the table.

2 Choose Table > Delete > Row, Column, or Table.
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To delete a row or column using the mouse:

Position the pointer over the border of the bottom or right side of the table so that a 
double-arrow icon (  or ) appears; hold down the mouse button; and then hold down 
Alt (Windows) or Option (Mac OS) while dragging either up to delete rows, or to the left to 
delete columns.

Note: If you press Alt or Option before holding down the mouse button, the hand tool will 
appear—so press Alt or Option after you begin dragging.

To delete cell contents without deleting cells:

1 Select the cells containing the text you want to delete.

2 Press Backspace or Delete, or choose Edit > Clear or Edit > Cut.

Cutting, copying, and pasting in a table
When text is selected within a cell, cutting, copying, and pasting actions are the same as 
for text selected outside a table. You can also cut, copy, and paste cells and their contents. 
If the insertion point is in a table when you paste, multiple pasted cells appear as a table 
within a table. You can also move or copy the entire table.

To cut, copy, and paste cells and their contents:

1 Select the cells you want to cut or copy (see “Selecting cells, rows, and columns” on 
page 154), and then choose Edit > Cut or Copy.

2 Do any of the following:

• To embed a table within a table, place the insertion point in the cell where you want the 
table to appear, and then choose Edit > Paste.

• To replace existing cells, select one or more cells in the table—making sure that 
there are sufficient cells below and to the right of the selected cell—and then choose 
Edit > Paste.

To move or copy a table to a new location:

1 To select the entire table, place the insertion point in the table and choose Table > 
Select > Table.

2 Choose Edit > Cut or Copy, move the insertion point where you want the table to 
appear, and then choose Edit > Paste.

Breaking tables across frames
When you create a table that is taller than the frame in which it resides, the frame is 
overset. If you thread the frame to another frame, the table continues in that frame. Rows 
move into threaded frames one at a time—you can’t break a single row across multiple 
frames.

Use Keep options to determine how many rows should remain together, or to specify 
where a row breaks, such as at the top of a column or frame.

To specify Keep options:

1 Place the insertion point in the appropriate row, or select a range of cells in the rows 
you want to keep together.

2 Choose Table > Cell Options > Rows and Columns.
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3 To keep the selected rows together, select Keep with Next Row.

4 To cause the row to break in a specified location, select an option (such as In Next 
Frame) in the Start Row menu, and then click OK.

Formatting a table
Use the Paragraph and Character palettes to format text within a table—just like 
formatting text outside a table. In addition, two main dialog boxes help you format the 
table itself: Table Options and Cell Options. Use these dialog boxes to change the number 
of rows and columns, to change the appearance of the table border and fill, to determine 
the spacing above and below the table, and to add other table formatting.

You can also use the Table palette or the context menu to format the table. Select one or 
more cells and then right-click (Windows) or Control-click (Mac OS) to display a context 
menu with table options.

A. Number of rows B. Row height C. Column width  D. Cell vertical alignment E. Cell inset values  
F. Number of columns G. Cell content rotation

Resizing rows and columns
Drag a row or column border to change the row height or column width. When you drag 
to resize the row or column, the width or height of the table changes, unless you hold 
down Shift.

Holding down Shift while dragging inside row or column borders affects only two rows 
or columns at once—one row or column gets bigger as the other gets smaller. Holding 
down Shift while dragging the right table edge will resize all the columns proportionally; 
holding down Shift while dragging the bottom table edge will resize all rows 
proportionally.

By default, row height is determined by the slug height of the current font. Thus, row 
height also changes if you change the point size of type for entire rows of text, or if you 
change the row height setting; see “Changing row height” on page 160.

To resize column widths and row heights:

1 Select cells in the columns and rows you want to resize.

2 Do one of the following:

• In the Table palette, specify Column Width and Row Height settings.

• Choose Table > Cell Options > Rows and Columns, specify Row Height and Column 
Width options, and then click OK.
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• Position the pointer over the edge of a column or row so that a double-arrow icon (  or 
) appears, and then drag left or right to increase or decrease the column width, or 

drag up or down to increase or decrease row height.

Before and after dragging to resize rows 

Note: When you change the width of the table, the table may extend outside the frame in 
which it appears; see “Changing the alignment of a table within a frame” on page 160.

To resize rows or columns without changing the table width:

Holding down Shift while dragging an inside row or column edge.

To resize rows or columns proportionally:

Hold down Shift while dragging the right table border or bottom table edge.

To resize the entire table:

Using the type tool, position the pointer over the lower right corner of the table so that 
the pointer becomes an arrow shape , and then drag to increase or decrease the table 
size. Hold down Shift to maintain the table’s height and width proportions.

Note: If the table spans more than one frame in a story, you cannot use the mouse pointer 
to resize the entire table.

Distributing columns or rows evenly
After you resize column widths or row heights, you can choose a menu command to give 
the selected rows or columns a uniform height or width.

To evenly distribute columns and rows:

1 Select cells in the columns or rows that should be the same width or height.

2 Choose Table > Distribute Rows Evenly or Distribute Columns Evenly.

Changing the spacing before or after a table
Use the Table Setup panel in the Table Options dialog box to change the spacing before or 
after a table. Note that changing the spacing before the table does not affect the spacing 
of a table row that falls at the top of a frame.

To change the spacing before or after a table:

1 Choose Table > Table Options > Table Setup.

2 Under Table Spacing, specify different values for Spacing Before and Spacing After, and 
then click OK.
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Changing row height
Use the Table palette or the Cell Options dialog box to change the row height. You can 
select At Least to set a minimum row height that will increase in height as you add text or 
increase the point size, or you can select Exactly to set a fixed row height. When you create 
a fixed row height, row height does not change when you add or remove text. A fixed row 
height often results in an overset condition in the cell; see “Working with overset cells” on 
page 162.

To change row height:

1 Using the type tool, place the insertion point in or select cells in the rows you want 
to resize.

2 Choose Table > Cell Options > Rows and Columns, or display the Table palette.

3 For Row Height, select Exactly or At Least, and then specify the height of the rows.

Changing cell inset spacing
Use the Table palette or the Cell Options dialog box to determine the inset spacing of 
selected cells, or the space between the cells’ borders and the text within.

In many cases, increasing the cell inset spacing will increase the row height. If the row 
height is set at a fixed value, make sure that you leave enough room for the inset values, to 
avoid causing overset text.

To change cell insets:

1 Using the type tool, place the insertion point in or select the cell or cells you want 
to affect.

2 Choose Table > Cell Options > Text, or display the Table palette.

3 Under Cell Insets, specify values for Top, Bottom, Left, and Right, and then click OK.

Changing the alignment of a table within a frame
A table assumes the width of the text frame or table cell in which it is created. However, 
you can change the size of the text frame or table so that the table is wider or narrower 
than the frame. In such a case, you can decide where you want the table to be aligned 
within the frame. 

To change the alignment of a table within a frame:

1 Place the insertion point to the right or left of the table. The insertion point becomes as 
tall as the table in the frame.

2 Select an alignment option in the Paragraph palette.

Adding text above a table
A table is anchored to the paragraphs that immediately precede and follow it. If you insert 
a table at the beginning of the text frame, you can’t click above the table to place an 
insertion point. Instead, use the arrow keys to move the insertion point before the table.

To add text above a table:

Place the insertion point at the beginning of the paragraph in the first cell, press the left 
arrow key, and begin typing.
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Inserting tabs in a table cell
When the insertion point is in a table, pressing Tab moves the insertion point to the next 
cell. However, you can insert a tab within a table cell.

Use the Tabs palette to define tab settings in the table. Tab settings affect the paragraph in 
which the insertion point is placed. 

To insert a tab:

1 Using the type tool, place the insertion point where you want to insert a tab.

2 Choose Type > Insert Special Character > Tab.

To change tab settings:

1 Select the columns or cells you want to affect.

2 Choose Type > Tabs to display the Tabs palette, and then adjust tab settings; see 
“Working with tabs” on page 135.

Changing the alignment of text within a table cell
To change the horizontal alignment of text within a cell, use the alignment option in the 
Paragraph palette; see “About text alignment” on page 126. Use the Cell Options dialog 
box or the Table palette to change the vertical alignment of text within table cells.

To change the vertical alignment of text within a cell:

1 Using the type tool, select the cell or cells you want to affect.

2 Choose Table > Cell Options > Text.

3 Under Vertical Justification, select an Align setting: Top, Center, Bottom, or Justify. If you 
select Justify, specify the Paragraph Spacing Limit; this will set a maximum amount of 
space to be added between paragraphs. For more information on these options, see 
“Aligning and justifying text vertically” on page 128.

4 For First Baseline, select an option to determine how text is to be offset from the top of 
the cell. The settings are the same as the corresponding settings in the Text Frame Options 
dialog box; see “Setting text frame properties” on page 83.

5 Click OK.

Merging and splitting cells
You can combine two or more cells in the same row or column in a single cell. For example, 
you can merge the cells in the top row of the table to create a single cell to be used for the 
table title.

In addition, you can split cells horizontally or vertically, which is especially useful when 
creating form tables. You can select multiple cells and split them vertically. However, you 
can split only one cell at a time horizontally.

To merge cells:

1 Using the type tool, select the cells you want to merge.

2 Choose Table > Merge Cells.
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To split cells:

1 Place the insertion point in the cell you want to split, or select a row, column, or block 
of cells.

2 Choose Table > Split Cell Vertically or Split Cell Horizontally. If multiple cells are selected, 
Split Cell Horizontally is dimmed.

Working with overset cells
In most cases, a table cell will expand vertically to accommodate new text and graphics 
being added. However, if you set a fixed row height and add text or graphics that are too 
large for the cell, a small red dot appears in the lower right corner of the cell, indicating 
that the cell is overset.

You cannot flow overset text into another cell. Instead, edit or resize the contents, or 
expand the cell or the text frame in which the table appears.

In the case of inline graphics or text with fixed leading, it is possible for the cell contents 
to extend beyond cell edges. You can select the Clip Contents to Cell options, so that 
any text or inline graphics that otherwise extend beyond any cell edge are clipped to the 
cell boundary.

To display the contents of an overset cell:

Do one of the following:

• Increase the size of the cell.

• Change the text formatting. To select the cell’s contents, click in the overset cell, press 
Esc, and then use the Character palette to format the text.

To clip contents to the cell:

1 Place the insertion point in the cell you want to clip, or select the cell or cells you want 
to affect.

2 Choose Table > Cell Options > Text.

3 Select Clip Contents to Cell, and then click OK.

Rotating text in a cell
You can rotate text in a selected cell in 90-, 180-, or 270-degree increments.

To rotate text in a cell:

1 Place the insertion point in the cell you want to rotate, or select the cell or cells you 
want to affect.

2 Choose Table > Cell Options > Text, or display the Table palette.

3 Select an option for Rotation, and then click OK.

Adding strokes and fills to a table
InDesign provides a number of ways for you to add strokes and fills to your tables. Use the 
Table Options dialog box to change the stroke of the table border, and to add alternating 
strokes and fills to columns and rows. To change the strokes and fills of individual cells, use 
the Cell Options dialog box, or use the Swatches, Stroke, and Color palettes.
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By default, the formatting you select using the Table Options dialog box overrides any 
corresponding formatting previously applied to table cells. However, if you select the 
Preserve Local Formatting option in the Table Options dialog box, the strokes and fills 
applied to individual cells are not overridden.

When selecting strokes and fills for the table, use the following options:

Weight Specifies the line thickness for the table or cell border.

Color Specifies the color of the table or cell border. The choices listed are those available 
in the Swatches palette.

Type Specifies the line style, such as Thick-Thin and Solid.

Tint Specifies the percentage of ink of the specified color to be applied to the stroke 
or fill.

Overprint When selected, causes the ink specified in the Color drop-down list to be 
applied over any underlying colors, rather than knocking out those inks.

To change the appearance of the table border:

1 With the insertion point in the table, choose Table > Table Options > Table Setup.

2 Under Table Border, specify desired Weight, Color, and Type settings, and specify a Tint 
percentage.

3 If you do not want stroke formatting of individual cells to be overridden, select Preserve 
Local Formatting, and then click OK.

To add stroke and fill to cells using the Cell Options dialog box:

1 Using the type tool, place the insertion point in or select the cell or cells in which you 
want to add a stroke or fill.

2 Choose Table > Cell Options > Strokes and Fills.

3 In the Preview proxy, specify which lines will be affected by stroke changes. For 
example, if you want to add a heavy stroke to the outside lines but not to the inside lines 
of the selected cells, click an inside line to deselect it. (Selected lines are blue; deselected 
lines are gray.)

Before and after deselecting middle line in Preview area; 
only outside lines are affected

In the proxy, double-click any outside line to select the entire outer selection 
rectangle. Double-click any inside line to select the inside lines. Triple-click anywhere 

in the proxy to select or deselect all lines.

4 For Cell Stroke, specify desired Weight, Color, and Type settings, and specify a Tint 
percentage.
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5 For Cell Fill, specify desired Color and Tint settings.

6 Select Overprint Stroke and Overprint Fill if desired, and then click OK.

You can also add strokes and fills to selected cells using the Stroke and Swatches 
palettes, respectively. 

To add a stroke to cells using the Stroke palette:

1 Select the cell or cells you want to affect.

2 Choose Window > Stroke to display the Stroke palette.

3 In the Preview proxy, specify which lines will be affected by stroke changes.

4 In the toolbox, make sure the Object button  is selected. (If the Text button  is 
selected, the stroke changes will affect the text, not the cells.)

5 Specify a weight value and stroke type.

To add a fill to cells using the Swatches palette:

1 Select the cell or cells you want to affect.

2 Choose Window > Swatches to display the Swatches palette.

3 Make sure the Object button  is selected. (If the Text button  is selected, the color 
changes will affect the text, not the cells.)

4 Select a swatch.

To add diagonal lines to a cell:

1 Using the type tool, place the insertion point in or select the cell or cells in which you 
want to add diagonal lines.

2 Choose Table > Cell Options > Diagonal Lines.

3 Click the button for the type of diagonal line you want to add.

4 Select Draw in Front to place the diagonal line in front of the cell contents; select Draw 
in Back to place the diagonal line behind the cell contents.

5 Under Line Stroke, specify desired Weight, Color, and Type settings; specify a Tint 
percentage and Overprint options, and then click OK.
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Adding alternating strokes and fills to a table
You can alternate strokes and fills to enhance readability or improve the appearance of 
your table. When you specify alternating strokes or fills in the Table Options dialog box, 
you specify options for both alternating patterns.

Before and after alternating fills in a table

Note: Alternating stroke and fill settings override cell stroke formatting, unless you select 
the Preserve Local Formatting option in the Table Options dialog box.

To add alternating strokes to a table:

1 With the insertion point in the table, choose Table > Table Options > Alternating Row 
Strokes or Alternating Column Strokes.

2 For Alternating Pattern, select the type of pattern you want to use. Select Custom if you 
want to specify a pattern; for example, one column with a thick black line followed by 
three columns with thin yellow lines.

3 Under Alternating, specify the stroke or fill options for both the first pattern and the 
subsequent pattern. For example, you may want to add a solid stroke to the first column 
and a Thick - Thin line to the next column, so that they alternate.

Note: In tables that span multiple frames, alternating strokes and fills for rows do not 
restart at the beginning of additional frames in the story; see “Breaking tables across 
frames” on page 157.

4 Select Preserve Local Formatting if you want formatted strokes previously applied to 
the table to remain in effect.

5 For Skip First and Skip Last, specify the number of rows or columns at the beginning 
and end of the table in which you do not want stroke attributes to appear, and then 
click OK.

To add alternating fills to a table:

1 With the insertion point in the table, choose Table > Table Options > Alternating Fills.

2 For Alternating Pattern, select the type of pattern you want to use. Select Custom if you 
want to specify a pattern such as one row shaded in gray followed by three rows shaded in 
yellow.

3 Under Alternating, specify the stroke or fill options for both the first pattern and the 
subsequent pattern. For example, if you selected Every Second Column for Alternating 
Pattern, you may want to shade the first two columns in a gray tint and leave the next two 
columns blank.

4 Select Preserve Local Formatting if you want previously formatted fills applied to the 
table to remain in effect.
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5 For Skip First and Skip Last, specify the number of rows or columns at the beginning 
and end of the table in which you do not want fill attributes to appear, and then click OK.

To turn off alternating strokes and fills for a table:

1 Place the insertion point in the table.

2 Choose Table > Table Options > Alternating Row Strokes, Alternating Column Strokes, 
or Alternating Fills.

3 For Alternating Pattern, choose None, and then click OK.
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Creating Books, Tables of 
Contents, and Indexes

Creating a book file
A book file is a collection of documents that can share styles and swatches. You can 
sequentially number pages in booked documents, print selected documents in a book, or 
export them to PDF. One document can belong to multiple book files.

One of the documents added to a book file is the style source. By default, the style source is 
the first document in the book, but you can select a new style source at any time. When 
you synchronize documents in a book, the specified styles and swatches from the style 
source replace those in other booked documents.

To create a book file:

1 Choose File > New > Book.

2 Type a name for the book, specify a location, and click Save. The Book palette appears. 
In Windows, the book file is saved with an .indb extension.

To add documents to a book file:

1 Choose Add Document in the Book palette menu, or click the plus button  at the 
bottom of the Book palette.

2 Select the InDesign document or documents you want to add. If you include InDesign 
1.5 or earlier documents, they will be converted to 2.0 format when added to the book. 
You must convert PageMaker or QuarkXPress documents before adding them to the 
book file.

3 Click Open.

4 If necessary, change the order of the documents by dragging them up or down to the 
appropriate locations.

5 To designate a document as the style source, select the box next to the document; see 
“Specifying a style source document” on page 168.

You can drag and drop files onto the Book palette from an Explorer (Windows) or 
Finder (Mac OS) window. You can also drag a document from one book to another. 

Hold down Alt (Windows) or Option (Mac OS) to copy the document.

To open a document in the Book palette:

In the Book palette, double-click the document.

To remove documents from a book file:

1 In the Book palette, select the document or documents you want to remove.
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2 Choose Remove Document in the Book palette menu, or click the minus button  at 
the bottom of the palette.

Removing the document doesn’t delete the file on disk; the document is removed only 
from the book file.

Specifying a style source document
The style source acts as the basis for design elements such as paragraph styles and 
swatches that are copied to other documents in the book when you choose the 
Synchronize command. You can choose a different style source at any time. 

A. Style source icon

To specify the style source:

In the Book palette, click the blank box next to the document that you want to be the style 
source; the style source icon  indicates which document is the style source.

Removing or replacing missing book documents
Icons in the Book palette indicate a document’s current status, such as open , missing  
(moved, renamed, or deleted), modified  (repaginated or edited while the book was 
closed), or in use  (if someone else has the document open). No icon appears next to 
closed documents.

To remove or replace a missing document:

1 Select the missing document in the Book palette.

2 Do one of the following:

• Choose Remove Document in the Book palette menu.

• Choose Replace Document in the Book palette menu, locate the document you want to 
replace it with, and then click Open.

• Select the missing document in the Book palette, choose Document Information in the 
Book palette menu, and then click Replace.

Opening, saving, and closing book files
You can open several books at the same time. Open books appear in the Book palette. The 
process of opening, saving, and closing book files is similar to opening, saving, and closing 
documents; see “Opening and closing documents” on page 11.

Book files are separate from document files. For example, when you choose the Save Book 
command, InDesign saves the changes to the book, not the documents in the book.

Note: If you are sharing book files over a server, make sure that you have a file 
management system in place, so that you don’t save over each others’ changes acciden-

A
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tally. For more information on sharing files over a server, see “Managing files using 
WebDAV” on page 240.

To save a book file:

Do any of the following:

• To save a book under a new name, choose Save Book As in the Book palette menu, 
specify a location and filename, and click Save.

• To save an existing book under the same name, choose Save Book in the Book palette 
menu, or click the Save button  at the bottom of the Book palette.

To close a book file:

Choose Close Book in the Book palette menu, or click the close button on the palette’s title 
bar.

To show or hide an open book:

Choose Window > [book name].

Synchronizing documents in a book file
When you synchronize documents in a book, styles and swatches are copied from the 
style source to the specified documents in the book, replacing any styles and swatches 
that have identical names. Use the Synchronize Options dialog box to determine which 
styles and swatches are copied.

If styles and swatches in the style source are not found in the document being synchro-
nized, they are added. If styles and swatches in the document being synchronized aren’t in 
the style source, they are left intact.

You can synchronize the book while documents in the book are closed. InDesign opens 
the closed documents, makes any changes, and then saves and closes the documents. 
Open documents are changed but not saved.

Note: Choosing Edit > Undo will undo changes only if the files are open at the time 
synchronization occurs.

To select which styles and swatches are to be synchronized:

1 Choose Synchronize Options in the Book palette menu.

2 Select the styles and swatches you want copied from the style source into the other 
book documents, and then click OK.

Note: If table of contents styles exist in the style source, all character and paragraph styles 
will be synchronized, even if the Character Styles and Paragraph Styles options in the 
Synchronize Options dialog box are deselected.



Using Help | Contents | Index Back 170  

Adobe InDesign Help Creating Books, Tables of Contents, and Indexes 

Using Help | Contents | Index Back 170  

To synchronize documents in a book file:

1 Do the following:

• Make sure that the appropriate document is selected as the style source in the Book 
palette.

• Make sure that the style and swatch options you want copied from the style source are 
selected in the Synchronize Options dialog box.

2 In the Book palette, select the documents you want to synchronize with the style 
source document. If no document is selected, the entire book will be synchronized.

To make sure that no documents are selected, click the blank gray area below the 
booked documents—you may need to scroll or resize the Book palette. You can also 

hold down Ctrl (Windows) or Command (Mac OS) and click a selected document to 
deselect it.

3 Choose Synchronize in the Book palette menu, or click the Synchronize button  at 
the bottom of the Book palette.

Numbering pages in a book
In a book file, automatic pagination is turned on by default. The page range appears 
beside each document name in the Book palette. The numbering style and starting page 
are based on each document’s settings in the Document Page Numbering Options dialog 
box. If Automatic Page Numbering is selected in the booked documents, the pages in the 
book are numbered sequentially.

By default, InDesign repaginates when you add or remove pages in booked documents, 
or when you make changes to the book file, such as reordering, adding, or removing 
documents. You can turn off automatic pagination and repaginate a book manually.

If a document is missing or cannot be opened, the page range is shown as “?” from the 
place where the missing document should be to the end of the book, indicating that the 
true page range is unknown. Remove or replace the missing document before you repag-
inate. If the In Use icon  appears, someone using a different computer has opened the 
document; the person must close the document before you can repaginate.

You can start document numbering on odd- or even-numbered pages in booked 
documents. You can also use other book numbering options, such as inserting 
blank pages.

To change the page numbering options of the selected book document:

Select the document in the Book palette, and then choose Document Page Numbering 
Options in the Book palette menu, or double-click the document’s page numbers in the 
Book palette. For more information, see “Changing Numbering and Section Options” on 
page 52.

Note: If you specify a starting page number in a booked document instead of selecting 
Automatic Page Numbering, the booked document will begin on the specified page; all 
subsequent documents in the book will be renumbered accordingly.

To start document numbering on odd- or even-numbered pages:

1 Choose Book Page Numbering Options in the Book palette menu.

2 Choose Continue on Next Odd Page or Continue on Next Even Page.
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3 Select Insert Blank Page to add a blank page to the end of any document in which the 
subsequent document must begin on an odd- or even-numbered page, and then click OK.

To turn off automatic pagination:

1 Choose Book Page Numbering Options in the Book palette menu.

2 Deselect Automatic Pagination, and then click OK. When this option is deselected, 
pages are not renumbered when you add or remove pages in booked documents—you 
must choose Repaginate in the Book palette menu.

To repaginate documents in a book file:

Choose Repaginate in the Book palette menu. If any documents are missing, the book 
cannot be repaginated; see “Removing or replacing missing book documents” on 
page 168.

Printing and outputting a book file
One advantage of using a book file is that you can use a single command to output—for 
print, preflight, package, or export to PDF—selected booked documents or the entire 
book. For more information on printing and outputting InDesign files, look up the appro-
priate topic in the index.

To print or output documents in a book:

1 In the Book palette, select the documents you want to output. When no documents are 
selected, you can output the entire book.

2 Choose an output command (such as Print Book or Print Selected Documents) in the 
Book palette menu.

About hypertext links
You can create hyperlinks so that when you export to Adobe PDF or HTML, a viewer can 
jump to other locations in the same document, to other electronic documents, or to Web 
sites.

Use the Hyperlinks palette to associate each destination with source text or graphics. 
A source is hyperlinked text, a hyperlinked text frame, or a hyperlinked graphics frame. 
A destination is the URL, position in text, or page to which a hyperlink jumps. A source 
can jump to only one destination, but any number of sources can jump to the same 
destination.

A. Hyperlink source B. Hyperlink destination icon

p to 
on, 
r of 
the 

nly 
but 
rces 

page being jumped to.
For more information, 
see the Adobe Web site. A

B



Using Help | Contents | Index Back 172  

Adobe InDesign Help Creating Books, Tables of Contents, and Indexes 

Using Help | Contents | Index Back 172  

For information on creating jump lines (such as “Cont’d on p. 6”), see “Adding automatic 
page numbers for story jumps” on page 55.

Setting up hyperlink destinations
Before you create a hyperlink, it is sometimes necessary to set up the destination that the 
hyperlink will jump to. InDesign supports three kinds of hyperlink destinations:

• A document page. When you create a page destination, you can specify the zoom 
setting of the page being jumped to. 

• A text anchor, which is any selected text or insertion-point location in a document. 

• A URL destination, which indicates the location of resources on the Internet, such as 
a Web page, a movie, or a PDF file. The name of a URL destination must be a valid URL 
address. When the reader clicks a URL hyperlink, the default browser launches with 
the URL.

Note: Hyperlink destinations do not appear in the Hyperlinks palette; they appear in the 
Destination section of the New Hyperlink dialog box.

To set up a page destination:

1 Choose Window > Hyperlinks to display the Hyperlinks palette.

2 Choose New Hyperlink Destination in the Hyperlinks palette menu.

3 Choose Page in the Type pop-up menu.

4 Specify the page number you want to jump to, and type the name of the page desti-
nation. It is generally a good idea to add a descriptive name for the page, such as “Intro-
duction,” instead of “Page 3.” In this example, if you add or remove pages before page 3, 
the destination name may no longer correspond to the page you wanted to link to.

5 For Zoom Setting, do one of the following to select the view state of the page being 
jumped to, and then click OK:

• Select Fixed to display the magnification level and page position that were in effect 
when you created the link.

• Select Fit View to display the visible portion of the current page as the destination.

• Select Fit in Window to display the current page in the destination window.

• Select Fit Width or Fit Height to display the width or height of the current page in the 
destination window.

• Select Fit Visible to display the page so that its text and graphics fit the width of the 
window, which usually means that the margins are not displayed.

• Select Inherit Zoom to display the destination window at the magnification level the 
reader will use when the hyperlink is clicked.

You can create a hyperlink to an unnamed page without first creating a destination; see 
“Creating hyperlinks” on page 173.

To set up a text anchor destination:

1 Choose Window > Hyperlinks to display the Hyperlinks palette.

2 In the document, use the type tool  to place the insertion point, or select the range of 
text, that you want to be the anchor. You cannot set up an anchor destination for text on a 
master page.
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3 Choose New Hyperlink Destination in the Hyperlinks palette menu.

4 Choose Text Anchor in the Type pop-up menu.

5 Type a name for the destination, and then click OK. 

To set up a URL destination:

1 Choose Window > Hyperlinks to display the Hyperlinks palette.

2 Choose New Hyperlink Destination in the Hyperlinks palette menu.

3 Choose URL in the Type pop-up menu.

4 Type or paste a URL, such as http://www.adobe.com. You can use any valid Internet 
resource protocol: http://, file://, ftp://, or mailto://.

5 Type a name for the URL destination, and then click OK.

You can create a hyperlink from a URL that you’ve typed in your document without first 
creating a destination; see “Creating hyperlinks” on page 173.

To edit or delete a destination:

1 Open the document in which the destination appears.

2 Choose Hyperlink Destination Options in the Hyperlinks palette menu.

3 For Destination, select the name of the destination you want to edit.

4 Do one of the following:

• Click Edit, and then make changes to the destination as necessary.

• Click Delete to remove the destination.

5 When you are finished editing or deleting destinations, choose OK.

Creating hyperlinks
Once you’ve created destinations, you can establish hyperlinks between those destina-
tions and the source text or graphics in your document. If you have not created hyperlink 
destinations, you can create unnamed destinations to pages within the current document, 
or to URLs that you specify.

You can determine how the hyperlinks appear in the document and in the exported 
Adobe PDF file. By default, they are surrounded by a thin, visible rectangle. However, you 
can change the color, width, and style of the hyperlinks’ appearance.

To create a hyperlink:

1 Select the text or graphic you want to be the hyperlink’s source.

2 Choose Window > Hyperlinks to display the Hyperlinks palette.

3 Choose New Hyperlink in the Hyperlinks palette menu, or click the Create New 
Hyperlink button  at the bottom of the Hyperlinks palette.

4 For Name, type the name of the Hyperlink. The name you type will appear in the Hyper-
links palette.

5 For Document, select the document containing the destination that you want to jump 
to. All open documents that have been saved are listed in the pop-up menu. If the 
document you’re looking for isn’t open, select Browse in the pop-up menu, locate the file, 
and then click Open.
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6 For Type, select Page, Text Anchor, or URL to display the available destinations for that 
category. To display all destinations, select All Types. For information on creating destina-
tions, see “Setting up hyperlink destinations” on page 172.

7 For Name, do one of the following:

• To create a hyperlink to a destination you created, choose the destination name.

• To create a hyperlink to an unnamed destination, choose Unnamed. If Page is selected 
for Type, specify the page number and zoom setting. If URL is selected for Type, specify 
the URL you want to jump to.

• Select None to create a hyperlink with no destination.

8 To specify the appearance of a hyperlink in InDesign and in the exported PDF file, do 
the following, and then click OK:

• For Type, select Visible Rectangle or Invisible Rectangle.

• For Highlight, select Invert, Outline, Inset, or None. These options determine the 
appearance of the hyperlink in the exported PDF file.

• For Color, select a color for the hyperlink rectangle.

• For Width, select Thin, Medium, or Thick to determine the thickness of the hyperlink 
rectangle.

• For Style, select Solid or Dashed.

To create a hyperlink from a URL:

1 Using the type tool , select a URL (such as http://www.adobe.com) that you’ve typed 
in your document.

2 Choose New Hyperlink from URL in the Hyperlinks palette menu.

To show or hide hyperlinks:

Choose View > Show Hyperlinks.

Editing and removing hyperlinks
You can change the name, type, or appearance of the hyperlinks in your document. You 
can also edit the hyperlink source. When you remove a hyperlink, the source text or 
graphic remains.

To edit a hyperlink:

1 In the Hyperlinks palette, double-click the item you want to edit, or select the item and 
choose Hyperlink Options in the Hyperlinks palette menu.

2 Make changes to the hyperlink as necessary, and then click OK.

To remove a hyperlink in the Hyperlinks palette:

1 In the Hyperlinks palette, select the item or items you want to remove.

2 Click the trash button at the bottom of the palette, and click Yes in the confirmation 
dialog box that appears. 

To reset hyperlinks:

1 Select the range of text, the text frame, or the graphic frame that will act as the new 
hyperlink source.
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2 Select the hyperlink in the Hyperlinks palette.

3 Choose Reset Hyperlink in the Hyperlinks palette menu.

To update hyperlinks to external documents:

Choose Update Hyperlink in the Hyperlinks palette menu. Hold down Alt (Windows) or 
Option (Mac OS) when you choose Update Hyperlink to open external documents that are 
currently closed.

Navigating to sources and anchors
Use the Hyperlinks palette to quickly locate and select sources and destinations.

To locate a hyperlink source:

1 In the Hyperlinks palette, select the item you want to locate.

2 Choose Go To Source in the Hyperlinks palette menu. The text or frame will be selected. 

To locate a hyperlink destination:

1 In the Hyperlinks palette, select the item you want to locate. If you click a hyperlink 
source in the document window, the corresponding hyperlink will be selected in the 
palette.

2 Choose Go to Destination in the Hyperlinks palette menu. If the item is a URL desti-
nation, InDesign starts or switches to your Web browser to display the destination. If the 
item is a text anchor or page destination, InDesign jumps to that location.

About the Table of Contents feature
You can create a table of contents (TOC) for any document or book in InDesign. You can 
even have multiple tables of contents in a document—for example, a list of chapters and a 
list of illustrations.

Each TOC is a separate story, which compiles information (including correct page 
numbers) from specified paragraph styles throughout a document or set of documents in 
a book.

Follow this process:

• Create and apply paragraph styles, such as Title, Heading 1, and Heading 2, that are 
appropriate for a table of contents. 

• In the Table of Contents dialog box, specify which paragraph styles are to be used in the 
table of contents and how the TOC will be formatted.

• Flow the table of contents story. 

The page numbers in the generated table of contents listing do not update automatically. 
Regenerate the table of contents to update the page numbers.

Note: If you add, delete, or edit entries in the placed table of contents story, these changes 
will be lost when you subsequently regenerate the TOC.
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Creating styles for a table of contents
InDesign uses the paragraph styles available in the current document or book to generate 
the table of contents entries. In addition, you can select a built-in InDesign table of 
contents style (TOC Body Style). If you select this style to format the TOC, the style appears 
in the Paragraph Styles palette after a table of contents is created. You can then edit 
this style.

By default, TOC entries are formatted using the paragraph styles of the source 
document(s). However, you can create separate paragraph styles for formatting the TOC. 
For example, if you generate a table of contents based on Head 1 and Head 2 styles, you 
can create corresponding TOC Head 1 and TOC Head 2 styles that include different fonts, 
first line indents, and tab leaders. You can then select these separate TOC styles when you 
create the table of contents.

Before and after editing table of contents entry styles

In addition, you can create character styles to format the TOC entries and page numbers. 
For example, if you want the page numbers to be in bold, create a character style that 
includes the bold attribute, and then select that character style when you create the table 
of contents.

For information on creating paragraph and character styles for the TOC, see “Using styles” 
on page 146.

Creating a table of contents
Before you create a table of contents, decide which paragraphs, such as chapter titles and 
section headings, should be included, and then define paragraph styles for each. Make 
sure that these styles are applied to all appropriate paragraphs in the document or 
booked documents. (See “Creating styles for a table of contents” on page 176.)

After you specify which styles you want to use in the table of contents, you can format the 
entries in the Style: <Paragraph Style Name> section of the Table of Contents dialog box.

A. Styles that appear in TOC B. Styles that determine TOC format

Table of Contents
Introduction 1
Chapter 1
Mammals 3
Bears 3
Cats 8
Dogs 10
Chapter 2
Birds 27
Parrots 29
Chapter 3
Reptiles 32
Lizards 33

          Table of Contents
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You can save table of contents settings so that you can reuse them later; see “Saving table 
of contents styles” on page 179.

To create a table of contents:

1 Do one of the following:

• If you’re creating a table of contents for a single document, you may want to add a new 
page at the beginning of the document.

• If you’re creating a table of contents for multiple documents in a book, create or open 
the document to be used for the table of contents, make sure that it’s included in the 
book, and then open the book file. For more information, see “Working with tables of 
contents and books” on page 179. 

2 Choose Layout > Table of Contents.

3 For Title, type the text (such as Contents or List of Figures) that will appear at the top 
of the table of contents. To determine how the title is formatted, select a style in the 
adjacent Style pop-up menu.

4 Select Include Book Documents to create a single table of contents for all documents in 
the book list, and to renumber the book’s pages. If this option is selected, paragraph styles 
in all of the book’s documents are available for generating the table of contents. Deselect 
this option if you want to generate a table of contents for the current document only. (This 
option is dimmed if the book file isn’t open.)

5 Under Styles in Table of Contents, double-click paragraph styles in the Other Styles box 
to move them into the Include Paragraph Styles box. For information on table of contents 
styles, see “Creating styles for a table of contents” on page 176.

6 To format the TOC text, select an item under Include Paragraph Styles, and then select a 
style in the Entry Style pop-up menu to format the style in the TOC. For example, an entry 
created from paragraphs having the Header 1 style will have the Header 1 paragraph style 
in the generated TOC, unless you specify a different entry style.

7 Select the Replace Existing Table of Contents option to replace an existing TOC with the 
TOC you are generating. To generate a new TOC story without altering the existing one, 
deselect this option. This option is dimmed if you have not previously created a TOC for 
this document.

8 To specify advanced options, such as the page number location of each entry, click 
More Options; see “Setting formatting options for the table of contents” on page 178.

9 Click OK. If Replace Existing Table of Contents is deselected, a loaded text icon appears. 
Place the table of contents story as you would any other text.

If you manually edit entries in the table of contents, these changes are overridden 
when you update the table of contents. For best results, edit the actual paragraphs in 

the documents, and then update the table of contents. For the same reason, you should 
edit the styles used to format the table of contents entries, rather than formatting the 
table of contents directly.
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Setting formatting options for the table of contents
When you click More Options in the Table of Contents dialog box, additional options 
appear for formatting the TOC. It’s important to note that the settings in the Style section 
apply only to the style selected under Include Paragraph Styles; if necessary, specify 
options separately for each style.

Page Number Specify whether the page number of the selected style should appear 
before or after the table of contents entry, or select No Page Number for any style that 
doesn’t require a page number.

You may want to create a character style that formats the page number. You can then 
select this style in the Style pop-up list to the right of Page Number; see “Creating styles 
for a table of contents” on page 176.

Note: If you want the page numbers of the TOC to include prefixes, such as B-1 or II-1, or to 
use a different numbering convention, see “Defining section numbering” on page 52.

Between Entry and Number Specify which characters you want between the table of 
contents entry and its page number. The default is ^t (the tab character, caret+t), which 
tells InDesign to insert a tab. You can choose other special characters, such as Right Indent 
Tab or Em Space, in the pop-up list. For a complete list of special characters and how to 
work with them, see “Inserting common symbols, spaces, and hyphens” on page 89.

Note: Make sure that you select the existing text in the text box before you select a 
different special character so that you don’t include, for example, both a tab character and 
an em space.

You may want to create a character style that formats the space between the entry and the 
page number. You can then select this style in the Style pop-up list to the right of Between 
Entry and Number; see “Creating styles for a table of contents” on page 176.

If the entry’s paragraph style includes a tab leader setting, and if the tab character (^t) is 
selected, a tab leader appears in the generated table of contents. For more information, 
see “Adding tab leaders” on page 138.

Sort Entries in Alphabetical Order Select this option to sort table of contents entries 
alphabetically. This option is useful for creating simple lists, such as lists of advertisers.

Level By default, each item added to the Include Paragraph Styles box is set to one level 
lower than the item immediately above it. These levels are significant if Sort Entries in 
Alphabetical Order is selected. In an alphabetized table of contents, level 2 items appear 
under level 1 items, and so on. 

Run-in Select this option if you want all TOC entries to be run into a single paragraph. 
A semicolon followed by a space (; ) separates the entries.

Include Text on Hidden Layers Select this option only if you want the paragraphs on 
hidden layers to be included in your table of contents. Deselect this option when you’ve 
used layers to store various versions or translations of the same text.
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Editing and updating a table of contents
If your table of contents requires editing, edit the actual paragraphs in the documents—
not the table of contents story—and then generate a new table of contents. If you edit 
the table of contents story, you’ll lose your revisions when you generate a new table 
of contents.

Note: It’s not a good idea to thread the TOC frame to other text frames in the document. 
If you replace the existing TOC, the entire story will be replaced by the updated TOC.

To edit a table of contents:

1 Make any changes to the paragraphs in the documents and the styles used in the table 
of contents.

2 Open the document containing the table of contents.

3 Choose Layout > Table of Contents.

4 Select Replace Existing Table of Contents, specify other settings in the dialog box as 
needed, and then click OK.

Working with tables of contents and books
When creating a table of contents for documents in a book, do the following:

• Before you create a table of contents, verify that the book list is complete, that all 
documents are listed in the correct order, and that all headings have been formatted 
with the appropriate styles. (See “Creating a book file” on page 167.)

• Use styles consistently throughout the book. Avoid creating documents with styles that 
have identical names but different definitions. If multiple styles have the same name 
but different style definitions, InDesign uses the style definition in the current 
document (if a definition exists there), or the first occurrence of the style in the book. 

• If the necessary styles do not appear in the pop-up menus in the Table of Contents 
dialog box, you may need to synchronize the book so that the styles are copied to the 
document containing the table of contents; see “Synchronizing documents in a book 
file” on page 169.

For steps in creating a table of contents, see “Creating a table of contents” on page 176.

Saving table of contents styles
Use the Save Style feature in the Table of Contents dialog box to save the current settings 
for use in future TOCs that you create. In addition, you can use the Table of Contents Styles 
dialog box to edit or delete existing styles, or to create new styles.

When you choose a saved TOC style, all the controls in the Table of Contents dialog box 
reflect the settings for that style.

To save table of contents settings as a style:

1 Choose Layout > Table of Contents.

2 Select the settings you want; see “Creating a table of contents” on page 176.

3 Click Save Style, type a name for the style, and then click OK.

To use a table of contents style:

Choose Layout > Table of Contents, and then choose the desired style in the Style pop-
up menu.
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To create, edit, or delete a table of contents style:

1 Choose Layout > Table of Contents Styles.

2 Do any of the following, and then click OK:

• To create a style, click New, type a name for the style, make changes to the settings, and 
then click OK.

• To edit a style, select the style and click Edit. Edit the style as necessary, and then 
choose OK.

• To delete a style, select the style and choose Delete. (You cannot delete the 
[Default] style.)

To import table of contents settings from another InDesign document:

1 Choose Layout > Table of Contents Styles.

2 Click Load, select the InDesign file containing the table of contents settings you want to 
copy, and then choose Open.

3 Click OK.

Creating an index
You can create a simple keyword index or a comprehensive, detailed guide to the infor-
mation in your book. InDesign lets you focus on the planning and structure while it 
does the hard work—tracking index entries as pages change, even across several 
documents. You can even edit index entries in the palette without having to hunt down 
individual topics.

An index entry is composed of two parts: a topic and a reference. Usually the reference is 
to a page number, but it can also be a cross-reference to another topic. 

The Index palette displays index entries

Planning an index
Creating a well-planned and complete index can help make the information in your 
document immediately accessible to your readers. Here are a few guidelines to consider:

• Think about how you want your index to look. How many topic levels will it have? Will it 
refer the reader to other related topics? Will a simple keyword index suffice, or do you 
want a more complex index?
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• Anticipate the variety of ways by which your readers might look up information. For 
instance, one reader may search for information on animals by looking under beasts; 
another may look for wildlife or fauna.

• Add index entries when the content of your document is fairly stable. If you delete large 
portions of your text later, you may lose some of your indexing work.

• Review your index several times before you generate the final index. Look for 
duplicate entries, weak subject areas, misspellings, and inconsistencies in capitalization 
and wording; for example, InDesign treats Cheetah, cheetah, and cheetahs as 
separate entries.

Adding page references to an index
The Index palette includes two modes: Reference mode and Topic mode. In Reference 
mode, the preview area displays page-reference entries in the current document or book. 
In Topic mode, the preview area displays only topics, not page numbers or cross-refer-
ences; see “Creating topics for an index” on page 189. You must be in Reference mode to 
create page-reference entries.

If you index text on a master page, the master page label appears in the Index palette. If 
you index text on the pasteboard, “PB” appears in the index palette. However, these labels 
will not appear in the generated index.

To add index references:

1 Using the type tool , place the insertion point where you want the index marker to 
appear, or select text to use as the basis for an index reference.

Note: When selected text contains inline graphics or special characters, some characters 
(such as index markers and inline graphics) are stripped out in the Topic Level box. Other 
characters, such as em dashes and copyright symbols, are converted to metacharacters 
(for example, ^_ or ^2).

2 Choose Window > Index to display the Index palette.

3 Select Reference.

4 To view references from any open documents in the book, select Book.

5 Choose New Page Reference in the Index palette menu. (If this command does not 
appear, make sure Reference is selected and that there is an insertion point or text 
selection in the document.)

6 To add text to the Topic Levels box, do any of the following:

• To create a simple index entry (such as cats), type the entry in the first Topic Levels box. 
(If text was selected, that text appears in the Topic Levels box.)

• To create entries and subentries, type the parent name (for this example, animals) in 
the first Topic Levels box, and type subentries (cats and Calicos) in subsequent boxes. If 
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necessary, click the up and down arrows to change places with the item above or below 
the selected item.

Index entry in the Topic Levels box (left) and resulting appearance in the Index (right)

To replace text in the Topic Levels box, double-click any topic in the list box at the bottom 
of the dialog box.

7 To change the sort order of text listed in Topic Levels, type the text that will become 
the basis for sorting in the adjacent Sort By box. For example, if you want de la Vega to be 
sorted by Vega instead of de, type de la Vega under Topic Levels and type Vega under 
Sort By.

8 Do any of the following:

• To create index entries that have a page range (such as cats 82–87), choose an option 
in the Type pop-up menu; see “Creating page ranges in an index” on page 184.

• To add emphasis to a particular index entry, such as a person’s name, select Number 
Style Override, and then specify the character style; see “Formatting an index” on 
page 188.

• To create an index entry without a page number, choose Suppress Page Range in the 
Type menu. Although no page number will appear in the generated index, the page 
number appears in parentheses in the Index palette.

9 To create index entries that refer to other entries, choose an option (such as See or See 
Also) in the Type menu, and then type the entry in the Referenced box, or drag the existing 
entry from the list at the bottom to the Referenced box; see “Creating cross-references in 
an index” on page 184.

10 To add the page reference, do one of the following:

• Click Add to add the page reference and leave the dialog box open for additional 
entries.

• Click Add All to locate all instances of the text selected in the document window and to 
create an index marker for each one; see “Creating multiple index entries using Add All” 
on page 183.

• Click OK to add the index entry and close the dialog box.

Note: If you click Cancel after clicking Add or Add All, the entries are not removed. Choose 
Edit > Undo New Page Reference to remove these entries.

11 When you’ve finished adding reference entries, click OK or Done.

Index markers appear next to the insertion point or at the beginning of a text selection. 
You can view these markers by choosing Type > Show Hidden Characters.
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To create a quick page-reference index entry using default settings:

1 In the document window, select the words for the index entry.

2 Press Alt+Ctrl+u (Windows) or Option+Command+u (Mac OS). An index marker using 
the default settings of the New Page Reference dialog box is added at the beginning of 
the selection.

To create an index entry for a proper name:

1 In the document window, select the name for the index entry.

2 Press Ctrl+Shift+F8 (Windows) or Command+Shift+F8 (Mac OS). An index marker is 
added at the beginning of the text selection, with the last selected word first, followed by 
a comma and the remaining selected words. For example, if James Paul Carter is selected, it 
will be indexed as Carter, James Paul. 

If you do not want to index according to the last word in the selection, include one 
or more nonbreaking spaces. For example, if you want to index James Paul Carter Jr. 

by Carter instead of Jr., place a nonbreaking space between Carter and Jr. To insert a 
nonbreaking space, choose Type > Insert White Space > Nonbreaking Space.

To create a new index entry based on an existing entry:

1 In the document window, click an insertion point, or select text where the index marker 
will appear.

2 In the Index palette, select Reference, and scroll the preview area to the entry you want 
to copy.

3 Do one of the following:

• Drag an entry to the New button  to insert an index marker at the insertion point, or at 
the beginning of the selection. 

• Select an entry in the palette preview area, and then hold down Alt (Windows) or 
Option (Mac OS) and click the New Entry button. The New Reference dialog box 
appears, with information about the selected entry. Make any changes, and then click 
Add or OK.

Creating multiple index entries using Add All
Using the Add All option is an effective way to index all occurrences of a specified term in 
a document or a book. When you click Add All, InDesign creates index markers at every 
occurrence of the words selected in the document—not the text specified in the dialog 
box.

When searching for occurrences of the selected text, InDesign considers only whole 
words. Searches are case-sensitive. For example, if cheetah is selected, cheetahs and 
Cheetah will not be indexed.

Note: When you click Add All, InDesign creates index markers at each occurrence of the 
text selected in the document, even if it’s already been marked for the index.

To create multiple index entries using Add All:

1 In the document window, select the text you want to search for.

2 In the Index palette, select Reference. 

3 To create index entries for any open documents in the book, select Book.



Using Help | Contents | Index Back 184  

Adobe InDesign Help Creating Books, Tables of Contents, and Indexes 

Using Help | Contents | Index Back 184  

4 Choose New Page Reference in the Index palette menu.

5 Choose Add All. InDesign adds index markers to all text that matches the selected text, 
regardless of whether the text has been indexed, so you may end up with multiple entries 
for the same word or phrase.

Creating page ranges in an index
You can create index entries that include a page range (such as cats 82–87) instead of a 
single page number. The Type pop-up menu in the New Page Reference dialog box 
includes the following page-range options:

To Next Style Change The page range extends from the index marker to the next 
change of paragraph style.

To Next Use of Style The page range extends from the index marker to the page where 
the next occurrence of the paragraph style specified in the adjacent paragraph style pop-
up menu appears.

To End of Story The page range extends from the index marker to the end of the current 
thread of text frames that contain text.

To End of Document The page range extends from the index marker to the end of the 
document.

To End of Section The page range extends from the index marker to the end of the 
current section as defined in the Pages palette; see “Changing Numbering and Section 
Options” on page 52.

For Next # of Paragraphs The page range extends from the index marker to the end of 
the number of paragraphs specified in the adjacent box, or to the end of as many 
paragraphs as exist.

For Next # of Pages The page range extends from the index marker to the end of the 
number of pages specified in the adjacent box, or to the end of as many pages as exist.

Suppress Page Range Turn off page range.

Creating cross-references in an index
You can create index entries that refer to other entries (such as See and See also). In the 
generated index, these cross-reference entries appear at the top of the list of subentries 
under the topic. Creating an entry with one of these options does not produce an index 
marker in the document. Select these cross-reference options in the Type pop-up menu in 
the New Page Reference dialog box. Specify the entry being referenced in the Referenced 
box below. If you want to refer to an entry and subentry, separate levels by typing a colon 
and a space (animals: cats).
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If you select the See [also] option in the Type pop-up menu, either “See” or “See also” will 
appear in the generated index, depending on whether the entry includes any subentries 
or page references. For example, if you create a See [also] cross-reference for fauna that 
refers to animals, “See also” appears if fauna includes subentries (such as fauna: cats) or a 
page-reference entry (such as fauna 15); and “See” will appear if fauna includes no suben-
tries or page-reference entries (such as fauna). Note that regardless of the context, “See 
[also]”—not “see” or “see also”—will appear in the Index palette, 

A. See [also] reference that includes page reference  
B. See [also] reference that does not include page reference

For information on changing the appearance of cross-reference entries, see “Formatting 
an index” on page 188.

Editing index entries
Use the Index palette to edit entries before or after you generate an index. If you make 
changes to the index itself, these changes will be lost when you regenerate the index.

References appear in the Index palette. The list is alphabetized and divided into sections 
by letter. Triangles appear next to references. You can click these triangles to expand or 
condense index entries.

You can edit either topic entries or page-reference entries. If you select an entry or 
subentry, you can change the name and sort order of the topic levels. If you select a page-
reference entry, you can make additional changes to the entry, such as selecting a new 
cross-reference.

A. Entry B. Subentry C. Page reference

For example, if you indexed “cat” several times, but need to change all entries to “cats,” you 
can edit the “cat” topic entry—all subordinate page references are affected. However, if 
you edit a page reference to change “cat” to “cats,” only one entry is affected.

To expand or collapse index entries in the Index palette:

Click a triangle to expand or collapse an individual entry. Hold down Ctrl (Windows) or 
Command (Mac OS), and click a triangle to expand or collapse all subentries for that entry.

E
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To edit an index entry using the Index palette:

1 Open the document containing the index entries.

2 In the Index palette, select Reference.

3 In the preview area, select an entry or page reference. To select a page reference, select 
the page icon below the entry.

4 Choose Topic Options or Page Reference Options in the Index palette menu. (You can 
also double-click the entry or page reference to edit it.)

5 Edit the page-reference entry, and then click OK.

To locate and select the marker for a page-reference entry in the document window:

1 If you like, choose Type > Show Hidden Characters.

2 In the preview area of the Index palette, select the entry you want to locate.

3 Choose Go to Selected Marker in the Index palette menu. The insertion point appears 
to the right of the index marker. You can then press Shift+Left Arrow to select the marker 
for cutting, copying, or deleting.

For more information, see “Working with markers” on page 190.

To update the preview area:

Choose Update Preview in the Index palette menu. This option is especially useful if you’ve 
edited your document extensively or moved index markers in the document window.

To find an index entry in the Index palette:

1 Choose Find in the Index palette menu.

2 Type the name of the entry you want to located, and then click the Up Arrow or 
Down Arrow.

Deleting index entries
To remove index entries, you can use the Index palette, or you can select the index marker 
in the document window. 

To delete index markers:

Do one of the following:

• In the preview area of the Index palette, select the entry you want to delete, and then 
click the Trash button  or choose Delete in the Index palette menu.

Note: If the selected entry is the heading for multiple subheadings, all subheadings are 
also deleted.

• In the document window, select the index marker and press Backspace or Delete.

Generating an index
Each index is a separate story that compiles information, including correct page numbers, 
from pages throughout a document or set of documents in a book. An index story can 
appear as a separate document or in an existing document.

The page numbers in the generated index listing are not updated automatically. Regen-
erate the index to update the page numbers.
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If an index marker appears in overset text when you generate the index, you are asked if 
you would like to include these markers in the index. If you click Yes, “PN” appears in the 
generated index instead of the actual page number.

To generate an index:

1 Do one of the following:

• If you’re creating an index for a single document, you may want to add a new page at 
the end of the document.

• If you’re creating an index for multiple documents in a book, create or open the 
document to be used for the index, and make sure that it’s included in the book. For 
more information, see “Creating an index” on page 180. 

2 Add index entries to the document or documents; see “Adding page references to an 
index” on page 181. Review the index in Topic mode to make sure that the index entries 
are organized properly.

3 Choose Generate Index in the Index palette menu.

4 For Title, type the text that will appear at the top of the index. To determine how the 
title is formatted, select a style in the Title Style pop-up menu.

5 To generate a new index story without changing the existing one, deselect Replace 
Existing Index. This option is dimmed if you haven’t generated an index.

6 Select Include Book Documents to create a single index for all documents in the current 
book list and to renumber the book’s pages. Deselect this option if you want to generate 
an index for the current document only.

7 Select Include Entries on Hidden Layers if you want index markers on hidden layers to 
be included in your index. 

8 To view additional index options, click More Options. For more information, see 
“Formatting an index” on page 188.

9 Click OK. If Replace Existing Index is deselected, a loaded text icon appears. Place the 
index story as you would any other text.

If you edit entries in the index, these changes are overridden when you regenerate the 
index. For best results, edit the index in the Index palette; see “Editing index entries” 

on page 185.
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Formatting an index
When you click More Options in the Generate Index dialog box, formatting options appear 
that let you determine the style and appearance of the generated index. InDesign 
includes a number of built-in paragraph and character styles that you can select to format 
the generated index, or you can create and select your own styles. After you generate the 
index, you can edit these styles in the Paragraph Styles and Character Styles palettes.

A. Title B. Section heading C. Level 1 entry D. Level 2 subentry  
E. Cross-reference F. Reference topic

The following formatting options appear when you click More Options in the Generate 
Index dialog box:

Nested/Run-in Select this option to determine whether the index is formatted in the 
default Nested style, with subentries as separate indented paragraphs, or Run-in style, 
with all levels of an entry appearing in a single paragraph. The Between Entries option 
determines which characters separate the entries.

Include Index Section Headings Select this option to generate section headings 
consisting of alphabet characters (A, B, C, and so on) representing the section that follows.

Include Empty Index Sections Select this option to generate section headings for all 
letters of the alphabet, even if the index lacks any first-level entries that begin with a 
particular letter.

Level Style For each index level, choose a paragraph style to be applied to each level of 
index entries. You can edit these styles in the Paragraph Styles palette after you generate 
the index.

Section Heading Select the paragraph style that determines the appearance of the 
section headings (A, B, C, and so on) in the generated index.

Page Number Select the character style that determines the appearance of the page 
numbers in the generated index. This setting does not affect index entries you formatted 
using the Number Style Override option.

Note: If you want the page numbers in the index to include prefixes, as in B-1 or II-1, see 
“Defining section numbering” on page 52.

Cross-reference Select the character style that determines the appearance of cross-
reference text (such as See and See also) in the generated index.

Cross-referenced Topic Select the character style that determines the appearance of the 
topic being referred to (such as beasts in See also beasts) in the generated index.
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Following Topic Type or select a special character to separate the entry from the page 
number (such as Animals  38). The default is two spaces. Determine formatting for this 
character by editing the corresponding Level Style, or by selecting another.

Between Page Numbers Type or select a special character to separate one page number 
or range from another. The default is a comma followed by an en space.

Between Entries If Run-in is selected, type or select a special character to determine how 
entries and subentries are separated. The default is a semi-colon followed by a space. If 
Nested is selected, this setting determines how two cross-references under a single entry 
are to be separated.

Before Cross-reference Type or select a special character that appears between a 
reference and a cross-reference, as in “Animals. See also beasts.” The default is a period 
followed by a space. Determine formatting for this character by switching or editing the 
corresponding level style.

Page Range Type or select a special character to separate the first and last numbers in a 
page range (such as Animals 38–43). The default is an en dash. Determine formatting for 
this character by switching or editing the Page Number style.

Entry End Type or select a special character to appear at the end of entries. If Run-in is 
selected, the specified character appears at the end of the last cross-reference. The default 
is no character.

Capitalizing topics
The Capitalize dialog box provides a global solution for editing the capitalization of index 
entries so that you don’t have to edit entries one by one. For example, if you’ve indexed 
some of your entries as lowercase (cats) and others as uppercase (Cats), these entries will 
be considered separate topics. You can fix this problem by capitalizing selected entries.

To capitalize topics:

1 In the preview area of the Index palette, select an entry.

2 Choose Capitalize in the Index palette menu.

3 Select whether you want to capitalize only the selected topic, the selected topic and all 
subtopics, all Level 1 topics, or all topics, and then click OK.

Creating topics for an index
A well-planned index uses topics consistently. Common indexing problems include 
mixing uppercase and lowercase (cats and Cats) and singular and plural forms (cat and 
cats). In this example, cat, cats, and Cats appear as separate entries. You can help to ensure 
consistency by creating a list of index topics to use as a reference while you’re creating 
index entries. Creating a list of index topics is optional. 
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If you select the Topic option in the Index palette, you can create index topics that have no 
page numbers associated with them. Unless you add corresponding page references, 
these topics will not appear in the generated index. Topics are also added to the list when 
you add index references.

Creating topics for an index

You can also import a list of index topics from another InDesign document.

To create a list of topics for an index:

1 Choose Window > Index to display the Index palette. 

2 Select Topic.

3 Select Book to display all topics listed in the open documents of the book to which the 
current document belongs.

4 Choose New Topic in the Index palette menu.

5 Type the topic name (for example, animals) in the first box. To create a subentry, type a 
name (cats) in the second box. In this example, “cats” is indented under “animals.” For 
more detailed information, see “Adding page references to an index” on page 181.

6 Click Add to add the topic, which will now appear in the New Topic dialog box as well as 
the Index palette.

7 Click Done when you’ve finished.

To import topics from another InDesign document:

1 Choose Import Topics in the Index palette menu.

2 Select the document containing the index topics you want to import, and then click 
Open. The topics will appear in Topic view.

To remove all unused topics:

Choose Remove Unused Topics in the Index palette menu. All topics that do not have page 
numbers associated with them are deleted.

Working with markers
InDesign uses the location of the marker to produce an accurate bookmark or page 
reference in table of contents, index, and exported PDF files. InDesign inserts a marker 
in text for items such as index entries, XML tags, and hyperlink anchors.
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These text markers are visible when you choose Type > Show Hidden Characters. They 
have no width and they don’t affect composition of text. However, you can select these 
markers and cut, copy, or delete them. 

When you select a word, all of its markers are also selected. Keep this in mind when you 
are cutting, copying, or deleting text.

Any changes you make to existing index or table of contents entries in the placed story are 
registered by the hyperlink text marker, and appear in the exported PDF file; however, any 
new entries you add later to the placed index or table of contents story are not detected, 
and will not have a hyperlink jump in the PDF file.

For more information on creating PDF files, see “Exporting a document or book to Adobe 
PDF” on page 361.

To display markers:

Choose Type > Show Hidden Characters.

To select a marker:

1 Choose Type > Show Hidden Characters.

2 Place the insertion point next to the marker.

3 Holding down Shift, press the Left Arrow or Right Arrow key to select the marker.

You can also locate markers using different methods. For example, you can locate an index 
marker by choosing the Go to Selected Marker option in the Index palette menu.
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Drawing

About paths
All paths share certain characteristics that you can manipulate to create a wide range of 
shapes. 

Closure A path is either open, like an arc, or closed, like a circle.

Stroke and fill A path’s outline is called a stroke. A color or gradient applied to an open or 
closed path’s interior area is called a fill. A stroke can have weight (thickness), color, and a 
dash pattern. After you create any path, you can change the characteristics of its stroke 
and fill.

A. Stroke with open path B. Fill with open path C. Both stroke and fill with open path  
D. Stroke with closed path E. Fill with closed path F. Both stroke and fill with closed path

Contents You can put text or graphics inside a path. When you put contents inside an 
open or closed path, you use the path as a frame. Contents are not the same as a fill; for 
example, a single frame can simultaneously contain text and use a gradient fill. 

A B C

D E F
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Parts of a path
A path is made up of one or more straight or curved segments. The beginning and end of 
each segment are marked by anchor points, which work like pins holding a wire in place. 
You change the shape of a path by editing its anchor points. In an open path, the starting 
and ending anchor points are called endpoints. You can control curves by dragging the 
direction lines that appear at anchor points to form curves. 

A. Selected (solid) endpoint B. Selected anchor point 
C. Curved path segment D. Direction line

Paths can have two kinds of anchor points—corner points and smooth points. At a corner 
point, a path abruptly changes direction. At a smooth point, path segments are connected 
as a continuous curve. You can draw a path using any combination of corner and smooth 
points. If you draw the wrong kind of path, you can always change it.

A. Four corner points B. Same point positions using 
smooth points C. Same point positions combining 
corner and smooth points

Don’t confuse corner and smooth points with straight and curved segments. A corner 
point can connect any two straight or curved segments, while a smooth point always 
connects two curved segments.

A corner point can connect both straight segments and 
curved segments

A

B

D

C

A B C
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Each path also contains a center point. You can use this point to drag the path, to align the 
path with other elements, or to select all anchor points on the path. The center point is 
always visible; it can’t be hidden or deleted.

For more information about working with anchor points and segments, see “Working with 
multiple anchor points and segments” on page 207.

Drawing basic shapes and straight lines
You can quickly create simple paths, such as lines, rectangles, ellipses, and regular 
polygons, using tools in the toolbox. The toolbox also contains tools for creating the same 
shapes as layout placeholders.

To draw or modify paths with precision, choose Window > Transform and use the 
Transform palette to monitor the size and position of a path as you draw it.

To draw a straight line, ellipse, rectangle, or regular polygon:

1 In the toolbox, do one of the following:

• To draw a path, select the line , ellipse , rectangle , or polygon  tool in the 
toolbox.

• To draw an placeholder (empty) graphics frame, select the ellipse frame , rectangle 
frame , or polygon frame  tool in the toolbox.

2 Drag in the document window to create the path or frame. You can constrain the shape 
as you draw by doing one or both of the following:

• To constrain a line to 45-degree angles, or to constrain the width and height of a path or 
frame to the same proportions, hold down Shift as you drag.

• To draw from the center of the object, hold down Alt (Windows) or Option (Mac OS) as 
you drag.

Dragging to create a basic circle

Note: The result shown above displays a bounding box around the path. If the selection 
tool  was recently active, you’ll see this bounding box. If the direct-selection tool  was 
more recently active, the path appears with anchor points instead. (See “Selecting objects” 
on page 20.)

To create a rectangle, polygon, ellipse, or line by dragging from the center:

1 Press Alt (Windows) or Option (Mac OS) with the rectangle  , polygon  , ellipse  , 
or line tool  selected.
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Position the pointer where you want the center of the shape to be, and then drag diago-
nally to any corner or edge until the shape is the desired size. Shift-drag to constrain the 
shape to a uniform height and width, or to multiples of 45 degrees, depending on the tool 
you’re using.

Drawing from the corner (left) and drawing from the center (right)

To specify settings for new regular polygons:

Double-click the polygon tool, specify the following settings, and click OK:

• For Number of Sides, type a value for the number of sides you want for the polygon.

• For Star Inset, type a percentage value to specify the length and thickness of a star’s 
spikes. The tips of the spikes touch the outer edge of the polygon’s bounding box, and 
the percentage determines the depth of the depression between each spike. Higher 
percentages create longer, thinner spikes.

Note: Polygon settings apply only to the next polygon you draw; you cannot apply them 
to a polygon you’ve already created.

Drawing with the pencil tool
Use the pencil tool to draw open and closed paths as if you were drawing with a pencil on 
paper. It is most useful for fast sketching or creating a hand-drawn look.

To draw a freeform path with the pencil tool:

1 Select the pencil tool . 

2 Position the pointer where you want the path to begin, and drag to draw a path. The 
pencil tool displays a small x to indicate a freeform path.

As you drag, a dotted line follows the tool. When you are finished drawing, anchor points 
appear at both ends of the path and at various points along it. The path takes on the 
current stroke and fill attributes, and it remains selected by default.

To draw a closed path with the pencil tool:

1 Select the pencil tool.

2 Position the pointer where you want the path to begin, and then start dragging to draw 
a path.

3 As you drag, hold down Alt (Windows) or Option (Mac OS). The pencil tool displays a 
small loop and a solid eraser  to indicate that you are drawing a closed path.

4 When the path is the size and shape you want it to be, release the mouse button (but 
not the Alt or Option key). After the path closes, release the Alt or Option key.
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To connect or merge two paths:

1 Select two paths.

2 Select the pencil tool.

3 Position the pointer on one path to continue the path, and then start dragging to draw 
the connecting path. 

4 As you drag, hold down Ctrl (Windows) or Command (Mac OS). The pencil tool displays 
a small merge symbol  to indicate the merging of the two paths.

5 When the paths are connected, release the mouse button, and then release the Ctrl or 
Command key.

Smoothing a path with the smooth tool
Use the smooth tool to remove excess angles from an existing path or a section of a path. 
The smooth tool retains the original shape of the path as nearby as possible. Smoothed 
paths generally have fewer points, which can make them easier to edit, display, and print.

Path before and after using smooth tool

To use the smooth tool:

1 Select the path you want to smooth with the direct-selection tool . 

2 Do one of the following:

• Select the smooth tool . 

• If the pencil tool is selected, hold down Alt (Windows) or Option (Mac OS) to change the 
pencil to the smooth tool.

3 Drag the tool along the length of the path segment you want to smooth. The modified 
stroke or path usually has fewer anchor points than the original.

4 Continue smoothing until the stroke or path is of the desired smoothness.
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Erasing a path with the erase tool
Use the erase tool to remove a part of an existing path or stroke. You can use the erase tool 
on paths, but not on text. 

Strokes before (left) and after (right) using erase tool

To use the erase tool:

1 Select the path you want to erase with the direct-selection tool . 

2 Select the erase tool .

3 Drag the tool along the length of the path segment you want to erase (not across the 
path). For best results, use a single smooth, dragging motion.

Anchor points are added to the ends of the resulting paths.

Setting preferences for the pencil and smooth tools
You can set preferences for the pencil tool and the smooth tool. The preferences include 
tolerances that control how sensitive the pencil and smooth tools are to the movement of 
your mouse or graphics-tablet stylus; an option for a path to remain selected after you 
draw it; and an option for editing or merging a path when the pencil tool is within a 
certain distance of it.

The tolerance is calculated in pixels. The greater the number of pixels you specify, the less 
complex the paths will be.

Paths with low fidelity and smoothness (left), and high 
fidelity and smoothness (right)
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To set preferences for the pencil tool and smooth tool:

1 Double-click the pencil tool  or smooth tool . 

2 Use the Fidelity and Smoothness sliders or type the values:

• The Fidelity slider controls how far (in pixels) curves can stray before you have to modify 
the path. With lower Fidelity values, the curves will closely match the pointer’s 
movement, resulting in sharper angles. With higher Fidelity value, the path will ignore 
small pointer movements, resulting in smoother curves. The pixel value range is 0.5 to 
20.

• The Smoothness slider controls the amount of smoothing (by percentage) applied 
when you use the tool. Lower smoothness values usually result in more anchor points 
and preserve more of a line’s irregularities; higher values result in fewer anchor points 
and a smoother path. The percentage value range is from 0% to 100%. The default is 
0%, which means no smoothing is automatically applied when you use the pencil tool.

3 To keep the path selected after you draw it, click Keep Selected. This option is selected 
by default.

4 (Pencil tool only) Select Edit Selected Paths (the default) to edit or merge a path when 
you are within a certain distance of it.

5 (Pencil tool only) For Within, type a value, or drag the slider to determine the pixel 
distance.

Note: If the Edit Select Paths option is deselected, you cannot edit or merge paths using 
the pencil tool; however, paths can be edited or merged using the pen tool.

6 Click OK.

Drawing with the pen tool
Use the pen tool to draw a path that you can’t draw with the simpler drawing tools. The 
pen tool lets you create straight lines and smooth, flowing curves with great precision; it 
will be familiar to you if you’ve used the pen tools in Adobe Illustrator and Photoshop.

Use the pen tool to draw paths that can contain any combination of straight and curved segments

Drawing straight segments
The simplest path you can draw with the pen tool is a straight line, made by clicking the 
pen tool to create two anchor points. By continuing to click, you create a path made of 
straight segments connected by corner points.
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To draw straight segments with the pen tool: 

1 Select the pen tool .

2 Position the tip of the pen point where you want the straight segment to begin, and 
click to define the first anchor point (do not drag). The anchor point remains selected 
(solid) until you add the next point. 

Note: The first segment you draw will not be visible until you click a second anchor point. 
Also, if direction lines appear, you’ve accidentally dragged the pen tool; choose Edit > 
Undo, and click again.

3 Click again where you want the segment to end. (Shift-click to constrain the segment’s 
angle to multiples of 45 degrees.) This creates another anchor point. 

4 Continue clicking the pen tool to create additional straight segments.

The last anchor point you add appears as a solid square, indicating that it is selected. 
Existing anchor points become deselected as you add more anchor points.

To reposition an anchor point as you draw it, hold down the spacebar and drag.

5 Complete the path by doing one of the following:

• To close a path, position the pen pointer over the first (hollow) anchor point. A small 
diagonal line (slash)  appears next to the pen tool when it is positioned correctly. 
Click this anchor point, and then position the pen over the other endpoint until a 
small loop appears next to the pen . Click the endpoint to close the path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, choose Edit > Deselect All, or select a different tool in the 
toolbox.

About direction lines and direction points
Before you draw and modify curved segments with the pen tool, it’s important to under-
stand anchor points on curves. When you use the direct-selection tool  to select an 
anchor point that connects curved segments, the segments display direction lines that end 
in direction points. The angle and length of the direction lines determine the shape and 
size of the curved segments. Moving the direction lines reshapes the curves. Direction 
lines don’t print.

After selecting an anchor point (left), direction lines appear on 
any curved segments connected by the anchor point (right)

A smooth point always has two direction lines, which move together as a single, straight 
unit. When you drag either of the direction lines on a smooth point, both direction lines 
move simultaneously, maintaining a continuous curve at that anchor point.
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In comparison, a corner point can have two, one, or no direction lines, depending on 
whether it joins two, one, or no curved segments, respectively. Corner-point direction 
lines maintain the corner by using different angles. When you drag a corner point’s 
direction line, the other direction line, if present, does not move.

Adjusting direction lines on a smooth point (left) and a corner point (right)

Direction lines are always tangent to (perpendicular to the radius of ) the curve at the 
anchor points. The angle of each direction line determines the slope of the curve, and the 
length of each direction line determines the height, or depth, of the curve.

Moving and resizing direction lines changes the slope 
of curves

Drawing curved segments
Create curves by using the pen tool to add anchor points where a curve changes 
direction, and to drag the direction lines that shape the curves.

Curves are easier to edit, and your system can display and print them faster, when you 
draw them using as few anchor points as possible. Using too many points can also 
introduce unwanted bumps in a curve. Instead, draw widely spaced anchor points, and 
practice shaping curves by adjusting the lengths and angles of the direction lines. 

To draw a curved segment:

1 Select the pen tool .

2 Position the pen tip where you want the curve to begin. Hold down the mouse button. 
The first anchor point appears, and the pen tip changes to an arrowhead .
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3 Drag to set the slope of the curve segment you’re creating. In general, extend the 
direction line about one-third of the distance to the next anchor point you plan to draw. 
Shift-drag to constrain the direction line to multiples of 45 degrees.

A. Positioning pen tool B. Starting to drag (mouse button pressed)  
C. Dragging to extend direction lines

4 Release the mouse button.

Note: The first segment will not be visible until you add a second anchor point.

5 Position the pen tool where you want the curve segment to end, and then do one of the 
following:

• To create a C-shaped curve, drag in the opposite direction of to the previous direction 
line.

A. Starting to drag second smooth point B. Dragging away from previous direction 
line, to create a C-shaped curve C. Result after releasing mouse button

• To create an S-shaped curve, drag in the same direction as the previous direction line.

A. Starting to drag new smooth point B. Dragging in same direction as previous 
direction line, to create an S-shaped curve C. Result after releasing mouse button

6 Continue dragging the pen tool from different locations to create additional smooth 
points.

A B CC

A B C

A B C
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7 Complete the path by doing one of the following:

• To close the path, position the pen tool over the first (hollow) anchor point. A small 
loop  appears next to the pen tool when it is positioned correctly. Click or drag to 
close the path.

• To leave the path open, Ctrl-click (Windows) or Command-click (Mac OS) anywhere 
away from all objects, choose Edit > Deselect All, or select a different tool in the 
toolbox.

Mixing curves, corners, and straight segments as you draw
You can freely alter the kinds of points and direction lines you’re using as you draw a path. 
This is useful for interactively drawing straight and curved segments on a single path, or 
when you want to draw two curved segments that are connected by a corner point.

To draw a straight segment followed by a curved segment:

1 Using the pen tool , click corner points in two locations to create a straight segment.

2 Position the pen tool over the selected endpoint. A convert-point icon  appears next 
to the pen tool when it is positioned correctly. To set the slope of the curved segment 
you’ll create next, click an anchor point, and drag the direction line that appears.

A. Straight segment B. Positioning pen tool over endpoint 
C. Beginning to drag D. Dragging direction line

3 Click and drag the third anchor point to complete the curve.

A. Holding pen tool down B. Dragging direction line 
C. New curve segment completed

To draw a curved segment followed by a straight segment:

1 Using the pen tool, drag to create the first smooth point of the curved segment.

A CB D

A B C
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2 Reposition the pen tool where you want the curved segment to end, drag to complete 
the curve, and release the mouse button. 

Drawing a curved segment

3 Position the pen tool over the selected endpoint. A convert-point icon  appears next 
to the pen tool when it is positioned correctly. Click the anchor point to convert the 
smooth point to a corner point.

A. Positioning pen tool over existing endpoint B. Clicking endpoint C. Result after clicking

4 Click the next corner point to complete the straight segment.

Extending a curved segment with a straight segment

To draw two curved segments connected by a corner:

1 Using the pen tool, drag to create the first smooth point of a curved segment.

A B C
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2 Reposition the pen tool, drag to create a curve with a second smooth point, and then 
hold down Alt (Windows) or Option (Mac OS) as you drag the direction line to set the 
slope of the next curve. Then release the key and the mouse button. This converts the 
smooth point to a corner point by splitting the direction lines.

A. Dragging a new smooth point B. Pressing Alt/Option to split direction lines while 
dragging, and swinging direction line up C. Result after releasing mouse button

3 Reposition the pen tool where you want the second curved segment to end, and drag a 
new smooth point to complete the second curved segment.

Dragging a new smooth point (left) to complete the second segment (right)

Adjusting path segments
You can change the shape of a path by adding, deleting, or moving the path’s anchor 
points. To adjust a curved segment, move one or more of its anchor points or direction 
lines. You can also adjust a path by converting smooth points to corner points, and vice 
versa.

Adding, deleting, and converting anchor points 
You can add or delete anchor points on any path. Additional anchor points can give you 
more control over the path, or extend an open path. You can also connect two open paths. 
Similarly, you can delete anchor points to change the shape of a path or to simplify the 
path. It’s a good idea to reduce the complexity of the path by deleting any unnecessary 
points.

The pen tool automatically changes to the add-anchor-point tool  or the delete-anchor-
point tool  when you position it over a selected path. The add-anchor-point tool adds 
the kind of point (corner or smooth) needed to preserve the existing shape of the path.

Note: You must delete anchor points by using the delete-anchor-point tool. The Delete, 
Backspace, and Clear keys and the Edit > Cut or Edit > Clear commands always delete the 
entire path, even if you select an anchor point on the path.

A B C



Using Help | Contents | Index Back 205  

Adobe InDesign Help Drawing 

Using Help | Contents | Index Back 205  

To add or delete an anchor point: 

1 Using the direct-selection tool , select the paths on which you want to add or delete 
anchor points.

2 Select the pen tool , the add-anchor-point tool , or the delete-anchor-point tool . 
All of these tools share the same location in the toolbox; if necessary, position the pointer 
over the pen tool and drag to choose the tool you want.

3 Do one of the following:

• To add an anchor point using either the pen tool or the add-anchor-point tool, position 
the pointer over a path segment, and click.

• To delete an anchor point using either the pen tool or the delete-anchor-point tool, 
position the pointer over an anchor point, and click.

To extend an open path or connect two open paths:

1 Using the pen tool, position the pointer over the endpoint of the open path you want 
to extend. A small slash appears next to the pointer  when it’s precisely positioned over 
the endpoint.

2 Click the endpoint.

3 Do one of the following:

• To create a corner point, position the pen tool where you want to end the new segment, 
and click. If you are extending a path that ends at a smooth point, the new segment will 
be curved by the existing direction line.

• To create a smooth point, position the pen tool where you want to end the new curved 
segment, and drag.

• To connect the path to another open path, click an endpoint on the other path. When 
you precisely position the pen tool over the other path’s endpoint, a small merge 
symbol  appears next to the pointer.

• To connect a new path to an existing path, draw the new path near the existing path. 
When you precisely position the pen tool over the existing path’s endpoint, a small 
merge symbol  appears next to the pointer.

To override automatic switching to the add- or delete-anchor-point tools:

Hold down Shift as you position the pen tool over the selected path or an anchor point. 
This is useful when you want to start a new path on top of an existing path. To prevent 
Shift from constraining the pen tool, release Shift before you release the mouse button.

To convert between smooth points and corner points using the convert-direction-
point tool:

1 Using the direct-selection tool, select the path you want to modify.

2 Switch to the convert-direction-point tool .

3 Position the convert-direction-point tool over the anchor point you want to convert, 
and do one of the following:
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• To convert a corner point to a smooth point, drag direction lines out of the corner point.

Dragging direction lines out of corner point to create smooth point

• To convert a smooth point to a corner point without using direction lines, click 
a smooth point.

Clicking smooth point to create corner point

• To convert a corner point without using direction lines to a corner point with 
independent direction lines, first drag direction lines out of a corner point (making it 
a smooth point). Release the mouse button, and then drag either direction line.

• To convert a smooth point to a corner point with independent direction lines, drag 
either direction line.

Converting smooth point to corner point

To temporarily switch from the convert-direction-point tool to the last-used selection 
tool, press Ctrl (Windows) or Command (Mac OS).

Adjusting straight and curved segments
You can modify the shape of a path by moving any of its anchor points, or by moving the 
direction lines attached to a curve segment. Editing existing segments is slightly different 
from drawing them. Keep the following guidelines in mind as you adjust existing 
segments:
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• If an anchor point connects two segments, moving that anchor point always changes 
both segments.

• When drawing with the pen tool, you can temporarily activate the direct-selection tool 
by holding down Ctrl (Windows) or Command (Mac OS) so that you can adjust 
segments you’ve already drawn.

• When you draw a smooth point with the pen tool, dragging the direction line changes 
the length of the line on both sides of the point. However, when you edit an existing 
smooth point with the direct-selection tool, you change the length of the direction line 
only on the side you’re dragging.

To adjust a straight segment:

With the direct-selection tool , drag the anchor point on either end of a segment. Shift-
drag to constrain the adjustment to multiples of 45 degrees.

If you’re simply trying to make a rectangle wider or narrower, it’s easier to select it with 
the selection tool, and then resize it using one of the handles on the sides of its 

bounding box.

To adjust a curved segment: 

1 Using the direct-selection tool , select the anchor point on either end of a curved 
segment. Direction lines appear on the anchor point and on the adjacent anchor points, if 
any are present (some curved segments use just one direction line).

2 Do one of the following:

• Drag the anchor point. Shift-drag to constrain movement to multiples of 45 degrees.

• Drag a direction line. If you’re adjusting a smooth point’s direction handles, both direction 
lines revolve around the anchor point. Shift-drag to constrain the direction line angle 
to multiples of 45 degrees.

To split the direction lines of a smooth point, use the convert-direction-point tool to 
drag them.

Working with multiple anchor points and segments
You can use the direct-selection tool to select multiple points or path segments on one or 
more paths. You can also select subpaths on a compound path. This is useful for quickly 
altering a portion of a path defined by several points, rather than moving each point 
individually.

Note: Stroke and fill attributes apply to entire paths, regardless of how many points are 
selected.

Dragging to select multiple points
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To select multiple points on a path:

1 Select the direct-selection tool .

2 Do one of the following:

• Drag around the points you want to select.

• Hold down Shift as you click the points you want to select.

To select all points on a path at once:

Using the direct-selection tool, select the center point.

Alt/Option-clicking a path with the direct-selection tool is useful for moving a whole 
path that’s nested inside a frame, or for moving a frame without moving its contents.

To select a path segment:

1 Make sure that no points on the path are selected; deselect the path if necessary.

2 Select the direct-selection tool, and then click the path segment you want to select.

Note: Selecting a segment doesn’t select any points, but will display any direction handles 
facing the segment. If you want to keep track of which segments are selected, select 
segments by selecting the points that define them.

To select multiple path segments:

Select the direct-selection tool, and then hold down Shift as you click the path segments 
you want to select.

To move a straight path segment:

With the direct-selection tool, drag any of the path segments.

Note: If the entire path moves, choose Edit > Undo, and then make sure that you click only 
the path itself—do not click the fill. All points should be hollow, not solid. You can move a 
curved segment only by Shift-selecting and then dragging the points that define it.

To reshape a curved path segment:

With the direct-selection tool, click to select a curved path segment, and then drag 
the curve.

To reshape closed paths or objects:

1 Using the direct-selection tool, do one of the following:

• Drag around the anchor points you want to select.

• Hold down Shift as you click the anchor points you want to select.

2 Position the cursor over the anchor point or path segment that you want to act as a 
focal point (that is, a point that pulls the selected path segments), and click the anchor 
point or path segment.

3 Drag the highlighted anchor points to adjust the path. The amount of movement of 
a given path segment is relative to its distance from a highlighted point:

• Selected points that act as the focal point move with the selection tool during 
dragging.

• Selected points that aren’t the focal point move in tandem with the dragged focal 
point.
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• Unselected anchor points are not affected by reshaping.

To copy a selected path segment by dragging:

1 Position the cursor over a segment, hold down the mouse button, and then without 
moving or releasing the buttons, press Alt (Windows) or Option (Mac OS).

2 Hold down both the Alt/Option key and the mouse button as you drag the selected 
segment.

3 When you’ve dragged the segment to the desired position, release the mouse button. 
The selected segment is copied, and the rest of the path is left behind.

Copying segments

Using the scissors tool
Use the scissors tool to split a path, graphics frame, or empty text frame at any anchor 
point, or along any segment. When you use the scissors tool, keep the following in mind:

• If you want to split a closed path into two open paths, you must slice in two places 
along the path. If you slice a closed path only once, you get a single path with a gap 
in it.

• Any paths resulting from a split inherit the path settings of the original path, such as 
stroke weight and fill color.

• You can’t split a frame containing text. Use the type tool to select all of the text 
characters in the frame, cut and paste them to another location, and then split the path.

• If you split a frame containing a graphic, an entire copy of the graphic remains inside 
each of the resulting frames. If you want only one frame to contain the graphic, split the 
frame, and then use the direct-selection tool to select the unwanted copy of the 
graphic and delete it, leaving only its frame.

To split a path:

Select the scissors tool , position it over a path, and click.

Using the Stroke palette
The Stroke palette provides control over the appearance of the edge, or stroke, of selected 
paths or text characters.



Using Help | Contents | Index Back 210  

Adobe InDesign Help Drawing 

Using Help | Contents | Index Back 210  

About stroke weights
The weight of a stroke is centered on its path. Half of the stroke falls inside the path, and 
half falls outside. For text characters only, InDesign automatically adjusts stroke weights so 
that the entire stroke weight exists outside the character outline. This preserves character 
shapes by preventing a growing stroke weight from closing up the inner areas of small text 
characters.

Path stroke weight is always centered over the path (top); character stroke weight 
always grows outward from the character outline when text has a fill (bottom)

When you select a path using the selection tool , you activate a bounding box that exists 
at the outer edge of the stroke weight. If you want to see the path at the center of a stroke, 
select the path using the direct-selection tool .

You can specify how stroke weight affects the bounding box edge and Transform palette 
measurements. (See “Changing how stroke weight affects bounding box and path dimen-
sions” on page 213, and “Including stroke weight in measurements” on page 273.)

Editing stroke characteristics
Use the Stroke palette to select the stroke attributes. If you want to apply a stroke color, fill 
color, or gradient fill to a path, use the toolbox and Swatches palette as explained in 
“Applying color” on page 302.

To display the Stroke palette:

Choose Window > Stroke.

To change the stroke weight:

1 Using any selection tool, select the path you want to modify.

2 In the Stroke palette, choose a stroke weight value in the menu, or type a value and 
press Enter (Windows) or Return (Mac OS).

Note: Strokes thinner than 0.25 point may be too thin to see when printed on high-
resolution output devices such as an imagesetter. To remove the stroke, type a value 
of 0 (zero).

To change the cap style:

1 Using any selection tool, select the path you want to modify.
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2 In the Stroke palette, select a cap style to specify the appearance of both ends of an 
open path:

• A butt cap  creates squared ends that abut (stop at) the endpoints.

• A round cap  creates semicircular ends that extend half the stroke width beyond the 
endpoints. 

• A projecting cap  creates squared ends that extend half the stroke width beyond the 
endpoints. This option makes the stroke weight extend evenly in all directions around 
the path.

Note: You can specify a cap option for a closed path, but the cap will not be visible unless 
the path is opened (for example, by cutting with the scissors tool). Also, cap styles are 
easier to see at thicker stroke weights.

To change the miter style:

1 Using any selection tool, select the path you want to modify.

2 In the Stroke palette, for Miter Limit, type a value and press Enter (Windows) or Return 
(Mac OS). You can type a value between 1 and 500 to specify when a corner point switches 
from a miter (pointed) join to a beveled (squared-off ) join. The default miter limit is 4, 
which means that when the miter extends from the path by at least four times the stroke 
weight, the path switches from a miter join to a bevel join. A miter limit of 1 results in a 
bevel join. The Miter Limit does not apply to a round join.

3 Choose one of the following options in the Join menu to specify the appearance of the 
stroke at corner points:

• A miter join  creates pointed corners that extend beyond the endpoint when the 
miter’s length is within the miter limit.

• A round join  creates rounded corners that extend half the stroke width beyond the 
endpoints.

• A bevel join  creates squared corners that abut the endpoints.

Note: You can specify miter options for a path that doesn’t use corner points, but the miter 
options will not apply until you create corner points by adding them or by converting 
smooth points. Also, miters are easier to see at thicker stroke weights.

To change the stroke type:

1 Using any selection tool, select the path you want to modify. 

2 In the Stroke palette, choose the stroke in the Type menu.

To create a dashed line:

1 Using any selection tool, select the path you want to modify.

2 In the Stroke palette, choose Dashed in the Type menu to create a repeating pattern 
of dashes.
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3 For Dash, type at least one Dash value and one Gap value to specify the lengths of 
dashes and the gaps between them. InDesign automatically repeats the sequence 
you type.

Effects of cap options on dashed strokes

Note: Round or projecting caps, because they extend into gaps, make the gaps 
appear smaller.

About start and end shapes
Keep the following guidelines in mind as you work with start and end shapes:

• You can’t edit the available end shapes, but if you’ve obtained plug-in software that 
adds more options, the Start and End menus in the Stroke Palette can include 
additional shapes.

• End shapes are sized in proportion to the stroke weight.

• End shapes automatically rotate to match the angle of an endpoint’s direction line.

• End shapes appear at endpoints of open paths only; they won’t appear on individual 
dashes of a dashed stroke.

• If you apply end shapes to a compound path that includes open subpaths, each open 
subpath will use the same end shapes.

• You can apply end shapes to a closed path, but they won’t be visible unless you open 
the path.

Adding start and end shapes
Use the Start and End menus in the Stroke palette to add an arrowhead or other shape 
to the end of an open path. 

To add end shapes to a path:

1 Using any selection tool, select an open path.

2 In the Stroke palette, choose a style in the Start and End menus. The Start menu applies 
a shape to the first endpoint of a path (as determined by the order in which the path’s 
points were drawn), and the End menu applies a shape to the last endpoint.

Hold down Alt (Windows) or Option (Mac OS) as you select an end shape, to apply it 
to both endpoints.

To switch a path’s start and end shapes:

1 Using the direct-selection tool , select an anchor point.
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2 Choose Object > Reverse Path.

Changing how stroke weight affects bounding box and path 
dimensions
When you change the stroke weight of a path, the outer dimensions of the path’s 
bounding box are preserved by default. This maintains the position of the stroke’s outer 
edge while its inner edge grows or shrinks with the stroke weight. The position and 
dimensions of the path (which lies at the center of the stroke) are changed accordingly. 
If you want to constrain the path’s position and dimensions, select the Weight Changes 
Bounding Box option.

A. Original path B. Stroke weight increased C. Stroke weight increased 
after selecting Weight Changes Bounding Box option

This option affects bounding box and path dimensions only; to specify whether paths are 
measured from the centers of their strokes or from their edges, see “Including stroke 
weight in measurements” on page 273.

Note: This option does not change how the weight of the stroke itself increases or 
decreases; weight always changes equally on both the inside and the outside of a path. 
You can observe this by selecting a path with the direct-selection tool before changing its 
stroke weight.

To change how stroke weight affects a path’s bounding boxes:

In the Stroke palette menu, do one of the following:

• Leave the Weight Changes Bounding Box deselected (the default) to keep paths 
aligned to guides, grids, or other layout objects when you change their stroke weights.

• Select the Weight Changes Bounding Box to preserve the dimensions of paths when 
you change their stroke weights, letting their outer edges expand or contract.

Using corner effects
You can use the Corner Effects command to quickly apply corner styles to any path. 
Available corner effects range from simply rounded corners to fancy ornamentation. If 
you’ve obtained plug-in software that adds more effects, the Corner Effects command in 
the Stroke palette can include additional shapes.

About corner effects
Corner effects appear on all of a path’s corner points, but never on smooth points. The 
effects change angles automatically when you move a path’s corner points. 

A B C
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If a corner effect significantly changes the path by, for example, creating a bulge inward or 
outward, it may affect how a frame interacts with its contents or with other parts of the 
layout. Increasing the size of a corner effect may push an existing text wrap or frame inset 
farther away from the frame.

Applying corner effects
You can’t edit a corner effect, but you can change its appearance by changing the corner 
radius or modifying the stroke.

If you applied corner effects but can’t see them, make sure that the path uses corner 
points and that a stroke color or gradient has been applied to it. Then increase the Size 
option in the Corner Effects dialog box, or increase the stroke weight in the Stroke palette. 

A. Fancy corner effect with no stroke B. Same effect with 1-point stroke  
C. Same effect with 4-point stroke

To apply a corner effect:

1 Using a selection tool, select a path.

2 Choose Object > Corner Effects.

3 Choose a corner effect in the Effect menu.

4 For Size, type a value to specify the radius by which the corner effect extends from each 
corner point.

5 Select Preview if you want to see the results of the effect before applying it. Then 
click OK.

Working with compound paths
You can combine several paths into a single object, called a compound path. Create a 
compound path when you want to do any of the following:

• Add transparent holes to a path.

• Preserve the transparent holes within some text characters, such as o and e, when you 
convert characters to editable letterforms using the Create Outlines command. Using 
the Create Outlines command always results in the creation of compound paths.

• Apply a gradient, or add contents that span multiple paths. Although you can also 
apply a gradient across multiple objects using the gradient tool, applying a gradient to 
a compound path is often a better method because you can later edit the entire 
gradient by selecting any of the subpaths. With the gradient tool, later editing requires 
selecting all of the paths you originally selected.

About editing compound paths
Keep the following guidelines in mind as you edit compound paths:

A B C
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• Changes to path attributes (such as stroke and fill) always alter all subpaths in a 
composite path—it doesn’t matter which selection tool you use, or how many 
subpaths you select. To preserve the individual stroke and fill attributes of the paths 
you want to combine, group them instead.

• In a compound path, any effect that is positioned relative to a path’s bounding box—
such as a gradient, or an image pasted inside—is actually positioned relative to the 
bounding box of the entire compound path (that is, the path that encloses all of the 
subpaths).

• If you make a compound path, then change its properties and release it, using the 
Release command, the released paths inherit the compound path’s properties; they 
don’t regain their original properties.

• If your document contains compound paths with many smooth points, some output 
devices may have problems printing them. If so, simplify or eliminate the compound 
paths, or convert them to bitmap images using a program such as Adobe Photoshop.

• If you apply a fill to a compound path, holes sometimes don’t appear where you expect 
them to. For a simple path like a rectangle, the inside, or the area you can fill, is easy to 
see—it’s the area within the enclosed path. However, with a compound path, InDesign 
must determine whether the intersections created by a compound path’s subpaths 
are inside (filled areas) or outside (holes). The direction of each subpath—the order 
in which its points were created—determines whether the area it defines is inside 
or outside. If a subpath is filled when you want it be a hole, or vice versa, reverse the 
direction of that subpath. 

Compound path containing two subpaths with same 
path directions (left) and opposite path directions (right)

Creating and editing compound paths
You can create a compound path from two or more open or closed paths. When you create 
a compound path, all of the originally selected paths become subpaths of the new 
compound path. The selected paths inherit the stroke and fill settings of the object 
farthest back in the stacking order.

Note: If one or more selected objects have contents, such as text or imported images, the 
attributes and contents of a compound path are set by the attributes and contents of the 
object farthest back. Selected objects farther behind, without contents, won’t affect the 
compound path.

You can change the shape of any part of a compound path by using the direct-selection 
tool to select one anchor point on one subpath. You can break up a compound path by 
releasing it, which turns each of its subpaths into an independent path. Finally, you can 
specify where holes appear in a compound path by reversing the path’s direction.
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To create a compound path:

1 Use the selection tool  to select all of the paths you want to include in the 
compound path.

2 Choose Object > Compound Paths > Make. A hole appears wherever selected 
paths overlap.

Two separate closed paths (left) and two subpaths of the same compound 
path (right); the compound path uses the center circle as a hole

To break up a compound path:

1 Using the selection tool, select a compound path.

2 Choose Object > Compound Paths > Release.

Note: The Release command is unavailable when the selected compound path 
is contained inside a frame, or when the path contains text.

To reverse the direction of a subpath:

1 Using the direct-selection tool, select a point on the subpath you want to reverse. 
Don’t select the entire compound path.

2 Choose Object > Reverse Path.

Creating paths from text outlines
Use the Create Outlines command to convert selected text characters into a set of 
compound paths that you can edit and manipulate as you would any other path. The 
Create Outlines command is useful for creating effects in large display type, but it is 
rarely useful for body text or other smaller-size type.

If you simply want to apply a color stroke, or a gradient fill or stroke to text characters, 
you don’t need to convert the text to outlines. You can use the toolbox and the 

Swatches, Color, or Gradient palettes to apply colors and gradients directly to the strokes 
or fills of selected characters.

About creating text outlines
The Create Outlines command gets its font outline information from the actual Type 1, 
TrueType, or OpenType files. When you create outlines, characters are converted in their 
current positions, retaining all graphics formatting, such as stroke and fill. 

When you convert type to outlines, the type loses its hints—instructions built into outline 
fonts for adjusting their shapes, so that your system displays or prints them optimally at 
small sizes. Therefore, type converted to outlines may not display as well when rendered in 
small sizes or at low resolutions.
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After converting type to outlines, you can do any of the following:

• Alter the letterforms by dragging individual anchor points using the direct-selection 
tool.

• Use the Edit > Paste Into command to mask an image by pasting it into the converted 
outlines.

• Use the converted outlines as text frames, so that you can type or place text in them.

A. Type character B. Image pasted into outline, creating frame C. Outline with type or placed text

Because converted text outlines become sets of compound paths, you can edit individual 
subpaths of converted outlines by using the direct-selection tool. You can also break the 
character outlines into independent paths by releasing them from the compound path. 
(See “Creating and editing compound paths” on page 215.)

Converting text outlines to paths
By default, creating outlines from type removes the original text. However, if you prefer, 
you can make outlines appear over a copy of the original text, so that none of the text is 
lost.

When you select type characters in a text frame and convert them to outlines, the 
resulting outlines become inline graphics that flow with the text. Because the converted 
text is no longer true type, you will no longer be able to highlight and edit the characters 
using the type tool. In addition, typographical controls will no longer apply. For example, a 
word converted to outlines will not hyphenate at the end of a line. Make sure that you’re 
satisfied with the typographic settings of the type you convert to outlines, and be sure to 
create a copy of the original text.

To convert text outlines to paths:

1 Use the selection tool  to select a text frame, or use the type tool  to select one or 
more characters.

2 Choose Type > Create Outlines.

A B C
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To convert a copy of text outlines to paths:

1 Use the selection tool  to select a text frame, or use the type tool  to select one or 
more characters.

2 Hold down Alt (Windows) or Option (Mac OS) as you choose Type > Create Outlines. 
The copy is created exactly on top of the original; use the selection tool to drag it away, if 
you like.

Note: Some font manufacturers block the information needed to create outlines. If you 
select such a protected font and choose Type > Create Outlines, a message will explain 
that the font cannot be converted.
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Importing, Exporting, 
and Managing Graphics

About vector graphics and bitmap images
Computer graphics fall into two main categories—vector graphics and bitmap images.

Vector graphics are made of lines and curves defined by mathematical objects called 
vectors. You can freely resize or magnify vector graphics without losing sharpness, 
because they are resolution-independent—the number of pixels used to display a vector 
graphic is determined by the resolution of the monitor or printer, not by the graphic itself. 
This is because a vector graphic is not converted to pixels until it is displayed or printed. 
The objects you create using the drawing tools in the InDesign toolbox are examples of 
vector graphics.

Bitmap images, also called raster images, are composed of small squares, known as pixels, 
that lie on grids (also known as a bitmaps or rasters). Bitmap images are the most common 
electronic medium for such continuous-tone images as photographs or images created in 
painting programs like Adobe Photoshop. Bitmap images are resolution-dependent—that 
is, they represent a fixed number of pixels. As a result, they can lose detail and appear 
jagged if they are scaled on-screen or if they are printed at a higher resolution than they 
were created for. Bitmap images often require large amounts of storage space, and often 
need to be compressed to keep file sizes down. You compress an image file in its original 
application before you import it into InDesign.

You can store computer graphics as bitmap images, vector graphics, or a combination of 
both, depending on the graphics file format.

Resolution for bitmap images
Resolution is the number of dots or pixels per linear unit used in the reproduction of 
artwork and images. 
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In print publishing, resolution is the density of pixels per inch, expressed as pixels per inch 
(ppi) or dots per inch (dpi). In the video-based graphics used in Web publishing, resolution 
usually means the horizontal and vertical dimensions of an image, expressed in pixels, such 
as 640-by-480. It’s important not to confuse screen or printer resolution with screen 
frequency or screen ruling.

72-dpi image (top) and 300-dpi image (bottom)

The following guidelines can help you determine your requirements for image resolution:

• Commercial printing requires 150 to 300 ppi (or more) images, depending on the press 
(dpi) and screen frequency (lpi) you’re using; always consult your prepress service 
provider before making production decisions. Because commercial printing requires 
large, high-resolution images, which take more time to display while you’re working 
with them, you may want to use low-resolution versions for layout and then replace 
them with high-resolution versions at print time, using the Links palette or the Open 
Prepress Interface. (See “Managing links and embedded graphics” on page 235, and 
“Determining how graphics print” on page 399.)

• Desktop printing usually requires images within the range of 72 ppi (for photographs 
printed on a 300 ppi printer) to 150 ppi (for photographs printed on devices up to 1000 
ppi). For line art (1-bit images), make sure that the resolution of your graphics matches 
the resolution of the printer.

• Because online publishing generally requires images with pixel dimensions that fit the 
intended monitor, the images are usually less than 500 pixels wide and 400 pixels tall, to 
leave room for browser window controls or such layout elements as captions. Creating 
an original image at screen resolution—96 ppi for Windows–based images, and 72 ppi 
for Mac OS–based images—lets you see the image as it will likely appear when viewed 
from a typical Web browser. When you’re publishing online, the only times you’re likely to 
need resolutions above those ranges are when you want viewers to be able to zoom in 
for more detail in a PDF document, or when you’re producing a document for printing 
on demand.



Using Help | Contents | Index Back 221  

Adobe InDesign Help Importing, Exporting, and Managing Graphics 

Using Help | Contents | Index Back 221  

Controlling image display quality and performance
Use the Display Performance settings to balance display speed and quality. You can 
specify the quality of how raster images, vector graphics, and transparencies are drawn. 
These settings give you more control over screen display performance and quality without 
compromising your printed output. The setting can then be applied to each window 
(View) or a local setting can be applied to individual page items. The following display 
settings are available:

Optimized Draws a raster image or vector graphic as a gray box (default). Use this 
option when you want to quickly page through spreads that have lots of images or trans-
parency effects.

Typical Draws a low-resolution proxy image (default) appropriate for identifying and 
positioning an image or vector graphic. Typical is the default option, and is the fastest way 
to display an identifiable image.

High Quality Draws a raster image or vector graphic at High Resolution (default). This 
option provides the highest quality but the slowest performance. Use this option when 
you want to fine-tune an image.

Note: Image display options don’t affect output resolution when exporting or printing 
images within an InDesign document. When printing to a PostScript device or exporting to 
HTML, EPS, or PDF files, the final image resolution depends on the output options you 
choose when you print or export the file.

A. Optimized B. Typical C. High Quality

Adjusting display group settings 
Using the Display Performance dialog box, define the settings for each display group, 
adjusting the values for raster images, vector graphics, and transparency, and then apply 
these settings to the window, individual image, or graphic.

To define display performance settings:

1 Select Edit > Preferences > Display Performance (Windows and Mac OS 9), or 
InDesign > Preferences > Display Performance (Mac OS 10.1).

2 In the Default View Settings section, select Typical, Optimized, or High Quality. Default 
View Settings will be automatically applied to each new window.

3 In the Adjust View Settings section, select a display group, and then adjust the 
following options:

Raster Images Slider Controls the display of bitmap images using one of three options:

• Gray Out draws an image as a gray box.

• Proxy draws images at proxy resolution (72 dpi).

CBA
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• High Resolution draws images at maximum resolution supported by the monitor and 
current view settings.

Vector Graphics Slider Controls the display of resolution-independent graphics. These 
settings are the same as those of the Raster Images Slider. See the paragraph above.

Transparency Slider Controls the display of transparency effects using one of 
four options:

• Off displays no transparency effects.

• Low Quality displays basic transparency (opacity and blend modes), and transparency 
effects (drop shadow and feather) are shown in a low-resolution approximation.

Note: In this mode, page contents are not isolated from the background; therefore, objects 
with blend modes other than Normal might appear different in other applications and 
final output.

• Medium Quality displays low-resolution drop shadows and feathers. This mode is 
recommended for most work unless the document is particularly transparency-heavy, 
or has many transparency effects.

• High Quality displays higher-resolution (144 dpi) drop shadows and feathers, CMYK 
mattes, and spread isolation.

Note: When a document’s blending space is CMYK and you have either enabled the 
overprint preview mode or soft proofing, opacity matting is done in CMYK rather than 
RGB. This means that partially transparent CMYK colors display as tinted CMYK colors. 

For more information on transparent objects, see “About transparency” on page 287.

Enable Anti-Aliasing Controls anti-aliasing for text, stroke, fill, and other page items. If 
text is converted to outlines, then the resulting outlines can be anti-aliased (Mac OS only). 
(See “Setting anti-aliasing” on page 19.)

Use Defaults Resets all controls back to the original default settings.

Greek Type Below Sets the greeking limit for text. Any type at or below the specified 
type size displays as a dimmed bar. (See “Greeking type” on page 19.)

4 Click OK.

To control display quality for all images and vector graphics:

Select a display setting in the View menu.

To control display quality for one object independent of the current View setting:

1 With the selection tool  or direct-selection tool , select an imported graphic.

2 Do one of the following:

• Select Object > Display Performance, and then choose a display setting.

• Right-click (Windows) or Control-click (Mac OS) the image. in the context menu 
that appears, choose a display setting from the Display Performance submenu.
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Preparing graphics to be imported
Because of the many ways you can output a document, a graphic may be ideal for one 
purpose and inappropriate for another. The following table summarizes how best to 
create graphics for the kind of document you’re designing. (See also “Understanding 
graphics formats and their options” on page 224.)

Placing a graphic
The Place command is used most often, and it’s the recommended way to import a graphic. 
You can also import a graphic from your desktop, or from any removable media, by using 
drag-and-drop or copy-and-paste. The drag-and-drop method works like the Place 
command, with images appearing in the Links palette after they’re imported; however, 
you cannot set import options for the files you drag and drop. (See “Alternate methods for 
importing graphics” on page 233.)

Note: If you place or drag and drop a graphic from a removable medium, such as a CD-
ROM, the link will break when you remove that medium from your system.

To import a graphic by placing it:

1 Do one of the following:

• To import a graphic without first creating a frame, make sure that nothing in the 
document is selected.

• To import a graphic into an existing frame, select the frame.

• To replace an existing image, select the graphics frame.

2 Choose File > Place and select a graphics file.

3 If you want to view the graphics file before importing, select Preview.

4 If you want to replace the selected object, select Replace Selected Item.

Final output Graphics type Format

High resolution 
(>1000 dpi)

Vector drawings Illustrator, EPS, PDF

Bitmap images Photoshop, TIFF, EPS, PDF

Process-color 
separations

Vector drawings Illustrator, EPS, PDF

Color bitmap 
images

Photoshop, CMYK TIFF, DCS, 
EPS, PDF

Color-managed 
graphics

Illustrator, Photoshop, RGB 
TIFF, RGB EPS, PDF

Low-resolution 
printing, or PDF 
for online viewing

All Any (BMP images only)

HTML All Any (InDesign converts 
graphics to JPEG and GIF 
when exporting)
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5 If you want to set format-specific import options, do one of the following:

• Select Show Import Options to see format-specific settings, and then click Open 
(Windows) or Choose (Mac OS).

• Hold down Shift as you click Open/Choose or Shift-double-click a filename.

6 If another dialog box appears, select your import options, and click OK. (See “Under-
standing graphics formats and their options” on page 224.)

7 Do one of the following:

• To import into a new frame, click the loaded graphics icon  in the layout at the place 
where you want the upper left corner of the graphic to appear.

• To import into an existing unselected frame, click the loaded graphics icon  anywhere 
in that frame.

• To import into an existing selected frame, you don’t need to do anything; the image 
automatically appears in that frame.

If you accidently replace an existing graphic with an image you’re placing, you can 
undo the placement by pressing Ctrl+Z (Windows) or Command+Z (Mac OS) to return 

the original image to the frame, and display the loaded graphics icon.

Understanding graphics formats and their options
Because documents have varying requirements for the handling of their graphics, 
InDesign can import a wide range of graphics file formats, most of which have options for 
controlling how the file is imported. By identifying the scope and purpose of your 
document and workflow, and consulting with the service providers who will help you 
produce your document, you can clarify which options to use. You can then plan your 
document around only those formats and options that best apply to your project.

The options available to you when you place a graphics file depend on the kinds of 
graphics you’ve decided to place. These options appear in dialog boxes when the Show 
Import Options is selected in the Place dialog box. The options you set remain in effect 
until you change them. If Show Import Options is not selected in the Place dialog box, 
InDesign applies the default settings, or the last settings used in placing a graphics file of 
that type. When PNG files are imported, the settings in the Import Options dialog box are 
always based on the selected file, not on the default or last-used settings.

Importing different file formats into a document
You use different file formats to achieve different results in a document. For example, a 
single InDesign spread could contain the following:

• Pages from an InDesign document exported to a PDF as single page or spread, and 
then re-imported and scaled.

• An imported bitmap EPS containing a clipping path created in Adobe Photoshop is 
used to make a transparent background in InDesign. 

• A Photoshop 1-bit and 24-bit TIFF image that uses white areas in the image to create 
a transparency for the background image to show through. 

• An EPS vector drawing from Adobe Illustrator.
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Importing format options
If you select Show Import Options when placing a bitmap graphic, you’ll see a dialog box 
containing these options:

Apply Photoshop Clipping Path Importing a clipping path that is saved with an image 
created in Photoshop gives you the ability to directly select an image and modify its path 
without changing the graphic frame. If this option isn’t available, the image was not saved 
with a clipping path, or the file format does not support clipping paths. If your bitmap 
image does not have a clipping path, you can create one automatically in InDesign; see 
“Using clipping paths to remove backgrounds from imported graphics” on page 262.

Image imported without clipping path (left) and with clipping path (right)

Color settings for all bitmap formats
You can apply color management options to individual imported graphics when using 
color management tools with your document. The following options are available when 
placing a bitmap graphic if you select Show Import Options, and then select Color 
Settings in the Import Image Options dialog box:

Enable Color Management Select this option to apply color management to the 
graphic you’re importing, and to activate the other options in this panel. Deselect this 
option if consistent color is not required for this graphic. 

Profile If Use Embedded is selected, leave this option unchanged. Otherwise, choose a 
color source profile that matches the gamut of the device or software used to create the 
graphic. This profile enables InDesign to properly translate its color to the gamut of the 
output device. (See “Obtaining, installing, and updating color profiles” on page 351.)

Rendering Intent Choose a method for scaling the color range of the graphic to the color 
range of the output device. Typically, you’ll choose Perceptual (Images), because it 
accurately represents colors in photographs. The Saturation (Graphics), Relative Colori-
metric, and Absolute Colorimetric options are better for areas of solid color, and do not 
reproduce photographs well. For a description of each Intent option, see ““About color 
management” on page 337.

Adobe Illustrator (.AI)
Artwork in Adobe Illustrator 5.5 and later can be placed directly into an InDesign layout. 
When you place an Illustrator 9.0 and later graphic using the Show Import Options dialog 
box, the options are identical to those for PDF files; see “Placing a PDF file” on page 230. 
When you place an Illustrator 5.5–8.0 graphic, the options are identical to those for EPS 
files; see “EPS (.EPS)” on page 226. 

If an Adobe Illustrator version 9.0 and later file contains transparent objects, the trans-
parency is preserved and will allow underlying artwork to show through.
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Adobe Photoshop (.PSD)
You can place Adobe Photoshop 4.0 and later images directly into a layout. When a 
Photoshop file is placed in a document, all layers and layer masks are automatically 
flattened. These changes affect the file inside the InDesign document only—the original 
Photoshop file is not altered. If you save paths, masks, or alpha channels in a Photoshop 
file, InDesign can use them to remove backgrounds, or to wrap text around graphics. 
Graphics that contain paths, masks, or alpha channels act as transparent objects when 
imported and interact only where the background is transparent; see “Working with 
clipping paths” on page 261 and “Wrapping text around objects” on page 101.

If you embedded an ICC color management profile in an Adobe Photoshop image, 
InDesign automatically reads the embedded profile. You can override the embedded 
profile while you’re importing a file by selecting Enable Color Settings in the Import Image 
dialog box. You can also override this profile after you import the file, by choosing Object 
> Image Color Settings. These actions will not remove or alter the profile embedded in the 
Photoshop image.

BMP (.BMP)
BMP is the standard Windows bitmap image format on DOS and Windows-compatible 
computers. However, BMP does not support CMYK, and its color support is limited to 1, 4, 
8, or 24 bits. It is less than ideal for commercially printed or online documents, and it is not 
supported by Web browsers. BMP graphics can provide acceptable quality when printed on 
low-resolution or non-PostScript printers.

DCS (.DCS)
Desktop Color Separations (DCS), developed by Quark, is a version of the standard EPS 
format. The DCS 2.0 format supports multichannel CMYK files with a single alpha channel 
and multiple spot channels; the DCS 1.0 format supports CMYK files without alpha 
channels. InDesign recognizes clipping paths in Photoshop-created DCS 1.0 and DCS 2.0 
files.

DCS files are intended to be used in a pre-separated, host-based workflow. If you export to 
a composite PDF, EPS, or PostScript® file from InDesign, only the composite EPS file is 
exported; the color separation files are not preserved. It is not recommended to color 
separate DCS files in-RIP or from a composite file. DCS files should not be used to create 
high-resolution color composite proofs.

EPS (.EPS)
The Encapsulated PostScript (EPS) file format is used to transfer PostScript language 
artwork between applications, and is supported by most illustration and page-layout 
programs. Typically, EPS files represent single illustrations or tables that are placed into 
your layout, but an EPS file can also represent a complete page. 

Because they are based on the PostScript language, EPS files can contain both vector and 
bitmap graphics. Since PostScript cannot normally be displayed on-screen, InDesign 
creates a bitmap preview for an EPS file for on-screen display. If you print a page with an 
EPS file to a non-PostScript printer, only this screen-resolution preview will be printed.

EPS allows for prepress-quality resolution, precision, and color. This format includes all of 
the color and image data required to color-separate DCS images embedded in the EPS 
graphic. EPS isn’t ideal for online publishing in HTML, but it works well for online 
publishing in PDF.
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EPS files can contain Open Prepress Interface (OPI) comments, which let you use fast, low-
resolution versions (proxies) of images for positioning on a page. For final output, either 
InDesign or your prepress service provider can automatically replace the proxies with high-
resolution versions.

When you place an EPS graphic and select Show Import Options, you’ll see a dialog box 
containing these options:

Read Embedded OPI Image Links This option tells InDesign to read links from OPI 
comments for images included (or nested) in the graphic.

Deselect this option if you’re using a proxy-based workflow and plan to have your service 
providers perform the image replacement using their OPI software. When this option is 
deselected, InDesign preserves the OPI links, but does not read them. When you print or 
export, the proxy and the links are passed on to the output file.

Select this option if you’re using a proxy-based workflow and you want InDesign, instead 
of your service provider, to perform image replacement when you output the final file. 
When you select this option, the OPI links appear in the Links palette. (See “Determining 
how graphics print” on page 399.)

Also select this option when you import EPS files containing OPI comments that are not 
part of a proxy-based workflow. For example, if you import an EPS file containing OPI 
comments for an omitted TIFF or bitmap image, you’ll want to select this option so that 
InDesign can access the TIFF information when you output the file.

Apply Photoshop Clipping Path Select this option to import a clipping path from 
a Photoshop 4.0 and later EPS file, which you can later edit in InDesign.

Proxy Generation This creates a low-resolution bitmap representation of an image 
when drawing the file to the screen. The following settings control how the proxy will 
be generated:

• Some EPS images contain an embedded preview. Select Use TIFF or PICT Preview to 
generate the proxy image of the existing preview. If a preview does not exist, the proxy 
will be generated by rasterizing the EPS to an offscreen bitmap (the quality of the 
bitmap is dependent on the quality of the embedded preview).

• Select Rasterize the PostScript to ignore the embedded preview. This option is typically 
slower but provides the highest-quality results.

Note: All instances of the imported file share the proxy setting when more than one single 
file is imported into the same document.

GIF (.GIF)
Graphics Interchange Format (GIF) is a standard for displaying graphics on the World Wide 
Web and other online services. Because it compresses image data without losing detail, its 
compression method is called lossless. Such compression works well with graphics that 
use a limited number of solid colors such as logos and charts; however, GIF cannot display 
more than 256 colors. For this reason it is less effective for displaying photographs online 
(use JPEG instead) and is not recommended for commercial printing. If an imported GIF file 
contains transparency, the graphic interacts only where the background is transparent. 
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JPEG (.JPG)
The Joint Photographic Experts Group (JPEG) format is commonly used to display photo-
graphs and other continuous-tone images in hypertext markup language (HTML) files 
over the World Wide Web and in other online media. The JPEG format supports CMYK, 
RGB, and grayscale color modes. Unlike GIF, JPEG retains all of the color information in an 
RGB image. 

JPEG uses an adjustable, lossy compression scheme that effectively reduces file size by 
identifying and discarding extra data not essential to the display of the image. A higher 
level of compression results in lower image quality; a lower level of compression results in 
better image quality, but a larger file size. In most cases, compressing an image using the 
Maximum quality option produces a result that is indistinguishable from the original. 
Opening a JPEG image automatically decompresses it.

Note: JPEG encoding, which can be performed on an EPS or DCS file in an image-editing 
application such as Adobe Photoshop, does not create a JPEG file. Instead, it compresses the 
file using the JPEG compression scheme explained above.

JPEG works well for photographs, but solid-color JPEG images (images that contain large 
expanses of one color) tend to lose sharpness. InDesign recognizes and supports 
clipping paths in JPEG files created in Adobe Photoshop. JPEG can be used for both online 
and commercially printed documents; work with your prepress service provider to 
preserve JPEG quality in printing.

PICT (.PICT)
The Macintosh PICT (or Picture) format is widely used for Mac OS graphics and page-
layout applications, and for transferring files between applications. The PICT format is 
especially effective in compressing images that contain large areas of solid color. InDesign 
for both Windows and Mac OS imports PICT files created from Mac OS screenshots and a 
variety of other applications, including clipart collections.

InDesign supports RGB PICT images with variable resolutions and embedded QuickTime 
images. PICT graphics do not support color separations, are device-dependent, and are 
not recommended for high-resolution commercial printing. The PICT format can provide 
acceptable quality only when printed on low-resolution or non-PostScript printers. 

WMF (.WMF)
The Windows Metafile Format (WMF) is a native Windows format used primarily for vector 
graphics, such as clip art, shared between Windows applications. WMF files may contain 
raster image information; however, InDesign recognizes the vector information only. WMF 
color support is limited to 16-bit RGB, and the format does not support color separations. 
It is not an ideal choice for commercially printed or online documents. WMF graphics can 
provide acceptable quality only when printed on low-resolution or non-PostScript 
printers.

PCX (.PCX)
The PCX format is commonly used in Windows systems. Most Windows software supports 
version 5 of the PCX format.
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The PCX format supports RGB, indexed-color, grayscale, and bitmap color modes, as well 
as the RLE compression method, which is lossless. It does not support alpha channels. 
Images can have a bit depth of 1, 4, 8, or 24 bits. However, PCX is not ideal for commer-
cially printed or online documents. PCX graphics can provide acceptable quality only 
when printed on low-resolution or non PostScript printers.

PDF (.PDF)
The Adobe Acrobat Portable Document Format (PDF) is standard for the electronic distri-
bution and viewing of complete documents. It preserves the layout, typography, bitmap 
images, and vector graphics files created in a great number of different applications. PDF 
can preserve color quality and layout precision for prepress work while compressing 
pages sufficiently for online distribution and viewing. PDF files can be viewed using the 
free Acrobat Reader®. For all of these reasons, PDF is a common format on the World Wide 
Web.

Based on the industry-standard Adobe PostScript 3™ page-description language for 
professional printing, PDF pages are similar to PostScript pages, but can also contain 
multimedia elements and features for searching and navigating electronic documents. For 
example, PDF files can contain movies, sound, hypertext links, and electronic tables of 
contents. However, InDesign doesn’t import included movies, sound, links, or buttons 
when you place a PDF file.

You can place a PDF page as a single graphic in InDesign using the Place command (see 
“Placing a PDF file” on page 230), or you can create an Acrobat 5.0–compatible PDF file 
using the Export command (see “Creating Adobe PDF Files” on page 361). 

If an imported PDF 1.4 (Acrobat 5.0) file contains transparent objects, the transparency is 
preserved and will allow underlying artwork to show through.

PNG (.PNG)
The Portable Network Graphics (PNG) format uses adjustable, lossless compression to 
display 24-bit photographs or solid-color images on the World Wide Web and in other 
online media. PNG was developed as a patent-free alternative to the GIF file format. It 
supports transparency in an alpha channel or a designated color. PNG is best used for 
online documents, although its color support makes it better for printed documents than 
GIF. However, color PNG graphics placed in an InDesign document are RGB bitmap 
images, so they print only as composites, not on color separations.

When you place a PNG image, you can select Show Import Options to see a dialog box 
with three panels of import settings. Two panels contain the same options available for 
other bitmap image formats. The other panel, PNG Settings, contains the following 
settings:

Use Transparency Information This option is enabled by default when a PNG graphic 
includes transparency. If an imported PNG file contains transparency, the graphic interacts 
only where the background is transparent. 

White Background If a PNG graphic does not contain a file-defined background color, 
this option will be selected by default. However, it is only enabled if Use Transparency 
Information is activated. If this option is selected, white is used as the background color 
when applying transparency information.
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File Defined Background Color If a PNG graphic was saved with a non-white 
background color, and Use Transparency Information is selected, this option is selected 
by default. If you don’t want to use the default background color, click White Background 
to import the graphic with a white background, or deselect Use Transparency Information 
to import the graphic without any transparency (displaying areas of the graphic that are 
currently transparent). Some image-editing programs can’t specify a non-white 
background color for PNG graphics.

Apply Gamma Correction Select this option to adjust the gamma (midtone) values of a 
PNG graphic as you place it. This option lets you match image gamma to the gamma of 
the device you will use to print or display the graphic (such as a low-resolution or non-
PostScript printer or computer monitor). Deselect this option to place the image without 
applying any gamma correction. By default, this option is selected if the PNG graphic was 
saved with a gamma value.

Gamma Value This option, available only if Apply Gamma Correction is selected, displays 
the gamma value that was saved with the graphic. To change the value, type a positive 
number from 0.01 to 3.0.

Scitex CT (.SCT)
The Scitex Continuous Tone (CT) format is used for high-end image processing on Scitex 
computers. Scitex CT files often come from Scitex scanners, which produce high-quality 
scans for commercial printing. The Scitex CT format supports CMYK, RGB, and grayscale 
files, but does not support alpha channels. Contact Scitex to obtain utilities for transferring 
files saved in the Scitex CT format to a Scitex system.

TIFF (.TIF)
TIFF is a flexible bitmap image format supported by virtually all paint, image-editing, and 
page-layout applications. Also, virtually all desktop scanners can produce TIFF images.

The TIFF format supports CMYK, RGB, grayscale, Lab, indexed-color, and bitmap files with 
alpha channels. InDesign recognizes OPI comments encoded in TIFF files. You can use an 
image-editing program such as Photoshop to create a clipping path if you want to create a 
transparent background for a TIFF image. InDesign supports clipping paths in TIFF images.

Placing a PDF file
Using the Place command, you can reuse existing PDF files in imaginative ways. For 
example, you can select an individual page from a catalog saved as PDF, and place it into 
an ad or brochure you’re creating in InDesign. InDesign preserves the layout, graphics, and 
typography in a placed PDF file. As with other placed graphics, you cannot edit a placed 
PDF page within InDesign.
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To place a PDF file:

1 Choose File > Place and select the PDF file you want to place.

2 To see a preview of a page in the PDF file, or to select options for placing specific pages, 
select Show Import Options, and then click Open (Windows) or Choose (Mac OS).

Place PDF dialog box for importing PDF files

3 Enter any required passwords, and click OK. If the PDF file was saved with any usage 
restrictions (for example, no editing or printing), you cannot place any pages from the file, 
whether or not you have the password.

4 If you are placing a page from a PDF file that contains multiple pages, select the page 
you want to place. Click the arrows, or type a page number under the preview image, to 
view a page before you place the file.

5 For Crop to, specify how much of the PDF page to place:

• Crop places the PDF only in the area that is displayed or printed by Adobe Acrobat.

• Content places the PDF page’s bounding box, or the minimum area that encloses the 
objects on the page, including page marks.

• Art places the PDF only in the area defined by a rectangle that the author created as a 
placeable artwork (for example, clip art).

• Trim identifies the place where the final produced page will be physically cut in the 
production process, if trim marks are present.

• Bleed places only the area that represents where all page content should be clipped, if a 
bleed area is present. This information is useful if the page is being output in a 
production environment. Note that the printed page may include page marks that fall 
outside the bleed area.
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• Media places the area that represents the physical paper size of the original PDF 
document (for example, the dimensions of an A4 sheet of paper), including page 
marks.

A. Media B. Content C. Bleed D. Trim E. Crop F. Art

6 Specify the following options, and click OK:

• Preserve Halftone Screens overrides InDesign’s settings when the PDF file contains 
halftone screen settings. This option applies only when InDesign is printing to a 
PostScript output device.

• Transparent Background places the PDF page so that you can see any text or graphics 
behind it on the InDesign layout. Deselecting this option places the PDF page with an 
opaque white background.

If you make the background transparent in a frame containing a PDF graphic, you can 
make it opaque later by adding a fill to the frame.

7 To add a graphic to the layout, click the place icon  where you want the upper left 
corner of the graphic to appear.

Comparing screen and device resolution in placed PDF pages 
A placed PDF page displays at the best resolution possible for the given scale and screen 
resolution. When printed on a PostScript output device, a placed PDF page always prints 
at the resolution of the device. When printed on a non-PostScript printer, a placed PDF 
page prints at the same resolution as the other InDesign objects in the document. For 
example, vector (drawn) objects will print at the same resolution as other vector objects in 
the document. Bitmap images will print at the best resolution supplied in the placed PDF 
file. 

Note: Non-PostScript printers do not support tinting for type or screen optimization for 
images, so their output quality will be inferior. 

A B

C D

E F
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Managing links in placed PDF files
A placed PDF page appears in the InDesign document as an on-screen preview, which is 
linked to a specific page in the original PDF file. If you change a PDF page after you place 
it, you may break the links. Consider the following:

• If you change the security settings in the original PDF file, the placed PDF page changes 
to a gray box.

• If you delete pages in the original PDF file, the placed PDF page changes to the page 
that now falls on the originally placed page number. 

• If you reorder the pages in the original PDF file and update the link, the placed PDF 
page may be different from what you expect. When that happens, place the page 
again.

Color and color management in placed PDF pages
Although high-fidelity colors, such as the PANTONE Hexachrome® system, are not 
supported by InDesign, those colors will be preserved in a placed PDF page. In addition, 
any color traps included in a placed PDF page will be preserved.

If a PDF file you’ve placed contains embedded ICC profiles, that information will control 
the way the file displays and prints from InDesign, and the profiles will be passed through 
when you print or generate PDF files. However, you cannot currently assign an ICC profile 
to placed PDF files that don’t already contain ICC profiles.

How security settings in placed PDF pages affect InDesign 
documents
Because a placed PDF page is linked to the original PDF file, the placed page also includes 
the security settings of the original file. If someone later changes the security settings in 
the original file, the security settings are updated in the placed PDF page when you 
update the links.

Whenever a placed PDF page has tighter security than the InDesign document to be 
exported, the placed PDF page will export as a gray box.

Alternate methods for importing graphics
The Place command is the primary method of importing, because it provides the 
highest level of support for resolution, file formats, and color, via the import options 
included with most file types. If you’re creating a document where those characteristics 
aren’t critical, you can copy and paste or drag-and-drop to import graphics into InDesign. 
When you use these methods to transfer a graphic into an InDesign document, some 
attributes of the original object may be lost, depending on the limitations of the operating 
system and the range of data types the other application makes available for transfer.

Copying and pasting or dragging and dropping between two InDesign documents, or 
within a single document, preserves all of the graphics attributes that were imported or 
applied. For example, if you copy a graphic from one InDesign document and paste it into 
another, the new copy will be an exact duplicate of the original, even including the 
original’s link information, so that you can update graphic when the file on disk changes. 
(See “Managing links and embedded graphics” on page 235.)

Note: You cannot use Object Linking and Embedding (OLE) or Publish and Subscribe (Mac OS) to 
import graphics. Many programs do not reliably preserve file format, color, and resolution 
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information when providing data through Publish and Subscribe or OLE. The Place 
command and the Links palette in InDesign provide comparable features, and have better 
support for publishing file formats.

Copying and pasting graphics
When copying and pasting a graphic from another document into an InDesign 
document, InDesign does not create a link to the graphic in the Links palette. The graphic 
may be converted by the system clipboard during the transfer, so both image quality and 
print quality may be lower in InDesign than in the graphic’s original application.

To import a graphic by pasting:

1 In InDesign or another program, select the original graphic, and choose Edit > Copy.

2 Switch to an InDesign document window, and choose Edit > Paste.

Dragging and dropping graphics
Select a graphic from Adobe Illustrator, Explorer (Windows), the Finder (Mac OS), your 
desktop, or any removable medium, and drag it into InDesign. The image must be in a 
format that InDesign can import. 

After dragging and dropping a file from any location other than Adobe Illustrator, it 
appears in the Links palette in InDesign. Using the Links palette, you can control versions 
and update as necessary. (See “Managing links and embedded graphics” on page 235.)

To drag and drop a graphic:

1 Select the original graphic.

2 Drag the graphic into an open InDesign document window. 

Note: In Windows, if you try to drag an item from an application that does not support 
drag and drop, the pointer displays the  icon.

To cancel dragging a graphic:

Drop the graphic onto any palette title bar.
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Using alternative import methods with Illustrator images
When you drag-and-drop or copy-and-paste an illustration from Adobe Illustrator 8.0, it 
appears in InDesign as a collection of editable objects. Illustrator files dropped into a 
document are initially grouped. For example, if you copy from Illustrator a drawing of a soccer 
ball with individually created patches, all of those patches are pasted into InDesign as 
separate, editable items.

Note: For illustrations created in Adobe Illustrator 9.0 and later, you must set the prefer-
ences within Illustrator to place an EPS file on the clipboard.

Illustration of soccer ball in Illustrator (left) and same illustration pasted into InDesign (right)

If your illustration contains gradient patterns or colors, it’s best to import them using the 
Place command. Illustrations created in Adobe Illustrator 8.0, which contain gradients, 
display correctly when imported using these methods. However, when importing from 
Illustrator 8.0 using other methods, gradients display as solid black objects and are 
imported as individually editable objects. If the pattern is complex, it may be cumbersome 
to work with in InDesign. 

Note: When importing from Illustrator 9.0 and later using the default preference settings, 
it is best to import the file as a PDF to preserve gradients, colors, and patterns, as well as 
transparency and blends. However, a PDF is imported as one object, which is not editable 
within InDesign, and will not have a link reference in the Links palette.

When you place or drag-and-drop text from Illustrator, the text is imported as one or more 
non-editable items that can be transformed and colorized in InDesign. For example, if you 
create text on a path in Illustrator and paste it into InDesign, the text can be colorized, 
rotated, and scaled, but it cannot be edited.

Managing links and embedded graphics
When you place a graphic, its original file is not actually copied into a document. Instead, 
InDesign adds a screen-resolution version of the file to the layout, so that you can view 
and position the graphic, and creates a link, or file path, to the original file on disk. When 
you export or print, InDesign uses the links to retrieve the original graphics, creating the 
final output from the full resolution of the originals. 

Links can help minimize the size of a document by storing graphics outside the document 
file. After placing a graphic, you can use it many times without significantly increasing the 
size of the document; you can also update all links at once.
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If the bitmap image you place is 48K or smaller, InDesign automatically embeds the full-
resolution image, instead of the screen-resolution version in your layout. InDesign displays 
these images in the Links palette, so that you can control versions and update the file 
whenever you like; however, the link is not necessary for optimal output.

Note: If you move a document to another folder or disk (for example, if you take it to a 
service provider), be sure you also move the linked graphics files; they are not stored inside 
the document. You can copy all related files automatically, using the Preflight and Package 
features. (See “Performing a preflight check” on page 406, and “Packaging files for 
handoff” on page 408.)

Imported text files are automatically embedded, and they also appear in the Links palette. 
(See “Editing and updating a linked text file” on page 90.)

About the Links palette
All files placed in a document are listed in the Links palette. This includes both local (on 
disk) files and assets that are managed on a server (such as a WebDAV server; see 
“Managing files using WebDAV” on page 240).

A. Link B. Page containing linked graphic C. Embedded- link icon D. Modified-link  
E. Missing-link icon F. Relink button G. Go To Link button H. Update Link button  
I. Edit Original button

A linked file can appear in the Links palette in any of the following ways:

• An up-to-date file displays only the file’s name and its page in the document.

• A modified file displays a modified link icon, a yellow triangle with an exclamation 
point . This icon means that the version of the file on disk is more recent than the 
version in your document. For example, this icon will appear if you import a Photoshop 
graphic into InDesign, and then another artist edits and saves the original graphic 
in Photoshop.

• A missing file displays a missing link icon, a red circle with a question mark . The 
graphic is no longer in the location from which it was imported, although it may still 
exist somewhere. This can happen if someone moves the original file to a different 
folder or server after it’s been imported into an InDesign document. You can’t know 
whether a missing file is up to date until its original is located. If you print or export a 
document when this icon is displayed, the file may not print or export at full resolution.

• An embedded file displays a square with shapes representing embedded files or 
graphics . Embedding the contents of a linked file suspends management operations 
for that link. If the selected link is currently in an “edit in place” operation, this option is 
not enabled. Unembedding the file restores management operations to the link.
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Using the Links palette
Use the Links palette to identify, select, monitor, and update files that are linked to 
external files. 

To display the Links palette:

Choose Window > Links. Each linked file and automatically embedded file is identified 
by name.

To select and center a linked graphic in the active document window:

1 Select a link in the Links palette.

2 Click the Go To Link button , or choose Go To Link in the Links palette menu.

To sort the links in the palette:

Choose Sort by Status, Sort by Name, or Sort by Page in the Links palette menu.

To modify a link in its original application:

1 Select a link in the Links palette.

2 Click the Edit Original button , or choose Edit Original in the Links palette menu.

Viewing link information
The Link Information dialog box lists specific information about the selected linked file. 
The Date, Time, and Size sections all specify information about the linked file at the time it 
was last placed or updated.

The Link Needed section specifies whether or not a link to a full-resolution version of the 
file is needed. Files that are automatically embedded at import (those under 48K, and text 
files) do not require links. 

To display link information:

1 Double-click a link, or select a link and choose Link Information in the Links 
palette menu.

2 If you like, do any of the following:

• To replace the current file (listed under the Name option), click Relink, locate and select 
a replacement file, and then click OK.

• To get the most recent version of the current file, click Update . If the Update button 
isn’t available, the file is already up to date.

• Click Next or Previous to see information for the other links in the Links palette.

3 Click Done.

Manually embedding a file
Manually embed (unlink) a linked file to make sure that it’s stored inside the document. 
Remember though, that embedding a file causes the document file to be larger than 
when the file was linked to an external file.

Note: Raster graphics under 48K and all text files are automatically embedded—the entire 
file is stored in the InDesign document and listed in the Links palette. 
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When you do embed a file, it is no longer updated when you edit the original version. 
However, if you decide to edit the original embedded file and update the information 
within your document, you can relink the graphic using the Unembed or Relink 
file options. 

To manually embed an image file:

1 Select a file in the Links palette. 

2 Choose Embed in the Links palette menu. The file remains in the Links palette marked 
with the embedded-link icon .

Note: For a text file that appears in the Links palette, select Unlink in the Links palette 
menu. When you embed a text file, it is automatically removed from the Links palette. 

To unembed a linked file:

1 Select one or more embedded files in the Links palette.

2 Do one of the following:

• Select Unembed in the Links palette menu.

• Click the Relink button  or select Relink in the Links palette menu.

3 Choose to link the file to the original file or to a folder InDesign creates from the 
embedded data stored in the document.

Updating, reestablishing, reassigning, and replacing links
Use the Links palette to check the status of any link, or to replace files with updated or 
alternate files. 

When you update or reestablish (relink) a link to a file, any transformations performed in 
InDesign are preserved. For example, if you import a 4-by-4cm square graphic and rotate it 
30 degrees, and then you relink it to an unrotated 6-by-8cm graphic, InDesign will scale the 
replacement graphic to 4-by-4cm and rotate it 30 degrees, to match the layout position of 
the graphic it’s replacing.

Note: Placed EPS files may contain OPI links, which will appear in the Links palette. Do not 
relink OPI links to files other than those originally intended by the creator of the EPS file; 
doing so can cause problems with font downloading and color separations.

To update a modified link:

1 In the Links palette, select one or more links marked with the modified-link icon .

2 Click the Update Link button , or choose Update Link in the Links palette menu.

To update all modified links at once:

1 In the Links palette, do one of the following:

• Deselect all links by clicking the bottom of the Links palette.

• Select all links marked with the modified-link icon.

2 Click the Update Link button, or choose Update Link in the Links palette menu.

To restore a missing link, or to replace a link with a different source file:

1 Do one of the following:
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• To restore a missing link, select any link marked with the missing link icon  in the Links 
palette.

• To replace a link with a different file, select any link in the Links palette.

2 Click the Relink button , or choose Relink in the Links palette menu.

3 In the Relink dialog box, do one of the following, and then click OK:

• Type a new file path in the Location text box.

• Click Browse, locate and select a file, and then click Open (Windows) or Choose 
(Mac OS).

• Drag a file from Explorer (Windows) or the Finder (Mac OS) to the Relink dialog box.

Note: If all of the missing files are located in the same folder, you can restore all of them at 
once: First select all the missing links (or select nothing) and restore one link, then all of the 
remaining missing links will be restored automatically.

To restore all missing links at once:

1 Do one of the following:

• Deselect all links by clicking the bottom of the Links palette.

• Select all missing links.

2 Click the Relink button, or choose Relink in the Links palette menu.

3 If the Relink dialog box appears, click Browse and locate the file, then click Open 
(Windows) or Choose (Mac OS).

4 Repeat, for every file that appears in the Relink dialog box.

To replace an imported file using the Place command:

1 Do one of the following:

• To replace the contents of a graphics frame, such as an imported graphic, use the 
selection tool  to select an imported file 

• To replace the contents of a text frame, use the text tool to click an insertion point in a 
text frame, and choose Edit > Select All.

2 Choose File > Place.

3 Locate and select the new file you want to use.

4 Make sure that Replace Selected Item is selected, and then click Open (Windows) or 
Choose (Mac OS).

If necessary, you can make the frame fit the new graphic. With the frame selected, 
choose Object > Fitting > Fit Frame to Content.

To replace an imported graphic using the Place command and scale the new graphic 
to the existing frame:

1 With the direct-selection tool , select an imported graphic (don’t select the frame).

2 Choose File > Place.

3 Locate and select the new file you want to use.
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4 Make sure that Replace Selected Item is selected, and then click Open (Windows) or 
Choose (Mac OS).

Note: This procedure doesn’t preserve the original proportions of the graphic.

Managing files using WebDAV
InDesign supports the Web Distributed Authoring and Versioning (WebDAV) server 
technology. Using this technology, you can connect to a WebDAV server, download and 
upload files, lock files so others cannot work on them at the same time as you do, and add 
(upload) additional files (called assets) to the server. Use a WebDAV server to work in a 
collaborative environment without fearing that files will be accidentally overwritten, or 
updates lost.

About workgroup management
When working in a collaborative environment, users must share files. The process of 
passing files from one collaborator to another involves working with a workgroup. 
Controlling this hand-off—so that only one person can edit a file at any given time—is 
called workgroup management. 

A WebDAV server provides workgroup management via the Web. When a file is managed 
by a WebDAV server, multiple users can download copies of the file, but only one user at a 
time can check out the file. The user who checks out the file can share his or her work with 
other users by updating the file on the server; however, other users can’t make changes to 
the managed file until it is checked in. This check-out/check-in system allows multiple 
users to access the same file, but prevents users from overwriting each other’s work. 

Getting started with workgroup management
To use the workgroup management features in InDesign, you must be able to connect to a 
WebDAV server. You can find detailed information, and the latest news about WebDAV, at 
www.webdav.org.

Important: Firewall software can interfere with the process of connecting to a WebDAV 
server. Check with your system administrator, or refer to your firewall software documen-
tation for information about setting options to access outside servers.

Different WebDAV servers have different authentication requirements. Some servers 
require you to enter a user name and password for every transaction; other servers require 
authentication only the first time you check out a managed file. When the Authentication 
dialog box appears, enter your user name and password, and click OK.

When adding a new server to the workgroup environment, you will need to provide a 
unique server nickname (this will appear in the Workgroup Servers list) and a URL for 
the server.

To set up a server for use with InDesign:

1 Choose File > Workgroup > Workgroup Servers.

2 Specify a folder in which you want to store local copies of managed files. To change the 
default location, click Choose, and specify a different folder.

Note: The path you choose here is used for all servers that you want to add. Changing this 
path does not change the location of files on existing servers. 
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3 Specify the WebDAV servers you want to use, or do one of the following:

• To add a new server to the list, click New, specify a server nickname and URL, and then 
click OK.

• To remove a server from the list, click Remove, and then click OK when the warning 
message appears.

4 Click OK, or click Advanced Options to specify additional information about the server.

5 To set up a custom workgroup file repository for this collection of files, select Use a 
Custom Workgroup Files Location for This Server in the Advanced Options dialog box. 
Then click Choose or Select, and specify a folder.

Note: This option is only available for adding a new server, not for existing servers. 

6 To specify additional URLs by which you can access this server, type the alternate URL 
under Alternate Server URLs for This Server, and click Add. Currently, InDesign stores the 
URL information, but does not use it to locate files.

7 To remove previously entered alternate URLs, select the URL and click Remove.

8 Click OK.

Important! Some proxy servers do not support HTTP 1.1, which is required for WebDAV 
support. If you are unable to properly access a WebDAV server, check to see whether you 
are going through a proxy server. If you are having connection problems with a proxy 
server, ask your network manager or ISP provider if the proxy server supports HTTP 1.1 
traffic. If not, you will need to bypass that proxy server in order to use the WebDAV 
features.

Opening managed files
To view a managed file, open a copy of the file from a WebDAV server. The File > 
Workgroup > Open command creates a local copy of the file on your hard drive.

Note: You can also open a managed file using the File Open command, but it will not be 
part of the managed workgroup.

After you have a local copy of a file, you can update it with changes from the managed file 
on the server by using the Revert command (for checked-out files), the Update command 
(for non-checked-out files), or by setting an automatic update option in the Workgroup 
preferences. (See “Setting preferences for managed files” on page 245.)

To open a managed file:

1 Choose File > Workgroup > Open.

2 Select a server, a directory, and the file you want to open.

3 Do one of the following:

• Click Check Out if you want to open and check out at the same time. (See “Checking 
files out and in” on page 242.)

• Click Open if you want to open a local copy without checking it out.

To update or revert a local file to the version on the server:

1 Open your local copy of the file.

2 Do one of the following:

• If the file is checked out, choose File > Workgroup > Revert.
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• If the file is not checked out, choose File > Workgroup > Update.

Checking files out and in
Checking out a file prevents other users from making changes to it on the WebDAV server. 
When you’re finished making edits, check the file in to update your changes to the server 
and release your lock on the managed file. 

You can save changes to the managed files you have checked out. To save changes to a 
managed file that has not been checked out, use the Save As command, and add that new 
file to the workgroup server.
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To check a file out:

Do one of the following:

• To check out the file that you already have open, choose File > Workgroup > Check Out.

• To open and check out a file at the same time, choose File > Workgroup > Open. Then, 
locate and select the file, and click Check Out. (See “Opening managed files” on 
page 241.)

To check a file in:

Do one of the following:

• To check a file in and update changes to the server, choose File > Workgroup > Check In.

• To check a file in without updating changes to the server, choose File > Workgroup > 
Cancel Check Out.

Placing managed files
Use the File > Workgroup > Place command to place a single, managed document as a link 
in a checked-out managed file. You can place documents from the current workgroup 
server only. To manage links for managed files, see “Managing files using WebDAV” on 
page 240.

To place a managed file:

1 Make sure that you are connected to the network, and that you have access to the 
managed server.

2 Open the checked-out version of a managed file. 

3 Choose File > Workgroup > Place, select a file, and then click Open. 

Managing links on a WebDAV server
The Links palette contains information on both local links (located on your hard disk) and 
managed links (those located on a server). 

A. Unspecified B. Modified C. Missing D. Live Out of Date E. Live Missing  
F. Live Check Out G. Live H. Check In/Out & Edit Original I. Verify Link

Important! To work with managed links, you must first connect to the network, and then 
set up your workgroup server. (See “About workgroup management” on page 240.)
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To save managed link updates:

1 Select the link in the Links palette.

2 Choose Save Link As in the Links palette menu; then specify a location on the 
WebDAV server.

To update or revert managed links to the latest version on the server:

1 Select the link in the Links palette.

2 Choose File > Workgroup > Place. 

3 Locate the file on the server, select Replace, and click Place.

To determine the status of managed links:

1 Select the link or multiple links in the Links palette.

2 Choose Verify Link in the Links palette menu.

Uploading changes to the server
While you have a file checked out, you can upload changes to the managed file on the 
server. This allows you to share your work with other users without giving up your lock on 
the file.

To upload changes to the server:

1 Open your local copy of the file.

2 Choose File > Workgroup > Save.

Adding files to the server
Adding a file to a WebDAV server initiates workgroup management for the file; in other 
words, you create a managed file by adding it to a server. You can add files to a server 
using the File > Workgroup > Save As command. The Save command adds to the server a 
managed file that has been altered; the Save As command adds to the server a previously 
unmanaged file. 

To add a file to a WebDAV server:

1 Open the file you want to add to the server.

2 Do one of the following:

• To add a previously unmanaged file to the server, choose File > Workgroup > Save As.

• To start a new workgroup for a managed file, choose File > Workgroup > Save As.

3 Choose a server in the pop-up menu; then locate the directory to which you want to 
save the file. 

4 Type a filename in the Name text box, and choose a format in the Format pop-up menu.

Note: Be sure to specify a file extension if the file will be downloaded to a computer 
running a Windows operating system.

5 To check the file out, select Keep This File Checked Out for Editing.

6 Click Save.
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Setting preferences for managed files
You can set preferences for opening managed files, to specify how they are checked out, 
how they are updated, and how links are updated. You can also set preferences for placing 
managed links. 

To set preferences for opening managed files:

1 Choose Edit > Preferences > Workgroup (Windows and Mac OS 9), or InDesign > Prefer-
ences > Workgroup (Mac OS 10.1).

2 Select one of the following options for Check Out from Server:

• Ask displays a dialog box when you open a file that is not checked out.

• Never opens the local copy of the file without displaying a dialog box and without 
checking it out.

• Always automatically checks out the file when you open it.

3 Select one of the following options for Update from Server, and click OK: 

• Ask displays a dialog box if the file has been updated on the server.

• Never opens the local copy of the file without displaying a dialog box and without 
downloading the latest version of the file from the server.

• Always automatically downloads the latest version of the file from the server.

4 Select one of the following options for Update Links from Server:

• Ask displays a dialog box when you open a file that contains links.

• Never opens the local copy of the file without displaying a dialog box and without 
updating links.

• Always automatically updates links when you open a file.

• Verify Only checks if links are broken and if so, display icons next to the broken links in 
the Links palette.

To set preferences for replacing managed links:

1 Choose Edit > Preferences > Workgroup (Windows and Mac OS 9), or InDesign > Prefer-
ences > Workgroup (Mac OS 10.1).

2 Select one of the following options for Replace Already-Linked File:

• Always automatically updates links when you place a file.

• Ask displays a dialog box when you place a file that contains links.

• Never places the local copy of the file without displaying a dialog box and without 
updating links.

To turn off workgroup functionality for this copy of Adobe InDesign:

Choose Edit > Preferences > Workgroup (Windows and Mac OS 9), or InDesign > Prefer-
ences > Workgroup (Mac OS 10.1), and deselect Enable Workgroup Functionality.

Adding metadata to documents
Metadata, or file info, is descriptive information that can be searched and processed by a 
computer. Use metadata to provide information about the contents of a document and to 
preserve information about a document that will be opened in other Adobe applications.
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To add metadata to a document:

1 Choose File > File Info.

2 Select a category from the list on the left side of the dialog box, type the desired 
metadata, and click OK.

• General specifies information about the document, such as title, author, and 
description. To specify copyright information, select Yes from the Copyrighted pop-up 
menu. Then type the copyright notice string and the URL of the person or company 
who owns the copyright.

• Keywords specifies words that can be used to search for the document. To add a word 
to the list, type the Keyword text box and click Add. To edit or replace a word in the list, 
select the word, change the text in the Keyword text box, and click Replace. To delete a 
word from the list, select the word and click Delete.

• Summary specifies status information for the document, including its creation data, 
modification data, and location. If the document is a managed file, the server location 
and checkout status also appear. You cannot edit Summary metadata.

3 Click Save, and specify a filename.

4 Click OK.

To edit metadata within a document:

Do one of the following:

• Select Load. With this option you can choose a metadata file embedded within the 
document. 

• Select Append. With this option you can replace all blank items (and those currently 
empty), and merge lists (like Keywords) and large text blocks (like Description) with the 
contents of the chosen metadata file. All other fields are left untouched.

Using object libraries
Object libraries help you organize the graphics, text, and pages you use most often. You 
can also add ruler guides, grids, drawn shapes, and grouped images to a library. You can 
create as many libraries as you need—for example, you can create different object libraries 
for varied projects or clients. During a work session, you can open as many libraries as 
system memory will allow. Object libraries can be shared across servers, and across 
platforms. If an object library includes text files, make sure that the file’s fonts are available 
and active on all systems that will access the library.

When you add a page element, such as a graphic, to an object library, InDesign preserves 
all attributes that were imported or applied. For example, if you add a graphic from an 
InDesign document to a library, the library copy will duplicate the original, including 
the original’s link information, so that you can update the graphic when the file on 
disk changes. 

If you delete the object from the InDesign document, the object’s thumbnail will still 
appear in the library palette, and all of the link information will remain intact. If you move 
or delete the original object, a missing link icon will appear next to the object’s name in 
the Links palette the next time you place it in your document from the library palette.
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Within each object library, you can identify and search for an item by title, by the date it 
was added to the library, or by keywords. You can also simplify the view of an object library 
by sorting the library items and displaying their subsets. For example, you can hide all 
items except EPS files.

A. Object thumbnail and name B. Library Item Information button  
C. Show Library Subset button D. New Item button E. Trash button

When adding an item to an object library, InDesign saves all page, text, and image 
attributes automatically, and maintains interrelationships among library objects and other 
page elements in the following ways: 

• Elements grouped in an InDesign document when dragged to the Library palette stay 
grouped when dragged out of the Library palette. 

• Text retains its formatting. 

• Paragraph styles and character styles that have the same name as styles used in the 
destination document are converted to the destination document’s styles; those that 
have different names are added to the document.

• The original layers of an object are preserved when the Paste Remembers Layers option 
is selected in the Layers palette menu.

Working with object libraries
An object library exists as a named file on disk. When you create an object library, you 
specify where to store it. When you open a library, it appears as a palette that you can 
group with any other palette; the object library’s filename appears in its palette tab. 
Closing an object library removes it from the current session, but doesn’t delete its file.

You can quickly add or remove objects, selected page elements, or an entire page of 
elements to or from an object library. You can also add or move library objects from one 
library to another. 

Note: To open an InDesign 1.0 or 1.5 object library file, see “Converting InDesign 1.0 and 
1.5 library files” on page 249.

To create a new library:

1 Choose File > New > Library.

2 Specify a location and name for the library, and click Save. Remember that the name 
you specify becomes the name of the library’s palette tab.
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To open an existing library:

Do one of the following:

• If you’ve already opened a library in the current session (and haven’t closed it), choose 
the library file in the Window menu.

• Choose File > Open, and select one or more libraries. In Windows, library files use the 
.indl extension.

To add an object or page to a library:

Do one of the following:

• Drag one or more objects from a document window to an active Object Library palette.

• Select one or more objects in a document window, and click the New Item button  in 
the Object Library palette.

• Select one or more objects in a document window, and choose Add Item in the Object 
Library palette menu.

• Choose Add All Items on Page in the Object Library palette menu.

If you hold down Alt (Windows) or Option (Mac OS) while you perform any of the 
above commands, the Item Information dialog appears as the item is added to the 

library.

To add an object-library object to the document:

Do one of the following:

• Drag an object from the Object Library palette to a document window.

• In the Object Library palette, select an object, and choose Place Item(s) in the Object 
Library palette menu.

To copy an object from one library to another:

1 Drag one library’s palette tab out of the Object Library palette group to separate them, 
so you can see both libraries at the same time.

2 Drag an item from one library palette tab to the other.

To move an object from one library to another:

1 Drag one library’s palette tab out of the Object Library palette group to separate them, 
so you can see both libraries at the same time.

2 Hold down Alt (Windows) or Option (Mac OS), and drag an item from one library 
palette tab to the other.

To delete an object from an object library:

In the Object Library palette, select an object, and do one of the following:

• Click the Trash button .

• Drag the item to the Trash button.

• Choose Delete Item(s) in the Object Library palette menu.

To close a library:

1 Click the tab for the library you want to close.
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2 Choose Close Library in the Object Library palette menu.

To delete a library:

In Explorer (Windows) or Finder (Mac OS), drag a library file to the Recycle Bin (Windows) 
or Trash (Mac OS). In Windows, library files have the .indl extension.

Converting InDesign 1.0 and 1.5 library files
Use the Asset Library Converter plug-in to convert InDesign 1.0 or 1.5 library files. The 
converter lets you export libraries to a format that InDesign 2.0 can import and retain all 
information contained in the original library file.

The Asset Library Converter requires InDesign 1.5.2. If you have InDesign 1.5 or 1.5.1, you 
need to download the free update from the Adobe Web site at the following addresses:

(Windows) www.adobe.com/support/downloads/idwin.htm

(Mac OS) www.adobe.com/support/downloads/idmac.htm

To use the Asset Library Converter plug-in:

1 Exit InDesign 1.5.2.

2 On the InDesign 2.0 application CD, locate the Asset Library Converter plug-in, which is 
located in the InDesign 1.5 Library Converter folder in the Goodies folder.

3 Move the Asset Library Converter plug-in to the Plug-ins > Filters folder in the InDesign 
application folder. 

Important: Be sure that you do not place the plug-in in the InDesign>Version 2.0 folder.

4 Restart InDesign 1.5.2 and choose Window > Libraries > Convert to Library Document, 
and then double-click the library file you want to export.

5 When the Save As dialog box appears, specify a name for the exported version of the 
library file, and then click OK.

6 Start or switch to InDesign 2.0, and choose Import Library Document in the Library 
palette menu.

7 Locate and select the file you saved in InDesign 1.5.2, and click Open. By default the 
only files listed are those saved by the Asset Library Converter.

8 When the Library dialog box appears, specify a name for the library, and then click Save.

Note: The library file is now saved to an InDesign 2.0 library and can be deleted from 
InDesign 1.5.

Changing the object library display
The object library can display objects as thumbnail miniatures or as a text list. In addition, 
you can sort the thumbnails or text list by object name, age, or type. The text-list view and 
sorting options work best if you’ve cataloged the objects.

To change the object library display:

Do any of the following:

• To view objects as thumbnails, choose Thumbnail View in the Object Library 
palette menu.

• To view objects as a text list, choose List View in the Object Library palette menu.
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• To sort the objects, choose Sort Items in the Object Library palette menu and choose by 
Name, by Oldest, by Newest, or by Type.

To view all objects:

Choose Show All in the Object Library palette menu.

Cataloging objects
With large or numerous object libraries, library information can be cataloged using the 
display objects’ names, by type of object, or words in a description.

To view, add, or edit library information:

1 In the Object Library palette, do one of the following:

• Double-click any object.

• Select an object, and click the Library Item Information button .

• Select an object, and choose Item Information in the Object Library palette menu.

2 View or change the Item Name, Object Type, or Description options as necessary, and 
click OK.

Finding objects
When you search for objects, all objects except the results of your search are hidden from 
view. You can also use the search feature to show and hide specific categories of objects. 
For example, you can display only object items with the word “star” in their names.

To find objects:

1 Choose Show Subset in the Object Library palette menu, or click the Show Library 
Subset button.

2 Do one of the following:

• To search all objects in the library, select Search Entire Library.

• To search only within the objects currently listed in the library (refining a previous 
search), select Search Currently Shown Items.

3 Choose a category in the first menu in the Parameters section.

4 In the second menu, specify whether the category you chose in the first menu must be 
contained in or excluded from the search.

5 To the right of the second menu, type a word or phrase you want to search for within 
the category you specified.

6 To add search criteria, click More Choices up to five times; each click adds one search 
term. To remove search criteria, click Fewer Choices as necessary; each click removes one 
search term.

7 To display only those objects that match all search criteria, select Match All. To display 
objects that match any of the criteria, select Match Any One.

8 Click OK to begin the search.

To show all objects again, choose Show All in the Object Library palette menu.
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Exporting options
You cannot export individual graphics from InDesign, but you can export one or more 
entire document pages to various formats, including Adobe Portable Document Format 
(PDF), Encapsulated PostScript (EPS), Hyptertext Markup Language (HTML), Scalable 
Vector Graphics (SVG), and PostScript® File format. For information on PDF, HTML, and 
PostScript® File, see the index.

Setting common export options
When you export to Adobe PDF, EPS, HTML, SVG or PostScript® File, you can specify the 
following options:

Data Format Specifies how InDesign sends the image data from your computer to a 
printer. ASCII exports as ASCII text, which is compatible with older networks and parallel 
printers and is usually the best choice for graphics used on multiple platforms. Binary 
exports as binary code, which is more compact than ASCII but may not be compatible 
with all systems. Binary is usually the best choice for documents used only on Mac OS 
systems. 

PostScript® Specifies a level of compatibility with the interpreters in PostScript output 
devices. Level 2 will often improve the printing speed and output quality of graphics 
printed only on a PostScript Level 2 or greater output device. Level 3 provides the best 
speed and output quality, but requires a PostScript 3 device. 

Note: InDesign automatically selects the PostScript level of your output device. 

Embed Fonts Specifies how to include fonts used in the pages you export.

• None includes a reference to the font in the PostScript file which tells the RIP or a post-
processor where the font should be included. This option is appropriate if the fonts 
reside in the printer. TrueType fonts are named according to the PostScript name in the 
font; however, not all applications can interpret these names. To ensure that TrueType 
fonts are interpreted correctly, use one of the other font downloading options.

• Complete downloads all fonts required for the document at the beginning of the print 
job. This option typically results in faster and smaller PostScript files when used with 
multipage documents. Complete is the InDesign default.

• Subset downloads only the characters (glyphs) used in the document. Glyphs are 
downloaded once per page. This option typically results in faster and smaller PostScript 
files when used with single-page documents, or short documents without much text.

Note: Some font manufacturers restrict the embedding of font files. Restrictions apply to 
copying font software. You are required to comply with applicable copyright law and the 
terms of your license agreement. For font software licensed from Adobe, your license 
agreement provides that you may take a copy of the font(s) you have used for a particular 
file to a commercial printer or other service provider, and the service provider may use the 
font(s) to process your file, provided the service provider has informed you that it has the 
right to use that particular software. For other font software, please obtain permission 
from your vendor.

Color Specifies how color is represented in the exported file. For example, if your 
document includes a mix of RGB and CMYK images and you choose CMYK in the Color 
menu, then the objects using RGB color values will convert to CMYK one of two ways: 
using color setting defaults or the InDesign internal RGB to CMYK conversion.
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Color setting defaults result in calibrated color outut, if you’ve selected Enable Color 
Management in the Edit > Color Settings dialog box.

The InDesign internal RGB to CMYK conversion results in uncalibrated color output, if 
you’ve deselected Enable Color Management in the Document Color Setting dialog box.

All spot color information is preserved during color conversion; only the process color 
equivalents convert to the designated color space. If you’re not sure which color choice to 
use, consult your prepress service provider. 

• Leave Unchanged (Export PDF only) leaves each image in its original color space. For 
example, if the document contains three RGB images and four CMYK images when you 
export to PDF, the resulting PDF file will contain the same RGB and CMYK images. 

• CMYK creates a separable file by representing all color values using the gamut of cyan, 
magenta, yellow, and black process color inks. 

• Gray converts all color values to high-quality black-and-white images. The gray levels 
(shades) of the converted objects represent the luminosity of the original objects.

• RGB represents all color values using the red, green, and blue color space. A PDF file 
with RGB color definitions is better suited for on-screen viewing. 

• Device Independent (Export EPS and PostScript® File only) is available only if you 
enabled color management; it allows an output device to use color management and 
profiles to represent colors optimally on that device. For example, InDesign uses source 
files for the color conversion, and the separations profile for conversion to CMYK or the 
monitor profile for conversion to RGB; otherwise, the InDesign defaults are used. 
Process colors created in InDesign are preserved in the exported file; however, process 
colors from imported graphics (except placed PDF pages) are converted to the color 
mode specified by this option. 

Note: You cannot convert color spaces in a placed PDF file. If you intend to create a color-
separable PDF file with placed PDF files that contain RGB color values, do one of the 
following: Either return to the creating application and make sure that the document 
contains only CMYK graphics, or make sure that color management is on and set up 
properly and the output device supports in-RIP separations.

Preview options Determine the characteristics of the preview image that is saved in the 
file. The preview image is displayed in applications that cannot display EPS artwork 
directly. If you don’t want to create a preview image, choose None in the format menu.

Images Specifies how much image data in placed bitmap images to include in the 
exported file. For other image options, see “Compressing and resampling images” on 
page 369.

• High Resolution includes all available high-resolution image data in the exported file 
and requires the most disk space. Choose this option if the file will be printed on a high-
resolution output device. 

• Low Resolution includes only screen-resolution versions (72 dpi) of placed bitmap 
images in the exported file. Choose this option in conjunction with the OPI Image 
Replacement option, or if the resulting PDF file will be viewed on-screen. 
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Omit for OPI Lets you selectively omit different imported graphics types (EPS, PDF, and 
bitmap images) when sending image data to a printer or file, leaving only the OPI links 
(comments) for later handling by an OPI server. The comments contain the information 
needed to replace a low-resolution proxy (For Placement Only image) with the high-
resolution image located on an OPI server. InDesign only includes the comments; the 
service provider must have access to the original high-resolution image on a server at 
replacement time. Omitted graphics are usually displayed as a gray box when viewed in 
the exported file. The Omit for OPI option doesn’t apply to embedded graphics. 

For information about OPI linking and EPS files, see “EPS (.EPS)” on page 226.

Important: Most OPI servers currently offer limited or no support for replacement of 
omitted PDF pages. Adobe expects that in the future, PDF pages will be able to be omitted 
and replaced just as bitmap images and EPS graphics are today.

OPI Image Replacement Enables InDesign to replace low-resolution EPS proxies of 
graphics with high-resolution graphics at output time. For OPI image replacement to 
work, the EPS file must contain OPI comments that link the low-resolution proxy image to 
the high-resolution image. InDesign must have access to the graphics linked by the OPI 
comments. If the high-resolution versions are not available, InDesign preserves the OPI 
links and includes the low-resolution proxy in the export file. Deselect this option to have 
an OPI server replace OPI-linked graphics later in the workflow.

For information about OPI linking and EPS files, see “EPS (.EPS)” on page 226.

Transparency Flattener When exporting a document that has transparent objects, 
InDesign performs a process called flattening. In the Transparency Flattener section, select 
the flattener style in the Styles menu. For more information on flattening, see the topics 
under “Controlling flattener settings and results using styles” on page 294.

Simulate Overprint Lets you soft-proof your document’s colors directly on the monitor 
before they are reproduced on a particular output device. (See “Simulating overprinting of 
spot inks” on page 420.)

Ink Manager Corrects any ink options without changing the design of the document; 
see “Using the Ink Manager” on page 317.

Exporting pages to EPS format
Use the export command to export InDesign pages in EPS format, which you can import 
into another program. If you export multiple pages, each page is exported as a separate 
file with a number appended to the end of the filename. For example, if you export pages 
3, 6, and 12, and specify the filename News.eps, InDesign will create three files named 
News_3.eps, News_6.eps, and News_12.eps.

If you want to open InDesign pages in Illustrator or Photoshop, export pages as PDF or 
EPS files.

To export one or more pages to an EPS format:

1 Choose File > Export.

2 Specify a location and a filename. Be sure to include the .eps extension.

3 For Save as Type (Windows) or Format (Mac OS), choose EPS, and click Save.

4 In the Pages section, do one of the following:

• Select All Pages to export all pages in the document.
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• Select Ranges and type a page range. You can type a range using a hyphen, 
and separate pages or ranges using commas.

• Select Spreads to export facing pages as a single EPS file (one spread per EPS).

5 Set additional options; see “Setting common export options” on page 251.

6 In the Bleed section, type a value between 0p0–36p0 to specify extra space for graphics 
that are positioned beyond the edge of the page or trim area.

7 Set Advanced options, and then click Export.

Exporting pages to SVG format
The Scalable Vector Graphics (SVG) format is an open-standard vector graphics format that 
lets you design Web pages with high-resolution graphics that incorporate real-time data.

Use the Export command to export an InDesign file in either SVG or SVGZ format. (The 
SVGZ format is a compressed version of the SVG format.) 

To export a page to SVG format:

1 Choose File > Export.

2 Select the folder in which you want to save the file, and type a name for the file in the 
Name text box.

3 In the Export dialog box, choose SVG or SVG Compressed in the Save as Type 
(Windows) or Format (Mac OS) pop-up menu.

4 In the SVG Option dialog box, set the following export parameters:

• Select the pages that you want to export. The Range text box allows you to specify 
specific pages (use a hyphen to separate page numbers in a range, or a comma to 
separate individual page numbers or ranges). The Export command exports only the 
selected text, objects, or both (this option will be disabled unless one or more page 
items is selected). The Spreads option exports each set of facing pages to a single page 
in the exported file.

• Fonts Subsetting lets you embed only those characters of the font that are used in the 
document; that is, a subset of the font. Select All Glyphs to subset every font character 
that occurs in the file (including non-Roman fonts such as Japanese characters). Select 
the Common English or Common Roman options to subset only English or Roman-
letter font characters that occur in the document.

• Embed Font Location embeds the subset font directly in the document (which 
increases file size but ensures that the font will always be included with the file), or link 
the file to the exported subset of the font from the original InDesign file.

• Image Location embeds GIF or JPEG images in the export file (which increases file size 
but ensures that the image is always included with the file), or links the file to its 
original InDesign file.

• Transparency Flattener displays previously saved groups of settings for flattening trans-
parent objects. (See “Controlling flattener settings and results using styles” on page 294 
and “Flattening individual spreads” on page 296.)
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• Cascading Style Sheet (CSS) Property Location lets you choose between four methods 
of saving style attributes in SVG code. The default method, Presentation Attributes, 
applies the highest level of properties, allowing for more flexibility during editing and 
transformations. The Style Attributes method is used if the SVG code will be used in 
transformation—for example, transformations using Extensible Stylesheet Language 
Transformation (XSLT)—but results in slightly larger file size. The Style Attributes (Entity 
References) results in faster rendering times and reduced SVG file size. The Style 
Elements method is used when sharing files with HTML documents. By selecting Style 
Elements, you can then modify the SVG file to move a style element into an external 
stylesheet file that is also referenced by the HTML file; however, the Style Elements 
option also results in slower rendering speeds.

• Decimal Places lets you specify the precision of the vectors in the exported artwork. You 
can set a value of 1 to 7 decimal places. A high value results in a larger file size and 
increased image quality.

• Encoding allows you to choose between ISO 8859-1 (ASCII) characters or characters 
encoded using the Unicode Transformation Format (UTF). UTF-8 is an 8-bit format; UTF-
16 is a 16-bit format.

5 Click Export.
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Arranging and Combining 
Objects

Modifying objects using graphics frames
If a graphic exists inside a frame (as all imported graphics do), you can modify it by 
changing its relationship to its frame, as in the following examples:

• Crop a graphic by making its frame smaller than the graphic.

• Create various masking and layout effects by pasting an object into a frame.

• Add a keyline or outline to a graphic by changing the stroke weight and color of 
its frame.

• Center a graphic against a background rectangle by enlarging its frame and setting the 
frame’s fill color.

To paste an object into a frame:

1 Do one of the following:

• To paste one object inside a frame, select the object.

• To paste two or more objects inside a frame, group them first, because a frame can 
contain only one object.

• To paste a text frame inside another frame and preserve its current appearance, select 
the entire text frame using the selection or direct-selection tool, not the text tool.

2 Choose Edit > Copy (or Edit > Cut, if you don’t want to keep the original).

3 Select a path or frame, and then choose Edit > Paste Into.

Image pasted into a frame

To remove a frame’s content:

1 Do one of the following:

• When you’re removing a graphic or a text frame, select the object with the direct-
selection tool . The direct-selection tool automatically changes to the hand tool  
when placed over the content of the frame.
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• When you’re removing text characters, select them with the text tool .

2 Do one of the following:

• To permanently remove the content, press Delete or Backspace.

• To place the content elsewhere on the layout, choose Edit > Cut, deselect the frame, 
and then choose Edit > Paste.

Note: An imported image cannot exist without a frame. If you cut an imported image from 
its frame and paste it elsewhere within a document, a new frame will be created for it 
automatically.

Aligning an object within a graphics frame
When you place or paste an object into a frame, it appears at the upper left corner of the 
frame by default. If the frame and its content are different sizes, you can use the Fitting 
commands to achieve a perfect fit automatically.

Frame alignment options apply to frames that contain either a graphic or another text 
frame, but they do not affect paragraphs inside a text frame—you control alignment and 
positioning of text itself using the Text Frame Options command and the Paragraph, 
Paragraph Styles, and Story palettes.

Note: Use Fitting commands to align a text frame nested within another frame, but not 
paragraphs in a text frame.

To align an object within a graphics frame:

Do any of the following:

• To center content within a frame, select a graphics frame and choose Object > Fitting > 
Center Content. The proportions of the frame and its content are preserved.

• To resize a frame to fit its content, select a frame and choose Object > Fitting > Fit Frame 
to Content. The frame’s proportions are altered to match the content proportions, if 
necessary. This is useful for “resetting” a graphics frame that you accidentally altered.

A. Original B. Frame resized to fit content C. Content resized to fit frame

• To resize content to fit a frame while preserving the content proportions, select a 
graphics frame, and choose Object > Fitting > Fit Content Proportionally. The frame’s 
dimensions are not changed. If the content and the frame have different proportions, 
some empty space will result.

• To resize content to fit a frame and allow the content proportions to be changed, 
choose Object > Fitting > Fit Content to Frame. The frame will not change, but the 

A B C
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content may appear to be stretched if the content and the frame have different propor-
tions.

Note: The Fitting commands fit the content outer edges to the center of the frame’s stroke. 
If the frame has a thick stroke weight, outer edges of the content will be obscured.

Moving a graphics frame or its content
When you move a frame using the selection tool, the frame’s content moves with it. The 
following techniques include ways to move a frame or its content independently of each 
other. These techniques are useful for adjusting how a graphic is cropped or masked by 
its frame.

If a selection tool doesn’t work the way you expect it to, try deselecting everything 
first. Do this by pressing Control+Shift+A (Windows) or Command+Shift+A (Mac OS).

To move a graphics frame or its content:

Do any of the following:

• To move a frame together with its content, drag them using the selection tool .

• To move content without moving the frame (that is, to pan content behind its frame), 
using the direct-selection tool , drag the contents. The direct-selection tool automati-
cally changes to the hand tool  when over the content of the frame.

Moving content, but not its frame

Note: If you hold down the mouse button on a graphic before you move it, a dynamic 
graphics preview (a ghosted-back image) of the entire graphic appears. This makes it 
easier to see how you are positioning the entire image within a frame.

• To move a frame without moving its content, using the direct-selection tool, drag the 
frame. Don’t drag any of the frame’s anchor points; doing so changes the shape of 
the frame.

Moving frame, but not its content
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To move a nested frame and its content without moving the parent frame:

Using the direct-selection tool, hold down Ctrl (Windows) or Command (Mac OS) as you 
drag the edge of the frame you want to move. Don’t drag the content.

Note: This procedure requires selecting the direct-selection tool in the toolbox; it won’t 
work if you temporarily activate the direct-selection tool by pressing the Ctrl (Windows) or 
Command (Mac OS) key.

Dragging nested objects within its parent frame

Creating a border or background with a graphics frame
A graphics frame is ideally suited for use as a border or background for its content, 
because you can change its stroke and fill independently of its content.

A. Photo in its graphics frame B. Frame with stroke applied C. Frame enlarged with both stroke and 
fill applied

To add a rectangular keyline or border to an imported graphic:

1 Using the selection tool , click an imported graphic to select the bounding box of its 
frame.

2 Use the Swatches palette and the toolbox to apply a stroke color to the frame.

3 If desired, adjust the frame’s stroke weight and style in the Stroke palette.

To use a frame as a background for its content:

1 Using the selection tool, click a frame to select its bounding box.

2 Drag any bounding box handle outward to enlarge the frame without resizing the 
graphic.

3 Apply a stroke or fill to the frame as desired.

You can quickly enlarge a frame equally around all sides by using the Transform 
palette. Select the frame with the direct-selection tool, set the Transform palette 

proxy  to the center point, and enter new values for the horizontal and vertical size.

CA B
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Cropping and masking
Cropping and masking are both terms that describe hiding part of an object. In general, 
the difference is that cropping uses a rectangle to trim the edges of an image, and 
masking uses an arbitrary shape to make an object’s background transparent. A common 
example of a mask is a clipping path, which is a mask made for a specific image.

Use graphics frames to crop or mask objects. Because an imported graphic is automati-
cally contained within a frame, you can crop or mask it immediately without having to 
create a frame for it. If you haven’t created a frame for an imported graphic manually, the 
frame is automatically created at the same size as the graphic, so it may not be obvious 
that the frame is there; see “Selecting objects” on page 20.

Note: For efficient printing, only the data for the visible parts of cropped or masked 
images is sent when you output the document. However, you will still save disk space and 
RAM if you crop or mask images to their desired shapes and sizes before importing them 
into your document.

To crop or mask an object:

Do any of the following:

• To crop an imported image or any other graphic already inside a rectangular frame, 
click the object using the selection tool  and drag any handle on the bounding box 
that appears. Press Shift as you drag to preserve the frame’s original proportions.

Cropping an image using a graphics frame

• To crop or mask any object, use the selection or direct-selection tool to select one 
object you want to mask. Choose Edit > Copy, select an empty path or frame smaller 
than the object, and choose Edit > Paste Into.

• To crop frame content precisely, select the frame with the direct-selection tool, and use 
the Transform palette to change the size of the frame.

With an imported graphic, you can also create a mask by using the drawing tools to 
change the shape of the graphic’s existing frame.
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Working with clipping paths
The term clipping path is commonly used in desktop publishing to describe a mask 
applied to, and often saved with, a specific graphic. With InDesign 2.0, you can create 
clipping paths to hide unwanted parts of an image, creating both a path for the image and 
a frame for the graphic. By keeping the clipping path and graphic frame separate, you can 
freely modify the clipping path without affecting the graphic frame by using the direct-
selection tool and other drawing tools in the toolbox. You can create clipping paths in the 
following ways:

• Place already-saved graphics with paths or alpha (mask) channels, which InDesign can 
use automatically. You can add paths and alpha channels to graphics using a program 
such as Adobe Photoshop.

• Use the Detect Edges option in the Clipping Path command to generate a clipping path 
for a graphic that was saved without one.

• Use the pen tool to draw a path in the shape you want, and then use the Paste Into 
command to paste the graphic into the path.

When you use one of InDesign’s automatic methods to generate a clipping path, an 
InDesign clipping path is attached to the image, resulting in an image that is clipped by 
the path and cropped by the frame.

Note: The graphic frame displays the color of the layer it appears on, and the clipping path 
is drawn in the inverse color of the layer. For example, if the layer color is blue, the graphic 
frame will appear as blue, and the clipping path will appear as orange.

About embedded paths and alpha channels
An embedded path is a path included with a graphic. The most common use for an 
embedded path is as a clipping path that removes the background of a graphic. In 
Photoshop, you draw paths using the pen tool, and store them in the Paths palette.
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An alpha channel is an invisible channel that defines transparent areas of a graphic. It’s 
stored inside a graphic with the RGB or CMYK channels. Alpha channels are commonly 
used in video-effects applications. You can create alpha channels using background-
removal features in Adobe Photoshop, such as layer masks, the Channels palette, the 
background eraser, or the magic eraser.

A. Original graphic B. Alpha channel C. Placed graphic 
D. Original graphic E. Graphic with embedded path F. Placed graphic

Using clipping paths to remove backgrounds from imported 
graphics
If you import a graphic saved in EPS, TIFF, or Photoshop format, and the graphic already 
contains a clipping path or an alpha channel, simply place it, and InDesign will use the 
path or channel automatically. When an imported graphic includes more than one 
embedded path or alpha channel, you can choose which path or alpha channel to use in 
making a clipping path. This gives you maximum flexibility in creating transparent 
backgrounds for imported graphics.

D E F

A B C
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If you want to remove the background from a graphic that wasn’t saved with a clipping 
path, you can do it automatically using the Detect Edges option in the Clipping Path 
command dialog box. The Detect Edges option hides the lightest or darkest areas of a 
graphic, so it works best when the subject is set against a solid white or black background.

If you don’t want InDesign to use the clipping paths saved with graphics, you can turn 
off the Create Frame from Clipping Path option; see “Understanding graphics formats 

and their options” on page 224.

Good (left) and bad (right) candidates for automatic clipping path

To create a clipping path using imported alpha channels or automatic edge 
detection:

1 Select an imported graphic, and choose Object > Clipping Path.

2 Choose one of the following options in the Type menu:

• To create a clipping path that hides either the lightest or the darkest tones in the image, 
choose Detect Edges. By default, the lightest tones are excluded; to exclude the darkest 
tones, also select the Invert option.

• To create a clipping path from an alpha channel saved with a graphic, choose Alpha 
Channel, and then choose the channel you want to use in the Alpha menu. If the Alpha 
menu is not available, no alpha channels were saved with the graphic. InDesign 
automatically recognizes Photoshop’s default transparency (the checkerboard 
background) as an alpha channel; if the graphic has an opaque background, you must 
use Photoshop to remove the background, or create and save one or more alpha 
channels with the graphic.

3 Specify the following options, and click OK:
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Threshold Type a value or drag the slider to specify the darkest pixel value that will 
define the resulting clipping path. Increasing this value makes more pixels transparent by 
extending the range of lightness values added to the hidden area, starting from 0 (white). 
For example, if you want to remove a very light drop shadow when using Detect Edges, 
try increasing the Threshold until the shadow disappears. If light pixels that should be 
visible are invisible, the Threshold is too high.

Threshold levels at 25 (left) and 55 (right)

Tolerance Type a value or drag the slider to specify how similar a pixel’s lightness value 
can be to the Threshold value before the pixel is hidden by the clipping path. Increasing 
the Tolerance value is useful for removing unwanted bumps caused by stray pixels that are 
darker than, but close to the lightness value of, the Threshold value. Higher Tolerance 
values usually create a smoother, looser clipping path, by increasing the range of values 
near the Tolerance value within which stray darker pixels are included. Decreasing the 
Tolerance value is like tightening the clipping path around smaller variations in value. 
Lower Tolerance values create a rougher clipping path by adding anchor points, which 
may make it harder to print the image.

Tolerance levels at 0 (left) and 5 (right)
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Inset Clipping Path Type a value to specify how far to shrink the resulting clipping path 
relative to the clipping path defined by the Threshold and Tolerance values. Unlike 
Threshold and Tolerance, the Inset Frame value does not take lightness values into 
account; instead, it uniformly shrinks the shape of the clipping path. Adjusting the Inset 
value slightly may help hide stray pixels that could not be eliminated by using the 
Threshold and Tolerance values. Enter a negative value to make the resulting clipping path 
larger than the clipping path defined by the Threshold and Tolerance values.

Inset frame at -0p1 (left) and 0p3 (right)

Invert Select to switch the visible and hidden areas, by starting the clipping path with the 
darkest tones.

Include Inside Edges Select this option to make areas transparent if they exist inside the 
original clipping path, and if their lightness values are within the Threshold and Tolerance 
ranges. By default, the Clipping Path command makes only the outer areas transparent, so 
use Include Inside Edges to correctly represent “holes” in a graphic. This option works best 
when the brightness levels of areas you want to make transparent don’t match any areas 
that must be visible. For example, if you choose Include Inside Edges for a graphic of silver 
eyeglasses, and the lenses become transparent, very light areas of the eyeglass frame may 
also become transparent, such as its specular highlights. If areas become transparent 
when that wasn’t your intent, try adjusting the Threshold, Tolerance, and Inset Frame 
values.

Restrict to Frame Select this option to create a clipping path that stops at the visible 
edge of the graphic. This can result in a simpler path when you use the graphic’s frame to 
crop the graphic.

Use High Resolution Image Select this option to calculate transparent areas using the 
actual file, for maximum precision. Deselect this option to calculate transparency based on 
the screen display resolution, which is faster but less precise. This option isn’t available if 
you chose Alpha Channel, because InDesign always uses an alpha channel at its actual 
resolution. (See “Specifying transparency” on page 288.)

To create a clipping path using an imported graphic’s embedded paths:

1 Select an imported graphic, and choose Object > Clipping Path.

2 Choose Photoshop Path, specify the following options, and then click OK:

Path Choose the path that you want to use. If the Path menu isn’t available, only one path 
was saved with the graphic, and InDesign is already using it.

Inset Frame Type a value to specify how far to shrink the resulting frame. You can use this 
option to “tighten” the path around the graphic.

Invert Select this option to switch the visible and hidden areas.
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Restrict to Frame Select this option to create a clipping path that stops at the visible 
edge of the graphic.

To convert a clipping path to a graphic frame:

Right-click (Windows) or Control-click (Mac OS) the image or its frame, and choose 
Convert Clipping Path to Frame in the context menu that appears.

To reset a clipping path to the default rectangular frame:

1 Select an imported graphic, and choose Object > Clipping Path.

2 Choose None in the Type menu, and click OK.

Grouping and ungrouping objects
You can combine several objects into a group so that they are treated as a single unit. You 
can then move or transform the objects without affecting their individual positions or 
attributes. For example, you might group the objects in a logo design so that you can 
move and scale the logo as one unit. Groups can also be nested—grouped into subgroups 
within larger groups. Use the selection, direct-selection, and group-selection tools to 
select different levels of a nested group’s hierarchy. See “Identifying and selecting nested 
objects” on page 266.

Grouping objects fuses them into a single unit. If you’re working with a stack of 
overlapping objects, and you group some objects that aren’t adjacent in the stacking 
order, the selected objects will be pulled together in the stacking order, right behind the 
frontmost selected object. If you group objects that exist on different named layers, all of 
the objects move to the frontmost layer on which you selected an object. Also, the objects 
you select must either be all locked, or all unlocked.

To group or ungroup objects: 

1 Select multiple objects to be grouped or ungrouped. Selecting part of an object (for 
example, an anchor point) will group the entire object.

2 Choose either Object > Group or Object > Ungroup.

If you’re not sure if an object is part of a group, select it using the selection tool , and 
look at the Object menu. If the Object > Ungroup command is available, you’ve 

selected a group.

Identifying and selecting nested objects
When one object contains another object, the contained object is said to be nested. 
Three kinds of nesting are common: Paths inside frames, frames inside frames, and 
groups inside groups. You can also use combinations of paths, frames, and groups to 
build hierarchies of nested objects. Always be aware of exactly which objects or object 
attributes you need to select, which ones are currently selected, and which selection tools 
to use to modify selections. For example, rotating a frame may or may not rotate its 
content, depending on how you selected the frame.
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You control selections in nested groups using the direct-selection, selection, and group-
selection tools as necessary. The group-selection tool  is a version of the direct-
selection tool and is not in the toolbox; you activate it temporarily when you need it. You 
can select text characters using the text tool at any time, no matter how deeply a text 
frame is nested. For a basic discussion of selection tools, bounding boxes, and frames, see 
“Selecting objects” on page 20.

To select an object inside a frame or group:

Using the direct-selection tool , click the object.

To select the bounding box of an object inside a frame or group:

1 Using the direct-selection tool, click the content to select it independently of the group.

2 Switch to the selection tool  to activate the object’s bounding box.

To select multiple nested objects:

1 Using the direct-selection tool, click the nested object.

2 Hold down Shift as you click each additional nested object you want to select.

Selection of multiple images in a nested group

To select up or down through a hierarchy of nested objects:

1 Using the direct-selection tool, click an object nested inside a graphics frame or group.

2 Hold down Alt (Windows) or Option (Mac OS) to temporarily activate the group-
selection tool , then click the same object repeatedly until you’ve selected the frame or 
group you want. (Do not click an anchor point.)

A. Image selected B. Frame containing image selected C. Group containing frame selected

To move nested objects within a group:

1 Using the direct-selection tool, click an object nested inside a group.

2 Hold down Ctrl (Windows) or Command (Mac OS) and drag the nested object. (Do not 
click an anchor point.)

CA B
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Stacking objects
As you create or import objects, they are stacked on a page in the order in which they are 
created. Each successive new object appears in front of all existing objects. The stacking 
order determines which object is on top when you overlap two objects. You can change 
the stacking order of objects at any time using the commands in the Object  > Arrange 
menu.

Restacking objects using the Object > Arrange menu commands is not the same as using 
the Layers palette. A separate stack of objects exists within each named layer, and the 
Object > Arrange menu commands control stacking only within each named layer. To send 
an object further forward or backward than the front or back of its named layer, see 
“Selecting, moving, and copying objects on layers” on page 70. If you haven’t created any 
named layers, your document contains just one stack of objects on the single default layer. 
Objects on masters exist at the back of each named layer.

Note: Grouping objects may change objects’ stacking order in relation to objects not 
being grouped. (See “Grouping and ungrouping objects” on page 266.)

To select an object in front of or behind a selected object:

1 Using the selection tool , do one of the following:

• To select the next object behind a selected object, press Ctrl (Windows) or Command 
(Mac OS) as you click an object on a stack within a single layer. 

• To select the next object in front of a selected object, press Ctrl+Alt (Windows) or 
Command+Option (Mac OS) as you click an object on a stack within a single layer.

2 If the selected object is not the one you want, continue pressing the appropriate keys 
and click repeatedly until the object you want is selected.

Note: This procedure requires selecting the selection tool in the toolbox; it won’t work if 
you temporarily activate the selection tool by pressing the Ctrl (Windows) or Command 
(Mac OS) key.

To select an object under the current tool’s position:

1 Position any tool over the object you want to select, even if it is partially covered by 
other objects.

2 Without clicking a mouse button, do one of the following:

• To progressively select back through objects under the pointer, press Ctrl+Alt+[ 
(Windows) or Command+Option+[ (Mac OS) repeatedly until the object you want is 
selected. When the object furthest back is selected, the selection will not change.

• To progressively select forward through objects under the pointer, press Ctrl/
Command+ Alt/Option+] repeatedly until the object you want is selected. When the 
frontmost object is selected, the selection will not change.

• To select the object furthest back in the stack under the pointer, press Ctrl/
Command+Shift+ Alt/Option+[.

• To select the object at the front of the stack under the pointer, press Ctrl/
Command+Shift+ Alt/Option+].

To move a selected object to the front or back of a stack:

Choose either Object > Arrange > Bring to Front or Object > Arrange > Send to Back. 



Using Help | Contents | Index Back 269  

Adobe InDesign Help Arranging and Combining Objects 

Using Help | Contents | Index Back 269  

To move a selected object forward or backward past the next object in a stack:

Choose either Object > Arrange > Bring Forward or Object > Arrange > Send Backward. 

Aligning and distributing objects
The Align palette can line up selected objects precisely along a horizontal or vertical axis, 
and can also distribute objects, spacing them evenly along a horizontal or vertical axis.

A. Vertical alignment buttons B. Vertical distribution buttons C. Horizontal alignment buttons  
D. Horizontal distribution buttons E. Use Spacing distribution

To display the Align palette:

Choose Window > Align.

Note: The Align palette doesn’t affect objects to which you’ve applied the Lock Position 
command, and doesn’t change alignment of text paragraphs within their frames.

Aligning objects
Alignment is based on the objects that best represent the new alignment. For example, 
if you click the Vertical Align Left button, all selected objects align to the left edge of the 
selected object furthest to the left.

To align objects:

1 Select at least two objects to align.

2 In the Align palette, click the button for the type of alignment you want.

Distributing objects
You can use the Align palette to space selected objects horizontally or vertically in the 
following ways:

• Distribute objects within the boundaries of the selection, by inserting an equal amount 
of space between the corresponding edges of all selected objects. For example, if you 
click the Vertical Distribute Top button, InDesign makes sure that there is an equal 
amount of space between the top edges of each selected object.

• Distribute objects according to a value you specify, by inserting a spacing value 
between the center points or corresponding edges of selected objects. This method 
does not preserve the total width or height of the original selection.

• Distribute objects within the boundaries of the selection, by inserting an equal amount 
of space between the facing edges of all selected objects. For example, if you click the 
Vertical Distribute Space button, InDesign makes sure there is an equal amount of 
space between all selected objects.

A

B

E

C

D
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• Distribute objects according to a value you specify, by inserting a spacing value 
between the facing edges of all selected objects. This method does not preserve the 
total width or height of the selection.

A. Original placement B. Distributing within selection; equal spacing between top edges  
C. Distributing by specifying value between top edges D. Original placement E. Distributing 
within selection; equal spacing between facing edges F. Distributing by specifying value 
between facing edges

When you use the distributing option, specifying a negative value moves objects left 
along the horizontal axis, or up along the vertical axis. Positive values move objects right 
along the horizontal axis, or down along the vertical axis. Specifying a positive value adds 
space between objects, and specifying a negative value removes space between objects.

To distribute objects within the selection boundary with equal space between 
facing edges:

1 If the Distribute Spacing section of the Align palette isn’t visible, choose Show Options 
in the Align palette menu.

2 In the Distribute Spacing section of the Align palette, make sure that Use Spacing is 
deselected.

3 In the Distribute Spacing section of the Align palette, click the button to distribute 
space along the horizontal or vertical axis.

To insert a specific amount of space between the centers or edges of objects:

1 In the Align palette, select Use Spacing in the Distribute Objects section, and then type 
the amount of space you want to apply.

2 Click a button to distribute selected objects along their horizontal or vertical axes.

A B C

D E F
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To insert a specific amount of space between the facing edges of objects:

1 If the Distribute Spacing section of the Align palette isn’t visible, choose Show Options 
in the Align palette menu.

2 In the Distribute Spacing section of the Align palette, make sure that Use Spacing is 
selected, and then type the amount of space you want to apply.

3 Click a button to distribute selected objects along their horizontal or vertical axes.

Locking object position
You can use the Lock Position command to specify that you don’t want certain objects to 
move in your document. As long as an object is locked, it cannot be moved, although you 
can still select it and change other attributes such as color. Locked objects stay locked when 
a document is saved, closed, and then reopened.

To lock the positions of selected objects: 

Choose Object > Lock Position.

To unlock the positions of selected objects: 

Choose Object > Unlock Position.

You can also use the Layers palette to lock one or more layers. This locks the positions 
of all objects on a layer, and also prevents them from being selected.

Using the Transform palette
Use the Transform palette to view or specify geometric information for any selected 
object, including values for position, size, rotation, and shearing. Commands in the 
Transform palette menu provide additional options and quick ways to rotate or reflect.

A. Horizontal (X) position B. Vertical (Y) position C. Width in current units D. Height in 
current units E. Proxy for origin F. Scale X Percentage and its menu G. Rotation angle 
and its menu H. Scale Y Percentage and its menu I. Shear angle and its menu

To display the Transform palette:

Choose Window > Transform, or double-click the rotate , scale , or shear  tool.

When you double-click the rotate, scale, or shear tool, the Transform palette option 
corresponding to that tool is automatically highlighted in the Transform palette, ready 

for you to type a value.
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Viewing geometric information in the Transform palette
When you select an object, its geometric information appears in the Transform palette. If 
you selected multiple objects, the information represents all selected objects as a unit. All 
transformations operate from the object’s origin; see “Setting the point of origin for trans-
formations” on page 274.

In addition, information about position is relative to the ruler origin. Angle information is 
relative to the pasteboard, where a horizontal line has an angle of zero degrees. You can 
change the way angle information is displayed for nested objects; see “Setting the 
reference orientation for nested objects” on page 272.

To view geometric information about objects:

Select one or more objects, and display the Transform palette.

Setting the reference orientation for nested objects
The Transform palette orients an object to a spread’s pasteboard, where a horizontal line has 
a rotation angle of zero degrees. By default, this is true even if the object is nested inside a 
transformed parent object (that is, if the object is part of a transformed group or pasted 
inside a transformed frame). For example, if you paste an unrotated graphic inside a frame, 
rotate the frame ten degrees with the graphic inside, and then select the graphic using the 
direct-selection tool, the Transform palette displays the graphic’s rotation angle as 
ten degrees.

Object’s rotation angle displayed relative to pasteboard

If you prefer, you can deselect the Transformations are Totals command to see the same 
information relative to the nested object’s parent. In the example above, if you deselect 
Transformations are Totals, the Transform palette displays the graphic’s rotation angle as 
zero (the angle it has relative to its rotated container).

Object’s rotation angle displayed relative to parent object

10°

20°
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To change the reference orientation for nested objects:

In the Transform palette menu, do one of the following:

• Leave Transformations are Totals selected (the default) to display transformation infor-
mation for nested objects relative to the pasteboard.

• Deselect Transformations are Totals to display transformation information for nested 
objects relative to the parent object.

Transforming group content
When you rotate, skew, or scale a set of grouped objects, the settings apply to the entire 
group, but not to individual objects within the group. For example, if you rotate a group 
30 degrees, the Transform palette displays 30° when the group is selected, but 0° when 
an individual object is selected. However, you can use the Transform Group Content 
command to apply these attributes to the individual grouped objects.

To transform grouped content:

1 Using the selection tool , select a group of objects that has been rotated, skewed, 
or scaled.

2 Choose Transform Grouped Content in the Transform palette menu.

Scaling a frame and its content together
When you scale a frame using the Transform palette, you can use the Scale Content 
command to specify whether to scale frame content when you scale a frame. The Scale 
Content command does not apply when you scale by dragging; instead, be sure that you 
selected the frame with the selection tool.

To change the Scale Content setting:

In the Transform palette menu, do one of the following:

• Leave Scale Content deselected (the default) if you are using the Transform palette to 
crop graphics by altering frame size.

• Choose Scale Content to select it if you are resizing images that use clipping paths, or 
graphics that are already cropped properly.

Including stroke weight in measurements
Because the stroke weight of a frame always grows out from the center of the stroke, 
stroke weight can affect an object’s size and position. You can choose whether the 
Transform palette measures an object’s size and position from the center or from the edge 
of its stroke.

Note: This option does not change how stroke weights themselves increase or decrease, 
only whether any changes affect measurements. To change how stroke weight affects 
frame position and dimensions, see “Changing how stroke weight affects bounding box 
and path dimensions” on page 213.

To include or exclude stroke weight from measurements:

In the Transform palette menu, do one of the following:

• Leave Dimensions Include Stroke Weight selected (the default) when you want palette 
measurements to represent the outer edge of an object’s stroke. For example, if one 
frame is two points shorter than the other, but the shorter frame’s stroke is two points 
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thicker, this setting will cause both frames to display the same height values in the 
Transform palette.

• Deselect Dimensions Include Stroke Weight when you want the palette measurements 
to represent an object’s path or frame regardless of its stroke weight. For example, two 
frames of the same height will display the same height values in the Transform palette, 
regardless of differences in their stroke weights.

Setting the point of origin for transformations
All transformations occur in relation to a fixed point on or near the object, called the point 
of origin, which you can change. The point of origin is marked by an icon  when a trans-
formation tool, such as the scale tool, is active.

Point of origin moved to center (left), and object scaled (right)

The default point of origin depends on the object:

• For most objects, the default point of origin is the center point of all objects in the 
current selection. 

• For a line, the default point of origin is the line’s midpoint.

• For an inline graphic, the point of origin is the graphic’s center. You cannot move it.

• For objects that are not a rectangular shape, the default point of origin may not be on 
the object itself, but outside its frame.
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You can move the point of origin by dragging it, or by using the proxy on the Transform 
palette. When you drag the point of origin, it snaps to bounding box handles or to the 
anchor points of a selected path. When you set the point of origin using the Transform 
palette proxy, you select one of nine points on the rectangular area enclosing all selected 
objects.

As you click different points on the Transform palette proxy (top left and right), 
the point of origin for selected objects changes (bottom left and right)

Note: Because the x and y (horizontal and vertical position) options in the Transform 
palette always represent an object’s point of origin, dragging the point of origin away 
from an object sets that object’s x and y position values away from itself.

To change the point of origin for selected objects:

Do one of the following:

• To drag the point of origin, select the rotate tool , scale tool , or shear tool , 
position the tool over the point of origin, and drag it to a new location.

• To specify a point of origin at a corner, side, or the center of the selected objects, click 
any of the nine points on the proxy  in the Transform palette.

Note: The point of origin always shows the last position chosen whenever you deselect the 
currently selected objects, or when you switch to a tool other than a selection or transfor-
mation tool.

Moving objects
You can move objects using any of several techniques. For greater control, see “Setting the 
point of origin for transformations” on page 274.

To move an object by dragging:

Using a selection tool, drag the object to a new position. Shift-drag to constrain the object 
to multiples of 45 degrees.

You can also move by dragging when the free transform tool is selected. (See “Using 
the free transform tool” on page 284.)

To move selected objects by specifying distance precisely in the Transform palette:

In the Transform palette, type a value for each of the x (horizontal) or y (vertical) position 
options. Then press Enter or Return.
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To move an object precisely using dialog box options:

1 Select one or more objects, and then choose Object > Transform > Move, or double-
click the selection tool .

2 Do one of the following:

• Enter the horizontal and vertical distances that you want the object to move. Positive 
values move the object down and to the right of the x axis; negative values move the 
object up and to the left. 

• Enter the distance and angle for the move. The angle you enter is calculated in degrees 
from the x axis. Positive angles specify a counterclockwise move; negative angles 
specify a clockwise move. You can also enter values between 180 and 360 degrees; 
these values are converted to their corresponding negative values (for example, a value 
of 270 degrees is converted to –90 degrees).

3 If the selected object is a frame with content, and you want the content to move with 
the frame, make sure that Move Content is selected. This option is selected by default.
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4 Do one of the following:

• To preview the effect before you apply it, select Preview.

• To move the object, click OK.

• To move a copy of the object, click Copy. 

To move or copy selected objects to another page by pasting:

1 Choose Edit > Cut or Edit > Copy. 

2 Target the destination spread, and choose Edit > Paste. The objects appear in the center 
of the target spread. 

To paste a copy at the same position as the original:

1 Select an object and then choose Edit > Copy.

2 Choose Edit > Paste in Place.

Note: If you want an object to appear in the same position on many pages, consider 
creating a master page with the object on it. For more information, see “Creating and 
applying masters” on page 57.

To set keyboard preferences that affect how 
objects move:

1 Choose Edit > Preferences > Units & Increments (Windows and Mac OS 9), or InDesign > 
Preferences > Units & Increments (Mac OS 10.1)> Units & Increments.

2 For Cursor Key, specify the distance you want each press of an arrow key to move a 
selection, and then click OK. If you hold down Shift while moving a selection, the selection 
moves ten times the distance you specify here.

To move selected objects by using the arrow keys:

Do one of the following:

• To move one unit (specified in the Units & Increments preferences dialog box), press the 
Left, Right, Up, or Down arrow key.

• To move ten times the specified distance, hold down Shift as you press an arrow key.

• To move continuously, hold down an arrow key.
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Changing size, proportions, or orientation
The toolbox includes three transformation tools—the rotate, scale, and shear tools. All 
transformations, with the addition of reflection, are available in the Transform palette, 
where you can precisely specify transformations.

A. Rotate tool in toolbox (top) and rotation angle in Transform palette (bottom)  
B. Shear tool in toolbox (top) and shearing angle in Transform palette (bottom) 
C. Scale tool in toolbox (top) and scale percentage in Transform palette (bottom)

About selections and transforming
Keep the following selection guidelines in mind when transforming objects:

• The results of a transformation can differ significantly, depending on which selection 
tool you use, so make sure that you’re using the right tool. Use the selection tool  to 
transform an entire path and any content, and use the direct-selection tool  to 
transform just a part of a path without its content. For more information, see “Working 
with multiple anchor points and segments” on page 207.

• A transformation affects all selected objects as a single unit. For example, if you select 
multiple objects and rotate them 30 degrees, they all rotate around one point of origin. 
If you want to rotate each selected object 30 degrees around its own point of origin, 
you must select and rotate it separately.

• When transforming type, use the selection or direct-selection tool to select an entire 
text frame or text converted to outlines. You can’t transform type selected using the 
type tool.

Rotating selected objects
You can rotate selected objects around a point of origin that you specify. (See “Setting the 
point of origin for transformations” on page 274.)

To rotate selected objects by dragging: 

1 Select the rotate tool .

2 Position the rotate tool away from the point of origin, and drag around it. To constrain 
the tool to multiples of 45 degrees, hold down Shift as you drag. For finer control, drag 
farther from the object’s point of origin.

You can also rotate by using the free transform tool. (See “Using the free transform 
tool” on page 284.)
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To rotate selected objects by a preset angle:

Do one of the following:

• To rotate 180 degrees, choose Rotate 180° in the Transform palette menu.

• To rotate 90 degrees clockwise, choose Rotate 90° CW in the Transform palette menu.

• To rotate 90 degrees counterclockwise, choose Rotate 90° CCW in the Transform 
palette menu.

• To rotate by another preset angle, choose an angle in the menu next to the rotation 
angle option  in the Transform palette.

To rotate selected objects by specifying a precise angle in the Transform palette: 

In the rotation angle option  on the Transform palette, type a positive angle to rotate 
selected objects counterclockwise, or type a negative angle to rotate selected objects 
clockwise. Then press Enter or Return.

To rotate an object precisely using dialog box options:

1 Select one or more objects, and then do one of the following:

• Choose Object > Transform > Rotate.

• Double-click the rotate tool . 

• To change the point of origin and specify a rotation angle in the Rotate dialog box, 
select the rotate tool, and Alt-click (Windows) or Option-click (Mac OS) the new point 
of origin.

2 Enter the rotation angle, in degrees, in the Angle option. Enter a negative angle to 
rotate the object clockwise; enter a positive angle to rotate the object counterclockwise. 

3 If the selected object is a frame with content, and you want the content to rotate with 
the frame, make sure that Move Content is selected. This option is selected by default.

4 Do one of the following:

• To preview the effect before you apply it, select Preview.

• To rotate the object, click OK. 

• To rotate a copy of the object, click Copy. 

Scaling selected objects
Scaling an object enlarges or reduces it horizontally (along the x axis), vertically (along the 
y axis), or both horizontally and vertically, relative to the point of origin you specify. For 
greater control, see “Setting the point of origin for transformations” on page 274.

You can also scale objects in one percent or five percent increments, similar to the way you 
can nudge an object’s position with the arrow keys. When you use this method to change 
the dimensions of a path, the Transform palette reports the path’s new height and width 
as 100%. When you use this method to change the dimensions of an image, the Transform 
palette reports the image’s new height and width as a percentage of its original 
dimension. This lets you easily reset an image to 100% at any time, by typing 100% into 
the image’s dimensions in the Transform palette. To track the percentage change of path 
dimensions, use the Scale tool or dialog box instead; see “Using the Transform palette” on 
page 271.
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To scale selected objects by dragging the selection bounding box:

Using the selection tool , hold down Control (Windows) or Command (Mac OS) as you 
drag any handle on the selection bounding box. To preserve the original proportions, hold 
down Control+Shift (Windows) or Command+Shift (Mac OS) as you drag a handle.

Original image (left) and enlarged image (right)

You can also scale by using the free transform tool. (See “Using the free transform 
tool” on page 284.)

To scale selected objects by dragging with the scale tool: 

1 Select the scale tool .

2 Position the scale tool away from the point of origin and drag. To scale the x or y axis 
only, start dragging the scale tool along one axis only. To scale proportionally, drag exactly 
between the x and y axes. You can also constrain scaling to either x or y axes, or both x and 
y axes proportionally, by holding down Shift as you drag the scale tool. For finer control, 
start dragging farther from the object’s point of origin.

To scale selected objects using a preset percentage value:

Choose a value in the menu next to the Scale X Percentage or Scale Y Percentage options 
in the Transform palette.

To scale selected objects by specifying a value in the Transform palette: 

1 In the Transform palette, type a value in any of the Width (W), Scale X Percentage , 
Height (H), or Scale Y Percentage  options.

2 Do one of the following:

• To apply the value, press Enter or Return.

• To apply the value while preserving the original proportions of the object, press 
Ctrl+Enter (Windows) or Command+Return (Mac OS). The other dimension’s value 
changes accordingly.

Note: If the content scales with the frame, and you don’t want this to happen, deselect the 
Scale Content option in the Transform palette menu. (See “Scaling a frame and its content 
together” on page 273.)

To scale an object precisely using dialog box options:

1 Select one or more objects. 

2 Do one of the following:

• Choose Object > Transform > Scale.
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• Double-click the scale tool . 

• To change the point of origin and specify a scaling percentage in the Scale dialog box, 
select the scale tool, and Alt-click (Windows) or Option-click (Mac OS) the new point of 
origin.

3 In the Scale dialog box, do one of the following:

• Select Uniform, and then enter a percentage in the Scale option to preserve the relative 
height and width of the object.

• Select Non-Uniform, and then enter the horizontal and vertical scale factors as 
percentages to scale the height and width separately. The scale factors are relative to 
the specified point of origin and can be negative numbers. 

4 If the selected object is a frame with content and you want the content to scale with the 
frame, make sure that Scale Content is selected. This option is selected by default.

5 Do one of the following:

• To preview the effect before you apply it, select Preview.

• To scale the object, click OK.

• To scale a copy of the object, click Copy. 

To scale by nudging with the keyboard:

Select an object and do one of the following:

• To enlarge by one percent, press Ctrl+. (Windows) or Command+. (Mac OS).

• To reduce by one percent, press Ctrl+, (Windows) or Command+, (Mac OS).

• To enlarge or reduce by five percent, use either of the preceding shortcuts while also 
holding down Alt (Windows) or Option (Mac OS).

It’s easy to remember these shortcuts, because they correspond to the keys that use 
the greater-than (>) symbol and the less-than symbol (<). The shortcuts aren’t listed 

with these symbols, because the shortcuts don’t use the Shift key.

About scaling type and stroke weights
When you use the procedures in this chapter to scale type, instead of using the size option 
in the Character palette, the Character palette indicates type size relative to a text frame’s 
original size (100%). For more information, see “Scaling type” on page 120.

Scaling a path scales the path’s stroke weight, but like type, the Stroke palette indicates 
the stroke weight relative to the path’s original size.

Reflecting selected objects
Reflecting an object flips the object across an invisible axis at the point of origin you 
specify. (See “Setting the point of origin for transformations” on page 274.)

You can reflect objects by using the selection tool or free transform tool to pull one 
side of an object’s bounding box past the opposite side, or by typing negative values 

into the Scale X Percentage or Scale Y Percentage options in the Transform palette.
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To reflect selected objects: 

Do one of the following:

• To reflect using the point of origin as a horizontal axis, choose Flip Horizontal in the 
Transform palette menu.

• To reflect using the point of origin as a vertical axis, choose Flip Vertical in the Transform 
palette menu.

An object reflected using Flip Horizontal (top) and Flip Vertical (bottom)

• To reflect using the point of origin as both a horizontal and vertical axis, choose Flip 
Both in the Transform palette menu, which results in a 180° rotation.

An object reflected using Flip Both

You can reflect an object at an angle other than those specified, by rotating the 
object first.

Shearing selected objects
Shearing an object slants, or skews it along its horizontal axis, and can also rotate both of 
the object’s axes. Shearing is useful for:

• Simulating some types of perspective, such as isometric projection.

• Slanting a text frame.

• Creating cast shadows, when you shear a copy of an object.

For greater control, see “Setting the point of origin for transformations” on page 274.

To shear selected objects by dragging:

1 Select the shear tool .
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2 Position the shear tool away from the point of origin, and drag. Shift-drag to constrain 
shearing to 45-degree increments. For finer control, start dragging farther from the 
object’s point of origin.

Point of origin placed at center (left), and dragging shear tool (right)

The shear tool may be easier to use if you move the point of origin to the center of the 
selection. You can also shear by using the free transform tool. (See “Using the free 

transform tool” on page 284.)

To shear selected objects by specifying a precise value:

1 Select one or more objects to shear.

2 In the Shear option on the Transform palette , type a positive or negative value to 
specify the shearing angle, and press Enter or Return.

To shear selected objects using a preset percentage value:

Choose a value in the menu next to the Shear option in the Transform palette.

To shear an object precisely using dialog box options:

1 With the selection tool, select the object or objects to shear. 

• Choose Object > Transform > Shear.

• Double-click the shear tool . 

• To change the point of origin and specify a shearing angle and axis in the Shear dialog 
box, select the shear tool, and Alt-click (Windows) or Option-click (Mac OS) the new 
point of origin.

2 In the Shear dialog box, enter the new shear angle. The shear angle is the amount of 
slant to be applied to the object, relative to a line perpendicular to the shear axis. (Shear 
angle is calculated clockwise from the current axis.)

3 Specify the axis along which the object is to be sheared. You can shear an object along a 
horizontal, a vertical, or an angled axis. 
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If you choose an angled axis, enter the angle of the axis that you want, in degrees, relative 
to the x axis.

Point of origin placed at left corner (left), and shear angle entered into Shear dialog box (right)

4 If the selected object is a frame with content and you want the content to move with 
the frame, make sure that Shear content is selected. This option is selected by default.

5 Do one of the following:

• To preview the effect before you apply it, select Preview.

• To shear the object, click OK. 

• To shear a copy of the object, click Copy.

Using the free transform tool
The free transform tool works the same way it does in Photoshop and Illustrator, by 
providing a way to perform any transformation with just one tool. You can combine trans-
formations, such as rotating and scaling, while the free transform tool is active.

You can use keyboard shortcuts to instantly switch between the transform tool (press 
E), the selection tool (V), and the direct-selection tool (A).

To move with the free transform tool:

1 Select the object or objects to move. 

2 Select the free transform tool . 

3 Click anywhere within the bounding box, and then drag.

To scale with the free transform tool:

1 Select the object or objects to scale. 

2 Select the free transform tool . 

3 Do one of the following:

• Drag any bounding box handle until the object is the desired size.

• Shift-drag the handle to preserve the selection’s proportions.

• Alt-drag (Windows) or Option-drag (Mac OS) to scale from the center of the bounding 
box (instead of from the opposite handle).

To rotate with the free transform tool:

1 Select the object or objects to rotate. 

2 Select the free transform tool . 
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3 Position the pointer anywhere outside the bounding box. The pointer changes to . 

4 Drag until the selection is at the desired angle of rotation.

To reflect with the free transform tool:

1 Select the object or objects to reflect. 

2 Select the free transform tool . 

3 Drag a handle of the bounding box past the opposite edge or handle, until the object is 
at the desired level of reflection.

To shear with the free transform tool:

1 Select the object or objects to shear. 

2 Select the free transform tool . 

3 Start dragging a handle on the side of the bounding box (not a corner) and then hold 
down Ctrl+Alt (Windows) or Option+Command (Mac OS) as you drag, until the object is at 
the desired perspective. Shift-drag to constrain the tool.

Note: If the object scales instead of skewing, make sure that you start dragging a side 
handle before you press the Ctrl/Command key. If you press the key first, the object scales.

Duplicating objects
Use the Duplicate command to replicate a selected object instantly. The new copy appears 
on the layout slightly offset down and to the right from the original.

To duplicate an object:

Select an object, and choose Edit > Duplicate.

Duplicating objects as you transform them
You can duplicate an object each time you change its position, orientation, or propor-
tions. For example, you can create a flower by drawing one petal, setting its point of origin 
at the base of the petal, and repeatedly rotating at incremental angles, simultaneously 
duplicating to leave behind a new copy of the petal at each angle.

To duplicate a selected object as you transform:

During a transformation, do one of the following:

• If you’re dragging the selection , rotate , scale , or shear  tool, hold down Alt 
(Windows) or Option (Mac OS) as you drag. To constrain the duplicate’s transformation, 
Alt+Shift+drag (Windows) or Option+Shift+drag (Mac OS).

• If you’re specifying a value in the Transform palette, press Alt+Enter (Windows) or 
Option+Return (Mac OS) after you’ve entered the value.

• If you’re pressing arrow keys to move objects, hold down Alt (Windows) or Option 
(Mac OS) as you press the keys.

Using step and repeat to duplicate objects
Use the Step and Repeat command to instantly create rows or columns of duplicates. 
For example, you can fill a page with evenly spaced duplicates of a single business 
card design.
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To duplicate selected objects into rows or columns:

1 Choose Edit > Step and Repeat.

2 For Repeat Count, specify how many duplicates you want to make, not counting 
the original.

3 For Horizontal Offset and Vertical Offset, specify how far to shift the position of each 
new duplicate from the previous duplicate along the x and y axes, respectively, and 
click OK.

To create a page full of duplicates, first use Step and Repeat with Vertical Offset set to 0 
(zero); this will create one row of duplicates. Then select the entire row and use Step 

and Repeat with Horizontal Offset set to 0; this will repeat the row down the page.



Using Help | Contents | Index Back 287  

Adobe InDesign Help Working with Transparency 

Using Help | Contents | Index Back 287  

Working with Transparency

About transparency
In InDesign, you can add transparency to your artwork in a variety of ways. You can 
vary the degree of transparency of an object or a group of objects from 100% opacity 
(completely “solid”) to 0% opacity (completely transparent). When you decrease 
an object’s opacity, the underlying artwork becomes visible through the surface of 
the object. 

Using options in the Transparency palette, you can also create special effects, such as 
knocking out or blending colors with other objects. 

Transparency features, including drop shadows and blend modes, can be applied to any 
object created in InDesign, as well as to objects placed from Photoshop and Adobe Illustrator

It’s possible to add transparency to your artwork without realizing it—for example, by 
adding drop shadows and feathering to objects, or by placing files with transparency that 
originated in other applications, such as Photoshop or Adobe Illustrator. Be aware of when 
you’re using transparency, because you need to set some extra options when printing and 
saving transparent artwork. (See “Controlling flattener settings and results using styles” on 
page 294 and “Setting up your transparent document for successful output” on page 296.)

Using grouped objects with the Transparency palette
By default, the Transparency palette acts on single objects, but you can also use it to create 
unique transparency effects at the group level.

If you simply select objects and change the opacity setting, the selected objects’ opacity 
will change relative to that of the others. Any overlapping areas will show an 
accumulated opacity. 
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In contrast, if you target a group that has been created with the Group command, and 
then change the opacity, the group is treated as a single object by the Transparency 
palette, and the opacities within the group don’t change. In other words, objects within 
the group don’t interact with each other in transparency.

Individual objects selected and set to 50% opacity (left) 
and group selected and set to 50% opacity (right)

Using the Transparency palette
Use the Transparency palette to specify the opacity and blending mode of objects, to 
isolate blending, and to “knock out” a portion of one object with the overlying portion of 
another object. (See “Selecting blending modes” on page 289 and “Creating transparency 
knockouts” on page 292.)

To display the Transparency palette:

Choose Window > Transparency.

To display transparency options:

Click the triangle  in the upper right corner of the palette, and choose Show Options.

Specifying transparency
You can apply transparency to selected objects and groups (including graphic and text 
frames), but not to individual text characters or layers; and you cannot apply different 
transparency values to the fill and stroke of an object. However, imported graphics with 
those types of transparency effects will display and print correctly. 

Note: To ensure that transparent objects imported from Illustrator 9.0 and later, Acrobat 
5.0, or Photoshop appear correctly, use the same color management settings throughout 
the applications. For more information, see “Synchronizing color management between 
applications” on page 348. You can visit the Customer Support area at Adobe.com for 
technical guides on setting up CMS between multiple applications.

By default, selecting an object or a group and applying a transparency setting changes the 
entire object (both the stroke and the fill) or the group container. 

To set the opacity of an object or group:

1 Select the object or group using one of the following methods:

• Use the direct-selection tool to select an object, a graphic in a frame, or an object in a 
group. This method sets transparency for the selection.

• Use the selection tool to select the object, group, or graphics frame. This method sets 
the transparency for the stroke, fill, and contents.
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• Use the selection tool to select a group on the layout. To select more than one group, 
hold down Shift, and click the other groups.

2 In the Transparency palette, type a value for Opacity, or click the arrow next to the 
Opacity setting, and drag the slider. As the opacity value of an object is reduced, its trans-
parency increases.

Note: If you direct-select and cut or copy an object from a transparent group in InDesign, 
and then paste the object somewhere else in the document, the pasted object won’t be 
transparent unless it was previously selected individually and had transparency applied.

Changing the appearance of transparent artwork on-
screen
Use the Display Performance dialog box to set transparency preferences. These prefer-
ences determine the on-screen quality of transparent objects, and turn on or off the 
display of transparency in your document. Turning off transparency in the display prefer-
ences doesn’t turn off transparency when printing or exporting the file. For more infor-
mation, see “Controlling image display quality and performance” on page 221.

Use the View menu to quickly change transparency display between Optimized, Typical, 
and High Quality. 

Note: Before you print a file containing transparency effects, make sure that you check the 
transparency preferences first. Printing automatically flattens the artwork, and may affect 
the appearance of the transparency effects.

To turn off transparency so it doesn’t display on-screen:

1 Choose Edit > Preferences > Display Performance (Windows or Mac OS 9) or InDesign > 
Preferences > Display Performance (Mac OS 10.1).

2 Drag the Transparency slider all the way to the left.

3 Click OK.

To change the appearance of transparent artwork on-screen:

1 Choose Edit > Preferences > Display Performance (Windows or Mac OS 9) or InDesign > 
Preferences > Display Performance (Mac OS 10.1).

2 Select a default view setting. 

Note: To see the cyan in a rich black fill, select High Quality Display. 

3 Drag the Transparency slider. The default setting is Medium Quality, which displays 
drop shadows and feathering.

4 Click OK.

5 When spot colors overlap with blend modes, choose View > Overprint Preview. This 
option ensures that you can see on-screen how spot colors interact with transparency.

Selecting blending modes
You can blend the colors between two overlapping objects by using the blending modes 
in the Transparency palette. 
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Blending modes let you vary the ways in which the colors of objects blend with the colors 
of underlying objects. 

Consider the following colors when visualizing a blending mode’s effect: 

• The base color is the underlying color in the artwork. 

• The blend color is the color of the selected object or group of objects.

• The resulting color is the color resulting from the blend. 

To specify the blending mode of an object or group:

1 Select one or more objects or a group.

2 In the Transparency palette, choose a blending mode in the menu. 

Normal Colors the selection with the blend color, without interaction with the base color. 
This is the default mode. 

Multiply Multiplies the base color by the blend color. The resulting color is always a 
darker color. Multiplying any color with black produces black. Multiplying any color with 
white leaves the color unchanged. The effect is similar to drawing on a page with multiple 
magic markers. 

Screen Multiplies the inverse of the blend and base colors. The resulting color is always a 
lighter color. Screening with black leaves the color unchanged. Screening with white 
produces white. The effect is similar to projecting multiple slide images on top of each 
other. 

Overlay Multiplies or screens the colors, depending on the base color. Patterns or colors 
overlay the existing artwork, preserving the highlights and shadows of the base color 
while mixing in the blend color to reflect the lightness or darkness of the original color. 

Soft Light Darkens or lightens the colors, depending on the blend color. The effect is 
similar to shining a diffused spotlight on the artwork. 

If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it 
were dodged. If the blend color is darker than 50% gray, the artwork is darkened, as if it 
were burned in. Painting with pure black or white produces a distinctly darker or lighter 
area, but does not result in pure black or white. 

Hard Light Multiplies or screens the colors, depending on the blend color. The effect is 
similar to shining a harsh spotlight on the artwork. 

If the blend color (light source) is lighter than 50% gray, the artwork is lightened, as if it 
were screened. This is useful for adding highlights to artwork. If the blend color is darker 
than 50% gray, the artwork is darkened, as if it were multiplied. This is useful for adding 
shadows to artwork. Painting with pure black or white results in pure black or white.

Color Dodge Brightens the base color to reflect the blend color. Blending with black 
produces no change.

Color Burn Darkens the base color to reflect the blend color. Blending with white 
produces no change.

Darken Selects the base or blend color—whichever is darker—as the resulting color. 
Areas lighter than the blend color are replaced, and areas darker than the blend color do 
not change. 
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Lighten Selects the base or blend color—whichever is lighter—as the resulting color. 
Areas darker than the blend color are replaced, and areas lighter than the blend color do 
not change. 

Difference Subtracts either the blend color from the base color or the base color from the 
blend color, depending on which has the greater brightness value. Blending with white 
inverts the base color values; blending with black produces no change.

Exclusion Creates an effect similar to, but lower in contrast than, the Difference mode. 
Blending with white inverts the base color components. Blending with black produces 
no change.

Hue Creates a color with the luminance and saturation of the base color and the hue of 
the blend color. 

Saturation Creates a color with the luminance and hue of the base color and the 
saturation of the blend color. Painting with this mode in an area with no saturation (gray) 
produces no change. 

Color Creates a color with the luminance of the base color and the hue and saturation of 
the blend color. This preserves the gray levels in the artwork, and is useful for coloring 
monochrome artwork and for tinting color artwork.

Luminosity Creates a color with the hue and saturation of the base color and the 
luminance of the blend color. This mode creates an inverse effect from that of the 
Color mode.

Note: The Difference, Exclusion, Hue, Saturation, Color, and Luminosity modes do not 
blend spot colors.

Isolating blending modes
When you apply blending modes to objects in a group, the effects of the blending modes 
are normally seen on any objects beneath the group.

You can use the Isolate Blending option to change the behavior of blending modes, so 
that only members of the selected group are affected; objects beneath the group are 
unaffected by the blending modes. This prevents a background object from altering 
the result.

Note: The Isolate Blending command is only useful for groups containing objects that 
have a blending mode other than Normal applied to them.

Group selected without Isolate Blending (left), and same 
group with Isolate Blending option applied (right)

Consider the following interactions when isolating blending modes in InDesign:

• To isolate only the image inside a graphics frame, use the direct-selection tool to select 
the object when you apply the blending mode.
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• To isolate the frame’s stroke, fill, and contents, use the selection tool to select the object 
when you apply the blending mode.

• To isolate a PDF file containing blending modes, select Transparent Background in the 
Place PDF dialog box as you place the file. Then, use the direct-selection tool to select 
the file, and select Isolate Blending in the Transparency palette.

To isolate blending modes:

1 Select a group containing two or more objects to which blending modes are applied. 

2 In the Transparency palette, select Isolate Blending.

Blending multiple color spaces
To blend the colors of transparent objects on a spread, InDesign converts the colors of all 
objects to a common color space using either the CMYK or RGB color profile for the 
document. This blending space enables objects of multiple color spaces to blend when 
interacting transparently. To avoid color mismatches between different areas of the 
objects on-screen and in print, the blending space is applied for screen and in the 
flattener. For more information about the flattener, see “About flattening” on page 294. 

The blending space is applied only to those spreads that contain transparency. 

To specify a blending color space:

Choose Edit > Transparency Blend Space, and then choose one of the document’s 
color spaces.

Note: For a typical print workflow, choose the CMYK color space.

Creating transparency knockouts
Use the Knockout Group option in the Transparency palette to make every object of the 
selected group “knock out”—that is, visually block out—underlying objects in the group. 

When you use the Knockout Group option, only objects within the selected group knock 
out. Objects beneath the selected group are still visible relative to the group, and are 
affected by the blending or transparency that you apply to objects within the group. If you 
want to ensure that a group of transparent objects will never knock each other out, 
deselect Knockout Group.

Group with Knockout Group option off (left) and with Knockout Group option on (right)

To knock out objects within a group:

1 Select the group using the selection tool.

2 Select Show Options in the Transparency palette menu, if necessary.

3 In the Transparency palette, select Knockout Group.
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To prevent objects from knocking out within a knockout group:

1 Select a group that has the Knockout Group option applied.

2 In the Transparency palette, deselect Knockout Group.

Adding drop shadows
The Drop Shadow command creates a three-dimensional shadow on any selected object. 
You can offset the drop shadow any distance from the object along the x or y axis, as well 
as vary the blending mode, opacity, blur, and color of the drop shadow.

Note: If you specify drop shadow settings without first selecting an object, each object you 
draw will have a drop shadow with those settings. 

To create a drop shadow:

1 Select one or more objects or a group.

2 Choose Object > Drop Shadow. 

3 Select Drop Shadow to activate the controls.

4 Choose a blending mode in the Mode menu. For more information, see “Selecting 
blending modes” on page 289.

5 Enter the amount of opacity you want for the shadow.

6 Enter the distance you want the drop shadow to be offset from the object on the x axis 
or the y axis.

7 Enter the distance from the edge of the shadow where you want any blurring to occur.

8 For Color, choose a color to specify the shadow color.

9 Select Preview to display the results on-screen. 

10 Click OK.

Feathering edges
The Feather command softens the edges of an object by fading them to transparent over 
the distance you specify.

Note: If you specify feathering settings without first selecting an object, each object you 
draw will be feathered with those settings. 

To make the edges of an object fade from opaque to transparent:

1 Select the object that has edges you want to feather.

2 Choose Object > Feather.

3 Select Feather to activate the controls.

4 For Feather Width, enter the distance over which you want the change from opaque to 
transparent to occur.

5 Choose a corner option:

Sharp The gradient exactly follows the outer edge of the shape, including sharp corners. 
Sharp is appropriate for star-like objects, or for a special effect on a rectangular shape.
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Rounded The corners are rounded by the feather radius; in effect, the shape is first inset, 
then outset, to form the two contours. Rounded creates a pleasing effect on rectangles.

Diffused Uses the Adobe Illustrator method, which makes the edges of the object fade 
from opaque to transparent.

6 Select Preview to display the results on-screen.

7 Click OK.

About flattening
Flattening cuts apart transparent art to represent overlapping areas as discrete pieces that 
are either vector objects or rasterized areas. As artwork becomes more complex (mixing 
images, vectors, type, spot colors, overprinting, and so on), so does the flattening and 
its results.

Flattening occurs whenever you print from InDesign or export to a format other than 
Adobe PDF 1.4 (Acrobat 5.0). InDesign flattens transparent objects according to the 
settings in the selected flattener style. (See “Controlling flattener settings and results using 
styles” on page 294.)

Flattening cuts transparent art apart to represent overlapping areas as discrete pieces that 
are either vector objects or rasterized areas; this example involves only vector objects

Controlling flattener settings and results using styles
If you regularly export or print documents that contain transparency, you can automate 
the flattening process by saving flattener settings in a flattener style. 

To apply a flattener style to a document or book:

In the Advanced panel of the Print or Export dialog box, choose a transparency flattener 
style in the Style menu. 

Note: To use custom flattener styles, see “Creating, saving, and loading custom flattener 
styles” on page 295.

About predefined flattener styles
For your convenience, InDesign includes three predefined transparency flattener styles. 
The settings are designed to match the quality and speed of the flattening with the 
resolution of rasterized transparent areas, depending on intended use.

Low Resolution Use for quick proofs that will be printed on black-and-white desktop 
printers, and for documents that will be published on the Web or exported to SVG.

Medium Resolution Use for desktop proofs and print-on-demand documents that will 
be printed on PostScript color printers.
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High Resolution Use for final press output, and for high-quality proofs such as separa-
tions-based color proofs.

Creating, saving, and loading custom flattener styles
You can save and load flattener styles, making it easy to back them up or to make them 
available to your service providers, clients, or others in your workgroup.

To create or edit a flattener style:

1 Choose Edit > Transparency Flattener Styles.

2 Do one of the following:

• Click New to create a style.

• To base a style on a predefined style, select one in the list, and click New.

• Select a custom style in the list and click Edit.

Note: You can’t edit the default flattener styles.

3 Type a name in the Name text box or accept the default name.

4 Drag the Raster/Vector Balance slider. The higher the setting, the less rasterization is 
performed on artwork. To keep as many objects vector as possible, select the highest 
setting; to rasterize all the artwork with transparency applied, select the lowest setting. 

Note: The amount of rasterization that occurs depends on the amount of RAM available 
to the program, the complexity of the page, and the types of overlapping objects.

5 Do the following:

• For Flattener Resolution, set an output resolution for rasterized artwork (except for 
gradient objects). In most cases, 300 dpi is sufficient.

• For Gradient Resolution, set an output resolution for gradient objects. In most cases, 
150 is sufficient.

6 Select any of the following, and then click OK:

• Force Text to Outlines to expand all text to outlines throughout the document. 
Otherwise, only transparent portions of the text may get converted to outlines, which 
may change their width. This option makes the width consistent. 

• Convert Strokes to Outlines to convert all strokes in the document to outlines, not just 
the ones with objects that have transparency. 

• Clip Complex Regions to decrease the probability of stitching. When the Raster/Vector 
Balance slider is not all the way to the right, complex areas sometimes get rasterized 
during the flattening process. Normally, the areas are rasterized in a “blocky” fashion 
that can cut though objects, so that part of an object can be rasterized and another can 
remain in vector form. This process can result in stitching. Selecting this option 
decreases the probability of stitching by ensuring that the raster/vector boundary 
always falls along existing object paths. However, this method can result in overly 
complex clipping paths, which may not print on some PostScript output devices. 

To save custom flattener styles:

1 Choose Edit > Transparency Flattener Styles.

2 Select one or more styles in the list and click Save.

3 Specify a name and location, and then click Save.
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To load flattener styles from another InDesign document:

1 Choose Edit > Transparency Flattener Styles.

2 Click Load.

3 Locate and double-click the file containing the style you want to load, and then 
click Open. 

To rename or delete custom flattener styles:

1 Choose Edit > Transparency Flattener Styles.

2 Do one of the following:

• To rename an existing style, select a style in the list, click Edit, type a new name, and 
then click OK.

• To delete styles, select one or more styles in the list, click Delete, and then click OK to 
confirm the deletion.

Flattening individual spreads
You can apply flattener settings to individual spreads in a document, overriding the 
flattener style you’ve set for the entire document or book. This is useful for controlling the 
flattening quality in documents with a mix of high-resolution images with lots of trans-
parency and low-resolution images. In this case, you can flatten the complex spread at a 
high quality, and use a faster and lower-quality flattener style on the other spreads. 

At print or export time, you can revert to the flattener settings for the document or book.

To flatten a spread:

1 Display the spread in the Document window.

2 Choose Spread Flattening in the Pages palette menu.

3 Choose any of the following, and then click OK:

• Default to use the document flattening style for this spread.

• None (Ignore Transparency) to ignore transparency for the spread. This is useful for 
troubleshooting by the service provider.

• Custom to open the Transparency Flattener Style dialog box for specifying settings.

To ignore the flattener style on an individual spread:

Select Ignore Spread Overrides from any of the following locations in InDesign:

• The Advanced panel of the Print or Export dialog box.

• The SVG Options dialog box with More Options selected.

Setting up your transparent document for successful 
output
Flattening may alter colors and transparent objects in your document in ways that can 
affect output quality. Flattened objects look transparent, but they are actually opaque and 
don’t allow other objects beneath them to show through.
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In most cases, flattening produces excellent results when you use an appropriate 
predefined flattener style, or create a style with settings appropriate for your final output. 
However, if your document contains complex, overlapping areas and you require high-
resolution output, you can achieve more reliable print output by following a few 
basic guidelines. 

For information on flattener styles, see “Controlling flattener settings and results using 
styles” on page 294.

For a complete reference and troubleshooting guide on how transparency affects output, 
see the document, “Achieving Reliable Print Output with Transparency,” in the Customer 
Support area of adobe.com.

Important: If you’re applying transparency to documents intended for high-resolution 
output, be sure to discuss your plans with your service provider. Good communication 
between you and your service provider will help you achieve the results you expect.

Spot colors and blend modes
Using spot colors with certain blend modes sometimes produces unexpected results. 
This is because InDesign uses process color equivalents on-screen, but uses spot color in 
print. In addition, isolated blending in an imported graphic could create knockouts in the 
active document.

If you use blending, check your design periodically using High Quality Display and 
Overprint Preview in the View menu. Overprint Preview gives an approximation of how 
spot inks that overprint or interact with transparent objects will appear. If the visual effect 
is not what you want, do any of the following:

• Use a different blend mode or no blend mode. Avoid these blend modes when working 
with spot colors: Difference, Exclusion, Hue, Saturation, Color, and Luminosity. 

• Use a process color where possible.

Blend space
If you apply transparency to objects on a spread, all colors on that spread convert to the 
transparency blend space you’ve chosen (Edit > Transparency Blend Space), either 
Document RGB or Document CMYK. Colors are converted “on the fly” as you draw objects. 
Colors in placed graphics that interact with transparency are also converted to the blend 
space. This affects only how you see the colors on-screen, not how the colors are defined 
in the document. 

Depending on your workflow, do one of the following:

• If you create documents for print only, choose Document CMYK for the blend space.

• If you create documents for Web only, choose Document RGB.

• If you create documents for both print and Web, decide which is most important, and 
then choose the blend space that matches the final output. 

• If you create a high-resolution print piece that you’ll also publish as a high-profile PDF 
document on a Web site, you may need to switch the blending space back and forth 
before final output. In this case, be sure to reproof the color on every spread that has 
transparency, and avoid using the Difference and Exclusion blend modes—these 
modes can change the appearance dramatically. 



Using Help | Contents | Index Back 298  

Adobe InDesign Help Working with Transparency 

Using Help | Contents | Index Back 298  

Type
Type may interact with transparent objects in ways that you didn’t intend, because of its 
proximity to the transparent objects. For example, type that wraps around a transparent 
object may not actually overlap the object, but the glyphs may be close enough to 
interact with the transparency. In this case, the flattener may convert the glyphs to 
outlines, resulting in thickened stroke widths on the glyphs only.

If this happens, you can expand all type to outlines for a consistent effect throughout the 
document. To expand all text to outlines, select Force Text to Outlines in the Transparency 
Flattener Style dialog box. Selecting this option may have an impact on processing speed.

Image replacement
The flattener requires high-resolution data to accurately process a document with trans-
parency. However, in an OPI workflow, placeholder or sample images are used, for later 
replacement with high-resolution versions by an OPI server. If the flattener doesn’t have 
access to the high-resolution data, then only the low-resolution proxy images end up at 
the OPI server, resulting in low-resolution images at final output. 

If you work in an OPI workflow, consider using InDesign to substitute images before saving 
the document as PostScript. To do this, choose OPI Image Replacement in the Advanced 
panel of either the Print or Export EPS dialog box. For more information, see “Exporting 
options” on page 251.

Color conversions
If a transparent object overlaps a spot color object, undesirable results may occur when 
you export to EPS format, and then convert spot colors to process colors upon printing or 
create color separations in an application other than InDesign. 

To prevent problems in these cases, make sure that your spot inks are consistent in both 
the original application (for example, Adobe Illustrator) and InDesign. This may mean that 
you’ll need to open an Illustrator document, convert a spot color to process color, export it 
again to EPS, and then place the EPS file in your InDesign layout.

Adobe PDF files
Exporting to Acrobat 4.0 (Adobe PDF 1.3) always flattens a document, which may affect 
the appearance of its transparent objects. Therefore, when you export an InDesign 
document with transparency to Adobe PDF, do any of the following:

• Whenever possible, choose Acrobat 5.0 compatibility in the Export PDF dialog box to 
preserve transparency in a live and fully editable form. Make sure that your service 
provider can handle Acrobat 5.0 files (Adobe PDF 1.4).

• If you must use Acrobat 4.0 compatibility because of a client requirement, consider 
using Simulate Overprint in the Advanced panel of the Export PDF dialog box. Simulate 
Overprint produces an on-screen simulation of the job printed with spot colors. In this 
case, your client will see on-screen what you see, but you won’t be able to print a spot 
ink plate. The flattener will keep spot color information wherever possible.

• Consider using the predefined [Press] Adobe PDF style. This style contains flattener 
settings appropriate for complex documents intended for high-resolution output.
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DCS (preseparated) images and multitone images
The flattener requires composite data to process transparent areas correctly. Because DCS 
images are preseparated, the flattener doesn’t see them. DCS images will print correctly if 
they don’t interact with transparent objects. 

To overcome DCS limitations, save your multitone images as EPS files. 

Trapping
Flattening may convert vectors to rasterized areas. Traps applied to artwork in Adobe Illus-
trator using strokes and placed in InDesign will be preserved. However, traps applied to 
vector artwork drawn in InDesign that becomes rasterized will be removed. 

To keep as many objects vector as possible, select the [High Resolution] transparency 
flattener style in the Advanced panel of the Print or export dialog boxes.
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Applying Color

About spot and process color types
You can designate colors as either spot or process color types, which correspond to the 
two main ink types used in commercial printing. In the Swatches palette, you can identify 
the color type of a color using icons that appear next to the name of the color. 

Spot colors
A spot color is a special premixed ink that is used instead of, or in addition to, CMYK process 
inks, and that requires its own printing plate on a printing press. Use spot color when few 
colors are specified and color accuracy is critical. Spot color inks can accurately reproduce 
colors that are outside the gamut of process colors. However, the exact appearance of the 
printed spot color is determined by a combination of the ink as mixed by the commercial 
printer and the paper it’s printed on, so it isn’t affected by the color values you specify 
or by color management. When you specify spot color values, you’re describing the 
simulated appearance of the color for your monitor and composite printer only (subject to 
the gamut limitations of those devices).

For best results in printed documents, specify a spot color from a color-matching system 
supported by your commercial printer. Several color-matching system libraries are 
included with InDesign; see “Loading colors from other color systems” on page 308.

Keep the number of spot colors you use to a minimum. Each spot color you create will 
generate an additional spot color printing plate for a printing press, and increase your 
printing costs. If you think you might need more than four colors, consider printing your 
document using process colors.

Process colors
A process color is printed using a combination of four standard process inks: cyan, 
magenta, yellow, and black (CMYK). Use process colors when a job requires so many colors 
that using individual spot inks would be expensive or impractical, as when printing color 
photographs. Keep the following guidelines in mind when specifying a process color:

• For best results in a printed document, specify process colors using CMYK values 
printed in process color reference charts, such as those available from a commercial 
printer.

• The final color values of a process color are its values in CMYK, so if you specify a process 
color using RGB or LAB, those color values will be converted to CMYK when you print 
color separations. These conversions work differently when you turn on color 
management; they are affected by the profiles you specify. (See “About color 
management” on page 337.)

• Don’t specify a process color based on how it looks on your monitor, unless you are sure 
you have set up a color management system properly, and you understand its limita-
tions for previewing color.
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• Avoid using process colors in documents intended for online viewing only, because 
CMYK has a smaller color gamut than that of a typical monitor.

Using spot and process colors together
Sometimes it’s practical to use process and spot inks in the same job. For example, you 
might use one spot ink to print the exact color of a company logo on the same pages of an 
annual report where photographs are reproduced using process color. You can also use a 
spot color printing plate to apply a varnish over areas of a process color job. In both cases, 
your print job would use a total of five inks—four process inks and one spot ink or varnish.

Important: If an object contains spot colors and it overlaps another object containing 
transparency features, undesirable results may occur when you export to EPS format; 
when you convert spot colors to process colors using the Print dialog box; or when you 
create color separations in an application other than InDesign. To prevent problems in 
these cases, you should first convert the spot colors to process colors before printing to 
preview the effects with Overprint Preview.

Comparing global and nonglobal process colors in InDesign and 
Illustrator
Adobe InDesign 2.0 and Adobe Illustrator 10.0 use slightly different methods for applying 
named process colors. Illustrator lets you specify a process color as either global or 
nonglobal, and InDesign treats all process colors as unnamed process colors. Unnamed 
process colors are nonglobal.

The InDesign equivalents to global process colors are swatches. Swatches make it easier to 
modify color schemes without having to locate and adjust each individual object. This is 
especially useful in standardized, production-driven documents like magazines. Because 
InDesign colors are linked to swatches in the Swatches palette, any change to a swatch 
affects all objects to which a color is applied.

The InDesign equivalents to nonglobal swatches are unnamed process colors. Unnamed 
colors do not appear in the Swatches palette, and they do not automatically update 
throughout the document when the color is edited. However, you can add an unnamed 
color to the Swatches palette, which then becomes a default color within the document.

Named and unnamed process colors only affect how a particular color is applied to 
objects, never how colors separate or behave when you move them between applications.

Working with swatches and unnamed colors
Use the Swatches palette menu to create and store spot colors as named swatches, so that 
you and your prepress service provider can uniquely identify each resulting spot color 
printing plate. In comparison, printing any process color requires no more than four inks, 
so you can use process colors either as swatches or as unnamed colors.

Swatches A swatch appears in the Swatches palette with a name you specify, making a 
color, gradient, or tint easy to locate and edit.

Unnamed colors You can create colors faster when you don’t have to name them. 
However, unnamed colors are more difficult to edit later, because they do not appear on 
the Swatches palette. Use the Add Unnamed Colors options to search for unnamed colors 
applied to objects within the document, and then add them to the Swatches palette. Colors 
are automatically named according to their CMYK, RGB, or LAB components.
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Applying color
InDesign provides a number of tools for applying color, including the toolbox, the 
Swatches palette, and the Color palette.

To switch between fill and stroke as the active selection, press the X key on the 
keyboard (when a text insertion point is not present). To switch between the fill and 

stroke colors of a selected object, press Shift+X. This tip does not apply to selected text 
characters.

A. Fill box B. Default fill and stroke C. Formatting affects container D. Swap fill and stroke  
E. Stroke box F. Formatting affects text G. Color H. Gradient I. None

To apply color:

1 Select the object you want to color by doing one of the following:

• For a path or frame, use the selection tool  or direct-selection tool , as necessary.

• For a grayscale or monochrome image, use the direct-selection tool . You can only 
apply two colors to a grayscale or monochrome image.

• For text characters, use the type tool  to change the text color of a single word or the 
entire text within a frame.

2 In the toolbox or Swatches palette, select the Fill box or the Stroke box to specify the fill 
or stroke of the object. (If you selected an image, the Stroke box has no effect.)

3 Select a color, tint, or gradient using the Swatches palette, toolbox color controls, or 
the Color or Gradient palettes. For more information about these color palettes and 
controls, see the Index.

Note: You cannot apply color or a gradient to an imported grayscale, color, or bitmap 
image.

Using the toolbox color controls
If you want to apply the last-used color or gradient, you can apply color using the toolbox 
alone. 

To apply color to selected objects using the toolbox:

Do one of the following:

• Click the Color button  to apply the last selected solid color in the Swatches or 
Color palette.

• Click the Gradient button  to apply the last-selected gradient in the Swatches or 
Gradient palette.
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• Click the None button  to remove the object’s fill or stroke.

To switch among Color, Gradient, or None in the toolbox, use these shortcuts: Press (,) 
to change the selection to a solid color; (.) to change the selection to a gradient; 

and (/) to change to None. This tip does not apply to selected text.

Using the Swatches palette
You can control all document colors and gradients in the Swatches palette alone. Use it to 
create, name, and store colors and gradients for instant access. When the fill or stroke of 
selected text or an object contains a color or gradient applied from the Swatches palette, 
the applied swatch is highlighted in the Swatches palette.

Six CMYK-defined colors appear in the default Swatches palette: cyan, magenta, yellow, 
red, green, and blue.

To change the swatches that appear by default in new documents, edit the Swatches 
palette when no documents are open.

A. Fill/stroke B. Text/object control C. Tint control  D. Color name E. Color swatch  
F. Gradient swatch G. None H. CMYK color I. Registration color J. Spot color K. Process color  
L. Color tint M. RGB color N. LAB color O. Show All Swatches button P. Show Color Swatches 
button Q. Show Gradient Swatches button R. New Swatch button S. Trash button

About swatch types
The Swatches palette stores the following types of swatches: 

Colors Icons on the Swatches palette identify the spot  and process  color types, and 
LAB , RGB , and CMYK  color modes.

Tints A percentage value next to a swatch in the Swatches palette indicates a tint of a 
spot or process color. (See “About tints” on page 311.)

Gradients An icon on the Swatches palette indicates whether a gradient is radial  or 
linear .

None The None swatch removes the stroke or fill from an object. You can’t edit or remove 
this swatch.
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Paper Paper is a built-in swatch that simulates the paper color on which you’re printing. 
Objects behind a paper-colored object won’t print where the paper-colored object 
overlaps them. Instead, the color of the paper on which you print shows through. You can 
edit the Paper color to match your paper stock by double-clicking it in the Swatches 
palette. Use the Paper color for previewing only—it will not be printed on a composite 
printer or in color separations. You can’t remove this swatch. Do not apply the Paper 
swatch to remove color from an object. Use the None swatch instead.

Note: If the Paper color is not working as described, and you are printing to a PCL printer, 
try switching your printer driver to Raster Graphics mode.

Black Black is a built-in, 100% process color black defined using the CMYK color model. 
You can’t edit or remove this swatch. By default, all occurrences of Black overprint (print on 
top of ) underlying inks, including text characters at any size. You can disable this behavior; 
see “Overprinting black” on page 418.

Registration Registration  is a built-in swatch that causes objects to print on every 
separation from a PostScript printer. For example, registration marks use the Registration 
color, so that printing plates can be aligned precisely on a press. You cannot edit or 
remove this swatch.

You can also add any colors from any swatch library to the Swatches palette so that they 
are saved with your document. (See “Using swatch libraries” on page 308.)

Working with the Swatches palette
Use the Swatches palette to create and name any color or tint, or to edit any named color. 
New colors or gradients that you create and store in the Swatches palette are associated 
only with the current document. Each document can have a different set of swatches 
stored in its Swatches palette. For information about creating tints, see “About tints” on 
page 311.

To display the Swatches palette:

Choose Window > Swatches.

To apply a color or gradient to selected text or objects using the Swatches palette:

1 Using the selection tool, select a text or object frame.

2 In the Swatches palette, select the Fill box or the Stroke box.

3 Do one of the following:

• To apply color to selected text, click the Text button .

• To apply color to a selected object or text container (such as a frame or a table), click the 
Object button .

4 Click a color or gradient swatch. The selected color or gradient is applied to any 
selected text or object, and it appears in the Color palette and in the Fill box or Stroke box 
in the toolbox.

You can set the default fill or stroke colors the same way you set other InDesign 
defaults. Choose Edit > Deselect All to make sure that no objects are selected, and then 

choose a color.
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To modify the type of swatches displayed:

In the Swatches palette, click one of the following buttons at the bottom of the 
Swatches palette:

• Show All Swatches  displays all color, tint, and gradient swatches.

• Show Color Swatches  displays only process color, spot color, and tint swatches.

• Show Gradient Swatches  displays only gradient swatches.

Note: The None swatch is always displayed regardless of which button you click.

To select all swatches not used in the document:

Choose Select All Unused in the Swatches palette menu. Only swatches that are not 
currently used in the active file will be selected.

Adding, duplicating, and deleting swatches
You can add color swatches to the Swatches palette by using the palette’s menu and 
buttons, or by using the Color palette. To add gradients to the Swatches palette, see 
“Creating gradients” on page 313.

You can also duplicate swatches; this can be useful when you want to create a warmer or 
cooler variation of an existing color. Note that duplicating a spot color will result in an 
additional spot color printing plate.

To add a new color swatch to the Swatches palette:

1 If you want to base your new swatch on the fill or stroke color of an existing object, 
select the object. In the Swatches palette, select the Fill box or the Stroke box.

2 Do one of the following:

• Choose New Color Swatch in the Swatches palette menu.

• Choose Add to Swatches in the Color palette menu.

3 For Color Type, choose the method you’ll use to print document colors on a 
printing press.

4 For Swatch Name, do one of the following:

• If you chose Process as the color type and you want the name always to describe the 
color values, make sure that Name With Color Value is selected.

• If you chose Process as the color type and you want to name the color yourself, make 
sure that Name With Color Value is deselected, and type a Swatch Name.

• If you chose Spot, type a Swatch Name.

5 For Color Mode, choose the mode you want to use in defining the color. Avoid 
changing the mode after you define a color.

6 Do one of the following:

• Drag the sliders to change the color values. You can also enter numeric values in the 
text boxes next to the color sliders.

• For spot colors, choose from the Color Mode swatch libraries.

7 If an out-of-gamut alert icon  appears, and you want to use the CMYK color values 
closest to the color you originally specified, click the small color box next to the alert icon.
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8 Click OK. The selected color or gradient appears in the Swatches palette and in the Fill 
box or Stroke box in the toolbox, and is applied to the fill or stroke of all selected objects.

To directly define a spot color using the New Color button in the Swatches palette, 
hold down Alt (Windows) or Command (Mac OS) as you click the New Color button.

To create a new swatch based on the fill or stroke color of an existing object

1 Select the object. In the toolbox or Swatches palette, select the Fill box or the 
Stroke box.

2 In the Swatches palette, do one of the following:

• Click the New Swatch button  and double-click the resulting new swatch.

• Choose New Color Swatch in the Swatches palette menu.

To add unnamed colors to the Swatches palette:

In the Swatches palette, choose Add Unnamed Colors. 

To duplicate a swatch in the Swatches palette:

Do one of the following:

• Select a swatch, and choose Duplicate Swatch in the Swatches palette menu.

• Select a swatch, and click the New Swatch button at the bottom of the palette.

• Drag a swatch to the New Swatch button on the bottom of the palette.

To delete a swatch from the Swatches palette:

1 Select one or more swatches.

2 Do one of the following:

• Choose Delete Swatch in the Swatches palette menu.

• Click the Trash button  at the bottom of the Swatches palette.

• Drag the selected swatches to the Trash button.

3 InDesign asks you how to replace the swatch you’re deleting. Do one of the following, 
and click OK:

• To replace all instances of the swatch with another swatch, click Defined Swatch, and 
choose a swatch in the menu.

• To replace all instances of the swatch with an equivalent unnamed color, click Unnamed 
Swatch.

To delete all unused swatches from a document:

Choose Select All Unused in the Swatches palette menu, and click the Trash button .

To delete swatches imported with an EPS file:

1 Delete the EPS file. If no references to the file are found, the swatches will be deleted 
automatically. If the swatches are not deleted, proceed to step 2.

2 Choose Select All Unused in the Swatches palette menu.

3 Press Ctrl (Windows) or Command (Mac OS), and click to deselect any swatches you 
want to keep, such as those created within your document.

4 Click the Trash button .
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Editing swatches
You can change individual attributes of a swatch by using the Swatch Options dialog box.

To edit a swatch:

1 In the Swatches palette, select a swatch, and do one of the following:

• Double-click the swatch. 

• Choose Swatch Options in the Swatches palette menu.

2 Adjust settings as desired, and click OK.

Naming process colors after their values
By default, the name of a process color swatch is derived from the values of the color’s 
components. For example, if you create a red process color using 10 percent cyan, 75 
percent magenta, 100 percent yellow, and 0 percent black, its swatch will be named C=10 
M=75 Y=100 K=0 by default. This makes it easier to identify the composition of process 
colors.

By default, the name of a process color swatch automatically updates when you change 
its CMYK values; you can switch this option off or on for individual swatches as needed. 
As with any swatch you define, you can change the name of a process color swatch at 
any time.

To switch automatic process swatch naming on or off:

1 Double-click a process color in the Swatches palette.

2 Do one of the following, and click OK:

• To let InDesign rename the swatch when you adjust its CMYK percentages, make sure 
that the Name with Color Value option is selected.

• To rename a swatch when you adjust its CMYK values, make sure that the Name with 
Color Value option is deselected.

Note: The new swatch is automatically renamed New Color Swatch (this has a number 
following it if more than one New Color Swatch exists) when this option is deselected. 
You can change this name manually. (See “Editing swatches” on page 307.)

Changing the swatch size
You can change the size of the swatches in the Swatches palette. Making the swatches 
smaller saves space on your monitor.

To modify the swatch display:

In the Swatches palette, choose one of the following display options in the palette menu:

• Name displays a small swatch next to the name of the swatch. The icons to the right of 
the name show the color model (CMYK, RGB, and so on), and whether the color is a spot 
color, process color, registration color, or none.

• Small Name displays compacted swatch palette rows.

• Small Swatch or Large Swatch displays only the swatch. A triangle with a dot in the 
corner of the swatch indicates that the color is a spot color. A triangle without a dot 
indicates a process color.
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Synchronizing conflicting swatches in a book
When you print a book whose chapters contain conflicting swatches, you can instruct 
InDesign to synchronize settings with the master document. (See “Synchronizing 
documents in a book file” on page 169 for more information.)

Using swatch libraries
You can use colors and gradients from other Adobe InDesign or Adobe Illustrator files. You 
can also import entire color libraries from other color systems, such as the PANTONE 
Process Color System®. 

Loading colors from other color systems
You can select from a range of color libraries—including the PANTONE Process Color 
System, Toyo™ Ink Electronic Color Finder ™ 1050, the Focoltone® color system, the 
Trumatch™ color swatch system, the DIC Process Color Note, and libraries created 
especially for Web use. Each color system that you select appears in its own Swatch Library 
palette. Before using a swatch library, consult with your prepress service providers to 
determine which ones they support.

To load predefined custom color libraries into InDesign:

1 Choose New Color Swatch, in the Swatches palette menu.

2 Do one of the following:

• Choose the library file, from the Color Mode list.

• Choose Other Library, from the Color Mode list, and then click Open (Windows) or 
Choose (Mac OS).

DIC Color Provides 1280 CMYK spot colors from the DIC Process Color Note. Colors may 
be matched against the DIC Color Guide, published by Dainippon Ink & Chemicals, Inc. For 
more information, contact Dainippon Ink & Chemicals, Inc., in Tokyo, Japan. 

Focoltone Consists of 763 CMYK colors. You can use Focoltone colors to help avoid 
prepress trapping and registration problems by viewing the Focoltone charts that show 
the overprints that make up the colors. 

A swatch book with specifications for process and spot colors, overprint charts, and a chip 
book for marking up layouts are available from Focoltone. For more information, contact 
Focoltone International, Ltd., in Stafford, United Kingdom.

HKS Use when your job specifies colors from the HKS color system, which is used 
in Europe.

PANTONE Used for printing inks. Each PANTONE color has a specified CMYK equivalent. 
To select a PANTONE color, first determine the ink color you want, using either the 
PANTONE Color Formula Guide 747XR or an ink chart obtained from your printer. PANTONE 
books are available from printers and graphic arts supply stores.

You can select from PANTONE Coated (spot colors), PANTONE Uncoated (spot colors), 
PANTONE Matte, and PANTONE Process colors. For more information, contact Pantone, 
Inc., in Carlstadt, New Jersey, U.S.A.

System (Windows) Includes 256 colors of the Windows default 8-bit palette, which is 
based on a uniform sampling of RGB colors.
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System (Mac OS) Includes 256 colors of the Mac OS default 8-bit palette, which is based 
on a uniform sampling of RGB colors.

Toyo Color Finder 1050 Consists of more than 1,000 colors based on the most common 
printing inks used in Japan. The TOYO Color Finder 1050 Book contains printed samples of 
Toyo colors and is available from printers and graphic arts supply stores. For more infor-
mation, contact Toyo Ink Manufacturing Co., Ltd., in Tokyo, Japan.

Trumatch Provides predictable CMYK color matching with over 2000 achievable, 
computer-generated colors. Trumatch colors cover the visible spectrum of the CMYK 
gamut in even steps. The Trumatch Color Finder displays up to 40 tints and shades of each 
hue, each originally created in four-color process and each reproducible in four colors on 
electronic imagesetters. In addition, four-color grays using different hues are included. For 
more information, contact Trumatch Inc., in New York, New York, U.S.A.

Web Includes the 216 RGB Web-safe colors most often used by Web browsers to display 
8-bit images. This library helps you create artwork for the Web using colors that display 
consistently across Windows and Macintosh systems.

Loading colors from other files
You can import colors and gradients from other documents. When you do so, all of the 
source file’s spot and process colors and gradients are added to a new palette. You can 
load colors from the following:

• Adobe InDesign documents (Windows filename extension: .indd)

• Adobe InDesign templates (.indt)

• Adobe Illustrator 8.x EPS documents (.eps)

To import colors, tints, and gradients from other files:

1 Choose New Color Swatch, in the Swatches palette menu.

2 Choose Other Library, from the Color Mode list, and then select the file from which you 
want to import swatches.

3 Click Open (Windows) or Choose (Mac OS).

You can also drag swatches from an InDesign document’s Swatches palette to the 
document window of another InDesign document. This adds the swatch to the 

second document’s Swatches palette.

Saving swatch library colors with your document
Swatch libraries are open only during the current session. If you want to use swatch colors 
in future sessions, copy them to your Swatches palette, using the New Color Swatch 
command.

You can’t edit the colors stored in a swatch library. To edit a color from a swatch library, 
copy it to the Swatches palette and then edit it there. (See “Editing swatches” on 
page 307.)



Using Help | Contents | Index Back 310  

Adobe InDesign Help Applying Color 

Using Help | Contents | Index Back 310  

Using the Color palette
Although the Swatches palette is the recommended palette for working with colors, you 
can also mix colors by using the Color palette; you may be familiar with it if you use other 
Adobe products, such as Adobe Illustrator. You can add the current Color palette color to 
the Swatches palette at any time. The Color palette is most useful for mixing unnamed 
colors; see “Adding, duplicating, and deleting swatches” on page 305.

Note: If you select an object that currently uses a named swatch, editing its color using the 
Color palette will change the color of that object only. If you want to edit the color throughout 
the document, double-click its swatch in the Swatches palette.

A. Fill box B. Stroke box C. Formatting affects container or text  
D. Last-used color E. Color spectrum F. Color value slider

To display the Color palette:

Do one of the following:

• Choose Window > Color.

• Double-click the fill-and-stroke proxy in the toolbox.

To edit the fill or stroke color of selected text or objects using the Color palette: 

1 Select the Fill box or the Stroke box in the Color palette.

2 Do one of the following:

• Adjust the Tint slider, which appears by default if the object uses a swatch from the 
Swatches palette. (See “About tints” on page 311.)

• Choose a LAB, CMYK, or RGB color model in the Color palette menu, and use the sliders 
to change the color values. You can also enter numeric values in the text boxes next to 
the color sliders.

• Position the pointer over the color bar, and click.

3 If an out-of-gamut alert icon  appears, and you want to use the CMYK color values 
closest to the color you originally specified, click the small color box next to the alert icon.

To create a swatch from a color in the Color palette:

1 In the Color palette, make sure that the active Fill or Stroke box displays the color you 
want to add.

2 Choose Add to Swatches in the palette menu.

To cycle through color modes using a shortcut: 

Do one of the following:

A
B

E F

C

D
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• In the Color palette, Shift-click the color bar at the bottom of the palette.

• In the New Color Swatch or Swatch Options dialog box, Shift-click the color box.

• In the New Gradient or Gradient Options dialog box, select a gradient stop, make sure 
that RGB, LAB, or CMYK is selected in the Stop Color menu, and then Shift-click the 
color box.

Applying colors by dragging and dropping
An easy way to apply colors or gradients is to drag them from a color source to an object 
or palette. Dragging and dropping lets you apply colors or gradients to objects without 
first selecting the objects. You can drag the following:

• The fill or stroke boxes in the toolbox or a palette.

• The gradient box in the Gradient palette.

• Swatches from the Swatches palette.

• The last-used color swatch located next to the out-of-gamut icon  in a palette.

You can drop colors or gradients on the following objects and palettes:

• The fill or stroke of a path. To drop color on a fill or stroke, position the center of the drag 
icon precisely over the path’s fill or stroke while you drag a color, and then release the 
mouse button.

• The Swatches palette.

If you drag one or more Swatches palette swatches, or the color swatch next to an out-of-
gamut icon, you can drop them into another InDesign document window, which adds the 
swatches to that document’s Swatches palette.

About tints
A tint is a screened (lighter) version of a color. Tinting is an economical way to make 
additional spot color variations without having to pay for additional spot color inks. Tinting 
is also a quick way to create lighter versions of process colors, although it doesn’t reduce 
the cost of printing process colors. As with non-tinted colors, it’s best to name and store 
tints in the Swatches palette so that you can easily edit all instances of that tint in 
your document.

Spot color and tints
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A tint of a spot color is printed on the same printing plate as the spot color. A tint of a 
process color multiplies each of the CMYK process inks by the tint percentage; for 
example, an 80% tint of C10 M20 Y40 K10 results in C8 M16 Y32 K8.

When you select a swatch in the Swatches palette, the Color palette automatically 
switches to a tint display so that you can create a tint immediately.

Creating and updating tints and their base swatches
You can adjust the tint of an individual object, or create tints by using the Tint slider in the 
Swatches palette or Color palette. The tint range is from 0% to 100%; the lower the 
number, the lighter the tint will be.

Because colors and tints update together, if you edit a swatch, all objects that use a tint of 
that swatch or unnamed color update accordingly. You can also edit the base swatch of a 
named tint using the Swatch Options command in the Swatches palette menu; this 
updates any other tints based on the same swatch.

To create a tint swatch using the Swatches palette:

1 In the Swatches palette, select a color swatch.

2 Select the arrow next to the Tint box.

3 Drag the Tint slider, and click the New Swatch button  or select New Color Swatch in 
the Swatches palette menu. The tint appears in the Swatches palette with the name of its 
base color and the percentage of the tint.

To create a tint swatch using the Color palette:

1 In the Swatches palette, select a swatch.

2 In the Color palette, drag the Tint slider, or enter a tint value in the Percentage box.

3 In the Swatches palette, click the New Swatch button, or select New Color Swatch in the 
Swatches palette menu. 

To create and apply an unnamed tint to selected objects:

1 In the Swatches palette, select the Fill box or the Stroke box.

2 Drag the Tint slider, or enter a tint value in the percentage box.

To edit a tint swatch or its base color swatch:

1 In the Swatches palette, double-click the tint swatch.

2 Do one of the following, and click OK:

• To edit the tint, change the Tint value. This updates all objects using that tint swatch.

• To edit the tint’s base color swatch, change the Color Mode or the Color Mode values. 
This also updates all other tints based on that same color swatch.
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Working with gradients
A gradient is a graduated blend between two or more colors or tints of the same color. 
The output device you use affects how gradients color-separate. (See “Printing gradients, 
color blends, and transparencies” on page 401.)

Note: When you create a gradient using colors of different modes and then print or color-
separate the gradient, all colors are converted to CMYK process colors. Because of the color 
mode change, colors may shift. For best results, specify gradients using CMYK colors. 

About gradients
Gradients can include process colors or spot colors using any color mode. Gradients are 
defined by a series of color stops in the gradient bar. A stop is the point at which a gradient 
changes from one color to the next, and is identified by a color square under the gradient 
bar. By default, a gradient starts with two colors and a midpoint at 50%.

A. Gradient fill B. Gradient type drop down C. Reverse button  
D. Starting color stop E. Midpoint F. Ending color stop

Creating gradients
You can create, name, and edit gradients using the same Swatches palette you use to work 
with solid colors and tints.

To create a gradient swatch:

1 Choose New Gradient Swatch in the Swatches palette menu.

2 For Swatch Name, type a name for the gradient.

3 For Type, choose Linear or Radial.

4 Select the first color stop in the gradient.

5 For Stop Color, do one of the following:

• To choose a color that’s already in the Swatches palette, choose Named Color, and 
select a color from the list.

• To mix a new unnamed color for the gradient, choose a color mode, and enter color 
values or drag the sliders.

6 To change the last color in the gradient, select the last color stop, and repeat step 5.

7 To adjust the position of gradient colors, do one of the following:

• Drag the color stops located under the bar.

• Select a color stop under the bar, and enter a Location value to set the position of that 
color. This position represents the percentage of distance between the previous color 
and the next color.

A
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8 To adjust the midpoint between two gradient colors (the point at which the colors are 
at 50%), do one of the following:

• Drag the diamond icon located above the bar. 

• Select the diamond icon above the bar, and enter a Location value to set the position of 
that color. This position represents the percentage of distance between the previous 
color and the next color.

9 Click OK. The gradient is stored in the Swatches palette with its name.

Using the Gradient palette
Although the Swatches palette is the recommended palette for creating and storing 
gradients, you can also work with gradients by using the Gradient palette, with which you 
may be familiar if you also use Adobe Illustrator. You can add the current gradient to the 
Swatches palette at any time. The Gradient palette is useful for creating an unnamed 
gradient that won’t be used often.

Note: If you select an object that currently uses a named gradient, editing the gradient by 
using the Gradient palette will change the color of that object only. To edit every instance of a 
named gradient, double-click its swatch in the Swatches palette.

To display the Gradient palette:

Choose Window > Gradient, or double-click the Gradient tool  in the toolbox.

To create an unnamed gradient for selected text or objects:

1 Click the Fill or Stroke box in the Swatches palette or the toolbox. (If the Gradient Fill 
box is not visible, choose Show Options in the Gradient palette menu.)

2 To define the starting color of a gradient, click the leftmost color stop below the 
gradient bar, and then do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) a color swatch in the Swatches palette.

• In the Color palette, create a color using the sliders or the color bar.

3 To define the ending color of the gradient, click the rightmost color stop below the 
gradient bar. Then choose the color you like, as described in the previous step.

4 Select either Linear or Radial in the Type menu, and adjust color and midpoint positions 
as explained in “Creating gradients” on page 313.

Note: When you change the gradient type, it will reset the gradient’s starting and ending 
points to its original default for the currently selected object.

5 To adjust the gradient angle, type a value for Angle.

Modifying gradients
You can modify gradients by adding colors to create multicolor gradients, and by 
adjusting color stops and midpoints. It’s a good idea to fill an object with the gradient 
you plan to adjust, so that you can preview the effect on the object while you adjust 
the gradient.

Note: If you edit a color swatch, any gradient stops that use that swatch will update 
accordingly, changing the gradient.
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To add intermediate colors to a gradient:

1 Double-click a gradient swatch in the Swatches palette, or display the Gradient palette.

2 Click anywhere below the gradient bar to define a new color stop. The new color stop is 
automatically defined by the color values at that position along the existing gradient.

3 Adjust the new color stop.

To remove an intermediate color from a gradient:

Select the intermediate color stop, and drag it to the edge of the palette.

To reverse a gradient’s color progression:

1 Activate a gradient.

2 In the Gradient palette, click the Reverse button .

Adjusting gradients with the gradient tool
Once you have filled an object with a gradient, you can modify the gradient by using the 
gradient tool  to “repaint” the fill by dragging along an imaginary line. This tool lets you 
change the direction of a gradient, its beginning point and endpoint, and apply a gradient 
across multiple objects.

To use the gradient tool on selected text, or objects with an existing gradient:

1 In the Swatches palette or toolbox, select the Fill box or the Stroke box, depending on 
where the original gradient was applied.

2 Select the gradient tool, and position it at the place where you want to define the 
beginning point of the gradient. Drag across the object in the direction you want the 
gradient to be applied. Hold down Shift to constrain the tool to multiples of 45 degrees.

3 Release the mouse button at the place where you want to define the endpoint of the 
gradient.

Drag to set direction and length of gradient

To apply a gradient across multiple selected objects:

1 Make sure that all selected objects already use a gradient.

2 In the toolbox, select the Fill box or the Stroke box.

3 Select the gradient tool, and position it where you want to define the beginning point 
of the gradient. Drag across the object in the direction you want the gradient to be 
applied. Hold down Shift to constrain the tool to multiples of 45 degrees.
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4 Release the mouse button at the place where you want to define the endpoint of 
the gradient.

Default gradient fill, and gradient applied across objects

If a compound path with a gradient is selected, you can edit the gradient across 
all of its subpaths by using the Gradient palette alone, without having to use the 

gradient tool.

About applying gradients to text
Within a single text frame, you can create multiple ranges of gradient text alongside 
default black text and color text.

About adjusting text gradients
A gradient’s endpoints are always anchored in relation to the bounding box of the 
gradient’s path or text frame. Individual text characters display the part of the gradient 
over which they are positioned. If you resize the text frame or make other changes that 
cause text characters to reflow, the characters are redistributed across the gradient, and 
the colors of individual characters change accordingly.

A. Underlying gradient fill B. Text characters with gradient applied  
C. Text added, and text shifting position relative to gradient fill

If you want to adjust a gradient so that its complete color range spans a specific range of 
text characters, you have two options:

• Use the gradient tool to reset the gradient’s endpoints, so that they span only the 
characters you selected when you applied the gradient.

• Select the text and convert it to outlines (editable paths), and then apply a gradient to 
the resulting outlines. This is the best option for a short run of display type in its own 
text frame. The gradient will be permanently anchored to the outlines, not the text 
frame, and the outlines will continue to flow with the rest of the text. However, the 
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outlines will function as a single inline graphic within the text frame, so you won’t be 
able to edit the text. Also, typographic options will no longer apply; for example, text 
converted to outlines will not hyphenate. (See “Creating paths from text outlines” on 
page 216.)

By default, type that shifts position will change relative to its gradient (left); 
when type is converted to outlines, an applied gradient moves with the type (right)

Using multiple gradients in a single text frame
Within a single text frame, you can select different ranges of text and apply a unique 
gradient to each range. Each gradient is added to the text frame and tracked separately 
with the characters you selected when you applied each gradient. However, the endpoints 
of the gradient are still anchored to the text frame’s bounding box, not to individual 
ranges of text.

Using the Ink Manager
The Ink Manager provides nonbinding control over inks at output time. Changes you 
make using the Ink Manager affect only the output, not how the colors are defined in 
the document. 

Ink Manager options are especially useful for prepress service providers. For example, if a 
process job includes a spot color, a service provider can open the document and change 
the spot color to equivalent CMYK process colors. If a document contains two similar spot 
colors when only one is required, a service provider can create an alias to a different ink. 
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In a trapping workflow, the Ink Manager lets you set the ink density for controlling when 
trapping takes place, and the correct number and sequence of inks. For information on 
using the trapping options, see “Adjusting ink neutral density values” on page 330 and 
“Specifying trapping sequence” on page 331.

A. Click the icon to change the ink type from process, 
to spot, to alias B. Aliased spot ink C. Spot ink

To display the Ink Manager:

Click the Ink Manager button from one of the following locations:

• Swatches palette menu.

• Output panel of the Print dialog box.

• Advanced panel of the Export PDF or Export EPS dialog box.

To convert all spot colors to process:

In the Ink Manager, click All to Process. The icon to the left of the color on the ink list 
changes to CMYK color mode, and the spot colors disappear from the Ink List.

To restore your spot colors, deselect All to Process.

Note: The process color equivalents may not exactly match the original spot colors. 
Selecting this option removes any ink aliases you have set up in the Ink Manager, and can 
also affect overprinting and trapping settings in your document.

To convert individual spot colors to process:

In the Ink Manager, click the ink type icon to the left of the spot color or aliased spot color. 
A four-color process icon appears.

Creating an alias for a spot color
If a document contains too many spot colors (for example, more than your service 
provider can print), you can print a spot color as a different ink. You can see the effects of 
ink aliasing in the printed output, and on-screen if Overprint Preview mode is on. You can 
create aliases to spot colors only. 

To create an ink alias:

1 Click Ink Manager in the Output panel of the Print dialog box, or choose Ink Manager in 
the Swatches palette menu.

B
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2 In the Ink Manager, select the spot color ink for which you want an alias.

3 Choose an option in the Ink Alias menu. The ink type icon and ink description change 
accordingly.

Copying attributes between objects 
Use the eyedropper tool to copy fill and stroke attributes, such as color, from any object in 
an InDesign file, including an imported graphic. By default, the eyedropper tool loads all 
available fill and stroke attributes of an object and sets the default fill and stroke attributes 
of any new objects you draw. You can use the Eyedropper Options dialog box to change 
the attributes the eyedropper tool copies. You can also use the eyedropper tool to copy 
type and transparency attributes; see “Copying type attributes with the eyedropper tool” 
on page 139 and “About transparency” on page 287.

Note: If an attribute is not listed in the Eyedropper Options dialog box, it can’t be copied 
with the eyedropper tool. The only exception is the corner effect for strokes, which is copied 
even though it isn’t listed in the Eyedropper Options dialog box.

To copy fill and stroke attributes using the 
eyedropper tool:

1 Select one or more objects that have the fill and stroke attributes you want to change.

2 Select the eyedropper tool .

3 Click any object that has the fill and stroke attributes you want to sample. A loaded 
eyedropper appears , and the selected objects are automatically updated with the fill 
and stroke attributes of the object you clicked.

4 To change other objects to the same attributes, click the objects with the loaded 
eyedropper. If an object is stroked and not filled, be sure to click the object’s outline.

To pick up new attributes when the eyedropper tool is loaded:

1 Press Alt (Windows) or Option (Mac OS) while the eyedropper tool is loaded. The 
eyedropper tool reverses direction, and appears empty , to indicate that it’s ready to 
pick up new attributes.

2 Without releasing the Alt or Option key, click an object containing the attributes that 
you want to copy, and then release the Alt or Option key so that you can drop the new 
attributes on another object.

To change the fill and stroke attributes affected by the eyedropper tool:

1 In the toolbox, double-click the eyedropper tool.

2 Choose Fill and Stroke Settings in the menu at the top of the Eyedropper Options 
dialog box.

3 Select the fill and stroke attributes you want to copy with the eyedropper tool, and then 
click OK.

To copy or apply only the fill and stroke color of an object, hold down Shift as you click 
an object with the eyedropper tool.
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Adding colors from other documents
When you copy or drag a swatch (or objects with a swatch applied) from one document to 
another, the swatch, including its tints and gradients, is added to the destination 
document’s Swatches palette.

To copy color or gradient swatches from one document to another:

Copy an object into the current document using drag-and-drop or copy-and-paste. You 
can also use the Other Library option in the Swatches palette menu to add new swatch 
palettes. (See “Using swatch libraries” on page 308.)

Note: If you drag a swatch that has the same name as a swatch that already exists in the 
destination document but has different color values, the swatch will be renamed “[original 
swatch name] 2.”

Using colors from imported graphics 

InDesign provides various ways for you to sample and redefine colors from the graphics 
you import into your document.

Using the eyedropper tool to sample colors from imported 
graphics
You can use the eyedropper tool to add colors from imported graphics to your document, 
or to apply them to objects in your document. This is useful for coordinating layout colors 
with images. For more information about the eyedropper tool, see “Copying attributes 
between objects” on page 319.

For best results with color separations, you may want to make sure that color names, types 
(such as spot and process), and models (such as RGB and CMYK) of the colors sampled in 
InDesign are consistent with the color definitions in the imported graphics. If you’re not 
sure about the best settings to use, consult with your prepress service provider.

Working with colors from EPS graphics
When you place an EPS graphic or an Adobe Illustrator 5.0–8.0 format file, names of spot 
colors used in the graphic are added to the Swatches palette in your document. Spot 
colors from EPS or Illustrator graphics are added to the Swatches palette so that you can 
be aware that they can cause additional printing costs later, and also so that you can use 
the spot colors in your document.

If you import an EPS file with a spot color name that is defined using the same name as a 
spot color in your document, but with different color values, you will be asked whether you 
want to use the color values in the EPS file or the ones in the document.
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Redefining imported spot colors as process colors
When you import an EPS or PDF graphic containing a spot color, InDesign adds the spot 
color name and definition to the Swatches palette. You can change an imported spot color 
swatch to a process color swatch. This provides flexibility for adapting colors—even those 
in imported graphics—to your current output requirements.

To change an imported spot color to a process color:

1 In the Swatches palette, double-click the swatch you want to edit.

2 In the Swatch Options dialog box, choose Process in the Color Type menu.

Note: This changes the color type in the InDesign document only. To permanently change 
the color type of colors within a graphic, open the graphic in the program in which it was 
created, and then edit the color in that program.
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Trapping Color

Compensating for ink misregistration by trapping
When a commercially printed document uses more than one ink on the same page, each 
ink must be printed in register (perfectly aligned) with any other inks that it abuts, so that 
there is no gap where the different inks meet. However, it’s impossible to ensure exact 
registration for every object on every sheet of paper running through a printing press, so 
misregistration of inks can occur. Misregistration causes an unintended gap between inks.

You can compensate for misregistration by slightly expanding one object so that it 
overlaps an object of a different color—in a process known as trapping. By default, placing 
one ink over another knocks out, or removes, any inks underneath to prevent unwanted 
color mixing; but trapping requires that inks overprint, or print on top of each other, so that 
at least a partial overlap is achieved.

Misregistration with no trap (left) and with trap (right)

Most traps employ spreading—expanding a light object into a dark object. Because the 
darker of two adjacent colors defines the visible edge of the object or text, expanding the 
lighter color slightly into the darker color maintains the visual edge.

Trapping solutions
You can trap a document using any combination of methods, including the following:

• Use process colors that don’t need trapping. (See “Using process colors that don’t need 
trapping” on page 417.)

• Overprint black. (See “Overprinting black” on page 418.)

• Manually overprint strokes or fills. (See “Manually overprinting strokes or fills” on 
page 419.)

• Use InDesign built-in trapping or Adobe In-RIP Trapping.

• Trap imported graphics, using the trapping features in the illustration or image-editing 
programs in which they were created. Refer to the documentation for these 
applications.
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Keep in mind that the trapping solution you choose must work well with the color output 
workflow you’re using, such as PostScript or PDF. (See “Two common print workflows” on 
page 414.)

Automatic trapping 

InDesign can automatically trap color documents with its built-in trapping engine, and 
can also take advantage of the similar but more powerful Adobe In-RIP Trapping engine 
available on Adobe PostScript output devices that support Adobe In-RIP Trapping.

Both trapping engines can precisely calculate and apply any necessary adjustments to the 
edges of both type and graphics throughout your document. They can apply effective 
trapping techniques to different parts of a single object, even if text or an InDesign object 
overlaps several different background colors. Trapping adjustments are made automati-
cally, and you can define trap styles to address the trapping requirements of specific 
page ranges. The effects of trapping are apparent only on color separations generated by 
a trapping engine; you cannot see the results on-screen within InDesign.

The trapping engine decides where to trap by detecting contrasting color edges, and then 
creates traps based on the neutral densities (lightness or darkness) of abutting colors, in 
most cases by spreading lighter colors into adjacent darker colors. The trapping settings 
you specify in the Trap Styles palette modify the trapping engine’s results.

Comparing Adobe In-RIP Trapping and built-in trapping
While built-in trapping and Adobe In-RIP Trapping are quite similar, they can produce 
significantly different output from the same document. For best results, read the following 
sections and learn about the differences between the two trapping engines.

Requirements for trapping
To trap documents using either the InDesign built-in engine or the Adobe In-RIP Trapping 
engine, you need the following software and hardware:

• A PPD (PostScript Printer Description) file for a printer that supports Adobe In-RIP 
Trapping. You must select this PPD by using the operating system driver. (See “Setting 
up a PPD” on page 386.)

• An Adobe PostScript Level 2 or later output device that uses a RIP that supports Adobe 
In-RIP Trapping. To find out if a PostScript output device supports Adobe In-RIP 
Trapping, contact the manufacturer or your prepress service provider.

General differences between built-in and Adobe In-RIP Trapping
The following are some of the features that differ between built-in trapping and Adobe In-
RIP Trapping:

• Composite color workflow. With built-in trapping, you can separate a document by 
using InDesign or in-RIP separations. To use Adobe In-RIP Trapping, you must use In-RIP 
separations.

• Trap widths. Built-in trapping limits trap widths to 4 points, regardless of the value you 
enter for the trap widths. For larger trap widths, use Adobe In-RIP Trapping.

Additional differences between built-in and Adobe In-RIP Trapping are described in the 
following sections.
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About trapping imported images
Built-in trapping traps images, such as photographs, to text and InDesign graphics. 
However, the images must be saved using a purely pixel-based file format that supports 
the color requirements of commercial printing. Built-in trapping will trap images saved in 
the BMP, GIF, JPEG, PCX, PICT, PNG, PSD (Photoshop), TIFF, and WMF file formats. Of these, 
PSD and TIFF are the most appropriate formats for commercial printing jobs; before using 
other formats, consult with your prepress service provider.

In file formats that are not purely pixel-based, the nonpixel data will prevent the image 
from working properly with built-in trapping. Built-in trapping cannot trap graphics saved 
in the AI (Adobe Illustrator), DCS, EPS, Adobe PDF, or PostScript file formats; if you want to 
trap these graphics file formats, use Adobe In-RIP Trapping. It’s easy to use one of these 
formats by mistake. Here’s why:

• While EPS and PDF images may appear to consist only of pixels, the pixels are actually 
contained inside a layer of PostScript code.

• The Desktop Color Separation (DCS) format is based on EPS, so images saved using DCS 
can’t be trapped by built-in trapping.

• If you’re using an Open Prepress Interface (OPI) server, verify that it creates for-position-
only (FPO) images using TIFF format, not EPS. If the images are TIFF, it may be possible 
to use built-in trapping, as long as you don’t select any Omit For OPI options at output 
time. (Omit For OPI options are located in the Advanced panel of the Print dialog box 
when a PostScript printer is targeted.)

Note: The behavior and precision of trapping within an OPI workflow depends on many 
factors, such as the downsampling method the OPI server uses to generate FPO images. 
For best results, consult with your OPI vendor for information about integrating Adobe 
trapping solutions with the vendor’s OPI server.

About trapping imported vector graphics
Both Adobe In-RIP Trapping and built-in trapping can trap text and graphics created with 
the tools in InDesign. However, built-in trapping doesn’t trap placed vector graphics 
such as EPS or PDF files. You can use built-in trapping with documents containing vector 
graphics in the following cases:

• One way to trap Illustrator art is to save the Illustrator file as a TIFF image, and place that 
image into InDesign. Make sure that you specify TIFF resolution and color options that 
are appropriate for your print job; see your prepress service provider if you’re unsure 
about the best settings.

• The text, paths, and frames you create in InDesign won’t trap correctly if they overlap a 
frame containing a placed graphic that built-in trapping won’t trap, such as placed Illus-
trator art. If the placed vector graphic isn’t rectangular, try reshaping the placed 
graphic’s frame closer to the graphic itself, and away from other objects. For example, 
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you might choose Object > Clipping Path to fit the graphics frame more tightly around 
the graphic.

InDesign text and graphics that overlap placed graphics (left) won’t trap correctly; 
to achieve good trapping, reshape the frame so that it doesn’t touch other objects (right)

About trapping text
Both the Adobe In-RIP and built-in trapping engines can trap text characters to other text 
and graphics (as long as they are placed directly on the layout, and aren’t contained in 
imported graphics). A text character overlapping different background colors traps 
accurately to all of the colors.

For best results with built-in trapping, use Type 1 fonts only; using TrueType fonts may 
result in inconsistent traps. Neither trapping engine traps bitmap fonts. If your document 
must use TrueType fonts and you want to use built-in trapping, consider converting all 
TrueType text to outlines by selecting the text and choosing Type > Create Outlines. The 
text will become InDesign objects that do trap reliably. Remember, though, that text can’t 
be edited after you convert it to outlines.

Maximizing trapping performance
Whether you use Adobe In-RIP trapping or built-in trapping, you can save time by not 
processing pages that don’t need trapping, such as pages containing black text only. You 
can use trap styles to enable trapping only for the page ranges that require it; for more 
information, see “Assigning a trap style to pages” on page 329.

The speed with which built-in trapping is accomplished depends on the speed of your 
computer system. If you’re trapping every page of a long document, use the fastest 
computer system you have. Built-in trapping also makes extensive use of your computer’s 
hard disk, so a fast hard disk and data bus will benefit the built-in trapping engine. To 
maximize the time your computers are available for other tasks, consider using Adobe In-
RIP Trapping, which processes all traps at the RIP, instead of at your computer.

Setting aside disk space for built-in trapping
To trap the edges of every color that requires trapping, the trapping engine creates a large 
number of paths which are used only by the output device (the paths are not stored in 
your document). While Adobe In-RIP Trapping processes and stores these additional paths 
at the RIP, built-in trapping uses your computer’s hard disk as a temporary storage area for 
these trap paths. Before you use built-in trapping, make available as much hard disk space 
as possible.

The amount of disk space you’ll need depends on a wide range of factors, so it isn’t 
possible to predict exactly what a particular trapping job will require. However, disk space 
requirements are most likely to increase when one or more of the following characteristics 
of your document increase:
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• Number of pages included in trapping page ranges

• Number of overlapping color objects

• Number of images that need to be trapped

• Amount of text that needs to be trapped

• Resolution of final output

If the processing of a job that uses built-in trapping is interrupted or exhausts your disk 
space, trapping data may be left behind on your hard disk. When necessary, you can exit 
from InDesign, and then find and delete temporary InDesign data in the C:\Temp folder 
(Windows) or the Cleanup At Startup folder (Mac OS).

Note: The Cleanup At Startup folder is an invisible folder at the top level of a Mac OS 
computer. Use a disk utility to see it or, to locate it using the Mac OS Find command, hold 
down Option as you click the left search criterion menu and choose the Visibility option; 
then choose Invisible in the right criterion menu.

Trapping a document
Trapping is a complex process that depends on the interaction of various color, ink, and 
printing factors; the correct settings vary, depending on specific printing conditions. Do 
not change the default trapping settings unless you’ve consulted with your prepress 
service provider, and read the trapping topics referred to in the following procedure to 
make sure that you understand how trapping options work in the context of your specific 
document and printing conditions.

When trapping multiple documents in a book, make sure that you assign any custom trap 
styles to page ranges within the individual documents of the book. You cannot assign 
trapping settings to an entire book at once. However, you can resolve conflicting styles in 
a document. (See “Printing books with conflicting trap styles” on page 336.)

To trap a document or book:

1 If necessary, create a trap style with custom settings for your document and press 
conditions. (See “Creating and editing trap styles” on page 327.)

2 Assign the trap style to a page range. (See “Assigning a trap style to pages” on 
page 329.)

3 Choose File > Print to open the Print dialog box.

4 Click Output on the left side of the dialog box to open the Output panel.

5 For Color, choose either Separations or In-RIP Separations, depending on whether 
you’re creating on-host or in-RIP separations.

6 For Trapping, choose one of the following options to trap the document:

• Application Built-In, to use the trapping engine included with InDesign.

• Adobe In-RIP, to use Adobe In-RIP Trapping. This option works only when you target an 
output device that supports Adobe In-RIP Trapping.

7 Click Ink Manager. As necessary, select an ink, specify the following options, and then 
click OK:
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• For Type, choose an ink type that describes the selected ink only if your prepress service 
provider recommends changing this setting. (See “Working with specialty inks or 
varnishes” on page 331.)

• For Neutral Density, type a value that describes the neutral density of the selected ink 
only if your prepress service provider recommends changing this setting. (See 
“Adjusting ink neutral density values” on page 330.)

• For Trapping Sequence, type a value to set the order in which inks are printed only if 
your prepress service provider recommends changing this setting. (See “Specifying 
trapping sequence” on page 331.)

8 Continue specifying other print options, and then click Print to print your document.

Using the Trap Styles palette
The Trap Styles palette provides a simple interface for entering trap settings and saving a 
collection of settings as a trap style. You can apply trap styles to any or all pages in the 
current document, or import the styles from another InDesign document. If you don’t 
apply a trap style to a trapping page range, that page range will use the [Default] trap 
style. The [Default] style is a collection of typical trap settings that are applied to all pages 
of a new document by default. To assign a different style, or to use no style, see “Assigning 
a trap style to pages” on page 329.

The way individual trapping options are used varies, depending on the situation. For more 
information, see the other trapping topics. For more information on using InDesign styles, 
see “About InDesign styles” on page 27.

To display the Trap Styles palette:

Choose Window > Trap Styles.

To view a trap style’s settings:

Do one of the following in the Trap Styles palette:

• Double-click the style.

• Select the style and choose Style Options in the palette menu.

To compress the trap styles list:

In the Trap Styles palette, choose Small Palette Rows in the palette menu. InDesign 
removes the divider lines and reduces the interline spacing, creating a more compact style 
list. 

To identify unused trap styles:

In the Trap Styles palette, choose Select All Unused in the palette menu. The trapping 
engine highlights all styles (except [Default] and [No Trap Style]) that have not been 
assigned to the current document. You can easily delete these styles.

Creating and editing trap styles
Use the Trap Styles dialog box to specify trap settings for new or existing styles (including 
the [Default] trap style), or to delete trap styles.
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To create or modify a trap style:

1 Choose Window > Trap Styles.

2 Choose New Style in the palette menu, or double-click a style to edit it. 

Note: Clicking the New Style  button at the bottom of the Trap Styles palette creates a 
style based on the [Default] trap style settings.

3 Specify the following options, and then click OK:

• For Name, type a name for the style. You can’t change the name of the [Default] trap 
style.

• For Trap Width, type values to specify the amount of overlap for inks. (See “Setting trap 
widths” on page 332.)

• For Trap Appearance, specify options for controlling the shape of the traps. (See 
“Setting trap appearance” on page 332.)

• For Images, specify settings that determine how to trap imported bitmap images. (See 
“Trapping imported graphics” on page 334.)

• For Trap Thresholds, type values to specify the conditions under which trapping 
occurs. Many variables affect the values you’ll need to enter here. For more information, 
consult with your prepress service provider, and see the other trapping topics.

To duplicate a trap style:

Do one of the following:

• In the Trap Styles palette, select a style and choose Duplicate Style in the palette menu.

• Drag a style to the New Style button at the bottom of the palette.

To delete a trap style:

1 In the Trap Styles palette, select the style(s), and then do one of the following:

• Click the Delete button .

• Choose Delete Styles in the palette menu.

2 If prompted to replace a trap style, choose one in the Delete Trap Style dialog box that 
appears. This dialog box appears if at least one of the selected styles has been assigned to 
a page.

3 Click OK to confirm the deletion.

Note: You cannot delete either of the two built-in styles: [Default] and [No Trap Style].

To import styles from another InDesign document:

1 In the Trap Styles palette, choose Load Trap Styles in the palette menu. 

2 Select the InDesign file and click Open.
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Assigning a trap style to pages
You can assign a trap style to a document or to a range of pages in a document. Pages with 
no abutting colors will print faster if you disable trapping on those pages. Trapping 
doesn’t actually occur until you print the document.

Trap assignments list the styles you have applied to various pages; 
the trap assignments are updated each time you click Assign

To assign a trap style to pages:

1 In the Trap Styles palette, choose Assign Trap Style in the palette menu.

2 For Trap Style, choose the style you want to apply.

3 Select the pages to which you want to apply the trap style.

4 Click Assign, and then click Done.

Note: If you click Done without clicking Assign, the dialog box closes without making any 
changes to the trap assignments. Trap assignments previously made using the Assign 
button are preserved.

To set up trapping page ranges:

1 In the Trap Styles palette, choose Assign Trap Style in the palette menu.

2 For Trap Style, choose the style you want to apply to the page ranges.

3 Select Range and type one or more ranges in ascending sequence, using a hyphen for 
each range, and separating pages and ranges with commas, or with commas and spaces. 
For example, 2-4, 6, 9-10, 12- is a valid range.

4 Click Assign, and then click Done.

To disable a trapping page range:

1 In the Trap Styles palette, choose Assign Trap Style in the palette menu.

2 Type a page range and choose [No Trap Style] in the Trap Style menu.

3 Click Assign, and then click Done.
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Adjusting ink neutral density values 
You can adjust the ink neutral density (ND) values that the selected trapping engine uses 
to determine the precise placement of traps. The default ND values for process inks are 
based on the neutral density readings of process ink swatches that conform to industry 
standards in different parts of the world. The language version of InDesign determines 
which standard it conforms to. For example, the ND values for the U.S. English and 
Canadian versions of InDesign conform to the Specifications for Web Offset Publications 
(SWOP) solid ink density values published by the Graphic Arts Technical Foundation of 
North America. InDesign lets you adjust process ink neutral densities to match printing 
industry standards in other parts of the world.

The trapping engine derives the ND values for a spot color from its CMYK equivalent. For 
most spot colors, the ND values of their CMYK equivalents are accurate enough for proper 
trap creation. Spot inks that are not easily simulated using process inks, such as metallic 
inks and varnishes, may need their ND values adjusted so that the trapping engine can 
trap them correctly. By typing new values, you can ensure that an ink that is observably 
darker or lighter is recognized that way in InDesign; the appropriate trap placement is 
then applied automatically.

You can get the appropriate neutral density value for a given ink by asking your 
commercial printer. The most accurate method of determining an ink’s ND value is by 
measuring a swatch of the ink with a commercial densitometer. Read the “V” or visual 
density of the ink (do not use process filters). If the value differs from the default setting, type 
the new value in the ND text box.

Note: Changing the neutral density for a spot color only affects how that color will trap. It 
does not change the appearance of that color in your document.

Follow these guidelines when adjusting ND values:

Metallic and opaque inks Metallic inks are usually darker than their CMYK equivalents, 
while opaque inks obscure any ink beneath them. In general, you should set the ND values 
for both metallic and opaque spot colors much higher than their default values to ensure 
that these spot colors won’t spread. 

Note: Setting an ink to Opaque or OpaqueIgnore in the Edit Trapping Inks dialog box 
prevents an opaque ink from spreading into other colors, unless another opaque ink has a 
higher ND value.

Pastel inks These inks are normally lighter than their process equivalents. You may want 
to set the ND value for these inks lower than their default values to ensure that they 
spread into adjacent darker colors.

Other spot inks Some spot colors, such as turquoise or neon orange, are significantly 
darker or lighter than their CMYK equivalents. You can determine whether this is the case 
by comparing printed swatches of the actual spot inks to printed swatches of their CMYK 
equivalents. You can adjust the spot ink’s ND value higher or lower as necessary.
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Working with specialty inks or varnishes
Using certain inks involves special trapping considerations. For example, if you are using a 
varnish on your document, you don’t want the varnish to affect trapping. However, if 
you’re overprinting certain areas with a completely opaque ink, there is no need to create 
traps for items underneath. Ink options are available for these situations. It’s usually best 
not to change the default settings, unless your prepress service provider recommends 
changing them.

To customize trapping with specialty inks:

1 Open the Ink Manager and select an ink that requires special treatment. For information 
about how to display the Ink Manager, see “Using the Ink Manager” on page 317.

2 For Type, choose one of the following options, and then click OK:

• Choose Normal for traditional process inks and most spot inks.

• Choose Transparent for clear inks to ensure that underlying items trap. Use this option 
for varnishes and dieline inks.

• Choose Opaque for heavy, nontransparent inks to prevent trapping of underlying 
colors but allow for trapping along the ink’s edges. Use this option for metallic inks.

• Choose OpaqueIgnore for heavy, nontransparent inks to prevent trapping of under-
lying colors and to prevent trapping along the ink’s edges. Use this option for those 
inks, such as metallics and varnishes, that have undesirable interactions with other inks.

Specifying trapping sequence
You can adjust the trapping sequence (also called the trapping order). The trapping 
sequence matches the order in which inks are printed at the press, but it does not match 
the order in which separations are produced at the output device.

The trapping sequence is particularly important when you’re printing with multiple 
opaque colors, such as metallic inks. Opaque inks with lower sequence numbers are 
spread under opaque inks with higher sequence numbers. This prevents the last applied 
ink from being spread, and still creates good traps. 

Note: Do not alter the default trapping sequence without first consulting with your 
prepress service provider.

To adjust the trapping sequence:

1 Open the Ink Manager. The current trapping sequence is displayed in the Sequence 
column of the inks list. To display the Ink Manager, see “Using the Ink Manager” on 
page 317.

2 Select an ink, type a new value for Trapping Sequence, and then press Tab. The 
sequence number of the selected ink is changed, and the other sequence numbers are 
changed accordingly.

3 Repeat the previous step for as many inks as necessary, and then click OK. 
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Setting trap widths
Differences in paper characteristics, screen rulings, and printing press conditions require 
different amounts of trap. Each Trap Width control allows a maximum value of 8 points. 
In practice, however, this value can be used only by Adobe In-RIP Trapping. If built-in 
trapping is used, any amount over 4 points is clipped to 4 points. To determine the appro-
priate trap widths for each job, consult with your commercial printer. Trap styles provide 
two different settings for trap width (the amount of overlap for each trap):

Default Specifies the trap width in points for trapping all colors except those involving 
solid black. Enter values from 0p0 to 0p8. The default value is 0p0.25. 

Black Indicates the distance that inks spread into solid black, or the holdback amount—
the distance between black edges and underlying inks for trapping rich blacks. The default 
value is 0p0.5. This value is often set to be 1.5 to 2 times the value of the default trap width. 

The value you set for Black Color determines what InDesign will consider to be a solid 
black or a rich black (a process color consisting of solid black with one or more compo-
nents of C, M, or Y inks). For details, see “Trapping with blacks and rich blacks” on 
page 335.

Note: If you choose Application Built-In trapping, and you specify a Default trap width 
or Black width larger than four points, the resulting trap width is limited to four points. 
However, the value you specified will continue to be displayed, because if you switch to 
Adobe In-RIP Trapping, traps larger than one point are applied as you specified.

Setting trap appearance
A join is where two trap edges meet at a common end point. You can control the shape of 
the outside join of two trap segments and the intersection of three traps. The Trap 
Appearance section in the Trap Style dialog box has two options:

Join Style Controls the shape of the outside join of two trap segments. Choose from 
Miter, Round, and Bevel. The default is Miter, which matches earlier trapping results to 
retain compatibility with previous versions of the Adobe Trapping Engine.

Trap join examples, left to right: miter join, round join, bevel join
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End Style Controls the intersection of three traps. Miter (the default) shapes the end of 
the trap to keep it away from the intersecting object. Overlap affects the shape of the trap 
generated by the lightest neutral density object that intersects with two or more darker 
objects. The end of the lightest trap is wrapped around the point where the three 
objects intersect.

Close-up of trap end examples: miter (left) and overlap (right)

Setting trap thresholds
You can adjust trap thresholds, as recommended by your prepress service provider, to corre-
spond to your printing conditions. Trap thresholds are available for the following color 
conditions:

Step Indicates the degree to which components (such as CMYK values) of abutting colors 
must vary before InDesign creates a trap. Type a value from 1% to 100%, or use the default 
of 10%. For best results, use a value from 8% to 20%. Lower percentages increase sensitivity 
to color differences and result in more traps. 

Black Color Indicates the minimum amount of black ink required before the Black width 
setting is applied. Type a value from 0% to 100%, or use the default of 100%. For best 
results, use a value no lower than 70%. (See “Trapping with blacks and rich blacks” on 
page 335.)

Black Density Indicates the neutral density value at or above which InDesign considers 
an ink to be black. For example, if you want a dark spot ink to use the Black width setting, 
enter the neutral density value here. Use any value from .001 to 10, but this value is 
typically set near the default of 1.6.

Sliding Trap Indicates the percentage difference (between the neutral densities of 
abutting colors) at which the trap is moved from the darker side of a color edge toward 
the centerline, to create a more elegant trap. (See “Using sliding traps” on page 334.)

Trap Color Reduction Indicates the degree to which InDesign uses components from 
abutting colors to reduce the trap color. This is useful for preventing certain abutting 
colors (such as pastels) from making an unsightly trap that is darker than either color. 
Specifying a Trap Color Reduction lower than 100% begins to lighten the color of the trap; 
a Trap Color Reduction value of 0% makes a trap whose neutral density is equal to the 
neutral density of the darker color.
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Adjusting trapping tolerance
Some jobs need only the most extreme color changes trapped, while others require traps 
for more subtle color changes. The Step Limit value specifies the threshold at which the 
trapping engine decides to create a trap.

To change how much the component inks in abutting colors can vary before causing 
those colors to trap, increase or decrease the value for Step Limit in the Trapping panel in 
the Print dialog box. The lower the Step Limit percentage, the more often traps are 
created between colors.

Using sliding traps
You can use a sliding trap to prevent abrupt shifts in trap placement along a gradient 
edge. During trapping, the trapping engine adjusts (slides) the trap position—from 
spreading the lighter color into the darker one, to straddling the centerline between them.

In the Trap Style dialog box, the Sliding Trap value determines when the trapping engine 
starts to straddle the centerline of the color boundary. The value refers to the proportion 
of the lighter color’s neutral density value to a darker, abutting color’s neutral density 
value. For example, setting the Sliding Trap value to 70% moves the point at which the 
trap begins to straddle the centerline to where the lighter color exceeds 70% of the darker 
color in neutral density (lighter color’s neutral density divided by darker color’s neutral 
density > 0.70). Colors of identical neutral density will always have their traps exactly 
straddle the centerline, unless the Sliding Trap is set to 100%.

To set the percentage difference at which a trap slides:

1 Open the Trap Style dialog box for a new or existing style. (See “Using the Trap Styles 
palette” on page 327.)

2 In the Trap Thresholds section, for Sliding Trap, enter a percentage from 0 to 100, or use 
the default of 70%. At 0%, all traps default to centerline; at 100%, sliding traps are 
turned off, forcing one color to be spread fully into another regardless of the neutral 
density relationship of the abutting colors.

Trapping imported graphics
You can create a trap style to control traps within images, and to control traps between 
bitmap images, such as photographs, and vector objects, such as those from a drawing 
program. If you’re using built-in trapping instead of Adobe In-RIP Trapping, be sure to 
understand the differences in the way each trapping engine handles imported graphics; 
see “About trapping imported images” on page 324.

The Trap Style dialog box includes the following options:

Trap Placement Provides options for determining where the trap falls when trapping 
vector objects (including objects drawn in InDesign) to bitmap images. All options except 
Neutral Density create a visually consistent edge. Center creates a trap that straddles the 
edge between objects and images. Choke causes objects to overlap the abutting image. 
Neutral Density applies the same trapping rules as used elsewhere in the document. 
Trapping an object to a photograph with the Neutral Density setting can result in 
noticeably uneven edges as the trap moves from one side of the edge to another. Spread 
causes the bitmap image to overlap the abutting object.
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Trap Objects to Images Ensures that vector objects (such as frames used as keylines) 
trap to images, using the Trap Placement settings. If vector objects do not overlap images 
in a trapping page range, consider turning this option off to speed trapping of that 
page range.

Trap Images to Images Turns on trapping along the boundary of overlapping or 
abutting bitmap images. This feature is on by default.

Trap Images Internally Turns on trapping among colors within each individual bitmap 
image (not just where they touch vector artwork and text). Use this option only for page 
ranges containing simple, high-contrast images, such as screen shots or cartoons. Leave it 
unselected for continuous-tone and other complicated images, as it will create bad 
traps. Trapping is faster when this option is unselected. 

Trap 1-Bit Images Ensures that 1-bit images trap to abutting objects. This option does 
not use the Image Trap Placement settings, because 1-bit images use only one color. 
In most cases, leave this option selected. In some cases, such as with 1-bit images 
where pixels are widely spaced, selecting this option may darken the image and slow 
the trapping.

Trapping with blacks and rich blacks
The value you type for Black Color in the Trap Style dialog box will determine what 
InDesign considers to be a solid black and a rich black. A rich black is any black color that 
uses a support screen—adding percentages of one or more process inks to strengthen 
the black.

The Black Color setting is useful when you must compensate for extreme dot gain (as 
when using low-grade paper stock). These situations cause black percentages lower 
than 100% to print as solid areas. By screening back blacks or rich blacks (using tints of 
solid black) and decreasing the Black Color setting from its default of 100%, you can 
compensate for dot gain and ensure that the trapping engine will apply the proper trap 
width and placement to black objects.

When a color reaches the Black Color value, the Black width value is applied to all abutting 
colors, and keepaway traps are applied to rich black areas using the Black width value.

If support screens extend all the way to the edge of a black area, any misregistration will 
cause the edges of support screens to become visible, creating an unwanted halo or 
distorting the edges of objects. The trapping engine uses a keepaway, or a holdback, 
placement for rich blacks to keep support screens a specified distance away from edges 
of reversed-out or light elements in the foreground, so that the light elements retain their 
sharpness. You control the distance of support screens from the edges of black areas by 
specifying the Black width value.

Note: Don’t worry that the Black width setting will be too wide for trapping thin elements, 
such as black keylines around graphics. In those cases, the trapping engine automatically 
overrides the Black width setting and limits the trap to half the width of the thin element.

To set the trap width for colors next to black:

1 Open the Trap Style dialog box for a new or existing style. (See “Using the Trap Styles 
palette” on page 327.)
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2 In the Trap Width section, for Black, enter a distance (in points) for how far you want 
other colors to spread into black, or for how far you want support screens choked back 
under black. Typically, the Black width is set to be 1.5 to 2 times the value of the Default 
trap width.

3 For Black Color and Black Density, set values. (See “Setting trap thresholds” on 
page 333.)

Note: To use black trapping features, a color area must use an ink with a neutral density 
greater than or equal to the Black Density, and the ink must occur in percentages greater 
than or equal to the Black Color.

4 Click OK as necessary to close dialog boxes.

Printing books with conflicting trap styles
You can apply one trap style to one sheet of output, such as one page. Normally this is not 
a concern. However, if you print multiple documents in a book, and each document or 
page has a different trap style, InDesign can resolve some trap style conflicts by synchro-
nizing styles among documents:

• If documents in a book use different trap styles with the same name, InDesign assigns 
the trap style used in the master document, provided you’ve selected the Trap Style 
option in the Synchronize Options dialog box. (See “Synchronizing documents in a 
book file” on page 169.)

• The synchronizing feature makes all the master document’s styles available to the other 
documents in the book, but does not assign them; you have to assign trap styles in 
each document, or use the [Default] trap style. The styles appear in the Trap Style menu 
of the document’s Assign Trap Styles dialog box. 

Note: If different trap styles are applied to pages in a spread, InDesign honors each 
trap style. 

Trapping documents with transparent objects
If your InDesign document contains transparent objects and traps, consider the trapping 
issues described in “Setting up your transparent document for successful output” on 
page 296.
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Producing Consistent Color

Why colors sometimes don’t match
No device in a publishing system is capable of reproducing the full range of colors 
viewable by the human eye. Each device operates within a specific color space, which can 
produce a certain range, or gamut, of colors.

The RGB (red, green, blue) and CMYK (cyan, magenta, yellow, and black) color models 
represent two main categories of color spaces. The gamuts of the RGB and CMYK spaces 
are very different; while the RGB gamut is generally larger (that is, capable of representing 
more colors) than CMYK, some CMYK colors still fall outside the RGB gamut. 

The extent of the RGB color gamut exceeds that of the CMYK color gamut.  
A. RGB color gamut B. CMYK color gamut

In addition, different devices produce slightly different gamuts within the same color 
model. For example, a variety of RGB spaces can exist among scanners and monitors, and a 
variety of CMYK spaces can exist among printing presses and desktop printers. 

Because of these varying color spaces, colors can shift in appearance when you transfer 
documents between different devices. Color variations can result from differences in 
image sources (scanners and software produce art using different color spaces), differ-
ences in brands of computer monitors, differences in the way software applications define 
color, differences in print media (newsprint reproduces a smaller gamut than magazine-
quality paper), and other natural variations, such as monitor age.

About color management
Color-matching problems result from various devices and software using different color 
spaces. One solution is to have a system that interprets and translates color accurately 
between devices. A color management system (CMS) compares the color space in which a 
color was created to the color space in which the same color will be output, and makes the 
necessary adjustments to represent the color as consistently as possible among 
different devices.

B

A
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The following components are integral to a color-managed workflow:

Device-independent color space To successfully compare different device gamuts and 
make adjustments, a color management system must use a reference color space—an 
objective way of defining color. Most CMSs use the CIE (Commission Internationale 
d’Eclairage) LAB color model, which exists independently of any device and is an interna-
tional standard for color measurement. For this reason, CIE LAB is considered device-
independent.

Color management engine Different companies have developed various ways to 
manage color. A color management system lets you choose a color management engine 
that represents the approach you want to use. Sometimes called the color management 
module (CMM), the color management engine is the part of the CMS that does the work of 
reading and translating colors between different color spaces. 

Color profiles The CMS translates colors with the help of color profiles. A profile is a 
mathematical description of a device’s color space; that is, how the reference CIE values of 
each color in the color space map to the visual appearance produced by the device. For 
example, a scanner profile tells a CMS how your scanner “sees” colors, so that an image 
from your scanner can be accurately translated into the CIE color space. From the CIE 
space, the colors can then be translated accurately again, via another profile, to the color 
space of an output device. InDesign uses ICC profiles, a format defined by the Interna-
tional Color Consortium (ICC) as a cross-platform standard. InDesign also supports 
Microsoft ICM (Image Color Management) profiles and system-level CMS on Windows 98, 
Windows 2000, and Windows Me.

Rendering intents No single color translation method can manage color correctly for all 
types of graphics. For example, a color translation method that preserves correct relation-
ships among colors in a wildlife photograph may alter the colors in a logo containing flat 
tints of color. Color management engines provide a choice of rendering intents, or trans-
lation methods, so that you can apply a method appropriate to a particular graphical 
element. For descriptions of the rendering intents available to InDesign, see “Specifying a 
rendering intent” on page 347.

Note: Don’t confuse color management with color correction. A CMS won’t correct an 
image that was saved with tonal or color balance problems. It provides an environment 
where you can evaluate images reliably in the context of your final output.

Do you need color management?
Use the following guidelines to determine whether or not you need color management:

• Color accuracy in your working environment isn’t required if you rely completely on 
prepress service providers and commercial printers for all of your color work.

• Color management is recommended for maintaining color accuracy in monitor display, 
the ability to soft-proof colors, and color consistency in large workgroups. 

• Color management is recommended if you reuse color graphics for print and online 
media, use various kinds of devices within a single medium (such as different printing 
presses), or print to different domestic and international presses. 

If you decide to use color management, consult with your production partners—such as 
graphic artists and prepress service providers—to ensure that all aspects of your color 
management workflow integrate with theirs.
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Creating a viewing environment for color management
Your work environment influences how you see color on your monitor and in printed 
output. For best results, control the colors and the light in your work environment by 
doing the following:

• View your documents in an environment that provides a consistent light level and color 
temperature. For example, because the color characteristics of sunlight change 
throughout the day and alter the way colors appear on your screen, keep shades closed 
or work in a windowless room. To eliminate the blue-green cast from fluorescent 
lighting, consider installing D50 (5000-degree Kelvin) lighting. Ideally, view printed 
documents in a D50 lightbox.

• View your documents in a room with neutral-colored walls and ceiling. A room’s color 
can affect the perception of both monitor color and printed color. The best color for a 
viewing room is polychromatic gray. Also, the color of your clothing reflected in the 
glass of your monitor may affect the appearance of on-screen colors.

• Match the light intensity in the room or lightbox to the light intensity of your monitor. 
View continuous-tone art, printed output, and on-screen images under the same 
intensity of light.

• Remove colorful background patterns on your monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate color perception. Set your desktop to 
display neutral grays only.

• View document proofs in the real-world conditions in which your audience will see the 
final piece. For example, you might want to see how a housewares catalog looks under 
the incandescent light bulbs used in homes, or view an office furniture catalog under 
the fluorescent lighting used in offices. However, always make final color judgments 
under the lighting conditions specified by the legal requirements for contract proofs in 
your country.

Turning on and setting up color management
InDesign simplifies the task of setting up a color-managed workflow by gathering most 
color management controls in a single Color Settings dialog box. Rather than adjusting 
each control manually, you can choose from a list of predefined color management 
settings. Each predefined configuration includes a set of color management options 
designed to produce consistent color for a common publishing workflow, such as prepa-
ration for Web or domestic prepress output. These predefined configurations can also serve 
as starting points for customizing your own workflow-specific configurations.

InDesign also uses color management policies, which determine how to handle color data 
that don’t immediately match your current color management workflow. Policies are 
designed to clarify the color management decisions you need to make when you open a 
document or import color data into an active document.

Keep in mind that you must specify color management settings before opening or 
creating files in order for the settings to take effect in those files.

Note: InDesign supports color management for files that use either the RGB, CMYK, or LAB 
color model. InDesign doesn’t support color management for the grayscale color model, 
or for spot colors as long as the spot colors aren’t converted to process color equivalents. If 
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a file with a grayscale object (defined in tints of black) is opened or imported into 
InDesign, that object will retain its grayscale qualities but will not be color-managed.

To open the Color Settings dialog box:

Choose Edit > Color Settings.

Turning on color management
Turning on color management activates CMS options throughout the program. The 
settings in the Color Settings dialog box are stored with a document, and will be different 
for each document. 

To turn on color management:

1 Choose Edit > Color Settings.

2 Select Enable Color Management. To disable color management, deselect this option.

When color management is on, you can display descriptions of the terminology and 
options in the dialog box by positioning the cursor over a section heading or menu item. 
These descriptions appear in the lower area of the dialog box. 

About disabling color management 
By default, color management is disabled in InDesign. When color management is 
disabled, but color conversion is required, InDesign uses two built-in profiles to convert 
between color spaces: Adobe RGB (1998) for RGB images, and U.S. Web Coated (SWOP) v2 
for CMYK images. For example, in a CMYK workflow where you’re printing to a CMYK 
device or exporting to a format (such as EPS or PDF) with CMYK as the selected output 
color space, it’s important not to change the actual CMYK values. Those values are defined 
in terms of your final press values. However, so that the CMYK colors may be seen on-
screen, the colors are converted to RGB for display purposes, using the built-in RGB profile. 
This results in on-screen colors that look more like printed CMYK colors. 

When color management is disabled, InDesign doesn’t let you override color mismatches 
using color management policies. In addition, InDesign ignores all profiles in placed 
graphics.

Using predefined color management settings
InDesign offers a collection of predefined color management settings (CSF) files, each with 
corresponding color profile and conversion options designed to preserve consistent color 
in a particular publishing workflow under typical conditions. In many cases, the 
predefined settings will provide sufficient color management for your needs.

Adobe Illustrator and Photoshop use the same predefined CSF files. (See “Synchronizing 
color management between applications” on page 348.)

To choose a predefined color management setting:

1 Choose Edit > Color Settings and select Enable Color Management.

2 For Settings, choose a configuration option:

Custom Uses the settings you choose in the Color Settings dialog box.
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Color Management Off Uses minimal color management settings to simulate the 
behavior of applications that do not support color management. Use this option to prepare 
content for video or on-screen presentations.

ColorSync Workflow (Mac OS only) Manages color using the ColorSync 3.0 CMS, with 
the profiles chosen in the ColorSync control panel. This color management configuration 
is not recognized by Windows-based systems, or by earlier versions of ColorSync.

Emulate Photoshop 4 Simulates the color workflow used by Adobe Photoshop 4.0 
and earlier.

Europe Prepress Defaults Manages color for content that will be output under typical 
European press conditions.

Japan Prepress Defaults Manages color for content that will be output under typical 
Japanese press conditions.

Photoshop 5 Default Spaces Manages color using the default working spaces for 
Photoshop 5.0 and later.

U.S. Prepress Defaults Manages color for content that will be output under typical U.S. 
press conditions.

Web Graphics Defaults Manages color for content that will be published on the World 
Wide Web.

When you choose a predefined configuration, the Color Settings dialog box is updated to 
display the specific color management settings associated with the configuration.

Customizing color management settings
Although the predefined settings can provide sufficient color management for some 
typical publishing workflows, you should customize individual options to suit specific 
workflows. For example, you could change the CMYK working space to a profile that 
matches the proofing system used by your prepress service provider.

It’s important to save your custom configurations, so that you can reuse and share them 
with other users who use the same color management workflows; for more information, 
see “Saving and loading custom color management settings” on page 348. 

The color management settings that you customize in the Color Settings dialog box 
have an associated preferences file called InDesign Color Settings, located in the 
following locations:

• In Windows, it’s in the Documents & Settings\<user>\Local Settings\Application 
Data\Adobe\InDesign\version 2.0\ folder.

• In Mac OS, it’s in the Preferences\Adobe InDesign\Version 2.0 folder in your 
System Folder.

To customize color management settings:

1 Choose Edit > Color Settings and select Enable Color Management.

2 To use a preset color management configuration as the starting point for your customi-
zation, choose that configuration in the Settings menu.

3 Specify the desired color settings. (As you make adjustments, the Settings menu option 
changes to Custom by default.)
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Specifying working spaces
Among other options, predefined color management settings specify the default color 
profiles to be associated with the RGB and CMYK color models. Central to the color 
management workflow, these default profiles are known respectively as the RGB and 
CMYK working spaces. The working spaces specified by predefined settings represent the 
color profiles that will produce the best color fidelity for several typical output conditions. 
For example, the U.S. Prepress Defaults setting uses a CMYK working space that is 
designed to preserve color consistency under standard Specifications for Web Offset 
Publications (SWOP) press conditions.

Working spaces act as the default color profiles for newly created documents. For 
example, if Adobe RGB (1998) is the current RGB working space, and U.S. Web Coated 
(SWOP) v2 is the current CMYK working space, then each new InDesign document uses 
colors within the Adobe RGB (1998) and U.S. Web Coated (SWOP) v2 gamuts. Working 
spaces also define the destination gamut of documents converted to the RGB or CMYK 
color model.

At times you may want to customize the RGB or CMYK working space to reflect a workflow 
that uses a particular output or display device. 

InDesign includes a standard set of color profiles that have been recommended and 
tested by Adobe Systems for most color management workflows. By default, only these 
profiles appear under the working space menus. To display additional color profiles that 
you have installed on your system, select Advanced Mode at the top of the Color Settings 
dialog box. To appear under a working space menu, a color profile must be bidirectional; 
that is, it must contain specifications for translating both into and out of color spaces. For 
information on installing color profiles, see “Adding device profiles to the color 
management system” on page 352.

For the RGB color model, the following standard working space options are available:

Adobe RGB (1998) Provides a fairly large gamut (range) of colors and is well suited to 
documents that will be converted to CMYK. Use this space if you need to do print 
production work with a broad range of colors.

sRGB IEC61966-2.1 Reflects the characteristics of the average PC monitor. This standard 
space is endorsed by many hardware and software manufacturers, and is becoming the 
default color space for many scanners, low-end printers, and software applications. This 
space is recommended for Web work, but not for prepress work (because of its limited 
color gamut).

Apple RGB Reflects the characteristics of the Apple Standard 13-inch monitor, and is 
used by a variety of desktop publishing applications, including Adobe Photoshop 4.0 and 
earlier. Use this space for files that you plan to display on Mac OS monitors, or for working 
with legacy (older) desktop publishing files.

ColorMatch RGB Matches the native color space of Radius Pressview monitors. 
This space provides a smaller-gamut alternative to Adobe RGB (1998) for print 
production work.

Monitor RGB Sets the RGB working space to the current color profile of your monitor. Use 
this setting if other applications in your workflow do not support color management. If a 
color management configuration that specifies Monitor RGB is shared with another user 
working on a different system, the configuration uses that system’s monitor profile as the 
working space.
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ColorSync RGB (Mac OS only) Matches the RGB space specified in the control panel for 
Apple ColorSync 3.0 or later. If a color management configuration specifying this setting is 
shared with another user working on a different system, the configuration uses that 
system’s ColorSync RGB space as the working space.

For the CMYK color model, the following standard working space options are available:

Euroscale (Coated) v2 Uses specifications designed to produce high-quality separations 
using Euroscale inks under the following printing conditions: 350% total area of ink 
coverage, positive plate, bright white coated stock.

Euroscale (Uncoated) v2 Uses specifications designed to produce high-quality separa-
tions using Euroscale inks under the following printing conditions: 260% total area of ink 
coverage, positive plate, uncoated white offset stock.

Japan Standard v2 Uses specifications designed to produce high-quality separations 
using Japan Standard inks under the following printing conditions: 300% total area of ink 
coverage, positive plate, coated publication-grade stock.

U.S. Sheetfed Coated v2 Uses specifications designed to produce high-quality separa-
tions using U.S. inks under the following printing conditions: 350% total area of ink 
coverage, negative plate, bright white coated stock.

U.S. Sheetfed Uncoated v2 Uses specifications designed to produce high-quality 
separations using U.S. inks under the following printing conditions: 260% total area of ink 
coverage, negative plate, uncoated white offset stock.

U.S. Web Coated (SWOP) v2 Uses specifications designed to produce high-quality 
separations using U.S. inks under the following printing conditions: 300% total area of ink 
coverage, negative plate, coated publication-grade stock. This profile was created using 
the TR001 characterization data.

U.S. Web Uncoated v2 Uses specifications designed to produce high-quality separations 
using U.S. inks under the following printing conditions: 260% total area of ink coverage, 
negative plate, uncoated white offset stock.

ColorSync CMYK (Mac OS only) Matches the CMYK space specified in the control panel 
for Apple ColorSync 3.0 or later. If a color management configuration specifying this setting 
is shared with another user working on a different system, the configuration uses that 
system’s ColorSync CMYK space as the working space.

Specifying color management policies
When you specify a predefined color management setting, InDesign sets up a color 
management workflow that will be used as the standard for all documents and color data 
that you open or import. For a newly created document, the color workflow usually 
operates as follows: The document uses the working space profile associated with its color 
model for creating and editing colors, and the profile is embedded in the saved document 
to provide color translation information for the destination output device.

However, some existing documents may not use the working space that you have 
specified, and some existing documents may not be color-managed. It is common to 
encounter the following exceptions to your color-managed workflow:

• You might open a document or import color data from a document that has not been 
color-managed, and that lacks a profile altogether. This is often the case when you open 
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a document created in an application that either does not support color management, 
or has color management turned off.

• You might open a document or import color data from a document that contains a 
color profile different from the current working space. This may be the case when you 
open a document that has been created using different color management settings, or 
an image that has been scanned and assigned with a scanner profile.

In either case, InDesign must decide how to handle the color data in the document. A color 
management policy looks for the color profile associated with an opened document or 
imported color data, and compares the profile (or lack of profile) with the current working 
space to make default color management decisions. If the profile matches the working 
space, the colors are automatically brought into the color management workflow that you 
have specified, using the working space profile. If the profile is missing or does not match 
the working space, InDesign displays a message that alerts you to the mismatch situation 
and, in many cases, lets you specify how to handle the colors in question. 

The following table provides a summary of the policy decisions you may be prompted to 
consider when opening or importing mismatched color data:

The predefined color management workflows are set to display warning or option 
messages when a default color management policy is about to be implemented. Although 
you can disable the repeated display of some of the messages, it is highly recommended 
that you continue to display all policy messages, to ensure the appropriate color 
management of documents on a case-by-case basis. You should turn off message displays 
only if you are very confident that you understand the default policy decision and are 
willing to accept it for all documents that you open. You cannot undo the results of a 
default policy decision once a document has been saved.

If desired, you can change the default policy behavior to reflect a color management 
workflow that you use more often. 

Mismatch situation Policy options that may be available

Opening non-color-managed 
document without color profile

• Use working space for editing but not saving; do not 
color-manage document. 

• Use working space for editing, and save working 
space with document.

• Use another color profile for editing, and save profile 
with document.

Opening document with color 
profile that does not match work-
ing space

• Use profile (instead of working space) for editing, and 
save profile with document.

• Convert colors to working space, and save working 
space with document.

• Discard profile, and do not color-manage document.

Importing color data into desti-
nation document

• Import and convert numeric values of source colors to 
color space of destination document, in order to pre-
serve color appearances.

• Import and preserve numeric values of source colors.
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To turn off the display of a policy message:

In the message dialog box, select the Don’t Show Again option if it is available.

To reset the display of policy messages that have been disabled:

1 Choose Edit > Preferences > General.

2 Click Reset All Warning Dialogs, and click OK.

To customize color management policies:

1 Choose Edit > Color Settings and select Enable Color Management.

2 Under Color Management Policies, choose one of the following to set the default color 
management policy for each color model:

• Off, if you do not want to color-manage imported or opened color data.

• Preserve Embedded Profiles, if you anticipate working with a mix of color-managed and 
non-color-managed documents, or with documents that use different profiles within 
the same color model.

• Convert to Working Space, if you want to color-manage all documents using the current 
working spaces.

For detailed descriptions of the default behaviors associated with each policy option, 
see the table following this procedure.

3 Select either, both, or neither of the following options. It is strongly recommended that 
you keep both options selected. Deselecting the options causes InDesign to implement 
default policy behavior without notification.

• Ask When Opening, to display a message whenever the embedded color profile in a 
newly opened document is missing or does not match the current working space. You 
will be given the option to override the policy’s default behavior.

• Ask When Pasting, to display a message whenever color profile mismatches occur as 
colors are imported into a document (via pasting and drag-and-drop, but not placing). 
You will be given the option to override the policy’s default behavior.

Policy option Default color management behavior

Off • No profiles are saved with new documents.

• If opened document’s profile does not match current working space, 
profile is discarded and not saved with document.

• If opened document’s profile matches current working space, profile 
is preserved and saved with document.

• For color data imported into same color model, numeric values of col-
ors are preserved.

• For color data imported into different color model, colors are con-
verted to destination document’s color space.
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Customizing advanced color management settings
When you choose Advanced Mode at the top of the Color Settings dialog box, you have 
the option of further customizing the settings used for color management.

Specifying a color management engine
The color management engine specifies the system and color-matching method used to 
convert colors between color spaces. For more information, see “About color 
management” on page 337.

The following standard engine options are available. If you have installed additional color 
management engines, they may also appear as options.

Adobe (ACE) Uses the Adobe color management system and color engine. This is the 
default setting for most preset color configurations.

Apple ColorSync Uses the color management system provided by Apple Computer, Inc., 
for Mac OS computers.

Microsoft ICM Uses the color management system provided by Microsoft Corporation 
for Windows 98, Windows 2000, Windows Millennium, and Windows XP computers.

Preserve Embedded 
Profiles

• Working space profile is saved with new documents.

• If opened document’s profile does not match current working space, 
profile is preserved and saved with document. 

• If opened document does not contain a profile, working space is used 
for editing but not saved with document. 

• For color data imported within same color model between either a 
non-color-managed source or destination, or from a CMYK document 
into a CMYK document, numeric color values are preserved.

• For all other import cases, colors are converted to destination docu-
ment’s color space.

Convert to Working 
Space

• Working space profile is saved with new documents.

• If opened document’s profile does not match current working space, 
document is converted to working space; working space is saved with 
document.

• If opened document does not contain a profile, working space is used 
for editing but not saved with document.

• For color data imported within same color model between either a 
non-color-managed source or destination, numeric color values are pre-
served.

• For all other import cases, colors are converted to destination docu-
ment’s color space.

Policy option Default color management behavior
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Specifying a rendering intent
Translating colors to a different color space usually involves adjusting the colors to accom-
modate the gamut of the destination color space. Different translation methods use 
different rules to determine how the source colors are adjusted; for example, colors that 
fall inside the destination gamut may remain unchanged, or they may be adjusted to 
preserve the original range of visual relationships as translated to a smaller destination 
gamut. These translation methods are known as rendering intents, because each technique 
is optimized for a different intended use of color graphics.

Note: The result of choosing a rendering intent depends on the graphical content of 
documents, and on the profiles used to specify color spaces. Some profiles produce 
identical results for different rendering intents. Differences between rendering intents are 
apparent when you print a document or convert it to a different working space. Differ-
ences may also be visible when soft- or hard-proofing.

The following rendering intent options are available:

Perceptual This intent aims to preserve the visual relationships between colors in a way 
that is perceived as natural by the human eye, although the color values themselves may 
change.

Saturation Appropriate for office and presentation graphics, this intent aims to create 
vivid color at the expense of accurate color. It scales the source gamut to the destination 
gamut but preserves relative saturation instead of hue, so that when translating to a 
smaller gamut, hues may shift. This rendering intent is suitable for business graphics, 
where the exact relationship between colors is not as important as having vivid colors.

Absolute Colorimetric Leaves colors that fall inside the destination gamut unchanged. 
This intent aims to maintain color accuracy at the expense of preserving relationships 
between colors. When translating to a smaller gamut, two colors that are distinct in the 
source space may be mapped to the same color in the destination space. 

Relative Colorimetric This intent is identical to absolute colorimetric, except for the 
following difference: relative colorimetric compares the white point (extreme highlight) of 
the source color space to that of the destination color space, and shifts all colors accord-
ingly. The relative colorimetric intent can be more accurate if the image’s profile contains 
correct white point information. This is the default rendering intent used by all predefined 
color management configurations.

Using black-point compensation
The Use Black Point Compensation option controls whether to adjust for differences in 
black points when converting colors between color spaces. When this option is enabled, 
the full dynamic range of the source space is mapped into the full dynamic range of the 
destination space. When this option is disabled, the dynamic range of the source space is 
simulated in the destination space; although this mode can result in blocked or gray 
shadows, it can be useful when the black point of the source space is lower than that of 
the destination space.

The Use Black Point Compensation option is selected for all predefined color management 
configurations. Keeping this option selected is highly recommended. 
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Saving and loading custom color management settings
When you create a custom color management configuration, name and save the configu-
ration to ensure that it can be reused and shared with other users. If you save the file in the 
default Settings folder, it will be available in the Color Settings dialog box. 

You can also load color management configurations that were saved in a location other 
than the default Settings folder. 

To save a custom color management configuration:

1 In the Color Settings dialog box, with color management on, click Save.

2 Name your color settings file, and click Save. 

To ensure that InDesign displays the saved configuration in the Settings menu of the Color 
Settings dialog box, save the file in the Settings folder (the default location when you first 
open the Save dialog box).

To load a color management configuration:

1 In the Color Settings dialog box, with color management on, click Load.

2 Locate and select the desired color settings file, and click Open.

When you load a custom color settings file, it appears as the active choice in the Settings 
menu of the Color Settings dialog box. If you choose a different option in the Settings 
menu, you must reload the custom settings file before you can use it again.

Synchronizing color management between applications
The Color Settings dialog box represents the common color management controls shared 
by several Adobe applications, including InDesign 2.0, Photoshop 6.0, and Adobe Illus-
trator 9.0 and later. If you modify and then save over the current color settings file in any 
application other than InDesign, you may be prompted to synchronize the common 
color settings upon starting InDesign, or upon reopening the Color Settings dialog box 
in InDesign. 

Synchronizing the color settings helps to ensure that color is reproduced consistently in 
Adobe applications that share the Color Settings dialog box. To share custom color 
settings between applications, be sure to save and load the settings file in the desired 
applications. (See “Saving and loading custom color management settings” on page 348.)

Soft-proofing colors
In a traditional publishing workflow, you print a hard proof of your document to preview 
how its colors will look when reproduced on a specific output device. In a color-managed 
workflow, you can use the precision of color profiles to soft-proof your document 
directly on the monitor. You can display an on-screen preview of how your document’s 
colors will look when reproduced on a particular output device.
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Keep in mind that the reliability of the soft proof is highly dependent upon the quality of 
your monitor, your monitor profile, and the ambient lighting conditions of your 
workstation. For information on creating a monitor profile, see “Creating an ICC monitor 
profile” on page 353.

Note: Viewing objects in high resolution in a color-managed document requires more 
system memory and involves greater rendering time.

To display a soft proof:

1 Make sure that color management is on, and then choose Edit > Preferences > Display 
Performance (Windows and Mac OS 9), or InDesign > Preferences > Display Performance 
(Mac OS 10.1)

2 Set the highest-quality view settings to ensure that all graphics and transparent areas 
use real source information, not proxy information, for display:

• Choose High Quality in the Default View Settings menu.

• Drag the sliders for Raster Images, Vector Graphics, and Transparency all the way to 
the right.

• Make sure that Enable Anti-Aliasing is checked, and Greek Type Below is set to 0 pt. 

• Click OK.

3 Choose View > Proof Setup, and choose the output display that you want to simulate:

• Custom, to soft-proof colors as displayed on a specific output device. Then follow the 
instructions outlined in the next procedure to set up the custom proof.

• Document CMYK, to soft-proof colors using the document’s CMYK color model as the 
proof profile space that you want to simulate.

• Working CMYK, to soft-proof colors using your current working CMYK color space as the 
proof profile space.

4 Choose View > Proof Colors to toggle the soft-proof display on and off. When soft 
proofing is on, a checkmark appears next to the Proof Colors command.

To create a custom proof setup:

1 Choose View > Proof Setup > Custom.

2 In the Proof Setup dialog box, for Profile, choose the color profile for the device for 
which you want to create the proof.

3 Do one of the following to determine the rendering intent for converting colors from 
the proofing (target device) space to the monitor:

• Select Paper White to simulate Absolute Colorimetric rendering intent to a D50-based 
LAB space, and then Relative Colorimetric without black-point compensation to the 
monitor. Selecting this option automatically selects Ink Black.

• Select Ink Black to simulate Relative Colorimetric rendering intent without black-point 
compensation to the monitor. 

• Deselect both options to use Relative Colorimetric with black-point compensation 
when converting colors to the proof profile space. 

Both options are dimmed if the selected profile doesn’t support these features. For more 
information, see “Specifying a rendering intent” on page 347, and “Using black-point 
compensation” on page 347. 
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4 Click OK.

Changing the color profile of a document
In some cases you may want to assign a different color profile to a document with an 
existing profile, remove the existing profile altogether, or convert a document's colors to a 
different color profile. For example, you may want to prepare the document for a different 
output destination, or you may want to correct a policy behavior that you no longer want 
implemented in the document. The Assign Profiles and Convert to Profile commands are 
recommended only for advanced users.

When using the Assign Profiles command, you may see a shift in color appearance as color 
numbers are mapped directly to the new profile space. Convert to Profile, however, shifts 
color numbers before mapping them to the new profile space, in an effort to preserve the 
original color appearances.

To reassign or discard the profile of a document:

1 Make sure that color management is on, and then choose Edit > Assign Profiles.

2 For RGB Profile and CMYK Profile, select one of the following:

• Discard (Use Current Working Space), to remove the existing profile from the document 
and use the working space profile for that color model.

• Assign Current Working Space <working space>, to embed the working space profile in 
a document that uses either no profile, or a profile different from the working space. 

• Assign Profile, to embed a different profile in a color-managed document. Choose the 
desired profile in the menu. InDesign embeds the new profile in the document without 
converting colors to the profile space.

3 Choose a rendering intent for each type of graphic in your document. For each graphic 
type, you can choose one of the four standard intents, or the Use Color Settings Intent, 
which uses the rendering intent currently specified in the Color Settings dialog box. For 
information on the standard intents, see “Specifying a rendering intent” on page 347. The 
graphic types include the following:

• Solid Color Intent sets the rendering intent for all vector art (solid areas of color) in 
InDesign native objects. 

• Default Image Intent sets the default rendering intent for raster images placed in 
InDesign. You can still override this setting on an image-by-image basis. (See “Viewing 
and changing profile settings for individual images” on page 360.)

• After-Blending Intent sets the rendering intent to the proofing or final color space for 
colors that result from transparency interactions on the page. Use this option when 
your document includes transparent objects.

4 To preview the effects of the new profile assignment in the document, select Preview, 
and then click OK.

To convert colors in a document to another profile:

1 Choose Edit > Convert to Profile.

2 Under Destination Space, choose the color profiles to which you want to convert the 
document's colors. The document will be converted to and tagged with these new profiles. 
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3 Under Conversion Options, specify a color management engine, a rendering intent, and 
a black-point option. For more information, see “Customizing advanced color 
management settings” on page 346.

4 To preview the effects of the conversion in the document, select Preview, and then 
click OK.

Embedding profiles in saved documents
By default, a document for which you have specified color management will have its 
profiles embedded when you save it in the native InDesign format (.indd). Profiles are not 
saved by default in non-color-managed documents. 

If color management is on, you can also embed profiles in the PDF files you export from 
InDesign. When you export a color-managed InDesign document to Adobe PDF, any 
version 4 ICC profiles used as working space profiles or embedded in placed images or 
PDF files will be converted to colorimetrically similar version 2 ICC profiles. If you select the 
Include ICC Profiles option to embed profiles in your Adobe PDF file, InDesign embeds the 
version 2 profiles into the Adobe PDF file. This conversion maintains compatibility with 
other products that may not yet support version 4 ICC profiles. The converted version 2 
profiles will provide the same color quality as the version 4 profiles.

For information on how to embed profiles when you export an InDesign document to PDF, 
see “Tagging colors with ICC profiles” on page 372. For information on how InDesign 
handles placed PDF files in a color-managed document, see “Preparing PDF files” on 
page 358.

Note: You can change or discard an embedded profile before saving a document, but you 
cannot change the default behavior to embed or not to embed profiles as you save a 
document. (See “Changing the color profile of a document” on page 350.)

Obtaining, installing, and updating color profiles
Precise, consistent color management requires accurate ICC-compliant profiles for all of 
your color devices. For example, without an accurate scanner profile, a perfectly scanned 
image may appear incorrect in another program, due simply to the difference between 
the scanner’s gamut and that of the program displaying the image. This misleading repre-
sentation may cause you to make unnecessary, time-wasting, and potentially damaging 
“corrections” to an already satisfactory image. With an accurate profile, a program 
importing the image can correct for any gamut differences and display a scan’s 
actual colors.

Once you obtain accurate profiles, they will work with all applications that are compatible 
with your color-management system. You can obtain profiles in the following ways, with 
the most precise methods noted first:

• Generate profiles customized for your specific devices, using professional 
profiling equipment.

• Obtain a profile created by the manufacturer. Unfortunately, such profiles do not 
account for individual variations that naturally occur among machines (even identical 
models from the same manufacturer) or with age.
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• Substitute an available profile that may be appropriate, given the information you have 
about the device’s gamut. For example, many Mac OS scanners have been optimized 
for an Apple RGB monitor gamut, so you might try using an Apple monitor profile for 
these devices. Be sure to proof images created with the profile before using the profile 
in production; this workaround is unlikely to produce results suitable for professionally 
color-managed work.

Adding device profiles to the color management system
The InDesign installer lets you choose from manufacturer-supplied device profiles for 
some commonly used equipment. This is useful if you don’t have access to hardware-
based calibration tools. It is not possible for the installer to supply profiles for all devices. If 
the installer did not install a profile for your device, create one, or contact the device 
manufacturer to obtain one.

To minimize the potential for confusion when you’re working with profiles, delete any 
profiles for devices you or your workgroup aren’t using.

In Mac OS, you can organize the ColorSync Profiles folder by creating additional 
folders within it, or by adding aliases to other folders.

To add profiles to your system:

Do one of the following:

• In Windows NT 4.0, copy profiles into the WinNT\System32\Color folder.

• In Windows 2000, copy profiles into the WinNT\System32\spool\drivers\color folder.

• In Windows 98, copy profiles into the Windows\System\Color folder.

• In Mac OS 9, copy profiles into the ColorSync Profiles folder in the System Folder 
(ColorSync 2.5 or later), or System Folder/Preferences/ ColorSync™ Profiles (ColorSync 
versions earlier than 2.5).

• In Mac OS 10.1, copy profiles into either of two locations, depending on your require-
ments.The main location is <OSX Disk> Library/ColorSync/Profiles. If you want your 
profiles to be seen only by you, copy them into <OSX Disk> / Users/<user>/Library/
ColorSync/Profiles.

Note: If you use ColorSync 2.5 but have also used earlier versions, some profiles may still 
be stored in System Folder/Preferences/ColorSync Profiles on your hard disk. For compati-
bility with ColorSync 2.5 or later, store profiles in the ColorSync Profiles folder in the 
System Folder.

Updating profiles
The color reproduction characteristics of a color device change as the device ages, so 
recalibrate it periodically, and generate updated profiles. Profiles should be good for 
approximately a month, depending on the device. Some monitors automatically 
compensate for phosphor aging.

Also, be sure to recalibrate a device when you change any of the factors that affect 
calibration— for example, when you change the room lighting or the monitor 
brightness setting.
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Creating an ICC monitor profile
Your monitor will display color more reliably if you use color management and maintain 
accurate ICC monitor profiles. A monitor calibration utility lets you calibrate and charac-
terize your monitor to a standard, and then save the settings as an ICC-compliant profile 
available to any program that uses your color management system. This calibration helps 
you eliminate any color cast in your monitor, makes your monitor grays as neutral as 
possible, and standardizes image display across different monitors.

Note: InDesign 2.0 automatically installs Adobe Gamma into your Windows Control 
Panel. In Mac OS, you can use the Apple monitor calibration utility to create a ColorSync 
profile, or you can use a recent version of Adobe Gamma that was installed with another 
Adobe product, such as Photoshop.

Although software calibration utilities are effective calibration and profiling tools, 
hardware-based utilities are more precise. If you have a hardware-based utility that can 
generate an ICC-compliant profile, you should use that one instead of the Adobe Gamma 
or Apple monitor calibration utility. 

Depending on your workflow scenario, an ICC monitor profile can be either a source 
profile, a destination profile, or both.

Note: Adobe Gamma can characterize, but not calibrate, monitors used with Windows NT 
4.0; the ICC profile you create with Adobe Gamma can be used by Adobe applications as 
the system-level profile in Windows NT 4.0. Its ability to calibrate settings in Windows 98, 
Windows 2000, Windows Me, and Windows XP depends on the video card and video driver 
software. In such cases, some calibration options documented here may not be available.

Calibrating versus characterizing 
a monitor
Such profiling software as Adobe Gamma can both characterize and calibrate your 
monitor. When you characterize your monitor, you create a profile that describes how the 
monitor is currently reproducing color. When you calibrate your monitor, you bring it into 
compliance with a predefined standard. Adjusting your monitor to the graphic-arts 
standard white-point 5000 Kelvin is an example of calibration.

Determine in advance the standard to which you are calibrating, so that you can enter the 
set of values for that standard. Coordinate calibration with your workgroup and prepress 
service provider to make sure that you’re all following the same standard.

About monitor calibration settings
Monitor calibration involves adjusting video settings. A monitor profile uses these 
settings to precisely describe how your monitor reproduces color.

Brightness and contrast The overall level and range, respectively, of display intensity. 
These parameters work just as they do on a television set. A monitor calibration utility 
helps you set an optimum brightness and contrast range for calibration.

Gamma The brightness of the midtone values. The values produced by a monitor from 
black to white are nonlinear—if you graph the values, they form a curve, not a straight 
line. Gamma defines the value of that curve at halfway between black and white. Gamma 
adjustment compensates for the nonlinear tonal reproduction of such output devices as 
monitor tubes.
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Phosphor The luminescent substance that monitors use to emit light. Different 
phosphors have different color characteristics.

White point The RGB coordinates at which full-intensity red, green, and blue 
phosphors create white.

Guidelines for creating an ICC monitor profile
The following guidelines can help you create an accurate monitor profile.

 Keep your monitor’s user guide handy while using a monitor calibration utility.

• Calibrate your monitor regularly, using an ICC-compliant calibration utility; your 
monitor’s colors will shift over time.

• If you have the Mac OS Gamma control panel (included with Adobe Photoshop 4.0 and 
earlier) or the Monitor Setup utility (included with PageMaker 6.0) for Windows, remove 
it; it is obsolete. Use the latest Adobe Gamma utility instead.

• Make sure that your monitor has been on for at least half an hour. This gives it sufficient 
time to warm up, for a more accurate color reading.

• Make sure that your monitor displays thousands of colors or more.

• Remove colorful background patterns on your monitor desktop. Busy or bright patterns 
surrounding a document interfere with accurate color perception. Set your desktop 
to display neutral grays only, using RGB values of 128. For more information, refer to the 
manual for your operating system.

• If your monitor has digital controls for choosing the white point from a range of preset 
values, set those controls before starting the calibration tool. Later, in the calibration 
utility, you’ll set the white point to match your monitor’s current setting. Be sure to set 
the digital controls before you start the calibration utility. If you set them after you 
begin the calibration process in the utility, you’ll need to begin the process again.

• Monitor performance changes and declines over time; recharacterize your monitor 
every month or so. If you find it difficult or impossible to calibrate your monitor to a 
standard, it may be too old and faded.

Calibrating with Adobe Gamma
The ICC profile you get by using Adobe Gamma uses calibration settings to describe how 
your monitor reproduces color. For more information on using Adobe Gamma, see the 
technical guides in the Support area of adobe.com.

To use Adobe Gamma:

1 In Windows, double-click Adobe Gamma, located in the Control Panel (Start > 
Settings > Control Panel). 

Note: If a recent version of Adobe Gamma exists on your Mac OS system, you can start it in 
the Apple menu. Choose Control Panels > Adobe Gamma.

2 Do one of the following:

• To use a version of the utility that guides you through each step, select Step by Step, 
and click OK. This version is recommended if you’re inexperienced. If you choose this 
option, follow the instructions described in the utility. Start from the default profile for 
your monitor, if available.
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• To use a compact version of the utility with all of the controls in one place, select 
Control Panel, and then click OK. This version is recommended if you’re experienced 
in creating color profiles.

Any time you’re working in the Adobe Gamma control panel, you can click the Wizard 
(Windows) or Assistant (Mac OS) button to switch to the wizard for instructions that 

will guide you through the same settings that are in the control panel, one option at 
a time.

Calibrating with the Apple monitor calibration utility
The Apple monitor calibration utility will help you calibrate your monitor and create a 
custom ColorSync profile. For more information on using the calibration utility, see the 
Mac OS Help system.

To use the Apple monitor calibration utility:

1 In the Apple menu, choose Control Panels > Monitors.

2 In the Multiple Scan Display dialog box, click Color, and then click Calibrate.

3 Use the monitor calibration assistant to guide you through each step.

Color-managing documents for online viewing
Color management for online viewing is different from color management for print media. 
With print media, you have far more control over the appearance of the final document. 
With online media, because your document will appear on a wide range of possibly uncal-
ibrated monitors and video display systems, your control over color consistency is signifi-
cantly limited.

When you color-manage a document for both print and online viewing, simply build your 
color management workflow around the requirements of the print version; the limitations 
of online color viewing are probably not surmountable until color management becomes 
common in Web browsers.

Color-managing PDF documents for online viewing
When you export Adobe Portable Document Format (PDF) files from InDesign with color 
management on, you can embed profiles. PDF files with embedded profiles reproduce 
color consistently in Acrobat 4.0 or later software running under a properly configured 
color management system. For information about color management in Acrobat software, 
see Acrobat online Help.

When PDF files are distributed over the World Wide Web, chances are high that they will be 
viewed on uncalibrated monitors. Embedding profiles will not significantly improve your 
changes for successful color reproduction.

Color-managing HTML documents for online viewing
Most Web browsers in use today do not support color management. In addition, few Web 
pages contain images with embedded profiles. If you manage a highly controlled 
environment, such as the intranet of a design studio, you may be able to achieve some 
degree of HTML color management for images by equipping everyone with a browser 
that supports color management, and calibrating all monitors.

If you plan to export your document as HTML, consider the following:
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• Disable color management for any imported images that use adaptive or indexed Web-
safe color palettes. Images that use indexed color palettes (such as Web-safe palettes) 
are like CMYK images in that their color values are already optimized for a specific kind 
of output. 

• Convert RGB and CMYK images to sRGB IEC61966-2.1, the Web standard RGB 
color space. 

Color-managing colors you create in your document
Any color you apply or create within InDesign automatically uses a default source profile 
that corresponds to the color model you used. If you switch color modes, the CMS uses the 
appropriate source profiles to translate the color to the CIE LAB gamut, and then to the 
new color model you choose. You normally won’t need to think about this if you’ve set up 
your default profiles properly.

When defining a process color using a CMS, select your colors from a process color-
matching library. You can ensure that the process colors you specify will be adjusted 
correctly for the press by choosing a CMYK source profile that matches your printing 
conditions. Changing color management settings or profiles can change the final output 
of process colors, because the CMS will adjust the final process color values as necessary.

It can be difficult to exactly reproduce a spot color on a monitor or proofing device, 
because many spot color inks exist outside the gamuts of many of those devices. 
Changing color values or CMS settings never affects the final spot color, because spot 
color inks are premixed. InDesign can color-manage only the density of tints made from a 
spot color.

Preparing imported graphics for color management
Use the following general guidelines when preparing graphics in other programs, so that 
you can color-manage them in your InDesign document.

Preparing RGB and LAB images
For non-CMYK workflows in which RGB or LAB colors are appropriate until final output 
time, use the following guidelines as you prepare RGB and LAB images:

• If the other program can embed ICC-compliant profiles, turn that option on before 
you export.

• If you’re using a vector graphics program that can export to PDF, consider doing so, to 
take advantage of color management. You can also import Adobe Illustrator files in 
their native format.

• To color-manage a bitmap image imported from a program that doesn’t support ICC 
profiles, expect to assign an appropriate profile to the image after you import it into 
your InDesign document. (See “Viewing and changing profile settings for individual 
images” on page 360.) 

• To reuse a color graphic for multiple final output devices or media, such as for print, 
video, and the Web, prepare the graphic using RGB or LAB colors whenever possible. 
If you must save in a color model other than RGB or LAB, keep a copy of the original 
graphic. RGB and LAB color models represent larger color gamuts than most output 
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devices can reproduce; they retain as much color data as possible, and then translate to 
a smaller output color gamut when necessary.

Note: In a print publishing workflow, most prepress service providers will expect final 
graphics to be in CMYK colors.

• If you’re scanning images you intend to use with a CMS, scan using a calibrated scanner 
and scanner driver software that embeds profiles.

Preparing CMYK images
For CMYK workflows where the goal is to obtain the best possible on-screen and 
composite proofs from the CMYK content, use the following guidelines as you prepare 
CMYK images:

• Embed profiles, if they are available. In InDesign, you can always choose not to use them. 
For details, see “Using color management when printing” on page 400, and “Viewing 
and changing profile settings for individual images” on page 360.

• Make sure that the color management settings are identical in the programs used to 
create the images. You can ensure this by saving your custom settings, and then 
loading the file into your active InDesign document. 

When you print, the CMYK values will be preserved, and the on-screen preview will be 
consistent from program to program. With proper monitor profiling, the on-screen colors 
will closely resemble those in the final printed document. 

Preparing Adobe Photoshop 6.0 and later images
Use the following guidelines to prepare Photoshop 6.0 and later for exporting color-
managed images:

• In Photoshop, choose Edit > Color Settings, and make sure that the color management 
settings match those in the rest of your workflow.

• Save or export images using one of the following file formats, which support 
embedded profiles both out of Photoshop 6.0 and later and into InDesign: PSD 
(Photoshop), TIFF, JPEG, and PDF. 

For more information, see the Adobe Photoshop 6.0 User Guide or its online Help.

Preparing Adobe Illustrator 9.0 and 10.0 graphics
Use the following guidelines as you prepare Illustrator 9.0 or 10.0 for exporting color-
managed images:

• In Illustrator, choose Edit > Color Settings, and make sure that the color management 
settings match those in the rest of your workflow.

• Save or export the artwork using one of the following file formats, which support 
embedded profiles both out of Illustrator and into InDesign: AI (Adobe Illustrator), TIFF, 
JPEG, and PDF. 

For more information, see the Adobe Illustrator 9.0 or 10.0 User Guide or its online Help.
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Preparing EPS files
InDesign can properly color manage placed EPS files from Photoshop, provided they were 
saved with PostScript color management. PostScript color management embeds the color 
data as PostScript-equivalent color space arrays (CSAs), which InDesign uses for on-screen 
display and printing. Using the CSAs, InDesign can display and print a file as it appeared in 
Photoshop, provided you use the same profiles and CMS settings in both InDesign and 
Photoshop. 

Important: Be sure you thoroughly understand the implications of using a PostScript 
color-managed output workflow before you prepare EPS files for your InDesign layout. 
PostScript color management sends the document’s color data, along with the source 
space profile, directly to a printer, and the printer manages the colors. Because of this, the 
exact results of the color conversion can vary among printers. 

For more information on using PostScript color management in Photoshop, see the Adobe 
Photoshop 6.0 User Guide or its online Help.

Preparing PDF files
If you create PDF files that you intend to place in your color-managed InDesign document, 
be sure to turn on color management and embed profiles. If a PDF file contains embedded 
profiles, InDesign can color-manage the display and printing of that file. However, you 
cannot use InDesign to change the profiles embedded in PDF files.

When a PDF file does not contain embedded profiles, InDesign can display and print the 
file as it appeared in the program that created it, if that program supports color 
management and you use the same profiles and CMS settings in both InDesign and the 
other program. However, this method cannot account for individual images contained 
within a file, each of which may require different profiles.

Photoshop, Adobe Illustrator, and Adobe Acrobat Distiller 4.0 and later can embed a 
profile for each image in a PDF document. InDesign recognizes and uses these image-
specific profiles.

Color-managing converted QuarkXPress or PageMaker files
When you convert QuarkXPress or PageMaker documents, ICC-compliant profiles 
embedded in images contained in the converted document are preserved, and treated as 
if placed directly into a new InDesign document. This means you can use the Image Color 
Settings command to control profile settings for those images. Profiles that are not ICC-
compliant will be replaced using the default CMS settings and profiles you specified for 
InDesign.

Color-managing colors imported using the Clipboard
When you import colors by pasting them from another InDesign document, InDesign 
applies to the colors the color management policies specified in the Color Settings 
dialog box.

When you paste content from a program other than InDesign, the colors are treated as if 
they were created using the source profile of the receiving document. This is because it is 
not common for programs to embed profiles in Clipboard data.
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Importing images into a color-managed document
When you import an image, you can control how it is color-managed in your document. If 
you know that an imported image contains an accurate embedded profile, just import it 
and continue working. InDesign reads the embedded profile and applies it to the image. 
In addition, InDesign applies the document’s default rendering intent, which is the 
rendering intent specified in the color settings file, rather than the one embedded with 
the image. You can change the color profile or rendering intent of the imported image. 
(See “Viewing and changing profile settings for individual images” on page 360.)

About importing images without embedded profiles
When you import an image that you know contains no profile, you have two choices:

• Do nothing. InDesign applies the appropriate default source profile selected in the 
Color Settings dialog box. This works well only if you know that the images were 
created using the same color space described by your default profiles.

• View, override, or disable the graphic’s current color management settings. You can do 
this using the Image Color Settings dialog box as you place the graphic, or at any time 
directly on the layout.

Color-managing scanned images
When you receive a CMYK scan, a scanner operator has converted the image from RGB to 
CMYK using a color lookup table. Use the following guidelines as you prepare scanned 
images:

• If the image has an embedded profile, use it for soft-proofing and controlling color in 
the document.

• If the image doesn’t have an embedded profile, use the document’s default profile.

• If the image’s source profile differs from your destination profile, and you don’t want to 
convert the CMYK color values at print time, you may want to turn off color 
management. You can turn off color management, either globally at print time or 
individually for selected images. For details, see “Using color management when 
printing” on page 400, and “Viewing and changing profile settings for individual 
images” on page 360.

Resolving profile conflicts
If you import an image saved with an embedded profile that has the same name as a 
profile already in your document, InDesign gives priority to the profile originally 
embedded in the image.

For example, suppose your document contains a source profile called MonitorD50.icm, 
and you import two images each with a profile also named MonitorD50.icm, and all three 
profiles are different. In this case, each image uses its own unique embedded version of 
the duplicate profile, instead of the InDesign document’s profile.
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Viewing and changing profile settings for individual 
images
You can view or override existing profile settings for an imported image, either when 
you’re importing it or when you’re editing it on the layout. This may become necessary in 
the following situations:

• Importing a graphic containing no profile, or an incorrectly embedded profile. For 
example, if the scanner manufacturer’s default profile was embedded, but you have 
since generated a customized profile, you can assign the newer profile.

• Applying profile settings that differ from your default settings, such as applying the 
Relative Colorimetric rendering intent to a solid-color bitmap image when your 
document default for images is Perceptual.

Note: Disabling color management for an image prevents color management from 
adjusting both the image’s appearance on your monitor and the final output.

To view or change an imported graphic’s color management settings:

1 Do one of the following:

• If the graphic is on the layout, select it, and then choose Object > Image Color Settings.

• If you’re about to import the graphic, choose File > Place, select Show Import Options, 
locate and select the file, and click Place. Then click Color Settings on the left side of the 
Image Import Options dialog box that appears.

2 Select Enable Color Management to apply color management to the image, or deselect 
it to exclude the image from color management.

3 For Profile, choose the source profile to apply to the graphic in your document:

• If a profile is currently embedded, the Profile menu in the Import Options dialog box 
reads “Use Embedded Profile.” In the Image Color Settings dialog box, the profile is 
displayed by name.

• If no profile is embedded, the menu reads “Use Document Default” and the image uses 
the default source profile for its color model.

This option is not available if Enable Color Management is deselected.

4 For Rendering Intent, choose a rendering intent. Your document’s default rendering 
intent is always displayed, unless you’ve overridden it using this option. This option is not 
available if Enable Color Management is deselected.

5 Click OK to close the dialog box.
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Creating Adobe PDF Files

Exporting a document or book to Adobe PDF
Exporting a document or book to Adobe PDF is as simple as using the default [Press] 
settings, or as customized as you need it to be to suit your task. The Adobe PDF export 
settings you specify are saved with the application, and will apply to every new InDesign 
document or book you export to Adobe PDF until you change them again. To quickly 
apply custom settings to Adobe PDF files, you can use styles.

You can export a document, a book, or selected documents in a book as a single Adobe 
PDF file. You can also copy content from your InDesign layout to the Clipboard, and 
automatically create an Adobe PDF file of that content. This is useful for pasting a PDF file 
into another application, such as Adobe Illustrator.

To export an open document to Adobe PDF:

1 Choose File > Export.

2 For Save as Type (Windows) or Formats (Mac OS), choose Adobe PDF. Type a filename, 
choose a location for the file, and click Save.

3 To view or change existing settings, click the panel names on the left side of the Export 
PDF page. 

4 Click Export.

To export a book to Adobe PDF:

Depending on whether or not documents are selected in the Book palette, choose Export 
Book to PDF or Export Selected Documents to PDF in the Book palette menu.

To export selected documents in a book:

1 Select a document or documents in the Book palette.

2 Choose Export Selected Documents to PDF in the palette menu. 

To export an Adobe PDF file using a PDF export style:

1 Choose File > Export.

2 Specify a location and name for the file, choose Adobe PDF in the Formats menu, and 
then click Save (Windows) or Export (Mac OS).

3 Choose a style in the Style menu, and then click Export.

For more information on Adobe PDF styles, see “Using Adobe PDF export styles” on 
page 364.



Using Help | Contents | Index Back 362  

Adobe InDesign Help Creating Adobe PDF Files 

Using Help | Contents | Index Back 362  

Producing Adobe PDF files for a high-resolution 
composite workflow
Using InDesign, you export your document to a composite Adobe PDF file called a digital 
master. These digital masters are compact, reliable files that you or your service provider 
can view, edit, organize, and proof. Then, at the appropriate time in the workflow, your 
service provider can either output the Adobe PDF file directly, or process it using tools 
from various sources for such post-processing tasks as preflight checks, trapping, 
imposition, and color separation.

Recommended tools for print publishing
In a typical print publishing workflow, documents are distributed in the format of the 
authoring application (called the native format). Once approved, the files are saved in 
PostScript or a proprietary format for prepress work and final printing. Because applica-
tions generate PostScript in so many different ways, PostScript files may be arbitrarily large 
and complex. In addition, such reliability problems as missing fonts, corrupt files, missing 
graphics elements, and unsupported features at output time can result in output 
problems.

In response, Adobe and its partners are working to create a reliable publishing workflow 
solution. Adobe is continually addressing the workflow needs of service providers, and 
recommends that you visit the Adobe Web site at www.adobe.com often for the latest 
developments. Currently, Adobe addresses publishing workflow needs by providing an 
integrated system of several technologies:

• Adobe Acrobat 5.0 software, with its support for Adobe PDF version 1.4.

• Adobe PostScript 3 printing technology, for device-independent support, Adobe In-RIP 
Trapping, in-RIP color separations, and smooth blends.

• Adobe Extreme™, which combines options for direct Adobe PDF output.

• Adobe InDesign, with its high-resolution page layout capabilities and direct Adobe PDF 
processing.

Switching to an Adobe PDF workflow
Many large publishers use Adobe PDF to streamline their review and production cycles. 
For example, numerous magazines and newspapers have adopted Adobe PDF as the 
standard format for delivering ads to local publishing offices via satellite or ISDN lines. 
Adobe PDF enables local publishers to instantly view an ad exactly as it was designed, 
make late-stage text edits, and reliably print from any computer.

A high-resolution composite Adobe PDF workflow typically includes a PostScript 3 output 
device whose RIP supports in-RIP separations. Therefore, if your output device uses 
PostScript Level 2 or does not support in-RIP separations, use a preseparated PostScript 
printing workflow. (See “Two common print workflows” on page 414.)

To produce Adobe PDF files for a high-resolution composite workflow:

1 Prepare the document for exporting to Adobe PDF.

2 Export using the [Press] style—the default Adobe PDF style for high-resolution output.

3 Proof and correct the Adobe PDF file.

4 Hand off the press-optimized Adobe PDF file to the prepress service provider.
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Checking your document before exporting
Before creating an Adobe PDF file to send to a service provider, make sure that the 
InDesign document meets your service provider’s specifications. The following list offers 
some recommendations:

• Use the Preflight feature to check fonts, links, graphics, and other information. (See 
“Performing a preflight check” on page 406.)

• View your Adobe PDF export settings prior to exporting, and then adjust them as 
necessary. You may be able to use the predefined Adobe PDF style, called “Press,” when 
you export your InDesign document. (See “Viewing a summary of Adobe PDF export 
settings” on page 374.)

• If your document uses transparent objects or effects, check the flattener settings in the 
flattener style you intend to use. (See “Controlling flattener settings and results using 
styles” on page 294. Also review the issues in the topic “Exporting transparency infor-
mation” on page 373.)

• If your service provider uses a PostScript Level 2 RIP and your document contains DCS 
files, colorized TIFF images, or duotone EPS files created from a version of Photoshop 
earlier than 5.0.2, either change the graphics in the document or create a preseparated 
PostScript file. Otherwise, the exported composite Adobe PDF file won’t include the 
information necessary for color separation, and all colors will print on the black plate.

• Use only high-resolution images in your document. 

• For best results, use only CMYK images in a four-color-process job. Alternatively, you 
can convert RGB images (except those in placed Adobe PDF files) to CMYK in the 
Advanced panel of the Export PDF dialog box.

Proofing and correcting a high-resolution composite Adobe 
PDF file
PostScript color printers can generate good preliminary color proofs. Composites from a 
desktop color printer help you to verify bitmap image resolution and preview overall page 
design and color relationships. However, unless you create color proofs using a profes-
sional printing and proofing tool, these composites may not reveal some common press 
problems, such as a pattern of interference lines called a moire pattern. 

If you’re using a color-managed workflow, you can use the precision of color profiles to 
perform an on-screen preview (a soft proof ). You can examine how your document’s colors 
will look when reproduced on a particular output device. (See “Soft-proofing colors” on 
page 348.)

Note: Unless you are using a color management system (CMS) with accurately calibrated 
ICC profiles and are sure you have properly calibrated your monitor, don’t rely on the on-
screen appearance of colors.

You or your service provider can do simple last-minute editing and touch-up on text and 
graphics in Acrobat 5.0. If a document requires more extensive editing, update the 
InDesign document and export it again to Adobe PDF. 

Handing off a print-ready Adobe PDF file to a service provider
A service provider uses prepress applications and in-RIP technologies to perform preflight 
checks, do trapping and imposition, and make the color separations of the pages in the 
digital master. 
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If you choose to leave out the images when creating the Adobe PDF file, make sure that 
the service provider has access to the original high-resolution images that are required for 
proper output. (See “Setting advanced options for color, fonts, graphics, and trans-
parency” on page 371.) In addition, make sure that the service provider has Acrobat 
Reader 4.0 or later for accurate viewing of text and color graphics. For best viewing, they 
should use Acrobat 5.0.

Preparing a document for on-screen viewing
With its small file sizes, platform independence, and online navigation, Adobe PDF is an 
ideal format for distributing documents electronically and viewing them on-screen. You 
can send Adobe PDF documents to other users as e-mail attachments, or you can 
distribute the documents on the World Wide Web or on an intranet.

The following guidelines apply to electronically distributed Adobe PDF files:

• Before putting Adobe PDF documents on a Web site, check to see that the text, artwork, 
and layout in the documents are complete and correct. 

• Set up passwords and other security options.

• Use a filename of no more than eight characters, followed by an extension of up to 
three characters. Many networks and e-mail programs shorten long filenames.

• Make sure that the filename has a .pdf extension if users will view the file on a Windows 
computer or on the Web.

• To apply default Adobe PDF export settings for on-screen viewing, choose [Screen] in 
the Style menu in the Export PDF dialog box. For more information on styles, see “Using 
Adobe PDF export styles” on page 364.

• Resolve printed page numbering with online page numbering if you intend to send the 
file via e-mail or the Web. For example, if your InDesign document contained front 
matter, such as a copyright page and table of contents, the body pages might not 
follow the numbering shown in the Acrobat status bar. Refer to your Acrobat 5.0 
documentation for details on how to renumber the pages. 

Note: Adobe PDF files exported from InDesign take advantage of such Acrobat features as 
support for ICC profiles for color management; smooth shading, for better representation 
of gradients; and links and bookmarks, for navigation. Therefore, to accurately view an 
Adobe PDF file from InDesign, you must use Acrobat Reader 4.0 or later. 

Using Adobe PDF export styles
You can easily automate Adobe PDF output jobs by saving all output settings as an Adobe 
PDF export style.
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About predefined Adobe PDF styles
For your convenience, InDesign includes four predefined styles for creating Adobe PDF 
files. The settings in these styles are designed to balance file size with quality, depending 
on how the Adobe PDF file is to be used. You can also create Adobe PDF styles with 
custom settings.

Check your InDesign Adobe PDF settings periodically using the Summary panel in the 
Export PDF dialog box. InDesign always uses the settings from the last PDF export; it 

doesn’t automatically revert to the default settings. 

eBook Creates Adobe PDF files that will be read primarily on-screen—on desktop or 
laptop computers or eBook readers, for example. This set of options balances file size 
against image resolution to produce a relatively small, self-contained file; compresses all 
information; converts all colors to RGB, or to Monitor RGB (if color management is 
enabled); and embeds subsets of all fonts used in the file (except the Base 14 fonts). Adobe 
PDF files created with the eBook options are compatible with Acrobat 5.0, and Adobe 
eBook Reader 2.2 and later.

Screen Creates compact Adobe PDF files that will be displayed on the World Wide Web or 
an intranet, or that will be distributed through an e-mail system for on-screen viewing. 
This set of options uses compression, downsampling, and a relatively low resolution to 
create an Adobe PDF file that is as small as possible; converts all colors to RGB, or to 
Monitor RGB (if color management is enabled); embeds subsets of all fonts used in the file 
(except the Base 14 fonts); maintains compatibility with Acrobat 4.0 and later; and 
optimizes files for byte serving.

Print Creates Adobe PDF files that are intended for desktop printers, digital copiers, and 
CD-ROM publishing; you can also send them to clients as publishing proofs. In this set of 
options, file size is still important, but it is not the only objective. This set of options uses 
compression and downsampling to keep a file size down; leaves colors unchanged; 
embeds subsets of all fonts used in the file; and prints at medium resolution to create a 
reasonably accurate rendition of the original document.

Press Creates Adobe PDF files that will be printed to imagesetters or platesetters as high-
quality final output. In this case, file size is not a consideration. The objective is to maintain 
all of the information in an Adobe PDF file that a commercial printer or service provider 
will need to print the document correctly. This set of options leaves color unchanged; 
embeds all fonts used in the file; prints at a higher resolution; and uses other settings to 
preserve the maximum amount of information contained in the original document.

Note: Before creating an Adobe PDF file to send to a commercial printer or service 
provider, check with the provider to find out what the output resolution and other settings 
should be. You may need to customize the export settings for a particular provider, and 
then provide them with a style file.

Creating custom Adobe PDF styles
You can create and save Adobe PDF styles, making it easy to back them up or to make 
them available to your service providers, clients, or others in your workgroup. You can edit 
existing styles (except the four predefined styles), and load existing styles for use in your 
InDesign document.

To open the PDF Styles dialog box:

Choose File > PDF Styles.
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To create or edit Adobe PDF styles:

1 In the PDF Styles dialog box, do one of the following:

• To create a new style, click New, and type a name.

• To change an existing custom style, double-click the file in the list, or select the file and 
click Edit.

2 Specify export settings as necessary in any of the panels listed in the menu under the 
name, and then click OK. The options available in the panels are the same as those in the 
Export PDF dialog box, except for the Security options; for more information, see “Adding 
security to Adobe PDF files” on page 374.

To rename or delete Adobe PDF styles:

1 In the PDF Styles dialog box, do one of the following:

• To rename an existing style, select a style in the list, click Edit, type a new name, and 
then click OK.

• To delete styles, select one or more styles in the list, click Delete, and then click OK to 
confirm the deletion.

2 Click OK to close the PDF Styles dialog box.

To save Adobe PDF styles:

1 In the PDF Styles dialog box, select one or more styles in the list to save.

2 Click Save. Specify a name and location, and then click Save.

To load existing Adobe PDF styles:

1 In the PDF Styles dialog box, click Load.

2 Locate and double-click the PDF file you want to load, or select the file and click Open.

Setting general Adobe PDF options
The General options allow you to specify an Acrobat version for file compatibility and 
other file and device settings. You can create Adobe PDF files that are compatible with 
Acrobat 4.0 or 5.0. Your choice determines whether some effects, such as overprint, 
preview correctly.

To set general Adobe PDF options:

1 Click General on the left side of the Export PDF dialog box. 

2 Choose a page or page range option:

All Exports all pages in the current document or book. This is the default setting.

Range Specifies the range of pages to export in the current document. You can type a 
range by using a hyphen, and separate multiple pages or ranges by using commas. This 
option is unavailable when you’re exporting books.

Spreads Exports pages together as if they were bound, or printed on the same sheet. You 
can export only one spread per sheet.

Important: Do not select Spreads for commercial printing; if you do, the service provider 
cannot impose the pages.
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3 Determine which version of Adobe Acrobat to use. Select Acrobat 5.0 to preserve trans-
parency, text, and spot colors in the artwork, if the file is placed in another application 
(such as Adobe InDesign or QuarkXPress).

4 Select any of the following options:

Generate Thumbnails Creates a thumbnail image for each page being exported, or one 
thumbnail for each spread if the Spreads option is selected in the General panel. Thumb-
nails increase file size.

Optimize for Fast Web View Optimizes an Adobe PDF file to reduce file size. InDesign 
restructures the file to prepare for page-at-a-time downloading (byte serving) from Web 
servers. This option compresses text and line art, overriding what you have selected in the 
Compression settings. This makes for faster access and viewing when the file is 
downloaded from the Web or a network.

View Adobe PDF after Exporting Opens the Adobe PDF file in Acrobat. For best results, 
use Acrobat 5.0. The Overprint Preview command in Acrobat 5.0 shows on-screen how 
blending, transparency, and overprinting will appear in the PDF document. 

Include eBook Tags Generates an Adobe PDF file that automatically tags elements in the 
story based on a subset of the Acrobat 5.0 tags that InDesign supports. This subset 
includes the recognition of paragraphs, basic text formatting, lists, and tables. For more 
information on tagged PDF files, see “Repurposing Adobe PDF documents” on page 375.

Include Hyperlinks Creates Adobe PDF hyperlink annotations for InDesign hyperlinks, 
table of contents entries, and index entries.

Include Bookmarks Creates bookmarks for InDesign table of contents entries, 
preserving the TOC levels. 

Export Nonprinting Objects Exports objects to which you have applied the Nonprinting 
option in the Attributes palette. 

Export Visible Guides and Baseline Grids Exports margin guides, ruler guides, column 
guides, and baseline grids currently visible in the document. Grids and guides export in 
the same color used in the document.

About compression methods
When exporting to Adobe PDF, InDesign can compress text and line art, and compress and 
resample color, grayscale, and monochrome bitmap images. Depending on the settings 
you choose, compression and resampling can significantly reduce the size of an Adobe 
PDF file with little or no loss of detail and precision.

• The Automatic option automatically sets the best possible compression and quality for 
the artwork contained in the document. For most Adobe PDF files, this option produces 
satisfactory results. JPEG is usually applied to 8-bit grayscale images, and to 8-bit, 16-
bit, and 24-bit color images when the images have continuous, smooth tones; ZIP is 
applied to 2-bit, 4-bit, and 8-bit grayscale images, to 4-bit color images and indexed 8-
bit color images, and to 16-bit and 24-bit color images when the images have sharp 
color changes.

• ZIP compression works well for images with large areas of single colors or repeating 
patterns and for black-and-white images that contain repeating patterns. InDesign 
provides 4-bit and 8-bit ZIP compression options. If you use 4-bit ZIP compression with 
4-bit images, or 8-bit ZIP compression with 4-bit or 8-bit images, the ZIP method is 
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lossless; that is, data is not removed to reduce file size, and therefore image quality is 
not affected. Using 4-bit ZIP compression with 8-bit data can affect the quality, 
however, because data is lost.

• JPEG compression is suitable for grayscale or color images. JPEG is lossy, which means 
that it removes image data and may reduce image quality; however, it works to reduce 
file size with a minimum loss of information. Because JPEG eliminates data, it can 
achieve much smaller files sizes than can ZIP compression.

• CCITT and Run Length compression are only available for monochrome bitmap images. 
CCITT (Consultative Committee on International Telegraphy and Telephony) 
compression is appropriate for black-and-white images and any images scanned with 
an image depth of 1 bit. Group 4 is a general-purpose method that produces good 
compression for most monochromatic images. Group 3, used by most fax machines, 
compresses monochromatic bitmaps one row at a time. Run Length compression 
produces the best results for images that contain large areas of solid black or white. 

About resampling
InDesign can downsample or subsample a bitmap image to reduce the amount of data in 
the image to no more than what an output device requires. You should resample bitmap 
images when they contain more data than the output device can use, or when the 
exported Adobe PDF file will be used on the Web. For a table showing different output 
resolutions, see “Compressing and resampling images” on page 369. If your images are 
sampled at a higher resolution than the device can use, processing time is increased.

Resampling refers to changing the pixel dimensions (and therefore the display size) of an 
image. When you downsample (decrease the number of pixels), information is deleted 
from the image. When you resample up (increase the number of pixels), new pixels are 
added based on color values of existing pixels.You specify an interpolation method—
average downsampling, subsampling, or bicubic downsampling—to determine how 
pixels are added or deleted.

• Downsampling averages the pixels in a sample area, and then replaces the entire area 
with the average pixel color at the specified resolution.

• Subsampling chooses a pixel in the center of the sample area, and then replaces the 
entire area with that pixel at the specified resolution. Subsampling significantly reduces 
processing time compared with downsampling, but results in images that are less 
smooth. Subsampling is not recommended for high-resolution printing.



Using Help | Contents | Index Back 369  

Adobe InDesign Help Creating Adobe PDF Files 

Using Help | Contents | Index Back 369  

• Bicubic downsampling uses a weighted average to determine pixel color, and usually 
yields better results than does the simple averaging method of downsampling. Bicubic 
is the slowest but most precise method, resulting in the smoothest tonal gradations.

A. Before resampling B. After downsampling C. After subsampling D. After bicubic downsampling

Note: Usually, InDesign can only downsample, not resample up. However, if the document 
contains transparent objects, the flattener may be able to upsample the images. The 
resolution to which the flattener upsamples or downsamples is controlled by using 
flattener styles. For more information, see “Controlling flattener settings and results using 
styles” on page 294.

Compressing and resampling images
Compression and resampling can significantly reduce the size of an Adobe PDF file, but 
can also degrade image quality. However, it doesn’t affect the quality of text and line art. 
You may want to experiment with these options to find an appropriate balance between 
file size and image quality.

Note: Before setting compression options, check with your service provider for recom-
mended settings.

To resample color or grayscale images:

1 Click Compression on the left side of the Export PDF dialog box. 

2 For Color Bitmap Images or Grayscale Bitmap Images, choose a resampling method.

3 Enter a resolution in dots per inch (dpi) that is 1.5 to 2 times the halftone screen 
frequency—the number of lines per inch (lpi) of halftone dots—at which the Adobe PDF 
file will be printed or viewed. 

As long as you don’t go below this recommended resolution setting, images that contain 
no straight lines or geometric or repeating patterns won’t be affected by a lower 
resolution. InDesign resamples all color or grayscale bitmap images in the document 
above that resolution value. 

Note: InDesign has a sampling threshold of 1.5. Because of this threshold, InDesign 
won’t resample an image unless the resolution of the image exceeds 1.5 times the value 
specified here. 

A B C D
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The following table shows common types of printers and their resolution measured in dpi, 
their default screen frequency measured in lines per inch (lpi), and a resampling resolution 
for images measured in pixels per inch (ppi). 

To compress color or grayscale bitmap images:

1 In the Compression panel of the Export PDF dialog box, choose a compression method 
for Color Bitmap Images or Grayscale Bitmap Images. Automatic usually works best for 
high-resolution printing. 

2 Choose a quality setting. Maximum usually works best for high-resolution printing.

To resample monochrome images:

1 Choose Compression in the menu at the top of the Export PDF dialog box.

2 For Monochrome Bitmap Images, choose a resampling method, and enter a resolution 
in dots per inch. InDesign resamples all monochrome bitmap images in the document 
above that resolution value. Use the same resolution as the output device, but do not 
exceed 1500 dpi. Saving a monochrome image at a resolution higher than 1500 dpi 
increases the file size, but does not improve image quality.

Note: Resampling monochrome images can have unexpected viewing results, such as no 
image display. If this happens, use downsampling, or choose No Sampling Change, and 
then export the file again. This problem is more likely to occur with subsampling than with 
downsampling.

To compress monochrome images:

1 Choose Compression in the menu at the top of the Export PDF dialog box. 

2 For Monochrome Bitmap Images, choose a compression method.

To apply compression to text and line art:

Make sure that Compress Text and Line Art is selected. InDesign applies the ZIP 
compression method to all text and line art in an Adobe PDF file. Because the ZIP method 
is lossless, it does not affect quality.

To reduce exported image data:

Make sure that Crop Image Data to Frames is selected. This option may reduce file size by 
exporting only image data that falls within the visible portion of the frame. Don’t select 
this option if post processors might require the additional information (for repositioning 
or bleeding an image, for example).

Printer resolution Default line screen Image resolution

300 dpi (laser printer) 60 lpi 120 ppi

600 dpi (laser printer) 85 lpi 170 ppi

1200 dpi (imagesetter) 125 lpi 240 ppi

2400 dpi (imagesetter) 150 lpi 300 ppi
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Specifying printer’s marks and bleeds
The settings on the Marks and Bleeds panel define the page information service providers 
use to work with your exported page. Selecting any printer’s-mark option expands the 
Adobe PDF file boundaries to accommodate the bleed or page marks. The options are the 
same as in the Print dialog box. (See “Specifying printer’s marks” on page 420.)

Setting advanced options for color, fonts, graphics, and 
transparency
The Advanced panel contains options for converting colors, embedding subsets of fonts, 
omitting graphics for OPI replacement, resolving OPI links in EPS graphics, and managing 
flattening and transparency.

In addition, the Ink Manager is available from this panel. If you make changes to your 
document using the Ink Manager (for example, if you change all spot colors to their 
process equivalents), those changes will be reflected in the exported file, but they won’t 
be saved with the Adobe PDF style. 

Converting colors to the destination color space
The Color settings specify how to represent color information in the exported Adobe PDF 
file. All spot color information is preserved during color conversion; only the process color 
equivalents convert to the designated color space.

InDesign uses the destination profile to describe the gamut of your final RGB or CMYK 
output device, such as your monitor or a SWOP standard. Using this profile, InDesign 
converts the document’s color information (defined by the source profile in the Working 
Spaces section of the Color Settings dialog box) to the color space of the target output 
device. For more information, see “Using predefined color management settings” on 
page 340.

Note: When you export a color-managed InDesign document to Adobe PDF, any version 4 
ICC profiles used as working space profiles or embedded in placed images or PDF files will 
be converted to colorimetrically similar version 2 ICC profiles. If you select the Include ICC 
Profiles option to embed profiles in your Adobe PDF file, InDesign embeds the version 2 profiles 
into the Adobe PDF file. This conversion maintains compatibility with other products that may 
not yet support version 4 ICC profiles. The converted version 2 profiles will provide the same color 
quality as the version 4 profiles.

To convert color objects:

1 In the Advanced panel of the Export PDF dialog box, choose either RGB or CMYK, 
depending on your destination device:

RGB Represents all color values using the red, green, and blue color space. An Adobe PDF 
file with RGB color definitions is better suited for on-screen viewing.

CMYK Creates a separable file by representing all color values using the gamut of cyan, 
magenta, yellow, and black process color inks.

2 Choose a destination profile in the menu.
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Tagging colors with ICC profiles
You can embed profile information for color management at viewing or printing time. 
That way, if the application or output device that uses the Adobe PDF file needs to 
translate colors into another color space, it has the profile information. (See “Embedding 
profiles in saved documents” on page 351.)

To tag colors with ICC profiles:

1 Turn on color management and set up profile information. (See “Turning on and setting 
up color management” on page 339.)

2 In the Advanced panel of the Export PDF dialog box, select the Include ICC 
Profiles option.

To leave color objects in their original color space:

In the Color menu, choose Leave Unchanged. The exported Adobe PDF file will contain the 
same RGB and CMYK images as the original document.

Simulating overprinting (Acrobat 4.0 compatible documents 
only)
Although Acrobat 4.0 doesn’t support overprint preview, you can simulate the overprint 
effect in the exported Adobe PDF document. This enables you to soft-proof your 
document’s colors directly on the monitor before they are reproduced on a particular 
output device. 

Note: Spot colors are not preserved when you simulate overprinting.

To simulate overprinting in Acrobat 4.0 documents:

1 In the General panel of the Export PDF dialog box, choose Acrobat 4.0 for 
Acrobat Compatibility.

2 In the Advanced panel of the Export PDF dialog box, select the Simulate 
Overprint option. 

About font embedding and substitution
InDesign embeds a font only if it contains a setting by the font vendor that permits it to be 
embedded. Embedding prevents font substitution when readers view or print the file, and 
ensures that readers will see the text in its original font. Embedding also allows you to edit 
text in the PDF file, provided you have the font installed on your computer. Note that 
embedding increases file size only slightly, unless the document uses double-byte fonts, a 
font format commonly used for Asian languages.

For each font embedded, InDesign can embed the entire font, or just a subset—the 
special characters called glyphs used in the file. Subsetting ensures that your fonts and 
font metrics are used at print time by creating a custom font name. That way, your version 
of Adobe Garamond, not your service provider’s version, can always be used by the service 
provider for viewing and printing. 

When InDesign cannot embed a font, due to the font vendor’s settings, and someone who 
opens or prints an Adobe PDF file does not have access to the original font, InDesign 
temporarily substitutes a Multiple Master typeface: either AdobeSerMM for a missing serif 
font, or AdobeSanMM for a missing sans serif font.
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The Multiple Master typeface can stretch or condense to fit, to ensure that line and page 
breaks in the original document are maintained. The substitution cannot always match 
the shape of the original characters, however, especially if the characters are unconven-
tional ones, such as script typefaces. The name of the original font is included in the Adobe 
PDF file, so that the font will display correctly if the file eventually has access to the font.

If characters are unconventional (left), the substitution font will not match (right)

Changing font embedding status
You can embed only the glyphs actually typed in the document, based on a threshold 
percentage (the default is 100%). The threshold determines the point at which InDesign 
embeds all characters for a font. For example, if you change the threshold to 35, InDesign 
embeds all characters only if more than 35% of the font’s characters are used in the file; if 
fewer than 35% of the characters are used, InDesign embeds only those characters.

To change font embedding status:

In the Advanced panel of the Export PDF dialog box, type a new percentage for the Subset 
Fonts Below option.

Omitting graphics
The OPI options in the Advanced panel let you selectively omit different imported 
graphics types when sending image data to a printer or file, leaving only the OPI links 
(comments) for later handling by an OPI server. For details, see “Setting common export 
options” on page 251.

Exporting transparency information
Transparent objects you create using InDesign tools are exported differently, depending 
on whether you use Acrobat 4.0 or Acrobat 5.0 compatibility. If you use Acrobat 4.0 
compatibility, InDesign flattens the transparent areas according to the settings in the 
selected flattener style. If you use Acrobat 5.0 compatibility, InDesign preserves the trans-
parent areas in a live and fully editable form. 

For more information on flattening, see the topics described in “Controlling flattener 
settings and results using styles” on page 294. If you intend to produce high-resolution 
output from your Adobe PDF file, consider the issues described in “Setting up your trans-
parent document for successful output” on page 296.

To apply a flattener style:

In the Advanced panel of the Export PDF dialog box, select the flattener style in the 
Styles menu. 
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Adding security to Adobe PDF files
You can restrict access to an Adobe PDF document when you export it. When files use 
security restrictions, any tools and menu items related to those features are dimmed.

An Adobe PDF file can require passwords to open a document (user password) and to 
change security settings (master password). If you set any security restrictions in your file, 
you should also specify a master password; otherwise, anyone who opens the file could 
remove the restrictions. If a file is opened with a master password, the security restrictions 
are temporarily disabled. If the file has both passwords, you can open it with either one.

Note: Adobe PDF styles don’t support passwords and security settings. If you select 
passwords and security settings in the Export PDF dialog box, and then click Save Style, 
the passwords and security settings won’t be preserved.

To add security to Adobe PDF files:

1 Choose File > Export to open the Export PDF dialog box, and then select the 
Security panel.

2 In the Security panel, specify any password protection you want:

• Select Password Required to Open Document and, in the User Password text box, enter 
the password users must enter before they can open the file.

• Select Password Required to Change Permissions and Passwords and, in the Master 
Password text box, enter the password users must enter before they can set or change 
any security options.

Note: You cannot use the same password in both text boxes.

3 Select options to define the level of user actions allowed:

No Printing Prevents users from printing the 
Adobe PDF file.

No Changing the Document Prevents users from filling in forms or making any other 
changes to the Adobe PDF file.

No Content Copying or Extraction, Disable 
Accessibility Prevents users from selecting text and graphics.

No Adding or Changing Notes and Form Fields Prevents users from adding or 
changing notes and form fields if they open the Adobe PDF file in Adobe Acrobat or 
another Adobe PDF editor.

For information about security settings in placed Adobe PDF files, see “How security 
settings in placed PDF pages affect InDesign documents” on page 233.

Viewing a summary of Adobe PDF export settings
Use the Summary panel of the Export PDF dialog box to check your settings prior 
to exporting. 

To view a summary of Adobe PDF export settings:

Click Summary on the left side of the Export PDF dialog box. 
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To save the summary as a text file:

1 Click Save Summary.

2 Type a filename, choose a location for the file, and click Save.

Copying and pasting PDF content using the Clipboard
You can use the system Clipboard to copy selections between an InDesign file and other 
Adobe products, such as Adobe Illustrator, Adobe Photoshop, Adobe Streamline, Adobe 
Dimensions, and Adobe Premiere. When you copy a selection to the Clipboard, it is copied 
as a complete Adobe PDF page, using settings similar to the Print PDF style: It leaves color 
unchanged; uses compression and downsampling to keep the file size down; embeds 
subsets of all fonts used in the file; and prints at medium resolution to create a reasonably 
accurate rendition of the original document. You can’t change these settings.

When you paste an Adobe Illustrator selection from the Clipboard into an InDesign 
document, it is pasted as either PDF or AICB (a format similar to EPS), depending on which 
option you specify. PDF preserves transparency, whereas AICB breaks selections into many 
smaller opaque objects that give an overall look of transparency. InDesign turns AICB 
objects into native InDesign objects.

To specify copying preferences:

1 Choose Edit > Preferences > General.

2 Select Copy PDF to Clipboard, and click OK.

Note: Copying selections as Adobe PDF requires time and memory.

To specify pasting preferences:

1 Choose Edit > Preferences > General.

2 In the Clipboard section, do one of the following, and then click OK:

• To paste as PDF, select Prefer PDF When Pasting. 

• To paste as AICB, leave the Prefer PDF When Pasting option unselected.

To copy using the Clipboard:

1 Select the InDesign object or objects you want to copy. Then choose Edit > Copy.

2 In the non-InDesign file to which you want to paste the objects, choose Edit > Paste.

Repurposing Adobe PDF documents
Tagged Adobe PDF files allow you to save your documents’ contents to other formats, 
such as RTF and XML, with better results; reflow your documents’ contents into different-
sized devices, such as eBook reading devices; and make your document’s contents acces-
sible to readers with motion and vision challenges through the use of a screen reader for 
Windows. You can create tagged Adobe PDF files automatically when you use InDesign to 
convert layout pages to Adobe PDF. 
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Content of different types of Adobe PDF documents
You can save InDesign content as unstructured or tagged Adobe PDF documents. These 
document types differ in what they contain and how their content can be repurposed. In 
general, the more structural information the Adobe PDF document contains, the more 
options you have for repurposing its content.

Unstructured Adobe PDF documents can contain several forms of content:

• The author’s content, including pages, articles, paragraphs, tables, and figures.

• Comments, such as online notes, graphic markups, and text markups.

• Pagination artifacts, such as page numbers and running headers.

• Layout and typographic artifacts, such as colored bars between columns of text and 
horizontal lines separating footnotes from text. 

• Printing artifacts, such as crop marks, registration marks, and page information printed 
outside of the crop marks.

In addition to this content, tagged Adobe PDF documents contain a logical structure tree 
that references the author’s content in a natural reading order. Comments and artifacts 
aren’t referenced by the logical structure tree, because they’re not considered useful when 
repurposing the document’s content. For example, when a document’s content is read by 
a screen reader, the document’s page numbers aren’t considered useful information.

In addition to a logical structure tree, tagged Adobe PDF documents contain further infor-
mation about the document’s content, including Unicode values of characters, spacing 
between words, and the recognition of soft and hard hyphens. 

The logical structure tree of tagged Adobe PDF document in Acrobat 5.0

To create a tagged Adobe PDF document:

1 Click General on the left side of the Export PDF dialog box.

2 Select Include eBook Tags.

3 Select additional options as needed, and then click OK.
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How different types of Adobe PDF documents can be repurposed
Depending on the type of Adobe PDF document you’ve created, you can repurpose its 
content by saving it in a different format with different results. 

Unstructured Adobe PDF In Acrobat 5.0, you can save unstructured Adobe PDF files to 
other formats, such as RTF, with good results. An unstructured Adobe PDF file saved to RTF 
recognizes paragraphs, but not basic text formatting, lists, or tables. You can’t reflow 
unstructured Adobe PDF files into different-sized devices, such as eBook reading devices. 
Unstructured Adobe PDF files aren’t reliably accessible by screen readers for Windows.

Tagged Adobe PDF In Acrobat 5.0, you can save tagged Adobe PDF files to other 
formats, such as RTF and XML, with the best results, including the recognition of 
paragraphs, basic text formatting, lists, and tables. You can reflow tagged Adobe PDF files 
so that they’re readable in different-sized devices. Tagged Adobe PDF files have been 
optimized for accessibility, so that they can be reliably accessed with a screen reader 
for Windows.

Extending tagged Adobe PDF capabilities
Using Adobe PDF structure commands, you can define a custom set of tags to extend your 
control over tagged Adobe PDF elements. This extensibility requires a cross-media plug-in 
called XMediaUI. To install and use the plug-in, see “Installing and using XML” on 
page 378.

With this plug-in installed, you can do the following:

• Map InDesign paragraph style names to Acrobat 5.0 tagged Adobe PDF 
paragraph styles.

• Change the reading order of stories and images. 

• Mark and hide printing artifacts, text, and images so that they won’t appear when 
reflowed in Acrobat 5.0. 
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Working with HTML Files

About XML
InDesign can build XML-based structure into new and legacy documents, making it more 
efficient and cost-effective for you to publish content to multiple channels including print, 
Web, handheld/wireless devices, and more. HTML and XML have similar elements and 
structure. However, XML differs from HTML in that it is extensible; users may define custom 
sets of element tags. 

You can export InDesign documents to XML format, and you can import XML documents 
into InDesign, flowing tagged text and graphics into frames.

Installing and using XML
Before you can tag your documents or import and export XML, you must copy the XMedia 
UI plug-in file to the Plug-ins folder.

For information, see the Install_ReadMe.

Preparing documents for HTML
If you’re creating a document for distribution on the Web, design it for the screen and then 
export it to HTML. InDesign can add navigational links based on hyperlinks.

Although you can create compelling Web pages using InDesign, the Export HTML feature 
is intended to simplify repurposing print material for the Web—it does not replace the 
versatility of Web authoring products such as Adobe GoLive.

Getting consistent color online
InDesign includes a color swatch library called Web, which consists of the colors most Web 
browsers use to display text and graphics in HTML documents. The 216 colors in the 
library, often called Web-safe colors, are consistent across platforms, because they are a 
subset of the colors that browsers use in both Windows and Mac OS. The Web-safe colors 
in InDesign are the same as those in Adobe Photoshop’s Web-safe color palette and Adobe 
Illustrator’s browser-safe color palette.

Each color in the library is named by its RGB values. Each color’s hexadecimal code, which 
HTML uses to define the color, is stored within the color swatch.

To use Web library colors:

1 Choose New Color Swatch in the Swatches palette menu. 

2 For Color Mode, choose Web.

3 Select the Web-safe color, and then click OK.

For more information, see “Using swatch libraries” on page 308.
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Naming HTML files
When naming an HTML file, keep in mind this information about standard naming 
conventions:

• Many network programs truncate (shorten) long filenames, so it’s best to use the 
standard UNIX file-naming convention in which a filename contains no more than eight 
characters followed by an extension.

• Use the .html or .htm extension. In Windows, InDesign automatically adds .html to 
the filename.

• Do not use special characters such as question marks (?), asterisks (*), or spaces 
between the letters in your filename—some browsers may not recognize the path 
name. If you must use special characters or spaces in the filename, check with an HTML 
editing guide for the correct code to use. For example, to create spaces between letters, 
you will need to replace the space with “%20”.

Designing for HTML
The HTML language describes the structure of a document, but the individual browser 
from which it is viewed controls the physical presentation of that document. Conse-
quently, the appearance of your HTML file will vary when viewed from different browsers. 
To address this issue, InDesign uses a World Wide Web Consortium standard called 
Cascading Style Sheets-1 (CSS-1), which solves many layout issues when used with 
browsers at or above version 4.0. 

Although HTML standards have evolved considerably, not every attribute of your page 
design can be preserved when you export your InDesign document to HTML. Some 
attributes don’t have equivalents in HTML language. Other attributes may be recognized 
correctly by HTML, but ignored by specific browsers. Consider the following issues when 
you design a document that will be published on the World Wide Web:

Type Exporting to HTML preserves some character and paragraph attributes, but not 
others. You can preserve the appearance but not the editability of nonstandard text by 
converting it to graphics. (See “Setting formatting options” on page 381.)

Attributes preserved in HTML include typeface (when available on the viewer’s machine) 
and size, leading, underlining and strikethrough, alignment, indents, space before and after 
paragraphs, and text color.

Attributes not preserved in HTML include baseline shift, ligatures, old style attributes, 
tracking, kerning, paragraph rules, justification, hyphenation, no-break settings, Keep 
options, and tab positions.

You can preserve the following nonstandard text attributes by converting to graphics: text 
with a gradient applied; frame background or frame stroke; text containing inline 
graphics; text in a non-rectangular, skewed, rotated, or scaled frame; wrapped text; and 
text with a drop cap.

Graphics HTML supports the GIF, JPEG, and PNG image formats. InDesign automatically 
converts certain text frame attributes and embedded graphics, including those drawn with 
InDesign drawing tools, to either GIF or JPEG, depending upon the transparency needed. 

The size (measured in both dimensions and bytes) and number of graphic images on a 
page determine how long that page takes to download to a Web browser. By limiting the 
number of images and keeping them small, you help to ensure that your Web page 
opens quickly.



Using Help | Contents | Index Back 380  

Adobe InDesign Help Working with HTML Files 

Using Help | Contents | Index Back 380  

Page layout When exporting a document to HTML, you can choose whether or not to 
maintain the positioning of objects on a page. Choosing the Best (CSS-1) option for 
Positioning preserves the positioning of page items with high fidelity by using CSS-1. To 
benefit from CSS-1 positioning, you must use a version 4.0 or later browser; different 
browsers support CSS-1 to varying degrees.

When you choose not to approximate page layout, the result is one column of continuous 
text, with graphics occupying separate paragraphs and flowing along with the text.

Best option deselected (left) and Best option selected (right)

Exporting a document to HTML
Exporting a document to HTML can be as simple as using the default settings, or as 
customized as you need it to be.

To export an InDesign document to HTML:

1 Choose File > Export.

2 For Save as Type (Windows) or Formats (Mac OS), choose HTML.

3 Type a filename, and choose a location for the file.

4 Click Save to open the Export HTML dialog boxes. The options are explained in the 
following topics.

5 Adjust settings as desired. Then choose another dialog box in the menu at the top of 
the current dialog box, or click Previous or Next.

6 When you have set the options in each dialog box, click OK. Depending on the options 
you’ve chosen, your HTML file may now appear in the Web browser of your choice.

Setting document options
Click Documents at the top of the Export HTML dialog box to set options affecting the 
entire document.

Export as a Single HTML Document Creates a single HTML file from your entire 
document. You can specify to export all pages, one page, or a range of pages. When you 
export more than one page as a single HTML file, a horizontal rule appears between the 
pages in the Web browser.

You can also type a title for your HTML file which appears in the title bar of most 
Web browsers. 
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Export as Multiple HTML Documents Creates individual HTML files for each page in 
your document, based on a list you can modify. By default, all pages in your document are 
listed and given filenames and titles based on the filename you entered when you saved 
the file. The page number is appended to the name. Use the following techniques to 
modify this list:

• To remove a page from the list, click the check mark next to the page number and name 
so that the box appears empty. Click the box again to restore the page.

• To change the default filename and title of any page, select the page, and then enter a 
new name and title in the Filename and Title boxes directly below the list of pages. To 
help you associate the original file with the title of the HTML page, use a similar 
filename and title.

View HTML Using Opens the selected Web browser or HTML editing application after 
export is complete and displays the first HTML file. Choose a browser in the menu, or 
choose Other to locate and select another browser or HTML editor, such as Adobe GoLive. 
The application you specify with the Other option will appear on the menu the next time 
you open the Export HTML dialog box. Using Other, you can add as many as three 
additional applications to this menu. If you add more than three, the first application you 
chose will be replaced by the last.

Setting formatting options
Choose Formatting at the top of the Export HTML dialog box to set general formatting 
options. If you choose a color using the system color picker, InDesign shifts the selected 
color to the closest Web-safe color.

Override Color Changes the color of all text in the HTML file to the selected color. You 
can either choose a Web-safe color in the menu, or double-click the color box and choose 
a color from the color picker. Remember that some text in your InDesign document 
may become a graphic in the HTML file; text in the form of a graphic is not affected by 
this option.

Maintain Non-Standard Text lets you choose whether to preserve the appearance or 
editability of nonstandard text. Choose Maintain Appearance to convert the text to a GIF 
image, which preserves the visual appearance of the text but renders it uneditable. 
Choose Maintain Editability to remove all nonstandard formatting, such as rotation.

Background None Leaves the background of the document as it appears in InDesign. No 
additional colors or images are added.

Background Color Applies a color of your choice to the background of your HTML page 
(or to all pages, if you’re exporting a document as multiple files). Either select one of the 
Web-safe colors in the menu, or double-click the color box and choose a color from the 
color picker.

Background Image Tiles the background of your HTML file with an image of your choice. 
When prompted, locate and select a GIF or JPEG image, and then click Open. If you change 
your mind, double-click the thumbnail in the dialog box or click Choose, and then select a 
different image.

Setting layout options
Choose Layout at the top of the Export HTML dialog box to determine how closely your 
page design is reproduced in your HTML file. 
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Positioning Choose an option for page-element positioning as explained in “Designing 
for HTML” on page 379.

InDesign Margins Select Maintain if you want the HTML file to have the same margins as 
your InDesign document. If you select None, the InDesign margins are discarded and the 
browser uses its own default margins.

Navigation Bar When you export an InDesign document as multiple HTML files, this 
option creates navigation links on each page. The links open next and previous pages. 
Select Top, Bottom, or Both depending on where you want the navigation links to appear. 
If you don’t want InDesign to create any navigation links, select None.

Setting graphics options
Choose Graphics at the top of the Export HTML dialog box to determine how InDesign 
converts graphics elements for your HTML file. The options under GIF Settings and JPEG 
Settings apply to all images converted during the export process.

Save Images As Lets you choose whether the individual graphics in your document 
are converted to GIF or to JPEG. You can select Automatic to let InDesign choose which 
of these two formats to use in each instance. The Automatic setting converts RGB, 
CMYK, LAB, and grayscale images to JPEG, and indexed-color images or images with 
transparency to GIF. Nonstandard text is converted to GIF, unless the text includes 
inline images.

Whichever option you choose, linked images already in the GIF, JPEG, or PNG formats with 
a 72-dpi resolution are exported without any conversion. This maintains any GIF animation 
or transparency in the linked images and also maintains the quality of JPEG images by not 
adding additional lossy compression. On the other hand, all embedded images—even 
those saved as GIF, JPEG, or PNG— are converted to the format you choose. 

Use Images Subfolder Creates a folder called Images within the folder where your HTML 
documents are saved. InDesign stores image files for your HTML documents in that new 
Images folder. This is a useful way of managing files, particularly if your HTML file is likely to 
include a large number of images. If you don’t select this option, all images are stored in 
the same folder as your HTML files.

Palette Lets you control how InDesign handles colors when creating GIF files for your 
HTML pages. The use of a limited color palette is required by the GIF format, which cannot 
include more than 256 colors. Select from the following options:

• Choose Adaptive (no dither) to create a palette using a representative sample of colors 
in the graphic without any dithering, or mixing of small spots of colors to simulate 
additional colors. This option often creates large areas of solid color, but the visual 
effect varies with the type of graphic. The results may be undesirable for multicolored 
photographs but suitable for cartoons, logos, maps, or computer screen-shots. 
Generally, the Adaptive (no dither) option gives the best image quality for graphics 
containing more than 256 colors; otherwise, choose Exact.

• Choose Web to create a palette of the Web-safe colors that are a subset of the Windows 
and Mac OS system colors.

• Choose Exact to create a palette using the existing colors in the graphic. If a graphic 
contains more than 256 colors, an alert message warns you that InDesign is unable to 
create an exact palette.
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• Choose System to create a palette using the built-in color palette for Windows or Mac 
OS. This choice may produce unexpected results when the image is displayed on a 
system using an 8-bit display with a different built-in palette.

Color Depth Lets you specify as many as 256 colors for each GIF created for your HTML 
files. Lower numbers result in smaller file sizes for each GIF, but may produce undesirable 
results. This option is available only for the Adaptive and Exact color palettes.

Interlace Causes GIF images to display gradually and in increasing detail as they are 
downloaded to a Web browser.

Image Quality Lets you determine the tradeoff between compression (for smaller file 
sizes) and image quality for each JPEG image created for your HTML file. Low produces the 
smallest file and the lowest quality; Maximum produces images with the largest file size 
and the highest quality.

Format Method Lets you determine how quickly JPEG graphics display when an HTML 
page is opened. Choose Progressive to make the JPEG images display gradually and in 
increasing detail as they are downloaded to a Web browser. Files created with this option 
are slightly larger, and they require more RAM for viewing. Choose Baseline to make each 
JPEG file display only after it has been completely downloaded; a placeholder appears in 
its place until the file displays.

Setting encoding options
Choose Options at the top of the Export HTML dialog box to select the encoding format 
for the HTML file. Select one of the following options in the Encoding menu:

• Unicode (UTF-8)

• Western (ISO-8859-1)

• Japanese (Shift-JIS)

• Japanese (ISO-2022-JP)

• Japanese (EUC-JP)

Making changes to an HTML or XML file
You can make changes to an InDesign-created XML or HTML file using any of the 
following methods:

• Open an XML or HTML file in an editing application, such as Adobe GoLive. When you 
open an InDesign HTML document in Adobe GoLive 4.0 or later, you may see question 
marks or pink boxes on the page. Replace these invalid characters with valid HTML 
characters as necessary.

• Open the original InDesign document in InDesign, and then make the necessary 
changes. Once you’ve made the changes in InDesign, you can again export the 
document or specific pages of the document to XML or HTML, using the original 
filename.
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Printing

About printing
Whether you are providing a multicolored document to an outside service provider, or just 
sending a quick draft of a document to an inkjet or laser printer, knowing a few basics 
about printing will make the print job go more smoothly, and help to ensure that the 
finished document appears as intended.

Types of printing When you print a file, InDesign sends it to a printing device, either to 
be printed directly on paper or to a digital printing press, or to be converted to a positive 
or negative image on film. In the latter case, the film can then be used to create a master 
plate for printing by a commercial press.

Types of images The simplest types of images, such as text, use only one color in one 
level of gray. A more complex image is one with color tones that vary within the image. 
This type of image is known as a continuous-tone image. A scanned photograph is an 
example of a continuous-tone image.

Halftoning To create the illusion of continuous tone, images are broken down into a 
series of dots. This process is called halftoning. Varying the sizes and densities of the dots 
in a halftone screen creates the optical illusion of variations of gray or continuous color in 
the printed image. 

Color separation Artwork that will be commercially reproduced and that contains more 
than a single color must be printed on separate master plates, one for each color. This 
process is called color separation.

Getting detail The detail in a printed image results from a combination of resolution and 
screen frequency. The higher an output device’s resolution, the finer (higher) the screen 
frequency you can use. (See “Specifying the halftone screen frequency” on page 423.)

Transparent objects If the artwork contains objects with transparency features that you 
added using the Transparency palette or the Drop Shadow or Feather commands, the 
transparent artwork will be flattened according to settings in the flattener style you 
choose. You can affect the ratio of rasterized images to vector images in the printed 
artwork. (See “Creating, saving, and loading custom flattener styles” on page 295.)
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About printer drivers
InDesign supports printing to both PostScript® and non-PostScript language printers, 
using most modern or current printer drivers. The InDesign CD includes the AdobePS 
printer driver, which enables InDesign output to comply with Document Structuring 
Conventions (DSC). When output is DSC-compliant, it can communicate its document 
structure and printing requirements to prepress applications that do imposition, trapping, 
and OPI image replacement, as well as to RIPs and printers. The result is smoother 
processing by post-processing applications and OPI servers.

Note: Pscript 5 and LaserWriter printer drivers also produce DSC-compliant PostScript files 
when used with InDesign 2.0. 

InDesign supports the following printer drivers for Windows and Mac OS systems.

For more information on supported PostScript printer drivers, including installation 
instructions, see the Adobe Printer Drivers section on the Adobe Web site. 

For information on creating PostScript files using supported printer drivers, see “Choosing 
the right method for creating a PostScript file” on page 410.

Resolving overlapping InDesign printer driver features
Some InDesign printing features appear in both the printer driver dialog boxes and the 
InDesign Print dialog box. If settings overlap, InDesign tries to synchronize the settings, 
or to ignore the driver’s settings. Some printer driver features (for example, N-up printing, 
which prints the same artwork multiple times on the same page) won’t work with 
InDesign features such as separations, and will produce adverse printing results. For best 
results when print settings overlap, specify the settings only in the InDesign Print dialog 
box. For more information, see “About PostScript Printer Description files” on page 386. 

Specifying printer driver features
If you want to specify settings to a specific printer, InDesign provides access to driver 
dialog boxes through these buttons in the InDesign Print dialog box:

Setup In Windows, this button opens the Properties dialog box for the currently 
selected printer.

Operating system Driver

Windows 98 AdobePS 4.5

Windows NT 4.0 AdobePS 5.2

Windows 2000 and Windows XP Pscript 5

Windows 98, Windows Me, and 
Windows NT 4.0

Pscript 4

Mac OS 9.2 AdobePS 8.7.2 and later

Mac OS 10.1 LaserWriter

Mac OS 9 LaserWriter 8.7 and later
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Page Setup In Mac OS, this button displays the standard Mac OS Page Setup dialog box 
for printing options. Most settings available in the Page Setup dialog box are available in 
the InDesign Print dialog box, and should be set there.

Printer In Mac OS, this button displays the dialog box for setting printer-specific options. 

Note: If you choose the PostScript File option for the Printer in the InDesign Print dialog 
box, the Setup (Windows), Printer (Mac OS), or Page Setup (Mac OS) buttons are made 
unavailable. 

About PostScript Printer Description files
A PostScript Printer Description (PPD) file isn’t the same as a printer driver; instead, it 
customizes the behavior of the driver for your specific printer. A PPD file contains infor-
mation about the output device, including printer-resident fonts, available media sizes 
and orientation, optimized screen frequencies, resolution, and color output capabilities. 
Selecting the PPD that corresponds to your PostScript printer or imagesetter populates 
the Print dialog box with the available settings for the output device.

InDesign uses the information in the PPD file to determine which PostScript information 
to send to the printer when printing a document. For example, InDesign assumes that the 
fonts listed in your PPD file reside in the printer, so they are not downloaded when you 
print, unless you explicitly include them.

Note: Certain PPD features commonly found in imagesetter PPDs won’t be accessible from 
the InDesign Print dialog box. To set those printer-specific features, click Setup (Windows), 
Printer (Mac OS), or Page Setup (Mac OS) in the InDesign Print dialog box.

Setting up a PPD
Because so many of InDesign’s printing features depend on the PPD for information, it’s 
important to set up the correct PPD before you print. Set up a PPD using the operating 
system driver.

For best printing results, Adobe recommends that you obtain the latest version of the PPD 
file for your output device from the manufacturer. Many prepress service providers and 
commercial printers have PPDs for the imagesetters they use. Be sure to store PPDs in the 
location specified by the operating system. For details, consult the documentation for 
your operating system.

To set up a PPD:

Depending on your operating system, do any of the following:

• In Windows, set up the PPD during printer installation. 

• In Mac OS 10.1, set up the PPD during print queue setup time.

• In Mac OS 9, set up the PPD any time using Chooser.

Printing a composite 
You can choose from a set of standard printing options in InDesign for any document or 
book you print. These printing options appear in the General and Setup panels of the Print 
dialog box. 
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If you’re making color separations, you can print a color or grayscale composite proof to 
check your work. A composite image can help you design and proof your layout before 
you print final (and costly) separations. 

When InDesign prints a composite, it prints all of the colors used in the file on one plate, 
regardless of whether any individual colors are selected. 

Consider the following issues when printing composites:

• Any overprinting options that you’ve selected in the document will print correctly on a 
printer that supports overprinting. Since most desktop printers don’t support 
overprinting, you can simulate the effects of overprinting by selecting Simulate 
Overprint in the Output panel of the Print dialog box. 

Important: Selecting Simulate Overprint will convert spot colors to process colors for 
printing. If you intend to use a file for separations on a RIP, or for final output, do not select 
this option.

• When you print to a black-and-white printer, InDesign produces a grayscale composite 
version of the pages. If the document contains color, InDesign prints visually correct 
grays to simulate that color. For example, the gray that simulates a 20% tint of yellow is 
lighter than a 20% tint of black, since yellow is visually lighter than black.

• When you print a book with chapters containing conflicting spot inks or trap styles, you 
can instruct InDesign to synchronize settings with the master document. (See 
“Synchronizing documents in a book file” on page 169.)

• If you’re using color management with the Book feature, make sure that each 
document in the book uses the same color management settings in the Color Settings 
dialog box. 

Note: Remember that, like monitors, color printers vary greatly in color reproduction 
quality; thus, proofs from your service provider are the best way to verify how the finished 
piece will look. 

Printing a document or book
The InDesign Print dialog box groups printing options in several panels. To print a book or 
selected documents in a book, open the Print dialog box from the Book palette; the only 
way to print a book is by using the Book palette.

To open the Print dialog box and view different groups of printing options:

1 Do one of the following to open the Print dialog box:

• If you have individual documents open, choose File > Print. This opens the Print dialog 
box for the frontmost open document.

• If you have either no documents or all documents selected in the Book palette, choose 
Print Book in the Book palette menu. This will print all documents in a book.

• If you have some documents selected in the Book palette, choose Print Selected 
Documents in the Book palette menu.
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2 Click a panel name on the left side of the Print dialog box.

The options display different panels of the Print dialog box

To print a composite of an open document or book:

1 Make sure that you’ve installed the printer driver for your computer. 

2 Open the Print dialog box in the File menu or the Book palette.

3 If a printer style has the settings you want, choose it in the Printer Style menu at the 
top of the Print dialog box. (See “Using styles for printing” on page 388.)

4 In the General panel, type the number of copies to print, and choose whether to collate 
pages or print them in reverse order. 

5 Indicate which pages you want printed. The Page Range option is unavailable if you’re 
printing a book. (See “Setting general print options” on page 390.)

6 Choose a paper size and orientation in the Setup panel. (See “Specifying the paper size” 
on page 391.)

7 Choose a composite color mode in the Output panel. (See “Choosing a composite color 
mode” on page 398.)

8 Adjust settings as needed for each option in a panel. For help with individual options, 
see the Index. Settings you specify in these panels are saved with the document.

9 Click Print. InDesign prints all visible layers, and all or selected documents in a book.

About printing to non-PostScript language printers 
You can print a document on a GDI (Windows) and QuickDraw (Mac OS) non-PostScript 
language printer. However, because PostScript is the standard page-description language 
for professional publishing, many high-end color and graphics features, such as screen 
frequencies or color separations, cannot be reproduced on non-PostScript printers. Most 
imported graphics file formats print acceptably. In general, a document printed to a non-
PostScript printer should look the way it appears on-screen when you choose View > 
Typical Display.

Some vendors sell software programs that add PostScript-language capability to a 
non-PostScript language printer. Check with your software reseller for availability and 

compatibility.

Using styles for printing
If you regularly output to different printers or job types, you can automate print jobs by 
saving all output settings as printer styles. Using printer styles is a fast, reliable way to print 
jobs that require consistently accurate settings for many options in the Print dialog box.
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You can save and load printer styles, making it easy to back them up or to make them 
available to your service providers, clients, or others in your workgroup.

To create a printer style:

Do one of the following:

• Choose File > Print, adjust print settings, and click Save Style. Type a name and click OK.

• Choose File > Printer Styles > Define and click New. In the Print dialog box that appears, 
type a name, adjust print settings, and click OK. 

To edit an existing printer style:

Do one of the following:

• Choose File > Print, adjust print settings, and click Save Style. Either name the style or 
choose a style in the Save Style As menu whose settings you want to overwrite. 
Click OK.

• Choose File > Printer Styles and choose the style in the menu. In the Print dialog box that 
appears, adjust print settings and click Save Style.

• Choose File > Printer Styles > Define, select a style in the list, and then click Edit. In the 
Print dialog box that appears, adjust print settings and click OK.

To change default printer style settings:

1 Choose File > Printer Styles > [Default].

2 Adjust print settings and click Save Style. 

3 Select the Style option and choose [Default] in the menu. Click OK.

To print using a printer style:

1 Choose a printer style in the File > Printer Styles menu. If you like, confirm the printer 
settings in the dialog box that appears.

2 Click Print.

To rename or delete printer styles:

1 Choose File > Printer Styles > Define.

2 Do one of the following:

• To rename an existing style, select a style in the list, click Edit, type a new name, and 
then click OK.

• To delete styles, select one or more styles in the list, click Delete, and then click OK to 
confirm the deletion.

3 Click OK.

To load existing printer styles:

1 Choose File > Printer Styles > Define.

2 Click Load.

3 Locate and double-click the .prst file containing the styles you want to load, and then 
click OK.
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To save printer styles:

1 Choose File > Printer Styles > Define.

2 Select one or more styles in the list and click Save.

3 Specify a name and location, and then click Save.

Setting general print options
The General panel of the Print dialog box includes controls common to most software 
print dialog boxes.

Specifying which pages to print
You can print all pages, even or odd pages only, or a contiguous range. You can also print 
master pages only.

Choose from the following page options:

All Prints all pages in the current document. This is the default setting. 

Range Specifies the range of pages to print in the current document. Separate numbers 
in a range by using a hyphen, and separate multiple pages or ranges by using commas or 
spaces. This option is unavailable when you are using the Book feature.

To print sections, use the format, SecA2-SecB5.

Sequence Choose All Pages to print all pages of a document. Choose Even Pages Only or 
Odd Pages Only to print only those pages within the specified range. These options are 
unavailable when you are using the Spreads option.

Print Master Pages Prints all master pages, rather than document pages. Selecting this 
option makes the Ranges option unavailable.

Spreads Prints pages together, as if they were bound, or printed on the same sheet. You 
can print only one spread per sheet. If the new page is larger than the currently selected 
paper size, InDesign prints as much as it can, but won’t automatically scale the page to fit 
the imageable area, unless you select Scale To Fit in the Setup panel of the Print dialog box. 
You may also want to specify landscape orientation. The Spreads option isn’t available for 
spreads wider than 18 feet, the maximum page size. 

If different trapping styles are applied to pages in the spread, InDesign resolves the differ-
ences as described in “Printing books with conflicting trap styles” on page 336.

Important: Do not select Spreads with the Booklet feature in Mac OS if you’re sending 
your files to a prepress service provider; if you do, the provider cannot impose the pages. 

Printing grids, guides, and other nonprinting objects
The General panel of the Print dialog box contains options for printing elements usually 
visible only on-screen. You can choose from the following options:

Print Non-printing Objects Prints all objects, regardless of your settings to selectively 
prevent individual objects from printing. 

Print Blank Pages Prints all pages in the specified page range, even if no text or objects 
appear on a page. This option is unavailable when you are printing separations.
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Print Visible Guides and Baseline Grids Prints visible margin guides, ruler guides, 
column guides, and baseline grids in the same color as shown in the document. You can 
control which guides and grids are visible in the View menu.

Setting output size and handling options
When you first created your document, you chose a page size and determined whether 
the document would have a portrait (tall) or landscape (wide) orientation. When you print, 
you need to make similar decisions to determine how your document appears on the 
printed page or on film.

About paper size
It’s important to distinguish between page size (as defined in the Document Setup dialog 
box for your document) and paper size (the sheet of paper, piece of film, or area of the 
printing plate you’ll print on). Your page size might be US Letter (8.5-by-11 inches), but you 
might need to print on a larger piece of paper or film to accommodate any printer’s marks 
or the bleed area.

The list of paper sizes available to InDesign comes from the PPD (PostScript printers) or 
from the printer driver (non-PostScript printers). If the printer and PPD you’ve chosen for 
PostScript printing support custom paper sizes, you’ll see a Custom option in the Paper 
Size menu. 

Most imagesetters can accommodate regular paper sizes, such as letter and tabloid, as 
well as transverse orientation, where the regular page size is rotated 90 degrees when 
printed. The transverse orientation is often a more efficient use of imagesetter media.

A. Letter (tall orientation) B. Custom C. Transverse

Specifying the paper size
For PostScript printing, InDesign normally uses the paper size default in the PPD file 
(PostScript printers) or the printer driver (non-PostScript printers). However, you can 
change the paper size to any of the sizes listed in the PPD file, and specify orientation in 
90-degree increments as well. Paper sizes are listed by familiar names (such as Letter). The 
dimensions define the limits of the imageable area—the total paper size, less any 
unprintable border used by the printer or imagesetter. Most laser printers cannot print to 
the exact edge of a page.

A B C
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If you select a different paper size (for example, if you change from Letter to Legal), the 
document is rescaled in the preview window. This is because the preview window displays 
the entire imageable area of the selected page; when the preview size is changed, the 
preview window automatically rescales to include the imageable area.

Note: The imageable area will vary by PPD file, even for the same paper size (for example, 
Letter), because different printers and imagesetters define the sizes of their imageable 
areas differently.

Make sure that your paper size is large enough to contain your document and the printer’s 
marks and bleeds. To conserve imagesetter film or paper, however, select the smallest 
paper size that will accommodate your document and the necessary printing information.

Note: The preview in the lower left area of the Print dialog box indicates whether you have 
enough space to include all printer’s marks and bleeds.(See “Viewing the fit of a 
document” on page 394.)

Note: Paper sizes for non-PostScript printing won’t be accessible from the InDesign Print 
dialog box. To choose those paper sizes, click Setup (Windows), Printer (Mac OS), or Page 
Setup (Mac OS) in the InDesign Print dialog box. 

To specify a paper size:

In the Setup panel of the Print dialog box, choose an option in the Paper Size menu.

Specifying the page orientation
In most cases, the page orientation specified in Document Setup (File > Document Setup) 
and the output orientation specified in the Setup panel of the Print dialog box should be 
the same (both portrait or both landscape), whether you print normal or transverse. If 
you’re printing spreads, you may want to choose a different paper size and orientation 
(such as landscape) to fit all pages of a spread on a single sheet.

To specify a page orientation:

In the Setup panel of the Print dialog box, click an Orientation button to rotate the 
document on the media. 

Orientation buttons: A. Portrait B. Landscape C. Reverse Portrait D. Reverse Landscape

Specifying a custom paper size 
For PostScript printing, you can specify a custom paper size using the Custom option in 
the Paper Size menu. This option is available only if you’re using a printer that accommo-
dates various paper sizes, such as a high-resolution imagesetter. 

A B C D
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The largest custom paper size you can specify depends on the maximum imageable 
area of your imagesetter. For more information, consult the documentation for your 
specific printer.

Note: Custom paper size options for non-PostScript printing won’t be accessible from the 
InDesign Print dialog box. To set those printer-specific features, click Setup (Windows), 
Printer (Mac OS), or Page Setup (Mac OS) in the InDesign Print dialog box. Check the 
documentation for your non-PostScript printer driver for details.

To specify a custom paper size:

1 Select a PPD (PostScript printers) or printer driver (non-PostScript printers) that 
supports custom paper sizes. You can use the PostScript File option to set up the PPD. 
For more information, see “Setting up a PPD” on page 386.

2 In the Setup panel of the Print dialog box, choose Custom in the Paper Size menu.

3 To specify width and height, do one of the following:

• To let InDesign determine the smallest paper size needed for your document’s 
contents, printer’s marks, and bleeds, select Auto for Width and Height. Auto, the 
default option, is also useful if you have different sized pages in a book and you’re 
printing on continuous media, such as a roll of film or photosensitive paper

• To specify a paper size larger than the default, enter new dimensions in the Width and 
Height text boxes. Be sure to increase the values; decreasing the default values may clip 
your document.

4 To change the placement of the page on the film, enter a value for Offset. 

The Offset value specifies the amount of space along the left side of the imageable area. 
For example, entering a value of 30 points in the Offset option shifts your page 30 points 
to the right. 

Page without offset (left), and same page with offset applied (right):  
A. Page B. Film C. Offset

5 To rotate both media and page contents, select Transverse and click OK. 

BA C
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You can conserve a considerable amount of film or paper by using Transverse in 
conjunction with Offset. Compare the following examples of an image printed by 
InDesign with Transverse selected and deselected. 

Transverse deselected (left), and film saved with Transverse selected (right):  
A. Offset value B. Gap C. Film saved

6 To specify the distance between individual pages when printing on continuous media, 
enter a value for Gap.

Viewing the fit of a document
You can view how the document’s pages fit on the chosen paper size before you print to a 
PostScript printer. A preview in the lower left area of the Print dialog box shows whether 
your paper and orientation settings will work for your page size. When you select different 
options in the Print dialog box panels, the preview updates dynamically with the 
combined effects of your print settings.

The preview has three views: 

Standard view Displays the relationship of a document page to the media. It shows the 
effects of various options such as paper size to imageable area, bleeds, page marks, and so 
on, as well as the effects of tiling and thumbnails. The following examples show four 
individual, not combined, settings. 

A. Default B. Spreads C. Orientation D. 2-by-2 Thumbnails
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Text view Lists the numerical values for certain print settings.

Summary of settings in preview

Custom page/Cut sheet views Display the effects of different print settings, depending 
on your page size. For custom page sizes, the preview shows how the media fits on the 
custom output device; what the maximum supported media dimensions are of the output 
device; and what the settings are for offset, gap, and transverse. For cut sheets, such 
as Letter and Tabloid, the preview shows the relationship of the imageable area to the 
media size. 

In both the custom page and cut sheet views, the preview also indicates the output mode 
using an icon: Separations , Composite Grayscale , Composite CMYK , or Composite 
RGB .

Custom page view (left): A. Direction of media travel B. Transverse deselected C. Paper size  
D. Media Cut sheet view (right): E. Imageable area F. Media

To switch between each type of preview:

Click the preview image in the lower left area of the Print dialog box.

Printing oversized documents
Although you can create InDesign documents as large as 18-by-18 feet, most desktop 
printers cannot print such large pages. 

To print an oversized document on your desktop printer, you can print each page of your 
document in pieces, called tiles, and then trim and assemble those pieces. If you prefer, 
you can scale the document to fit the available paper size. 

A B C D
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Tiling a document
A document’s dimensions do not necessarily match the paper sizes used by printers. As a 
result, when you print, InDesign divides the oversized document into one or more 
rectangles, or tiles, that correspond to the page size available on the printer. You can then 
assemble the overlapping sections.

You can have InDesign tile a document automatically, or you can specify the tiles yourself. 
The information area below the preview tells you how many tiles will print. Tiling manually 
lets you control the origin point for the upper left corner of the tile, so that you determine 
where the page falls on the paper.

To tile a document automatically:

1 In the Setup panel of the Print dialog box, select Tile.

2 Choose one of the following options in the Tile menu:

• Auto, to automatically calculate the number of tiles required, including the overlap.

• Auto Justified, to increase the amount of overlap (if necessary) so that the right sides of 
the rightmost tiles are aligned at the right edge of the document’s page, and the 
bottom sides of the bottommost tiles are aligned at the bottom edge of the 
document’s page.

• Manual, to print a single tile. Before you choose this option, first specify the upper left 
corner of this tile by dragging the zero point of the rulers. Then choose File > Print, and 
select Manual for the Tile option.

3 For Overlap, type the minimum amount of duplicated information you want printed on 
each tile for ease in assembly. The Overlap option uses the unit of measure specified for 
the document. The value should be greater than the minimum nonprinting margins for 
the printer. You can specify up to half the size of the shortest side of the document page to 
overlap. For example, tiles for a page that measures 11-by-17 inches (279.4mm-by-
431.8mm) can overlap up to 5.5 inches (139.7mm).

Divide oversized page into segments and print tiles (left); Assemble the overlapping sections (right)

To tile a document manually:

1 If necessary, choose View > Show Rulers to display the rulers.

2 Drag the intersection of the rulers to reset the zero point to the desired upper left 
corner of the tile you want to print. Remember to leave room for overlap and printer’s 
marks. The size and shape of the area InDesign prints is determined by the current paper 
size and orientation.

3 Choose File > Print.
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4 In the Setup panel of the Print dialog box, select Tile and choose Manual in the 
Tile menu.

Scaling a document
To fit an oversized document on a smaller piece of paper, you can scale the document’s 
width and height, either symmetrically or asymmetrically. Asymmetric scaling is useful 
when, for example, you’re printing film for use on a flexographic press: If you know in 
which direction the plate will be mounted on the press drum, scaling can compensate for 
the 2% to 3% stretching of the plate that usually occurs. Scaling does not affect the size of 
the pages in the document.

Note: When you print spreads, each spread is scaled separately.

To scale a document:

1 In the Setup panel of the Print dialog box, select Width to activate the Width and 
Height boxes.

2 To maintain current document width to height proportions, select Constrain Propor-
tions. Otherwise, make sure that this option is unselected.

3 Type percentages from 1 to 1000 in the Width and Height boxes. If you 
selected Constrain Proportions, you need to enter only one value; the other is updated 
automatically.

To scale a document automatically:

1 In the Setup panel of the Print dialog box, make sure that Tile is unselected. If Tile is 
selected, the Scale to Fit option is unavailable.

2 Select Scale to Fit. The scaling percentage, which is determined by the imageable area 
defined by the selected PPD, appears next to the Scale to Fit option. 

Changing page position
When you print a document to a cut-sheet media size that is larger than the document 
size, you can control where the bleed areas, printer’s marks, and the page fall on the media 
by using the Page Position options in the Setup panel of the Print dialog box. If a 
document doesn’t fit the media and needs to be clipped, you can specify which part of the 
document is clipped. The preview image in the Print dialog box shows the results. 

Note: If you want to see all bleed areas and printer’s marks, use the Scale to Fit option 
instead of Page Position; scaled pages are always centered. The Page Position options are 
made unavailable when Scale to Fit, Thumbnails, or Tile is selected.

To change the page position on the media:

In the Setup panel of the Print dialog box, choose a position in the Page Position menu. 
The default page position is Upper Left.

Note: The default position for documents created in InDesign 1.0 or 1.5 was centered. If 
you open those documents in InDesign 2.0, the page position will remain centered.
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Printing thumbnails
To fit multiple pages on a single page, you can create thumbnails—small preview versions 
of your document. Thumbnails are useful for verifying content and organization. Where 
appropriate, InDesign automatically changes the paper orientation to provide the best fit 
of the page to the paper; however, you’ll need to reset the original orientation if you 
deselect the Thumbnails option.

Note: Printing thumbnails disables all printer’s marks and bleeds.

To print thumbnails:

1 In the Setup panel of the Print dialog box, select Thumbnails.

2 In the menu, choose the number of thumbnails per page. 

Choosing a composite color mode
In the Output panel of the Print dialog box, you can determine how composite color in the 
document is sent to the printer. Composite modes only affect rasterized images and 
objects created using InDesign; placed graphics (such as EPS and Adobe PDF files) are not 
affected unless they overlap transparent objects. For details, see the document “Achieving 
Reliable Print Output with Transparency” on the Adobe Web site.

Note: The options available for non-PostScript printing depend on the color model the 
printer uses, which is usually RGB.

Choose from the following options:

Composite Gray Sends grayscale versions of specified pages to the printer when, for 
example, you are printing to a monochrome printer without making separations. When 
this option is selected, the trapping option is disabled.

Composite RGB Sends a full-color version of specified pages to the printer when, for 
example, you are printing to an RGB color printer without making separations. When this 
option is selected, trapping is disabled.

Composite CMYK Sends a full-color version of specified pages to the printer when, 
for example, you are printing to a CMYK color printer without making separations. When 
this option is selected, trapping is disabled. (This option is available only for PostScript 
printers.)

Note: For information on separation color modes, see “Two common print workflows” on 
page 414.

Text as Black Prints all text created in InDesign in black unless it has the color None or 
Paper, or a color value that equals white. Selecting this option is useful when you’re 
creating content for both print and PDF distribution. For example, if hyperlinks were blue 
in the PDF version, they would print black on a grayscale printer, rather than in halftone 
patterns, which would be difficult to read.
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Printing graphics and fonts
InDesign has several options for making bitmap images, EPS graphics, and PDF pages 
print most efficiently on PostScript printers. In addition, you can specify how InDesign 
downloads fonts to the printer. The options you choose determine the size of the resulting 
PostScript file. 

Note: When you print native Illustrator graphics and EPS files from InDesign to a non-
PostScript printer, InDesign sends the on-screen preview to the printer, which can result in 
poor image quality.

Determining how graphics print
When you are exporting or printing documents that contain complex graphics (for 
example, high-resolution images, EPS graphics, PDF pages, or transparent effects), it will 
often be necessary to change resolution and rasterization settings in order to obtain the 
best output results. 

Choose from the following options in the Graphics panel of the Print dialog box to specify 
how graphics are handled during output.

Send Data Controls how much image data in placed bitmap images to send to the 
printer or file.

All Sends full-resolution data, which is appropriate for any high-resolution printing, or for 
printing grayscale or color images with high contrast, as in black-and-white text with one 
spot color. This option requires the most disk space.

Optimized Subsampling Sends just enough image data to print the graphic at the best 
possible resolution for the output device. (A high-resolution printer will use more data 
than a low-resolution desktop model.) Select this option when you’re working with high-
resolution images but printing proofs to a desktop printer. 

Note: For separations, you can control how much image data is sent by changing the 
Frequency value in the Output panel of the Print dialog box.

Proxy (72 dpi) Sends screen-resolution versions of placed bitmap images, thereby 
reducing printing time. 

None Temporarily removes all graphics when you print and replaces them with graphics 
frames with crossbars, thereby reducing printing time. The graphics frames are the same 
dimensions as the imported graphics, so you can still check sizes and positioning. 
Suppressing the printing of imported graphics is useful when you want to distribute text 
proofs to editors or proofreaders. Printing without graphics is also helpful when you’re 
trying to isolate the cause of a printing problem.

Setting options for fonts 
Printer-resident fonts are fonts stored in a printer’s memory or on a hard drive connected to 
the printer. Type 1 and TrueType fonts can be stored either on the printer or on your 
computer; bitmap fonts are stored only on your computer. InDesign downloads fonts as 
needed, provided they are installed on your computer’s hard disk. 

Choose from the following options in the Graphics panel of the Print dialog box to control 
how fonts are downloaded to the printer. For more information about these options, see 
“Setting common export options” on page 251.
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None Includes a reference to the font in the PostScript file, which tells the RIP or a post-
processor where the font should be included. 

Complete Downloads all fonts required for the document at the beginning of the 
print job. 

Subset Downloads only the characters (glyphs) used in the document. 

Download PPD Fonts Downloads all fonts used in the document, even if those fonts 
reside in the printer. Use this option to ensure that InDesign uses the font outlines on your 
computer for printing common fonts, such as Helvetica, Times, and so on. Using this 
option can resolve problems with font versions, such as mismatched character sets 
between your computer and printer or outline variances in trapping. However, unless you 
commonly use extended character sets, you don’t need to use this option for desktop 
draft printing.

Sending PostScript information
Choose from the following options in the Graphics panel of the Print dialog box to specify 
how PostScript information is sent to the printer. For more information about these 
options, see “Setting common export options” on page 251.

PostScript Specifies a level of compatibility with the interpreters in PostScript 
output devices. 

Data Format Specifies how InDesign sends the image data from your computer to 
a printer.

Omitting graphics
The OPI options in the Advanced panel let you selectively omit different imported 
graphics types when sending image data to a printer or file, leaving only the OPI links 
(comments) for later handling by an OPI server. For details, see “Setting common export 
options” on page 251.

OPI Image Replacement Enables InDesign to replace low-resolution EPS proxies of 
graphics with high-resolution graphics at output time. 

Omit for OPI Selectively omits imported graphics when sending image data to a printer 
or file, leaving only the OPI links (comments) for later handling by an OPI server. 

Using color management when printing
When you print a color-managed RGB or CMYK document, you can specify additional 
color management options to keep color consistent in the printer output. For example, 
suppose that your document currently contains a profile tailored for prepress output, but 
you want to proof the document colors on a desktop printer. In the Print dialog box, you 
can convert the document’s colors to the color space of the desktop printer; the printer 
profile will be used to convert colors from the current document profile to the printer 
profile when printing. If you select the Proof color space and target an RGB printer, you can 
send color data as RGB values to the printer.
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When printing to a PostScript printer, you also have the option of using PostScript color 
management. In this workflow, InDesign sends the document’s color data in a calibrated 
version of its original color space, along with the document profile, directly to the 
PostScript printer and lets the printer convert the document to the printer color space. The 
printer’s color space is stored at the device as a color rendering dictionary (CRD); this 
makes device-independent output possible. CRDs are PostScript equivalents of color 
profiles. The exact results of the color conversion can vary among printers. To use 
PostScript color management, you must have a printer that uses PostScript Level 2, 
version 2017 or later or PostScript 3; it is not necessary to install an ICC profile on your 
system for the printer, unless you intend to proof your output.

Important: Use PostScript color management only if you understand its complexities. For 
information on profiles and color-managed workflows, see “About color management” on 
page 337.

To color-manage a document using the document color space:

1 Choose Edit > Color Settings and turn on color management. 

2 Review or change your document color settings. To change document color settings, 
choose Edit > Assign Profiles or Edit > Convert to Profile, and make your changes. For 
details, see “Changing the color profile of a document” on page 350.

3 In the Color Management panel of the Print dialog box, under Print Space, choose an 
option for Profile:

• To print using the document’s current color profile, choose Document CMYK. No 
conversions will be performed on the colors when the document is printed.

• To print using a different destination profile, choose that profile from the list.

• To print to a PostScript printer and have colors managed at the level of the printer, 
choose PostScript Color Management.

4 If you choose PostScript Color Management for the Profile, you can also choose a color 
rendering dictionary in the CRD menu to change the printer’s default color space at 
output time. To do that, choose a CRD from the list; otherwise, leave the CRD option set 
at Default.

To color-manage a document using the proof color space:

1 Choose View > Proof Setup, and choose the output display you want to simulate. (See 
“Soft-proofing colors” on page 348.)

2 In the Color Management panel of the Print dialog box, under Source Space, 
select Proof. 

3 Choose the rendering intent to use when converting colors in the proof space to the 
printer color space. For more information, see “Specifying a rendering intent” on 
page 347.

Printing gradients, color blends, and transparencies
Files with gradients and color blends can be difficult for some printers to print smoothly 
(without discrete bands of color) or at all. You can take steps to improve the printed results 
of gradients and color blends on such printers. You can also improve the way in which 
transparent objects print.
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Improving gradients and color blends in print
PostScript Level 2 and PostScript 3 output devices can print up to 256 shades of gray, and 
most PostScript desktop laser printers are capable of printing approximately 32 to 64 
shades, depending on the device resolution, specified screen frequency, and halftoning 
method. Banding occurs when each available shade covers an area large enough for 
you to see individual shades. Also, if you specify a gradient using two percentage values 
that differ by less than 50%, you’re specifying a narrow range of shades that’s more likely 
to result in banding. If you have difficulty printing smooth gradients without banding, try 
these techniques:

• Use a gradient that changes at least 50% between two or more process 
color components.

• Specify lighter colors, or shorten the length of dark gradients. Banding is most likely to 
occur between very dark colors and white. 

• Increase the percentage of change in the gradient. (See “Working with gradients” on 
page 313.)

• Decrease the screen frequency for the document (PostScript output devices only). (See 
“Specifying the halftone screen frequency” on page 423.)

• If banding occurs in an imported graphic, such as an Adobe Illustrator file, you may 
need to adjust the original graphic.

• Print to a PostScript 3 output device, which is capable of producing smoother gradients.

• If you’re printing to a device that does not use halftone or stochastic screening (such as 
dye-sublimation or continuous-tone color laser printers), select Force Continuous Tone 
Behavior in the Advanced panel of the Print dialog box. 

• Use shorter gradients. The optimum length depends on the colors in the gradient, but 
try to keep gradients shorter than 7.5 inches. See “Calculating the maximum gradient 
length based on the color change” on page 404.

About halftone dots and printer dots
Most printers simulate gray by using halftone dots printed on a grid; the grid cells are 
called halftone cells, and the grid rows are called lines or line screens. Each halftone dot is 
made up of printer dots. As the halftone cell fills up with printer dots, the halftone dot gets 
larger, resulting in a darker shade of gray.
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Printer resolution determines the number of dots available to create the halftone dot. A 
printer with smaller dots can produce a wider variety of halftone dot sizes, allowing more 
shades of gray. Screen frequency also plays a role: As screen frequency increases, the 
halftone cell gets smaller, and so can hold fewer printer dots, resulting in fewer possible 
shades of gray. As a result, there is a tradeoff between the number of possible gray levels 
and image coarseness.

A. Continuous tone simulated by line screen B. Line screen consisting 
of halftone dots in rows C. Halftone dots consisting of printer dots

Ensuring that your resolution/line screen produces 256 grays
In printing your file, you may find that the resolution of your printer, when combined with 
the chosen line screen, allows fewer than 256 levels of gray. A higher screen frequency 
decreases the levels of gray available to the output device. For example, if you are printing 
at a resolution of 2400 dpi, using a line screen higher than 150 results in fewer than 256 
levels of gray.

The number of gray levels an output device supports depends on both the resolution and 
the capabilities of the device. If you are printing to a PostScript output device that uses 
halftone dots, use the values in the table. If you are using a device that supports improved 
screening technologies, such as a PostScript 3 output device with smooth shading, use a 
custom screen. (See “Specifying the halftone screen frequency” on page 423.)

B

A

C
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The following table lists the maximum line screens you can use with output devices and 
still maintain all 256 levels of gray.

Calculating the maximum gradient length based on the 
color change
InDesign calculates the number of steps in a gradient based on the percentage of change 
between the colors in the gradient. The number of steps, in turn, determines the 
maximum length of the gradient before banding occurs. 

The gradient’s number of steps and maximum length assume that you are printing the file 
with a line screen and resolution that produce 256 levels of gray.

To determine the maximum gradient length based on the color change:

1 Select the line tool , and drag from the beginning point and the endpoint of 
the gradient.

2 On a piece of paper, note the distance displayed in the Transform palette. This distance 
represents the length of the gradient.

3 Calculate the number of steps in the gradient by dividing the number of grays by the 
percentage change in color. 

To determine the percentage change in color, subtract the lower color value from the 
higher color value. For example, a gradient between 20% black and 100% black is an 
80%—or 0.8—change in color. 

Output Device Resolution Maximum Line Screen

300 19

400 25

600 38

900 56

1000 63

1270 79

1446 90

1524 95

1693 106

2000 125

2400 150

2540 159

3000 188

3252 203

3600 225

4000 250
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When creating a gradient using process colors, use the largest change between the colors. 
For instance, a gradient from 20% cyan, 30% magenta, 80% yellow, and 60% black to 20% 
cyan, 90% magenta, 70% yellow, and 40% black indicates a 60% change, because the 
greatest change occurs in magenta, from 30% to 90%.

4 Using the number of steps calculated in step 3, see if the length of the gradient is 
larger than that indicated in the table. If it is, reduce the length of the gradient or change 
the colors.

Note: The number of steps a printer supports depends on the resolution and imaging 
capabilities of the printer. This table presents recommendations for PostScript Level 2. 
PostScript 3 output devices have improved imaging capabilities
.

Number of Steps 
InDesign Recommends

Maximum Gradient Length

Points Inches Cms

10 21.6 .3 .762

20 43.2 .6 1.524

30 64.8 .9 2.286

40 86.4 1.2 3.048

50 108.0 1.5 3.810

60 129.6 1.8 4.572

70 151.2 2.1 5.334

80 172.8 2.4 6.096

90 194.4 2.7 6.858

100 216.0 3.0 7.620

110 237.6 3.3 8.382

120 259.2 3.6 9.144

130 280.8 3.9 9.906

140 302.4 4.2 10.668

150 324.0 4.5 11.430

160 345.6 4.8 12.192

Number of Steps 
InDesign Recommends

Maximum Gradient Length

Points Inches Cms

170 367.2 5.1 12.954

180 388.8 5.4 13.716

190 410.4 5.7 14.478

200 432.0 6.0 15.240
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Printing and saving transparent artwork
When your document contains transparent objects, InDesign performs a process called 
flattening before printing or exporting the document. For information, see “About 
flattening” on page 294 and “Controlling flattener settings and results using styles” on 
page 294.

Transparency exposes different and sometimes unfamiliar issues for Adobe applications 
and file formats. For tips on getting good output results, see “Setting up your transparent 
document for successful output” on page 296.

Viewing print settings
Use the Summary panel of the Print dialog box to view your output settings prior to 
printing, and then adjust them as necessary. For example, you can see if the document will 
omit certain graphics for OPI replacement by the service provider. 

To view a summary of output settings:

In the Print dialog box, click Summary.

To save the summary as a text file:

1 In the Summary panel of the Print dialog box, click Save Summary. 

2 Accept the default filename or type another name for the text file, and click Save.

Performing a preflight check
Before printing or handing off the document to a service provider, you can perform a 
quality check on the document. Preflight is the industry-standard term for this process. The 
preflight utility serves these purposes:

• Warns of problems that may prevent a document or book from imaging as desired, 
such as missing files or fonts.

• Provides helpful information about a document or book, such as the inks it uses, the 
first page a font appears on, and print settings.

210 453.6 6.3 16.002

220 475.2 6.6 16.764

230 496.8 6.9 17.526

240 518.4 7.2 18.288

250 540.0 7.5 19.050

256 553.0 7.7 19.507

Number of Steps 
InDesign Recommends

Maximum Gradient Length

Points Inches Cms
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To perform a preflight check for a document 
or a book:

1 Do one of the following:

• For a document, choose File > Preflight.

• For a book, in the Book palette menu choose Preflight Book or Preflight Selected 
Documents, depending on whether all, some, or none of the documents are selected in 
the Book palette. The Preflight dialog box opens with the current book settings.

The preflight utility checks hidden layers but does not check pasteboard content.

2 Using the Summary panel in the Preflight dialog box as a guide, check fonts, links, 
graphics, and other information. An alert icon ( ) indicates problem areas.

The Summary panel also displays the page number of any transparent object in a 
document, or the number of documents with transparent objects in a book. 

3 To show information for all layers, select Show Data for Hidden Layers on the Summary 
panel.

4 To list only missing or out-of-date links and RGB graphics, select Show Problems Only 
on the Fonts or Links and Images panel. 

5 Click Report at any time to save the current information on each of the preflight panels 
in a text file, which you can open in a text editor.

Viewing fonts 
The Fonts panel of the Preflight dialog box lists all fonts used in the document—including 
fonts embedded in EPS files, native Adobe Illustrator files, and placed PDF pages—and 
determines whether the font is installed on your computer. Selecting Show Problems Only 
lists only problem fonts. Make sure that the fonts you used in the document are licensed, 
installed, and activated (if you use a type manager, such as Adobe Type Manager Deluxe) 
on your computer or on the output device.

To correct missing fonts:

Close the Preflight dialog box and install the fonts on your computer or select a PPD with 
the fonts you need.

Viewing links and images
The Links and Images panel of the Preflight dialog box lists all links, embedded images, 
and PDF files used in the document—including DCS and OPI links from linked EPS 
graphics. Images embedded in EPS graphics are not included as links in the preflight 
report. The preflight utility indicates missing or out-of-date links, and any RGB images 
(which may not separate properly unless color management is on and set up correctly). 
(See “Managing links and embedded graphics” on page 235.)

To repair links and images:

1 To view only problem images, select Show Problems Only in the Links and Images panel 
of the Preflight dialog box.

2 To repair a link, do one of the following:

• Select the problem image and click either Update or Relink.

• Click Repair All.
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3 Locate the correct image files and click Open.

Viewing colors and inks
Using the document’s ink list, the preflight utility checks for spot colors with duplicate 
color definitions. A duplicate spot color will produce an additional separation plate.

To correct color and ink problems:

Close the Preflight dialog box and delete any duplicate spot colors in the Swatches 
palette. (See “Adding, duplicating, and deleting swatches” on page 305.)

Viewing print settings
The Print Settings panel of the Preflight dialog box reflects the current print settings for 
the document. 

Viewing external plugins 
The External Plugins panel of the Preflight dialog box lists all external plugins used in the 
document.

Packaging files for handoff
You can gather the files you’ve used, including fonts and linked graphics, for easy handoff 
to a service provider. You can give your service provider an InDesign file, a composite PDF 
file made from your document, or a PostScript file. (See “About PostScript files” on 
page 409.)

You don’t need to perform a final preflight check before packaging. InDesign performs an 
up-to-date preflight check. If problem areas are detected, a dialog box appears. 

To package files:

1 Do one of the following to open the Package dialog box:

• Choose File > Package. 

• In the Preflight dialog box, click Package.

• In the Book palette menu, choose Package Book or Package Selected Documents, 
depending on whether all, some, or none of the documents are selected in the Book 
palette. 

2 If a dialog box appears alerting you to possible problems, do one of the following:

• Click View Info to open the Preflight dialog box where you can correct problems or get 
further information. When you’re satisfied with the document, begin the packaging 
process again.

• Click Continue to begin packaging.

3 Fill in the printing instructions. The filename you type is the name of the report that 
accompanies all other packaging files. This report, which is saved in the default text editor 
format, includes the information in the Printing Instructions dialog box; a list of all used 
fonts, links, and inks required to print the document; and print settings. The report is 
stored in the same folder as the other packaging files.

4 Click Continue, and then specify a location in which to save all packaging files.

5 Select the following, as needed:
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• Copy Fonts (Roman Only) copies all necessary font files, not the entire typeface.

• Copy Linked Graphics copies linked graphics files. Linked text files are always copied.

• Update Graphic Links in Package changes graphic links (not text links) to the package 
folder location. If you want to relink text files, you must do so manually and check 
whether the formatting retains the appropriate view inside the document. (See 
“Editing and updating a linked text file” on page 90.)

• Include Fonts and Links from Hidden Layers packages the objects located on hidden 
layers.

• View Report opens the printing instructions report in a text editor immediately after 
packaging. To edit the printing instructions before completing the packaging process, 
click the Instructions button.

6 Do one of the following to specify how to handle hyphenation:

• To prevent the document from composing with the external user dictionary, and to 
prevent the document’s hyphenation exceptions list from merging with the external 
user dictionary, select Use Document Hyphenation Exceptions Only. You may want to 
select this option when packaging a document to be printed by someone outside your 
workgroup, such as when you take the document to a service provider.

• To allow the external user dictionary (on the computer on which the file is opened) to 
merge with the document’s hyphenation exceptions list, and to allow the document to 
compose using the exceptions lists stored in both the external user dictionary and 
inside the current document, leave Use Document Hyphenation Exceptions Only 
unselected.

7 Click Package to continue packaging.

About PostScript files
As an alternative to printing a document to a printer, you can save a PostScript-language 
description of the document as a .ps file for printing on remote printers, for example, by 
a prepress service provider.

The size of a PostScript file is usually larger than the original InDesign document, because 
the graphics and fonts are embedded. Once you create the PostScript file, you can copy it 
to a disk or other removable storage unit (such as a Zip disk), or use a modem to send it to 
the service provider. The service provider can then send the file directly to the imagesetter.

Note: Be sure to save the PostScript file to your hard disk before you transfer it to a 
network drive or to removable media. The slower access time between the hard disk and 
other drives can corrupt or lose data, thereby damaging your document or book.

You can save your InDesign document or book in any of three types of PostScript files: 
device-independent, device-dependent, or device- and driver-dependent. 
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Choosing the right method for creating a PostScript file
The following table lists recommended printer drivers and output methods for achieving 
the best results with post-processing applications and InDesign. If your document will be 
processed by an OPI server, or by an imposition, trapping, or other prepress application 
before it is printed by a RIP, choose PostScript File in the Printer menu in the InDesign Print 
dialog box. That way, InDesign has complete control over the DSC output. For desktop 
printing, use any supported PostScript printer driver.

* Printer driver isn’t used when printing to PostScript File. 
** PPD used by the selected printer is shown here. 

Creating a device-independent PostScript file
This type of PostScript file is created when PostScript File is selected in the Printer menu, 
and Device Independent is selected in the PPD menu. A device-independent PostScript 
file has the following characteristics:

• It is 100% DSC-compliant, making it ideal for such post-processing tasks as trapping 
and imposition. 

Printer selection: PostScript File

Operating 
system

Supported printer 
driver

PPD Prepress 
rating

All platforms n/a* Device-independent Best

n/a* Device-dependent Best

Printer selection: <installed printer>

Operating 
system

Supported printer 
driver

PPD Prepress 
rating

Mac OS 9.2 AdobePS 8.7.2 and 
later

n/a** Good

LaserWriter 8.7 and 
later

n/a** Poor

Mac OS 10.1 LaserWriter n/a** Good

Windows 
2000/XP

AdobePS 5 n/a** Good

Pscript 5 n/a** Good

Windows NT 
4.0

AdobePS 5.2 n/a** Good

Pscript 4 n/a** Poor

Windows Me/
98

AdobePS 4.5.1 n/a** Good

Pscript 4 n/a** Poor
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• All device and driver dependencies are removed, so that the file will print to almost 
any output device. However, special printer features found in PPD files, such as image 
exposure, available media sizes, optimized screen frequencies, and so on, aren’t 
available in device-independent output.

• The color output is always composite CMYK, but it also includes spot colors. As a 
result, it has to be separated in post-processing software, or at the RIP using in-RIP 
separations.

• It cannot be trapped by InDesign; trapping must occur at the RIP, or in post-
processing software.

• It can only be printed to file (not directly to a device or application) from InDesign.

• This type of file is ideal for composite prepress workflows, where the file will be trapped 
and separated later in the production process, such as during imposition, trapping, or 
at the RIP (if the PPD and output device support in-RIP separations).

To save your document or book as a device-independent PostScript file using 
InDesign: 

1 In the Print dialog box, for Printer, choose PostScript File.

2 For PPD, choose Device Independent.

3 View or change existing print settings. InDesign uses the current page range when 
creating the PostScript file.

4 Click Save.

5 Specify a name and location, and click Save.

Creating a device-dependent PostScript file
This type of PostScript file is created with a PPD selected, and has the following character-
istics:

• It is 100% DSC-compliant, making it ideal for such post-processing tasks as trapping 
and imposition.

• It contains a description of everything in your document, including information about 
linked files, optimized screen frequencies, resolution, and available media sizes tailored 
to the currently selected output device. 

• All driver dependencies are removed.

• It can be composite or separated. All of the color output methods that InDesign 
supports are available. (In-RIP separations are available if the PPD and output device 
support them.)

• It can be trapped by InDesign (either by using Application Built-In or Adobe In-RIP 
Trapping).

• It can only be printed to file (not directly to a device or application) from InDesign.

• This type of file is ideally suited to pre-separation or trapping workflows, where the file 
will be trapped using automatic or Adobe In-RIP Trapping features within InDesign.

To save your document or book as a device-dependent PostScript file using 
InDesign: 

1 In the Print dialog box, for Printer, choose PostScript File.
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2 Choose the PPD for the final output device.

3 View or change existing print settings. InDesign uses the current page range when 
creating the PostScript file.

4 Click Save.

5 Specify a name and location, and click Save.

Creating a device- and driver-dependent PostScript file
This type of PostScript file is created with a printer and supported driver selected, and has 
the following characteristics:

• It is driver-dependent. This means that the PostScript file will contain code generated 
by InDesign and by the driver. The InDesign code is primarily responsible for the page 
content, including font downloading, and for setting basic device information, such as 
media size, resolution, and screening. The driver is primarily responsible for setting 
special driver features, such as watermarks, and for enabling or controlling special 
device features it gets from the PPD. Since InDesign doesn’t have complete control over 
creating the PostScript file, the level of DSC compliance isn’t quite as high as it is with 
driver-independent PostScript files. The level of DSC compliance, and therefore the 
PostScript file’s suitability for prepress tasks, depends on the printer driver used. For 
recommended printer drivers, see “Choosing the right method for creating a PostScript 
file” on page 410.

• It is device-dependent. This means that it contains code for enabling and controlling 
specific device features, making it less compatible with devices other than the 
target device.

• It can be composite or separated (all of the color output methods that InDesign 
supports are available).

• It can be trapped by InDesign (either by using Application Built-In or Adobe In-RIP 
Trapping).

•  It can be printed directly to the device, or to file.

• This type of file is ideally suited for proofing (by the designer) to desktop PostScript 
printers. It can also be used by service providers who don't plan to do any prepress 
tasks to the job outside of InDesign or the RIP system. In other words, if trapping is 
done, it happens in InDesign or at the RIP. 

For a list of supported printer drivers and related information, see “About printer drivers” 
on page 385.

To save your document or book as a PostScript file using a PostScript printer driver 
(Windows):

1 In the InDesign Print dialog box, click the Setup button at the bottom of the dialog box.

2 In the printer driver’s dialog box, select Print to File.

3 If you’re using the AdobePS printer driver for prepress purposes, do the following:

• Click the Layout tab, and then click the Advanced button.

• Click Document Options, and then choose Optimize for Portability in the PostScript 
Options menu. Click OK.

4 Click OK or Print to return to the InDesign Print dialog box.
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5 In the InDesign Print dialog box, click Print.

6 Specify a name and location, and click Save.

To save your document or book as a PostScript file using a PostScript printer driver 
(Mac OS 9):

1 In the InDesign Print dialog box, click the Printer button at the bottom of the 
dialog box.

2 In the printer driver’s dialog box, choose File in the Destination menu, and then 
click Save.

3 Specify a name and location, and click Save.

4 In the InDesign Print dialog box, click Print.

To save your document or book as a PostScript file using a PostScript printer driver 
(Mac OS 10.1):

1 In the InDesign Print dialog box, click the Printer button at the bottom of the dialog 
box.

2 In the printer driver’s dialog box, choose Output Options in the pop-up menu.

3 Select the Save a File option.

4 Choose PostScript in the Format menu, and click Save.

5 Specify a name and location, and click Save.

6 In the InDesign Print dialog box, click Print.
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Producing Color Separations

Two common print workflows
Successful commercial printing of a document requires several steps: planning and 
organizing, design and content development, and prepress tasks, in which your electronic 
files are prepared to be reproduced with ink on paper. Although the steps are similar in 
today’s production and prepress workflows, the sequence a document follows from start 
to finish can vary considerably. For example, you can integrate proofing into the page 
assembly process, or proof your document at each step.

InDesign supports two common PostScript workflows; the main difference is where 
separations are created—at the host computer (the system using InDesign and the printer 
driver), or at the output device’s RIP (raster image processor). Another alternative is a PDF 
workflow; see “Producing Adobe PDF files for a high-resolution composite workflow” on 
page 362.

Host-based separations In the traditional host-based, preseparated workflow, InDesign 
creates PostScript information for each of the separations required for the document, and 
sends that information to the output device.

In-RIP separations In the newer RIP-based workflow, a new generation of PostScript RIPs 
performs color separations, trapping, and even color management at the RIP, leaving the 
host computer free to perform other tasks. This approach takes less time for InDesign to 
generate the file, and minimizes the amount of data transmitted for any given print job. 
For example, instead of sending PostScript information for four or more pages to print 
host-based color separations, InDesign sends the PostScript information for a single 
composite PostScript file for processing in the RIP. (See “Printing and saving separations” 
on page 425.)

About separations
To produce high-quality separations, it helps to be familiar with the basics of printing, 
including line screens, resolution, process colors, and spot colors.

It is also recommended that you work closely with the print shop that will produce your 
separations, consulting its experts before beginning each job and during the process.
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To reproduce color and continuous-tone images, printers usually separate artwork into 
four plates—one plate for each of the cyan, magenta, yellow, and black portions of the 
image. When inked with the appropriate color and printed in register with one another, 
these colors combine to reproduce the original artwork. The process of dividing the image 
into two or more colors is called color separating, and the films from which the plates are 
created are called the separations. 

Composite (left) and separations (right)

Outputting to CMYK 
When you’re preparing an image to be printed, artwork is separated into CMYK output 
with the process colors cyan (C), magenta (M), yellow (Y), and black (K). (The letter K is 
used for black to avoid confusion, because B might also stand for blue.)

Outputting spot colors
You can use custom inks, called spot colors, in addition to, or in place of, process colors. For 
example, instead of using the four process colors to reproduce artwork consisting of black 
text and bluish-green line drawings, you could use two spot colors—one of black, and one 
representing the exact shade of green. In addition, you can use spot color inks to produce 
colors not reproducible by CMYK inks, such as fluorescent and metallic colors.

You can use the Color palette to display the CMYK equivalent of a spot color.

To view the process color equivalents of a spot color:

1 Select the spot color in the Swatches palette.

2 Choose CMYK in the Color palette menu. 

The CMYK equivalent values for the spot color are displayed in the Color palette. 

You can also hold the cursor over the spot color in the Swatches palette. The formula 
for the color will appear in the tool tip.

Outputting registration colors
If you want to print a color on all plates in the printing process, including spot color plates, 
you can apply registration color to the objects. For composite output, these objects will 
print as C 100, M 100, Y 100, and K 100. For separations, these objects will print as 100% on 
each plate.

Registration color is typically used for crop marks and trim marks. (See “Specifying printer’s 
marks” on page 420.)
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To output registration color:

1 Select the objects to which you want to apply registration color.

2 Choose Window > Swatches.

3 In the Swatches palette, click the Registration color swatch ( ). 

Steps for producing color separations
You can color-separate a document from InDesign, or prepare a document for in-RIP 
separations. To produce in-RIP separations, you need the following software and 
hardware:

• A PPD file that supports in-RIP separations.

• Any PostScript 3 output device, or a PostScript Level 2 device whose RIP supports in-RIP 
separations. 

Once you’ve created separations of the InDesign document, the settings you’ve chosen in 
the Print dialog box are saved with the separated file. If you open a file that has never been 
separated in InDesign, the program returns to the default settings. To quickly apply 
custom separation settings to a document, use a printer style.

To prepare your document for color separations:

1 Correct any color problems in your artwork. (See “Checking colors in your document” 
on page 417.)

2 Set overprint options. (See “Selecting overprint options for overlapping colors” on 
page 418.)

3 Specify the appropriate printer’s marks and bleed options. (See “Specifying printer’s 
marks” on page 420, and “Specifying the bleed area” on page 422.)

4 Create trapping instructions to compensate for misregistration on press. (See “Trapping 
a document” on page 326.)

Note: Steps 1–4 are recommended but not required in producing color separations.

5 If you’ve created a printer style with the appropriate separation settings, select it in the 
Printer Style menu at the top of the Print dialog box. (See “Using styles for printing” on 
page 388.)

6 Choose a printer or PostScript® file in the Printer menu.

7 If you’re printing to a PostScript file, choose the PPD for the device that will output the 
separations.

8 To view or change existing print options, click a panel on the left side of the Print dialog 
box. 

9 Before you deliver your document to a service provider, proof the separations. (See 
“Proofing color separations” on page 425.)

10 Print or save separations. (See “Printing and saving separations” on page 425.)
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Checking colors in your document 
Printed colors may not match the colors that were displayed on your monitor. For 
example, an object that looked red on-screen may now look orange. At this point, you 
need to correct any color problems in your artwork. You should also verify that your 
monitor has been characterized, as described in “Creating an ICC monitor profile” on 
page 353.

If your document is color managed, you can preview how a color will appear when repro-
duced on a particular output device. (See “Proofing color separations” on page 425.)

Types of colors you can use, and how they are separated
You can color artwork with process colors, spot colors, or a combination of both. For infor-
mation on your color choices, see “Adding, duplicating, and deleting swatches” on 
page 305. 

When printing separations, you can convert spot colors to their process color equivalents 
so that they will be printed on the CMYK plates. (See “Separating spot colors as process 
colors” on page 423.)

Using process colors that don’t need trapping
You can avoid the need for trapping by designing your document in such a way that your 
use of colors eliminates the possibility of misregistration. You can prevent misregistration 
by making sure that abutting process colors have common inks. For example, if you 
specify a dark purple stroke with a vivid red fill, they will both contain a significant 
percentage of magenta. The stroke’s and fill’s common magenta will print as a single area, 
so that if misregistration occurs in the other process inks, the magenta printing plate will 
make any resulting gap hard to see.

Printing gradients as separations
Consider the following when producing separations for documents with gradients:

• A gradient created in InDesign that contains a combination of spot and process colors 
will be separated onto both the process and spot plates. 

• A gradient that contains process colors will be separated onto the process plates.

• A gradient that contains two tints of the same spot color will be separated onto a single 
spot color plate. 

• To create a gradient that separates on one piece of film between a spot color and white, 
create a gradient fill between the spot color and a 0% tint of the color. 

• If you create a gradient between two spot colors, you should assign different screen 
angles to those spot colors in the Separation Setup dialog box. This is because if two 
spot colors have the same screen angle, they will overprint each other. If you’re not sure 
what the angles should be, consult with your prepress service provider. (See “Speci-
fying the halftone screen frequency” on page 423.)
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Selecting overprint options for overlapping colors
If you have not changed the transparency of your artwork with the Transparency palette, 
the fills and strokes in the artwork will appear opaque, because the top color knocks out, or 
cuts out, the area underneath. You can prevent knockout by using the Overprint options 
in the Attributes palette. After you’ve set your overprint options, you can preview the 
overprinting effects on-screen. (See “Viewing how colors will overprint” on page 420.)

InDesign also has overprint simulation, which is useful for simulating the effects of 
overprinting spot inks. You can view the overprinting effects on a composite printing 
device. (See “Simulating overprinting of spot inks” on page 420.)

Deciding when to manually overprint strokes or fills
Automatic trapping in InDesign—either as built-in trapping or Adobe In-RIP Trapping—
nearly eliminates the need for manual overprinting. However, manual overprinting can be 
an effective solution in the rare cases when you can’t use automatic trapping.

Use the following guidelines to determine whether or not to use overprinting:

• Consult with your service provider to see if their output devices support manual 
overprinting.

• Overprint when the artwork doesn’t share common ink colors and you want to create a 
trap or overlaid ink effects. When overprinting process color mixes or custom colors 
that don’t share common ink colors, the overprint color is added to the background 
color. For example, if you print a fill of 100% magenta over a fill of 100% cyan, the 
overlapping fills appear violet, not magenta.

• Don’t overprint when using a stroke to trap two process colors. Instead, you specify a 
CMYK stroke color that uses the higher value from the corresponding inks in each 
original color. 

• Make sure that you and your prepress service provider agree on when and how to 
overprint manually, because doing so will significantly affect trapping options 
specified in the Print dialog box. Overprinting is supported by most, but not all, 
PostScript Level 2 and PostScript 3 devices. 

Overprinting black
Many commercial printers traditionally overprint some or all instances of black ink. This 
helps prevent misregistration of small black-type characters positioned over color areas, 
or of color areas outlined with black lines.

By default, InDesign always overprints process black (shown as [Black] in the Swatches 
palette). This includes all black strokes, fills, and text characters of any size. It can be 
cheaper and easier to have the print shop overprint black on the press. You can choose to 
overprint black either when printing or when saving selected separations. If you disable 
Overprint Black, all instances of Black knock out (remove underlying inks).

Note: Overprint Black does not work for objects that appear black because of their trans-
parency settings or styles.

To change the black overprint setting:

1 Choose Edit > Preferences > General.

2 In the Print Options section, select or deselect Overprint Black.
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Manually overprinting strokes or fills
You can overprint strokes or fills of any selected paths using the Attributes palette. An 
overprinted stroke or fill doesn’t need to be trapped, because overprinting covers any 
potential gaps between adjacent colors. You can also overprint a stroke to simulate a trap 
(by overprinting a color you’ve manually calculated as the proper combination of two 
adjacent colors). 

Keep the following guidelines in mind as you apply manual overprinting:

• If you use the Overprint Fill option on a 100% black stroke or fill, the black ink may not 
be opaque enough to prevent the underlying ink colors from showing through. To 
eliminate the show-through problem, use a four-color (rich) black instead of a 100% 
black. Consult with your service provider about the exact percentages of color to add to 
the black.

• When using a stroke to trap objects (but not text characters), select a stroke weight that 
is twice the required trap width. This is because the stroke is applied to the center of its 
path, so you are overprinting only half of the stroke width beyond the object’s 
boundary.

• When using a stroke to trap two spot colors or a spot and a process color, you usually 
apply the lighter color to the stroke, and overprint the stroke.

To overprint a stroke or fill:

1 Select one or more paths with the selection  tool or direct-selection tool , or select 
text characters with the type tool . To overprint the stroke of a path that is pasted inside 
a frame, you must first select the nested (inner) path using the direct-selection tool.

A. Cyan (bottom layer) B. Magenta (middle layer)  C. Yellow (top layer)

2 Choose Window > Attributes.

3 In the Attributes palette, do one or both of the following:

• To overprint the fill of selected objects, or to overprint unstroked type, select Overprint 
Fill.

• To overprint the stroke of selected objects, select Overprint Stroke.

To overprint a paragraph rule:

1 Make sure a swatch exists for your overprint color.

2 Using the type tool , click an insertion point in a paragraph.

3 In the Paragraph palette, choose Paragraph Rules in the Paragraph palette menu.

C

BA
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4 In the pop-up menu at the top of the dialog box, choose the paragraph rule you want 
to overprint.

5 Select Overprint Stroke, and click OK.

The Overprint Stroke option in the Paragraph Rules dialog box can be part of a 
paragraph style.

Viewing how colors will overprint
Overprint Preview mode provides an on-screen “ink preview” that approximates how 
blending, transparency, and overprinting will appear in color-separated output. However, 
it’s important that you carefully check overprinted colors on separated documents using 
integral or overlay proofs. 

Note: You can also see overprinting effects when you output to a composite printing 
device. This is useful for proofing color separations.

Appearance of artwork on monitor and printed artwork

To preview how colors will overprint and blend:

Choose View > Overprint Preview.

Simulating overprinting of spot inks
Overprint simulation is useful for simulating the effects of overprinting spot inks with 
different neutral density values (for example, red and blue). When you print to a composite 
output device using overprint simulation, you can see if the resulting color is one that you 
want to overprint or knock out. For more information about neutral density, see “Adjusting 
ink neutral density values” on page 330.

To simulate overprinting:

1 In the Output panel of the Print dialog box, choose a composite option in the 
Color menu.

2 Select Simulate Overprint.

Specifying printer’s marks
When you prepare a document for printing, a number of marks are needed to help the 
printer align separation films when producing proofs, measuring film for correct 
calibration and dot density, trimming film to size, and so on. Selecting any page-mark 
option expands the page boundaries to accommodate printer’s marks or bleed, (the parts 
of text or objects that extend beyond the page boundaries after trimming).



Using Help | Contents | Index Back 421  

Adobe InDesign Help Producing Color Separations 

Using Help | Contents | Index Back 421  

If you are setting crop marks and want the artwork to contain a bleed area (a margin 
added to the page so that it can be trimmed after printing), make sure that you extend the 
artwork past the crop marks to accommodate the bleed. (See “Specifying the bleed area” 
on page 422.)

Also make sure that your media size is large enough to contain the page and any printer’s 
marks and bleeds. If a document doesn’t fit the media, you can control where items are 
clipped by using the Page Position option in the Setup panel of the Print dialog box. (See 
“Setting output size and handling options” on page 391.)

A. Crop marks B. Registration marks C. Page information D. Color bars E. Bleed marks

The Marks & Bleeds panel includes the following options:

All Printer’s Marks Selects all printer’s marks at once.

Type Lets you choose default printer’s marks or custom marks, if provided by other 
companies (for Japanese pages, for example). 

Crop Marks Adds fine (hairline) horizontal and vertical rules that define where the 
page should be trimmed. Crop marks can also help register (align) one color separation 
to another.

Color Bars Adds small squares of color representing the CMYK inks and tints of gray (in 
10% increments). Your service provider uses these marks to adjust ink density on the 
printing press.

Registration Marks Adds small “targets” outside the page area for aligning the different 
separations in a color document.

Page Information Prints the filename, page number, current date and time, and color 
separation name in 8-point Arial (Windows) or 8-point Helvetica (Mac OS) in the lower left 
corner of each sheet of paper or film. The Page Information option requires 0.5 inches 
(13mm) along the horizontal edge.

Offset Specifies how far from the edge of the page (not the bleed) InDesign will draw 
printer’s marks. By default, InDesign draws printer’s marks 6 points from the edge of the 
page. To avoid drawing printer’s marks on a bleed, be sure to enter an Offset value greater 
than the Bleed value.

Weight Displays possible weights for crop and bleed mark lines.

Bleed Marks Adds fine (hairline) rules that define the amount of extra area to image 
outside the defined page size.

A

D

E
C

B
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To include printer’s marks on the separations:

1 Choose File > Print.

2 Click Marks & Bleeds on the left side of the Print dialog box.

3 Select either All Printer’s Marks or individual marks.

Specifying the bleed area
The bleed is the amount of artwork that falls outside the printing bounding box, or 
outside the crop marks. You can include bleed in your artwork as a margin of error—to 
ensure that the ink still extends to the edge of the page after the page is trimmed or to 
ensure that an image can be stripped into a keyline in a document. Once you create the 
artwork that extends into the bleed, you can use InDesign to specify the extent of the 
bleed. Files saved in PostScript file format allow capable post-processing programs to 
implement their own variable bleed. (See “About PostScript files” on page 409.)

Changing the bleed moves the crop marks farther from or closer to the image; the crop 
marks still define the same size printing bounding box, however.

To specify the bleed area:

1 Choose File > Print.

2 Click Marks & Bleeds on the left side of the Print dialog box.

3 Enter values from 0 to 6 inches (or equivalent) for the Top, Bottom, Left, and Right text 
boxes (for single-sided documents), or Top, Bottom, Inside, and Outside (for double-sided 
documents with facing pages). These values specify the placement of the Bleed marks. 

Note: Bleed marks appear only if you select the Bleed Marks option in the 
Marks & Bleeds panel.

Specifying which colors to separate 
Each separation is labeled with the color name that InDesign assigned it. If an icon of a 
printer  appears next to the color name, InDesign creates a separation for the color. Any 
spot inks—including those defined and used in imported PDF files or EPS graphics—also 
appear in the ink list. 

To specify whether to create a separation for a color:

1 In the Output panel of the Print dialog box, select Separations or, if you use a PPD file 
that supports in-RIP separations, select In-RIP Separations.

2 Do one of the following:

• By default, InDesign creates a separation for every process and spot color in the 
document. To create a separation, make sure that the printer icon is displayed next to 
the color name in the ink list. 

• To choose not to create a separation, click the printer icon next to the color’s name. The 
printer icon disappears, and no separation is created. 
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Separating spot colors as process colors
You can convert all spot colors to equivalent CMYK process colors in the Ink Manager. 
When spot colors are converted to their process color equivalents, they are printed as 
separations rather than on a single plate. Converting a spot color is useful if you’ve 
accidentally added a spot color to a process color document, or if the document contains 
more spot colors than are practical to print. This conversion doesn’t affect how the colors 
are defined in the document. For more information, see “Using the Ink Manager” on 
page 317.

Note: You can also print a spot color as a different ink. (See “Creating an alias for a spot 
color” on page 318.)

Specifying the halftone screen frequency
In commercial printing, continuous tone is simulated by dots (called halftone dots) printed 
in rows (called lines or line screens). Lines are printed at different angles to make the rows 
less noticeable. The Screening menu in the Output panel of the Print dialog box displays 
the recommended sets of line screens in lines per inch (lpi), and resolutions in dots 
per inch (or dpi), based on the currently selected PPD. As you select inks in the ink list, 
the values in the Frequency and Angle text boxes change, showing you the halftone 
screen frequency and angle for that ink. 

A high line-screen ruling (for example, 150 lpi) spaces the dots closely together to create 
a finely rendered image on the press; a low line-screen ruling (60 lpi to 85 lpi) spaces the 
dots farther apart to create a coarser image. The size of the dots is also determined by the 
line screen. A high line-screen ruling uses small dots; a low screen ruling uses large dots. 
The most important factor in choosing a line-screen ruling is the type of printing press 
your job will use. Ask your service provider how fine a line screen its press can hold, and 
make your choices accordingly.

The PPD files for high-resolution imagesetters offer a wide range of possible screen 
frequencies, paired with various imagesetter resolutions. The PPD files for low-resolution 
printers typically have only a few choices for line screens, usually coarser screens of 
between 53 lpi and 85 lpi. The coarser screens, however, give optimum results on low-
resolution printers. Using a finer screen of 100 lpi, for example, actually decreases the 
quality of your image when you use a low-resolution printer for final output. 

To specify a halftone screen frequency and resolution:

In the Output panel of the Print dialog box, choose one of the following options:

• To select one of the preset screen frequencies and printer resolution combinations, 
choose an option in the Screening menu.

• To specify a custom halftone screen frequency, select the plate to be customized, and 
then enter the lpi value in the Frequency text box and a screen angle value in the Angle 
text box.

Note: Before creating your own halftone screens, check with your service provider for the 
preferred frequencies and angles. Also, be aware that some output devices override the 
default frequencies and angles.
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Specifying the emulsion and image exposure
Depending on the type of printing press used and how information is transferred from the 
film to the printing plates, you may need to give your service provider film negatives or 
positives, with emulsion side up or down. Emulsion refers to the photosensitive layer on a 
piece of film or paper. Typically, service providers require negative film in the United States 
and positive film in Europe and Japan. Check with your service provider to determine 
which emulsion direction they prefer.

To tell whether you are looking at the emulsion side or the nonemulsion side (also referred 
to as the base), examine the final film under a good light. One side appears shinier than 
the other. The dull side is the emulsion side; the shiny side is the base.

A. Positive image B. Negative C. Negative with emulsion side down

Important: The emulsion and image exposure settings in the InDesign Print dialog box 
will override any conflicting settings in the printer driver. Always specify print settings 
using the InDesign Print dialog box.

To specify emulsion:

1 In the Output panel of the Print dialog box, for Color, choose Composite Gray or a 
separation option. 

2 For Flip, select one of the following options:

• None (the default), to make no changes to the orientation of the imageable area. Type 
in the image is readable (that is, “right reading”) when the photosensitive layer is facing 
you.

• Horizontal, to mirror the imageable area across a vertical axis so that it is “wrong 
reading.”

• Vertical, to mirror the imageable area across a horizontal axis so that it is upside down.

• Horizontal & Vertical, to mirror the imageable area across the horizontal and vertical 
axes so that it is wrong reading. Type is readable when the photosensitive layer is facing 
away from you. Images printed on film are often printed Horizontal & Vertical.

To specify the image exposure:

1 In the Output panel of the Print dialog box, for Color, choose Composite Gray or a 
separation option. 

2 Select or deselect the Negative option.

A B C
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Checking your separation and document settings
The Summary panel in the Print dialog box displays a summary of color management 
information, printer’s marks dimensions, and bleeds for the document. The panel also 
indicates whether trapping has been enabled. 

You can also perform a quality check before printing or handing off the document to a 
service provider. (See “Performing a preflight check” on page 406.)

Proofing color separations
You can create a hard proof to verify that colors will print on the correct separations, or a 
soft proof to preview how your document’s colors will look when reproduced on a 
particular output device. (See “Soft-proofing colors” on page 348.)

Note: Unless you have been using a color management system (CMS) with accurate ICC 
profiles, the on-screen colors may be unreliable.

The hard proof represents your expectation of the way the final separations will appear, 
and helps the service provider to verify that the output is correct. Be sure to print proofs 
on a PostScript printer; you cannot reliably proof color separations printed from a non-
PostScript printer. 

For assurance that the file will print correctly, consider saving the separations as a 
PostScript file, converting the PostScript file to Acrobat PDF using Acrobat Distiller, and 
then viewing the PDF document in Acrobat. By viewing the PDF document in Acrobat, you 
can inspect high-quality PostScript output on-screen at a high level of detail.

Printing and saving separations
Depending on the prepress software available, a service provider may be able to perform 
such prepress activities as trapping, imposition, separating, and OPI replacement at the 
output device’s RIP. Therefore, your service provider may prefer to receive a composite 
PostScript file of the document optimized for in-RIP separations, rather than a presepa-
rated PostScript file.

Performing in-RIP separations requires a PostScript 3 output device, or a PostScript Level 2 
device whose RIP supports in-RIP separations. If the document contains duotones from 
Photoshop 5.0 or later, a PostScript 3 device is required to generate in-RIP separations. You 
also need to select a PPD file that supports this device.

Saving the file saves the separation settings, the PPD information, and any color conver-
sions you have specified in the Print dialog box.

Note: To use Adobe In-RIP Trapping, you must be working with in-RIP rather than host-
based separations. Otherwise, the trapping feature won’t have access to all of the colors at 
once, and trapping won’t occur.

To print or save separations:

1 At the top of the Print dialog box, choose a style in the Printer Style menu, if one with 
the appropriate separation settings exists.

2 Do one of the following:

• To print to an output device, choose the device in the Printer menu.



Using Help | Contents | Index Back 426  

Adobe InDesign Help Producing Color Separations 

Using Help | Contents | Index Back 426  

• To print to a file, choose PostScript® File in the Printer menu. Then choose a PPD that 
supports the output device. For more information, see “About PostScript files” on 
page 409.

3 Click General, and specify the pages to separate.

4 Click Output, and do one of the following:

• To print to an output device, choose Separations to create the separations in InDesign.

• To print to a file, choose either Separations, or In-RIP Separations to save separation 
settings in a composite PostScript file for processing in the RIP. 

5 Click Graphics, and do the following:

• For Send Data, choose All.

• For Fonts, choose Complete or Subset, unless fonts will be inserted later (for example, at 
the RIP or by a post-processing application). 

• For PostScript®, select the PostScript level of the output device: Level 2 or Level 3.

6 Click Advanced, and do any of the following:

• To replace low-resolution graphics embedded in placed EPS files with their high-
resolution versions at output time, make sure that Read Embedded OPI Links was 
selected when the EPS file was placed in the InDesign document, and then select OPI 
Image Replacement in the Advanced panel of the Print dialog box. For information 
about OPI linking and EPS files, see “EPS (.EPS)” on page 226.

• To omit different imported graphics types for later replacement by an OPI server, select 
from the Omit For OPI options. For more information, see “Setting common export 
options” on page 251.

• For Transparency Flattener Style, choose [High Resolution] or an available custom style 
with high-resolution settings.

7 Choose any other print options.

8 Do one of the following:

• To print to an output device, click Print.

• To print to a file, click Save and accept the default filename, or type another name for 
the file. Then click Save again.
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Macintosh Shortcuts

Selecting and moving objects

*Press Shift to constrain movement to 45 degree angles.

**Amount is set in Edit > Preferences > Units & Increments.

Editing paths and frames

Result Action

Temporarily selects  or  (last used) Any tool (except selection tools) + 

Temporarily selects  (group-
selection tool)

 + ; or , , or  +  + 

Adds to or subtracts from a selection 
of multiple objects

, , or  +  –click (to deselect with , 
click center point)

Duplicates selection when  appears , ,  +  –drag *

Duplicates and offsets selection**  + , , , or 

Duplicates and offsets selection by 
10 times**

 +  + , , , or 

Moves selection**  , , , or 

Moves selection by 10 times**  + , , , or 

Selects master page item from 
document page

  or  +  +  –click

Selects next object behind or in front  +  –click or  +  +  –click

Selects next object under pointer or in 
front of selected object 

 +  + ] or [

Selects next or previous frame in story  +  + Page Down or Page Up

Selects first or last frame in story  +  +  + Page Up or Page Down

Result Action

Temporarily selects  +  + , or  +  

Temporarily switches between  and   

Temporarily selects  + 
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Tables

Keeps  selected when pointer is over 
path or anchor point

 + 

Moves anchor point and handles 
while drawing

 + spacebar

Result Action

Insert Table  +  +  + T

Insert row  + 9

Insert column  +  + 9

Insert or delete rows or columns 
while dragging

Begin dragging row or column border, 
and then hold down  as you drag

Delete row  + Delete

Delete column  + Delete

Resize rows or columns without 
changing the size of the table

 –drag interior row or column border

Resize rows or columns proportionally  –drag right or bottom table border

Move to next cell Tab

Move to previous cell  + Tab

Move to first cell in column  + Page Up

Move to last cell in column  + Page Down

Move to first cell in row  + Home

Move to last cell in row  + End

Move to first row in frame Page Up

Move to last row in frame Page Down

Start row on next column Enter (numeric keypad)

Start row on next frame  + Enter (numeric keypad)

Toggle between selecting and 
deselecting cell

Esc 

Select cell  + /

Select row  + 3

Select column  +  + 3
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Transforming objects

*After you select the transform tool, hold down the mouse button, and then hold down Option and drag. 
Press Shift to constrain movement to 45 degree angles.

**Press Option to increase or decrease size by five percent.

Finding and changing text

Select entire table  +  + A

Table Options dialog box  +  + T

Cell Options dialog box  +  + B

Result Action

Duplicates and transforms selection , , or  +  –drag*

Displays Transform palette Double-click , , or  in toolbox

Resizes selection proportionately  +  

Increases size by one percent**  + .

Decreases size by one percent**  + ,

Resizes graphics frame and content  +  –drag

Constrains proportion  , , or  +  –drag

Result Action

Inserts selected text into Find What box  + F1

Inserts selected text into Find What box 
and finds next

 + F1

Finds next occurrence of Find What text  + F2 or  +  + F 

Inserts selected text into Change To box  + F2

Replaces selected text with 
Change To text

 + F3

Replaces selected text with 
Change To text and finds next

 + F3
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Working with type 

Result Action

Bold  +  + B

Italic  +  + I

Normal  +  + Y 

Underline  +  + U

Strikethrough  +  + /

All caps (on/off )  +  + K

Small caps  +  + H

Superscript  +  + + (plus sign)

Subscript  +  +  + + (plus sign)

Resets horizontal/vertical scale to 100%  +  + X or  +  +  + X 

Aligns left, right, or center  +  + L, R, or C 

Justifies all lines  +  + F (all lines) or J (all but last line)

Increases or decreases point size*  +  + > or < 

Increases or decreases point size by 5 
times*

 +  +  + > or <

Increases or decreases leading*  +  or 

Increases or decreases leading by 5 
times*

 +  +  or 

Selects or deselects preferences setting 
for typographer’s marks

 +  +  + “

Autoleading  +  +  + A

Aligns to grid (on/off )  +  +  + G

Auto-hyphenates (on/off )  +  +  + H

Increases or decreases kerning and 
tracking 

 +  or 

Increases or decreases kerning and 
tracking by five times

 +  +  or 

Increases kerning between words*  +  + \

Decreases kerning between words*  +  + Delete
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*Press Shift to increase or decrease kerning between words by 5 times.

**Amount is set in Edit > Preferences > Units & Increments.

Navigating through and selecting text 

Clears all manual kerning and resets 
tracking to 0

 +  + Q

Increases or decreases baseline shift**  +  +  or 

Increases or decreases baseline shift by 5 
times

 +  +  +  or 

Automatically flows story  –click loaded text icon

Semi-automatically flows story –click loaded text icon

Recomposes all stories  +  + /

Inserts current page number  +  + N

Inserts section marker text (or place-
holder)

 +  +  + N

Result Action

Moves to right or left one character  or 

Moves up or down one line  or 

Moves to right or left one word  +  or 

Moves to start or end of line Home or End key

Moves to previous or next paragraph  +  or 

Moves to start or end of the story  + Home or End key

Selects one word Double-click word

Selects one word right or left  +  +  or 

Selects one character right or left  +  or 

Selects one line above or below  +  or 

Selects start or end of line  + Home or End key

Selects one paragraph Triple-click or quadruple-click paragraph, 
depending on Text Preferences setting

Selects one paragraph before or after  +  +  or 

Selects current line  +  + \

Selects characters from insertion point  – click
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Viewing

Selects start or end of story  +  + Home or End key

Result Action

spacebar (with no text insertion point), 
 –drag (with text insertion point), or  

+ spacebar, and then release 

 + spacebar

 +  + spacebar or  + 

Fits page in window  + 0

Fits spread in window Double-click  or  +  + 0

Displays 100% magnification  + 1 or double-click  

Zooms to 50%, 200%, or 400%  + 5, 2, or 4

Redraws screen  + F5

Switches between current and previous 
zoom levels

 +  + 2

Scrolls up or down one screen Page Up or Page Down 

Goes back or forward to last-
viewed page

 + Page Up or Page Down 

Goes to previous or next spread  + Page Up or Page Down 

Cycles through units of measurement  +  +  + U

Snaps guide to ruler increments  –drag guide

Selects first or last frame  +  +  + Page Up or Pag Down

Selects previous or next frame  +  + Page Up or Page Down

Selects page number in page box  + J 

Goes to master page while Pages palette 
is closed

 + J, type prefix of master, press Enter

Selects magnification box in 
document window

 +  + 5 (main keyboard)

Switches between page and spread 
guides (creation only)

 –drag guide

Creates vertical and horizontal ruler 
guides for the spread

 –drag from zero point 
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Indexing

Typical display resolution  +  + Z

Optimized display resolution  +  + O

High-quality display resolution  +  + H

Selects all guides  +  + G

Locks or unlocks zero point Control–click zero point and choose 
option

Uses current magnification for view 
threshold of new guide 

 –drag guide

Selects buttons in alert dialog boxes Press first letter of button name, 
if underlined

Information on installed plug-ins and 
InDesign components

 + Apple menu > About InDesign

Result Action

Index palette  + F8

Create index entry without dialog box  +  + U

Create proper name index entry 
(last name, first name)

 +  + F8

Open Add Page Reference dialog box  + U
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Windows Shortcuts

Selecting and moving objects

*Press Shift to constrain movement to 45 degree angles. 

**Amount is set in Edit > Preferences > Units & Increments.

Editing paths and frames

Result Action

Temporarily selects  or  (last used) Any tool (except selection tools) + Ctrl

Switches between  and  Hold down Ctrl and press Tab

Temporarily selects  (group-
selection tool)

 + Alt; or , , or  + Alt + Ctrl

Adds to or subtracts from a selection of 
multiple objects

, , or  +  –click (to deselect with , 
click center point)

Duplicates selection when  appears , ,  + Alt–drag*

Duplicates and offsets selection** Alt + , , , or 

Duplicates and offsets selection by 10 
times**

Alt +  + , , , or 

Moves selection** , , , or 

Moves selection by 10 times**  + , , , or 

Selects master page item from 
document page

  or  +  + Ctrl–click

Selects next object behind or in front  + Ctrl–click or  + Alt + Ctrl–click

Selects next object under pointer 
or in front of selected object 

 Alt + Ctrl + ] or [

Selects next or previous frame in stroy Alt + Ctrl + Page Down or Page Up

Selects first or last frame in story  + Alt + Ctrl + Page Up or Page Down

Result Action

Temporarily selects  + Alt + Ctrl, or  + Alt 

Temporarily switches between  and  Alt 
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Tables 

Temporarily selects  + Alt

Keeps  selected when pointer 
is over path or anchor point

 + 

Moves anchor point and handles 
while drawing

 + spacebar

Result Action

Insert Table  + Alt + Ctrl + T

Insert row Ctrl + 9

Insert column Alt + Ctrl + 9

Insert or delete rows or columns 
while dragging

Begin dragging row or column border, 
and then hold down Alt as you drag

Delete row Ctrl + Backspace

Delete column  + Backspace

Resize rows or columns without 
changing the size of the table

 –drag interior row or column border

Resize rows or columns proportionally  –drag right or bottom table border

Move to next cell Tab

Move to previous cell  + Tab

Move to first cell in column Alt + Page Up

Move to last cell in column Alt + Page Down

Move to first cell in row Alt + Home

Move to last cell in row Alt + End

Move to first row in frame Page Up

Move to last row in frame Page Down

Start row on next frame  + Enter (numeric keypad)

Start row on next column Enter (numeric keypad)

Toggle between cell and text selection Esc 

Select cell Ctrl + /

Select row Ctrl + 3
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Transforming objects

*After you select the transform tool, hold down the mouse button, and then hold 
down Alt and drag. Press Shift to constrain movement to 45 degree angles.

**Press Alt to increase or decrease size by five percent.

Finding and changing text

Select column Alt + Ctrl + 3

Select entire table Alt + Ctrl + A

Table Options dialog box Alt + Ctrl + T

Cell Options dialog box Alt + Ctrl + B

Result Action

Duplicates and transforms selection , , or  + Alt–drag*

Displays Transform palette Double-click , , or  in toolbox

Resizes selection proportionately  +  

Increases size by one percent** Ctrl + .

Decreases size by one percent** Ctrl + ,

Resizes graphics frame and content  + Ctrl–drag

Constrains proportion  , , or  +  –drag

Result Action

Inserts selected text into Find What box Ctrl + F1

Inserts selected text into Find What box 
and finds next

 + F1

Finds next occurrence of Find What text  + F2 or Alt + Ctrl + F 

Inserts selected text into Change To box Ctrl + F2

Replaces selected text with 
Change To text

Ctrl + F3

Replaces selected text with Change To 
text and finds next

 + F3
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Working with type

Result Action

Bold  + Ctrl + B

Italic  + Ctrl + I

Normal  + Ctrl + Y 

Underline  + Ctrl + U

Strikethrough  + Ctrl + /

All caps (on/off )  + Ctrl + K

Small caps  + Ctrl + H

Superscript  + Ctrl + + (plus sign)

Subscript  + Alt + Ctrl + + (plus sign)

Resets horizontal or vertical scale 
to 100%

 + Ctrl + X or  + Alt + Ctrl + X 

Aligns left, right, or center  + Ctrl + L, R, or C 

Justifies all lines  + Ctrl + F (all lines) or J (all but last line)

Increases or decreases point size*  + Ctrl + > or < 

Increases or decreases point size by 
five times*

 + Ctrl + Alt + > or <

Increases or decreases leading* Alt +  or 

Increases or decreases leading by 
five times*

Alt + Ctrl +  or 

Autoleading  + Alt + Ctrl + A

Selects or deselects preferences setting 
for typographer’s marks

 + Alt + Ctrl + “

Aligns to grid (on/off )  + Alt + Ctrl + G

Auto-hyphenates (on/off )  + Alt + Ctrl + H

Increases or decreases kerning & tracking Alt +  or 

Increases or decreases kerning & tracking 
by five times

Alt + Ctrl +  or 

Increases kerning between words* Alt + Ctrl + \

Decreases kerning between words* Alt + Ctrl + Backspace
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*Press Shift to increase or decrease kerning between words by 5 times.

**Amount is set in Edit > Preferences > Units & Increments.

Navigating through and selecting text 

Clears all manual kerning and resets 
tracking to 0

Alt + Ctrl + Q

Increases or decreases baseline shift**  + Alt +  or 

Increases or decreases baseline shift by 5 
times

 + Alt + Ctrl +  or 

Automatically flows story  –click loaded text icon

Semi-automatically flows story Alt–click loaded text icon

Recomposes all stories Alt + Ctrl + /

Inserts current page number Alt + Ctrl + N

Inserts section marker text 
(or placeholder)

 + Alt + Ctrl + N

Result Action

Moves to right or left one character  or 

Moves up or down one line  or 

Moves to right or left one word Ctrl +  or 

Moves to start or end of line Home or End key

Moves to previous or next paragraph Ctrl +  or 

Moves to start or end of the story Ctrl + Home or End key

Selects one word Double-click word

Selects one word right or left  + Ctrl +  or 

Selects one character right or left  +  or 

Selects one line above or below  +  or 

Selects start or end of line  + Home or End key

Selects one paragraph Triple-click or quadruple-click paragraph, 
depending on Text Preferences setting

Selects one paragraph before or after  + Ctrl +  or 

Selects current line  + Ctrl + \

Selects characters from insertion point  –click
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Viewing

Selects start or end of story  + Ctrl + Home or End key

Result Action

spacebar (with no text insertion point), 
Alt-drag (with text insertion point), or 
Ctrl + spacebar, and then release Ctrl

Ctrl + spacebar

Alt + Ctrl + spacebar or  + Alt

Fits page in window Ctrl + 0

Fits spread in window Double-click  or Alt + Ctrl + 0

Displays 100% magnification Ctrl + 1 or double-click  

Zooms to 50%, 200%, or 400% Ctrl + 5, 2, or 4

Redraws screen  + F5

Switches between current and previous 
zoom levels

Alt + Ctrl + 2

Switches to next or previous 
document window

 + Ctrl + F6 or Ctrl + F6

Scrolls up or down one screen Page Up or Page Down 

Goes back or forward to last-
viewed page

Ctrl + Page Up or Page Down 

Goes to previous or next spread Alt + Page Up or Page Down 

Selects first or last frame  + Alt + Ctrl + Page Up or Page Down

Selects previous or next frame Alt + Ctrl + Page Up or Page Down

Selects page number in page box Ctrl + J 

Goes to master page while Pages  
palette is closed

Ctrl + J, type prefix of master, press Enter

Selects magnification box in 
document window

Alt + Ctrl + 5 (main keyboard)

Cycles through units of measurement  + Alt + Ctrl + U

Snaps guide to ruler increments  –drag guide

Switches between page and spread 
guides (creation only)

Ctrl–drag guide
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Indexing

Creates vertical and horizontal ruler 
guides for the spread

Ctrl–drag from zero point 

Typical display resolution Alt + Ctrl + Z

Optimized display resolution Alt + Ctrl + O

High-quality display resolution Alt + Ctrl + H

Selects all guides Alt + Ctrl + G

Locks or unlocks zero point Right-click zero point and choose option

Uses current magnification for view 
threshold of new guide 

Alt–drag guide

Selects buttons in alert dialog boxes Press first letter of button name 
if underlined

Information on installed plug-ins and 
InDesign components

Ctrl + Help > About Design

Result Action

Index palette  + F8

Create index entry without dialog box  + Ctrl + U

Open Add Page Reference dialog box Ctrl + U

Create proper name index entry (last 
name, first name)

 + Ctrl + F8
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Legal Notices

Copyright
© 2001 Adobe Systems Incorporated. All rights reserved.

Adobe® InDesign® 2.0 User Guide for Windows® and Macintosh

This manual, as well as the software described in it, is furnished under license and may be used or copied only in accordance with the terms of 
such license. The content of this manual is furnished for informational use only, is subject to change without notice, and should not be 
construed as a commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors 
or inaccuracies that may appear in this book.

Except as permitted by such license, no part of this publication may be reproduced, stored in a retrieval system, or transmitted, in any form or 
by any means, electronic, mechanical, recording, or otherwise, without the prior written permission of Adobe Systems Incorporated.

Please remember that existing artwork or images that you may want to include in your project may be protected under copyright law. The 
unauthorized incorporation of such material into your new work could be a violation of the rights of the copyright owner. Please be sure to 
obtain any permission required from the copyright owner.

Any references to company names in sample templates are for demonstration purposes only and are not intended to refer to any actual 
organization.

Adobe, the Adobe logo, Acrobat, Acrobat Reader, Adobe Garamond, After Effects, Classroom in a Book, Clearly Adobe Imaging, the Clearly 
Adobe Imaging logo, Illustrator, InDesign, Jimbo, PageMaker, Photoshop, PostScript, and PostScript 3 are trademarks of Adobe Systems Incor-
porated in the United States and/or other countries.

Apple, ColorSync, Mac, Macintosh, QuickTime, Power Macintosh, and TrueType are trademarks of Apple Computer, Inc. registered in the U.S. 
and other countries. Focoltone is a registered trademark of Gordon Phillips Limited. Pentium is a registered trademark of Intel Corporation. 
Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation registered in the U.S and/or other countries. Kodak is 
a registered trademark and Photo CD is a trademark of Eastman Kodak Company. Pantone, Inc. is the copyright owner of color data and/or 
software which are licensed to Adobe Systems Incorporated to distribute for use only in combination with Adobe InDesign software.
PANTONE Color Data and/or Software shall not be copied onto another disk or into memory unless as part of the execution of 
InDesign software.

THE PROXIMITY/MERRIAM-WEBSTER DATABASE, © Copyright 1990, Merriam-Webster Inc., © Copyright 1990 - All Rights Reserved, Proximity 
Technology Inc., THE PROXIMITY/ FRANKLIN ELECTRONIC PUBLISHERS INC. DATABASE, © Copyright 1994, Franklin Electronic Publishers Inc., © 
Copyright 1994  All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ FRANKLIN ELECTRONIC PUBLISHERS INC. DATABASE, © 
Copyright 1994, Franklin Electronic Publishers Inc., © Copyright 1997 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ WILLIAM 
COLLINS SONS & CO. LTD. DATABASE, © Copyright 1990, William Collins Sons & Co. Ltd., © Copyright 1990 - All Rights Reserved, Proximity 
Technology Inc. THE PROXIMITY/ WILLIAM COLLINS SONS & CO. LTD. DATABASE, © Copyright 1990, William Collins Sons & Co. Ltd., © Copyright 
1997 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ WILLIAM COLLINS SONS & CO. LTD. DATABASE, © Copyright 1984, 
William Collins Sons & Co. Ltd., © Copyright 1988 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ DR. LLUIS DE YZAGUIRRE I 
MAURA DATABASE, © Copyright 1991, Dr. Lluis de Yzaguirre i Maura, © Copyright 1991  All Rights Reserved, Proximity Technology Inc. THE 
PROXIMITY/MUNKSGAARD INTERNATIONAL PUBLISHERS LTD. DATABASE, © Copyright 1990, Munksgaard International Publishers Ltd., © 
Copyright 1990 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ VAN DALE LEXICOGRAFIE BV DATABASE, © Copyright 1990, 
Van Dale Lexicografie bv, © Copyright 1990 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ VAN DALE LEXICOGRAFIE BV 
DATABASE, © Copyright 1995, Van Dale Lexicografie bv, © Copyright 1996 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ VAN 
DALE LEXICOGRAFIE BV DATABASE, © Copyright 1997, Van Dale Lexicografie bv, © Copyright 1997 - All Rights Reserved, Proximity Technology 
Inc. THE PROXIMITY/ IDE A.S. DATABASE, © Copyright 1989, IDE a.s., © Copyright 1989 - All Rights Reserved, Proximity Technology Inc. THE 
PROXIMITY/ IDE A.S. DATABASE, © Copyright 1990, IDE a.s., © Copyright 1990 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ 
HACHETTE DATABASE, © Copyright 1992, Hachette, © Copyright 1992 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ 
EDITIONS FERNAND NATHAN DATABASE, © Copyright 1984, Editions Fernand Nathan, © Copyright 1989 - All Rights Reserved, Proximity 
Technology Inc. THE PROXIMITY/ TEXT & SATZ DATENTECHNIK DATABASE, © Copyright 1991, Text & Satz Datentechnik, © Copyright 1991 - All 
Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ BERTELSMANN LEXICON VERLANG DATABASE, © Copyright 1997, Bertelsmann 
Lexicon Verlang, © Copyright 1997 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ WILLIAM COLLINS SONS & CO. LTD./ 
BERTELSMANN LEXICON VERLANG DATABASE, © Copyright 1986/1997, William Collins Sons & Co. Ltd./ Bertelsmann Lexicon Verlang, © 
Copyright 1997 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/WILLIAM COLLINS SONS & CO. LTD./ BERTELSMANN LEXICON 
VERLANG DATABASE, © Copyright 1990/1997, William Collins Sons & Co. Ltd./ Bertelsmann Lexicon Verlang, © Copyright 1997 - All Rights 
Reserved, Proximity Technology Inc. THE PROXIMITY/ S. FISCHER VERLAG DATABASE, © Copyright 1983, S. Fischer Verlag, © Copyright 1997 - All 
Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ ZANICHELLI DATABASE, © Copyright 1989, Zanichelli, © Copyright 1989 - All Rights 
Reserved, Proximity Technology Inc. THE PROXIMITY/MORPHOLOGIC INC. DATABASE, © Copyright 1997, MorphoLogic Inc., © Copyright 1997 - 
All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ RUSSICON COMPANY LTD. DATABASE, © Copyright 1993-1995, Russicon 
Company Ltd., © Copyright 1995 - All Rights Reserved, Proximity Technology Inc. THE PROXIMITY/ ESPASSA-CALPE DATABASE, © Copyright 
1990, Espassa-Calpe, © Copyright 1990 - All Rights Reserved, Proximity Technology Inc.

Color-database derived from Sample Books © Dainippon Ink and Chemicals, Inc., licensed to Adobe Systems Incorporated. Portions © Eastman 
Kodak Company, 1999 and used under license. All rights reserved. Portions © The Focoltone Colour Systems, and used under license. Portions © 
Trio Systems, LLC. 

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110-2704, USA
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Notice to U.S. government end users. The software and documentation are “commercial items,” as that term is defined at 48 C.F.R. §2.101, 
consisting of “commercial computer software” and “commercial computer software documentation,” as such terms are used in 48 C.F.R. 
§12.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48 C.F.R. §§227.7202-1 through 227.7202-4, as applicable, the 
commercial computer software and commercial computer software documentation are being licensed to U.S. government end users (A) only 
as commercial items and (B) with only those rights as are granted to all other end users pursuant to the terms and conditions set forth in the 
Adobe standard commercial agreement for this software. This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/). Unpublished rights reserved under the copyright laws of the United States.
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Index

A
Absolute Colorimetric rendering intent 347

absolute numbering 55

Acrobat version compatibility settings 367

Acrobat.  See Adobe Acrobat

activating

bounding boxes 22

palettes 8

windows 19

Actual Size command 15

Add All Items on Page command 248

Add All option, indexes 183

Add Item command 248

add-anchor-point tool 205

adding pages 248

Adjust Text Attributes When Scaling option 
120

adjusting paths with the pen tool 204

Adobe Acrobat

color managing PDF 355, 358

comparing versions 4.0 and 5.0 366

high-resolution composite workflow and 
PDF 362

version compatibility settings 366

Adobe Gamma command 354

Adobe Gamma utility 353

Adobe Gamma wizard 355

Adobe Illustrator

adding colors from 320

alternate import methods 235

color managing 357

color managing PDF 358

editing InDesign pages in 253

import options 225

importing colors from 320

patterns 320

trapping 324

when to use 223

Adobe InDesign

converting 1.0 documents 14

Adobe In-RIP Trapping 323, 326

Adobe PageMaker

color managing 358

converting publications 11

templates 12

Adobe Paragraph Composer command 141

Adobe Photoshop

alpha channels 226

clipping paths and 226, 262

color managing 357

color managing PDF 358

importing files from 226

layers 226

opening InDesign pages in 253

paths 226

removing backgrounds with 262

trapping images from 324

when to use 223

Adobe PostScript 3

Adobe Extreme and 362

export option for 251, 400

overprinting 418

PDF workflow and 362

smooth gradients 401, 402

Adobe PostScript Extreme 362

Adobe PostScript Level 2

color separations and 362

export option for 251, 400

support for 256 shades of gray 401

support for overprinting 418

Adobe Single-line Composer command 141

After First letters option 142
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AI files.  See Adobe Illustrator

aliases, ink 318

Align palette 269

Align to Baseline Grid option 43

aligning

grids and objects 37

objects and guides 43

objects to other objects 269

objects within frames 257

paragraphs to baseline grid 127

tables in a frame 160

text in tables 161

type 126

type along a path 106

type vertically within a frame 128

type, buttons for 126

All Caps command 122

All Lines in Paragraph option 132

All option 366

All Printer’s Marks option 421

Allow Graphics and Groups to Resize option 
66

Allow Pages to Shuffle command 48, 50

Allow Ruler Guides to Move option 66

alpha channels

clipping paths created from 261

described 262

Photoshop and 226

PNG format and 229

text wrap using 102

alternate glyphs 88

Alternates for Current Selection option 88

anchor points

adding 198, 205

adding, deleting 204

adjusting 206, 215

appearance 20

changing type of point 205

corner, smooth, and center 193

described 193

drawing and 198

selection states and 21, 195

working with multiple 207

anchors, hypertext 172

Angle option

gradient 314

halftone screen 423

anti-aliasing 19

Append style sheets.  See  Character Styles 
palette

Application Built-In option 326

application preferences. See defaults

Apply Default Spreadsheet Style option 
(Excel) 111

Apply Gamma Correction option 230

Apply Master to Pages command 59

Apply Photoshop Clipping Path option 225, 
227

Arabic numerals 52

arithmetic in palettes and dialog boxes 7

arrowheads 212

Ascender option (path type) 106

Ascent option, baseline offset 84

ASCII

exporting 112

import option for text 110

importing 109

assets, cataloging 250

Assign Profiles command 350

At Start/End of Paragraph option 132

Attributes palette 419

Auto Justified option 396

Auto option 393, 396

autoflow 81

automatic leading 116

Automatic option 367

automatic page insertion 81

Automatic Page Numbering option 53

automatic recovery feature 24

automatic text flow See  autoflow

B
Background Color option 381

Background Image option 381

Background None option 381

background Paper color 31
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backgrounds

adding to graphics 259

banding in gradients 401, 404

base (non-emulsion side) 424

base color 290

Based on Master option 58, 62

Based On option 10, 147, 148

baseline grid

Align to Baseline Grid option 128

aligning paragraphs to 127

defined 37

snapping objects to 43

viewing 128

Baseline Offset option 84

Baseline path type alignment command 106

baseline shift 121

baseline, tables 161

baselines of text 116

Before Cross-reference option 189

Before Last _ letters option 142

Between Entries option 189

Between Page Numbers option 189

bevel join 211

Bicubic downsampling 369

Binary option (exporting) 251, 400

bitmap images

BMP files 226

color management and 225

described 219

formats for 223

options 399

printing 399

resolution for 219

black

color definition 304

in composite proofs 387

overprinting 418

trapping next to 335

Black Color option

definition of black 336

dot gain and 335

rich blacks and 332

trapping thresholds and 333

Black Density option 333, 336

Black option 333

Trap Width 332, 335

Bleed Marks option 421

Bleed option 231, 254, 371

bleeds

clipping in PDF format 231

described 44, 422

overriding by prepress software 422

page size and 31, 391

printer’s marks and 420

specifying for EPS export 253

blend color 290, 292

blending modes 289, 291

BMP files 226, 324

boldface 113

book files

adding documents to 167

closing 168

described 167

opening 168

removing documents from 167

repaginating documents in 171

saving 168

synchronizing documents in 169

books

creating 167

exporting to PDF 171

indexes 187

numbering pages in 170

packaging, preflighting 171

printing 171

reordering documents 167

replacing missing documents 168

synchronizing documents 167

table of contents and 179

borders, adding to graphics 259

Bottom path type alignment command 106

Bounding box option 101

bounding boxes

activating 22, 210
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appearance of 20

compound paths and 214

cropping and 260

deactivating 22

defined 20

gradient endpoints and 316, 317

layer color and 71

nested objects and 266

paths, and appearance of 194

point of origin and 274

reflecting objects using 281

resizing and 259, 280

stroke weight and 213

text wrap and 101

box frame. See stroke

box shape. See corner effects

boxes.  See frames

breaking links in PDF 233

breaking paragraphs 132

breaks, preventing 143

Bring Forward command 269

Bring to Front command 268

built-in trapping

compared to Adobe In-RIP Trapping 323

disk space requirements 325

turning on 326

bullets, inserting 89

butt cap option 211

C
calculating math 7

cancel loaded text icon 81

Cap Height option, baseline offset 84

cap style 211

capitalization, changing 122

capitalized word, hyphenating 142

capitalizing index entries 189

Cascade command 19

Cascading Style Sheets-1 379, 380

case, changing 122

cataloging objects 250

CCITT compression in PDF 368

Cell Alignment option (Excel) 111

Cell Range option (Excel) 111

cells, table

cutting, copying and pasting 157

described 151

inserting tabs in 161

inset spacing 160

merging and splitting 161

overset 152

overset cells 162

selecting 154

Center (image trap) option 334

Center Content command 257

Center path type alignment command 106, 
107

center points 194

centering.  See aligning

Change Case command 122

change security settings password 374

Change Source dialog box.  See linking

changing text 91, 94

Character command 113

character formatting 146

Character palette 5, 114

Character Set option 110

character style 146

Character Styles command 146

Character Styles palette 146

characters, special 54

Check Out command 243

Check Spelling command 96

child master 62

Choke option 334

Ciceros 35

Clip Complex Regions option 295

Clipboard 358, 375

Clipping Path command 263, 265, 266

clipping paths

converting into frames 261

described 261

Invert option 265

Photoshop files and 263

closed paths
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drawing with pen tool 199, 202

drawing with pencil tool 195

overview 192

closing book files 168

CMYK

icon in Swatches palette 303

images 359

output 415

CMYK color mode, EPS export 252

CMYK values and step limit 333

Color Bars option 421

Color Burn mode 290

Color button 302

Color Dodge mode 290

Color folder for Windows profiles 352

color management

black point compensation 347

calibrating monitors 353

characterizing monitors 353

Clipboard and 358

color spaces in 337

disabling for specific images 360

engine 338, 346

imported graphics and 359

loading settings 348

objects created in InDesign 356

overriding individual images 360

policies 343, 346

PostScript 401

predefined settings 340

profiles. See profiles

rendering intents 347

saving settings 348

scans and 359

setting up 339

soft-proofing 348

turning on/off 339

viewing environment 339

working spaces 342

color management system. See color 
management

color managing

Adobe Illustrator files 357

bitmap graphics 225

EPS files 358

file formats 223

HTML output 355

imported graphics 356

JPEG files 357

multiple media and 356

online viewing of output 355

PageMaker objects 358

PDF files 355, 358

Photoshop 6 images 357

Web browser output 355

color matching module 338

color matching systems.  See name of color 
matching system

Color mode option 291

color models 310

color modes 310

Color option

baseline grid 37, 38

column and margin guides 31

document grid 38

for PDF export 251

layers 68, 71

ruler guides 42

Color palette 310

color profiles. See profiles

color rendering dictionary 401

color separating described 415

color separations

adjusting ink density values 330

converting spot to process colors 423

described 384, 414

dot gain control 335

file formats best for 223

making trapping unnecessary 419

Paper color 304

PostScript separation workflows 414

printing and saving 425

printing gradients as 417

proofing 425

screen frequencies, custom 423

setting options 416
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specifying which colors to separate 422

Color Settings command 340, 341, 359

Color Settings options 360

color spaces 337

color stitching 295

colored dot in Layers palette 70

colorizing images 302

colors

adding from other documents 320

applying by dragging and dropping 311

applying gradient fills 314

applying text 302

applying toolbox controls 302

Black, defined 304

checking for duplicate spot colors 408

checking printed 417

choosing layer colors 71

converting before PDF export 251

cycling through modes 310

defining global process 301

defining Paper color 304

defining Registration color 304

device-independent 338

from imported graphics 320

high-fidelity in PDF 233

importing Web-safe 309, 378

ink problems 408

layer selection color 70

loading custom libraries 308

naming after CMYK values 307

overprinting strokes or fills 419

redefining spot as process 317, 321, 423

representing in exported files 251

sampling from imported graphics 320

soft-proofing 348

specifying process colors 301

spot, described 300

swatches

 See swatches.
trapping to compensate for ink 

misregistration 322

colors, base 290

column and margin guides 31

column break 89

columns

creating unequal widths 32

exporting to HTML 380

guide colors 31

gutter 32, 84

in text frames 83

Layout Adjustment and 65

multiple 32

table, deleting 156

table, inserting 155, 156

table, resizing 158

table, selecting 154

Columns option 32

commercial printing

common file formats for 226

resolution and 220

TIFF file formats 230

compatibility settings 366

Complete option 251, 400

composer 141

composite color workflow 323

composites, creating for in-RIP separations 
414

composition 140, 141

composition preferences 125, 132, 141, 145

compound paths

creating 216

described 214

end shapes and 212

gradients and 215, 316

printing and 215

releasing 215

reversing 216

reversing inside and outside 216

stacking order and 215

compressing PDF output 370

compression

downsampling 368

JPEG 368

lossless 227, 367

lossy 228, 382

LZW 230
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PDF output 370

Run Length 368

subsampling 368

TIFF format 230

Configure Plug-ins command 28

conflicts, resolving profile 359

conserving paper, film 392, 394

Constrain Proportions option 397

containers, frames as 63

context menus 10, 52, 54

Contextual Alternatives option 115

continued lines 55

continuous-tone images 384

Convert Quotes 80

Convert Strokes to Outlines option 295

Convert to Profile option 350

convert-direction-point tool 205

converting

Adobe InDesign 1.0/1.5 14

Adobe PageMaker 12

object library files 249

paths to frames 64

QuarkXPress 12

tables to text 153

text to tables 153

coordinates 35

Copy command 42, 234, 277

Copy Fonts (Roman Only) option 409

Copy Linked Graphics option 409

Copy option 11

Copy PDF to Clipboard option 375

copying

 See also duplicating

content to Clipboard 375

drag and drop 233

fill and stroke attributes 319

layers 71

objects 70, 285

pages and spreads 49

and pasting 233

path segments 278

type attributes 139

copyright symbols 89

corner effects 213, 214

Corner Effects command 213, 214

corner points 193, 206, 213

corner shapes 214

correcting mistakes 24

CRD 401

Create Guides command 40

Create Outlines command 214, 216

Crop Image Data to Frames option 370

Crop Marks option 421

crop marks, setting 422

Crop to option 231

cropping, described 260

Cross-reference option 188

Cross-referenced Topic option 188

cross-references

hyperlink jumps 171

indexes 184

CSS-1 379, 380

Cursor Key option 277

cursor movement keyboard shortcuts 85

curve handles. See direction points

curves

adjusting 207

drawing 200, 202

See also drawing

smoothing 197

custom colors, in gradients 315

Custom measurement units option 34

Custom paper size menu 393

custom startup file 308

Cut command 42, 277

D
Darken mode 290

dashed lines, drawing 211

Dashed option 211

Data Format option 251, 400

data recovery 24

DCS files

EPS files and 226
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importing 223, 226

trapping 324

Default fill and stroke button 302

defaults

document level 26

InDesign Defaults file 25, 27

InDesign SavedData file 25

program level 26

setting 26

trap style, defined 327

trap width option 332

Define (printer styles) command 389

degree symbols 89

Delete Item(s) command 248

Delete Layer command 73

Delete Master Spread command 60

Delete Page command 50

Delete Unused Layers command 73

delete-anchor-point tool 205

Denominator option 116

Descender option (path type) 106

Description option 250

Deselect All command 23, 199

Desired option 143, 144

destinations, hyperlink

described 171

editing 173

Detach All Objects from Master command 61

Detach Selection From Master command 61

Detect Edges option 263

Detected Edge option 102

Device Independent option 252

device-independent color 338

diagonal lines, adding to tables 164

diamond icon (gradients) 314

DICCOLOR 308

dictionaries

adding a word 98

customizing 96, 125

deleting a word 98

preferences 97

Proximity language 124

Dictionary command 97

Difference mode 291

digital master 362

direction lines

adjusting 202, 204, 206

defined 199

described 192

end shapes and 212

moving 199, 200

direction points 199

direct-selection tool

activating temporarily 21, 206

adjusting compound paths with 215

adjusting paths with 199, 204, 206

adjusting text frames with 75

compared to selection tool 20

moving and copying 278

selecting frame contents with 258

selecting nested objects with 22, 418

selection states and 21, 210

disabling color management 340

Discretionary Hyphen 142

discretionary ligatures 115

Display Master Items command 61

display preferences, transparency 289

distances, measuring 35

distortion effects, path type 107

distributing objects 269

distributing type vertically 128

dithering 382

document grid 37, 38, 66

document layers.  See layers

Document Layout palette. See  Pages palette

document preferences.  See defaults

Document Setup dialog box 30, 31

Document Structuring Conventions (DSC) 385

documents

adding to books 167

converting QuarkXPress and PageMaker 12

copying layers between 70

importing different file formats into 224

layers 70
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new 30

opening 11

opening and closing 11

printing.  See printing

recovering 24

reformatting 65

saving 23

scaling 397

starting new 30

dot gain, compensating for 335

dots per inch (dpi) 423

Double Quotes option 89

double-byte fonts 372

downloading fonts 399

downsampling 368

dragging and dropping

colors 311

imported graphics 233, 234

table rows or columns 156

text 79

drawing

adjusting segments 204, 206

basic shapes 194

changing point types 205

curved segments 200

ellipses and circles 194

erase tool 197

mixing straight and curved segments 202

paths 195, 198

pen tool and 198

pencil tool and 195

polygons 194

rectangles and squares 194

rounded rectangles and squares 194

smooth tool 196

straight lines 194

drop caps 130

Drop Shadow command 293

DSC output 385

Duplicate Master Spread command 60

Duplicate Page command 49

Duplicate Spread command 49

Duplicate Swatch command 306

duplicating

direct-selection tool and 278

fill and stroke attributes 319

into rows and columns 285

layers 71

objects 70, 285

pages and spreads 49

reflecting objects and 285

spreads 49

step and repeat 285

swatches 305

type attributes 139

duplicating.  See also Copying

E
eBook PDF style 365

edges

feathering and softening 293

showing and hiding for frames 64

Edit Dictionary command 98

Edit Original button 236, 237

Edit Original command 90, 237

editing

hyperlinks 174

index entries 185

text 85, 90

Effect menu 214

effects, corner 213

ellipse frame tool 194

ellipse tool 194

ellipses 89

ellipses, drawing 89, 194

em dashes 89

em spaces 89

Embed command 238

Embed Fonts option 251

embedded paths described 261

embedding

graphics 236, 237

tables within tables 153

unembedding 237
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emulsion 424

en dashes 89

en spaces 89

Enable Anti-Aliasing option 222

Enable Color Management option

for imported images 225, 360

Enable Layout Adjustment option 66

enabling color management 339

encoding images 399, 400

End menu for strokes 212

end shapes 212

End Style option 333

endpoints described 193

Entire Pasteboard command 15

Entry End option 189

EPS files, trapping 324

EPS graphics

checking for missing fonts 407

clipping paths and 262

color management and 358

colors from 320

exporting 226

import options 226

preserving printing information for PDF 366

replacing linked graphics 253, 400

when to use 223

erase tool 197

even page break 90

Excel, importing 111

Exclusion mode 291

Export Book to PDF option 361

Export command 361

EPS 253

HTML 380

PDF 361

Transparency Flattener option 253

export files 251

Export Selected Documents to PDF option 361

exported files

converting color spaces 251

embedding fonts in 251

exporting

HTML 380, 382

options 251

PDF 361, 374

text 112

to EPS format 253

to PostScript 253

to SVG format 254

extensions, filename 309

Extra Carriage Returns option 111

Extra Spaces option 111

Extreme. See Adobe PostScript Extreme

eye icon in Layers palette 72

eyedropper tool

colors and 320

fill and stroke attributes and 319

type attributes and 139

using 319

F
face (typeface) 113

facing pages and margins 32

Facing Pages option 30, 47

Feather command 293

feathering edges 293

figure spaces 89

File Defined Background Color option 230

file formats

 See also individual format names

commercial printing 226

import options 110, 224

importing graphic 223

text 104

TIFF 230

file naming, HTML 379

filename extensions 309

files, managed 241

Fill box 302, 310

fills

adding to tables 162

alternating, adding to tables 165

and paths 192

applying 302
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compound paths and 215

copying 319

described 192

overprinting 419

removing 302

film

base 424

conserving 392, 394

filters, import 109

Find Font command 94

Find/Change command 93, 94

finding and changing text 91, 94

finding objects 250

first baseline offset 84

First Page command 17

Fit Content Proportionally command 257

Fit Frame to Content command 257

Fit Guides To option 40

Fit Page in Window command 15

Fit Spread in Window command 15

Fixed option, baseline offset 84

fixing mistakes 24

Flattener Resolution option 295

flattener styles

automating 294

loading, importing 296

predefined 294

saving 295

flattening document layers 73

flexographic printing 397

Flip Both command 282

Flip Horizontal command 282

Flip Vertical command 282

flowing text 80

flush spaces 89, 145

Flush zone. See Justification command

FOCOLTONE Color System 308

Following Topic option 189

font characters 87

font family 113

Font menu command 114

font subsetting 251, 372, 400

fonts

copying attributes 319

downloading 399

embedding in PDF files 372

embedding in PostScript files 251

finding and changing 91, 94

handling missing 125

installing 114

missing 94, 407

multiple master 116, 372

OpenType 87, 216

optical size of multiple master 116

specifying 114

stored on computer or printer 399

substituted, highlighting in documents 125

substitution of in PDF files 372

Fonts panel 407

Force Text to Outlines option 295, 298

forced line breaks 89

Format option 12

formatting paragraphs 126

fractions, inserting 115

frame break 90

frames

aligning objects within 257

anchor points 20

breaking tables across 157

changing alignment of tables within 160

clipping paths and 261

compared to paths 63

converting paths to 64

creating borders or backgrounds 259

creating inline 100

creating text 75, 217

cropping within 260

drawing tools 194

graphics frames described 64

inset 214

masking 260

Master Text Frame option 30

moving 258

moving contents 258
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nesting 266

pasting objects into 256

showing and hiding edges 64

text, described 75

threaded 75

tools for handling 20

using as placeholders 12

frames, creating

drawing.  See paths

free transform tool 284

freeform paths

See pencil tool

freehand tool. See pencil tool

Frequency option 423

front matter, numbering 52

G
Gamma utility 354

Gamma Value option 230

gamma, matching image to device 230

Gap option 212

General job options, setting 366, 376

Generate Thumbnails option 367

generating indexes 186

GIF format

compared to PNG 229

described 227

HTML output and 379

trapping 324

global process colors 301

glyph scaling 143, 144

glyphs 87, 143, 372

Glyphs palette 87

Go Back command 18

Go Forward command 18

Go To Link button 236, 237

Gradient button 302

Gradient Fill box 314

gradient fill. See gradients

Gradient palette 314

Gradient Resolution option 295

gradient tool 314, 315, 316

gradients

adding colors to 315

adding intermediate colors to 315

applying across multiple objects 315

applying to text 316

applying while editing text 124

banding 401

changing angle 314

creating compound paths and 215

defining 313

described 313

endpoints of 316

length, maximum 404

modifying 314

print troubleshooting 402

printing 401

printing as separations 417

trapping 334

working with 313

Graphic Arts Technical Foundation of North 
America 330

graphics

adding to tables 152

aligning within frame 257

bitmap vs. vector 219

embedded, explained 235

embedding 237

formats and options 224

import file formats 223

linked, explained 235

managing 219

modifying within frames 256

moving 258

moving frames or content 258

omitting when exporting 253

optimizing print resolution 399

overprinting 419

preparing to import 223

using frames for 64

using resolution 219

Graphics command 64

Gray color mode, EPS export 252

gray levels 403
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grayscale images 370

Greek Type Below option 222

greeking 19

grids

creating 37

showing and hiding 38

snapping to 43

using 33

Grids command 37, 38

Grids in Back option 38

Grids Preferences 127

Group command 266

grouping objects 266

groups

nesting 266

on Object Library object 247

transforming content 273

guides

deleting 40

identifying 31

moving ruler 41

page 39

preferences 31

ruler 39

snapping to 43

spread 39

stacking order 31, 42

Guides command 31, 43, 44

Guides in Back option 43

Guides in Back preference 43

gutters 32

option 40

value 84

H
H & J Violations option 141

hair spaces 89

halftone dots 423

halftone screen frequency 369

halftoning 384

hand tool 17

handing off files 406, 408

handles, frame 20

hanging indent 134

hanging punctuation 133

Hard light mode 290

Height (H) option 280

Height page size option 30

Hexidecimal color codes 378

hidden layers 72, 409

hidden tools 4

Hide Frame Edges command 64

Hide Master Items command 61

Hide Others command 72

hiding

layers 72, 411

nonprinting elements 44

High Quality (resolution) option 221

high-fidelity colors in PDF 233

highlighting H&J violations 141

highlighting loose and tight lines 145

HKS color model 308

holdback 332, 335

horizontal axis 269

horizontal flipping 282

Horizontal measurement units option 34

Horizontal Offset option 286

Horizontal Scaling 120

host computer (printing) 414

host-based separations 425

HTML

and JPEG formats 379

and PNG format 379

color management and 355

editing 383

exporting 380

exporting graphics to 379

file formats for 223

formatting options 381

graphics options 382

layout options 381

naming files 379

options 380

preserving layout using CSS-1 380
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preserving page layout 380

preserving text formatting 379, 382

supported graphics formats 379

Web swatch library 378

Hue mode 291

hyperlinks

creating 173

described 171

editing 174

jumping to 175

resetting 174

setting up destinations 172

updating 175

hypertext

editing, deleting destinations 173

setting up destinations 172

Hyphen Limit option 142

Hyphenate Capitalized Words option 142

Hyphenate option 142

hyphenation 82, 96, 141

Hyphenation command 142

Hyphenation Exceptions options 97

Hyphenation Zone option 142

hyphens, recognition of soft and hard 376

I
ICC

converting from PageMaker 13

profiles 338

profiles monitor 353

ideographic spaces 89

Ignore Object and Layer Locks option 66

Ignore Ruler Guide Alignments option 66

Image Color Settings command 226, 360

image data.  See encoding images

image exposure 424

image replacement 400

by an OPI server 253

Image Trap Placement option 335

imageable area 391, 397

images

checking links 407

colorizing 302

in online publishing 220

including in PDF files 252

resampling during PDF export 369, 370

Images option, PDF export 252

import options

color settings 225

EPS 226

Microsoft Word 109

PNG files 229

imported graphics

color management and 356

display performance 221

finding fonts in 94

sampling colors from 320

trapping 324, 334

imported images.  See imported graphics

importing

copying and pasting 233

dragging and dropping 233

graphics 223

JPEG files 228

object library objects 247

styles 150

table of contents settings 180

tables from other applications 153

in port 75

inches 35

Include eBook Tags option 367

Include Empty Index Sections option 188

Include Fonts and Links from Hidden Layers 
option 409

Include ICC Profiles option for PDF export 372

Include Index Section Headings option 188

Include Inside Edges option 102, 265

Include option (Word and RTF) 110

Increment Every option 37

increments, setting kerning 119

Indent to Here special character 135

indents 133, 134

InDesign Defaults 25

InDesign Margins option 382

InDesign SavedData 25
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InDesign Template option 12

InDesign work area 4

indexes

adding all entries 183

adding page references 181

books 187

capitalizing entries 189

creating 180

creating topics 189

cross-references 184

deleting entries 186

displaying markers 191

editing entries 185

expanding or collapsing entries 185

formatting 188

generating 186

index entries described 180

locating markers 186

overview 180

page ranges 182, 184

planning 180

proper names 183

removing unused topics 190

selecting entries 186

sort order 182

titles 187

Ink Alias menu 319

Ink Black option 349

Ink Manager 253, 317, 371, 423

Ink Manager button 326

ink sequence (trapping order) 331

inks

opaque 330

optimized screen frequencies 423

pastels 330

problems with 408

trapping metallic 330

inline frames 100

inline graphics  See  inline frames

in-RIP separations 425

In-RIP Separations option 426

Insert Glyphs command 88

Insert option 48

Insert Page Number command 52

Insert Section Name command 51, 54

Insert Table command 151

Insert White Space command 89

insertion point 85

inset 83

Inset Clipping Path option 265

Inset Frame option 265

Inside margin option 32

Interactive drop shadow tool 293

Invert option (clipping paths) 265

Isolate Blending option 291

Item command 65

Item Name option 250

J
Join Style option 332

JPEG compression, for PDF 368

JPEG files

color managing 357

HTML export and 379

import options for 228

including in PDF 368

trapping 324

jump lines 55

Jump Object option 101

Jump to Next Column option 101

jumps, hypertext 171

justification

button 127

defined 126

hyphenation and 141

multi-line composer and 127

spacing 143

vertical 128

Justification command 144

Justify Text Next To Wrap option 103, 141

justifying wrapped text 103

K
Keep Lines Together option 132
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Keep Options command 132

Keep Spread Together command 47

Keep Violations option 132, 141

Keep With Next _ Lines option 132

keepaway traps 335

kern pairs 117

kerning

adjusting 118

manual 118

metric 117

optical 118

setting increments 119

Kerning option 119

keyboard control 8

keyboard shortcuts 9

scaling objects 281

knocking out

black 304, 418

defined 322

Paper swatch 304

Knockout Group option 292

knockouts

preventing 418

Transparency palette option 287

L
LAB icon in Swatches palette 303

language dictionary 125

Last Page command 17

Layer Options command 69

layers

 See also Layers palette

adding objects to 69

arranging 71

choosing color 71

copying between documents 70

defined 67

deleting 73

duplicating 71

final output and 72, 409

locking 72

merging or flattening 73

moving objects to other layers 70

object libraries and 247

options for 69

Photoshop files and 226

ruler guides and 39, 41

selecting objects on 70

showing and hiding 72

targeting 69

working with 67

Layers command 68

Layers palette

colored dot 70

described 67

eye icon 72

locking layers 73

pencil icon 73

Layout Adjustment

defined 65

masters and 57

options 66

rules 65

Layout Adjustment command 66

leading

apply to paragraphs 117

baseline offset 84

described 116

specifying 117

Leading option, baseline offset 84

Leave Unchanged option 252

Left margin option 32

letter spacing 143

Level 1, 2, and 3 Compatible option 400

Level Style option 188

libraries. See object libraries, swatch libraries

ligatures

defined 124

discretionary 115

Ligatures command 124

Lighten mode 291

line art, compressing in PDF 370

line screen

 See also screen frequency
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described 423

maximum with gradients 404

printer 423

printer resolution and 370

line tool 194

linear gradients 313

lines

adding to tables 162

creating dashed 211

drawing 194, 199, 202

drawing with pen tool 198

drawing with pencil tool 195

See also paths

Link Information command 237

linking

 See also Links palette

and unlinking 237

checking links 407

overview 235

packaging for handoff 409

PDF previews 233

restoring 238

unlinking 237

updating links for handoff 409

linking and embedding.  See  OLE

Links and Images panel 407

Links command 5

Links palette 5, 90, 236, 237

links, hypertext 171

List View command 249

loaded graphics icon 224

loaded text icon 76, 81

Location option 239, 313, 314

Lock Guides command 41

Lock Guides option 41, 68

Lock Layer option 68

Lock Others command 73

Lock Position command 269, 271

locking layers 72

locking objects 271

logical structure tree

defined 376

long documents, numbering 52

lossless compression 227, 367

lossy compression 228, 382

lowercase letters 122

Luminosity mode 291

M
Mac OS system colors 309

Macintosh PICT. See PICT

magnifying 14, 15

 See  scaling

Make command 216

managed files

checking in and checking out 242

creating 244

opening 241

uploading changes to 244

manual kerning 118

Manual option 396, 397

manual text flow 80, 81

margin alignment 133

margin guides.  See margins

margins 31, 32, 65

Margins and Columns command 32

Margins option 32

Marker option 54

markers

index 186, 190, 191

start-of-section 53

marquee 15, 21

masking described 260

masks, Photoshop files and 226, 261

Master option 48

Master Options For command 58, 62

master pages.  See masters

master password 374

Master Text Frame option 30, 82

masters

creating 57

deleting 60

managing prefixes 57

parent and children 62
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removing from document pages 59

selecting unused 60

using 57

masters, using

applying 58

autoflow and 81

basing on other masters 62

creating text frames on 82

editing 59

options 58

overriding 61

placing text on 79

showing or hiding master items 61

math, calculating 7

Maximum option, justification 143, 144

measuring

distances 35

measurement units supported 8

object dimensions 272, 273

overriding current units 35

rulers and measurement units 33

setting up units 34

Merge Layers command 73

Merge User Dictionary Into Document option 
97

merging layers 73

metadata 245

Metafile. See Microsoft Windows Metafile

metallic inks, trapping 330

metrics kerning 117

Microsoft Windows Metafiles, import options 
228

Microsoft Word, importing 110

midpoint, gradient 314

millimeters 35

Minimum option, justified text 143, 144

misregistration 322

missing fonts 94

Missing Fonts command 125

Missing-link icon 236

missing-link icon 239

mistakes, undoing 24

miter join 211

Miter Limit option 211

Modified-link icon 236

modified-link icon 238

modifying gradients 314

modules, plug-in 19

monitor profiles 353

monitors

calibrating 353

characterizing 353

monochrome images in PDF 370

Move command 276

moving

direction lines and points 199

frames 258

graphic frames or their content 258

objects and duplicating 285

objects between layers 70

objects by dragging 275

objects by nudging 285

objects by specifying distance 275

objects using dalog box options 276

objects using free transform tool 284

objects with Move command 276

objects, ways of 275

point of origin 274, 275

preferences for 277

ruler guides 41

using selection tool 278

with direct-selection tool 278

multi-line composer. See Paragraph Composer

Multiple master fonts 116

multiple page spreads 47

Multiply mode 290

N
Name option 58, 68

Named Color option 313

naming files 309

native format, defined 362

navigating

through tables 152

navigating pages 17
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Navigation Bar option 382

Navigator palette 14, 16

ND.  See neutral density

nested objects

described 266

identifying and selecting 266

setting reference orientation 272

Nested/Run-in option, index 188

nesting groups 266

neutral density 334

adjusting 330

Black Density and 333

measuring 330

values 330

Neutral Density option 334

New Color Swatch command 306

New Document dialog box 30

new documents 30

New Gradient Swatch command 313

New Item button 247

New Layer button 68

New Layer command 68

New Library command 247

New Library Item button 248

New Master command 58

New Page button

adding pages 48

adding spreads 58

duplicating spreads 49, 60

New Page command 48

New Swatch button 306

New Tint Swatch command 312

New Window command 19

Next Page button 17

Next Page command 17

Next Page Number command 56

Next Style option 147

No Adding or Changing Notes and Form 
Fields option 374

No Break command 143

No Changing the Document option 374

No Content Copying or Extraction, Disable 
Accessibility option 374

No Printing option 374

nonbreaking hyphens 143

nonbreaking spaces 89, 143

None button 302, 303

None option 251, 399, 400

None swatch 303

non-global process colors 301

non-PostScript printers 399

Non-Uniform scaling option 281

Normal mode 290

Normal option

ink type 331

Open dialog box 11

Normal View mode 44

nudging 285

Number of Sides option 195

Number option 31, 40, 58

numbering

absolute 55

front matter 52

page sections 52, 55

pages 51

pages for story jumps 55

pages in books 170

table of contents 178

Numbering & Section Options command 53, 
54

Numbering & Section Options dialog box 52

numerals, page numbering 52

Numerator option 116

O
object libraries

adding and removing objects 247

adding objects 248

cataloging objects 250

changing the view 249

creating new 247

deleting library files 249

finding objects 250

overview 246

palette menu 247
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thumbnails 247

Object Library palette 247

object linking and embedding 233

Object shape option 101

Object Type option 250

objects

aligning and distributing 269

changing point of origin 275

cropping or masking 260

duplicating 285

grouping 266

pasting into frames 256

rotating 278

shearing 282

stacking 268

odd page break 90

Offset option 131, 393, 394, 421

offset, first baseline 84

old style figures, OpenType fonts 116

OLE 233

Omit for OPI option 253, 400

omitting graphics 253

on-demand printing 364

online publishing 301

online viewing 355

opacity described 287

Opacity option 289

Opaque Ignore option 331

opaque inks, trapping 330

Opaque option (ink type) 331

Open command 12, 248

Open from Workflow command 241

open password, defined 374

open paths 192

Open Prepress Interface (OPI) 227

and exporting files for 253

exporting files for 400

links 252

Omit for OPI option 373, 400

trapping images 324

opening book files 168

opening documents and templates 11

opening QuarkXPress and Adobe PageMaker 
files 12

OpenType fonts 87, 115, 116, 216

OPI comments.  See OPI links

OPI Image Replacement option 253, 399, 400

OPI links 238

optical kerning 118

optical margin alignment 133

Optical Margin Alignment option 133

optical size axis 116

Optimize for Fast Web View option 367

Optimized (resolution) option 221

Optimized Subsampling option 399

order.  See also stacking order

ordinals 115

organizing objects 249

orientation 31, 391

Orientation button 392

Orientation option 31

origin, ruler 36

origin.  See  point of origin, zero point

Original option, Open dialog box 11

orphan 132

out port 75

outline type style 114

outlines, creating from type 216

out-of-gamut warning icon 310

Outside margin option 32

ovals 194

ovals, drawing 194

Overlap option 396

Overlay mode 290

Overprint Black option 418

Overprint Fill command 419

Overprint Preview command 289

overprint simulation 420

Overprint Stroke option 131, 419, 420

overprinting

and trapping 322

black 418

exporting option 253

options for overlapping colors 418

paragraph rules 419
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simulating 387

strokes and fills 418

strokes or fills manually 419

Override Color option 381

overset cells, clipping contents 162

overset text 75

oversized documents 395, 396, 397

P
Package Book option 408

Package option 408

Package Selected Documents options 408

packaging files for hand off 408

page breaks 90

page guides 39

Page Information option 421

page layout

and spreads 390

changing settings 31

exporting to HTML 380

preserving during HTML export 380

page menu 18

Page Number option 188

page numbering.  See numbering pages

page orientation 31, 392

Page origin option 36

page position on media, changing 397

page preview 394

Page Range option 189

page ranges, index 182, 184

page size 30, 391

Page size option 30

PageMaker, converting layers 13, 67

page-number marker 51

pages

 See also Pages palette

duplicating 49

exporting 251

facing 30

maximum number of 30

numbering.  See numbering pages

page breaks 89

pasteboard 44

selecting 46

shuffling 50

turning 17

Pages command 45

Pages palette 44, 45

adding pages 48

arranging 49

deleting pages 50

masters.  See masters

sections 52

selecting 46

Pages section 253

pagination of books 170

Palette option 382

palettes

calculating values 7

changing display 6

compacting lists in 7

docking 7

keyboard control 8

measurement units 8

menus 6

showing and hiding 5

specifying focus 8

using 5

palettes.  See also the palette name

PANTONE 308

Paper color 31, 304

paper size 391

defined 391

orientation and 392

overview 391

Paper White option 349

paragraph breaks 132

Paragraph command 117, 126

Paragraph Composer 127, 141

paragraph formatting 126

Paragraph palette 5, 126, 133

paragraph rules 130, 419

Paragraph Rules command 130

paragraph styles 146, 247
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Paragraph Styles command 146

Paragraph Styles palette 146

paragraph symbols 89

Parameters options 250

parent master, defined 62

parent objects 272

Password Required to Change Permissions 
and Passwords option 374

Password Required to Open Document option 
374

passwords for PDF 233, 374

Paste command

between pages 277

guides and 42

importing graphics 234

inline frames 100

text 78, 79

threaded text frames and 78

Paste Into command 260

Paste Remembers Layers command 70

Paste Remembers Layers option 247

pasteboard 15, 39, 44

pastel inks, trapping 330

Path option 265

path type

creating 104

deleting 105

described 104

distortion effects 107

flipping 107

spacing 108

start and end boundaries 105

vertical alignment 106

path type tool 104

paths

adding start and end shapes 212

adjusting segments with pen tool 204

anchor points 193

and frames 63, 64

basic shapes 194

changing direction 212

changing with pen tool 204

combining into compound 214

connecting 205

connecting or merging 196

converting text to 216

corner effects 213

creating closed 199, 202

creating compound 214, 216

creating curved segments 200

creating holes in 214

creating with pen tool 198

creating with pencil tool 195

dashed lines 211

direction 215

editing stroke characteristics 210

endpoints 193

erasing 197

extending open 205

measuring 213

open and closed 192

overview 192

Photoshop and 226

reversing direction 216

reversing subpath direction 216

segments 193, 206

selecting 20

selecting segments and points 207

smoothing 196

splitting 209

start and end shapes 212

strokes and fills 192

strokes described 192

PB, index 187

PCX files 228, 324

PDF compatibility settings 367

PDF files

checking for missing fonts 407

color management 233

color managing for online viewing 355

copying content to Clipboard 375

exporting 361

fonts, enbedded 372

high-fidelity colors 233

high-resolution composite workflow 362
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high-resolution printing 363

how to include images in 252

Illustrator files 357

JPEG file output 368

managing links 233

OPI links 252

output styles 364

outputting books 171

overview 229

passwords 231

preflight check 363

preparing 358

preparing EPS files 358

previewing 233

print-ready hand-off 363

resolution of placed pages 232

reusing 230

saving or exporting Photoshop files as 357

security settings in 233, 374

specifying area to import 231

trapping graphics 324

types of 376

versions 367

PDF options

setting General 366

tagged Adobe PDF, creating 376

PDF Styles option 365

pen tool described 198

pencil icon 73

pencil tool 195, 198

Perceptual rendering intent 347

performance 325

display group settings 221

image display quality and 221

Photoshop Path option 102, 265

picas 35

PICT files 228, 324

pixels described 219

Place command 239

compared to other importing methods 233

import options for 110, 223

inline frames and 100

object libraries 248

PDF files 231

replacing imported files 239

text 80

placeholder text 82

placeholders 12, 63, 64

placing text

and graphics 233

master page 79

placing.  See also names of file formats

Plain type 113

Platform option 110

plug-in modules 19, 28

PNG files

compared to GIF 229

HTML export and 379

import options 229

trapping 324

point of origin

described 274

rotating 279

scaling 281

shearing 283

point types, changing 205

points (anchor points) 193

points (unit of measure) 35

points, direction 199

polygon frame tool 194

polygon tool 194

polygons, drawing 194

Portable Document Format.  See PDF

portrait orientation icon 31

Position option 123

Positioning option 382

PostScript 3.   See Adobe PostScript 3

PostScript 3. See Adobe PostScript 3

PostScript files

creating 411

trapping and 324

types 411

PostScript Level 2.   See Adobe PostScript Level 
2
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PostScript Printer Description file.  See PPD 
files

PostScript® File option 411, 426

PPD files 323, 386

and page size 391

and PostScript printing 386

obtaining 386

offset information in 394

overview 385

screen frequency and angle information 423

screen rulings in 423

preferences

composition 141

guides 31

hyphenation 96

image display 221

kerning 119

location of file 25

measurement units 34

opening managed files 245

pencil tool 197

restoring defaults 26

ruler origin 36

setting 25

smooth tool 197

text 116

toolbox layout 5

transparency 289

workflow 245

Workgroup 245

prefix 57

Prefix option 58

Preflight Book option 407

preflight described 406

Preflight option 407

Preflight Selected Documents options 407

preflighting documents 406

prepress service provider

handing off files 408

prepress workflows

creating PostScript files for 409

DSC-compliant output 385, 410

Preserve Halftone Screens option 232

Preserve Local Formatting option 165

preset 25

Press PDF style 365

Preview Mode 44

Preview option 350

Preview options 252

previewing

color conversions 351

documents 44

page fit 394

Previous Page command 17

Previous Page Number command 56

previous-page button 17

Print Book command 171

Print command 387

Print dialog box 387

Print PDF style 365

print quality and line screens 423

print settings 387, 408

Print Settings panel 408

printable area. See  imageable area

printer drivers

installing 385

overlapping printing features 385

preferred 385

viewing Mac OS printing options 385

printer’s marks 420

custom 421

space required for printing 420

printer-resident fonts, defined 399

printers

available gray levels 403

line screen 423

non-PostScript 388

with resident fonts 399

printing

bitmap images 399

book files 171

books 171

changing print settings 387

checking page fit 394

checking separation, document settings 
425
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CMYK output 415

color as grayscale 387

commercial resolution 220

compound paths 215

gradients as separations 417

graphics options 399

grayscale proofs 387

handoff instructions 408

high-resolution file formats 226, 230

large documents 395

Mac OS options 385

manual overprinting 419

methods 384

on demand 364

overprinting guidelines 418

page ranges 390

PDF export styles 364

PDF resolution 232

PostScript workflows 414

preventing layer printing 72

sections 390

separations 425

tiling documents 396

process color icon 303

process colors 300

compared to spot colors 300

naming 307

Profile color management option 225

Profile option 360

profiles 338

adding or updating 352

embedding in output 351

guidelines for monitors 354

ICC, converting from PageMaker 13

ICC, converting from version 4 o version 2 
351

ICC, converting from version 4 to version 2 
371

ICC, embedding in PDF files 372

obtaining 351

reassigning 350

resolving conflicts 359

storage location 352

updating 352

projecting cap option for strokes 211

Proof Colors command 349

Proof Setup commands 349, 401

proofing separations on PostScript printers 
425

proper names, index 183

Proportional Lining option 116

Proportional Oldstyle option 116

Proximity language dictionary 124

Proxy Generation option 227

.ps file 411

PSD files.  See Adobe Photoshop

publication.  See document

Publish and Subscribe 233

publishing online.  See  World Wide Web

punctuation spaces 89

Q
QuarkXPress

color management and 358

converting layers 13, 67

converting templates from 13

opening files 11, 12

quotation marks

inserting 89

specifying preference option 89

R
radial gradients 313

RAM, undo steps and 24

Range option 366, 390

Ranges option 254

raster images described 219

Raster Images Slider option 221

Raster/Vector Balance slider 295

Read Embedded OPI Image Links option 227

reader’s spreads

choosing paper 392

trapping and 336

Recovered document 24

“Recovered” message in title bar 24
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rectangle (marquee) 15, 21

rectangle frame tool 194

rectangle tool 194

rectangles, drawing from center 194

Redo command 25

reducing the view 14

reflecting

described 281

duplicating and 285

free transform tool 285

nudging 285

objects 281

point of origin and 274

reformatting 65

registered trademarks, inserting 89

Registration color 304

registration colors, outputting 415

Registration Marks option 421

Relative Colorimetric rendering intent 347

Release command 216

releasing compound paths 215

Relink button 236, 239

Relink command 239

Relink option 407

Remove All Local Overrides command 61

Remove Existing Ruler Guides on Page option 
40

Remove Selected Local Overrides command 
61

Remove Unused Topics command 190

Rendering Intent color management option 
225

Rendering Intent option 360

rendering intents 338, 347, 349

renumbering PDF files 364

Repair All option 407

Repeat Count option 286

Repeat Tab command 137

Replace Existing Table of Contents option 177

replacing text 91

Report option 407

repurposing Adobe PDF documents 375, 377

resampling images

color or grayscale 369

monochrome 370

sampling threshold 369

table of resolutions 370

resizing objects. See scaling objects

resizing tables 158

resolution

comparing screen and device in PDF 232

described 219

for printing graphics 399

independence 219

matching image to output device 399

of printed images, controlling 399

specifying in separations 423

Restrict to Frame option 265, 266

restricting access to PDF files 374

resulting color, in blending modes 290

Retain Format option 80

Reverse Path command 213

reverse text 124

reversing compound paths 216

reversing path direction 212, 216

Revert command 25

RGB color mode, EPS export 252

RGB icon 303

rich blacks 335

right indent tab 138

Right margin option 32

right mouse button 10

Roman numerals 52

Roman type 113

Rotate 180° command 279

Rotate 90° CCW command 279

Rotate 90° CW command 279

Rotate command 279

rotate tool 275, 278

rotating

dragging rotate tool 278

duplicating and 285

nudging 285

objects, dialog box options 279

point of origin and 274
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selected objects 278

specifying angle 279

table text 162

Transform command 279

using free transform tool 284

rotation angle option 279

round cap option 211

rounded corners 213

rounded join 211

rounded rectangles, drawing

centered 194

rows, table

creating fixed height 160

deleting 156

described 151

height of 151

inserting 155, 156

resizing 158

selecting 154

RTF, saving Adobe PDF documents to 377

Rule Above option 130

Rule Below option 130

ruler guides

creating 39

creating automatically 40

deleting 42

evenly spaced 40

layers and 39

Layout Adjustment and 65

moving 41

selecting 41

stacking order 42

using 33

Ruler Guides command 42

rulers 33

measurement units 33, 34

setting horizontal origin 36

using 33

zero point 35

rules above or below paragraph 130

Run Length compression in PDF 368

Run-in option, table of contents 178

S
Saturation mode 291

Saturation rendering intent 347

Save a Copy command 23

Save As command 23

Save as Type menu 12

Save as Type option 253

Save command 23

Save Images As option 382

Save Style button 389

saving

Adobe PDF documents to RTF 377

book files 168

PostScript file 409

your work 23

Scale command 280

Scale Text Attributes command 121

Scale to Fit option 397

scale tool 275, 280

Scale X Percentage option 280

Scale Y Percentage option 280

scaling

adjusting type attributes 120

bounding box and 280

described 279

dialog box options and 280

documents 397

documents when printing 397

duplicating and 285

frames and their contents 273

glyphs 143, 144

horizontal 120

keyboard shortcuts for 281

nudging 285

objects within frames

point of origin and 274

proportionally 280

Scale command and 280

scale tool 280

specifying a value 280

spreads 390

type 120
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type and stroke weights 281

using free transform tool 284

scaling a document 397

scissors tool 209

Scitex Continuous Tone (SCT) files 230

Screen mode 290

Screen PDF style 365

screen ruling 423

Screening option 423

scrolling the view 17

SCT (Scitex Continuous Tone) files 230

Search Currently Shown Items option 250

Search Entire Library option 250

searching and replacing text 91, 94

Section Heading option 188

section marker 54

section numbering 55

Section Prefix option 53

section symbols, inserting 89

sections

creating 52

masters and 57

numbering 52, 55

printing ranges 390

removing 54

security settings in PDF 233, 374

segments, path

adjusting 206

described 193

drawing 200, 202

Select All command 22, 23

Select All Unused command 305, 306

Select Unused Masters command 60

selecting

activating selection tool 206

all objects 23

bounding box 22

defined 20

frames 75

layer color for 70, 71

multiple points 207

objects on layers 70

pages 46

ruler guides 41

segments of paths 207

spreads 46

text 86

tools for 20

selection bounding box.  See bounding box

selection marquee 21

selection tool

activating temporarily 21

moving and resizing objects with 75, 258

overview 20

selecting objects with 21

selection states and 22, 210

using 20

semi-automatic text flow 81

Send Backward command 269

Send Image option 399

Send to Back command 268

Separations option 422, 426

Separations option (trapping) 326

separations. See color separations

Set Dictionary to option 110

shade stepping 293

shadow type style 114

shadows. See drop shadows

shapes, drawing basic 194

Shear command 283

shear tool 275, 282

shearing

by dragging 282

dialog box options 283

duplicating and 285

free transform tool and 285

nudging 285

point of origin 283

point of origin and 274

selected objects 282

Shear command 283

specifying a value 283

Sheet option (Excel) 111

shortcuts, keyboard 9
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Show All command 250

Show All Layers command 72

Show All option 250

Show All Swatches button 305

Show Baseline Grid command 128

Show Color Swatches button 305

Show command 5

Show Data for Hidden Layers option 407

Show Frame Edges command 64

Show Gradient Swatches button 305

Show Guides option 41, 68

Show Hidden Cells option (Excel) 111

Show Import Options 110, 111, 224

Show Import Options option 225, 360

Show Import Preferences. 80

Show Layer option 68

Show Layers command 68

Show Library Subset button 247

Show Options command 126

Show Problems Only option 407

Show Stroke command 210

Show Subset command 250

Show Tools command 4

Show/Hide Baseline Grid command 38

Show/Hide Document Grid command 38

Show/Hide Guides command 41

Show/Hide Rulers command 33

shuffling pages 48, 50

side-bearing 143

Simulate Overprint option 253

simulating overprinting 387

Single Quotes option 89

single-line composer 141

Size menu command 114

Size option 123, 214

skew.  See shear

skewing.  See shearing

slanting type 121

Sliding Trap option 333, 334

sliding traps 334

slugs in text 151

Small Caps option 122

small caps, OpenType fonts 116

Small Palette Rows command 7

smooth points 193, 206, 213

smooth tool 198

smoothing paths or strokes 196

Snap To command 44

snap zone 43

Snap Zone option 66

snapping to grids 43

snapping to guides 43

Soft light mode 290

softening edges 293

soft-proofing 348, 372

Solid option for strokes 211

Sort by command 237

Sort by Name command 237

Sort by Status command 237

Sort Items command 250

sorting table of contents entries 178

source, hypertext 171

space above or below paragraph 127

space, flush 145

spaceband 143

spaces, inserting 89

spacing

above and below paragraphs 127

highlighting loose or tight lines 145

objects 269

path type characters 108

setting for words or letters 144

tables 159

special characters

column break 89

even page break 90

frame break 90

glyphs 87

indent to here 135

inserting 54

jump line page numbers 55

odd page break 90

page break 90

right indent tab 138
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Specifications for Web Offset Publications 330

Spell checker 96

spelling 96

Spine origin option 36

splitting paths 209

spot color icon 303

spot colors 300, 318, 330

outputting 415

spread guides 39

Spread option 334

Spread origin option 36

spreading 322

spreads

adding and removing pages 48

creating 47

defined 44

deleting pages from 50

duplicating 49

masters and 57

multiple-page 47

page orientation 392

scaling to fit 390

selecting 46

setting up 30

zero point and 35

Spreads option, EPS export 254

stacking objects 268

stacking order

compound paths 215

grouped objects 268

guides 31, 42

layers and 71

Star Inset option 195

Start At option (sections) 53

Start menu for strokes 212

Start option (grids) 37

Start Paragraph option 132

Start Section option 53, 55

start shapes 212

starting new documents 30

Start-of-section marker 53

startup file 308

Stationery option 12

Step and Repeat command 285

Step Limit option 334

Step option 333

Stop Color option 313

stop, gradient 313

story 75

Story command 133

story jumps 55

straight lines, drawing 199

straight quotes 80

strikethrough type 123

Stroke box 302, 310

Stroke palette 209

strokes

adding to tables 162

alternating, adding to tables 165

bevel join 211

cap style 211

dashed 212

described 192

editing characteristics 210

end options for 212

erasing 197

miter join 211

overprinting 419

rounded join 211

smoothing 196

type, changing 211

weight 210, 213, 273

style attributes 147

Style option 54, 146

Style Options command 148

style sources

described 167

selecting 168

styles

applying 147

basing on other styles 149

creating 146

deleting 149

editing 148
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flattener 294

importing 109

loading from other document 150

object libraries and 247

overview 146

PDF export 364

printer 364, 388

removing from text 149

setting Next 148

table of contents 179

table of contents, creating 176

tables of contents 177

trap 327

using 146

Styles palettes 146

subpaths 215

subsampling 368

subscript type 123

Subscript/Inferior option 116

Subset option 251, 400

Substituted Fonts option 125

Summary panel 407

superior. See superscript type

superscript type 123

Superscript/Superior option 116

support screens 335

SVG format, exporting to 254

Swap fill and stroke button 302

swashes 115

swatch libraries 308, 378

Swatch Options command 307

swatches

displaying name 307

editing 314

libraries 308

loading from color systems 308

modifying 305

size of 307

working with 301

Swatches palette 303, 320

SWOP standards 330

symbols, typing 89, 113

symmetrical points.  See smooth points

synchronizing book documents 167, 169

system color options 309

T
tab leaders 138

table of contents

advanced formatting options 178

and books 179

contents between entry and number 178

creating 176

creating for books 177

creating styles for 176

editing 177, 179

hidden layers 178

importing content settings 180

levels 178

overview 175

page numbers 178

run-in option 178

sorting entries 178

styles 177, 179

title 177

updating 179

tables

adding alternating fills and strokes 165

adding content 151

adding fills to 162

adding text above table 160

adding text to 152

aligning text in 161

aligning within a frame 160

breaking across frames 157

cell inset spacing 160

converting from text 153

converting to text 153

creating 151

cutting and pasting 157

deleting columns and rows 156

editing 154

embedding within other tables 153

fixed row height 160
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formatting 158

graphics, adding 152

importing 153

inserting columns and rows 155, 156

merging cells 161

moving 157

moving through 152

overset cells 152, 162

resizing 158

rotating text in cells 162

spacing before and after 159

tabs 138, 161

typing text in 151

tabs

decimal 138

in tables 161

inserting in tables 138

overview 135

removing 137

repeating 137

right indent 138

setting 136

Tabs command 126, 136

Tabs palette 126, 133, 136

Tabular Lining option 116

Tabular Oldstyle option 116

tagged Adobe PDF documents

defined 377

tagged text 111, 112

Tagged Text.PDF 112

targeting layers 69

targeting.  See also selecting

template option 12

templates 11, 12

text

adding to tables 152

aligning 126

aligning and justifying vertically 128

applying color to 302

autoflow 81

changing case 122

combining with graphics 99

compressing in PDF 370

converting into table 153

converting to paths 216

deselecting 86

drag and drop 79

editing 85

editing in original application 90

exporting 112

finding and changing 91

flowing 80

gradients, applying 316

import filters 109

import options 109

justifying 141, 144

linked files 90

navigating 85

object libraries and 247

pasting 78, 79

placeholder, inserting 82

placing 79

placing files 80

reverse 124

Roman or plain 113

selecting 86

semi-autoflow 81

tables in 151

threaded text frames 75

trapping 325

typing text 79

updating linked 90

wrapping around objects 101

Text command 65

text files, importing 110

Text Frame Options command 129

text frames

creating 79, 217

described 64, 75

First Baseline 84

in port and out port 75

Layout Adjustment and 66

master 30

master pages 82



Using Help | Contents | Index Back 475  

Adobe InDesign Help Index 

Using Help | Contents | Index Back 475  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

options settings 83

orientation 85

properties 83

threading 75, 76

unthreading 77

viewing text threads 77

text icon 81

Text Preferences 116, 122

Text to Box.  See Create Outlines command

text wrap

around objects 101

changing shapes 103

command palette 5

corner shapes 214

ignoring 84

inverting 103

options 101

tips 103

thin spaces 89

thread 76

thread icon 77

threaded text frames

described 75

disconnecting a frame 78

overview 75

removing a frame 78

viewing 77

threading text 75

cancelling 76

Threshold option 264

Thumbnail View command 249

thumbnails in PDF 367

thumbnails, creating 398

TIFF files

clipping paths and 262

color managing 357

format overview 230

import options 230

when to use 223

Tile command 19

tiling

automatically 396

defined 396

manually 396

repositioning the zero point 396

Tint slider 310

tints 311

title bar 24

Titling Alternatives option 115

Tolerance option 264

toolbox 4, 5, 302

tools.  See individual tool names

Top path type alignment command 106

topics, index 189

TOYO Color Finder 1050 309

tracking 117, 118

trademarks symbols 89

trademarks, inserting 89

transferring PostScript language artwork 226

Transform command 271

Transform Group Content command 273

Transform palette 271

compared to tools 278

proxy 275

showing and hiding 5

zero point and 35

Transformations are Totals command 272

transforming objects

duplicating and 285

free transform tool 284

overview 278

point of origin and 274

reflecting 281

scaling 279

size, proportion or orientation 278

transparency

and output 296

described 287

PNG graphic imports 229

saving graphics 382

setting preferences 289

tips for using 288

turning off on-screen display 289

using grouped objects 287
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Transparency Blend Space option 292

Transparency Flattener option 253

Transparency Flattener Styles option 295

Transparency palette 288

Transparency Slider option 222

Transparent Background option 232

transparent holes 214, 215

Transparent option 331

Transverse option 393

transverse page size 391

Trap 1-Bit Images option 335

Trap Color Reduction option 333

Trap Images Internally option 335

Trap Images to Images option 335

trap join 332

Trap Objects To Images option 335

Trap Placement option 334

trap style 327

Trap Width options 332

trapping 322

Adobe In-RIP Trapping 326

automatic 323

avoiding with process colors 417

black 335

built-in 326

described 322

gradients 334

graphics 334

holdback amount 332

imported images 324

keylines to images 335

making trapping unnecessary 419

maximizing performance 325

metallic inks 330

order 331

page ranges 329

pastel inks 330

sliding traps 334

solutions 322

specialty inks 331

spreads and 336

Step option 334

Trap Thresholds options 333

Trap Width options 332

varnishes 331

trapping page ranges 329

trapping styles 336

Trapping Thresholds options 333

Trash button

Layers palette 73

object libraries 247, 248

Pages palette 50, 60

swatches 306

Triple Click Selects Line option 86

troubleshooting

color and ink problems 408

missing fonts 407

printing gradients 402

printing tiles 396

problem links 407

true expanded font 120

TrueType fonts

described 216

trapping 325

TRUMATCH 309

turning on/off color management 339

type

along a path 104

attributes, copying with eyedropper tool 
139

capitalization, changing 122

case 122

color 124

duplicating attributes 139

fonts, finding and replacing 94

gradient 124

hints 216

HTML export limitations 379

kerning 117

scaling 120

skewing or slanting 121

superscript and subscript 123

underline and strikethrough 123

white 124

Type 1 fonts 216
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type on paths.  See path type

Type option 421

type style 91, 113

type tool 75

typeface 113

Typical (resolution) option 221

typographic quotes 80

U
underline type 123

Undo command 25

undoing mistakes 24

Unembed command 238

Ungroup command 266

ungrouping objects 266

Unicode values of characters 376

Units & Increments command 34, 277

Units & Increments preferences 8, 34, 119

units of measure.  See measurement units

unlinking graphics 237

Unlock command 271

unlocking layer guides 41

unnamed colors 301

Unstructured Adobe PDF, defined 377

Update Graphic Links in Package option 409

Update Link button 90, 236, 238

Update Link command 238

Update option 407

Update Workgroup command 242

updating modified links 238

uppercase letters 122

URL destinations, hypertext

described 172

setting up 173

Use Black Point Compensation option 347

Use Color Settings Intent option 350

Use Defaults option 222

Use Document Hyphenation Exceptions Only 
option 409

Use High Resolution Image option 265

Use Images Sub-Folder option 382

Use Transparency Information option 229, 230

Use Typographer’s Quotes option 89

User Defined Page Breaks to option 110

user passwords 374

V
values, calculating 7

varnishes 331

vector graphics

when to use 223

vector graphics described 219

Vector Graphics Slider option 222

vertical alignment

path type 106

text 128

Vertical alignment and justification 128

vertical axis 269

vertical justification 128

Vertical measurement units option 34

Vertical Offset option 286

Vertical Scaling 120

View Info option 408

View option (Excel) 111

View PDF after Exporting option 367

View Report option 409

View Threshold option 38, 42

viewing link information 237

views

changing 14

creating additional 19

magnifying 14

reducing 14

scrolling 17

switching 19

W
Web

 SeeWorld Wide Web

Web browsers, color managing 355

Web server for HTML files 378

Web swatch library 378

WebDAV

Check In and Out command 242
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managing files using 240

managing link updates 244

managing links 243

Open command 241

Place command 243

updating managed files 241

Upload to Server command 244

Web-safe colors 309, 356, 378

Weight Changes Bounding Box option 213

Weight option 421

Weight option (strokes) 131

White Background option 229

white type 124

widow 132

Width (W) option 280

Width of rule option 131

Width page size option 30

windows

activating 19

arranging 19

creating additional 19

switching 19

switching views 19

Windows Metafile. See Microsoft Windows 
Metafile

Windows system colors 308

WMF files 228

word breaks 143

word spacing

generally 143

in tagged PDF documents 376

Word, importing 110

Words Longer than _ letters option 142

words, finding and changing 91

work area 4

workflow management

adding files to 244

checking files in and out 242

downloading managed files 241

uploading changes 244

workflows

high-resolution composite PDF 362

host-based preseparated 414

in-RIP separations 414

PostScript printing 414

workgroup management

described 240

preferences for 245

working spaces

defined 342

specifying 342

World Wide Web

common file formats for 229

GIF file format 227

JPEG file format 228

PDF documents and 355

PDF file format 229

Wrap Offset option 102

wrap, text 101

X
x Height option, baseline offset 84

X option (position) 275

XML overview 378

Y
Y option (position) 275

Z
zero point

changing 35

repositioning 396

ZIP compression in PDF 367

Zoom In and Out commands 15

Zoom Setting, hypertext options 172

zoom tool 14

zooming 14
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